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1 Overview

The Printer Management Utility

The Printer Management Utility (PMU) allows you to organize all of the
printers in your office remotely in a single database, download software and
printer settings from a host computer with a single mouse click, and use a
virtual operator panel to configure printers in the same room or on the other
side of the world.

Requirements

* an InfoPrint 6500/6400 Series line matrix, 6700/4400 Series thermal, or
6700-M40 Series thermal printer

» the printer must be attached to the host system via a 10/100Base-T
Ethernet Interface or a wireless Ethernet Interface; if you do not have an
Ethernet Interface, see your dealer for an upgrade

* a host computer running the Windows® (98, NT, 2000, XP, Server 2003,
or Vista) or UNIX® (such as AIX®, Linux®, or Solaris™) operating system

* a host computer running a Java™ 2 Platform, Standard Edition (J2SE™)
Java Runtime Environment (JRE) that is fully JRE 5 compliant or higher

NOTE: Vista requires JRE 6.

«  for Windows, a minimum hardware configuration of a 450MHz Pentium®
with 128 MB of RAM

To install and edit the database, it is not necessary to have the printers
connected. When starting a session with a printer, the printer must be
connected and turned on.

Installing the Software

The Windows, Linux, and Solaris versions of JRE 5 and the Java-based PMU
are available on CD. Follow the on-screen instructions to first install JRE 5 for
your platform, then the PMU.

NOTE: If you are using Vista, download JRE 6 at http://java.sun.com/javase
Install JRE 6 first, then the PMU.

If you have another UNIX operating system, see your system
administrator.



Chapter 1  Printer Setup

Printer Setup

Your printer uses the diagnostic port to communicate with the PMU. The
diagnostic port must be configured to interact with the Ethernet Interface.
Follow the PMU, Telnet, or Operator Panel Method below for your printer
model to configure the diagnostic port.

PMU Method

All Supported Printers

You can configure the diagnostic port to interact with the Ethernet Interface
using the PMU. See “Enable Remote Printer Management” on page 143.

Telnet Method

All Supported Printers
1. Install the Ethernet Interface (refer to the installation instructions).
2. Make sure the IP Address is set up on the Ethernet Interface:
» Use the operator panel (refer to the User’s Manual).
—OR-

» Use the PMU: select Utilities » Assign IP Address. See “Assign IP
Address” on page 142.

3. Open a command prompt session and type:
telnet ipaddress

4. Atthe telnet login: prompt, type:
root<Enter>

5. Atthe password: prompt, enter the password and press <Enter>
(there is no password by default)

6. Atthe ipaddress:root> prompt, type:
enable printermgr<Enter>

7. Close the telnet session. The Ethernet Interface is now activated.

10



Operator Panel Method

Operator Panel Method

6500 Series Line Matrix Printers

o3 © e N o k0~

0.
1.

On the operator panel, press the STOP key to take the printer offline.
Press RETURN and ENTER at the same time to unlock the ENTER key.
Press MENU. QUICK SETUP displays.

Press T SCROLL until PRINTER CONTROL displays.

Press ENTER. INTERFACE SELECTION displays.

Press | SCROLL until PRINTER MANAGEMENT PORT displays.
Press ENTER. DISABLE displays. If ETHERNET displays, go to step 10.
Press | SCROLL until ETHERNET displays.

Press ENTER. As asterisk (*) appears next to ETHERNET.

Press RETURN and ENTER at the same time to lock the ENTER key.
Press START to put the printer back online.

6400 Series Line Matrix Printers

© © N o 0 &

10.

On the operator panel, press the STOP key to take the printer offline.

Press SCROLL T and SCROLL | at the same time to unlock the ENTER
key.

Press SCROLL T, SCROLL |, ENTER, and RETURN keys at the same
time to enter the Serivce menu.

Press SCROLL | until PRINTER MGMT displays.

Press ENTER until DIAGNOSTIC PORT displays.

Press ENTER again to see the current selection.

Press SCROLL | until Debug Ethernet or Debug Adapter displays.
Press ENTER to select it.

Press SCROLL T and SCROLL | at the same time to lock the ENTER
key.

Press START to put the printer back online.

6700 Series Thermal Printers

3.
4.
5.

On the operator panel, press the PAUSE key to take the printer offline.

Press = to place the printer in Menu mode. QUICK SETUP displays on
the operator panel.

Press | and ! at the same time to unlock the . key.
Press - until PRINTER MGMT displays.
Press | until PNE Port displays.

NOTE: If PNE Port does not display, see “Factory Menu” below.

11



Chapter 1  Printer Setup

6. If you have the internal PCI Ethernet Interface, press + until Ethernet
displays. If you have the external Ethernet Interface, press + until Adapter
displays.

Press I to select it.
Press | and ! at the same time to lock the ! key.
Press PAUSE twice to put the printer back online.

Factory Menu

On the operator panel, press the PAUSE key to take the printer offline.
Press | and ! at the same time to unlock the . key.

Press +, —, |, and T at the same time to enter the Factory menu.
Press | until PNE Port (or Diagnostic Port) displays.

o M 0 b =

If you have the internal PCI Ethernet Interface, press + until Ethernet (or
Debug Ethernet) displays. If you have the external Ethernet Interface,
press + until Adapter (or Debug Adapter) displays.

Press ! to select it.
Press | and . at the same time to lock the ! key.
Press PAUSE twice to put the printer back online.

6700-M40 Series Thermal Printers

Press := to enter Menu mode.

Press the Down and . keys at the same time to unlock the . key.
Press the Right key until 85 PRINTER SETUP displays.
Press .J to enter the ¥5] PRINTER SETUP menu.

Press the Up key until Admin User displays.

Press the Right key until Enable displays.

Press I to select it. An asterisk (*) displays after Enable.
Press = to enter Menu mode. &t MEDIA SETUP displays.
9. Press the Down key until & INTERFACES displays.

10. Press . to enter the Bt INTERFACES menu.

11. Press the Down key until Printer Mgmt displays.

© N o o k0w N~

12. Press  to enter the Printer Mgmt menu.

18. Press the Down key until PNE Port displays.

14. Press the Right key until Ethernet displays.

15. Press I to select it. An asterisk (*) displays after Ethernet.

16. Press the Down and  keys at the same time to lock the  key.
17. Press Il twice to put the printer back online.

12



Set Password

4400 Series Thermal Printers

On the operator panel, press the PAUSE key to take the printer offline.
Press | and . at the same time to unlock the ! key.

Press +, —, |, and T at the same time to enter the Factory menu.
Press | until Diagnostic Port displays.

Press + until Debug Ethernet displays.

Press I to select it.

Press | and . at the same time to lock the ! key.

© N o o > N~

Press PAUSE twice to put the printer back online.

Set Password

See “Set Printer Password” on page 127 to learn how to set passwords.
If the password is unknown you must clear it first.

6500 Series

Go into the SERVICE menu (press T SCROLL, | SCROLL, MENU, and
CONFIG at the same time), then into the PRINTER MGMT menu.

Press | SCROLL until CLEAR PASSWORD displays. Unlock the ENTER
key, then press ENTER to clear the User and Supervisor passwords.

Under the Security tab in Printer Properties, delete any passwords that
already exist. Now you may set new passwords as described on page 127.

6400 Series

Go into the SERVICE menu (press Scroll T, Scroll |, Enter, and Return at
the same time), then into the PRINTER MGMT menu. Press Scroll | until
CLEAR PASSWORD displays. Unlock the Enter key, then press Enter to
clear the User and Supervisor passwords.

Under the Security tab in Printer Properties, delete any passwords that
already exist. Now you may set new passwords as described on page 127.

6700/4400 Series

Go into the Factory menu (press +, —, |, and T at the same time). Press T or |
until Clear Password displays. Unlock the ! key, then press ! to clear the
User and Supervisor passwords.

Under the Security tab in Printer Properties, delete any passwords that
already exist. Now you may set new passwords as described on page 127.

6700-M40 Series

Go into the Factory menu (press the Up, Down, Left, and Right keys at the
same time). Press T or | until Clear Password displays. Unlock the - key,
then press I to clear the User and Supervisor passwords.

Under the Security tab in Printer Properties, delete any passwords that
already exist. Now you may set new passwords as described on page 127.

13



Chapter 1

Printer Setup

IMPORTANT
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Set Telemetry Path (6700/4400 Series Only)

The following procedure enables you to collect data using the Data Validation
application.

1. On the operator panel, press the PAUSE key to take the printer offline.

2. Press := to place the printer in Menu mode. QUICK SETUP displays on
the operator panel.

Press | and ! at the same time to unlock the . key.
Press + until VALIDATOR displays.

Press | until Telemetry Path displays.

Press + or — until Network Port displays.

N o o Mo

Press . to activate it.

NOTE: Since only one port can be used at a time, DEACTIVATING HOST
SERIAL displays.

If you later change the setting to Serial Port or Disabled,
REACTIVATING HOST SERIAL will display.

8. Press | and ! at the same time to lock the ! key.
9. Press PAUSE twice to put the printer back online.
For more information, refer to the Online Data Validator User's Manual.

Check Port Number

Make sure your printer port number has the same setting as the Ethernet
Interface.

To check the port number using the PMU, see page 20.

To check the port number on the printer, see Table 1 to determine the port
number menu location for your printer model. The default port number is
3001.

Do not set the Port Number to the same value as the Status Port Number
(the default is 3002) or the Mgmt Port Number (the default is 3007).

Table 1. Port Number Menu Location

Printer Model Menu

6700-M40 Series INTERFACES » Printer Mgmt » PNE Port Number

6700 Series PRINTER MGMT or Factory » PNE Port Number
4400 Series Factory » PMU Port Number

6500 Series PRINTER MGMT » PRINTER MANAGER PORT NO.
6400 Series SERVICE » PRINTER MGMT »

PRINTER MANAGER PORT NO.




Limitations

Loading and Using Foreign Language Fonts

PMU supports Asian languages such as Korean, Simplified Chinese, and
Traditional Chinese. UTF-8 encoding is utilized since it has the ability to
support all known languages and is backwards compatible with ASCII
(specifically O - 7F).

Microsoft operating systems provide most of fonts for the world languages
which can be obtained from Microsoft's web site. UNIX operating systems
such as Linux and Solaris requires more setup since the operating systems
provide less fonts than Microsoft. Java uses five logical fonts (Dialog,
Dialoginput, Serif, Sanserif and Monospaced) to map to the fonts on the
system. Mapping is done in the Java font.properties file. Dialog, size 12 is the
default font for all language dependent applications. Through mapping of the
font.properties file, the Dialog font supports all of the printer supported
languages. Mapping of operating system fonts should be performed by a
System Administrator.

Limitations

Not all of the items in the PMU Suite will display UTF-8. All PMU menus,
dialogs, tooltips and printer names will be displayed in ASCII.

Only the following applications, utilities, and displays support UTF-8
encoding:

» Printer Database status messages

»  Printer configuration languages in the Configuration Editor
» Information Capture’s viewable configuration data

» Virtual Operator Panel text

» Factory Settings Differences table data

»  Web page support (Printer List Page Message area only)
* SNMP Browser data

Older versions of PMU Suite (including previous products such as Advanced
Tool Kit, ODV Data Manager and EPC Data Manager) will not support new
printers with UTF-8 encoded byte streams.

All versions of PMU Suite that support UTF-8 encoding will support older
printer firmware versions.

Windows Setup

Java for Windows platforms includes a font.properties file that is used to map
foreign languages to Microsoft Window fonts. This includes all languages
supported on the printer.

15
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Unix Setup

Java for Linux platforms also includes a font.properties file. This file needs to
be modified to support the fonts on the user’s Linux or Solaris platforms.

Find or purchase the printer supported fonts for the languages needed. The
additional printer languages supported include Korean, Simplified Chinese,
and Traditional Chinese. Use a package manager such as Red-Hat Package
Manager (RPM) to load the font files onto the UNIX system. Once the fonts
are loaded, modify the component font mappings in the font.properties file for
Allfonts, Serif, Sansserif, Monospaced, Dialog and Dialoginput Logical fonts.
Use absolute path names, path names starting with $JRE_LIB_FONTS or X
Logical Font Description (xIfd) names for the fonts.

Add the following:

* new font names to the search sequences

» any exclusion character ranges for the languages
» the paths to the locations of the actual font files.

Finally, add the valid X11 font directories to the X11 server font path. For a
detailed description of the font.properties file see

Sun’s Java Internationalization Guide at
http://java.sun.com/j2se/1.5.0/docs/guide/intl/fontconfig.html.



Getting Started

This section provides a short tutorial on how to set up and access a printer
using the PMU.

1. This tutorial assumes the host computer running the PMU and the printer
you want to access are connected by a network. You must know the
printer's IP Address and Port Number.

2. From your operating system, launch the PMU. Click the splash screen to
see the main window of the printer database more clearly. See Figure 1.

File Edit View Applications Status Utilities Help |Dialug

-Jiel~

=@ cflef @ P[0 »me@x =daYemeoE (S ux @R
= defaultpdb
A E] New_Printer (4 template)

Status and Error Log

Figure 1. Printer Database Main Window

17



Chapter 1 Getting Started

Pinter Properties ————____________________________[|
Identification | Security rCunnemiuns hnfurmatiun |

Hame {(Unigque): ‘New_F'rinter |

Printer Description: ‘A template |

Use only printable characters for printer name and description.

| ok || cance

Figure 2. Printer Properties: Identification Tab
3. Double-click New_Printer (A template). The Printer Properties dialog
box opens. See Figure 2.

4. Assign a name to your printer. Delete the words New_Printer in the
Name (Unique) field, and then type Tutorial.

5. Assign a description to this printer. Delete the words A template in the
Printer Description field, and then type My First Connection.

18



Printer Properties E

(Identiﬁ[:atinn Security | Connections rIMDrmatinn |

User Password: | |

Superdasor Password: | | [_] Supervisor Mode

Telnet Guest Password: | |

Telnet Root Passwaord: | |

Use only printable characters for passwords.

OK | | cancel

Figure 3. Printer Properties: Security Tab
Click the Security tab. See Figure 3.

If you are using the PMU for the first time, it is likely that no passwords are
assigned to this printer. If you are unsure, contact your system
administrator.

» If no passwords are assigned, leave the password boxes empty.

e If a User password is necessary to access this printer, type the password
in the User Password field.

» If a Supervisor password is necessary to access this printer, type the
password in the Supervisor Password field, and check the Supervisor
Mode check box.

» If a Telnet guest password is necessary to poll the status of the printer,
type the password in the Telnet Guest Password field. See “Security Tab”
on page 58.

» If a Telnet root password is necessary to update wireless printer settings,
type the password in the Telnet Root Password field. See “Security Tab”
on page 58.

In any case, an asterisk (*) character appears in the field after each letter
you type to preserve password secrecy.

For more details on setting up and changing passwords, see page 51.

19
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Printer Properties E

(Identiﬁ[:atinn rSEcurity Connections | Information |

f Access Method r Network r SerialModem |

IP Address: |12?.EI.EI.1

Port Number: |3un1 | | Default |

Time Out {5..300 seconds): 15

OK | | cancel

Figure 4. Printer Properties: Connections Tab — Network Sub-Tab
Click the Connections tab. By default, the Network sub-tab displays.

Click the IP Address field and then type the IP Address of the printer you
want to access. Follow the format shown in Figure 4.

The Port Number field must be set to the same port as the printer. Leave

it set at 3001. Leave the Time Out (5..300 seconds) field set at 15
seconds.



(Identiﬁ[:atinn rSEcurity Connections | Information |

f Access Method r Network r SerialModem |

Access Method: | Ethernet -

Download Mode: |Access Method ~ |

Printer Timeout on Firmware Download: | 2 jminites =
CH

Firmware Download Initial Delay (Sec): |

OK | | cancel

Figure 5. Connections: Connections Tab — Access Method Sub-Tab

10. Click the Access Method sub-tab. See Figure 5.

The Access Method tells the PMU how the host computer communicates
with the printer. Make sure it is set to Ethernet. Ignore Download Mode
and Download Timeout for now. These options are described in “Access
Method Sub-Tab” on page 61.
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File Edit View Applications Status Utilities Help |Dia|ng v|12|v

|
=S B ckl¢ e PO ¢ e x =@ -EnEsed s ue

‘= defaultpdh
5 = Tutorial (My First Connectian) |

3 [ 1D
5] ER

Status and Error Log:

Piscwering printers

Figure 6. Printer Database Main Window

11. Click OK. The Printer Properties dialog box closes and you return to the
printer database main window. See Figure 6. Your printer is now set up in
the PMU database.

12. Try to access the virtual operator panel as a test to see if the information
you input is accurate. Follow this procedure:

a. Tutorial (My First Connection) should be highlighted in blue, as
shown in Figure 6. If it is not highlighted, click it to select it.

b. Select Applications » Operator Panel. The virtual operator panel
appears (see “Operator Panel” on page 108). If not, an error
message appears in the Status and Error Log pane. Check your
password to make sure it is correct. If the error continues, contact
your system administrator.
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Overview

Printer Database

When you start the PMU, the printer database window appears first. The
printer database tool organizes and controls printers and Download files.
Figure 7 shows how the database looks when the PMU launches for the first
time.

Menu Bar Toolbar Database Pane

Fle Edit View Applications Status Utiities Help / |Dialng |v|12‘v

|
=8 e al [P[o] [4]nelex =¢a e == u= @5

= defaultpdh
A E Mew_Printer (4 ternplate)

Status and Error Log:

LY

N A
\ Status and Error Log Pane ) i
Status Bar Polling Indicator

Figure 7. Printer Database Main Window

The menu bar contains all the menus used to control the functions of the
program. The menus are described later in this chapter.

The toolbar contains buttons for the most commonly used menu functions.
See page 53 for descriptions of the toolbar buttons.

Use the Database pane to access and control your printers in a tree format.
The first line of the database tree displays the database file name. In Figure 7,
the default file name for this database is default.pdb. From there, your
database tree branches out to include printers, folders, and Download files,
which you can organize into groups. With a single mouse click, you can

23
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download a file to several printers at once. In addition, you can use as many
databases with the PMU as you want. Databases save as .pdb files on your
local hard drive.

NOTE: You can open only one printer database at a time.

The Status and Error Log scrolls status and error messages as you work
through the program. If the PMU does not function properly, look at this pane
for error messages. Use the scroll bar on the side of the pane to reference
previous status and error messages. The status and error messages relate to
the current PMU session, not to the specific database. When you exit the
PMU, these messages will be deleted.

The Status Bar displays brief status messages of the PMU, some of which
appear in the Status and Error Log.

The Polling Indicator turns green whenever printers are being polled.



The File Menu

The Menu Bar

The printer database menu bar is located at the top of the window
(see Figure 7). Use the menu bar to access all the functions of the PMU.

The following are descriptions of the options located on the menu bar.

The File Menu

File | Edit Yiew Applications 5Status LUWilities Help
New Ctril-H [ l;_'J@ I Eﬁ.x
Open Ctrl-O

Sawve cil-s (A template)

Save As

Preferences

Exit

Figure 8. File Menu

New

Creates a new database file. Since the PMU allows only one database file to
be open at a time, it asks if you want to save your changes to the current
database before it creates a new one.

Open

Opens a database file. Since the PMU allows only one database file to be
open at a time, it asks if you want to save your changes to the current
database before it opens a different one.

Save

Saves the active database file using its current name.

Save As

Prompts you to enter a name for the current database file before the PMU
saves it. Use Save As if you do not want to overwrite the current database file.

Preferences

Opens the Preferences dialog box. See page 26.

Exit
Exits the PMU.
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Preferences

The Preferences dialog box has three tabs: Printer Database, Configuration
Editor, and Servers. See Figure 9.

Printer Database Tab

Preferences |

(| Printer Database r Configuration Editor r Servers |/ Macro Settings |

Database File Hame

|defau|t.pdb | ‘ Browse |

Lease Time on Printer Connection: |3 %

Security

[_] Show message when the printer is not protected

OK | | Cancel

Figure 9. Preferences: Printer Database Tab
The Printer Database tab controls database features.

Database File Name: Enter the name of the default database file. The PMU
opens this database file when the program starts. To select a new default
database file, type it into the Database File Name field, or click Browse to
locate a file on your network.

Lease Time on Printer Connection: Enter an amount (in seconds) to set the
maximum amount of time a printer connection can remain open without any
communication. The default is three seconds.

Security: Check the Show message when the printer is not protected
check box to enable a warning message that informs you when a selected
printer does not have an assigned password.



Preferences

Configuration Editor Tab

Prferences g
( Printer Database If Configuration Editor r Servers |/ Macro Settings |

Editor Keys

Hide Keyr: Unhide Key: Dec. Key: Inc. Kew:

T TR | A

ok || cancel

Figure 10. Preferences: Configuration Editor Tab
The Configuration Editor tab controls features of the Configuration Editor
utility.

Hide Key/Unhide Key: Assigns which keys hide and unhide menu items in
the Configuration Editor menu tree (see page 67). The default for Hide is H h.
The default for Unhide is U u.

Dec./Inc. Key: Assigns which keys will decrement and increment menu items
in the Configuration Editor menu tree (see page 67). The default for
decrement is < ,. The default for increment is > ..
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Servers Tab

Preferences | x| |

( Printer Database |/ Configuration Editor Servers | Macro Settings |
SHMP Trap Server

Port: | 49152 [_] Service Enahled

Weh Server

Port: | 5080 [_] Service Enabled

MML Server

Port: | 2081 [] Service Enabled

Hote: Restart program to use new settings.

ok || cancel |

Figure 11. Preferences: Servers Tab

The Servers tab allows you to assign port values for the SNMP (Simple
Network Management Protocol) Trap Server, the Web Server, and the XML
Server. Click Service Enabled next to the corresponding server to turn it on.

NOTE: You must restart the PMU to use the new settings and enable the
servers.

SNMP Trap Server: The service that enables the PMU to receive alerts from
the printer when its status changes. Once the PMU receives the alert, the
PMU creates an instant status poll to reflect the change in the database pane.
For instance, if you turn the printer offline, the printer sends an alert to the
PMU causing it to change the printer status instantly. In the database pane,
the printer status changes to offline.

NOTE: The SNMP Trap Server works only if the printer’'s Ethernet Interface
is configured correctly using the Configure Print Servers utility. See
“Configure Print Servers” on page 145.

Web Server: Allows you to view the active PMU using a web browser. See
“Web Access” on page 121.

NOTE: If you want to use the Web Server service, you must also enable the
XML Server service.

XML Server: The PMU uses XML to communicate with its web server.
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Macro Settings Tab

Preferences | x| |

( Printer Database |/ Configuration Editor r Servers Ir Macro Settings |

rGeneraI rHetwurk rSEriaI |

Macro Config File: |default.m|:f | | Browse |

Printer Port: |LF'T1 '| | Rescan |

[_] Use selected network printer

ok || cancel

Figure 12. Preferences: Macro Settings Tab — General Sub-Tab

The Macro Settings tab has three sub-tabs: General, Network, and Serial.
See Figure 12.

General Sub-Tab

Macro Config File: Displays the macro file that will load automatically when
you start the macro utility. To select a new default macro config file, type it into
the Macro Config File field, or click Browse to locate a file on your network.

Printer Port: Allows you to select the port that data is sent through. The
choices vary according to the host computer. Possible choices include LPT1,
LPT2, COM1, COM2, and Network.

If you select COM1 or COM2, click the Serial tab to further define printer
parameters. If you select Network, click the Network tab to further define the
network parameters.

» Use selected network printer: Check this box to send data directly to
the network printer selected in the printer database. You do not need to
further define network parameters.

» Rescan: Checks to see which ports are currently available on the host
computer.
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Preferences |

|/ Printer Database r Configuration Editor r Servers |'|’ Macro Settings |
( General | Metwork | Serial |

IP Address: |1 27.0.01 |

Port: |91nn | | Defaut |

OK | | Cancel

Figure 13. Preferences: Macro Settings Tab — Network Sub-Tab

Network Sub-Tab

Use the Network tab only when the Printer Port on the General tab is set to
Network.

IP Address: The address of the printer where the PMU will send the data.

Port: The port number that the PMU will use to send the data. This must
match the Ethernet Interface of the printer where the PMU will send the data.
In most cases this is 9100, the default. If not, contact your system
administrator.
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Preferences |

|/ Printer Database r Configuration Editor r Servers |'|’ Macro Settings |
[ General | Metwork | Serial |

Speed: | 9600 -|
Word Size: |8 -
Stop Bits: | 1 -|

Parity: | None - |

Flow Control: |HD“E v‘

OK | | Cancel

Figure 14. Preferences: Macro Settings Tab — Serial Sub-Tab

Serial Sub-Tab

Speed: The baud rate at which data transfers. This setting must match the
speed of the printer host serial port under the SERIAL PORT menu (thermal
printers) or the SERIAL submenu in the HOST INTERFACE menu (all other
printer models). See “Serial Port” (thermal) or “Host Interface” (all others) in
your User’s Manual.

Word Size: The number of data bits per character. In most cases this should
be set to 8.

Stop Bits: Inter-character gap. Can be set to 1 or 2. The normal setting is 1.

Parity: Adds an error checking bit if set to Odd or Even. The default is None.
Other settings include Mark and Space.

Flow Control: Prevents data overrun by adjusting the sending side according
to the needs of the receiving side.

* None: No adjustment occurs.
« Rts/Cts in: Hardware flow control on serial-input.
» Rts/Cts out: Hardware flow control on serial-output.

» Xon/Xoff in: Software flow control on serial-input using the X-on and
X-off control characters.

»  Xon/Xoff out: Software flow control on serial-output using the X-on and
X-off control characters.
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The Edit Menu

File | Edit | Wiew Applications Status LWilities Help

= || Insert * Eolder % o
=Y Cut Cirl- | Printer .
t§ Copy cti-c | Download File
Paste Cirl-v | Paste Buffer
Delete
Include / Exclude

Figure 15. Edit Menu

Use the Edit option on the menu bar to build your database. The options in the
Edit menu are described below.

Insert

Adds a folder, printer, or Download file into your database. You must select an
existing database item to create a folder, printer, or file. You can also paste
the contents of the paste buffer (the last item that was copied or cut) into the
database. The new icon appears one level below the selected database item.
If there are items below the selected database item, the new item appears at
the end.

Inserting an item involves three steps:

1. Select a database item. (The new icon will appear below the item you
select.)

2. Define which type of icon you want to add. Select Edit » Insert » and then
select the item you want to add. Or click the [ (insert new folder),
g (insert new printer), or ﬂi (insert new Download file) icon.

A new icon appears in the database.
3. Define what printer, folder, or file this icon represents.
a. To define a printer, see “Defining Printer Properties” on page 56.

b. To define a folder, double-click New Folder. The Folder Name dialog
box opens. Type the name of the folder and click OK.

c. To define a Download file, see “File Download” on page 86.

Cut

Removes selected folders, printers, or files from the database and places it in
the paste buffer.

Copy

Copies selected folders, printers, or files from the database to the paste
buffer, leaving the original intact.

NOTE: You can select multiple database items by using the Ctrl or Shift key.
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Paste

Places the item in the paste buffer on the database tree. To paste, you must
select a database item. The pasted item appears on the same level as the
selected database item.

NOTE: If you select Edit » Paste, the pasted item appears on the same level
as the selected database item. However, if you select Edit » Insert »
Paste Buffer, the pasted item appears one level below the selected
database item.

Delete

Permanently removes a selected folder, printer, or file from the database.

Include/Exclude

Deactivates a selected folder, printer, or file. Inactive database items display a
red circle with a slash through it on top of the item’s icon.

You cannot send information to or receive information from excluded
database items using the following Applications, Status, and Utilities menu
options: Flash File Manager, File Download, Update Status, and Configure
Print Servers.

To activate a database item, select the inactive item and then select
Edit » Include/Exclude.

The View Menu

File Edit | View Applications Status LWilities Help
= B Collapse Tree D | ¥ BB X

Expand Tree

default.

A E N Ste *| ® Angled Lines
Toolbar ) Horizontal Lines
- ' Ho Lines

Figure 16. View Menu

Collapse Tree

Collapses all folders on the database menu tree. Only the top level menu
items display.

Expand Tree

Expands all folders and printers on the database menu tree. All folders,
printers, and Download files display.
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Style

Angled Lines: Shows the links between database items using angled lines.

File Edit View Applications Status Lhilit
e REEERE A EL
—) Chsample.pdh
@ &5 Building A
@ =4 Manufacturing
[D] CPrinter Software A prg
@ CAmanufacturing Configs.cfy
@ Area 1 (north end of building
A Area 2 fwest end of building)
@ =3 Administration Office
(D] CiPrinter Software B.prg
(D] choffice Configs.cfg
£ Yending Room §
% & Conference Roorm ()
@ CAConference Configs.cfg
@ (=3 Special Fants
(D] CiFonts pff
@ Area 1 (north end of building
g4 Yending Room §
[C7 Building B

Figure 17. Angled Lines

Horizontal Lines: Shows the links between folders using horizontal lines.

=B cHleal R o] &)=
) Chsample.pdh
@ =5 Building A
@ =5 Manufacturing
[D] CiPrinter Software A prg
@ CAmanufacturing Configs.cfy
@ Area 1 {north end of building)
£ Area 2 fwest end of building)
@ =9 Administration Office
(D] CPrinter Software B.prg
(D] crofice Configs cig
£ Yending Room 0
% & Conference Roorm ()
@ CAConference Configs.cfg
@ =4 Special Fonts
(D] o Fonts pff
@ Area 1 (north end of building
£ Wending Room §
[ Building B

Figure 18. Horizontal Lines
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No Lines: Shows no lines between database items.

File Edit View Applications Status LHiliti

'}

=B |cFe| ck| PO | 4|B|E

=

Chsample.pdh

@ =5 Building A

@ =5 Manufacturing

[D] CiPrinter Software A prg

@ CAmanufacturing Configs.cfy

@ Area 1 {north end of building)

£ Area 2 fwest end of building)
@ =9 Administration Office

(D] CPrinter Software B.prg

(D] crofice Configs cig

£ Yending Room §

% & Conference Roorm ()
@ CAConference Configs.cfg

@ =4 Special Fonts

(D] o Fonts. pff

@ Area 1 (north end of building

£ Wending Room §
(] Building B

Figure 19. No Lines
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Toolbar

Allows you to select which buttons display on the toolbar.

NOTE: By default, some icons do not appear in the toolbar.

For a description of the toolbar icons, see “The Toolbar’ on page 53.

Customize Toolbar |

(] & Open | clearan
[v] 5% Save

[v] = Folder

[v] ¢ Printer

[v] (& Download File
[viBD Edit

[¥] {7 Include ! Exclude

Set all

Default

[v] ¥ Cut

(v Bz Copy

[v] (& Paste

[v] B, Paste Buffer
[v] ¥ Delete

[v] E=H Operator Panel

1]

OK Cancel

Figure 20. Customize Toolbar



The Applications Menu

The Applications Menu

File Edit View

Applications | Status

= B o ¢
= default.pdb
A = Mew_Pri

Configuration Editor
Flash File Manager
C5T Manager

File Download
Media Profiler

Operator Panel
Information Capture
Factory Differences
AutolD Data Manager
0DV Quality Wizard
Speed Keys

Joh Capture

Litilities Help

=Y =R

Figure 21. Applications Menu

For an explanation of the Applications menu options, find the menu option in

Table 2 and go to the corresponding page.

Table 2. Applications Menu Options

Menu Option Page
Configuration Editor page 67
Flash File Manager page 82
CST Manager page 147
File Download page 86
Media Profiler page 100
Operator Panel page 108
Information Capture page 112
Factory Differences page 77
ODV Quality Wizard page 115
Speed Keys page 116
Job Capture page 117
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The Status Menu

File Edit View Applications |Status | Litilities Help

= B |cF| gk @ BD| @ Discover Printers
default pdh Update Status —

£ B Mew_Printer (8 templaty Broperties

Figure 22. Status Menu
Discover Printers

To search for printers on a network, select Status » Discover Printers, or
click the 'jE' Discover Printers button at the far right of the toolbar. The
results of the search display in the database pane.

Discover Printers searches for printers on a network based on the settings
specified in the Discovery tab of the Status Monitoring Properties dialog box.
The next section explains how to configure your search.
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Properties

Select Status » Properties to open the Status Monitoring Properties dialog
box. The dialog box contains three tabs: Discovery, Polling, and Alert
Delivery.

NOTE: To enable printer discovery, check the Enable Printer Discovery
check box.

Status Monitoring Properties

[ Discovery || Palling |  Alert Delivery |

[¥| Enable Printer Discovery

|/ Print Server Discovery |/ Polled Discovery |/ Known Printers Discovery |

[¢| Enable Print Server Discovery  Response Wait (Seconds): |5

Eroadcast P | SubnetMask |  Return Gatewsay | | Add
2A8.255 788 255 0.0.0.0 0.0.0.0

[ ramow |

| ok || cancet || appy

Figure 23. Status Monitoring Properties:
Discovery Tab — Print Server Discovery Sub-Tab

Discovery Tab

You can discover printers on a network in three ways:

1. Print Server Discovery: This option allows you to discover all InfoPrint
4400/6400/6500/6700/6700-M40 Series Ethernet Interface-equipped
printers on a subnet. To enable the option, check the Enable Print
Server Discovery check box in the Status Monitoring Properties dialog
box (see Figure 23), then click Apply or OK.

Response Wait (Seconds): To specify the time delay (in seconds) the
PMU waits for a printer response. By default, the value is set at 5
seconds.

Broadcast IP, Subnet Mask, and Return Gateway: These settings must
match your network configuration. See your system administrator.

NOTE: To discover unconfigured Ethernet Interfaces, you must enter the
Gateway Address and Subnet Mask in the Return Gateway field.
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File Edit View Applications Status Utilities Help ‘Dialog |V|12|V|

=B e e PO |4 ae x| =@y ane e <o u= &R

u
BB
L

= default.pdb
A E Mew_Printer (& ternplate)

4 Progress...

@ D

iscovery
Running Print Server Discovery
[ ]

Cancel

T T e e e e e e T e e e

Status and Error Log

Piscwering printers

Figure 24. Print Server Discovery in Progress

If Enable Print Server Discovery is enabled, a progress indicator displays
while the PMU discovers printers. See Figure 24.
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Status Monitoring Properties E3
[ Discovery | Polling | Alert Delivery |

[¥l Enable Printer Discovery
( Print Server Discovery |/ Polled Discovery |/ Known Printers Discovery |

[¥] Enable Polled Discovery

First IP Address | LastIP Address | | Add
Remove
| ok || cancet || appy

Figure 25. Status Monitoring Properties:
Discovery Tab — Polled Discovery Sub-Tab

2. Polled Discovery: This option allows you to select a range of IP
addresses to poll. To enable the option, click the Polled Discovery tab
and check the Enable Polled Discovery check box, then click Add (see
Figure 25). In the First IP Address field, enter the first IP address of your
desired range. In the Last IP Address field, enter the last IP address. Click
Apply or OK. The PMU polls the printers within your specified range and
displays the results in the database pane.

If Polled Discovery is enabled, a progress indicator displays while the
PMU discovers printers. See Figure 26.

=B cklg|a P2 4 8aeR X =0 a5 e g s wel

= default.pdb
8 B Mew_Printer (4 template)

4. Progress. ..

45 Dpiscovery
L
J;»g Polling 10.22.1.111

Figure 26. Polled Discovery in Progress
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Status Monitoring Properties E

Discovery || Polling | Alert Delivery |

[l Enable Printer Discovery

f Print Server Discovery |/ Paolled Discovery |/ Known Printers Discovery |

[¥] Enable Known Printers Discovery

| Clear all
Delete

|_ox || cancer || apoy

Figure 27. Status Monitoring Properties:
Discovery Tab — Known Printers Discovery Sub-Tab

3. Known Printers Discovery: This option logs previously discovered

printer IP addresses. From this log, you can select and delete previously
polled discoveries to create a new polling list to target your printer search.
To enable the option, click the Known Printers Discovery tab and check
the Enable Known Printers Discovery check box (see Figure 27). From
the polled list of IP addresses, refine your search by keeping or deleting

found IP addresses. Click Apply or OK to start a new poll based on your

specification.

NOTE: You cannot manually add an IP address to this list. If you delete an IP

address, it is lost until it is rediscovered.

If Known Printers Discovery is enabled, a progress indicator displays
while the PMU discovers printers. See Figure 28.

& B cieal P2 40 ee X =G s =g s me |65

K= default.pib
A E Mew_Printar (4 template)

4 Progress._.

ﬂﬁ Discovery
e Known Printers 10.22.5.27

[

Figure 28. Known Printers Discovery in Progress
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Polling Tab
Status Monitoring Properties
[ Discovery | Polling |  Alert Delivery |
[¥| Enable Status Monitoring SHMP Pacing (MS): |100
PrinterfFolder | FirstiP | LastiP | Enable | Initial Delay ‘ Add
Discovery: truie a0

Folder: root true G0 Remme

4 [EE [ »

| OK H Cancel || Apphy

Figure 29. Status Monitoring Properties: Polling Tab

The Polling option allows you to control the way the PMU polls printers on the
network. For instance, you can create a timed interval for the PMU to poll
every 30 seconds or every two minutes. You can also specify a range of IP
addresses.

To enable the option, check the Enable Status Monitoring check box in the
Polling tab (see Figure 29). The SNMP Pacing (MS) value places a delay
between each SNMP request. This feature minimizes the network load. By
default, the value is set at 100 milliseconds (.1 second).

NOTE: If Discovery is enabled, then a discovery also occurs, based upon the
settings in the Discovery tab (see “Discovery Tab” on page 39).

Now you can set parameters to a new task. The parameters include:

Printer/Folder: To select which printer or folder you want the PMU to poll.
Click the field to select options from a drop-down menu.

First IP: To set the beginning IP address in a polling range. Use this option if
you select Range: as the Printer/Folder option.

Last IP: To set the last IP address in a polling range. Use this option if you
select Range: as the Printer/Folder option.
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Enable: To select whether or not you want to enable polling of a specific task.
If you want the PMU to poll the printers according to the specifications of your
first task, select true. Otherwise, select false.

Initial Delay (S): To specify the time delay from when the PMU starts to when
the PMU polls printers. The time delay is calculated in seconds.

Polled Interval (S): To poll printers automatically with timed intervals
calculated in seconds. Use this option to periodically poll for new printers
every few seconds.

Response Wait (MS): To specify the time delay the PMU waits between
SNMP responses. By default, the value is set at 300 milliseconds
(.3 seconds).

NOTE: If your network is overloaded and the responses are slow, you may
not receive a response with the default setting. In this case, increase
your Response Wait (MS) value.

NOTE: If you enter a low value for slow networks, you may receive no
response. In this case, increase the Response Wait (MS) value.
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Alert Delivery Tab

Status Monitoring Properties

[ Discovery | Polling | Alert Delivery |

[¥l| Enable Motification

[ AlertLog | Email Alerts | Syslog Posting |

[¥] Enable Log File

LogFile | Size | Dewice | First | Last | of
alerts.log 1000 Folder: raot enahl

Add

Browse

Clear

tif

i

[ »

| OK H Cancel || Apphy

Figure 30. Status Monitoring Properties:
Alert Delivery Tab — Alert Log Sub-Tab

Select Status » Properties to open the Status Monitoring Properties dialog
box. Click the Alert Delivery tab. Check the Enable Notification check box
to enable the option. The Alert Delivery properties allow you to customize the
way the PMU notifies you of potential printer errors. Descriptions of the three
alert types follows:

1. Alert Log: Allows the PMU to log alerts to a file located in the PMU
installation directory. To log alerts, check the Enable Log File check box,
then click Add (see Figure 30). A task item adds to the log list. In the task
item, specify the following as applicable, then click Apply or OK.

Log File: To name the log file. The default file name is alerts.log.

Size: To set the maximum file size, in bytes. The default (and
minimum required) size is 1000 bytes.

Device: To choose a device item you want the PMU to monitor, such
as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.
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NOTE: In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Marker,
Cutter, Barcode, RFID, Scanner, Label, Intervention Needed,
Consumables, and Power Cart: For a description of the alert groups
and printer events, refer to “Alert Groups” in the SNMP Configuration
section of chapter three in the Ethernet Interface User’'s Manual. All
options are enabled by default.

To set up alert groups on the Ethernet Interface, see “Configure Print
Servers” on page 145.

Comment: Enter comments as needed.

Status Monitoring Properties

[ Discovery | Polling | Alert Delivery |

[¥| Enable Motification

[ AlertLog | Email Alerts | Syslog Posting |

[¥] Enable Email
Outgoing Mail (SMTP) Server : | |
Email Subject : |Printer8tatu5 |
Email Sender : |printermanager@vnurcnmpany.cnm |
SMTP Email Server Port: (25
Ernail Address | Device | First | Last | Offline | Add
Folder: root enahle
Remaove
4 [E D
| ok || cancet || appy

Figure 31. Status Monitoring Properties:
Alert Delivery Tab — Email Alerts Sub-Tab

2. Email Alerts: The PMU sends you an alert e-mail if a printer error occurs.
To set up Email Alerts, check the Enable Email check box. Enter
information in the following fields:

Outgoing Mail (SMTP) Server: See your system administrator.
Email Subject: Enter the subject of e-mail.
Email Sender: Enter your e-mail address.

SMTP Email Server Port: See your system administrator.
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Next, click Add to define a new task (see Figure 31). In the new task item,
specify the following information, then click Apply or OK.

NOTE:

Email Address: Enter the e-mail address where you want the PMU
to send the alert messages.

Device: To choose a device item you want the PMU to monitor, such
as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.

In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Marker,
Cutter, Barcode, RFID, Scanner, Label, Intervention Needed,
Consumables, and Power Cart: For a description of the alert groups
and printer events, refer to “Alert Groups” in the SNMP Configuration
section of chapter three in the Ethernet Interface User’'s Manual. All
options are enabled by default.

Comment: Enter comments as needed.

Status Monitoning Properties E3

[ Discovery | Poliing | Alert Delivery |

[¥| Enable Notification

[ Alert Log | Email Alerts | Syslog Posting |

[¥] Enable Syslog

MachineAddress| Fort | Device | First | Last | Add

814 Folder: root
Remove

bl |

[ »

| OK H Cancel || Apphy

Figure 32. Status Monitoring Properties:
Alert Delivery Tab — Syslog Posting Sub-Tab
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3. Syslog Posting: Used in a UNIX operating system, it allows the PMU to
log alerts to a file located in the PMU installation directory. To log alerts,
check the Enable Syslog check box, then click Add (see Figure 32). A
task item adds to the log list. In the task item, specify the following as
applicable, then click Apply or OK.

NOTE:

Machine Address: The UNIX IP Address.
Port: See your system administrator.

Device: To choose a device item that you want the PMU to monitor,
such as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.

In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Marker,
Cutter, Barcode, RFID, Scanner, Label, Intervention Needed,
Consumables, and Power Cart: For a description of the alert groups
and printer events, refer to “Alert Groups” in the SNMP Configuration
section of chapter three in the Ethernet Interface User’'s Manual. All
options are enabled by default.

Comment: Enter comments as needed.
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Update Status

Update Status shows the condition of the printer at the time the status is
checked. To update the status of a printer, select Status » Update Status, or
click the T___II (green flag) button at the right of the toolbar.

Figure 33 shows a printer with a wireless Ethernet Interface that uses two

ports. The T__— (signal strength) icon represents the wireless port, while the
& (ethernet port) icon represents the ethernet port.

The printer's model number, if available, displays in brackets following the
printer icons. The printer name is a user defined field that is used to
distinguish a printer in the database. This field can be modified in the Printer
Properties dialog box under the Identification tab. The name chosen must be
unique from all the other printer names in the database and must use
printable ASCII characters.

File Edit YWiew Applications Status LWilities Help |Dialug

[l
B cHe @ P2 b eeex =@ s Reeg s vR 8
default.pdh

A E 7= =m [IBM 6700 Therrnal ] New_Printer (4 template) ONLINE = Batt 240.00 Hrs
@gr@ =X [IEM G700 Thermal ] Mew Printer 1 (& ternplate) OMNLINE = Batt 240.00 Hrs

Figure 33. Update Status

When the printer status updates, the @ (printer) icon may change color:
» Green indicates the printer is online, functioning properly, and can print
* Yellow indicates a warning, but the printer can print

* Red indicates the printer is offline or not functioning properly and cannot
print

» Grey indicates that the printer is not recognized

The message to the right of the printer description is identical to the message
on the operator panel.

If you enable status polling, the printer status updates automatically.

The E (ribbon supply) icon indicates the amount of ribbon available on the
printer.

e Green indicates a full or nearly full ribbon supply
* Yellow indicates a moderate ribbon supply
* Red indicates a small or no ribbon supply
» Grey indicates one of the following:
» The ribbon supply feature is not supported on the printer

» For thermal printers, the printer is not using ribbon but rather direct
thermal

» For thermal printers, the printer has not printed since it was powered
on, so the PMU cannot determine the amount of ribbon remaining

» For line matrix printers, the printer was powered on with a fault
condition (not allowing the ribbon to be activated), so the PMU cannot
determine the amount of ribbon remaining
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»  For line matrix printers, the amount of ribbon remaining has reached 0%
(you can still print depending on the operator panel settings)

» Dark grey (line matrix printers only) indicates that the amount of ribbon
remaining has reached 25%

NOTE: The following three icons appear only if the features are installed.
The T__: (signal strength) icon indicates the strength of the radio signal.
»  Green with three or four bars indicates a strong signal

* Yellow with two bars indicates a moderate signal

* Red with one bar indicates a weak or non-existent signal

The [ (ethernet port) icon always remains blue, since it represents an
ethernet connection.

The I (battery power) icon indicates the percentage of available battery
power.

» Green indicates the battery has 61% to 100% available power
* Yellow indicates the battery has 20% to 60% available power
* Red indicates the battery has less than 20% available power

Place the pointer over the E T__: or I icon to obtain status information
about the feature. See Figure 34, Figure 35, and Figure 36.

NOTE: No information displays if you place the pointer over the IE@ icon.

File Edit \iew Applications Status UWilities Help ‘Dialug

BB cie a PO 4 BaR X =8 Y =)
default pdb
@ﬁ?’_—:n [IBM 6700 Thermal ] Mewe_Printer (& template) OMLIMNE = Batt 240.00 Hrs

[Ribhon rermaining 50% to 75% |

Figure 34. The Ribbon Supply Icon



The Utilities Menu

File Edit View Applications Status LHilities Help Dialon

=B cfed (PO 3 ke =ddyan

default.pdb
8 B T.= = [ IEBM 6700 Thermal ] Mew_Printer (A ternplate) ONLINE = Batt 240.00 H

|5igna| Strength 94%\

Figure 35. The Signal Strength Icon

File Edit View Applications Status LUWilities Help Dialog
= B cileal P 0o sneR X =6 !

= default.pdb
ﬁ. T__:ﬁ [1BM 6700 Thermal | Mews_Printer (A template) ORNLIME = Batt 240.00

Percent Charged: 94%
Battery Voltage: 12.1 Volts
Current Draw: -3.4 Amps
Time Remaining: 13.2 Hours

Figure 36. The Battery Power Icon

The Utilities Menu
File Edit View Applications Status | Utilities | Help Dialog
| & oo @) 5[] | 4| Reboot Printer a
= defaultpdh Set Printer Password —
&3 E Mew_Printer (& template) Set Wireless Properties
Macro Liiliy
SHMP Browser

Assign IP Address

Enable Remote Printer Management
LockUnlock Menus

Configure Print Servers

Figure 37. Utilities Menu

For an explanation of the Utilities menu options, find the menu option in
Table 2 and go to the corresponding page.
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Table 3. Utilities Menu Options

Menu Option Page

Reboot Printer page 127
Set Printer Password page 127
Set Wireless Properties page 129
Macro Utility page 138
SNMP Browser page 141
Assign IP Address page 142
Enable Remote Printer page 143
Management

Lock/Unlock Menus page 144
Configure Print Servers page 145

The Help Menu
File Edit Yiew Applications Status Utilities | Help Dialm

= B [efe | o] [4m[@]f o =/a[@]w

default.pdh
A E Mew P

About

Displays the About dialog box. The About dialog box shows the PMU
program’s version information and part number, and the Java version

number.

rinter (& termplate)

Figure 38. Help Menu



The Help Menu

The Toolbar

The PMU toolbar contains buttons that perform functions. See below for a
description of each button. Refer to the specified page for a more detailed

description.

You can select which buttons display on the toolbar. See page 36.

Button

| x® @ & ~ 0% B & 0 B W

b

o
[ 1]

Description

Open: Opens a different printer database.

Save: Saves the current printer database.

Folder: Inserts a new folder into the printer database
(page 32).

Printer: Inserts a new printer into the database
(page 32).

Download File: Inserts a new Download file into the
database (page 32).

Edit: Defines the properties of the selected item
(page 56).

Include/Exclude: Deactivates a selected folder, printer,
or file (page 33).

Cut: Removes a selected folder, printer, or file from the
database and places it in the paste buffer (page 32).

Copy: Copies a selected folder, printer, or file to the
paste buffer (page 32).

Paste After: Pastes the item in the paste buffer after the
selected item (page 33).

Paste Into: Pastes the item in the paste buffer into the
selected item (page 33).

Delete: Removes the selected item (page 33).

Operator Panel: Virtual operator panel that allows you
to make selections via the PMU as if you are using the
physical operator panel (page 108).

Information Capture: Allows the PMU to capture
information sent between the computer and the printer
(page 112).

Configuration Editor: Allows you to edit the data sent
from the computer to the printer before the printer
receives it (page 67).
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from the factory settings for all configurations (page 77).

File Download: Allows you to download a configuration,
firmware, or flash file to the printer (page 86).

ODV Quality Wizard: Opens the ODV Quality Wizard
window (page 115).

Configure Print Servers: Opens the Configure Print
Servers window (page 145).

Speed Keys: Opens the Speed Keys window
(page 116).

Flash File Manager: Opens the Flash File Manager
window (page 82).

Media Profiler: Opens the Media Profiler window
(page 100).

CST Manager: Opens the CST Manager window
(page 147).

Job Capture: Opens the Job Capture window
(page 117).

Macro Utility: Opens the Macro Utility window
(page 138).

Update Status: Marks a printer or printers for status
updates (page 49).

Discover Printers: Searches for new printers (page 38).



Database Items

Managing the Database

To organize your databases easily and effectively, use the Edit option on the
printer database menu bar. You can add, delete, and assign printers,
configuration files, and download files to your database tree. You can also
organize them using folders. All Edit menu functions have buttons on the
toolbar (see page 53).

Database Items

I:l Folder: Use folders to group the elements of your database.
@ Printer: See “Defining Printer Properties” on page 56.

@ Download file: A flash file or a configuration file (created in the
Configuration Editor which is described on page 67) stored on your
host computer.

A flash file contains information (e.g., the printer’s firmware file or a font
file) that you can download to the flash SIMM memory of a printer or
group of printers.

A configuration file contains user-defined printer configurations that you
can download to your printer using either the printer database or the
Configuration Editor.

For information about Download files, see “File Download” on page 86.
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Defining Printer Properties

Jel]

File Edit View Applications Status Utilities Help ‘Dialog
2 B cile e PO & e x =@ 6 R s e s we 85

=3 default pdb Printer Properties 3

53 5 New_Printer ¢ rldemiﬁcation rSecurity rCunnec‘tiuns rlnformaiion |

Hame {(Unigue): |New7Primer |

Printer Description: |g ternplate |

Use only printable characters for printer name and description.

Figure 39. Defining Printer Properties

Before you can use any of the PMU applications, you must define the printer's
properties. You must identify the printer and configure how the printer
communicates with the PMU. To define a printer, double-click the printer’s
name or click the lp (edit database entry) button. The first time you run the
PMU, double-click New_Printer (A template). The Printer Properties dialog
box opens. See Figure 39.

The Printer Properties dialog box contains four tabs: Identification, Security,
Connections, and Information, described in the next sections.
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Identification Tab

Pinter Properies &
[ dentification || Security | Connections | Information |

Mame {Unique): ‘New_F'rinter |

Printer Description: ‘ A template |

Lise onhy printable characters for printer name and description.

oK | | Cancel

Figure 40. Printer Properties: Identification Tab

Name (Unique)/Printer Description: Assigns a name to your printer to
identify it in the printer database. You can also assign a printer description,
which appears in parentheses to the right of the printer name in the database.

When you assign a printer name and description, use only printable
characters. Spaces may be used to separate words.
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Security Tab

T S ~ |

| Identification | Security | Connections | Information |

User Password: ‘ |

Superisor Password: ‘ | [_] Supervisor Mode

Telnet Guest Password: ‘ |

Telnet Root Password: ‘ |

Lise onhy printable characters for passwaorids.

QK | | Cancel

Figure 41. Printer Properties: Security Tab

User/Supervisor Password: Enter the printer's password, if appropriate.
The password feature restricts access to certain functions of the PMU. In
User mode, the PMU does not allow the following functions: downloading
files, configurations, or configuration names to the printer; clearing the error
log; and setting passwords. Supervisor mode allows unrestricted access to all
functions of the PMU.

User and Supervisor passwords are only recognized up to 9 characters, and
are displayed as *****, one * for each character typed. Use only printable
characters for passwords. Spaces may be used to separate words. To set up
a password, see “Set Printer Password” on page 127.

Telnet Guest Password: The PMU uses Telnet to read various printer
settings.

IMPORTANT  If you change the Telnet guest password, click OK and then the
T___\ (green flag) button (or select Status » Update Status).

Telnet Root Password: The PMU uses Telnet to update various printer
settings.

IMPORTANT If you change the Telnet root password, click OK and then the
E (green flag) button (or select Status » Update Status).
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Telnet Guest Password Errors

File Edit View Applications Status UWilities Help ‘Dialug

=B e P 0 s nnex =ddyaE e e
[defaultpdb|
&A= New_Printer (A template) Telnet Error:Check <guest- password

Figure 42. Telnet Guest Password Error: Polling the Printer Status

The PMU uses Telnet to poll the printer status. If your printer reports a Telnet
error (see Figure 42), enter the password for the user guest (page 58).

See your system administrator.

Wirelezz Properties

l/GeneraI | WEP Encryption | Kerberos |"EAP [ "WPA |

SSID: | | Sub-Channel:
Network Mode: Infrastructure = Transmit Power:

Mot A Wireless Printer E
Antenna Diversity: E

® Either this is not a wireless printer or a
;

connection to the printer cannot be obtained. :
Authentication: E

[_] international Roaming

Fress Send Button To Download Settings Printer Settings:

[ update || Close |

Power Mgmt:

Figure 43. Telnet Guest Password Error: Reading Wireless Settings

The PMU also uses Telnet to read wireless printer settings (page 129). If the
PMU reports a Telnet error when attempting to read wireless printer settings
(see Figure 43), enter the password for the user guest (page 58).

See your system administrator.
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Telnet Root Password Errors

Wireless Properties

(" General [ WEPEncryption |{ Ferberos | EAF [wpa |

SSID: |Samp|e 351D |Suh-ChanneI: default

i i i i x
Netwark Mode: Failure Sending Wireless Properties B

Telnet error occurred while sending the new
wireless properties to the printer.

Antenna Diversit: | Prii

Power S et MO ﬁ Error: Failure occurred while setting the SSID.

e op Please send the properties again. 9 = |

[_] International Roaming
Fress Stop Button To Abort Sending Properties Read -
Close

Figure 44. Telnet Root Password Error

If the PMU reports a Telnet error when attempting to update wireless printer
settings (see Figure 44), enter the password for the user root (page 58).

See your system administrator.

Enable Command Failed |

Remaote printer management on the printer failed
and is disabled. Check the printer to see that it

is powered on and has a network card installed,
then try it again.

Press "0K" to continue.

Figure 45. Enable Command Failed

The PMU also uses Telnet to enable remote printer management (see
“Enable Remote Printer Management” on page 143).

If the PMU reports an error when attempting to enable remote printer
management (see Figure 45), enter the password for the user root (page 58).

See your system administrator.
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Connections Tab

T S

 Identification | Security || Connections |  Information |

" Access Method | Network | SerialModem |

Firmware Download Initial Delay (Sec):

Access Method: | Ethernet i

Download Mode: |Access Method |

Printer Timeout on Firmware Download: | 2 minutes
1]

QK | | Cancel

Figure 46. Printer Properties:
Connections Tab — Access Method Sub-Tab

The Connections tab contains three sub-tabs: Access Method, Network, and
Serial/Modem.

Access Method Sub-Tab

Access Method: |dentifies how the PMU accesses the printer. Refer to the
Ethernet Interface User’'s Manual to set up the Ethernet Interface for your

printer.

Ethernet: To connect the host computer to the printer via the
Ethernet Interface.

Network (TCP): To connect the host computer to the printer via a
network interface.

Printer Serial Port (Direct): To connect the host computer to the
printer directly via the serial port.

Printer Debug Port (Direct): To connect the host computer to the
printer directly via the debug port.

Printer Serial Port (Modem): To connect the host computer to the
printer via a modem and the serial port.

Printer Debug Port (Modem): To connect the host computer to the
printer via a modem and the debug port.

Download Mode: Identifies how the PMU downloads files and configurations
to the printer. Access Method is the only option available.

Printer Timeout on Firmware Download: Specifies the number of minutes
the printer waits for data while downloading a file from the host computer. If a
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stall lasts for more than the specified time, the printer times out and the
download terminates. If you have a slow connection between the PMU and
the printer, you may need to define a longer Download Timeout period.

The Download Timeout range is between 1 and 60 minutes. The default is
2 minutes.

Firmware Download Initial Delay (Sec): Specifies the number of seconds
the PMU waits before sending files to the printer. If the printer is not ready
within the specified time, the download will terminate, and the Status and
Error Log will report Connection Refused.

If you receive this error message, increase the initial delay time. The default is
60 (seconds).

Network Sub-Tab

Pinter Properties ———__________________________[|
(Iderrtiﬁcatiun rSEcurity Connections | Information |

f Access Method r Metwork r SerialModem |

IP Address: |1 2r.o.aon

Port Number: |3nn1 | | Defaut |

Time Out {5..300 seconds): 15

| ok || cancel

Figure 47. Printer Properties: Connections — Network Sub-Tab

Enter the printer’s IP Address and Port Number. (Click Default to reset the
Port Number to 3001.) The Time Out option sets the amount of time, in
seconds, the PMU waits for a response from the printer after sending a
command. If there is no response in the specified amount of time, an error
message appears in the Status and Error Log pane. If you have a slow
connection between the PMU and the printer, you may need to define a
longer Time Out period. Define the Time Out between 5 and 300 seconds (the
default is 15 seconds).

NOTE: The Network settings must match the settings in the operator panel
menu. See “ETHERNET PARAMS”, “ETHERNET ADDRESS”, or
“WIRELESS ADDRESS?” in the printer's User’s Manual to check the
IP address.

To check the port number on the printer, see “Check Port Number” on
page 14.
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Serial/lModem Sub-Tab

The Serial/Modem tab contains two tabs: Serial Port Parameters and Modem
Control.

Serial Port Parameters

Pinter Properies &
 Identification | Security || Connections |  Information |

[ Access Method | Network | SerialModem |

| Serial Port Parameters | Modem Control |
Connect Using: |(COM 1 -
Speed: | 9600 Baud
Word Size: |8 Bits b

Parity: | Mone

Nl

Stop Bits: | 4 git -

QK | | Cancel

Figure 48. Printer Properties: Connections — Serial/Modem Sub-Tab
Serial Port Parameters

Connect Using: The serial port to use for connection. The default is COM1.
The range is COM1 to COM20.

Speed: The baud rate at which data transfers. This setting must match the
speed of the printer serial debug port. See Table 4 to determine the serial
debug port baud rate menu location for your printer model

Table 4. Serial Debug Port Baud Rate Menu Location

Printer Model Menu

6700-M40 Series INTERFACES » Printer Mgmt » Baud Rate

6700 Series PRINTER MGMT or Factory » Baud Rate
4400 Series Factory » Baud Rate

6500 Series PRINTER MGMT » BAUD RATE

6400 Series SERVICE » PRINTER MGMT » BAUD RATE

Word Size: The number of data bits per character. Must be set to 8 bits.

Parity: Adds an error checking bit if set to Odd or Even. Since the word size
must be set to 8 for correct operation, parity should normally be set to None.

Stop Bits: Inter-character gap. Can be set to 1 or 2. The normal setting is 1.
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Modem Control

Printer Properties E |

(Iderrtiﬁcatiun rSEcurity Connections | Information |

f Access Method r Metwork r SerialModem |

( Serial Port Parameters r Madem Control |

Phone Number:

[w] Wrait for dial tone

[¥] Show status when dialing

Dial Method Call Back

% Tone O Pulse Number: [_] Enable

| ok || cancel

Figure 49. Printer Properties: Connections — Serial/Modem Sub-Tab
Modem Control

Phone Number: Enter the phone number you wish to call.

Dial Method: Choose Tone or Pulse.

Call Back: Enter your phone number, and check Enable if you want to use it
as a call back number.
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Information Tab

Pinter Properties ————____________________________[|
(Iderrtiﬁcatiun rSEcurity rCunnemiuns Information

Hardware Address: 00:30:72.09:C8.F7
IP Mask: 255.0.0.0

Gateway: 10.22.1.254

Print Server Name: M_09C9F7

SMB Workgroup: WORKGROUP
Location: null

Serial Mumber: 51703

oK | | Ccancel

Figure 50. Printer Properties: Information Tab

Contains information about your printer. Refer to the Ethernet Interface User’s
Manual for more information.
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3 Applications and
Web Access

Configuration Editor

4 Configuration Editor [New_Printer]
File Edit View Migration

= B @ <@ s ialoy v |12]~|
FFLIME
Frotect Configs.: Disable
o~ MEDIA SETUP
o= SEMEOR SETUP
o= EMULATICN
o~ PRINTER SETUF
o= |NTERFACES

o RFID

Displayed Language Displayed Configuration Power-Up Configuration

|English | - | |Fac‘tury | hd | |Factury | b |
’7 —

Figure 51. Configuration Editor Window

To access the Configuration Editor application, select a printer from the
printer database and select Applications » Configuration Editor or click the
E (configuration editor) button. Select File » Upload From Printer to upload
configurations from the printer. The configurations upload from the printer and
the active configuration displays in the Configuration Editor window. See
Figure 51.

The Configuration Editor supports offline editing, allowing the editing of stored
configurations. If you start the Configuration Editor without connecting to a
printer, the screen will be blank (indicating no configuration loaded). A
configuration will not display until you load a configuration file from a disk or
computer.

The Configuration Editor allows you to upload, modify, and download eight
user-defined configurations and the factory default configuration (only if
modification of the factory configuration has been enabled; see the NOTE on
page 69). You may also save sets of configurations to your local hard drive so
that they can be easily downloaded to the printer at any time.

The Configuration Editor does not change the current configuration or the
active printer status until the configurations are downloaded to the printer.
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Menu Tree

The Configuration Editor displays the printer configurations in a tree format
(see Figure 51). The top level of the tree is the OFFLINE menu. From this
level, the tree branches into the printer's submenus. Menu items that have a
117,' or &&= (handle) next to them have further submenus below them. Click the
handle to expand or collapse the submenus below. (You may also use the
Expand Tree/Collapse Tree options in the View menu, but these options will
expand or collapse all submenus.)

The Configuration Editor has three drop-down menus at the bottom. The
Displayed Language option allows you to select from five or more different
languages to display the configuration information. The Displayed
Configuration option lets you choose between the available configurations to
display. The Power-Up Configuration allows you to assign which configuration
loads whenever the printer turns on.

Creating Configurations

Along with the factory configuration, your printer allows up to 8 user-defined
configurations that can be downloaded to your printer's memory. You may
create configurations using the operator panel or by using the Configuration
Editor.

To create a configuration using the Configuration Editor:

1. Select Edit » Copy From:. A list of configurations appears. Undefined
configurations appear gray. Choose one of the configurations.

2. Click Edit. (Notice that the configuration you chose in step 1 now appears
next to the Copy From: menu item.) Move your mouse down to Copy To.
A list of configurations appears. Choose the number of the configuration
you want to create. This new configuration is created with the settings
from the configuration you chose in step 1.

NOTE: If you choose to Copy To a configuration which already exists, that
configuration will be overwritten.

3. You may now edit the configuration settings. See “Changing
Configurations” on page 69.



Changing Configurations

Changing Configurations

Configuration settings in the Configuration Editor can be changed two ways:
* make the changes directly on the menu tree
» use the Menu Editor

NOTE: Normally, the factory default configuration cannot be changed.
However, you can enable modification of the factory configuration.
Select Edit » Enable Factory Edit. It is strongly recommended that
you do not modify the factory default configuration. If you choose to
modify the factory configuration, you should first upload it from the
printer, and then save it. This way, you will have a backup copy of the
factory configuration. To disable modification of the factory
configuration, select Edit » Disable Factory Edit.

Making Changes on Menu Tree

1. Using the Displayed Configuration menu at the bottom of the window,
click the drop-down arrow to choose the configuration to change.

2. Expand the submenus until the configuration setting you want to change
displays.

3. Select the menu item you want to change. A selection box surrounds your
choice. See Figure 52.

@ PRINTER SETUP
Fower Saver Time: 15 minutes
FPwr Save Control: Enable
Display Language: Enalish
Figure 52. Selecting a Menu Item

4. Double-click an item to open the Menu Editor (page 70) for that item, or
use the < and > keys to toggle through the available options. See
Figure 53. (You may change these keys in the printer database window:
select File » Preferences, then click the Configuration Editor tab.

See page 27.)

@ PRINTER SETLUP
Fower Saver Time: 15 minutes
Pwer Save Control: Enable
Dizsplay Language: Spanish
Figure 53. Toggling Through The Available Options
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Menu Editor
£ Menu Editor: Printer Protocol

Factory (0) Edit Off Configuration 1 Configuration 2
P-Series -
! Hidden

Configuration 3 Configuration 4 Configuration 5

Configuration 6 Configuration 7 Configuration &

HideAll || CopyFact || oK || cancel || appy |

Figure 54. Menu Editor

Double-click any menu item to open the Menu Editor window. Figure 54
shows the screen you see when you double-click the Printer Protocol option.
By using the Menu Editor, you may view and adjust the settings of all nine of
the printer configurations at once. To change a setting, click the drop-down
arrow underneath the corresponding configuration and choose an option.
Grayed out configuration names and settings do not exist; you must create
the configuration before you can edit it (see page 68).

To hide a menu item in the operator panel, select Hidden under a
configuration. Click Hide All to hide this menu item in all configurations. (For
more information on hiding, see page 71.)

Select Copy Fact (1-8) to set all configurations to the same value as the
factory or user-defined configuration currently selected under the
Edit » Copy From: menu in the Configuration Editor (see page 68).

Click Cancel to exit the Menu Editor without saving your changes.
Click Apply to save your changes without exiting the Menu Editor.
Click OK to save your changes and exit the Menu Editor.

Deleting Configurations

To delete any of the configurations (except the factory configuration), select
Edit » Delete » and choose the number of the configuration to be deleted.

Naming Configurations

You may name any of the eight user-defined configurations using an
alphanumeric string of 1 to 15 characters. Select Edit » Names to open the
Edit Configuration Names window.

Choose the configuration you want to name, then click OK to assign the name
change, Cancel to exit this window without saving your changes, or Reset to
restore the original configuration numbers.
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IMPORTANT

Hiding/Unhiding Menu ltems

4 Configuration Editor [New_Printer]
File Edit View Migration

= B @ <@ @ ialoy v |12]~|
@ PRINTER SETUP
Power Saver Time: 19 minutes
Pwr Save Contral: Enable
Display Language: English
Alarm: On
Power-up State: Online
Pt Setup Parse: Enable
Pt Setup SFCC 21h
Cancel Key: Enable —
Ret. Status Port: Serial
Compatihility: Default
Ld Char at Pwrlp: Disahle
Ld Set at Pwrllp: Disable
- Main FFS
Auto Locking: Disahle

hd E it Dooaffoe 4 000 1D,

Displayed Lahguage Displayed Configuration Power-Up Configuration
[English |~/ |Factory v| |cra1 [+

| »

il

Figure 55. Hiding a Menu Item

The Configuration Editor allows you to hide menus to make the operator
panel menus easier to use, or to restrict printer operators from accessing
certain printer configuration menu items. If you choose to hide a menu item in
the Configuration Editor, the hidden menu item still loads into the printer when
the configuration downloads to it. However, the hidden menu item does not
appear on the operator panel.

The Configuration Editor displays hidden menus in gray on the menu tree.
When a menu item is hidden, all of its sub-menus are hidden as well.

In Figure 55, the Display Language menu item is hidden. The Display
Language menu item cannot be changed from the operator panel.

Depending upon the active emulation, active interface, or hardware
attached to the printer, some menu items cannot be hidden on the
operator panel, even though they may be defined as “hidden” in the
PMU.

You can still change hidden menu items using the Menu Editor.
You can hide or unhide menu items in three ways:

1. In the menu bar, select View » Hide/Unhide Menus. With this menu
option, you may hide or unhide individual items, sub-menus or the entire
configuration.

Using the Menu Editor. See page 70.

Using the keyboard. From the menu tree, select a menu item. A selection
box appears around the selected menu item. Press H to hide the menu
item or U to unhide the menu item. (To change these keys, select

File » Preferences in the printer database window. See page 27.)

71



Chapter 3

Configuration Editor

IMPORTANT

72

Saving Configuration Files

Normally, your printer can save only nine configurations in its memory. You
change these configurations through the operator panel. However, using the
PMU, you can store a nearly unlimited number of configurations on your host
computer.

Once you have made your changes, you can save your configurations as a
.cfg file on your local hard drive. This way, you can open any set of
configurations from your host computer and download them into your printer
quickly and easily.

To save configurations to your local hard drive, select File » Save As. Be sure
to save your configuration as a .cfg file.

Opening Configuration Files

To open a configuration file, select File » Open. The Configuration Editor
loads the settings from the file you choose.

These settings do not affect the current configuration or the active
printer status until the configurations are downloaded to the printer.

NOTE: The Configuration Editor displays only one configuration file at a time.
Be sure to save any changes before opening another configuration file.

If you load a configuration file that was created with the PMU version 3.03H or
earlier, you may need to link the affiliated CST file. In this case, select

File » Open again, and check the Link CST File check box. See Figure 56.
Navigate to the affiliated .cst file and double-click it (or single-click it and click
the Select button). Save the configuration file, and the CST information will
save to the new configuration file. (You will not need to link the CST file in the
future.)

NOTE: If you hover the pointer over the Link CST File check box, a screen
tip appears that describes this functionality.

Look In: | pmu v| @ @ @ @E

3 lib I?H_ink CST File
T licenses = = - It' = ——y
. orme older configuration files may be missing
[T uninstaller required CST infarmation. Select this aption
I webapps to selectthe CET file that contains this
3 xmil infarmation. Mate that itis the responsibility
of the user to select the correct 5T file.
hen the configuration is saved, the PAA
configuration info is then saved as well.
File Name: | |
Files of Type: | Configuration Related Files { *.cfg *.bnd *.cst ) % |

| Open || Cancel |

Figure 56. Linking a CST File
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Downloading Configurations

You may use the Configuration Editor to download into your printer any
configurations you have created. Open the configuration file you want to use,
then select File » Download To Printer to send individual configurations, all
configurations, or just the configuration names.

Downloading a configuration overwrites the corresponding configuration
currently stored in the printer. If you want to save the configurations currently
stored in the printer before overwriting them, upload them into the
Configuration Editor first, and then save them as a .cfg file on your local hard
drive.

NOTE: Be sure to calibrate your thermal printer after you download a
configuration to it. See “Running Auto Calibrate” in the printer’s
User’s Manual.

Uploading Configurations

The Configuration Editor can upload configurations from a printer. Select
File » Upload From Printer. Once the configurations upload, you can save
them to a file. Now you can select another printer from the database and
upload its configurations. The PMU prompts you to save the previously
uploaded configuration before the new configuration uploads.

Migration

Over time, menus and functions changed to reflect the new features of the
printers. Some printer features have been removed to provide better or more
complete printer features. Older saved configurations may have used these
removed features or contain settings that no longer exist or have been
modified in new printer firmware. This can cause potential problems when
downloading new printer firmware while preserving previously saved
configurations if the saved settings are not analyzed and adjusted to work
with the new firmware. This analysis and adjustment has been summarized
into one word: migration.

Transferring Saved Settings

Original Method

To ensure that your settings from the saved configuration are set correctly in
the printer: print out the old configurations, download the configurations to the
printer, print out the new configurations, and compare the old settings with the
new settings.

If you need to make changes: upload the configurations to the Configuration
Editor, make changes, and re-download to the printer.
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Enhanced Method

Using the migration utility in the Configuration Editor, all these things can be
done without having to download the configurations to the printer until you
know they are correct. No migrated settings will be downloaded to your printer
until you download them. This way you can run the migration, view the results,
view the report, and make any necessary changes without affecting your
saved configurations or the configurations in the printer.

How To Use The Migration Utility
STEP 1:

Load the configurations settings that need to be migrated into the
Configuration Editor before using the migration utility.

Migration Limitations

Only attempt to migrate saved configuration settings from printers of the same
model type and the same emulations. An example of a different printer model
type is a thermal printer configuration to a line matrix printer.

The printer that you are going to migrate the settings to should be a superset
of or contain the same emulations as the saved configurations. For example,
migrate saved settings that contain an ANSI emulation on a line matrix printer
to another line matrix printer that contains ANSI and PGL. Do not migrate
these same saved settings to a line matrix printer that does not contain ANSI.
The migration utility does not prevent you from doing this, but the results
would be useless and could cause problems if the migrated configurations
were downloaded and then loaded on a different printer type.

Make sure the printer model type and emulations of the saved
configurations match the printer model type and emulations of the
printer you want to migrate the settings to before attempting to migrate
the saved settings.

Loading Configuration Settings

The configuration settings to migrate can be opened using the Configuration
Editor in the following ways:

Loading From a File

Click the = (open configuration file) button or select File » Open. Choose
your configuration file and then click OK.

Loading From a Printer

Select a printer in the printer database. Click the @ (upload configuration)
button or select the File » Upload From Printer to upload the settings.



Migration

STEP 2:

Select a printer and begin the migration of the saved configuration
settings.

Select a Printer to Use for Migration

Select a printer in the printer database. The printer you select must have new
printer firmware. If it does not, exit the Configuration Editor and download new
firmware to the selected printer (see “File Download” on page 86), then select
the printer in the printer database.

Start the Migration

Click the @ (migrate) button or select Migration » Run Migration. Several
messages will appear in the bottom left corner of the Configuration Editor that
indicate the progress of the migration.

STEP 3:

View the results using the Configuration Editor.
The results will display graphically in the Configuration Editor.

Several different icons will display depending on the migration. Hover the
pointer over an icon to display a short description. A icon can represent
several types of changes. The migration report details these changes
(page 76).

Select Migration » View Results to see the migration results.
This menu has the following submenus:

Original Configurations

All Menus: Displays the original configuration settings with the menus that
were removed from the original configurations.

Removed Menus: Displays only the menus that were removed from the
original configurations.

Migrated Configurations

All Menus: Displays the migrated configuration settings including all of the
menus that were modified.

Modified Menus: Displays only the menus that were modified by the
migration of the saved settings.

If you select Modified Menus and then select View » Expand Tree, all of the
menus that were affected by the migration will display in a simplified view.

Migration Icon Definitions

(® Indicates a new menu or a new set of menus.

Ei—) Indicates that the menu previously existed in the saved configurations and
was added to another menu.
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e Indicates that the menu previously existed in the saved configurations and
was moved to another menu, or removed from the current menu but still exists
in the saved configurations.

¢ Indicates that the menu was completely removed.

A Indicates that this menu or a submenu has changed. The change can be
various things such as range or increment.

A\ Indicates that additional selections have been added to this menu.
A\ Indicates that selections have been removed from this menu.

ﬁ Indicates that this menu has been replaced with another menu or the
menu definition has changed.

STEP 4:
View the results using the Migration Report Viewer.
Select Migration » View Report or double-click the @ Migration Report

icon (located at the top of the migrated configurations display) to open the
Migration Report Viewer.

The Migration Report Viewer displays a detailed textual report of the
information that displays graphically in the Configuration Editor. Use the
Migration Report Viewer to view, save, or print the report.

NOTE: It is recommended to use landscape mode when printing the
migration report.

The report contains the following types of messages:

Informational Messages: Menu settings that migrated without problems.
They display to inform you that there was a change during the migration.

Warning Messages: Menu settings that attempted to migrate to the new
configurations and were changed. Analyze these settings to determine if they
are desirable.

Intervention Messages: Menu settings that could not migrate to the new
configurations. This could occur when a menu item was completely removed
and the user utilized a setting other than the default. In this case the Migration
Utility cannot decide what action to take.

IMPORTANT  You must resolve intervention messages, or the printer may not operate
properly.

STEP 5:

Post-migration.

After you review the migrated configuration, save, delete, or download the
migrated configuration file to one or more printers using the PMU.
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Factory Settings Differences

Menu Bar —

Toolbar ——

The Factory Settings Differences application allows you to keep track of
migration from old to new printers. It displays the differences between the
Factory configuration settings and all other saved configuration settings. The
differences are highlighted to show value differences between configurations.

Two views displaying the data are available. The All Settings view shows all of
the menus, highlighting the value differences. The Differences Only view
shows the menus and its corresponding values that differ from the Factory
settings.

To access the Factory Settings Differences application, select

Applications » Factory Differences or click the #i (find differences) button.
The application opens with no configuration data loaded. The Factory
Settings Differences window contains three sections: the menu bar, toolbar,
and the configuration settings differences pane. See Figure 57.

Configuration Settings
Differences Pane

= 5| g |Dialug v|z2|~

Menu Marne | Menu Level | Factory | configuration 1 | Configuration 2 |

1 Il b
Displayed language

Figure 57. Factory Setting Differences Window
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Menu Bar

The menu bar consists of a File menu and a View menu.

File Menu
File | View
Open Ctrl-0
Upload Differences Ctil-L
Save Ctrl- 5
Save As Ctrl- 2
Print Ctrl-F
Exit Ctrl-E

Figure 58. Factory Settings Differences — File Menu

Open

The Open submenu allows you to select and open a previously saved Factory
Settings Differences file. The file must be one that was created with this
application.

NOTE: No error checking is available for an invalid file type, including
Comma Separated Variable (CSV) formatted files that were not
created by this application.

Upload Differences

The Upload Differences submenu uploads the configurations and determines
the Factory settings differences. The results display in a table in the All
Settings view.

Save and Save As

The Save and Save As submenu allows you to select and save the Factory
setting differences file to a file. The results table can only be saved in the
Differences Only view. You will be informed if you try saving the file in the All
Settings view. The saved file will be in CSV format.

Print

The Print submenu allows you to set up printing preferences and print the
differences table. You can print the differences table in both views.



Toolbar

View Menu
Yiew
All Settings Ctrl-A
Differences Only Cirl-D

Figure 59. Factory Settings Differences — View Menu

All Settings View

The All Settings view displays all of the menus in the configuration,
highlighting the menus that are different from the Factory settings and their
values. The menu name and its associated values are highlighted in different
colors for easy distinction. See page 80.

Differences Only View

The Differences Only view shows the top level menus and the menus that
have configuration values that are different than the Factory settings. Since
this view only shows the differences, the menu names are not highlighted.
The menu values are highlighted for easier distinction. See page 81.

Toolbar

= || sd 2 52| <3 pialoy v |12 |~

Figure 60. Factory Settings Differences — Toolbar

The toolbar contains buttons for Open, Save, Upload Differences, All Settings
View, Differences Only View and Print. These buttons perform the same
actions as their menu counterparts. The toolbar also has font selection and
size boxes to allow user selectable preferences.
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Configuration Settings Differences Views

This view consists of a non-editable table that displays the menu name, the
menu level, the Factory default settings, and the values of other saved
configurations.

The menu level column shows a menu option’s hierarchy level from the top
menu. Number 1 indicates the top menu, and the largest number is the menu
that is the furthest down the menu tree.

All Settings View

In the All Settings View mode, all menus and its corresponding values display
in a table. The menus with values different from the Factory configuration is
highlighted in purple and the value itself is highlighted in yellow.

See Figure 61.

File View
| 2P| [praiog [~[1z]~]
Menu Mame menu Level Factory Manufacturing | Floor 1 Floar 2

Currency Sign 5 RWE Select RWME Select] RME Select] RWME Select| =
AR3IZ40 Compat. 1) Dizahle Dizahle Dizahle Dizahle
CPILFI Select =

Select CFI 4 10.0 CPRI 12.0CPl 13.3CPI 20,0 CPI
Select LF| 4 6.0 LPI 6.0 LPI 6.0 LPI 8.0LPI
ICECS CPI 4 6.7 CPI 6.7 CPI 5.0 CPI 6.7 CPI
lHost Command 3 lgnore Unidir|  lgnare Unidir.| lgnare Unidir.|  lgnore Unidir,
VFont Attributes 3

Typeface 4 Mear LG Mear L2 Mear LG Mear LO|=]|
Styling Type 4 SOMG SOMG SOMG SOMG
BHiah Density 4 Dizahle Dizahle Dizahle Dizahle
lProp. Spacing 4 Dizahle Dizahle Dizahle Dizahle
¥Eold Print 4 Disahle Disahle Disahle Disahle
lltalic Frint 4 Dizahle Dizahle Dizahle Dizahle|

4] i I I
Displayed language

[Engtish |~]

Figure 61. All Settings View
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Differences Only View

In the Differences Only View mode, only the differences between the Factory
configuration and other menu configurations are listed. The differing values
are highlighted in yellow. The menus are not highlighted.

File ‘iew

& B[B0[B) |piatoy [~[rz[~]
Menu Mame Menu Level Factory Manufaciuring | Floar 1 Floor 2

Protect Configs. 1
|HOST INTERFACE 1 Auto Switching Centronics Serial| IEEE 1284
JEMULATION 1
ISeIectCF‘I 4 10.0 CPI 12.0CPI 133 CPI 20,0 CP1j
lselect LPI 4 .0LPI 6.OLPI 6.0LPI soLpl|
lDBCS CPI 4 .7 CFI £.7 CPI 5.0 CPl 6.7 CPIf
WFunct ofLines nlines 5 Jald] ol a3} aa||
lFunctinn of GPln characters i} 136 163 181 272
IPRINTER CONTROL 1
}aDVANCED USER 1

l ] I |

Displayed language

|[Engiish |+]

Figure 62. Differences Only View

Displayed Language

The Displayed Language drop-down menu shows all available foreign
languages that the attached printer supports. Since this depends on the
printer, the drop-down menu will be disabled when the Factory Settings
Differences application is first launched. After the Upload Differences program
is executed, the available language names supported by the printer will
display.

After you select a language, the program determines if it has already been
uploaded, and changes the table settings to this language. If it is not loaded,
the program uploads the selected language and redisplays the table settings
in the new language.
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4. Flash File Manager

Printer List Refresh File List

Warehouse - FFS Info Not Loaded | Get File Info

Manufacturing - FFS Info Not Loaded
Office - FFS Info Not Loaded
Lab - FFS Info ot Loaded

FFS information not available for Warehouse®, use "Get File Info’ to upload.

Figure 63. Flash File Manager Window

With the Flash File Manager, you can view a list of the unprotected files
loaded in the printer’s flash memory and optional EMC (Expanded Memory
Cartridge).

NOTE: The EMC is available only for 6700-M40 printers.

You can upload the files to the host computer, save them for backup, delete
them, and download them to another printer.

Select Applications » Flash File Manager or click the @ (flash file
manager) button. See Figure 63.

The Printer List pane displays a list of printers that are selected in the printer
database. If you select one printer, it appears alone in the list. If you select a
folder, all active printers in the folder appear.

If you return to the printer database and select another printer or folder, click

Refresh to update the Flash File Manager and display the newly selected

printer(s).

NOTE: Cloned printers or different folders that link to the same printer do not
display. Only the original printer displays.



Get File Info

Get File Info

4. Flash File Manager

Printer List Refresh File List

Warehouse - Files found: 5 | Get File Info 91674.sf, 57858 bytes, data not loaded.

Manufacturing - FFS Info Not Loaded 00249.sf, 96922 hytes, data not loaded.
Office - Files found: 10 01059.sf, 56290 ytes, data not loaded.
Lab - FFS Info Hot Loaded ————————— |91060.sf, 55938 Iytes, data not loaded.

Upload 9167 1.sf, 58130 ytes, data not loaded.

01880.sf, 70330 hytes, data not loaded.

Delete 93008.5f, 57282 bytes, data not loaded.
’—Dm ote & Optimize | [EMC193099.51, 56290 intes, data not loade
; [EMC] 94072.5f, 55038 hytes, data not loade

[EMC] 94079.5f, 58130 bytes, data not loade

1B

Status Bar ———— |Last status for "Office’ - Get File Info Completed

Figure 64. Get File Info

Select a printer, and then click Get File Info to see a list of the unprotected
files loaded in the printer’s flash memory. Progress displays in the status bar
at the bottom of the window. After you retrieve the flash memory information,
the files appear in the File List pane. See Figure 64.

NOTE: The files are located on the printer’s internal flash memory. If [EMC]
precedes the file name, then the file is located on the optional EMC.

When complete, select another printer and click Get File Info to view its flash
memory information.

You can only view the flash memory information from one printer at a time,
but the Flash File Manager remembers what information has been retrieved.
NOTE: _ For printers that have not had flash memory information loaded, the message
Displays only if | FFS (Flash File System) Info Not Loaded displays in the Printer List.
the printer has— See Figure 64.

an EMC installed NOTE: Although you have retrieved the flash memory information, the files

have not been uploaded. Notice the message “data not loaded” in the
File List. To upload the files, see “Upload” on page 84.

The status bar will toggle from the status of the last operation performed to
the status of the printer flash: memory available (free), memory used (in use),
and memory deleted but not optimized (trashed):

[Last status for "Office’ - Get File Info Completed |

[Printer Flash info for "Office’ - free 1469kb, in use 2346kh, trashed Ob |

If you have an EMC installed, the status bar will also toggle the status of the
EMC:

IEMC info for "Office’ - free 32223Kkh, in use 304Kh, trashed Ob |
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Upload

& Flash File Manager

Printer List Refresh File List

Warehouse - Files found: 5 | Gt File Info 01674.5f, 57858 bytes, data loaded,

Manufacturing - FFS Info Hot Loaded 00249.sf, 96922 ytes, data loaded.
Office - Getting File Data... 91059.sf, 56290 hytes, data loaded.
Lab - FFS Info Not Loaded ——— (91060.sf, 55938 ytes, data loaded.

91671.5f, 58130 bytes, data loaded.
91880.sf, 70330 hytes, data loaded.

Delete 03008.sf, 57282 bytes, data loaded.
’W [EMC] 93099.5f, 56290 ytes, data not loade
; [EMC] 94072.5f, 55938 bytes, data not loade

Save As [EMC] 94079.sf, 58130 hytes, data not loade

1]

Last status for "Office’ - Upload Completed

Figure 65. Uploaded Flash Files

To upload unprotected files, select a printer, and then select the files you want
to upload from the File List. Click Upload to upload the unprotected files from
the flash memory. Progress displays on the status bar at the bottom of the
window.

After the files upload, they appear selected in the File List pane. See
Figure 65. Click Save As to save all the files together as one downloadable
file (bundle file). Save the file with a .pff file extension.
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4. Flash File Manager

Printer List Refresh File List

Warehouse - Files found: 5 | Get File Info 9167 4.sf, 57858 bytes, data loaded.
Manufacturing - FFS Info Not Loaded 00249.sf, 96922 hytes, data loaded.
Office - Getting File Data... 91059.sf, 56200 bytes, data loaded.
Lab - FFS Info Hot Loaded —— (91060.sf, 55938 ytes, data loaded.

91671.5, 58130 bytes, data loaded.
91889.5f, 70330 bytes, data loaded.

Delete 93008.5f, 57282 bytes, data loaded.
’W [EMC] 93099.5f, 56290 hytes, data not loade
; [EMC] 94072.5f, 55938 hytes, data not loade

Save As [EMC] 94079.5f, 58130 bytes, data not loade

(lf:

Last status for "Office’ - Upload Completed

Figure 66. Selecting Multiple Files

Or, you may use the Shift or Ctrl key to select single or multiple files.
See Figure 66. This way, only the selected files will save to the .pff file when
you click Save As.

NOTE: You can save only uploaded files to a downloadable file.

Delete And Optimize

IMPORTANT  You can not undo a flash file deletion.

You can erase files from the printer’s flash memory. Select the files you want
to delete from the File List, then click Delete. To download files back to the
flash memory, see “File Download” on page 86.

Once you have deleted files, the flash memory is not optimized until you click
Optimize. Optimizing reclaims flash space from deleted flash files.

NOTE: The printer reboots after you Optimize.

To delete and optimize in one step, select the files you want to delete from the
File List, then click Delete & Optimize.

CST Manager

See “Datastream Adapter” on page 147.
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NOTE: The terms download and upload as used here and in the software
indicate the printer’s point of view. Therefore, when you download a
file, you are sending information to the printer (the printer downloads).
When you upload a file, you are receiving information from the printer
(the printer uploads).

To utilize the File Download application, make sure Enable Status
Monitoring is checked in the Polling tab (see page 43). Then select your
printer in the printer database and click the update status button to
make sure your printer has been polled at least once (see page 49).

The File Download application allows you to download any of the following file
types (program files, configuration files, recovery files, and flash files) to either
a single printer or to a group of printers in one step. Recovery files are an
exception and should only be downloaded back to the printer that had
problems during a download.

To download a file to a single printer, insert a @ (Download file) icon below
the printer (one level lower than the printer). To download a file to a group of
printers, insert the Download file icon on the same level as the printers (in the
same folder containing the printers). Use the printer database and insert
additional Download file icons to download as many files to as many printers
as you want.

NOTE: Previous versions of the PMU required different file types to be
downloaded to the printer in separate steps, which is why the various
file types were identified by or @ icons. With this version of the
software, a distinction between the various file types is not needed,
and a @ icon identifies all file types. Therefore, if you open a printer
database that was saved using a previous version of the software, all
icons will change to (3] icons.



Define The Download Files

Define The Download Files

After you insert Download files, you must define them:

1. Double-click @ New Download File. The Define Download File dialog
box opens. See Figure 67.

2. Click Browse. The Open dialog box opens.

Define Download File |

Thiz can be a printer program file, configuration file, ar flash file.
It can be a softhware repository (S0 or directonyd.

Download files are selected according to their hierarchical relationship to
the printer receiving the download files.

Mewy Dovwnload File |Ernwse

Test OK Cancel

Figure 67. Define Download File

3. Navigate to a program (firmware), configuration, recovery file, or flash file,
select it, then click Open.

4. Since multiple file types can now be downloaded in one operation, a Test
button is provided to allow you to verify if the file type specified is
supported by the printer. Clicking the Test button causes the PMU to
evaluate the specified file and display the file type — this will help you
verify that you selected the correct file. Click OK if the file type returned is
correct, click Cancel to terminate, or click Browse to select another file.

5. When you are finished, click OK. The database displays the path and
name of the program, configuration, recovery, or flash file.
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Download The Files

After you define Download files in your database, you must download them to
your printer for them to affect the active print state.

NOTE: Each emulation used by the printer has its own list of valid flash files it
can use. Refer to the appropriate Programmer’s Reference Manual
for details about valid flash files.

To begin the download process, select a printer or a folder containing printers
and select Applications » File Download, or click the @ (file download)
icon. The File Download dialog box opens and displays a list of all the printers
that you selected in the printer database. See Figure 68.

NOTE: If you later select a different printer or folder in the printer database
and the File Download dialog box is still open, click Update List to
update the list of printers.

4. File Download

Printar | Fitrware [ Restore Config] Restare Flash| Canfig File| Flash Files]
Area 1 (10.224.2.86)
Area 2 (10.224.2.96)
Vending Room (10.224.2.95)
Conference Room (10.223.2.85)

EE=E
EOOC
LYY
=&
=D&

Start || UpdateList |

Figure 68. File Download

The following are the download options for each printer:
Firmware: Check this box to download the printer firmware (program file).

Restore Config: Check this box to restore the configurations that were in the
printer once the Program File download has been completed.

Restore Flash: Check this box to restore the flash files that were in the
printer before the Program File was downloaded.

Config File: Check this box to download a new configuration file.
Flash Files: Check this box to download additional flash files.

For each printer listed, various combinations of these operations can be
executed. Some combinations are mutually exclusive. For example, the PMU
does not allow you to simultaneously preserve the printer’s configurations and
download a new configuration file to the same printer (you cannot check both
Restore Config and Config File for the same printer). Similarly, you cannot
restore configurations or flash files unless you are downloading new program
files.

NOTE: You can double-click a field name (e.g., Firmware, Config File, etc.) to
check or uncheck the check boxes for all displayed printers at once.
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Viewing the File Destination

Select a printer in the File Download dialog box and click Properties. The
Update Properties dialog box opens. See Figure 69.

i Update Properties for Manufacturing

Summary

| »

l: ¢:ySingle Font.sf

Destination: Printer Flash

2:C:\1 Font.sf

LDrestination: Expanded Memory Cartridge

3. €:\3 Files.pff

Destination; Multiple Files to Printexr Flash

4. ¢:\Fonts.pff

Drestination: Multiple Files to Expanded Memory Cartridge

5 C:\Multiple Files.pff

Destination: Both Printer Flash and Expanded Memory Cartridge
Dovmload Configuration: No

Configuration Download

| "| | Settings
User Files
Destmaton e e o o

| OK | | Cancel |

Figure 69. Update Properties

The Update Properties dialog box lists all the files that will be downloaded to
the selected printer, the source of the files, and their destinations:

Printer Flash (a single file to the printer’s flash memory) or Multiple Files to
Printer Flash. Also, if the printer supports the EMC: Expanded Memory
Cartridge (a single file to the EMC), Multiple Files to Expanded Memory
Cartridge, or Both Printer Flash and Expanded Memory Cartridge.

The PMU can only download files to the EMC through the Ethernet
Interface.

Changing the File Destination

If you have the optional EMC and you wish to change the destination of a
single file, click Destination. The User Files dialog box opens. See Figure 70.

Select Printer Flash or EMC to specify the new destination.

NOTE: Bundle files (archives that contain multiple files, usually with a .pff
extension) cannot have their destinations changed. Files within
bundle files will download to the printer’s flash memory, the EMC, or
both, depending on their original location.
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User Files Eq |

Destinations

Bundled files, multiple files concatenated

together, will appear grayed out and cannot

have their destinations changed.

Hame: Printer Flash: EMC:

C:iSingle Font.sf ] i)

C:\1 Font.sf i -
oK Cancel

Figure 70. User Files

Restoring Configurations and Flash Files

Whenever a printer downloads a program (firmware) file, the configurations
and flash memory are erased. You can choose whether or not to restore the
configurations and/or flash memory to what was previously loaded. Check or
uncheck the Restore Config check box for configurations and/or the Restore
Flash check box for flash files. By default, the configurations and flash
memory will restore.

If you uncheck Restore Config or Restore Flash, the configurations or
flash memory will erase when you initiate a program file download.

NOTE: If a download fails due to a power interrupt or a severed connection, the
configurations and flash files will be lost and will not restore. You can
still restore the printer using the recovery file, but only if Restore Config
and/or Restore Flash was checked. See “Recovery File” on page 99.

If you are downloading a program file and flash files, the Flash Files and
Restore Flash check boxes will be checked. The flash files will restore, but
they will be overwritten if the new flash files you are downloading have the
same name.
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4. File Download

Area 1{10.224.2 86): - Session message =» Connecting. - Please wait...

frea 2 (10.224.2.96): Presenving: saving flash file => 90249.sf

Vending Room {10.224.2.95): Preserving: saving flash file => 9167 1.sf

Conference Room {10.224.2.37): Uploading: configurations => Bytes uploaded = 63797

Figure 71. Download in Progress

Confirm that the correct files will be sent to the appropriate printers. Close the
dialog box to cancel the download and start over.

Click Start to begin the download. Once the download is in progress, click
Abort or close the dialog box to abort the download. See Figure 71.

Aborting a download may leave the printer in an unstable state.

During the download, the printer’s flash memory will be erased, and
CLEARING FLASH will display on the operator panel. At this time, the PMU
may appear to stop operating. This is normal, and the entire download
process should take no more than fifteen minutes.

NOTE: Be sure to calibrate your thermal printer after you download a
configuration to it. See “Running Auto Calibrate” in the printer’s
User’'s Manual.

You can also download a series of files to several printers at once using
folders. Select a folder and select Applications » File Download. All of the
appropriate files inside the selected folder download to all of the printers
inside that folder.

NOTE: Downloading a configuration file does not immediately update the
printer’s active configuration. You must activate a downloaded
configuration using the Load Config. setting in the operator panel.
Refer to the printer's User’s Manual for details.

See page 92 for examples of using the printer database and the File
Download application to download files.
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Downloading Examples
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Figure 72. Sample Database

In this sample printer database (Figure 72), the printers are organized
according to different parts of the building. Each area contains its own printers
and Download files.

In the Manufacturing folder, two printers share the same program and
configuration Download files, the Area 1 printer has a flash Download file (in
this example, a fonts file), and the Area 2 printer has no flash Download file.

In the Administration Office folder, two printers share a program Download
file, the Vending Room printer has a configuration and a flash Download file,
and the Conference Room printer has no configuration or flash Download file.

The Building B and Building C folders are collapsed.



Download The Files

IMPORTANT

£ . File Download

Printar | Fitrware [ Restore config|Restare Flash| Canfig File| Flash Files]
Conference Roam (10.223.2.85) v [v] [v] [ [
Stat | | UpdateList |

Figure 73. File Download: Conference Room Printer

Example 1

In this example, the user selected the Conference Room printer, then
selected Applications » File Download or clicked the £ (file download)
button. The File Download dialog box opens. See Figure 73.

The Conference Room printer will download a program (firmware) file, and the
configurations and flash memory will restore

If you uncheck Restore Config or Restore Flash, the configurations or
flash memory will erase when you initiate a program file download.
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£ . File Download

Printar | Fitrware [Restore ¢ |Restore FI| Config File | Flash Files |
vending Room (10.224.2 95) v 1 [v] [v] =]
Stat | | UpdateList |

Figure 74. File Download: Vending Room Printer

Example 2

In this example, the user selected the Vending Room printer, then selected
Applications » File Download or clicked the &g (file download) button. The
File Download dialog box opens. See Figure 74.

The Vending Room printer will download a program (firmware), configuration,
and flash file, and the flash memory will be restored.

To see a summary of the files the printer will download, double-click the
printer or select the printer and click Properties.
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4. \Ipdate Properties for Yending Room

Summary

Dovmnload Program File: Yes
File: ¢:\Printer Software B.pryg
Restore User Files: Yes
Restore Configuration: No
Download User Files: Yes
l: ¢:\Fonts.pff
Dovwnlead Configuration: Yes
File: € :\Wending Configs.cfyg

Configuration Download

C:Nending Configs.cfg v|| Settings |

| ol || Cancel |

Figure 75. Update Properties for the Vending Room Printer
The Update Properties dialog box opens. See Figure 75.

In this example, the Vending Room printer will download the Printer
Software B.prg program file, the Vending Configs.cfg configuration file, and
the Fonts.pff flash file.
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Configuration Download Settings E3 |

Configurations

Hame: Download: Power-Lp:
Factory Default ¥ ]

1 v

2 v (g

3 v )

4 v il

5 v o

6 v )

7 v [

8 v o

OK Cancel

Figure 76. Configuration Download Settings

Since the printer will download a configuration file, you can click Settings to
open the Configuration Download Settings dialog box. See Figure 76.

You can select or deselect specific configurations within the configuration file
you want to download. Only the selected configurations will download. You
can also select which of the configurations will be set as the Power-Up
configuration.

In this example, the printer will download all configurations, and the Power-Up
configuration will be set to configuration 4.
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£ . File Download

Printar | Fitrware [ Restore Config] Restare Flash| Canfig File| Flash Files]
Area 1 (10.224.2.86) [l [l vl [v] ]
Area 2 (10.224.2.96) v [ v v ]
Stat | | UpdateList |

Figure 77. File Download: Manufacturing

Example 3

In this example, the user selected the Manufacturing folder, then selected
Applications » File Download or clicked the &5 (file download) button. The
File Download dialog box opens. See Figure 77.

In this example, the Area 1 and Area 2 printers will download the same
program (firmware) file and a configuration file, since both files are in the
same folder as the two printers (see Figure 72). In addition, the Area 1 printer
will download a flash file.

Both printers will have their flash memories restored.
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4. File Download

Printar | Fitrware [ Restore Config] Restare Flash| Canfig File| Flash Files]
Area 1 (10.224.2.86) v _] [v] v v
Area 2 (10.224.2.96) v ] v =] ]
wending Room (10.224.2.95) v [ vl ] v
Conference Roam (10.223.2.85) v [v] [v] [ [

Start || UpdateList |

Figure 78. File Download: Building A

Example 4

In this example, the user selected the Building A folder, then selected
Applications » File Download or clicked the Fg (file download) button. The
File Download dialog box opens. See Figure 78.

In this example (refer to Figure 72):

» The Area 1 and Area 2 printers will download the same program
(firmware) and configuration files, and their flash memories will be
restored.

e The Area 1 printer will download a flash file.

* The Vending Room and Conference Room printers will download the
same program file.

* The Vending Room printer will download a configuration and a flash file,
and its flash memory will be restored.

» The Conference Room printer will not download a flash or configuration
file, but its configurations and flash memory will be restored.

IMPORTANT  Make sure the same printer is not listed more than once in the File
Download dialog box.
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IMPORTANT

Recovery File

Whenever a printer downloads a program (firmware) file, the configurations
and flash memory are erased. You can choose to restore the configurations
and/or flash memory, but if during the download the power interrupts or the
connection severs, the files will be lost and will not restore.

The PMU makes a recovery file of the configurations and flash memory
before they are erased. The recovery file is located in the PMU installation
directory.

If a download fails, the Status and Error Log will display the location of the
recovery file. The file is named after the printer name in the printer database,
followed by a .par extension (printer archive).

Add a download file under the printer that failed during the download process.
Open the Define Download File dialog. Click the browse button and navigate
to the location of the recovery file. The recovery file is displayed in the Status
and Error Log. Click OK to define the download file.

It is necessary that a program file be used with your recovery file. Make
sure that you add a program file under the printer in the database or
enable it if it is disabled.

Click the printer to download and open the File Download application. Click
Start to download the recovered files and settings to the printer.

NOTE: The properties and the download settings cannot be changed when
you are using a recovery file. Recovery files are not deleted by the
File Download application once an error occurs. This file should be
deleted once the printer has the recovered configuration settings and
flash files.

The .par archive contains the configuration file, which is named after the
name of the printer in the printer database. The archive also contains the flash
files, which are named exactly as they appeared in the flash memory.
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The Media Profiler application is only available for thermal printers. It provides
a means to analyze media sensing problems. You can use it on labels that
are difficult to profile using the standard printer profiling method. If necessary,
you can capture, document, and send this information to professional service
centers for further analysis.

Menu and
Toolbar Profiler View

4. Media Profiler [_[Ol=]

File View Capture

@ @ f| |100% -

= Disable (0) Resolution: 300 DPI =
Paper Out (0) |
2550" 1 1 1 1 | 1 1 1 1 |1“ 1 1 1 1 1 1 1 1
|
1971 I
127 I
|
63 |
|
. |
|
Staws:  ,  NoteeNA | ModetNA | Versiom:NA | PMN:NA s
Status Bar

Figure 79. Media Profiler Window

To access the Media Profiler application, select Applications » Media
Profiler or click the -~ (media profiler) button. The Media Profiler will open
with no profiler data loaded or captured. It is divided into four sections, the
menu bar, toolbar, profiler view (which contains the profiler graphic), and
status bar. See Figure 79.



The Menu And Toolbar

The Menu And Toolbar

File View Capture

= || & Dimm -

"’M \

Save Stop Capture Zoom Selection Box
Start Capture Add/Edit Notes
Open
Figure 80. Media Profiler Menu and Toolbar
File

Open: Opens a dialog wherein the user can select a previously saved file that
contains profiler data. Media profiler files use the .mpd extension (Media
Profiler Data).

Save/Save As: Saves captured data to disk for later reference or for use in
another program. The file will save with the .mpd extension by default.

Notes: To add notes to captured data. Since the first line of the notes will
display in the status bar (see “The Status Bar” on page 107), use short and
distinct information that will be included in screen captures.

Exit: Exits the Media Profiler application. You will be warned if any data
needs to be saved.

View
Show Crosshair: When this menu item is checked (the default), a crosshair

will display when the mouse pointer is hovering above the profiler graphic
(see Figure 82 on page 103).

Clear: This will clear the profile view. The user will be informed if the captured
data has not been saved.
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Capture

Start Media Profiling |

Profile Source | Hew_Printer b

[_] Print Profile

Run For |0 seconds

1..3600%, O=manual stop

OK Cancel

Figure 81. The Start Media Profiling Dialog Box
Start: Opens the Start Media Profile dialog box. See Figure 81.

From the Profile Source drop-down menu, you can choose an available
printer from the printer database. This is the source for the media profile test.

If you check the Print Profile checkbox, the profiler data will also print on the
installed media. The Run For value determines how long the profiler test will
run. If you select 0 seconds (the default), the test will run until you stop the
capture (click the stop capture button, press F6, or select Capture » Stop).

NOTE: You can always stop a capture before a specified time elapses.

After you click OK, the Media Profiler will attempt to establish a connection
with the selected printer. If a connection is established, it will check if the
printer supports capturing the media profiler data. If it does, the profiler test
will start. The profiler test will run until the specified time has elapsed or until
you stop the capture.

Stop: This action is enabled while a profiler test is running. If selected, it will
stop the currently running profiler test.
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Profiler View

Legend Ruler Profiler Graphic
Profiler View

__A/_

4. Media Profiler

File View Capture

== [>]o] @
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Figure 82. Profiler View

The center part of the Media Profiler window is the profiler view. The profiler
view is divided into three sections: the legend, ruler, and profile graphic.
See Figure 82.

Legend

The legend displays the current values for two thresholds: Sensor Type and
Paper Out. These values are set to zero by default since no threshold values
have been received. These values are updated when the capture starts.

Sensor Type can be one of the following: Disabled, Mark, Gap, Advanced
Gap, or Advanced Notch. By default it is set to Disabled. When dynamic
sensing is enabled on the printer, the value of Sensor Type is Dynamic.

The Ruler

The ruler displays the length of the captured profile in inches. The ruler has
small ticks every tenth of an inch, and a larger tick ever half inch. A resolution
of 300 DPI is used by default to determine the length. When the profile
capture starts the actual DPI will be retrieved from the printer and the ruler will
update to reflect the correct DPI.
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Profile Graphic

& Media Profiler - [ProfileCapturel ]~

File View Capture
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Figure 83. Profiler Graphic

The profile graphic has four horizontal divider lines to indicate the quarter
values of the sample data. When the capture starts, the samples of the
profiler data will display on the graph.

The printer will send out the profiler sample data on regular intervals and the
profiler view will be updated automatically. If the profiler graph is too wide to
be shown in one window, a scroll bar will appear to be able to scroll the graph.

The printer sends out one sample for each dot, so 300 samples per inch will

be received for a 300 DPI printer. During the capture, the view will auto scroll
to show the last captured profiler data until the specified time has elapsed or
you stop the capture. See Figure 83.

When the profiler test starts, the printer will send out the current threshold
values. The thresholds are indicated by colored horizontal lines on the profiler
graphic: blue for the Sensor Type threshold and green for the Paper Out
threshold. If dynamic sensing is enabled on the printer, the Sensor Type
threshold will be shown dynamically similar to the sample data.
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& Media Profiler - [ProfileCapturel ]~
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Figure 84. The Crosshair

The crosshair appears when the Show Crosshair menu item is checked (the
default). When the pointer hovers above the profiler graphic, a crosshair is
shown to indicate the sample value at that location and the distance to the
origin. See Figure 84.

Press the Ctrl key to change the crosshair into a horizontal line that follows
the mouse vertical position. You can use this to determine the optimal sensor
values.

NOTE: Set the zoom factor to display the entire graph for this feature. See
“Zoom” on page 106.
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Figure 85. Zooming

You can use the zoom selection box to set the zoom factor. See Figure 85.
You can enter a zoom factor or select a predefined zoom factor. The valid
range is 5% to 400%.

If you have a mouse with a scroll wheel, the wheel can be used to zoom in

and out. The zoom factor in the zoom selection box will update to reflect the
current zoom factor.

You can zoom to display the entire graph in on window and determine the
maximum and minimum sample values using the crosshair.
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Adjust the Origin

& Media Profiler - [ProfileCapture3]*

File View Capture

== > 16% A

— Gap (202) Resolution: 300 DPI =
Paper Out (250)
255|||||_?“|||||||||_?"||||||||L\%lnl||||||||2;I|||||||||4|“||| |||||6|“||| I

I | ) | )

191[] [l 1 | il I

127

63

-

Status: profiling stopped. Mote: N/ Maodel: SL5304r MP | Version: WV1.18E | P/N: 368364

Figure 86. Adjusting the Origin

By default the origin of the graph is located at the first sample of the captured
data (leftmost position). You can adjust the origin by clicking on the ruler and
dragging the origin to the desired location. See Figure 86.

You can use this to determine the length/slippage of scanned labels in
conjunction with the crosshair.

The Status Bar

The status bar is at the bottom of the Media Profiler window (see Figure 79 on
page 100) and is divided into five sections. The first section displays status
messages. The second section displays the first line of the notes, if notes
were added (see Notes on page 101). The last three sections display the
model, version, and part number from the printer being profiled. By default
these are set to N/A.

For More Information

Refer to “Running Media Profile” in the User’s Manual.
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Operator Panel

The PMU includes a virtual operator panel that simulates all the functions of
the physical operator panel on your printer. See Table 5 below which lists the
different virtual operator panels.

Table 5. Virtual Operator Panels

Figure Page Printer

Figure 87 | page 109 | 6500 Series line matrix

Figure 88 | page 109 | 6400 Series line matrix

Figure 89 | page 110 | 6700/4400 Series thermal

Figure 90 | page 110 | 6700-M40 Series thermal

The layout of the operator panel changes to visually simulate the printer being
used (line matrix or thermal), but the keys and indicators function as
described on page 111, regardless of the type of printer used.

The virtual operator panel uploads special font tables from the printer and
uses them to match the printer’s actual front panel display. If viewing Asian
language symbols, the virtual operator panel determines and displays the
proper number of lines.

To access the operator panel, select the appropriate printer from the printer
database and then select Applications » Operator Panel or click the

[ (operator panel) button.
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Secondary Operator Panel Window )
Status Indicator
Operator Keys Message Display
4. Opeiator Panel [Hew_Printer] |
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Figure 87. 6500 Series Line Matrix Printer Virtual Operator Panel
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Figure 88. 6400 Series Line Matrix Printer Virtual Operator Panel
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i Operator Panel [Thermal P... = E3
Message Display -
ao

DHLINE
ETHERHET fPGL fLP+

FRENE

Operator Keys

Disabled/In Progress
Indicators

Figure 89. 6700/4400 Series Thermal Printer Virtual Operator Panel
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Figure 90.6700-M40 Series Thermal Printer Virtual Operator Panel
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Primary/Secondary Operator Keys

Clicking the primary and secondary operator keys in the operator panel
causes the printer to perform the same actions as if you were pressing the
keys on the printer’'s operator panel. For example, when the printer is online,
click the STOP key (6500/6400 Series) or the Il (PAUSE) key
(6700/4400/6700-M40 Series) to take the printer offline. Click the START (or
PAUSE) key to place the printer back online.

Some functions require pressing multiple keys at the same time. To simulate
this, hold down the Shift key on your host keyboard as you select each key.
The selected keys change color to indicate that they are part of the multiple
key press. Release the Shift key, and the selected keys on the operator panel
activate as if they were pressed simultaneously.

For example, to unlock the ENTER () key, hold down the Shift key on your
keyboard, then click RETURN and ENTER (6500 Series), T and | (6400
Series), | and ! (6700/4400 Series), or the Down and  keys (6700-M40
Series). Release the Shift key, and the ENTER () key unlocks.

NOTE: For an explanation of the functions of each primary and secondary
operator key, refer to the printer's User’'s Manual.

Message Display

The message display shows what is displayed on the physical operator panel.
Use the message display to configure menu options and read error
messages.

Status Indicator

The status indicator displays the current operating mode:
Online mode: The indicator displays bright green.
Offline mode: The indicator displays black.

Fault mode: The indicator flashes.

Disabled Indicator

Normally, when you control the printer via the operator panel, the Disabled
light is off, and the Enable button underneath the status indicator is grayed
out. While the PMU has control of the physical operator panel, the message
PRINTER UNDER REMOTE CONTROL appears on the physical operator
panel to alert others that the printer is being controlled remotely.

However, if someone presses a key on the printer, the virtual operator panel
disables. The Disabled indicator lights up, and the Enable button activates.
Click the Enable button to give control of the printer back to the virtual
operator panel.

In Progress Indicator

This light flashes when the printer is working on a job or moving paper.
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Information Capture

£ |nformation Capture [Mew_Printer]
File Configuration Printout Error Log Directory Dialoginput |v |12 |v|

Figure 91. Information Capture Window

To access the Information Capture application, select a printer from the
printer database and select Applications » Information Capture or click the
(information capture) button. See Figure 91.

The Information Capture application allows you to view the configurations or
error logs saved in the printer's memory and save them as a text file to your
local hard drive.

Loading a configuration into the Information Capture does NOT change the
active configuration — this is a view only application. If you want to change
the active configuration, use the Configuration Editor (see page 67) or the
operator panel.
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The following are descriptions of the Information Capture menus.

File

Save As: Saves the configuration or error log displayed in the Information
Capture window as a .txt text file on your local hard drive. This .txt file can be
opened in any word processing program.

Print: Prints the text of the information captured to the host computer’s
default printer.

Clear Window: Clears the Information Capture window of any displayed
configurations or error logs.

Close: Closes the Information Capture window.

Configuration Printout

Current/Factory/Power-Up/All/1-8: Choose which configuration you want to
view. If you choose more than one configuration without clearing the window,
each additional configuration adds to the end of the display. See Figure 92.

4. Information Capture [New_Printer]

File Configuration Printout Error Log Directory |Dialuglnput |'|12 |V|
CURFENT CONFIGURATION

ML

001 File Part Number (3ee Reference Mumber)
00Z Reference Number 3569456

003 DCJ/FRC V1. 22K  Z1-Tul-05 #3694a85

004 EOOT/FRC We.0lh 31-Aug-07 #368563

005 BASE EMULS CT/PGL/VGL/ZGL/TGL/IGL A STGL S
DGLALP+

00& EBUILD CONTENT IPDE/PIL Ver 1A/EASE EMULS

007  FEATUREZ ENAELED 365093 (AICII)

aog 365lZl (AGPIO)

008 FLASH g MB

010  DRAM iz MB

011 HEAD REZOLUTION 300 DPI

0lz PTE ON TIME 1677.1 HOURS

013 PTE MEDIA DIST 3260677 INCHES

014 HEAD PRINT DIST 3lo4d5%6 INCHES

015 HEAD ON TIME 340. 5 HOURS

0ls ETHERNET VERSION  WER=1.4.53
017 QUICKE SETUP

o1& Frint Intensity -15

ols Print Zpeed 6 ip=s

oz0 Print Mode Direct

ozl HMedia Handling Tear-0ff 3trip |

Figure 92. Configuration Printout

Error Log

All Errors: Displays the printer’s error log.
Clear: Clears all errors from the printer's memory.

NOTE: The printer’s error log and the Status and Error Log at the bottom of
the main printer database window of the PMU are separate. Clearing
the printer’s error log does not clear the Status and Error Log.
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Directory

Flash File System: Displays the file system information for your printer.

NOTE: If your printer is equipped with an EMC (6700-M40 printers only), the
files will be displayed in two areas: one for the printer’s internal flash
memory, and one for the EMC. See Figure 93.

4. Information Capture [New_Printer]

File Configuration Printout Error Log Directory

FILE JIYSTEM STATISTICS

View Main Files

93779.st 177228 Bytes
93952.sf 210124 EBytes
91409.sf 47218 Bytes
90993 . st 47256 Bytes
9z250.st 59792 Bytes
gzz44.sf 3134 Bytes
92243.sf 39790 Bytes
9z500.sf 190512 Bytes
plugin. cdm 122066 Bytes
hog3updt. cdm 53480 Bytes
pluginfp. cdm 206161 Evtes
e RIE J68 Bytes
Printer’s ho? . fnt 431 Evytes
Internal _| uif.ss 21647 Bytes
Méﬂiﬁ? plugin. ttf 26928 Bytes
utt.s=s 15181 Bytes
ptnxd.dwvl 174 Evtes
ptnxb.dvl 174 Evtes
ptnxd . dwvl 174 EBvytes
SMTIFILES.ALL 40824 Bytes
EPCZ03 . TIF 1580 Bytes
EFC300. TIF 3Z26 Bytes
wersion 47 Byktes
netermb . dat 151 Bytes
ptxLogo. gif 0230 Byktes
Total Bytes In Use By Active Files 1605063
Total Bytes In Use By Deleted Files O
Total Bytes Awvailable 2302516
View EMZ Files
91059, st 36290 Bytes
910e0. st 35038 Bytes
EMC — 91e71.st 58130 Bytes

Total Bytes In Use By Active Files 170358
Total Bytezs In Use By Deleted Files O
Total Bytes Available 16484010

Figure 93. Directory: Printer’s Internal Flash Memory and EMC
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ODV Quality Wizard

IMPORTANT

IMPORTANT

4. 0DV Quality Wizard [Area 1]

Print Intensity -3 -2 %

Print Speed 6 ips u%

Test Print

Settings Recommendation:
Earcode Code 39 Status:

OK Cancel
Figure 94. ODV Quality Wizard Window

NOTE: You must set the following in the VALIDATOR menu to use the ODV
(Online Data Validator) Quality Wizard:

e Set Telemetry Path to Network Port.
e Set Telemetry Data to Full Report or Validation Mode.

The ODV Quality Wizard is a function that helps you select the best
combination of print speed and print intensity that will produce optimal bar
code output. It displays controls that allow you to select a print speed and a
print intensity.

Click the Test Print button to print and validate a test bar code pattern. Based

on the validation results, the ODV Quality Wizard provides setting
suggestions to optimize the bar code quality.

Do not follow any suggestions if “Barcode Code 39 Status” does not
display “Pass.”

Click OK to save these changes in Configuration 1. Configuration 1 then
becomes the Power-Up configuration (see page 67). Click Cancel to not save
the changes.

Clicking the X| Close button in the upper-right corner functions the
same as clicking OK.

NOTE: The ODV Quality Wizard is printer specific, and not all printer models
have ODV Quality Wizard support. Printers without ODV Quality
Wizard support display the error message:
Operation not allowed on this type of printer.
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Speed Keys
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i Speed Keys [Area 1]

Printout Quality Settings r Validator Settings
}i’ Physical Unit Setup r Media Sensor Calibration |

i® Use Inches
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Figure 95. The Speed Keys Window

The Speed Keys are single buttons that allow you to perform a specific
operation without having to traverse the operator panel menu structure. The
Speed Keys assist you in performing repetitive functions associated with
printer configuration or maintenance.

To access Speed Keys, select a printer then select Applications »
Speed Keys or click the [E=T] Speed Keys button. See Figure 95.

Changes made using Speed Keys are changed in the printer and saved in
Configuration 1. Configuration 1 then becomes the Power-Up configuration
(see page 67).

NOTE: Speed Keys are printer specific, and not all printer models have
Speed Key support. Printers without Speed Key support display the
error message:

Operation not allowed on this type of printer.

The Speed Keys are grouped according to their use:
« Physical Unit Setup

* Media Sensor Calibration

*  Printout Quality Settings

» Validator Settings

NOTE: For an explanation of the functions the Speed Keys perform, refer to
the printer's User’s Manual.



Directory

Job Capture

4. Job Capture [New_Printer]

File Search View Capture Triggers Options

EEIE

[Length: 0 [Rnw: 1 [Culumn: 1 [l]: <EOF> Ilnsert
[Port: ParallelE-Net Adapter In [capture: off [Recefved: 0 [saved: 0

Figure 96. Job Capture Window

Job Capture is an application that captures host datastreams through a
specified host interface. This aids in debugging and diagnosing printer errors
when working with technical specialists.

To access the Job Capture application, select a printer from the printer
database and select Applications » Job Capture or click the

fﬁ (job capture) button.

Job Capture allows you to capture, modify, analyze, and save information to a
file.

To use Job Capture:

1. Be sure the computer running the PMU is connected to the printer using
the diagnostic port. See “Printer Setup” on page 10.

2. Select Capture » Data From and then select the interface the printer will
use to receive the file you want to capture.

3. Select Capture » Start to place the PMU in capture mode. The interface
sends the information to the terminal window until you turn off capture
mode.

4. Select Capture » Stop to stop the capture.

The capture window displays the capture information in three formats: Text,
Hex, and Capstone. Select View » Display Format to choose the information
format. Select View » Display Control Codes to view the control codes
embedded in the file.

Once you capture the file and choose the display options, you can save the
information to your local hard drive. Select File » Save As and enter a file
name. The PMU saves the captured information as a .cap text file. You can
open a .cap file in any word processing program.
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Select File » Clear Window to clear all capture information from the terminal
window. Select File » Quit to close the Job Capture application.

Job Capture Features

File

Open
Opens a Job Capture file.

Save/Save As

You can save captured data to disk for later reference or for use in another
program. To save the captured data, select File » Save or File » Save As.
Data from Twinax sources can be saved in either Hex or Capstone format.

Clear Window

To erase captured data, select File » Clear Window. If you have not already
saved the data, a prompt appears and asks if the data should be erased
without saving.

Quit

Exits the Job Capture program.

Search
Search |
Data to Find
pri nt er -
072 B9 BE 74 BS T2
Options Direction
[_] lgnore Case @ Forward
" Backward
Scope Origin
® Global @ From Cursor
{_! Entire Scope
OK Cancel

Figure 97. Search Captured Data



Job Capture Features

Search Captured Data

You can search captured data for specific sequences. Select Search »
Search Captured Data. Enter the data as a hex or text string. Click OK, and
the matching data highlights.

To further refine your search, you can choose whether or not to ignore the
case, and specify the direction and origin of the search. If you have text
selected, you can also choose whether to search the selected text or all text
(Global). Use the down arrow in the upper-right corner to see a history of your
searches. See Figure 97.

Search Again

To continue searching, click Search Again. A message appears if the search
is unsuccessful.

View

Display Format

Data displays in three ways:
o Text

* Hex

« Capstone

Capstone is for Coax/Twinax applications. You can edit Capstone data in Hex
mode only.

Display Command Codes

* Normal: Codes do not display.
» Dots: Dots represent the code.

* Mnemonics: Codes display within brackets. For example, Line Feed is
<LF>, Carriage Return is <CR>, etc.

Capture

Start

Starts the capture. You can also use the ’. (start capture) button.

Stop

Stops the capture. You can also use the H (stop capture) button.

Data From

Selects the capture source of data. Options include:
» Parallel/E-Net Adapter In

e Serial In

» Serial Out
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e Twinax Host Data

e Coax Host Data

+ C/T Base Emulation
e PCI Ethernet In

e USBIn

NOTE: The USB port is available only on 6700 and 6700-M40 Series thermal
printers.

Triggers

Start Trigger

Trigger count: |1 % Bytes saved hefore start trigger: |0 % [] Ignore Case

Stop Trigger

Trigger count: |1 % Bytes saved after stop trigger: |0 % [_] lgnore Case

[C] Limit saved data to: : vtes

[ ok || cancel |

Figure 98. Configure Triggers Window

A Trigger allows a selective capture of host data. You need to specify two
triggers, a start trigger and an end trigger. Select Triggers » Configure.
See Figure 98.

Enter triggers as text or hex strings with a maximum length of 256 characters.
Job Capture scans received data for the start trigger sequence. Once found,
data capture begins and continues until Job Capture finds the end trigger.

If you do not set a start trigger, all data is captured when the Job Capture
starts. If you do not set an end trigger, the data will continue to capture until
you stop it.

A second trigger option is a trigger count. You can set Job Capture to start or
stop once it finds a set number of start and/or stop triggers. The window that
displays captured data shows any lines containing start triggers and highlights
the start trigger strings. You can also use the Search feature to search
through captured data.

The Ignore Case check box allows character case to be ignored. Check the
box to search for a string regardless of character case, and the data will
capture once the string is found.

NOTE: You cannot apply triggers to Coax/Twinax and TCP/IPDS jobs.

Options
Disable Printing

Select Options » Disable Printing to capture data without printing.




The PMU Web Site URL Address

Web Access

You can access your printers using a web browser. You can monitor the
status, open an operator panel, check the configurations, and access the
printer web page.

NOTE: To access your printer using a web browser, you must enable the
Web Server and XML Server services (see page 28). Remember to
exit and restart the PMU to enable the service.

The PMU Web Site URL Address

Open a web browser. In the URL address field, type http://, followed by
the host IP address of the workstation running the PMU or the host name
(computer name, not case-sensitive), followed by a colon (:), and then the
Web Server port number (see page 28).

For example:
http://10.224.5.121:8080
or:

http://1ab21042:8080

NOTE: Make sure the port number does not conflict with another port number
designated for a different purpose.

Press Enter, and the web page for your designated printer appears. See
Figure 100 on page 122.

To find the host name using Windows, right-click My Computer on the
desktop and select Properties. Click the Computer Name (or Network
Identification) tab, then click Change (or Properties). The computer name
appears in the Computer name field. See Figure 99.

Computer Hame Changes 2 | x|

'ou can change the name and the membership of this
computer, Changes may affect access to nebwork rezources.

LCorputer name;
ABZ1042

Full computer name:
LAB 21042 miz. yourcompany. com

Mo, |

~ Member of
& Domain;

Imis.ynurcnmpany. com

" Workgroup:

ak I Cahcel

Figure 99. Finding Your Host Name In Windows
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Login To The PMU Web Site

User: |

Password: N
Figure 100. The PMU Web Site

By default, three categories of login privileges are available. See Table 6 for a
list of categories and their corresponding user names and passwords.

Table 6. User Login Options

Login Category User name Password
Standard standard standard
Supervisor super super
Administrator admin admin

Type admin for the user name and password, then click Login. The Select
Desired Page web page appears. See Figure 101.

admin is Logged in - Please Select Desived Page

Frinter List Page

Change Fassword Fage

Figure 101. The Select Desired Page Web Page

Changing The User Password

Change Password

New Password: —
T —

Change Password

Figure 102. The Change Password Web Page

You can change the default password. Click Change Password Page, and
the Change Password web page appears. See Figure 102.

Enter a new password in the New Password and Retype Password fields,
then Click Change Password. Your password changes and you return to the
Select Desired Page web page.
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The Printer List Page

The Printer List Page

This page will refresh once a minute. Time: 14:33

Sort Printers by | Status (Errors) | Sort |
. , Operator Printer Weh
Printer ID| Address |Status MMessage Configuration Panel Page
Thermal (Building &) PEINT HEAD

Thermal(10.224.1. 14 1[ERROE, Current Cpen Cpen

TP = Cloze Print Head

Line Line Matriz (Building B) ONLINE >
Matrix| 024 1130 O powER s4VER MODE

Current Dpen COpen

Figure 103. The Printer List Web Page

Click Printer List Page. The Printer List web page appears and lists the same
printers found in the database pane. See Figure 103.

By default, printers are sorted by Status (Errors). You can also sort printers by
Status (Warnings), Status (Online), Address (Ascending), and
Address (Descending).

In the above example, the thermal printer displays an error because it is
offline. Any printer not ready to print displays an error status.

For an explanation of the Printer List Page options, find the option in Table 7
and follow the corresponding reference.

Table 7. Printer List Page Options

Web Page Option Reference
Configuration displays the printer’s current configuration
Operator Panel see page 108
Printer Web Page opens the Ethernet Interface Home Page; refer to
chapter three of the Ethernet Interface User’s
Manual

NOTE: Administrators and Supervisors can access all five options. Standard
users can access only Configuration and Printer Web Page.
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Changing User Settings, IP Addresses,
and IP Address Ranges

=7uml wversion="1.0" encoding="UTF-8" 7>

<IDOCTYPE ppmsML Wew Sowrce for full doctvpe, . )=
- “ppmasML=

- =zlLoginDatabasex=

«l-- For some user to access the printer information, they nesed to he
added by userid. -
«l-- The IF address of their machine also needs to be authorized. ==

- =lserDatabases

<l-- Rkl1l the user names, their privilege type (sStandard, sSuper, admin)
needs to he added here -=

<userid password="standard" privilege="standard">standard«/userid>

<userid password="super" privilege="super'>super</,userid=>

<userid password="admin" privilege="admin">admin</userid=

</UserDatabases
- «MachineDatabasex=
«<l-- Individual address can be included or excluded from accessing the
printer information. ==
<l-- diphddrezzIncluded and iplddressExcluded are used for individual
addresses. -

<ipaddressincluded=10.22.1.121</ipAddressIincluded:

<ipasddressExcluded=100.100.100.100</ipAddressExcluded:=

«l-- Mze iplhddressIncludeRange and its start and end actrikbutea to

define the access range. -—=

<ipaddressIncludeRange start="00.00.00.00" end="255.255.255.255" />

«l-- Uze iphddressExcludseRange and its start and end attributes to

define the invalid access range. -

<ipAddressExcludeRange start="00.00.00.00" end="00.00.00.1" />
</MachineDatabazex

</LoginDatabasex=

</ pprshls

Figure 104. The PpmLogin.xml File

The PpmLogin.xml file, located in the PMU installation directory, contains
user settings and the included/excluded IP addresses and IP address ranges.
See Figure 104.

To modify this file, open it using a text editor.

IMPORTANT  The PpmLogin.xml file should only be modified by expert users.
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Incorrect entries in this file could render the Web Server service
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Changing User Settings, IP Addresses, and IP Address Ranges

User Settings
Password Privilege category User name
- <lUserDatabasex>
<l-- k1l the user nsgnes, their privilege type (stgndard, super, admin)
needs to be added hege -==

zuserid password="standard" privilege="standard"=standard</userid=

<userid password="super" privilege="super'=super</; userid=

zuserd password="admin" priviege="admin">admin</userid=
=/UserDatabasex

Figure 105. User Login Parameters

The user name, password, and privilege category are defined in the
<UserDatabase> section of the file. See Figure 105.

Password: Defines the password for the designated user name. When you
change the password using the Change Password web page, this information
updates.

Privilege Category: Defines the privilege for the designated user name. The
available options are: standard, super, and admin.

User name: Defines the user name. You can only change the user name by
modifying this attribute.

You can add additional users by duplicating the following line in the
<UserDatabase> section:

<userid password="standard" privilege="standard">
standard</userid>
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IP Addresses and IP Address Ranges

Included IP Address Included IP Address Range

<l-- Individual addres} can he included oy excluded from accessing the
printer information. e

<l-- iphddressIncluded|and ipiddreszsExcluded are used for individusal
addresses. S \

<ipAddressincluded=10.22.1.121</ipAddressinclufeds
<ipAddressExcluded=100.100.100.100=/ipAddresgE=cluded:

=l

Use ipAddressI#:ludeRange and its stgrt and end attrilbutes to
define the access ra

noe . S

<ipAddressIncludeRange| start="00.00.00.00" end="255.255.255.255" />

2l

Uze iphddressExcludeRange and its start and end attributes to

define the invalid slzcess range. s
<ipAddressExcludeRange start="00.00.00.00" end="00.00.00.1" /=
=/MachineDatabase= ' | |

Excluded IP Address Excluded IP Address Range

Figure 106. Include/Exclude IP Address Options

You can define which IP addresses are available to the PMU for access. Any
IP address not included or defined in the included range will be unavailable to
the PMU. In addition, any IP address excluded or defined in the excluded
range will also be unavailable. The included and excluded IP addresses are
defined in the <MachineDatabase> section of the file. See Figure 106.

Address Included: Defines which IP address to include.

Address Excluded: Defines which IP address to exclude.

Address Include Range: Defines the range of IP addresses to include.
Address Exclude Range: Defines the range of IP addresses to exclude.

You can add additional included/excluded IP addresses or IP address ranges
by duplicating the corresponding lines in the <MachineDatabase> section:

<ipAddressIncluded>10.22.1.121</ipAddressIncluded>
<ipAddressExcluded>100.100.100.100</ipAddressExcluded>

<ipAddressIncludeRange start="00.00.00.00"
end="255.255.255.255"></ipAddressIncludeRange>

<ipAddressExcludeRange start="00.00.00.00"
end="00.00.00.1"></ipAddressExcludeRange>



4  Uiilities

Reboot Printer

Reboots the selected printer.

Set Printer Password

The PMU does not allow passwords to change unless the Supervisor
password matches the password in the Printer Properties. See “Security Tab”
on page 58.

NOTE: If a password exists but is unknown, you must clear it first.
See “Set Password” on page 13.

To set the printer password in the database:

1. Double-click the printer name. The Printer Properties dialog box opens.
Click the Security tab.

Type the User and Supervisor passwords.

Check the Supervisor Mode check box.

Click OK.

o M 0D
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To change the printer password:
1. Click the printer name to select it.

2. Select Utilities » Set Printer Password. The Change Password dialog
box opens.

Change Password | x| |

Enter new password:

[_| Supervisor Passworid:

Set Delete Cancel

Figure 107. Change Password Dialog Box
3. Type the new password.

4. For a new Supervisor password, check the Supervisor Password check
box. For a new User password, leave this box unchecked.

Click Set.

If you entered a new Supervisor password, double-click the printer name.
The Printer Properties dialog box opens.

Click the Security tab.

Type the same password you entered in step 3 in the Supervisor
Password field.

9. Click OK.
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General Tab

Set Wireless Properties

NOTE: For a more thorough description of these settings, refer to the
Ethernet Interface User’s Manual.

To set wireless properties, select a wireless printer from the printer database
then select Utilities » Set Wireless Properties.

The Wireless Properties dialog box contains four tabs: General, WEP
Encryption, Kerberos, EAP, and WPA.

Wireless Properties [ x|

| General | wWEP Encryption | Kerberos [EAP |"WPA |

ssi: | | sub-channet:
Network Mode: Transmit Power:
Antenna Diversity: Transmission Rate: |
Power Mgmi: Preamble Length: |Defau|t | g |
Authentication: Profile: |
[ International Roaming
Fress Read Button For Current Settings Printer Settings: Read

Close

Figure 108. Wireless Properties: General Tab

General Tab

You must click Read to obtain the printer’s settings before you can modify
them.

NOTE: If the Ethernet Interface has a password assigned to the user guest,
then a Telnet guest password is required. See “Security Tab” on
page 58.

SSID (Service Set Identifier): A 1 to 32 case sensitive character string that
identifies the SS network that the printer with a wireless Ethernet Interface is a
part of.

Network Mode: Determines if the client communicates using an access point
(Infrastructure) or other clients peer to peer (Ad Hoc).

Antenna Diversity: The Ethernet Interface supports a single (Primary and
Auxiliary) and dual (Diverse) antenna mode.

Power Saver Mode: Determines if the Ethernet Interface will go into a power
saving mode (Modes 1 through 5) or stay powered up (CAM: Continuous
Access Mode).
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Authentication: Determines the authentication scheme: Open, Shared,
Kerberos, or LEAP.

Open system authentication allows all devices that have the authentication
algorithm number for open system to authenticate.

Shared key authentication involves a four step process using secure or
encrypted text by means of WEP.

LEAP is to enable LEAP operation.
Kerberos is to enable Kerberos operation.

Sub-Channel: Determines the channel for the radio frequency card:
1 through 15 and Default.

Transmit Power: Determines the wattage of the transmission power: Max
(100 mW - Default), 50% (30 mW), 25% (15 mW), 10% (5 mW), and
1% (1 mW).

Transmission Rate: Currently unavailable. Determines the rate of data
transmission from the radio frequency card to the access point: 1 MHz, 2MHz,
5 MHz, 11 MHz, and Automatic.

Preamble Length: Determines the size of the packet header generated by
the access point: Long, Short, or Default (set by the access point).

Profile: Determines the 802.11g Wireless (Wi-Fi) mode in which to operate.

International Roaming: Check this check box to enable roaming outside the
home country.

When you are finished, click Send to transmit the values to the printer.

NOTE: If the Ethernet Interface has a password assigned to the user root,
then a Telnet root password is required. See “Security Tab” on
page 58.

If you are not going to modify settings on any other tabs, you must update the
printer for the settings to take effect. Click Update to update the printer.

Make sure the settings match those configured in the Access Point.



WEP Encryption Tab

IMPORTANT

WEP Encryption Tab

General | WEP Encryption | Kerberos [ EAP ['WPA |

For 40 bit encryption {ASCII) use 5 characters
For 12% hit encryption {ASCII) use 13 characters
For 40 bhit encryption (Hex) use 10 characters
For 12§ bit encryption {Hex) use 2?6 characters

® Key1 | | Casci ® Hex

Ckey2 | | ©asCl ® Hex

O Key3 | | ©asci ® Hex

O Keyt | | CasCl @ Hex
Read

Close

Figure 109. Wireless Properties: WEP Encryption Tab

You must click Read to obtain the printer’s settings before you can modify
them.

NOTE: If the Ethernet Interface has a password assigned to the user guest,
then a Telnet guest password is required. See “Security Tab” on
page 58.

Select which key you want to use for Wireless Equivalency Privacy (WEP)
encryption. Use the correct number and type of digits for your preferred
encryption strength (40 or 128 bit), then select ASCII or Hex.

Click Disable to disable WEP encryption for the selected printer.

Click Clear to clear all keys displayed on the WEP Encryption tab
simultaneously. (The keys stored in the Ethernet Interface are not affected.)

When you are finished, click Send to transmit the values to the printer. You
can transmit up to four keys at once, but only the selected key will become the
active key in the printer.

NOTE: If the Ethernet Interface has a password assigned to the user root,
then a Telnet root password is required. See “Security Tab” on
page 58.

NOTE: If the values are not in the selected format, or if the exact number of
characters required is not entered, an error message will appear.
Correct the problem, then click Send again.

If you are not going to modify settings on any other tabs, you must update the
printer for the settings to take effect. Click Update to update the printer.

Make sure the settings match those configured in the Access Point.
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Kerberos Tab

The Kerberos tab contains four sub-tabs: Print Server, KDC, Set Password,
and Credentials.

Wireless Properties

rGeneraI rWEPEncrymiun Kerheros | Enp |/WPn |

("Print Server | KDC | SetPassword | Credentials |

Status:

[Z] Activate Kerberos

Renewable Lifetime: | | | second(s) v |

Print Server Name: | |

Press Read Button For Current Settings | Read

Figure 110. Wireless Properties:
Kerberos Tab — Print Server Sub-Tab

Print Server Sub-Tab

You must click Read to obtain the printer’s settings before you can modify
them.

NOTE: If the Ethernet Interface has a password assigned to the user guest,
then a Telnet guest password is required. See “Security Tab” on
page 58.

Status: Displays Authenticated or Not Authenticated once an attempt to send
Kerberos information has been sent.

Activate Kerberos: Check this check box to have the printer use Kerberos
when the printer is using a wireless connection.

Renewable Lifetime/Units: The maximum allowable renewable lifetime in
seconds, hours, or days. The range is 300 seconds to 3 days, or O (i.e., no
limit). The default is 0.

Print Server Name: The name of the print server.
When you are finished, click Send to transmit the values to the printer.

NOTE: If the Ethernet Interface has a password assigned to the user root,
then a Telnet root password is required. See “Security Tab” on
page 58.

If you are not going to modify settings on any other tabs, you must update the
printer for the settings to take effect. Click Update to update the printer.

Make sure the settings match those configured in the Access Point.



Kerberos Tab

IMPORTANT

Wireless Properties

fGeneraI rWEPEncryptiun Kerberos | EAP rWF'A |

(Print Server | KDC | SetPassword | Credentials |

KDC Port:

KDC Hame: | |

KDC Realm: | |

Clock Skew: second{s) ~
TicketLifetime: | | ’m

FPress Read Button For Current Settings Read

Figure 111. Wireless Properties:
Kerberos Tab — KDC Sub-Tab

KDC Sub-Tab

You must click Read to obtain the printer’s settings before you can modify
them.

NOTE: If the Ethernet Interface has a password assigned to the user guest,
then a Telnet guest password is required. See “Security Tab” on
page 58.

KDC Port: The TCP/UDP port number used by the KDC. The default is 88.

KDC Name: The name of the KDC which the Access Point is registered. The
default is krbtgt.

KDC Realm: The realm of the KDC which the Access Point is registered. The
default is LOCALREALM.

Clock Skew/Units: The maximum allowable time difference between the
Print Server clock and the KDC clock, in seconds, hours, or days. The default
is 300 seconds.

Ticket Lifetime/Units: The maximum allowable ticket lifetime in seconds,
hours, or days. The range is 300 seconds to 3 days. The default is 10 hours.

When you are finished, click Send to transmit the values to the printer.

NOTE: If the Ethernet Interface has a password assigned to the user root,
then a Telnet root password is required. See “Security Tab” on
page 58.

If you are not going to modify settings on any other tabs, you must update the
printer for the settings to take effect. Click Update to update the printer.

Make sure the settings match those configured in the Access Point.
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Wireless Properties

fGeneraI rWEPEncryptiun Kerberos | EAP rWF'A |

((Print Server [[KDC | SetPassword || Credentials |

New Password:
| |

Confirm Password:

| |

FPress Read Button For Current Settings Read

Figure 112. Wireless Properties:
Kerberos Tab — Set Password Sub-Tab

Set Password Sub-Tab

You must click Read to obtain the printer’s settings before you can modify
them.

NOTE: If the Ethernet Interface has a password assigned to the user guest,
then a Telnet guest password is required. See “Security Tab” on
page 58.

New Password/Confirm Password: Use these fields to set the Kerberos
password. Click Confirm to confirm that both the passwords match.

When you are finished, click Send to transmit the value to the printer.

NOTE: If the Ethernet Interface has a password assigned to the user root,
then a Telnet root password is required. See “Security Tab” on
page 58.

If you are not going to modify settings on any other tabs, you must update the
printer for the settings to take effect. Click Update to update the printer.

Make sure the settings match those configured in the Access Point.



Kerberos Tab

Wireless Properties

fGeneraI rWEPEncryptiun Kerberos | EAP rWF'A |

((Print Server [KDC | SetPassword | Credentials |

Principal Name:

Service Principle Yalid Starting

FPress Read Button For Current Settings

Credentials Sub-Tab

Figure 113. Wireless Properties:
Kerberos Tab — Credentials Sub-Tab

This tab displays the Service Principle, the date and time the settings are

valid, and the date and time the settings expire.
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EAP Tab

Wireless Properties

rGeneraI rWEPEncrymiun rKerherus |'{ EAP |WPA |

User Name:

Password:

Confirm Password:

| |

Figure 114. Wireless Properties: LEAP Tab

You may choose one of three commonly used authentication methods that
are supported on the NIC. The methods are PEAP, LEAP, and TTLS.

User Credentials

Enter the User Name, Password, and Confirm Password corresponding to the
RADIUS (Remote Authentication Dial-In User Service) server, then click
Confirm to confirm the Password.

To enable EAP in the ethernet, select the General tab. Click Send to transmit
the EAP settings and the wireless properties defined in the General tab.
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WPA Tab

WPA Tab

Wireless Properties

(‘General | WEP Encryption | Ferieros | EGP [ wpa

WPA Mode WPA Cipher

Disahle Disable w
Passphrase:

Confirm Passphrase:

| |

Figure 115. Wireless Properties: WPA Tab

This tab displays the information necessary for the WPA (Wi-Fi Protected
Access) wireless security scheme.

WPA Mode: Selects the WPA wireless security mode. By default the mode is
set to Disable thus disabling WPA security. If set to Personal, this selects a
personal or pre-shared key mode for WPA security.

WPA Cipher: Selects the WPA Cipher wireless security setting.
Passphrase: Sets the individual bytes of the WPA Passphrase.

Refer to the printer’'s User’'s Manual and the Ethernet Interface User’s Manual
for more information.
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Macro Utility

The Macro Utility allows you to create a series of ten buttons that will do a
range of things such as sending a string of text to the printer to performing
functions such as form feeds.

To access the Macro Utility, click the E—_ﬁ (macro utility) button at the far right
of the toolbar, or select Utilities » Macro Utility. The Macro Utility window
opens. See Figure 116.

You can use the File menu options to save and open a set of macros.

£ Macro Utility P S |
File
Macro Name Copies
| 1 | 1 I%” Configure
| 2 | 1 I%” Configure
| 3 | 1 I%“ Configure
| 4 | 1 I%” Configure
| 5 | 1 l,%” Configure
| iy | 1 I%“ Configure
| 7 | 1 I%“ Configure
| 8 | 1 I%” Configure
| 0 | 1 I%” Configure
| 10 | 1 I%i Configure |
Printto: LPT1
Status: ldle
0%

Figure 116. The Macro Utility Window
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Configure Macro

Configure Macro

Macro String

[_] Print from file: Macro Hame |1

| oK ” Cancel |

Figure 117. The Configure Macro Dialog Box

To create or edit a macro, click Configure to the right of the macro name

(initially 1 through 10). The Configure Macro dialog box opens. See
Figure 117.

Configure Macro

~Macro String

[¥] Print from file: Browse Macro Hame |Feadile t:d

| oK ” Cancel |

Figure 118. The Print from file Check Box

To use a file as a macro, check the Print from file check box. Then click
Browse to locate your file (such as a .txt file). By default, the file name

becomes the macro name. Rename it in the Macro Name field. See
Figure 118.

Click OK to finish configuring the macro.
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A4 B5 78 74 20 53 T4 72 B9 GE A7

[Z1 Print from file: Macro Hame |Text String

| OK H Cancel |

Figure 119. The Macro String Field

You can create a second kind of macro by typing in the Macro String field.
The ASCII text appears above, and the hex code below. Use the up and down
arrow keys to switch between ASCII text and hex code. Rename the macro in
the Macro Name field. See Figure 119.

Click OK to finish configuring the macro.
The configured macros now appear in the list. See Figure 120.

4. Macro Utility !EIE
File
Macro Hame Copies
| Readie.txt | 1 I%” Configure
| Text String | 1 I%” Configure
| 3 | 1 I%” Configure
| 4 | 1 I%” Configure
| A | 1 I%” Configure
| 6 | 1 I%” Configure
| ¥ | 1 I%” Configure
| ] | 1 I%” Configure
| g | 1 I%” Configure
| 10 | 1 I%: Configure |
Printto: LPT1
Status: Idle
0%

Figure 120. Configured Macros

Click the corresponding Macro Name button to send it to the printer. Adjust
the number of copies in the Copies field.




Configure Macro

SNMP Browser

-__* SHMP Browszer

File

P | | om: [1.251.21.1.1.0 community: |public

| cet || wak || cear |

[ »

1]

Figure 121. SNMP Browser

The SNMP Browser enables you to view attribute values in the Printer MIB
managed by the Ethernet Interface. You can retrieve an attribute value of a
specific MIB Object ID (OID), or you can walk or traverse the MIB.

Three inputs are required before you can use the SNMP Browser:
1. IP: defines the IP address of the target printer.

2. OID: defines either the specific MIB object ID you want to view, or the
starting location for the MIB walk.

3. community: defines the access community defined in the Ethernet
Interface. The default is public.

The Get button retrieves the attribute and attribute value for the specific OID
entered. If the OID entered is invalid, you will receive the Error: SNMP error
message.

The Walk button traverses the MIB starting with the OID entered. The display
is in the format: OID=Attribute_Value.

The Clear button clears the current display.

The File menu allows you to open a previously saved SNMP Browser
session, save the current session to file, or send the current session to a
printer.
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A Aszzign IP Address

Broadcast Address: |255.255.255.255 |

Hardware Address: | |

New IP Address: | |

Hew Mask: | |

Hew Gateway: | |

Assign Cancel

Figure 122. Assign IP Address

Allows you to assign IP addresses remotely to Ethernet Interfaces that have
not been previously configured, or to reconfigure the Ethernet Interface
settings. See Figure 122.

This utility requires expert network knowledge. If you assign incorrect
network parameters to the printer, then other devices on the network
may operate improperly, possibly causing the whole network to be
unusable.

The Assign IP Address utility has five fields:

Broadcast Address: To enter a subnet broadcast number or a direct IP
address to find the printer.

Hardware Address: To enter the Machine Access Code (MAC) on the
Ethernet Interface.

New IP Address: To assign the printer its new IP address. Make sure
this address is correct and do not enter an already existing IP address.

New Mask: To enter the new mask address, if necessary. If you need the
same mask, type the mask number.

New Gateway: To enter the gateway number the new printer uses.

Once you click Assign, the Ethernet Interface settings change immediately.

NOTE: To view the new settings on the operator panel, reset the Ethernet

Interface (refer to the Ethernet Interface User’'s Manual) or reboot the
printer: set the power switch to O (Off), wait 15 seconds, then set the
power switch to | (On).
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Enable Remote Printer Management

This sets the printer’s diagnostic port to Ethernet, without having to navigate
through the printer’s operator panel.

It performs the following in the background:

Opens a command prompt session.

Executes a telnet command to the printer's IP address.
Logs in as root.

Executes the enable printermgr telnet command.

o~ 0D~

Closes the command prompt session.

NOTE: You must have Telnet root privileges to use this utility. See “Telnet
Root Password” on page 58.

Select Utilities » Enable Remote Printer Management, and the following
dialog box opens:

Enable Hemote Printer Management E

% This feature requires Telnet root privileges and
| the password must he entered in the Security
tab of the Printer Properties dialog. If this has
been done, press "ves" to continue.

If the root password has not heen entered

or you do not know it, press “No™ to exit.

Yes No

Figure 123. Enable Remote Printer Management Dialog Box

Click Yes to continue.

When remote printer management has been enabled, the following dialog box
opens:

Remote Printer Management Enabled |

Remate printer management on the printer was
successiully enabled. You should now he able to
run all the application programs and utilities.
Press "0OK" to continue,

OK

Figure 124. Remote Printer Management Enabled
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If the following error message appears, then remote printer management has
not been enabled.

IMPORTANT  You may need to set the correct root password. See “Security Tab” on
page 58.
Enable Command Failed |
Remaote printer management on the printer failed
and is disabled. Check the printer to see that it
is powered on and has a network card installed,
then try it again.
Press "0K" to continue.
Figure 125. Remote Printer Management Not Enabled
Lock/Unlock Menus
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Lock/Unlock Menus |

% Please make a selection

Lock menus -

OK Cancel

Figure 126. Lock/Unlock Menus Dialog Box

The Lock/Unlock Menus dialog box allows you to lock or unlock menus on a
selected printer.

When you lock menus on a printer, the menu tree is disabled in the operator
panel (physical and virtual). Any key that affects the menu tree such as +, —,
T, L, 4, UP, DOWN, NEXT, and PREV will not function. Also, any key that
goes to a menu, e.g., the JOB SELECT or TEST PRINT key, will not function.

NOTE: When some of the above listed keys are used in combination with
another to perform functions not related to the menu, they are not
disabled.

Other keys not disabled are those that perform a function, e.g., PAUSE,
FEED, ONLINE, PAPER ADVANCE, VIEW, SET TOF, PRT CONFIG, and
PAGE EJECT.
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Configure Print Servers

g Configure Print Servers

Login: Password: [] Automatic

Printer | Status | Trap Port \ Wiarning | Offline | Media Input | hedia Output \
Mew_Printer Ready Set [v] [v] [v] [v]

[

|»
Press (Start) to configure the Print Servers Start Cancel

Figure 127. Configure Print Servers Window

To access the Configure Print Servers application, select one or several
printers from the printer database then select Utilities » Configure Print
Servers or click the @ Configure Print Servers button. The Configure Print
Servers window appears (see Figure 127).

The Configure Print Servers application allows you to set the trap port
according to the SNMP Trap Server setting (see page 28).

The Configure Print Servers application also allows you to select or deselect
alert groups. To deselect an alert group, uncheck the check box(es) of the
corresponding option(s). (By default all check boxes are checked.) The alert
group options include:

*  Warning *  Marker * Intervention
o Offline o Cutter » Consumable
e Media Input » Barcode e Label

* Media Output - RFID + Power Cart
* Media Path » Scanner

Click Start to configure the print servers.

NOTE: Check the Automatic check box to have the PMU connect directly
with the printer.

Uncheck the check box to have the PMU make a Telnet connection
with the printer. Enter root in the Login field and the password for the
user root in the Password field.

When your printer encounters a problem that falls within the parameters of the
selected alert options, the corresponding alert message appears. Refer to the
Alert Groups Table in chapter three of the Ethernet Interface User's Manual
for descriptions of the alert message options.

NOTE: To check the print servers configuration, go to the Ethernet Interface
web page as discussed in chapter three of the Ethernet Interface
User’s Manual.
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5 Datastream Adapter

Overview

The datastream adapter is a software filter tool that allows you to take data
from an incoming datastream and replace the data with different data, insert
new data at any location in the datastream, or flush out portions of the
datastream. This is accomplished through Character Substitution Tables
(CSTs) created by the CST Manager (page 148). See Figure 128.

4 CST Manager - CSTBundlel_bnd

File Edit Tools

EEENEIO JESIL Y1

[[] once Input: New
Mode:
I NP UT A
ppend
Replace ¥ | |49 4E 50 55 54
Count: Output: | Insert |
S louTpPuT |
4F A5 A4 A0 55 54
[o]y] Input Mode Qutput
| st \EETEmIEN
Edit Information || Patterns / Variables || Status Response Definition |

IEI'H'IUL: LPP|AR: Disabled|LM: May 18, 2006 3:11:51 PM PDT I 0% IErrnrs:I] IWarnings:l] Ilnserl

Figure 128. Creating a CST to Download Into a Printer
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Using the CST Manager, you decide which data, as sent by the host, gets
modified by the printer.

Open the PMU and select Applications » CST Manager or click the ﬁ:g
(CST Manager) button to open the CST Manager window. See Figure 129.

Menu and )
Toolbar Input/Output Fields

& CST anager - Z4 TBundietbmd

FEe i nex g
[lonee e 8 o

Maode:

I |Raplace b | M
Count: Output: | Insert |
| =

h oo oo oo o o —

23 e ][

Edit Information || Paﬂernsf\.‘ariables/ || Status Response Definition |

IEI'H'IUL: LPPJAR: Disabled LM: May 18, 2006 3:11:51 PM PDT / Iu% IErrurs:l] IWarnings:l] Ilnsert

Status Bar CST Listing Field
Figure 129. CST Manager Window
The CST Manager has a Toolbar, Input/Output fields, and a CST Listing Field.



The Menu And Toolbar

The Menu And Toolbar

File Edit Tools

TITTITITIN

Save Print Cut Copy Delete Upload CST Download CST

from printer to printer
Open CST Paste
Bundle Check CSTs for errors
and warnings
File

New: Closes the current bundle and creates a new one. See “CSTs and CST
Bundles” on page 154.

Open: Opens a file dialog where you can select a CST bundle from a local
disk. If the bundle has more than one CST, the first CST displays in the table.

Reopen: Displays the last eight opened CST bundles.
Save: Saves the current CST.

Save As: Similar to Save, except allows you to save the CST using a different
location and name.

Backup History: Displays the backup history of a file. The system maintains
the last 20 versions of a file.

Properties: Displays version information of a file.

Set Password: Sets the password for the current bundle.
Print: Prints selected CST entries.

Quit: Closes the CST.

Edit

Cut: Moves the selected item to the paste buffer. The paste buffer holds only
one item at a time. When you cut another item, the paste buffer updates.
Ctrl + X is the shortcut.

Copy: Copies the selected item to the paste buffer. Ctrl + C is the shortcut.

Paste: Copies the contents of the paste buffer to the selected area. Ctrl + V is
the shortcut.

Delete: Deletes the current selection.
Select All: Selects all entries in the active CST.

New CST: Adds a new CST to the bundle. CSTs have default names, but you
can change them. Names can have only 8 characters.

Rename CST: Renames the CST.
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Delete CST: Deletes the current CST from the bundle.
Import CST(s): Imports CST(s) from a bundle file.

Tools

Test

Tests the functionality of the active CST.

NOTE: The active CST is the CST currently selected/shown in the CST
Manager window.

In the left (Input) pane of the Test dialog box, you can open and edit input files
or create your own test files.

Click Run, and the active CST processes the input file and displays the
results in the right (Output) pane.

Right-click in the Input or Output pane, and a View/Search pop-up menu
appears. See Figure 130.

Available views are Normal (no control codes display), Dots (control codes
display as dots), Mnemonics (control codes display as mnemonics,
e.g., <LF>), and Hex (all characters display as a hex value).

& Test- CST-1

Input )| Output

View F Hormal Ctrl-H
Search »| Dots Cirl-0
Mnemaonics Cirl-hd

ﬂex Ctrl-H
Total: 0 - Pos: 0 - Selection: 0 Total: 0 - Pos: 0 - Selection: 0
open || save || saveas | | save || savens |

Figure 130. The View/Search Pop-up Menu
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Sowch |

Data to Find
n u | | -
BE 75 BC BC
Options Direction
[_] lgnore Case ® Forward
i) Backward
Scope Qrigin
(® Global @ From Cursor
i_! Entire Scope
OK Cancel

Figure 131. Search Dialog Box

Available searches are Find, Find Next, and Find Previous. If you select Find,
a Search dialog box opens. See Figure 131.

Upload

Makes a connection to a printer from the printer database, then determines if
the printer has a CST file. If so, it uploads the CST file into the CST manager.
If the file is password protected, you will need to provide the password or else
the upload will cancel.

Download

Downloads the open CST file from the CST Manager to a printer. It makes a
connection to a printer from the printer database, then determines if the
printer has a CST file. If so, it warns you that the file will be overwritten if you
proceed.

You must enable the CST option in the printer before you can use it. To
enable the CST:

Open the PMU.

Select Applications » CST Manager.

In the Input field, type INPUT.

In the Output field, type oUTPUT. See Figure 128.

Select File » Save As.

Name the CST something simple like CST-1, CST-2, etc.
In the PMU, select a printer.

© N o o kw2

In the CST Manager, select Tools » Download to download your saved
CST to the printer.
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9. Inthe PMU, select Applications » Operator Panel.
10. Take the printer offline.

11. Select PRINTER CONTROL » Applic. Adapter if you have a thermal
printer, or select MAINT / MISC » Applic. Adapter if you have a line
matrix printer.

12. Change the setting from Disable to the name of the CST you downloaded
(such as CST-1, CST-2, etc.). Your CST is now enabled.

NOTE: To maximize the performance of a CST, you need to save itin a
Configuration file. See “Configuration Editor” on page 67.

Validate Bundle

Checks CSTs for syntax errors and missing information such as “Start Flush”
commands that have no corresponding “End Flush” command. Errors display
in red. Warnings display in yellow.

You cannot execute CSTs with errors, but you can execute CSTs with
warnings.

Options
Specifies options that apply to the CST. Includes the following check boxes:

» Use Last Selected Upload Printer
e Use Last Selected Download Printer
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Input/Output Fields
(] Once Input: New |
Mode: W
Replace - | W
Count: Output: 4
Upiate

Figure 132. CST Input/Output Fields

These fields allow you to select the appropriate Input/Output sequence.
Use Shift + Alt + i and Shift + Alt + o to switch between the Input and Output
fields.

See “Modes And Attributes” on page 155 for the different Mode selections.
Use the four buttons on the right with the Input/Output fields.

New: Clears the Input and Output fields.

Append: Enters the Input and Output fields at the end of the current CST.

Insert: Enters the Input and Output fields before the selected entry in the
CST.

Update: Re-enters the Input and Output fields into the current CST after
editing.

Input Field

The Input Field displays the Input string the datastream adapter looks for.
Enter Input strings in one of two ways: as an ASCII character or as a hex
value. You can switch between the two entry modes by using the up and
down arrow keys. To select attributes, place the mouse over a character and
right-click. Available attributes display (see “Modes And Attributes” on

page 155).

Output Field

Use the Output Field to specify what the datastream adapter does when the
incoming data matches the data and conditions specified in the Input Field.
Specify data if performing a Replace, or specify the name of a CST if
performing a CST Select.

NOTE: Attributes are not available in the Output field.
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The CST Listing Field

an Input [ Mode output

Figure 133. CST Listing Field

The field below the input and output fields shows the CST. To copy an entry,
click it and press Ctrl + C or use the copy button on the toolbar. To move an
entry up or down, click it and press Ctrl + up arrow or Ctrl + down arrow.

You can also click and drag an entry to a new position. Double-click an entry
to place its data in the Input/Output fields. The area at the bottom of the dialog
box lists statistical data about the use of CSTs, the available space, and the
selected edit mode.

CSTs and CST Bundles

A CST contains all information necessary to perform an application
adaptation. The CST size is limited to avoid complex adaptations that may
affect printer performance, and to reduce printer memory usage. If a CST
exceeds the size limit, an error message displays. The working space for a
CST is approximately eight kilobytes.

CSTs are stored in a CST bundle. Each CST bundle can hold up to 64 CSTs.
You can name and store as many CST bundles as the storage device allows.

You can define up to 8 different configurations, and each configuration can
have a CST connected to it. Each configuration can have one CST, or one
CST can apply to multiple or all configurations. When you download a CST
bundle to the printer, the CSTs are available to the datastream adapter. You
can then configure the printer to select the correct CST for your applications.

NOTE: Only one configuration and CST bundle can be active at a time.

Status Bar

The status bar, located at the bottom of the CST Manager window, displays
the following items (in order):

e Status info:
« EMUL: the emulation for which the CST is active.

* AR:indicates if Enable Auto Reset is checked in the Edit Information
dialog box. See “Enable Auto Reset” on page 161.

* LM: date and time this CST was last modified.
» A percentage bar which shows the total space used in the active CST.
»  Error count of the CST bundle.
*  Warning count of the CST bundle.
» Edit mode: Insert over overwrite.
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Modes And Attributes

Modes

Fourteen modes handle data: Replace, Remove, Insert, Flush, Transparent,
Skip GFX Data, Select CST, CST ON, CST OFF, Reset, Response, PAA
Event, Store, and Reset All Variables. Each mode allows certain attributes to
apply to the characters of the datastream.

Common Attributes

All modes have four attributes in common: Match, Don’t Care, Don’t Care
Except, and Ignore Case. Also, if at least one Pattern is defined, all modes
have the Insert Pattern attribute. And, if at least one Variable is defined, all
modes (except Store) have the Insert Variable attribute.

You can use these in combination (Or) with other attributes available in the
selected mode. Some modes can use extra attributes. See page 158 for
attribute information.

Replace Mode
The Replace mode replaces part of one datastream with another.
The extra attribute for Replace is Parameter.

Remove Mode

The Remove mode removes data from the datastream. For example, the CST
can remove all occurrences of ” (quotation mark) from the text that is sent to
an Epson FX-1050 emulating printer.

No extra attributes exist for Remove.

NOTE: When using the Don’t Care Except attribute, the Input string is
removed from the datastream except when the Don’t Care Except
condition matches.

Insert Mode

The Insert mode inserts data in the datastream.

The extra attributes for Insert are Before and After (to specify the insertion
point).

Flush Mode

The Flush mode is a combination of the Remove and Replace mode. It
removes longer parts of datastreams without you needing to type in every
character of that datastream, and replaces the removed data with new data.

The extra attributes for Flush are Start, End, and Count.
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Transparent Mode

The Transparent mode allows you to control which data is removed, replaced,
or modified. Sometimes the datastream of a graphics file contains a character
sequence that is specified in the active CST for removal. If you mishandle this
graphics file, important data could be removed.

The extra attributes for Transparent are Start, End, and Count.

Skip GFX Mode

The Skip GFX mode allows the Bit Image Graphics command to be
recognized and the following data to become transparent which prevents the
datastream adapter from removing selected strings from graphics. This allows
graphic code to print properly.

The extra attributes for Skip GFX are 8-pin graphic data, 16-pin graphic data,
24-pin graphic data, and Graphic plot data.

Select CST Mode

The Select CST mode allows you to switch CSTs immediately. Use it if
different conversions are required (one per job). You do not need to select the
matching CST through the printer front panel.

This mode needs a unique header for each of the jobs requiring a CST to
activate. Once a switch occurs, the datastream adapter resets, selects the
indicated CST, and restarts.

NOTE: Buffered data (the portion of the incoming datastream that invokes the
Select CST mode) is not deleted; it is rescanned using the new CST.

No extra attributes exist for Select CST.

CST On, CST Off Mode

These modes prevent data handling by CSTs until enabled by part of the
incoming datastream.

No extra attributes exist for CST On and CST Off.

Reset Mode

The Reset mode is used to reset the CST such that, if the Use Once flag has
been set for one or more entries in the table, these entries become available
again for the next datastream. See “The Use Once Flag” on page 160.

No extra attributes exist for Reset.
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Response Mode

This feature was added to the datastream adapter to allow the definition of a
protocol: an interaction between the host computer and the printer that allows
the host computer to determine status details of the printer. This allows you to
be certain that a job (or label, or form) is completely printed before the next
job is sent.

The Status Response definition feature allows the user to specify what input
string will be used by the host computer to request a status report from the
printer. It also allows the actual response to be defined, and the connection of
a certain printer status as a condition to this response.

The extra attribute for Response is Flush.

PAA Event Mode

In the PAA Event mode, when the defined character sequence in the Input
field is found, an event is generated that can be handled by the GPIO. The
event generated is determined by the Event ID value. Up to 65,535 different
events can be identified using the Event ID parameter.

The extra attribute for PAA Event is Flush.

Store Mode

The Store mode is used to store information from the host data so it can be
used by other modes that allow variables in the Output field. It requires
exactly one variable to be set in the OCS field. As a result this mode can only
be selected if one or more variables are defined.

Right-click the Output field and a pop-up menu appears with the available
variables. See Figure 134. All characters in the Input field that have the
Include attribute selected (see “Attributes” on page 158) are copied into the
selected variable. By default, all characters typed or copied into the Input field
have the Include attribute selected. The entry can only be added to the active
table if a variable has been set. If you select the wrong variable, the variable in
the Output field needs to be removed first before another variable can be
selected.

The extra attributes for Store are Flush and Include.

[C] Once Input:

New
Mode:
AF ; 12 3 456 7 A
ppend
Store v| 41 46 3B 31 32 33 34 35 36 37 Q
Count: Output: | Insert |
rFy
© || msertVariable ¥ Variable 1

Variahle 2
an Input | Qutput
J Variable 3 %J

Figure 134. Available Output Variables for Store Mode

Reset All Variables Mode

The Reset All Variables mode resets and clears all defined variables.
No extra attributes exist for Reset All Variables.
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Attributes

4 CST Manager - CSTBundlel_bnd

File Edit Tools

FEEENEIO RS Y1

[C] Once Input: New
Maode: . =

At t r i but e s | | Append
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Figure 135. CST: Accessing Attributes

To access attributes, right-click any item in the Input field (or select multiple
items and right-click). Different attributes are available depending on what
mode is selected (see “Modes” on page 155). In the above example, the “s” in
“Attributes” was right-clicked while in Replace mode. See Figure 135.

These are the different attributes used by the various modes and their
descriptions:

Match

The most common and simplest Attribute. If the specified character(s) match
the datastream, then a replacement occurs if in Replace mode. It is the
default setting.

Don’t Care

Allows certain characters in the datastream to be wild cards; that is, it does
not matter what character it is. If the others match, then the replacement
occurs if in Replace mode.

Don’t Care Except

Allows characters in the datastream to be wild cards, but only if they do not
match the character specified.
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Ignore Case

Allows the matching of characters to be case independent. Whether the
character is “X” or “x” a match occurs.

Parameter

Allows characters in the incoming datastream to have a “label.” You can use
this label in the outgoing datastream to move characters to other locations
without changing them. If the outgoing datastream has no label specified,
then the character is removed from the incoming datastream.

Before/After

Specifies where the data is inserted.

Start/End

Starts and stops data flushing (activates and deactivates the datastream
adapter). Any data in the Output field passes to the printer instead of being
flushed.

Count

Specifies a fixed number of characters that are flushed following the Count
attribute (deactivates the datastream adapter). The fixed number is specified
in the Count field.

Flush

Removes the input string from the datastream, preventing it from being
printed.

Include

Specifies that the character that has the attribute will be included in the Store
mode operation.

Insert Pattern

Allows a defined pattern to be inserted in the CST. See “Patterns / Variables”
on page 162.

Insert Variable

Allows a defined variable to be inserted in the CST. See “Patterns / Variables”
on page 162.
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Additional Features

Use Once Flag

4 CST Mznager - CSTBundlel_bnd

File Edit Tools
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\ Edit Information || Patterns /Vfariables || Status Response Definition |
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Entry On/Off Flag Edit Information Patterns / Variables Status Response
Definition

Figure 136. Additional Features

The Use Once Flag

This flag, which is set during the entry of a CST, is used when it is impossible
to create entries in the table that are unique enough to allow for different
outputs according to each of the entries. This might be the case when data
extraction is done and the printable data is always preceded or followed by
the same character (or sequences).

NOTE: A positive note in using this flag is that as more CST entries get
marked as “used,” the less entries need to be checked by the
datastream adapter and the faster the conversion takes place. Even if
you do not need the flag to compensate for a lack of uniqueness in
the incoming data, setting the flag for entries that will occur only once
improves the throughput of the datastream adapter.

When the end of the CST has been reached, the used flags will need to be
reset so that this CST can be applied to the next datastream.
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The Entry On/Off Flag

To reset the used flags:
e Append the Reset mode to the CST.

» Check the Enable Auto Reset check box in the Edit Information dialog
box. See “Edit Information” on page 161.

NOTE: The only difference between the two methods is that the Reset mode
can be placed anywhere in the CST. The Enable Auto Reset flag
takes effect only when the end of the CST has been reached.

The Entry On/Off Flag

This flag is used to temporarily enable/disable entries in the CST. It can be
used for testing purposes and for diagnosing large CSTs. The default for this
flag is On.

Edit Information

Edit Information - [CST-1] |

General | Memo |

Select Emulation [_] Enable Auto Reset
® LPP ) PGL

(IWGL ) CTHI
1 PCL2 LG
1 ANSI

JPPL ) PPl

OK Cancel

Figure 137. Edit Information Dialog Box

Click Edit Information, and the Edit Information dialog box opens.

General Tab

Select Emulation: Allows you to select the emulation that is active for the
CST. Even though the printer can store many emulations, only one can be
active for the CST. LPP is the default emulation.

Enable Auto Reset: When checked, all entries that have the Once option
checked are automatically reset in the CST so that this CST can be applied to
the next datastream. The entries are reset only when the end of the CST has
been reached.

Memo Tab

Use the Memo tab to save comments with the CST (e.g., comments that
describe the CST function and purpose).
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Click Patterns / Variables, and the Object Definition dialog box opens.

This dialog box is divided into the following tabs: Pattern Character, Pattern,
Formatted Pattern, and Variable. When you click OK, the defined set of
patterns, pattern characters, formatted patterns, and variables will be
available for use by the current bundle.

You must add defined objects to their associated lists, or else they will
be lost when you close the Object Definition dialog box.

Pattern Character Tab

Object Definition Ed

Formatted Pattern | Variable |
IT Pattern Character I Pattern |
Character: |0x20: ¥ | HNote: ‘ |
Range: | | = |
Pattern Character List
| Hew
OK I | Cancel

Figure 138. Patterns Character Tab

Use the Pattern Character tab to add, remove, and edit new and existing
pattern characters. A pattern character can be used by the datastream
adapter to check host data against a range of values.

Character: Selects the character that identifies the pattern character. The
available values range from 0x20 to OxFF. The values 0x00 to Ox1F are
reserved. The values are listed with their hex value and printable character. If
you select a character already defined in the drop-down list, the properties for
the character will display in the Note and Range fields. You can change the
data and click Update to update the definition in the Pattern Character List.

Note: A short note, description, or name of the pattern character. This will
appear in pop-up menus where you insert and use pattern characters.



Pattern Character Tab

Range: The range of values datastream adapter checks against.
NOTE: A continuous interval is separated by two dots, e.g., a..z.

Enter hex values with the prefix 0x. To define a continues hex interval, enter
O0xNN..0xNN (where NN is a value ranging from 00 to FF).

You can define multiple intervals per pattern character by separating the
intervals with a , (comma) or a space character.

NOTE: To include an interval separator, enter them either as hex, e.g., 0x20
and 0x2C, or make it part of a continues interval, e.g., 0x10..0x30.

Default Pattern Characters

You can select a set of default pattern characters by using the Range drop-
down list. The Character and Note fields of the default pattern characters are
set to the values listed in Table 8. If you choose a default pattern and the
identifier (character) is already in use, the first unused identifier from the
Character drop-down list is used.

Table 8. Default Pattern Characters

0.9 # Numerals

A.Z U Uppercase
a.z L Lowercase
A.Z a.z A Alpha
0.9,A.Z,a.z @ Alpha Numeric
0..9, A..F, a.f H Hex Values
0x00..0x1F C Ctrl-Codes
0x20..0x7F P Printables
0x80..0xFF S Upper Set

Pattern Character List
Lists all the patterns characters that you have defined and added to the list.

New: Click New to reset the Range and Note fields. The first unused identifier
from the Character drop-down list is chosen.

Add: If the displayed text on the second button is Add, the pattern character
(with chosen identifier) has not been added to the Pattern Character List.
Click Add to add the defined pattern character to the end of the Pattern
Character List.

Update: If the displayed text on the second button is Update, the pattern
character (with chosen identifier) is already in the Pattern Character List. Click
Update to update the pattern character properties with the new properties.
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Edit: Select an item in the Pattern Character List, and click Edit to edit it.
NOTE: If you select more than one item, you can only to edit the first item.

Remove: Select one or more items in the Pattern Character List, and click
Remove to remove them from the list.

IMPORTANT Removing pattern characters invalidates entries that use the pattern

characters.
Pattern Tab
Formatted Pattern |~ Variable |
‘ Pattern Character It Pattern |
Name: | |
Pattern:
Pattern List
| Hew
OK | | Cancel

Figure 139. Pattern Tab
Use the Pattern tab to add, remove, and edit new and existing patterns.

Name: The name of the pattern. The name must be unique for this type of
datastream adapter object. This name appears in pop-up menus when you
insert and use patterns.

Pattern: To enter the pattern in a way similar to defining the input of a CST
entry (see “Input Field” on page 153). If you type a character that is defined as
a pattern character (see “Pattern Character Tab” on page 162), the default
attribute will be Pattern Character: it will display over a light green background
with the mnemonic pch. To use the character as a literal, right-click the
character and select the Match attribute.
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IMPORTANT

Pattern List

Lists all the patterns you have defined and added to the list.

New: Click New to clear the Name and Pattern fields and create a new
pattern. Use a unique and descriptive name. This hame appears in pop-up
menus when you insert a pattern.

Add: If the displayed text on the second button is Add, the defined pattern
has not been added to the Pattern List. Click Add to add the pattern definition
to the end of the Pattern List. The pattern appears in the list with its name
followed by a separator and the pattern.

NOTE: If the pattern contains control codes, they will display in red. Other
non-printable characters will display as red dots.

Update: If the displayed text on the second button is Update, the defined
pattern is already in the Pattern List. Click Update to update the pattern
properties with the new properties.

Edit: Select an item in the Pattern List, and click Edit to edit it.
NOTE: If you select more than one item, you can only to edit the first item.

Remove: Select one or more items in the Pattern List, and click Remove to
remove them from the list.

Removing patterns invalidates entries that use the patterns.

Move Up/Move Down: Patterns appear in pop-up menus in the order that
they appear in the Pattern List. Select an item in the Pattern List, and click
Move Up or Move Down to move the pattern up or down on the list.
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Formatted Pattern Tab

Use the Formatted Pattern tab to add, remove, and edit new and existing
formatted patterns. You can use a formatted pattern to identify host data
patterns that do not have a fixed length.

Object Definition

[ Formatted Pattern_| Variable |
| Pattern Character r Pattern |

Name: | |
i Minimum Length: |0 %
Data Pattern:

24 Maximum Length: |16 %

Delimiter: Start: O End: O Auto:  [[]

Formatted Pattern List

Add

OK I | Cancel

Figure 140. Formatted Pattern Tab

Name: The name of the formatted pattern. The name must be unique for this
type of datastream adapter object. This name appears in pop-up menus when
you insert and use formatted patterns.

Data Pattern: To insert a single character that is used as the data pattern.
This may either be a pattern character or any other character with the default
Don’t Care attribute. The default for this field is * (asterisk) with the Don’t Care
and Include attributes.

Right-click the character and the following pop-up menu appears:

inc | Minimum Length: |0 I%i
Data Pattern:
E @ Don't Care Length: |16 l%i
o [ Flush
Delimiter: St{ ,, . . Auto: [

Figure 141. Data Pattern Pop-up Menu
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If you use a data pattern character that is not defined as a pattern character,
the Don’t Care attribute is always selected. Use the Flush attribute to flush the
found data from the host data. Use the Include attribute include the found data
in Store operations. The Include attribute is selected by default.

If you use a data pattern character that is defined as a pattern character, the
Pattern Character attribute will be selected by default, and the background of
the inc mnemonic will be light green. To change it to a wild card character,
right-click the character. The attribute pop-up menu appears. See Figure 142.

inc | Minimum Length: |0 I%i
Data Pattern: iz O Don't Care T =
~ | ® Pattern Character =]
Delimiter: St - cpich : [
¥ Include

Figure 142. Pattern Character Pop-up

The Pattern Character attribute is selected by default. To use the data pattern
character as a wildcard, select the Don’t Care attribute.

Minimum Length: Defines the minimum length the pattern must have. If the
data pattern is set to scan for numerals using a pattern character, it must find
at least n numerals (the value set by this property) before a match is
considered.

Maximum Length: Defines the maximum length the pattern may have. If the
data pattern is set to scan for numerals using a pattern character, it only
scans for a maximum of n numerals (the value set by this property) before a
match is made.

Delimiter

Use delimiters to find data easier. You can look only for a start delimiter, end
delimiter, start and end delimiters, or auto delimiter.

Start: When you enable Start, a pattern match occurs only when the Start
character is found. The Start character may be a single character or a pattern
character, and it has the Flush and Include attributes.

End: When you enable End, a pattern match occurs only if the End character
is found at the end of the data pattern and the maximum length is not
exceeded. The End character may either be a single character or a pattern
character, and it has the Flush and Include attributes.

Auto: When you check the Auto check box, the pattern considers the first
character found to be the start and end delimiter. See the following example.

NOTE: In the following example, items enclosed in <> indicate datastream
adapter objects like Pattern, Pattern Character, etc. Random host
data is indicated by “....” preceding and/or following the sample data.
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IMPORTANT

Auto Example:

Pattern Character
Identifier: #
Range: 0..9
Note: Numerals

Formatted Pattern
Name: fpFieldData
Data Pattern: <#>
Min: O
Max: 5
Delimiter: Auto

Entry 1
Input: AF;< fpFieldData >
Mode: Remove
Output: N/A

Test Case 1
Host data: ....AF;"12345"....
Result: Match for Entry 1
Reason: As delimiter is set to auto the first quote is seen as the start and
end delimiter.

Test Case 2
Host data: ....AF;"123456"....
Result: No Match
Reason: Max length exceeded.

Test Case 3
Host data: ....AF;"01234"....
Result: No Match
Reason: No Matching end delimiter.

Formatted Pattern List
Lists all the formatted patterns that you have defined and added to the list.
New: Click New to reset all data fields.

Add: If the displayed text on the second button is Add, the formatted pattern
has not been added to the Formatted Pattern List. Click Add to add the
defined formatted pattern to the end of the Formatted Pattern List.

Update: If the displayed text on the second button is Update, the formatted
pattern is already in the Formatted Pattern List. Click Update to update the
formatted pattern properties with the new properties.

Edit: Select an item in the Formatted Pattern List, and click Edit to edit it.
NOTE: If you select more than one item, you can only to edit the first item.

Remove: Select one or more items in the Formatted Pattern List, and click
Remove to remove them from the list.

Removing formatted patterns invalidates entries that use the formatted
patterns.



How to Use Patterns

How to Use Patterns

[] Once Input:

New
Maode:
E
T = | p ® Match Append
—| © Don't Care
Count: O | Insert |
o ) Don't Care Except
he ’7 O lgnore Case
O Parameter
m Input Qutput

Insert Pattern »
Insert Formatted Pattern »

Figure 143. Inserting Patterns in the Input Field

Once you define the patterns you can use them in CST entries. To insert a
pattern, right-click a character from the input string. Insert Pattern and/or
Insert Formatted Pattern displays at the bottom of the pop-up menu. See
Figure 143.

Use these menus to insert your pattern or formatted pattern. The pattern will

be inserted before the character. To append a pattern, right-click past the end
of the Input string.

[] Once Input: New

Maode:
A 1 F ; 1 CRLF A
ppend
|Raplace '| 41 pat 46 3B fpt 0D DA

Figure 144. Inserted Patterns

A pattern has an index number in red on a light green background with the
mnemonic pat below the index number. A formatted pattern uses the
mnemonic fpt. See Figure 144.

[] once Input: New
Maode:
A 1 F ; 1 CRLF A
ppend
Replace - 41 pat 46 3B fpt 0D DA Q
Count: Qutput: | Insert |
: ~ B F ;
FE 42 46 3B Insert Pattern Pl
1
m Input | Insert Formatted Pattern >| 1-1p1 hput

Figure 145. Inserting Patterns in the Output Field

The same formatted pattern may be used more then once in the Input field.
When you want data found by the pattern to be copied to the Output field, use
the index number (in red) to identify the data. To add a pattern to the Output
field, use the same procedure as for the Input field. The Insert Pattern and
Insert Formatted Pattern menus list all patterns used in the Input field with the
index number in front of the pattern name. See Figure 145.
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|_| Once Input: | Hew

Mode: A 1?F s 1 crRLF Append
|Replace v| 41 pap T ; |
{ Posi{1)- Sel{0)- PAT: [Pattern 1 - A]} |

Figure 146. Pattern Screen Tip

ot |

To see pattern details, i.e., name and definition, hover the pointer over the
character in the Input field to display a screen tip. See Figure 146.

NOTE: For some Modes, you cannot insert patterns into the Output field.

Pattern Recognition Example

Normally, the CST only allows you to do an absolute match on a character. It
has not been possible to check if a character is within a given range of
characters (unless you write a very complicated CST).

Pattern recognition allows the user to specify either a range of characters or a
specific pattern with a unique name that can be used to test the input data
against.

Example

The following command sets the label size for thermal printer 1:

<ESC>Daaaa,bbbb,cccc<LF><NULL>
where aaaa is the length of the label, bbbb is the effective print width and cccc
is the effective print length.

NOTE: aaaa, bbbb, and cccc are always fixed at 4 digits with a value range
of 0000 to 9999.

Convert this command (assuming the units are the same) into the PGL
PAPER command for thermal printer 2.

Start with a CST that will translate the <ESC>D into PAPER. Skip the value of
aaaa since thermal printer 2 can detect the forms length using the
CALIBRATE function. The value of bbbb will be used in combination with the
WIDTH function, and the value of cccc in combination with the LENGTH
function. This results in the following translation:

Thermal printer 1: <ESC>Daaaa,bbbb,cccc<LF><NULL>

Thermal printer 2: PAPER;CALIBRATE;LENGTH cccc;WIDTH
bbbb<CR><LF>

To be able to copy the value of bbbb into the WIDTH function and the value of
cccce into the LENGTH function, label these values and specify their ranges to
be from 0000 to 9999.

To do this, use the Object Definition capability of the datastream adapter.



Pattern Recognition Example

Object Definition Ed

Formatted Pattern | Variable |
IT Pattern Character I Pattern |
Character: |0x20: ¥ | HNote: ‘ |
Range: | | = |
Pattern Character List
| Hew
OK I | Cancel

Figure 147. Object Definition: Pattern Character
1. Inthe CST Manager, click Patterns / Variables. See Figure 147.

Next, define the required pattern character by selecting it from the list of
available characters.

2. Click the Character down arrow and select 0x23: #. The # character will
be used as a label.
NOTE: The total number of different pattern characters that can be selected
is 224.

3. If necessary, enter a note to go with this label in the Note field. For
example, use Length if the Pattern Character is going to be used for the
Length value of the command to translate.

4. Type 0..9 in the Range field. This is the range of values this label can
have.

NOTE: A range is specified using two periods in sequence, i.e., 0..9 or A..Z.
A comma should be used as a delimiter if more than a single range or
value is specified for a pattern character, i.e., A..Z,0..9 if the range
should cover both uppercase alpha and numeric values.

Use the Range down arrow to select pre-defined ranges.
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Object Definition Ed

Formatted Pattern |/ Variable |
‘ Pattern Character r Pattern |

Character: |0x23:# ™~ | HNote: ‘ |

Range: |g.9 [=]

Pattern Character List
0x23:# - -(0..9) | —

| OK I | Cancel

Figure 148. Defining a Pattern Character
5. Click Add to add the pattern character to the list. See Figure 148.
Next, set up a full pattern using the pattern character just defined.
6. Click the Pattern tab.
7. Type Length in the Name field. This is the name of the first pattern.
8. Inthe Pattern field, type #### for the pattern character to be used.

NOTE: The number of pattern characters that can be entered to form a
pattern is unlimited.

9. Click Add to add the pattern to the list.

10. Click New to clear the Name and Pattern fields.

11. Type width in the Name field. This is the name of the second pattern.
12. In the Pattern field, type #### for the pattern character to be used.
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Object Definition Ed
e
Mame: Width |

Pattern: |# # # #

Pattern List

Length - ##58#%
WWidth - #si#

Hew

Move Down

Gl

| OK I | Cancel

Figure 149. Defining Patterns
13. Click Add to add the pattern to the list. See Figure 149.
14. Click OK to return to the CST Manager.
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£ CST Manager - C5TBundlel_bnd
File Edit Tools

BN

[ once Input: New
Maode: | ’7
| Replace - | % M
Count: Output: | Insert |
S
o Input Mode Qutput

| mcst-1 [\CETBRIEN

Edit Information || Patterns / Vfariables || Status Response Definition |

IEI'H'IUL: LPP|AR; Disabled LM: May 26, 2006 8:31:34 AM PDT I 0% IErrurs: 0 IWarnings: 0 Ilnsert

Figure 150. Selecting the Input Field

Now you can use the just defined pattern in the CST. Create an entry in the
CST where the input field specifies the thermal printer 1 command sequence
bbbb be replaced by the Width pattern and cccc be replaced by the Length
pattern.

15. Click the Input field to place the cursor. See Figure 150.
16. Press the down arrow key to enter Hex entry mode.

17. Type 1B (for ESC).

18. Press the up arrow key to enter ASCII entry mode.

19. Type Daaaa,.

20. Right-click to the right of the last character position.

21. Hover the pointer over Insert Pattern. A list of available patterns
displays.

22. Select Width.
23. Press the right arrow key to reposition the cursor and type , (comma).
24. Right-click to the right of the comma and select Insert Pattern » Length.
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Input: Hey
escD a a a a , 1 , 2 LF nuL Appe
18 44 B1 B1 B1 B1 2C pat 2C pat 0A 00 —
Ourtpaut: Inse

Figure 151. Entering the Input String

25. Press the right arrow key, then the down arrow key and type 0A00
(for LF and NUL). See Figure 151.

NOTE: The entry in the CST will show “pat” (Pattern) in the attribute field and
a pattern number in the character field. The hex value shown below
the pattern number has no specific meaning.

Since the aaaa value is not going to be used, we need to give these
characters the Don’t Care attribute.

26. Select aaaa.

27. Right-click the selected aaaa and select Don’t Care. The attribute field
changes from “m” (Match) to “dc” (Don’t Care).

28. In the Output field, type ~PAPER ; CALIBRATE. This PGL command
replaces the “<ESC>Daaaa” part of the thermal printer 1 command.

29. Continue by typing ; LENGTH[space].

Input: Hew
de de de de

escD a a a a , 1 , 2 LF nNUL Append
1B 44 61 B1 B1 61 2 pat 2C pat 0A 00
Output: ‘ Insert ‘

ALI BRATES ; LENGSGTH
41 4C 40 42 52 41 54 45 3B 4C 45 4E 47 54 43 20 | InsertPatiern’k 1 - Width

2 - Length
| Mode | Qutput || 4%

Figure 152. Entering the Output String

30. Right-click at the insertion point and select Insert Pattern » 2 - Length.
See Figure 152.

NOTE: Make sure you right-click to the right of the space.
31. Press the right arrow key and type ; WIDTH[space].
32. Right-click at the insertion point and select Insert Pattern » 1 - Width.

33. Press the right arrow key, then the down arrow key and type 0D0A
(for CR and LF).
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£ CST Manager - C5TBundlel._bnd*
File Edit Tools

EEER S LRSI

[ once Input: New
Mode: de dc do de
* EszcD a a a a 1 2 LF HNUL Y
' , ppend
|REP|BCE '| 1B 44 B1 B1 B1 A1 2C pat 2C pat 0A 00 Q
Count: Output: | Insert |
“ N G T H 2: Wl DTH 1 cCR LF
T [E 47 54 48 20 pat 3B 57 49 44 54 48 20 pat 0D 0A Update |
o Input | Mode | Output [
[w] =ESC=Daaaa,|1: Width|,|2: Lenot Replace ~PAPER;,CALIERATE,LENGTH E

Figure 153. The Appended CST
34. Click Append. See Figure 153.
Now you will test the newly created CST.
35. Select Tools » Test. The Test window opens. See Figure 154.

& Test- CST-1

s
=
=
v

Output

Total: 0 - Pos: 0 - Selection: 0 Total: 0 - Pos: 0 - Selection: 0

| Open | | Save | | Save As | §§ | Save | | Save As

Figure 154. The Test Window
36. Right-click the Input window.
37. Select View » Hex. To enter the Hex entry mode.

38. Click just to the right of the eight zeros to position the cursor.
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Input N

Output

0ooo oooo 1E

Figure 155. Hex Entry Mode

39. Type 1B. To enter the hex equivalent of <ESC>. See Figure 155.

Input b

Output

<ESC>

Figure 156. Mnemonics Entry Mode

40.

Right-click the Input window and select View » Mnemonics. To enter the

Mnemonics entry mode. Notice the 1B changed to <ESC>. See

Figure 156.
41. Type D0123, 0450, 0600.
42,

43.

Right-click the Input window and select View » Hex.
Click just to the right of 0010 on the second line.

Input :

Output

0ooo oooo0 1B 44 30 31 32 33 &C 30 34 35 30 &
0000 0010 04 00 ;

Figure 157. Hex Equivalents of LF and NUL

44. Type 0A00. To enter the hex equivalent of LF and NUL. See Figure 157.

45. Right-click the Input window and select View » Mnemonics.

46. Click Run to test the CST against your input.

Input b

Output

<E4C>D0123,0450,0600<LF>
<NUL>

~PAPER;CALIBRATE ; LENGTH 0600;WIDTH 0450

Figure 158. Successful CST Test Results

The length and width information have successfully been placed in the correct
position in the PGL command. See Figure 158.

NOTE: If a value outside the specified range (in this case, outside the range
0..9) is entered, no conversion takes place and the input string is
passed on to the printer unmodified.
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Variable Tab

Use Variable tab to define variables. Use a variable to store data from the
host so that it can be used at a later time. To define a variable, enter the name
of the variable and add it to the Variable List. To store data into the variable
use the Store mode (page 157). To clear the content of all defined variables
use the Reset All Variables mode (page 157).

Object Definition
Formatted Pattern | Variable |
Pattern Character |/ Pattern |
Name: |
Variable List
| Hew ‘
OK | | Cancel

Figure 159. Variable Tab

Name: The name of the variable. This name appears in pop-up menus where
you insert and use variables.

Variable List

Lists all the variables that you have defined and added to the list.

New: Click New to clear the Name field.

Add: Click Add to add the named variable to the end of the Variable List.
NOTE: The name of the variable must be unique.

Edit: Select an item in the Variable List, and click Edit to copy its name into
the Name field.

NOTE: If you select more than one item, only the name of the first item will
copy into the Name field.

Remove: Select one or more items in the Variable List, and click Remove to
remove them from the list.

Removing variables invalidates entries that use the variables.



Variable Tab

Status Response Definition

Status Responsze Generator
Conditions
Hame: | |
Qutput:
New Status Bits

i_! Unconditional

i Job In Process

_r Joh Complete

T Wait Job Complete

EEED

Protocol

‘ New |Name
|

Interface
| Active ~|

| OK || Cancel |

Figure 160. Status Response Generator

Click Status Response Definition, and the Status Response Generator
dialog box opens. See Figure 160.

Use the Status Response Generator to define status responses. You can
define printer status bits that make up the condition on which a response
should be generated, as well as the details of each response.
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Conditions

Use the upper section of the Status Report Generator to add new conditions
or select existing conditions to edit or remove.

Name: The name of the condition.
Output: The response for when the condition is met.

Status Bits

Unconditional: To create an unconditional protocol. When you select
Unconditional, all other status bits are disabled.

NOTE: If you have already added other conditions, and then you later add a
condition with the Unconditional Stop Bits property, all other
conditions will be removed from the list.

Job Complete: To create a Job Complete condition.
Job In Process: To create a Job In Process condition.

NOTE: You cannot have more than one condition in the Conditions list with
the same Status Bits setting.

Conditions List

Lists all the conditions that you have defined and added to the list. A condition
is listed by its name followed by a separator and the output sequence.

In the output sequence, control codes display as mnemonics and other
non-printable characters display as red dots.

New: Click New to reset all data fields.

Add: If the displayed text on the second button is Add, the condition has not
been added to the Conditions list. Click Add to add the defined condition to
the end of the Conditions list.

Update: If the displayed text on the second button is Update, the condition is
already in the Conditions list. Click Update to update the condition properties
with the new properties.

Edit: Select an item in the Conditions list, and click Edit to edit it.
NOTE: If you select more than one item, you can only to edit the first item.

Remove: Select one or more items in the Conditions list, and click Remove to
remove them from the list.

Removing conditions invalidates entries that use the conditions.

Protocols

Use the lower section of the Status Report Generator to add new protocols or
select existing protocols to edit or remove.

A protocol is a single condition or set of conditions.

Name: The name of the protocol. This name appears in pop-up menus where
you insert and use protocols.



How To Use Conditions And Protocols

IMPORTANT

Interface: Use this drop-down list to select which (host) interface the
response should go to. Active is the interface on which the CST operates.

Protocol List
New: Click New to reset the Name and Interface fields.

Add: If the text displayed on the second button is Add, the protocol has not
been added to the Protocol list. Click Add to add the protocol to the Protocol
list.

NOTE: The protocol appears in the list with its name followed by a separator
and the name of the interface used.

Update: If the text displayed on the second button is Update, the protocol is
already in the Protocol list. Click Update to update the protocol properties
with the new properties.

Edit: Select an item in the Protocol list, and click Edit to edit it.
NOTE: If you select more than one item, you can only to edit the first item.

Remove: Select one or more items in the Protocol list, and click Remove to
remove them from the list.

Removing protocols invalidates entries that use the protocols.

How To Use Conditions And Protocols

After you define one or more protocols, return to the CST Manager to create a
new entry available for editing. Select Response from the Mode drop-down
list. In the Input field, enter the data on which the response should be
triggered. Right-click the Output field, and select the desired protocol from the
pop-up menu.

You can enter prefixes and suffixes, and these will be sent with the defined
output of the protocol. For example, if the output is defined as pre <Series-1>
suf, and the On_Empty condition is met, then pre 1<CR> suf will be the
response.

A protocol displays with the protocol icon over a light red background with the
mnemonic ptc. To see protocol details, i.e. name and interface, hover the
pointer over the protocol icon in the Output field to display a screen tip.

See Figure 161.

Count: Qutput: | Insert |
Fy
- [E
i
Hm T |F'DS(IU)-SE|(EI)-F'T(?iUEL:';'DtDCDl'I-|ntEF|faCEZACtI\-'E]| Qutput ”

Figure 161. Protocol Screen Tip
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Status Response Generator Example

A host computer sends out an ENQ character to request the printer’s status.
The host computer expects to receive an ACK character when the job has
finished, or a NAK character if the printer is printing.

In the CST Manager, click Status Response Definition. The Status
Response Generator dialog box opens. See Figure 162.

Status Hezponse Generator
Conditions
Hame: | |
Qutput:
Hew Status Bits

i Unconditional

i) Job In Process

i Job Complete

1 Wait Job Complete

[« IS

Protocol

‘ Mew |Name

Interface
| Active |

| 0K || Cancel |

Figure 162. Status Response Generator

You can define the protocol conditions in the upper half of this window. This
protocol, along with other available protocols, will be listed in the lower half.
From this list, the correct protocol is selected during the creation of a CST.

NOTE: You must add protocol conditions before you can add a protocol.
For now you will only define a single protocol.

1. Use a descriptive name for the first condition that should be tested.
In the Name field, type job_printing.



Status Response Generator Example

2.

Conditions

Hame: |ij_printing

Output: (M4
P15 |
Hew Status Bits

i} Unconditional

i_+ Job In Process

i+ Job Complete

i Yfait Job Complete

Add

[« IS »

Figure 163. Switching Between ASCII and Hex Entry Modes

Define the output that should be transmitted to the host.
In the Output field, press the down arrow key and type 15 (NAK).
See Figure 1683.

NOTE: Use the up and down arrow keys to switch between the ASCII and

3.

Hex entry modes.

Under Status Bits, click Job In Process to select the correct condition to
test.

Here is a description of the Status Bits conditions:

4.

Unconditional: This condition is always TRUE. The response is sent to
the host immediately.

Job Complete: This condition is TRUE if the printer is not processing or
printing any data. The response is sent to the host immediately but ONLY
IF this condition is TRUE.

Job In Process: This condition is TRUE if the printer is processing or
printing data. The response is sent to the host immediately but ONLY IF
this condition is TRUE.

Wait For Job Complete: This condition is TRUE if the printer is not
processing or printing any data. The response is sent to the host AS
SOON AS this condition is TRUE.

Click Add to add the entry to the list of protocol conditions.

Now you will add a second condition.

5.
6.
7.

In the Name field, type job done.
In the Output field, press the down arrow key and type 06 (ACK).
Under Status Bits, click Job Complete.
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Conditions
job_printing -» <NAK=> Hame:
job_done -> <ACK>
Qutput:
New Status Bits

i} Unconditional

i_+ Job In Process

i+ Job Complete

i Yfait Job Complete

[« IS »

Figure 164. Adding Conditions

8. Click Add to add the entry to the list of protocol conditions. See
Figure 164.

9. Name this protocol that is comprised of the two conditions.
In the Name field (bottom half of window), type print complete.

10. Select the interface to use for the status response.
Click the Interface down arrow, and select Active.

NOTE: The interface selected does not have to be the same interface the
host is using for a status request. The available interfaces are Active,
Serial, Parallel, and Network.

Protocol

print_complete - Interface ‘ Hew Hame

|print_u:nmplete

Update | hterface

| active |

4

[ »

Figure 165. Adding Protocols
11. Click Add to add it to the list of protocols. See Figure 165.
12. Click OK to return to the CST manager.

NOTE: For the status reporting to work, the printer will have to be online.
Offline conditions, like all error situations, cannot be transmitted to the
host.

Now you will enter the input string that will trigger the protocol you just
created.

13. Click the Mode down arrow, and select Response.
14. In the Input field, press the down arrow key and type 05 (ENQ).



Status Response Generator Example

4 CST Manager - CSTBundlel. bnd

File Edit Tools

ECIEIEIEN 1RSI E-E]

] Once Input: New
Mode:
ENi2 Append
|Response | |ociEmmn
Count: Oul O Don't Care | Insert |
Y
= ' Don't Care Except

—1 O lgnore Case

on Input 5 Flush Output

CST-1 [RESIEnE

Edit Information I Patterns / Variables | status Response Definition |

EMUL: LPP |AR: Disabled|LM: May 23, 2006 9:22:24 AM PDT [ 0% lErrurs: 1} lWarnings: 1} Ilnsert

15.

Figure 166. Response Mode Attributes

Right-click your input string. A list of possible attributes displays. See
Figure 166.

NOTE: In addition to the four common attributes, Response mode has the

16.
17.

18.
19.
20.
21.
22.

Flush attribute. This attribute removes the input string from the
datastream, preventing it from being printed.

Click away from the attributes to close the list.

Right-click the Output field to specify which protocol should be used when
a status is requested. A list of protocols (in this case just one) displays.

Select print_complete.

Click Append to append it to the CST.

Select File » Save or File » Save As to save the bundle.
Download the bundle file to the printer.

Enable the CST in the printer.

The printer now has a status reporting protocol.

NOTE: The input string used to request the printer status does not have to be

a single control code like the ENQ character. Likewise, the output
does not have to be NAK or ACK. It can be anything that the host can
transmit and handle.

It is possible to create a status reporting protocol that uses
sentences. For example, replace the ENQ in the example with
“Printer, how are you doing on this print job?” Replace the Job In
Progress condition output with “I am almost done.” Finally, replace
the Job Complete condition output with “ have just finished this job.”
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CST Manager And EBCDIC

In addition to the standard ASCII character set commonly used for printing,
many applications use the EBCDIC character set. The CST Manger is
specifically designed to work with ASCII. To work with EBCDIC coded files,
characters in the Input and Output strings need to be entered in their EBCDIC
representation. Since the CST Manager does not have an EBCDIC view
mode, these entries must be entered in hex.

EBCDIC/ASCII Table

To help in creating EBCDIC CSTs, refer to the following table for Twinax,
Coax LU-1, Coax LU-3, and ASCII.

NOTE: For LU-3 in the following table: EM = End of Message,
FF = Form Feed, NL = New Line, and CR = Carriage Return.

EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3

00 NUL Null Null 00 NUL Null

01 SOH Start of Header EM 01 SOH Start of Header
02 STX Start of Text FF 02 STX Start of Text

03 ETX End of TEXT NL 03 ETX End of Text

04 PF Punch Off 04 EOT End of Transmission
05 HT Horizontal Tab CR 05 ENQ Enquiry

06 LC Lower Case 06 ACK Acknowledge

07 BEL Delete 07 BEL Bell

08 > 08 BS Backspace

09 < 09 HT Horizontal Tab
0A SMM Start of Man. Message ¢ 0A LF Line Feed

0B VT Vertical Tab ! 0B VT Vertical Tab

oC FF Form Feed ) oC FF Form Feed

oD CR Carriage Return ( oD CR Carriage Return
OE SO Shift Out } OE SO Shift Out

OF SI Shift In { OF SI Shift In

10 DLE Data Link Escape SP 10 DLE Data Link Escape
11 DCH1 Device Control 1 = 11 DCH1 Device Control 1
12 DC2 Device Control 2 ) 12 DC2 Device Control 2
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3

13 ™ Tape mark “ 13 DC3 Device Control 3
14 RES Restore / 14 DC4 Device Control 4
15 NL New Line \ 15 NAK Neg. Acknowledge
16 BS Back space | 16 SYN Synchronous Idle
17 IL Idle | 17 ETB End of Transm. Block
18 CAN Cancel ? 18 CAN Cancel

19 EM End of Medium ! 19 EM End of Medium
1A CcC Cursor Control $ 1A SuB Substitute

1B CU1 Customer Use 1 ¢ 1B ESC Escape

1C IFS Interch. File Separator 1C FS File Separator

1D IGS Interch. Grp Separator 1D GS Group Separator
1E IRS Interch. Rec. Separator $ 1E RS Record Separator
1F IUS Interch. Unit Separator 1F us Unit Separator
20 DS Digit Select 0 20 SP Space

21 SOS Start of Significance 1 21 ! Exclamation point
22 FS Field Separator 2 22 “ Quotation Mark
23 3 23 # Number Sign

24 BYP Bypass 4 24 $ Dollar sign

25 LF Line Feed 5 25 %o Percent

26 ETB End of Transm. Block 6 26 & Ampersand

27 ESC Escape 7 27 ‘ Apostrophe

28 8 28 ( Left Parenthesis
29 9 29 ) Right Parenthesis
2A SM Set Mode | 2A * Asterisk

2B cu2 Customer Use 2 - 2B + Plus Sign

2C # 2C , Comma

2D ENQ Enquiry @ 2D - Minus Sign

2E ACK Acknowledge % 2E Period

2F BEL Bell _ 2F / Slash

30 & 30 0 Zero
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3

31 31 1 One

32 SYN Synchronous Idle 32 2 Two

33 , 33 3 Three

34 PN Punch On 34 4 Four

35 RS Reader Stop + 35 5 Five

36 ucC Upper Case - 36 6 Six

37 37 7 Seven

38 38 8 Eight

39 39 9 Nine

3A 3A Colon

3B CuU3 Customer Use 3 ~ 3B ; Semicolon

3C DC4 Device Control 4 ~ 3C < Less-than Sign
3D NAK Negative Acknowledge 3D = Equal Sign

3E 3E > Greater-than Sign
3F SuB Substitute 3F ? Question Mark
40 SP Space 40 @ At Sign

41 41 A A

42 42 B B

43 43 C C

44 44 D D

45 45 E E

46 46 F F

47 47 G G

48 48 H H

49 49 I I

4A ¢ Cent Sign 4A J J

4B Period 4B K K

4C < Less-than Sign 4C L L

4D ( Left Parenthesis 4D M M

4E + Plus sign 4E N N
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3
4F | Logical Or 4F (0] (0]
50 & Ampersand “ 50 P P
51 51 Q Q
52 52 R R
53 ¢ 53 S S
54 ! 54 T T
55 55 u u
56 56 \Y \Y
57 57 w w
58 58 X X
59 59 Y Y
5A ! Exclamation Point 5A 4 4
5B $ Dollar Sign 5B [ Opening Bracket
5C * Asterisk 5C \ Back Slash
5D ) Right Parenthesis 5D 1 Closing Bracket
5E ; Semicolon 5E A Caret
5F - Logical NOT 5F _ Underline
60 - Minus Sign 60 Grave Accent
61 / Slash 61 a a
62 62 b b
63 63 c c
64 64 d d
65 65 e e
66 66 f f
67 67 g g
68 68 h h
69 69 i i
6A 6A i i
6B , Comma 6B k k
6C % Percent 6C k k
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3

6D _ Underline 6D m m

6E > Greater-than Sign 6E n n

6F ? Question Mark 6F o o

70 # 70 p p

71 71 q q

72 72 r r

73 @ 73 s s

74 $ 74 t t

75 75 u u

76 76 % %

77 77 w w

78 78 X X

79 79 y y

7A Colon 7A z z

7B # Number Sign 7B { Opening Brace

7C @ At Sign 7C | Vertical Line

7D ‘ Apostrophe 7D } Closing Brace

7E = Equal Sign 7E ~ Tilde

7F “ Quotation Mark # 7F DEL Delete

80 a 80

81 a a b 81

82 b b c 82

83 c c d 83

84 d d e 84 IND Index

85 e e f 85 NEL Next Line

86 f f g 86 SSA Start of Selected Area
87 g g h 87 ESA End of Selected Area
88 h h i 88 HTS Horz. Tabulation Set
89 i i i 89 HTJ Horz. Tab w. Justif.
8A k 8A VTS Vertical Tabulation Set
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3

8B | 8B PLD Partial Line Down
8C m 8C PLU Partial Line Up

8D n 8D RI Reverse Index

8E o} 8E SS2 Single Shift 2

8F p 8F SS3 Single Shift 3

90 q 90 DCS Device Control String
91 j j r 91 PU1 Private Use 1

92 k k s 92 PU2 Private Use 2

93 k k t 93 STS Set Transmit State
94 m m u 94 CCH Cancel character

95 n n v 95 MW Message Waiting

96 o} o} w 96 SPA Start of Protected Area
97 p p X 97 EPA End of Protected Area
98 q q y 98

99 r r z 99

9A “ 9A

9B ¢ 9B csli Control Seq.

Introducer
9C ! 9C ST String Terminator
9D 9D OSC Operating System
Cmd.

9E ; 9E PM Privacy Message

9F * 9F APC Applic. Program Cmd.
A0 A A0

A1l B A1l

A2 s s C A2

A3 t t D A3

A4 u u E A4

A5 v v F A5

A6 w w G A6

A7 X X H A7
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3
A8 y y | A8
A9 z z J A9
AA K AA
AB L AB
AC M AC
AD N AD
AE (0] AE
AF P AF
BO Q BO
B1 R B1
B2 S B2
B3 T B3
B4 U B4
B5 \'% B5
B6 w B6
B7 X B7
B8 Y B8
B9 Grave Accent z B9
BA # BA
BB @ BB
BC $ BC
BD BD
BE ; BE
BF * BF
Co Co
C1 A A C1
c2 B B c2
C3 C C C3
C4 D D C4
C5 E E C5
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3
C6 F F C6
c7 G G c7
(01} H H (1]
C9 | | C9
CA CA
CB CB
cC cC
CD CD
CE CE
CF CF
DO DO
D1 J J D1
D2 K K D2
D3 L L D3
D4 M M D4
D5 N N D5
D6 (0] (0] D6
D7 P P D7
D8 Q Q D8
D9 R R D9
DA DA
DB DB
DC DC
DD DD
DE DE
DF DF
EO EO
E1 E1
E2 S E2
E3 T E3
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EBCDIC
Hex | Mnemonic Hex | Mnemonic ASCII
Twinax/LU-1 LU-3
E4 U E4
E5 \Y E5
E6 w E6
E7 X E7
E8 Y E8
E9 Z E9
EA EA
EB EB
EC EC
ED ED
EE EE
EF EF
FO 0 Zero FO
F1 1 One F1
F2 2 Two F2
F3 3 Three F3
F4 4 Four F4
F5 5 Five F5
F6 6 Six F6
F7 7 Seven F7
F8 8 Eight F8
F9 9 Nine F9
FA FA
FB FB
FC FC
FD FD
FE FE
FF FF
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CST Manager Version Control System

The Version Control System (VCS) allows you to assign an application name
and add version information to the files. This information helps you easily
identify the purpose of the files created and in which application. The VCS
prints the application name and version information in the printer’s
configuration printout.

Application Name and Version Information

The application name is a logical user-defined name for the CST application
and is stored inside the CST Configuration file. The maximum length is 16
characters.

The version information contains the following:
* Version Number — V<version>.<revision><release level>
where:
<version> = decimal number (1 ... n)
<revision> = decimal number ( two digits: 00 ... 99)
<release level> = upper-case alphabetic character (A ... ZZ)
Examples: V1.00A (initial version), V2.06C, V3.21AA, V3.21BX.
« Last Modification Date - <month> - <day> - <year>
Indicates when the PAA CST File was last modified.
* File ID — Unique 32-bit hexadecimal number (checksum).

NOTE: The VCS system cannot prevent the creation of two files that contain
the same application name and version information but different
content. To help identify such similar files, the Manager will include a
checksum in the file.

Both the version number and last modification date are stored in the
respective configuration file.
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Creating a New File

When creating and saving a file for the first time, the Set Application Name
dialog box opens prompting you to enter a logical name to identify the
application.

Set Application Name |

,@ Please provide a name that identifies this application.

Enter Name: |CSTEundlei| |

Hote:

The version control system requires an application name.
It is this name that will be displayed on configuration
printouts on printers that support this feature.

OK

Figure 167. Setting the CST Application Name

Opening an Existing File

When you select File -> Open, or upload a file from the printer, the VCS
checks if the file contains version information. If not, a dialog box opens and
prompts you to enter a logical application name. The version number is set to
1.00A. You can then start modifying the application.

Modifying an Existing File

After opening an existing file, the process of building and modifying the
application starts. To save your work as a new file or subsequent
modifications of an existing file, do the following:

« Save As New File

Select File -> Save As. The application name is already assigned and the
version number is 1.00A. Select a folder name, enter a file name, and
click Save. The file is then stored on disk.

196



Application Name and Version Information

e Subsequent Saves

Select File -> Save. The Version Confirmation dialog box opens with save
options. See Figure 168.

Yerzion Confirmation | x| |

?

Application Name: |CBTElundIe1 |

(@ Save with current version V1.004
() Save with new release level V1.00B
i) Save with new revision number  V1.014
i) Save with new version number  Y2.004

OK Cancel

NOTE:

NOTE:

Figure 168. Confirming the File Version

If you do not change the application name, the ‘Save as new
application’ option is disabled. In this case, you must select one of the
first four options. ‘Save with current version’ is the default selection.

If you change the application name, ‘Save as new application’ is
enabled, allowing you to reset the version number to 1.00A.

The version numbers displayed with the options are the version
numbers the CST Manager will store in the file.

Version number increment rules.

When a file reaches release level Z and you select ‘Save with new
release level', the release level increments to AA.

For example, 1.01Z becomes 1.01AA.

When the release level reaches ZZ and the you select ‘Save with new
release level’, the release level resets to A and the revision number
increments. For example, 1.01ZZ becomes 1.02A.

When the revision number reaches 99 and you select ‘Save with new
revision number’, the revision number resets to 00, the release level
resets to A, and the version number increments.

For example, 1.99C becomes 2.00A.

197



Chapter 5 CST Manager Version Control System

Viewing File Version Information

To view version information of a file, select File -> Properties.

File Properties | x| |

I@ Application Name: CS5TBundle1
Version: \V1.004

Checksum: A8109054

Last Modified: 28-May-08

OK

Figure 169. Viewing File Properties

Automatic File Backup System

The CST Manager automatically creates backups of the last 20 saved
versions of a file. This backup system uses the file name (as specified in the
File Save As ... dialog) to create the following file and folder structure:

< jav.user.dinbackup > - the java user directory is the PMU install directory.
< File Name > - folder that will store the backups.
< ~ddmmyyyy_hhmmss>.bck - backup of the latest previous version of a file.

< ~ddmmyyyy _hhmmss>.bck - backup of the second latest previous version
of afile

< ~ddmmyyyy_hhmmss>.bck - backup of the oldest previous version of the
file.

Example:

File name = ‘INFOPRINT_SecurePrinting.gcf
< jav.user.dinbackup >
INFOPRINT_SecurePrinting
~11042008_123145.bck
~11042008_124432.bck

~11042008_145022.bck
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Backup History

The CST Manager has a Backup History option that allows you to view the
backup history of a file. The system maintains the last 20 versions of the file.
This dialog has options to clear the history, open an older version, and save
under a different file name.

B Backup History for [ D:\Java Projects\MATKY TestApp.gpf]

Marme Wersion | Checksum Date Time
Testipp W1.00A [TATDCIAA (22 Apr 2008 |11:36:33 |Created on save by ICSPI||
_Testhpp W1.00A |[CDET2ZABQ |22 Apr 2008 |11:36:116 |Created on save by I3F'I||
_TestApp W1.004 [EGS9FBRD [22 Apr2008  [11:36:01 |Created on save by GPI|
_Testipp W1.00A  [321CAABE |22 Apr 2008 113546 |Created on save by GPI||
_Testipp W00A  [143DAC4D |22 Apr 2008 |11:35:37 |Created on save by I3F'I||
_TestApp W1.00A [IGIEBFF7 [22 Apr2008 [11:27:20 |Created on save by GPI|
_Testipp W1L00A  [TATDCISA |22 Apr 2008 |11:11:08 |Created on save by GPI||
_Testipp Y1004 |E9S9FESD |22 Apr2008 111012 |Created on save by ICSPI||
_Testhpp W .00A  |26F503148 |22 Apr 2008 |11:09:58 |Created on sawve by GPI||
_Testipp W1.00A  [TATDCIGA |22 Apr 2008 [10:6213 |Created on sawve by GPI||
_Testipp W1.00A [TEDFO811 |22 Apr 2008 |10:38:24 |Created on save by ICSPI||
_Testhpp W.00A  |GEFBZEDF |22 Apr 2008 |09:46:11 |Created on save by I3F'I||
Events-01 W1.004 |[BCIABBCE|16 Apr 2008 |11:03:26 |Created an save by GF'I||
1] Il | I »‘
| Clear | ‘ Open ‘ | Save As ‘ | Close ‘

Figure 170. Backup History Information

» Name - displays the application name assigned to the file at the time the
backup was created.

» Version - displays the version assigned to the file at the time the backup
was created.

e Checksum - displays the checksum calculated over the data of the file at
the time the backup was created.

« Data and Time - shows when the backup file was created.

* Notes - displays which version of the CST manager the backup file was
created.

» Clear button - clears the history.
»  Open button - opens the backup file for editing.

e Save As button - saves a backup file under a different name to a local
storage medium.

» Close button - closes the dialog.
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Notices

This information was developed for products and services offered in the
U.S.A.

InfoPrint Solutions Company may not offer the products, services, or features
discussed in this document in other countries. Consult your local InfoPrint
Solutions Company representative for information on the products and
services currently available in your area. Any reference to an InfoPrint
Solutions Company product, program, or service is not intended to state or
imply that only that InfoPrint Solutions Company product, program, or service
may be used. Any functionally equivalent product, program, or service that
does not infringe any InfoPrint Solutions Company intellectual property rights
may be used instead. However, it is the user’s responsibility to evaluate and
verify the operation of any non-InfoPrint Solutions Company product,
program, or service.

InfoPrint Solutions Company may have patents or pending patent applications
covering subject matter described in this document. The furnishing of this
document does not give you any license to these patents. You can send
license inquiries, in writing, to:

InfoPrint Solutions Company, LLC
6300 Diagonal Hwy 002J
Boulder, CO 80301-9270

U.S.A.

The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INFOPRINT SOLUTIONS COMPANY PROVIDES THIS PUBLICATION “AS
IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not
apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
be incorporated in new editions of the publication. InfoPrint Solutions
Company may make improvements and/or changes in the product(s)
described in this publication at any time without notice.

Any references in this information to non-InfoPrint Solutions Company Web
sites are provided for convenience only and do not in any manner serve as an
endorsement of those Web sites. The materials at those Web sites are not
part of the materials for this InfoPrint Solutions Company product and use of
those Web sites is at your own risk.
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InfoPrint Solutions Company may use or distribute any of the information you
supply in any way it believes appropriate without incurring any obligation to
you.

Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:

InfoPrint Solutions Company, LLC
6300 Diagonal Hwy 002J
Boulder, CO 80301-9270

US.A.

Such information may be available, subject to appropriate terms and
conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by InfoPrint Solutions Company under terms of
the InfoPrint Solutions Company Customer Agreement, InfoPrint Solutions
Company International Program License Agreement or any equivalent
agreement between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments
may vary significantly. Some measurements may have been made on
development-level systems and there is no guarantee that these
measurements will be the same on generally available systems. Furthermore,
some measurement may have been estimated through extrapolation. Actual
results may vary. Users of this document should verify the applicable data for
their specific environment.

Information concerning non-InfoPrint Solutions Company products was
obtained from the suppliers of those products, their published announcements
or other publicly available sources. InfoPrint Solutions Company has not
tested those products and cannot confirm the accuracy of performance,
compatibility or any other claims related to non-InfoPrint Solutions Company
products. Questions on the capabilities of non-InfoPrint Solutions Company
products should be addressed to the suppliers of those products.

COPYRIGHT LICENSE:

This information contains sample application programs in source language,
which illustrates programming techniques on various operating platforms. You
may copy, modify, and distribute these sample programs in any form without
payment to InfoPrint Solutions Company, for the purposes of developing,
using, marketing or distributing application programs conforming to the
application programming interface for the operating platform for which the
sample programs are written. These examples have not been thoroughly
tested under all conditions. InfoPrint Solutions Company, therefore, cannot
guarantee or imply reliability, serviceability, or function of these programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.



References in this document to InfoPrint Solutions Company products,
product features, programs or services do not imply that InfoPrint Solutions
Company intends to make such products, product features, programs or
services available in all countries in which InfoPrint Solutions Company
operates or does business.

Trademarks

These terms are trademarks or registered trademarks of Ricoh Co., Ltd., in
the United States, other countries, or both:

¢ InfoPrint
¢ Infoprint
* Ricoh

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corporation in the United States, other
countries, or both. If these and other IBM trademarked terms are marked on
their first occurrence in this information with a trademark symbol (® or ™),
these symbols indicate U.S. registered or common law trademarks owned by
IBM at the time this information was published. Such trademarks may also be
registered or common law trademarks in other countries. A current list of IBM
trademarks is available on the Web at "Copyright and trademark information”
at www.ibm.com/legal/copytrade.shtml

Other company, product, or service names may be trademarks or service
marks of others.

Software License Agreement

CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS
BEFORE USING THIS PRODUCT. INSTALLATION INDICATES YOUR
ACCEPTANCE OF THESE TERMS AND CONDITIONS. PROMPTLY
REMOVE ALL FILES RELATED TO THIS PRODUCT FROM YOUR HOST
PLATFORM SHOULD YOU DISAGREE WITH ANY OF THE TERMS OR
CONDITIONS LISTED BELOW.

1. “Software” shall mean the digitally encoded, machine readable data and
program. The term “Software Product” includes the Software identified on
the distribution media and any accompanying documentation. The term
“Distribution Media” refers to any method by which the Software Product
is delivered to the end user, including but not limited to Floppy Disks,
CD-ROM, Magnetic Tape and On-Line distribution via the Internet. The
Software Product is licensed (not sold) to you, and Printronix®, Inc. either
owns or licenses from other vendors who own, all copyright, trade secret,
patent and other proprietary rights in the Software Product.

2. You agree to accept a non-exclusive license to use the Software
identified on the distribution media solely for your own customary
business or personal purposes.
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10.

To protect the proprietary rights of Printronix, Inc., you agree to maintain
the Software Product and other proprietary information concerning the
Software Product in strict confidence and to establish reasonable
procedures regulating access to and use of the software.

You agree not to duplicate or copy the Software except that you may
make one backup copy. You agree that any such copy shall contain the
same proprietary notices as those appearing on the original.

You shall not sublicense, sell, lease, or otherwise transfer all or any
portion of the Software Product separate from the printer(s), without the
prior written consent of Printronix, Inc.

You may not modify or prepare derivative works of the Software Product.
You may not transmit the Software Product over a network, by telephone,
or electronically using any means; or reverse engineer, decompile or
disassemble the Software.

You may transfer the Software Product with the printer(s), but only if the
recipient agrees to accept the terms and conditions of this Agreement.
Your license is automatically terminated if you transfer the Software
Product and printer(s).

This License shall continue until terminated. This license may be
terminated by agreement between you and Printronix, Inc. or by
Printronix, Inc. if you fail to comply with the terms of this License and such
failure is not corrected within thirty (30) days after notice. When this
License is terminated, you shall either return to the place you obtained
them, or destroy, the printer and all copies of the Software and
documentation.

Printronix, Inc. warrants that for ninety (90) days after delivery, the
Software will perform in accordance with specifications published by
Printronix, Inc., and that the distribution media will be free from defects in
material and workmanship. Printronix, Inc. does not warrant that the
Software is free from all bugs, errors and omissions.

THE PARTIES AGREE THAT ALL OTHER WARRANTIES, EXPRESS
OR IMPLIED, INCLUDING WARRANTIES OF FITNESS FOR A
PARTICULAR PURPOSE AND MERCHANTABILITY ARE EXCLUDED.

Your exclusive remedy and the sole liability of Printronix, Inc. in
connection with the Software is replacement of defective distribution
media upon their return to Printronix, Inc. Printronix, Inc. will not be liable
for any loss or damage caused by delay in furnishing a Software Product
or any other performance under this Agreement. Printronix does not w
arrant that the functions contained in the Software will meet your
requirements or that the operation of the Software will be uninterrupted or
error free. Printronix reserves the right to make changes and/or
improvements in the Software without notice at any time.

IN NO EVENT WILL PRINTRONIX, INC. BE LIABLE FOR LOST
PROFITS, LOST DATA, BUSINESS INTERRUPTIONS OR ANY OTHER
DIRECT, INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES
ARISING OUT OF THE USE OF OR INABILITY TO USE THIS
PRODUCT, EVEN IF PRINTRONIX HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES, OR ANY DAMAGES CAUSED BY
ABUSE OR MANIPULATION OF THE SOFTWARE. SOME STATES DO
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NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR
CONSEQUENTIAL OR INCIDENTAL DAMAGES, SO THE ABOVE
LIMITATION MAY NOT APPLY TO YOU.

. California law governs this Agreement.
12.

Use, duplication or disclosure by the Government is subject to restrictions
as set forth in the Rights in Technical Data and Computer Software
clause at FAR 242.227- 7013, subdivision (b) (3) (ii) or subparagraph (c)
(1) (ii), as appropriate. Further use, duplication or disclosure is subject to
restrictions applicable to restricted rights software as set forth in FAR
52.227-19 (c) (2).

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT,
UNDERSTAND IT, AND AGREE TO BE BOUND BY ITS TERMS AND
CONDITIONS. NEITHER PARTY SHALL BE BOUND BY ANY
STATEMENT OR REPRESENTATION NOT CONTAINED IN THIS
AGREEMENT. NO CHANGE IN THIS AGREEMENT IS EFFECTIVE
UNLESS WRITTEN AND SIGNED BY PROPERLY AUTHORIZED
REPRESENTATIVES OF EACH PARTY. BY INSTALLING THIS
SOFTWARE PRODUCT, YOU AGREE TO ACCEPT THE TERMS AND
CONDITIONS OF THIS AGREEMENT.
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A
Access Method sub-tab, 61
After attribute, 159
Alert Delivery tab, 45
Alert Log, 45
Alert, email, 46
Application Name
CST, 195
Applications
Configuration Editor, 67
CST Manager, 148
Factory Settings Differences, 77
File Download, 86
Flash File Manager, 82
Information Capture, 112
Job Capture, 117
Media Profiler, 100
ODV Quality Wizard, 115
Operator Panel, 108
Speed Keys, 116
Applications menu, printer database, 37
Assign IP Address, 142
Attributes
Before/After, 159
Count, 159
Don’t Care, 158
Don’t Care Except, 158
Flush, 159
Ignore Case, 159
Include, 159
Insert Pattern, 159
Insert Variable, 159
Match, 158
Parameter, 159
Start/End, 159
Auto delimiter example, 168

Index

Backup History, GPIO, 199

Before attribute, 159
Broadcast Address, 142

Changing
configurations, 69

IP addresses, web access, 124
user password, web access, 122

user settings, 124

Character Substitution Table Manager

See CST Manager
Cisco EAP, 136

Collapse database tree, 33

Conditions list, 180

Conditions, how to use, 181

Configuration Editor, 67

changing configurations, 69
creating configurations, 68

Menu Editor, 70
menu tree, 68
Migration, 73
tab, 27

Configuration Editor tab, Preferences, 27
Configuration Printout, 113
Configuration Settings Differences Views, 80

Configurations, 72

Configurations, downloading, 72, 86

Configure Macro, 139

Configure Print Servers, 145

Connections tab, 61
Control panel
See Operator Panel

C

Copy item in database, 32

Count attribute, 159
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Create Download

configurations, 68 configurations, 73, 86
database file, 25 examples, 92
Credentials, 135 flash files, 86
CST program files, 86
application name, 195
Version Control System, 195 E
version information, 195 EAP tab, 136
CST Input field, 153 EBCDIC, 186
CST Manager EBCDIC/ASCII table, 186
CST bundles, 154 Edit Information, 161
Edit, 149 Edit menu, printer database, 32
File, 149 Email Alerts, 46
Input/Output fields, 153 EMC, 82
listing field, 154 Enable Remote Printer Management, 143
Tools, 150 End attribute, 159
CST Off mode, 156 Entry On/Off flag, 161
CST On mode, 156 Error Logs
CST Output field, 153 PMU, 24
Cut item from database, 32 printer, 113
Example
D Auto delimiter, 168
Data From, 119 Pattern Recognition, 170
Database File Name, 26 Status Response Definition, 182
Database file, create, 25 Excluding item in database, 33
Database tree, 23 Expand database tree, 33
Datastream adapter, 147 Expanded Memory Cartridge, 82
Dec./Inc. Key, 27
Defining printer properties, 56 F
Delete Factory Settings Differences, 77
configurations, 70 configuration settings differences views, 80
item from database, 33 displayed language, 81
Delimiter, 167 menu bar, 78
Directory, 114 toolbar, 79
Discover Printers, 38 File Backup System
Discovery GPIO, 198
Known Printers, 42 File Download, 86
Polled, 41 File menu, printer database, 25
Print Server, 39 Flash file download, 86
Discovery tab, 39 Flash File Manager, 82
Display Command Codes, 119 Flush attribute, 159
Displayed Language, factory settings Flush mode, 155
differences, 81 Fonts, foreign language, 15
Don’t Care attribute, 158 Foreign language fonts, 15
Don’t Care Except attribute, 158 limitations, 15

Windows setup, 15
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Formatted Pattern List, 168
Formatted Pattern Tab, 166

G

General sub-tab, 29
General tab, 129
Getting started, 17
GPIO
Backup History, 199
file backup system, 198

H
Hardware Address, 142
Hardware requirements, 9
Help menu, printer database, 52
Hide Key/Unhide Key, 27
Hiding menu items, 71

Identification tab, 57
Ignore Case attribute, 159
Include attribute, 159
Including item in database, 33
Information Capture, 112
Configuration Printout, 113
Directory, 114
File, 113
Information tab, 65
Input field, CST, 153
Input/Output fields, 153
Insert item in database, 32
Insert mode, 155
Insert Pattern attribute, 159
Insert Variable attribute, 159
Installation, 9
IP addresses, web access, changing, 124

J

Job Capture, 117
Capture, 119
File, 118
Options, 120
Search, 118
Triggers, 120
View, 119

KDC sub-tab, 133
Kerberos

Credentials, 135

KDC, 133

Print Server, 132

Set Password, 134
Known Printers Discovery, 42

L
Lease Time on Printer Connection, 26
Lock/Unlock Menus, 144
Login to the PMU web site, 122

M
Macro Settings tab, Preferences, 29
Macro Utility, 138
Making changes on the menu tree, 69
Match attribute, 158
Media Profiler, 100
Menu Bar, factory settings differences, 78
Menu bar, printer database
Applications, 37
Edit, 32
File, 25
Help, 52
Status, 38
Utilities, 51
View, 33
Menu Editor, 70
Menu tree, 68
Migration, 73
Mode
CST Off, 156
CST On, 156
Flush, 155
Insert, 155
PAA Event, 157
Remove, 155
Replace, 155
Reset, 156
Reset All Variables, 157
Response, 157
Select CST, 156
Skip GFX, 156
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Store, 157
Transparent, 156

N
Naming configurations, 70
Network sub-tab, 30, 62
New Gateway, 142
New IP Address, 142
New Mask, 142

0]
ODV Quality Wizard, 115
Open
configuration file, 72
database file, 25
Operator Panel, 108

6400 Series line matrix printer, 109
6500 Series line matrix printer, 109
6700/4400 Series thermal printer, 110
6700-M40 Series thermal printer, 110

Disabled indicator, 111
in progress indicator, 111
message display, 111
primary operator keys, 111
secondary operator keys, 111
status indicator, 111

Output field, CST, 153

P
PAA Event mode, 157
Parameter attribute, 159
Password, printer

setting, 127

Supervisor, 58

Telnet guest, 58

Telnet root, 58

User, 58
Paste item into database, 33
Pattern Character List, 163
Pattern Character Tab, 162
Pattern List, 165
Pattern Recognition example, 170
Pattern Tab, 164
Patterns / Variables, 162
Patterns, how to use, 169
Polled Discovery, 41
Polling tab, 43
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Preferences, 25, 26
Configuration Editor, 27
General, 29
Macro Settings, 29
Network, 30
Printer Database, 26
Serial, 31
Servers, 28

Primary operator keys, 111

Print Server Discovery, 39

Print Server sub-tab, 132

Printer database
items, 55
main window, 23
menu tree, 23
toolbar, 53

Printer Database tab, Preferences, 26

Printer discovery, 38

Printer list page, 123

Printer Properties
Access Method, 61
Connections, 61
defining, 56
Identification, 57
Information, 65
Network, 62
passwords, 58
Security, 58
Serial/Modem, 63

Printer setup, 10

Program file download, 86

Protocol list, 181

Protocols, 180

Protocols, how to use, 181

R
RADIUS server, 136
Reboot Printer, 127
Recovery file, 99
Remove mode, 155
Replace mode, 155
Requirements, 9
Reset All Variables mode, 157
Reset mode, 156
Response mode, 157

Restoring configurations and flash files, 90



S

Save
configuration files, 72
database file, 25
Save As, 25
Search Again, 119
Search Captured Data, 119
Secondary operator keys, 111
Security, 26
Security tab, 58
Select CST mode, 156
Serial sub-tab, 31
Serial/Modem sub-tab, 63
Servers tab, Preferences, 28
Set Password sub-tab, 134
Set Printer Password, 127
Set Wireless Properties, 129
Skip GFX mode, 156
SNMP Browser, 141
SNMP Trap Server, 28
Software requirements and installation, 9
Speed Keys, 116
Start attribute, 159
Status and Error Log, 24
Status bar, 154
Status Bits, 180, 183
Status menu, printer database, 38
Status Monitoring Properties, 39
Status Response Definition, 179

Status Response Definition example, 182

Status update, 49

Store mode, 157

Style of database tree, 34
Supervisor password, 58
Syslog Posting, 48

T

Telnet guest password, 58
errors, 59
Telnet root password, 58
errors, 60
Toolbar, 36, 53
Toolbar, factory settings differences, 79
Transparent mode, 156
Tutorial, getting started, 17

U

Unhiding menu items, 71
Update Status, 49
Uploading configurations, 73
Use Once flag, 160
User password, 58
User settings, changing, 124
Utilities

Assign IP Address, 142

Configure Print Servers, 145

Enable Remote Printer Management, 143

Lock/Unlock Menus, 144
Reboot Printer, 127
Set Printer Password, 127
Set Wireless Properties, 129
SNMP Browser, 141
Utilities menu, printer database, 51
Utility, Macro, 138

Vv

Variable List, 178
Variable Tab, 178
VCS

CST, 195
Version Control System

CST, 195
Version Information

CST, 195
View menu, printer database, 33
Viewing configurations, using Information
Capture, 112
Viewing Error logs, 113
Virtual Operator Panel

See Operator Panel

W

Web access
changing IP addresses, 124
changing user settings, 124
Web Server, 28
Web site
changing the user password, 122
login, 122
printer list page, 123
URL address, 121
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WEP Encryption tab, 131
Wireless properties, set, 129
WPA tab, 137

X
XML Server, 28
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