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WarpZ2 Installation

For PC’s:

Installing Warp2 on your IBM PC or compatible computer

requires about 55 Megabytes of hard disk space. The installation
procedure is as follows:

1. Write down the serial number found on the first disk;
you will be asked for it later.

2. Insert disk 1 into a floppy disk drive.
3. Select File/Run from the Windows program manager.

4. Typea:installorb:install, as appropriate, and
select OK.

5. Answer questions from the installation script.

Note that if you choose the option to create example DOS
configuration files, the files are created with a ".exm" extension,
e.g., the example file for "autoexec.bat" would be "autoexec.exm".
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Note also that the example file only contains the difference
between the old and new files, not a complete copy. Because of
this, Cypress recommends that you simply choose the option to
go ahead and modify the originals. The installation procedure
copies the original file to a ".bak" extension. Example files
"win.exm" and "system.exm," found in your Windows directory,
are also created.

_G___.
NOTE

IMPORTANT DOS REMINDER...

Your PATH must be shorter than 128 characters.
This is a DOS limitation.

IMPORTANT WINDOWS TIPS...

1. The Optimizing Windows chapter of the
Microsoft Windows User’s Guide includes numer-
ous ideas to increase performance. We especially
recommend creating a SMARTdrive of 1 to 2
Megabytes. We aiso recommend a Windows 3.1
virtual memory size of 16 Megabytes.

2. Some PC clones utilize the upper portion of the
first megabyte of memory in a manner that con-
flicts with Windows. If any Warp2 (or other) appli-
cation “hangs,” try adding the following line to your
SYSTEM.INI file (found in the Windows directory)
in the section marked as indicated:

[386Enh]
EMMexclude=A000-FFFF

After adding this line, re-start Windows. If the

problem persists, consult your PC manufacturer
for additional assistance.

Warp2 Installation
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For Sun:

Installing Warp2 on your Sun workstation requires about
38 Megabytes of hard disk space. The installation procedure is as
follows:

1. Ifit does not already exist, create the directory where
you want the software to be located.

2. Forinstallation from a tape, tar the contents of the tape,
run the install script and answer the questions:

tiger% mkdir /usr/local/warp
tiger% cd /usr/local/warp
tiger% tar xvf /dev/rst8
tiger% ./install

For installation from disks, insert the first disk and bar
the contents before running the install script:

tiger% mkdir /usr/local/warp
tiger% cd /usr/local/warp
tiger% bar xvfZ /dev/rfd0
tiger% ./install

3. When asked for the serial number, simply enter your
company name, or copy the number from the tape (or
first disk) label.

4. In your .cshrc or .login file, set a variable called
CYPRESS_DIR pointing to your install directory. Make
sure your path includes /your_Cypress_directory/bin.

For example:

setenv CYPRESS_DIR /usr/local/warp
set path=($path $CYPRESS_DIR/bin)
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If you are installing Warp2, skip immediately to Step 7.
If you are installing Warp2+, perform Steps 5 and 6 at
this time.

5. Set your pASIC environment variables in your .cshre file
as follows:

setenv SPDE_ROOT $CYPRESS_DIR/spde
setenv XVTPATH $SPDE_ROOT/print
setenv UIDPATH $SPDE_ROOT/%N.uid
set path=($path $SPDE_ROOT)

6. Copy the pASIC configuration file into your home
directory:

cp SCYPRESS_DIR/spde/.spderc $HOME

7. By default on the Sun Sparc, the Galaxy and Nova
interfaces use the OpenLook toolkit. If the user wishes to
use the Motif interface instead, set the environment
variable CYPRESS_MOTIF to TRUE.

For example:
setenv CYPRESS_MOTIF TRUE

Adding this command to your .login or .cshrc files will
make this interface change permanent.

4 Warp2 Installation
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Cypress Software License Agreement

1. LICENSE. Cypress Semiconductor Corporation
(“Cypress”) hereby grants you, as a Customer and Lic-
ensee, a single-user, non-exclusive license to use the
enclosed Cypress software program (“Program”) on a sin-
gle CPU at any given point in time. Cypress authorizes
you to make archival copies of the software for the sole
purpose of backing up your software and protecting your
investment from loss.

2. TERM AND TERMINATION. This agreement is effective
from the date the diskettes are received until this agree-
ment is terminated. The unauthorized reproduction or use
of the Program and/or documentation will immediately
terminate this Agreement without notice. Upon termina-
tion you are to destroy both the Program and the docu-
mentation.

3. COPYRIGHT AND PROPRIETARY RIGHTS. The Pro-
gram and documentation are protected by both United
States Copyright Law and International Treaty provi-
sions. This means that you must treat the documentation
and Program just like a book, with the exception of mak-
ing archival copies for the sole purpose of protecting your
investment from loss. The Program may be used by any
number of people, and may be moved from one computer to
another, so long as there is No Possibility of its being
used by two people at the same time.

4. DISCLAIMER. THIS PROGRAM AND DOCUMENTA-
TION ARE LICENSED “AS-IS,” WITHOUT WARRANTY
AS TO PERFORMANCE. CYPRESS EXPRESSLY DIS-
CLAIMS ALL WARRANTIES, EXPRESSED OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE
IMPLIED WARRANTY OF MERCHANTABILITY OR
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FITNESS OF THIS PROGRAM FOR A PARTICULAR
PURPOSE.

5. LIMITED WARRANTY. The diskette on which this Pro-
gram is recorded is guaranteed for 90 days from date of
purchase. If a defect occurs within 90 days, contact the
representative at the place of purchase to arrange for a
replacement.

6. LIMITATION OF REMEDIES AND LIABILITY. IN NO
EVENT SHALL CYPRESS BE LIABLE FOR INCIDEN-
TAL OR CONSEQUENTIAL DAMAGES RESULTING
FROM PROGRAM USE, EVEN IF CYPRESS HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
CYPRESS’S EXCLUSIVE LIABILITY AND YOUR
EXCLUSIVE REMEDY WILL BE IN THE REPLACE-
MENT OF ANY DEFECTIVE DISKETTE AS PROVIDED
ABOVE. IN NO EVENT SHALL CYPRESS’S LIABILITY
HEREUNDER EXCEED THE PURCHASE PRICE OF
THE SOFTWARE.

7. ENTIRE AGREEMENT. This agreement constitutes the
sole and complete Agreement between Cypress and the
Customer for use of the Program and documentation.
Changes to this Agreement may be made only by written
mutual consent.

8. GOVERNING LAW. This Agreement shall be governed by
the laws of the State of California. Should you have any
question concerning this agreement, please contact:

Cypress Semiconductor Corporation
Attn: Legal Counsel

3901 N. First Street

San Jose, CA 95134-1599

408-943-2600
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Chapter

Warp2 Process
1 Overview

About This Chapter

Overview

This chapter provides an overview of the design process using
Warp2 tools.

Warp2 Overview
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1.1. What do you do with Warp2?

Warp2 is a collection of tools for designing and synthesizing circuits to
be transferred to programmable logic devices. The Warp2 tool set comes
in two versions: Warp2 (for targeting PLDs) and Warp2+ (for targeting
PLDs and pASIC380 FPGAs).

With Warp2, you can:

¢ use VHDL descriptions (structural, behavioral, or both) to
describe a design.

¢ compile and synthesize the resulting design description.
“Compile” means check the design description to make
sure it’s syntactically correct and contains no obvious
logical errors, such as unconnected inputs, etc.
“Synthesize” means convert the design description into a
mapping file that can be transferred to a programmable
device.

® create a program file for any supported programmable
logic device (PLD).

With Warp2+, you can also target pASIC380 FPGAs.

There are other tasks you can perform, but at the highest
conceptual level, that’s it in a nutshell.

1-2 | Warp2 Overview
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Figure 1-1. Warp2 Conceptual Process Flow.
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1.2. What kinds of devices can | target using Warp2?

Warp2 supports a wide variety of Cypress programmable devices.
Warp2 features a common user interface so that the process of targeting
one device is much like that of targeting any other.

Table 1-1 lists the parts for which you can target designs when
using Warp2. These parts can be divided into five families:

1-4

PLDs: the bulk of the Cypress programmable logic device
family.

MAX CPLDs: the Cypress high-density complex PLD
family.

FLASH370 CPLDs: the Cypress high-speed, high-density
FLASH complex PLD family.

pASIC380 FPGAs: the Cypress very-high-speed CMOS
FPGA family (supported in Warp2+ and Warp3).
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Table 1-1.
Warp2-Supported Parts
Family Part #’s
PLDs C16L8 C16R4 C16R6 C16R8
C16V8 C20G10  C20G10C C20RA10
C22V10  C22VP10 (331 C335
MAX C341 C342 C343 C344
CPLDs C346 C346H
FLASH370 | C371 C374 C375
CPLDs
pASIC380 | C381A C382A C383A C384A
FPGAs! C385A C386A

1. Supported in Warp2+ only.
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1.3.

What’s the design process in Warp2?

The usual order of design in Warp2 is as follows: (1) describe the design
in VHDL; (2) compile and synthesize; (3) process QDIF file (when
targeting pASIC380 FPGAs only); and (4) program the target device.

1-6

You can describe designs in Warp2 behaviorally, structurally, or
using a combination of both.

As their name implies, behavioral descriptions specify the way a
design behaves. Behavioral descriptions take the form of text
files containing statements written in a hardware description
language. In the case of Warp2, this hardware description
language is VHDL. Automated tools convert the behavioral
description into circuit structure that implements the specified
behavior.

In the Warp2 system, you write a VHDL source file that
describes your design’s behavior, then you use the Warp VHDL
synthesis compiler to synthesize a circuit that implements that
behavior.

Structural descriptions specify the components that make up a
design, as well as how they are connected (like a netlist).
Structural descriptions can be included in VHDL source files.

Descriptions can be hierarchical; that is, a design at one level can
use a component described at a lower level. Once a design is
completely described, whether behaviorally or structurally, Warp
compiles and synthesizes this representation, i.e., converts it into
a format that can either be directly programmed onto a PLD or
CPLD, or that can be processed further to program pASIC380
FPGAs (Warp2+ and Warp3 only).

Warp2 Overview
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1. Describe design
- text (VHDL) - text editor

[2. Compile and synthesize - Warp

3. Process QDIF (pASIC only) - SpDE

——— 1 4. Simulate - Nova

correct

-}

Yy v

5. Create program file

functionality?

Figure 1-2. Warp2 Process Overview (Detailed).
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1.4. What are “parts libraries,” and why should | know about them?

Parts libraries are directories in which VHDL descriptions of

components are stored. A comprehensive set of parts libraries comes
with Warp2.

Warp2 provides libraries containing the following types of
components:

* adders

* multipliers

® counters

* common logic gates

* input/output components
* memory elements

* multiplexers

* registers

¢ shifters

¢ TTL components.

You can open the VHDL description of any library component for
viewing with any text editor. The default location of the VHDL
descriptions of library components is:

\WARP\LIB\COMMON\ FAMILY.VHD

where family is the generic name of a particular component
group (e.g., COUNTER.VHD, GATES.VHD).
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To instantiate a component in a VHDL description, use a VHDL
component instantiation statement. See the description of
components in Chapter 5 of the Warp Synthesis Compiler
Manual.

For more information about the libraries, refer to the Warp
System Library Manual.
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1.5.

Where can | call if | have problems?

Cypress Semiconductor has offices around the world. If you need
information about (or if you experience any difficulties using) any
Cypress product, call one of the numbers listed below.

1-10

Country Toll- Free Number Country Toll-Free Number
N. America | 1-800-419-1481 Japan 0031-11-1731
Australia 0014-800-125-203 | Korea 008-1-800-942-8203
Belgium 11-8729 Netherlands | 06-022-5303
Denmark 8001-0413 Norway 050-12068
Finland 9800-10065 Singapore 800-1758
France 05-90-1251 Spain 900-99-1163
Germany 0130-81-1902 Sweden 020-795-637
Hong Kong | 800-7214 Switzerland | 045-05-8808
Israel 00-17-942-1803 UK 0800-89-7339
Italy 1678-97-034
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Warp2 Tools

About This Chapter

Overview

Warp2 comprises a set of tools for creating and synthesizing
designs for programmable logic devices. This chapter describes
each tool in the set.
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21. Galaxy

Galaxy is the graphical user interface for Warp, Warp2’s VHDL
compilation and synthesis tool.

To bring up Galaxy on an IBM PC or compatible, double-click on
the GALAXY icon within the Warp2 or Warp2+ program group.

To bring up Galaxy on a Unix workstation, type “galaxy &<CR>"
from the command line.

To run Warp directly (i.e., without the Galaxy user interface),
type a Warp command line at the shell prompt. See Chapter 2 of
the Warp Synthesis Compiler Manual for more information about
the Warp command line.

For complete information on Warp and Galaxy, see the Warp
Synthesis Compiler Manual.
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22. Warp

Warp is Warp2’s VHDL synthesis compiler.

Warp takes a VHDL description of a circuit as input. Warp
produces JEDEC files (used for programming PLDs) or QDIF
files (used by the SpDE tools when targeting pASIC380 FPGAs).!

For complete documentation of Warp and Galaxy, see the Warp
Synthesis Compiler Manual.

1. available with Warp2+ and Warp3 only.
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23.

Nova

Nova is Warp2’s JEDEC functional simulator.

2-4

The Nova user interface gives you an easy way to:

specify JEDEC files to simulate;
read or write stimulus files;

edit input waveform traces;
simulate the behavior of a design;

alternate between various views (i.e., collections of
signals), and specify signals to include in each view;

specify the length and resolution of a simulation;
specify segments, where you can re-apply and edit initial
conditions, in order to compare results of differing initial

conditions side-by-side;

and lots of other useful capabilities.

For complete documentation of the Nova simulator, see the Nova
User’s Manual, which comes as part of the Warp2 documentation

set.
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2.4. Place & Rte

The “Place&Rte” tool processes a QDIF file (generated by Warp) in
order to target pASIC380 FPGA’s. This tool is available with Warp2+
and Warp3 only.

The “Place&Rte” tool is a tool provided by QuickLogic, a Cypress
technology partner.

Place&Rte is used to perform automatic placement and routing,
delay modeling, critical-path timing analysis, automatic test
vector generation, and device programming and test.

For more information about the Place&Rte tool, see the SpDE/
Warp System User’s Manual, included in the Warp2
documentation set.
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Cypress Software License Agreement

1. LICENSE. Cypress Semiconductor Corporation
(“Cypress”) hereby grants you, as a Customer and Lic-
ensee, a single-user, non-exclusive license to use the
enclosed Cypress software program (“Program”) on a sin-
gle CPU at any given point in time. Cypress authorizes
you to make archival copies of the software for the sole
purpose of backing up your software and protecting your
investment from loss.

2. TERM AND TERMINATION. This agreement is effective
from the date the diskettes are received until this agree-
ment is terminated. The unauthorized reproduction or use
of the Program and/or documentation will immediately
terminate this Agreement without notice. Upon termina-
tion you are to destroy both the Program and the docu-
mentation.

3. COPYRIGHT AND PROPRIETARY RIGHTS. The Pro-
gram and documentation are protected by both United
States Copyright Law and International Treaty provi-
sions. This means that you must treat the documentation
and Program just like a book, with the exception of mak-
ing archival copies for the sole purpose of protecting your
investment from loss. The Program may be used by any
number of people, and may be moved from one computer to
another, so long as there is No Possibility of its being
used by two people at the same time.

4. DISCLAIMER. THIS PROGRAM AND DOCUMENTA-
TION ARE LICENSED “AS-IS,” WITHOUT WARRANTY
AS TO PERFORMANCE. CYPRESS EXPRESSLY DIS-
CLAIMS ALL WARRANTIES, EXPRESSED OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE
IMPLIED WARRANTY OF MERCHANTABILITY OR
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FITNESS OF THIS PROGRAM FOR A PARTICULAR
PURPOSE.

5. LIMITED WARRANTY. The diskette on which this Pro-
gram is recorded is guaranteed for 90 days from date of
purchase. If a defect occurs within 90 days, contact the
representative at the place of purchase to arrange for a
replacement.

6. LIMITATION OF REMEDIES AND LIABILITY. IN NO
EVENT SHALL CYPRESS BE LIABLE FOR INCIDEN-
TAL OR CONSEQUENTIAL DAMAGES RESULTING
FROM PROGRAM USE, EVEN IF CYPRESS HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
CYPRESS’S EXCLUSIVE LIABILITY AND YOUR
EXCLUSIVE REMEDY WILL BE IN THE REPLACE-
MENT OF ANY DEFECTIVE DISKETTE AS PROVIDED
ABOVE. IN NO EVENT SHALL CYPRESS’S LIABILITY
HEREUNDER EXCEED THE PURCHASE PRICE OF
THE SOFTWARE.

7. ENTIRE AGREEMENT. This agreement constitutes the
sole and complete Agreement between Cypress and the
Customer for use of the Program and documentation.
Changes to this Agreement may be made only by written
mutual consent.

8. GOVERNING LAW. This Agreement shall be governed by
the laws of the State of California. Should you have any
question concerning this agreement, please contact:

Cypress Semiconductor Corporation
Attn: Legal Counsel

3901 N. First Street

San Jose, CA 95134-1599

408-943-2600
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Chapter

Introduction

About This Chapter

Overview

The Warp2 Tutorial walks you through a common sequence of
operations in using Warp2. The Tutorial shows you how to create,
compile, synthesize, and simulate a design.

This chapter presents:

introductory information about Warp2;

a discussion of what this manual is and where it fits in the
larger scheme of Warp2 documentation;

our assumptions about tools you should be familiar with to
run the Tutorial, including sources of information about
those tools;

some conventions about typography, wording, and
illustrations used in this manual;

installation and licensing requirements for running the
Tutorial;

the objectives of the Tutorial; and
the contents of the Tutorial.
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Introduction

1.1. Introduction to Warp2

Warp2 is a Cypress Semiconductor software product that enables users
to describe electronic designs using VHDL, then compile and synthesize
those descriptions to program Cypress parts, such as PLD’s and

pASIC380 FPGA’s.!

Warp2 consists of three programs:

* The Warp VHDL compiler translates VHDL text
descriptions into files that can be mapped onto
programmable parts.

®* The Nova JEDEC functional simulator allows you to verify
the correctness of a design by simulating its behavior.

* The SpDE toolkit contains a set of tools for fitting designs
onto pASICs. This tool set includes a placer, router, logic
optimizer, path analyzer, and an automatic test vector
generator, among others. (SpDE is only available with
Warp2+ and Warp3.)

1. Available with Warp2+ and Warp3 only.

1-2 Warp2 Tutorial
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1.2. Conventions

The following conventions are used throughout this manual:

Notational Conventions:

Menu items Whenever an item from a menu is refer-
enced, the reference takes the form
menu-name/item-name/item-name...

The first entry in the reference is the name
of the menu; the second is the name of the
menu item; the third and succeeding
entries indicate choices from sub-menus.
Example: “Select File/Open...” tells you to
pull down the File menu, and select the
“Open...” item from it.

Italic Words are italicized for emphasis or to draw
attention to new terms.

Courier Denotes the contents of a text file, or indicates
that displayed text is system output. Also indi-
cates the text of typed commands.

File-Naming Conventions

Warp2 runs on two different types of platforms: IBM PC’s and
compatible computers, and Sun workstations.

IBM PC’s and compatible computers specify file locations by
designating a disk drive and using a backslash (\) character to
distinguish directory levels, e.g., “c:\level1l\level2\myfile”.

Sun workstations specify file locations using a forward slash (/)
and no disk drive designator, e.g., “/levell/level2/myfile”.

Warp2 Tutorial 1-3
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For consistency and brevity, this manual uses the same notation
as IBM PC’s and compatibles when referring to file locations.
Unix platform users are asked to make appropriate translations.

Mouse Conventions

The following terms describe common actions you might perform
in using this manual:

Click

Double-click

Drag

Press

Select

Place the mouse cursor over an object, then press
and release the appropriate mouse button.

Position the mouse cursor over an object, then
press and release the appropriate mouse button
twice in rapid succession.

Position the mouse cursor over an object or at a
specified location. Press and hold the appropriate
mouse button. While holding down the mouse
button, move the cursor to the new location.
Finally, release the mouse button.

When you are instructed to “press” a specified
key, locate the key on the keyboard and press it.

When you are instructed to “select” an option,
move the cursor over the option, then click the
appropriate mouse button.

Warp2 Tutorial
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Other Conventions

The following visual indicators denote special situations you may
encounter while using this manual:

O
NOTE

Warp2 Tutorial

This icon indicates a note: a point in the tutorial
where you must exercise special caution, or where
the procedure might vary depending upon the plat-
form you're using, or where there’s something else
you should know about that doesn’t fit into the
main flow of the text.

This icon indicates a hint. a point in the tutorial
where you could save a little time, a few key-
strokes or much frustration, if you only knew the
hint that’s being explained.

This icon indicates a shortcut. This tutorial has
been designed so that you can choose which
parts of the Warp2 design, compilation, synthesis,
and simulation process you want to work on.
When you see this symbol, you're being given a
choice to skip to another section of the tutorial.
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1.3. Objectives

The objective of the Warp2 Tutorial is to demonstrate the use of Warp2
tools for creating, compiling, synthesizing, and simulating designs.

Tools to be demonstrated in the Warp2 Tutorial include:

* Warp: compiles VHDL descriptions, produces JEDEC files
to program PLD’s, and produces QDIF files used in
programming pASIC380 FPGA’s.

¢ Nova: simulates the JEDEC file created in the Warp step.

1-6 Warp2 Tutorial
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1.4. About the Tutorial

The Warp2 Tutorial shows how to use tools to create, compile,
synthesize, and simulate designs.

Chapter 2 of this Tutorial demonstrates, in step-by-step fashion,
how to create designs using Warp2 tools.

Consider the following design problem: we wish to design a
controller for a soft-drink dispensing machine. The machine has
two bins to dispense Pepsi and Coca-Cola, respectively. Each bin
holds three cans of soft drink. (This could be any positive integer,
but three is an easy number to simulate with.)

We want the circuit to dispense a beverage when the user presses
a button for that beverage and one or more cans of the beverage
are available. We want the circuit to NOT dispense a beverage
when no cans of that beverage are available. We want to get a
REFILL signal when both bins are empty. We also want to be
able to press a RESET signal to tell the circuit that the machine
has been replenished and that the bins are full again.

The solution, described in Chapter 2, will proceed as follows:

First, we’ll describe a circuit in VHDL that controls the operation
of one bin. It will respond appropriately to a “get_drink” signal
(i.e., by giving a drink when one is available), keep count of the
number of cans left in the bin, and set an EMPTY signal when its
bin becomes empty and is in need of resetting. We’ll call this
circuit “binctr”. We will also add appropriate VHDL to make a
“package” out of the circuit, which will allow us to use the circuit
in higher-level designs.
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Then, we’ll write a structural description of a circuit that
instantiates two binctrs and other logic as appropriate, to
describe the larger design that we have in mind. We’ll call the
larger design “refill”.

After that, we’ll synthesize the binctr and refill VHDL
descriptions into a JEDEC file, and simulate the behavior of the
resulting design.

Figure 1-1 shows the sequence of operations used in the Tutorial
exercises.
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Text editor -
write behavioral VHDL
description of lower-level
circuit (BINCTR)

l

Make package for binctr,
so it can be instantiated
multiple times.

l

Text editor -
write structural VHDL
description of upper-level
circuit (REFILL)

l

Warp -
compile and synthesize
VHDL description of
REFILL

l

NOVA -
simulate behavior of
REFILL circuit

Figure 1-1. Flow Diagram of Warp2 Tutorial, Chapter 2.
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1.4. About the Tutorial
1.4.1. File/Directory Management

As you work through the tutorial, don’t write anything into your Warp
directory or its sub-directories. Instead, copy the information you need
into a different directory and work from there.

By default, the Warp2 installation procedure for IBM PC’s and
compatible computers installs Warp2 software into a directory
named c:\warp. On Sun workstations, the default location for
the Warp2 software is the directory pointed to by the
CYPRESS_DIR environment variable.

When doing the Tutorial exercises (or any other time, for that
matter), don’t write anything into the Warp directory. Instead,
create a separate directory to practice in (e.g., c:\w2tutor).
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1.4. About the Tutorial
1.4.2. Differences in Operating Systems

Warp2 operates identically on both Unix and Windows systems.
However, there are differences in the way you start Warp2 and in the
appearance of various objects on the display.

Starting Warp2

On Windows systems, you start Warp2 by double-clicking on the
Galaxy icon from the Cypress program group.

On Unix systems, you start Warp2 by typing “galaxy<CR>” from
within a shell window.

Differences in Display

Although dialog boxes and prompts may differ in appearance
between the two platforms, their functionality is identical.
Screen captures in this manual are taken from the Windows
version of Warp2. Differences in the Unix version are identified
when necessary. In most cases, any adjustments needed to go
from Windows to Unix versions of Warp2 displays are obvious.
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Naming Restrictions

When working in the Windows environment, you MUST keep file
names restricted to eight or fewer alpha-numeric characters (of
which the first must be an alphabetic character), plus a file
extension of up to three characters ( e.g., “.exe”, “.vhd”, etc.). This
is important to remember if you might transfer data between
Windows and Unix implementations of Warp2.

— G Keep in mind also that some Unix systems have
NOTE trouble with spaces embedded in file names. That

can be true for IBM PCs and compatible systems,

too. Don’t use embedded spaces in file names.
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The Tutorial

About This Chapter

Overview

This chapter takes you step-by-step through the tutorial
example, using a low-level behavioral description and a high-
level structural one. When you complete this chapter, you will
know how to:

* write an entity declaration, architecture, and package
declaration for a VHDL behavioral description of a simple
circuit;

* write an entity declaration and architecture that
instantiates the simple circuit in a structural description
of a higher-level circuit;

¢ run Warp to synthesize the schematic’s VHDL description;

* run Nova to simulate the behavior of the design.
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2.1. Write the “binctr” VHDL description

The “binctr” VHDL description controls the behavior of a single bin in
the drink machine. It acknowledges drink requests, dispenses drinks,
keeps count of the number of drinks remaining, and sets an output
signal when the bin becomes empty.

The “binctr” VHDL description will be written in three parts:

* the ENTITY declaration declares the name, direction, and
data type of each port of the component;

* the ARCHITECTURE describes the behavior of the
component;

* the PACKAGE declaration provides the information to
Warp to allow binctr to be used as a component in a
higher-level design.

The following pages discuss the contents of each of these sections
of the VHDL description. You can use any ASCII text editor to

type BINCTR.VHD.
S If you would rather not type the BINCTR.VHD file
NOTE yourself, you can copy it from the Warp directory.
The default location for the BINCTR.VHD file is

c:\warp\examples\w2tutor\binctr.vhd on PC’s, and
$CYPRESS_DIR/examples/w2tutor on UNIX
workstations.

From either of these locations, copy binctr.vhd to
your project directory. Then, read along for the
next few pages, to help you understand the pur-
pose of each section of a VHDL source file.
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2.1. Write the “binctr” VHDL description
2.1.1. Write the Entity Declaration

The ENTITY declaration declares the name, direction, and data type of
each port of the component.

Figure 2-1 lists the entity declaration for the binctr component.

The ENTITY declaration declares that entity “binctr” has five
external interfaces, or “ports.” It has three input ports of type
BIT, named reset, get_drink, and clk, respectively. It has two
output ports, also of type BIT, named give_drink and empty,
respectively.

entity binctr is port(
reset, get_drink, clk : in bit;
give_drink, empty: out bit);
end binctr;

Figure 2-1. ENTITY Declaration of binctr Component.
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2.1.

Write the “binctr” VHDL description
2.1.2.

Write the Architecture

The ARCHITECTURE portion of a VHDL description describes the
behavior of the component.

2-4

Figure 2-2 lists the architecture portion of the binctr component’s
VHDL description. The architecture appears after the entity
declaration in the .VHD file.

The first line declares an architecture named “archbinctr” of
entity “binctr”.

The next two lines declare a constant and a signal, respectively.

* The constant, named “full”, determines how many drinks
are in a full bin.

* Signal “remaining”, of type integer with a range from 0 to
the value of constant full, keeps track of how many drinks
are left in the bin.

The BEGIN that follows the signal declaration marks the start of
the architecture body.

A process declaration follows, marked by the keyword PROCESS
and an ensuing BEGIN.
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architecture archbinctr of binctr is
constant full:integer:=3; -- max of 3 drinks/bin
signal remaining:integer range 0 to full;
begin
proc_label :process begin
wait until clk = '1';
if reset = 'l' then
remaining <= full;
empty<='0";
give_drink<='0"';
elsif remaining=0 then
empty <= 'l1l';
give_drink <= '0‘';
elsif get_drink = 'l' then
remaining <= remaining - 1;
give_drink <= '1°';
elsif get_drink = '0' then
give_drink <= '0';

else
give_drink <= give_drink;
end 1if;

end process;
end archbinctr;

Figure 2-2. ARCHITECTURE of binctr Component.

The line “WAIT UNTIL clk="1" synchronizes all activity within
the process with transitions of signal clk to ‘1’.

Subsequent signal activity is handled in the following order:

¢ Ifsignal “reset” is ‘1, then signal “remaining” is set to full,
signal “empty” is set to ‘0’, and signal “give_drink” is set to
‘0’. (Notice that this means reset has priority over
get_drink; if reset and get_drink are both true on the same
clock cycle, the bin is reset, but no drink is given.)
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* Otherwise, if signal “remaining” has value 0, then signal
“empty” is set to ‘1’ and signal “give_drink” is set to ‘0’.

® Otherwise, if signal “get_drink” is ‘1’, then signal
“remaining” is decremented by one and signal “give_drink”
1s set to ‘1’

* Otherwise, if signal “get_drink” is ‘0’, the signal
“give_drink” is set to ‘0’.

* Otherwise, give_drink is set to the current value of
give_drink. Inclusion of this clause is not strictly
necessary, but it’s good VHDL coding practice .

Several lines ending the IF statement, process, and architecture
follow. Note that the END statement ending the architecture
must be accompanied by the name of the architecture, which
MUST match the name shown on the first line of the
architecture.
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2.1. Write the “binctr” VHDL description
2.1.3. Write the Package Declaration

The PACKAGE declaration provides the information to the Warp
compiler to allow binctr to be used as a component in a higher-level
design.

Figure 2-3 lists the package declaration for the binctr component.

O The package declaration must appear before the
NOTE entity declaration or architecture in the .VHD file.

package binctr_pkg is
component binctr
port (reset, get_drink, clk : in bit;
give_drink, empty: out bit);
end component;
end binctr_pkg;

Figure 2-3. PACKAGE Declaration of binctr Component.

The first line in Figure 2-3 declares the name of the package. The
name of the package must be distinct from the name of any
component declared within that package. Using the convention
“<entity>_pkg” works nicely.

The second line declares a component named “binctr”. The
component name that appears on this line must match the name
of an accompanying entity.
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2-8

The port statement declares the name, direction, and type of
each port in the component. You can copy the port statement
from the entity declaration for this purpose.

An “end component” and “end binctr_pkg” statement conclude
the package declaration. Note that the package named in the
END package statement must match that shown in the first line
of the package delcaration.

At this point, save the file as c:\w2tutor\binctr.vhd.
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2.2. Run Warp

Warp is the VHDL synthesis compiler for Warp2.

Warp takes VHDL descriptions as input. Warp has two functions
in the Warp2 system: (1) to verify that VHDL descriptions are
syntactically correct, and (2) to produce JEDEC or QDIF files to
program output devices.

At this point in the Tutorial, we’ll use Warp to verify that the
BINCTR.VHD file is syntactically correct. This step isn’t strictly
necessary; we could simply go on and build the higher-level
design for the “refill” circuit. But it’s always a good idea to
compile and simulate any VHDL description once you've
completed it. That way, you can spot problems in your VHDL
description when they are easiest to identify and correct. Later
on, should you encounter problems with the larger circuit, you
can at least be assured that you have taken care of any bugs at
the lower levels of the hierarchy.
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2.2. Run Warp
2.2.1. Start Galaxy

Galaxy is the user interface for the Warp VHDL synthesis compiler.

To start Galaxy, double-click on the Galaxy icon in the Cypress
program group. (If you're using a Unix workstation, type
“galaxy<CR>" at a shell prompt). The Galaxy window appears
(Figure 2-4).

=| Galaxy R
File Edit Tools Font F1=Help

Cypress Semiconductor
Copyright 1993

Figure 2-4. The Galaxy window (#1).
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2.2, Run Warp
2.2.2. Compile binctr.vhd

To bring up the Warp dialog box, select Tools/Run Warp Menu from the
Galaxy menu bar.

The Warp dialog box appears (Figure 2-5).

This dialog box lists the VHDL files available in the current
directory on the left side, and the VHDL files selected for
compilation/synthesis on the right side.

To select the binctr.vhd file for compilation, select binctr.vhd from
the list of files on the left-hand side, then click on the “Add”
button.

Then, select “Compile Only” from the “Build” button group near
the lower-left corner of the dialog box.

Then, click on “OK”. Warp runs, printing messages to keep you
appraised of its progress.

The compilation process should run to completion, without any
error messages.

— G If you do get error messages, check to make sure

NOTE that the various parts of the binctr.vhd file read
EXACTLY as they are listed on the preceding
pages. Better yet, copy the binctr.vhd file from the
\w2tutor sub-directory of the Warp directory, then
run Warp again.
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CiiW3TUT

~VYHDL Files:

f binctr.vhd
[-]
[le22v10]
[sch]
[sym]
[wir]

fa]

[b-]

Il

el

[+

I~ Build:

@ Compile Synthesize
C Compile Only

~Warp Input Files:

" Selected Device:
default

Figure 2-5. Warp dialog box (#1).
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23. Generate a VHDL Description of the Higher-Level Circuit

Having defined the behavior of the lower level of the circuitry, we can
describe the wupper level structurally by instantiating various
components and connecting them with appropriate internal signals.

Figure 2-6 shows file REFILL.VHD, a structural description of
the highest level of our tutorial circuit.

The first five lines tell Warp to use various packages containing
components and functions referred to in the design. Specifically,
the CKPAD component is in the IOPKG package, the AND2
component is in the GATESPKG package, and the binctr
component is in the BINCTR package. The CYPRESS and
RTLPKG packages contain definitions that are used in almost all
designs.

The entity declaration declares an entity named REFILL and
defines the names, types, and direction of its seven input and
output ports.

The architecture that follows starts by declaring three internal
signals. These are used to connect the output of one component to
the input of another.

For example, the EMPTY port of the binctr component labeled
bin_1 connects to internal signal empty_1. Signal empty_1, in
turn, connects to the A port of the AND gate named and_1.

Instantiation of two BINCTRs, one AND gate, and a CKPAD
(clock pad) completes the structural description of this circuit.
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use work.IOPKG.all;

use work.GATESPKG.all;
use work.BINCTR_PKG.all;
use work.cypress.all;
use work.rtlpkg.all;

entity REFILL is
port (GIVE_PEPSI: INOUT bit;

GIVE_COKE: INOUT bit;
REFILL_BINS: INOUT bit;
RESET: IN bit;
CLK: IN bit;
GET_COKE: IN bit;
GET_PEPSI: IN bit);

end REFILL;

architecture archREFILL of REFILL is
signal i_clk: bit;
signal empty_1: bit;
signal empty_2: bit;
begin
bin_1: BINCTR
port map (RESET => RESET,
GET_DRINK => GET_PEPSI,
CLK => i_clk,
GIVE_DRINK => GIVE_PEPSI,
EMPTY => empty_1);
and_1: AND2
port map (A => empty_1,
B => empty_2,
Q => REFILL_BINS);
bin_2: BINCTR
port map (RESET => RESET,
GET_DRINK => GET_COKE,
CLK => i_clk,
GIVE_DRINK => GIVE_COKE,
EMPTY => empty_2);
clk_pad: CKPAD
port map (P => CLK,
Q => i_clk);
end archREFILL;
Figure 2-6. REFILL.VHD file
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2.4. Run Warp to compile and synthesize entire circuit

Warp is the VHDL synthesis compiler for Warp2.

Warp takes VHDL descriptions as input and produces JEDEC or
QDIF files as output. JEDEC files are used to program PLD’s.
QDIF files are used as input to the SpDE tools, which produce
output files used to program pASIC380 FPGA’s.

The first time you ran Warp, earlier in the Tutorial, it was simply
to verify that the BINCTR.VHD file was syntactically correct.

On the following pages, you’ll run Warp to produce a JEDEC file
for a specific target device (in this case, a C22V10).
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2.4. Run Warp to compile and synthesize entire circuit
2.4.1. Start Galaxy

Galaxy is the user interface for the Warp VHDL synthesis compiler.

To start Galaxy, double-click on the Galaxy icon in the Cypress
program group. (On Unix workstations, type “galaxy<CR>” at a
shell prompt.) Close the ensuing “About” window. The Galaxy
window appears (Figure 2-7).

=] Galaxy |'|‘
File Edit Tools Font F1=Help

Cypress Semiconductor
Copyright 1993

Figure 2-7. The Galaxy window (#2).
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2.4. Run Warp to compile and synthesize entire circuit
24.2. Start Warp

To bring up the Warp dialog box, select Tools/Run Warp Menu from the
Galaxy menu bar.

The Warp dialog box appears (Figure 2-8).

This dialog box lists the VHDL files available in the current
directory on the left side, and the VHDL files selected for
compilation/synthesis on the right side.

To select a VHDL file for compilation/synthesis, click on the
name of the file on the left side, then click on the “Add” button.

To de-select a file for compilation/synthesis, click on the file’s
name on the right side, then click on the “Remove” button.

The asterisk (*) alongside the name of the REFILL.VHD file
indicates that Warp2 has processed this file and identified it as
the highest-level description of a multi-file VHDL hierarchy. (The
asterisk is NOT part of the file name, however; it’s just a visual
aid, to help you identify the highest-level files in projects.)

Now, let’s specify a target device...
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CAREMWITUT

~VYHDL Files: ~¥Warp Input Files:

binctr.vhd

*refill.vhd
[-]
[lc22v10]
[ic335]
flc344]
fic381]
[sch]
[sym]
fvhd]
[wir]

binctr.vhd
*refill.vhd

r Build: ~ Selected Device:
default

@ Compile _Synthesize
O Compile Only

Figure 2-8. Warp dialog box (#2).
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2.4. Run Warp to compile and synthesize entire circuit
2.4.3. Synthesize a VHDL Description

To specify a target device (along with other compilation/synthesis
options), click on the Options button from the Warp dialog box.

The Warp options dialog box appears (Figure 2-9).

For this tutorial, you will synthesize the VHDL description in file
REFILL.VHD to a C22V10 PLD.

To select the C22V10, scroll through the “Devices:” list and
highlight “C22V10”, then click “OK”.

When the Warp dialog box re-appears, click on “OK”. Warp runs,
printing messages to keep you appraised of its progress.
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Warp Option
rDevices: rOptimize:—™—— [ Output:
default O None Create JEDEC File
C16L8 ® Quick O Create HEX Filp
C16R4 O
C16R6 Large
C16R8 O xor
C16v8
c20G10
~ Fitter:

[J Force Flip-Flop Types
C22vP10

O Use 3 avpe Farm

gggg O tge “Traype Form
€330 ® Use aptimal "D o1 T Form
C33 [ Keep Polarity as Specified
C332

[J Allow Fitter to Change Pin Assignments
|CZ2V1I} I [J Force Logic Factoring
Package:

g ~Run Options:

IPALCZZV'I 0-20PC{PI

[J Quiet Mode

Figure 2-9. Warp Options dialog box.
This operation generates two files of particular interest (among
others):

¢ The first is named REFILL.JED. The .JED file can be used
to program the 22V10.

* The second file is named REFILL.RPT. It contains pinout
and timing information, along with lots of other
information about the final synthesized design.
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Exit the Galaxy window. (Choose “Exit” from the File menu.)

—— If compilation errors occur, do the following:
NOTE 1. make sure the text of your binctr.vhd file is

entered exactly as shown earlier in this chapter;
better yet, copy it from the \w2tutor sub-directory
of the Warp directory.

2. run Warp again.
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2.5. Run Nova to simulate the behavior of the design

Once the design is synthesized, it’s a good idea to simulate its behavior
to ensure that it functions as intended.

We’ll use the Nova simulator to test the behavior of the design. In
this tutorial, we’ll perform the following steps:

* start Nova;

¢ open the REFILL.JED file;

* create a new view and populate it with the signals we'’re
interested in (and only those signals);

* designate and edit a clock signal;
* set the values of the stimulus signals in the simulation;
* simulate the design;

* examine results to figure out what happened.
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2.5. Run Nova to simulate the behavior of the design
25.1. Start Nova and Open the REFILL.JED File

To start Nova, double-click on the Nova icon in the Cypress program
group. (From Unix workstations, type “nova<CR>” at a shell prompt.

The Nova screen appears, followed by the Nova “About” box. The
“About” box goes away by itself in a few seconds. If you want to
make it go away faster, click anywhere in the “About” box.

To open the REFILL.JED file, first choose the “Open...” item from
the File menu. Find the appropriate directory in the ensuing
Open File dialog box, select the REFILL.JED file, then click on
“Open”. The results should look like Figure 2-10.

Nova: REFILL Device: C22¥10
imulate ¥Yiews Options

Figure 2-10. Nova Screen When REFILL.JED File Is First Opened.
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2.5. Run Nova to simulate the behavior of the design
2.5.2. Create a View

The View is the collection of signals available for viewing on the Nova
screen. To make it easier to see what’s going on in our simulation, we’ll
create our own view, filling it with just the signals we’re interested in.

1. Choose the “Edit Views” item from the Views menu.
2. Click on the “New View” button.

3. In the ensuing dialog box, give the new view any unique
name; “tutview” will do nicely.

4. Click on the signal name in the “Full View” portion of the
window, then on the “Add” button, for each of the following
signals:

clk;

reset;
get_pepsi;
get_coke;
give_pepsi;
give_coke;
refill_bin.

5. Click on “OK”. The new view should appear on the Nova
display screen, and should look like Figure 2-11.
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Nova: REFILL Device: C22V10
Eile Edit Simulate Views Options

Figure 2-11. Nova Display Screen With New View Defined.
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2.5. Run Nova to simulate the behavior of the design
2.5.3. Designate a Clock Signal

We'll use the Edit/Clock menu item to give signal “clk” a series of
alternating highs and lows.

1. Select signal “clk” by clicking on its name in the Nova
display. The signal trace should turn blue when the entire
signal is selected in this manner. (The trace will become a
dashed line on monochrome monitors.)

2. Select the “Clock” item from the Edit menu.

3. When the Edit/Clock dialog box appears, click on “OK” to
accept the default clock values.

Signal “clk” appears as a series of equally-spaced, alternating
highs and lows (Figure 2-12).
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Nova: REFILL Device: C22V10
mulate VYiews Options

Figure 2-12. Clock Signal Designated.
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2.5. Run Nova to simulate the behavior of the design

2.5.4. Set the Values of Stimulus Signals

Besides the clock signal, we will set the values of the following input
signals for our simulation: reset, get_pepsi, and get_coke.

1.

Set “reset” to high for one rising clock edge. To do so:

a. position the cursor on the “reset” trace, just to the left
of a rising clock edge;

b. click and hold the left mouse button;

c. drag the cursor along the trace to the right of the rising
clock edge, then release the mouse button.

d. type a‘l’.

<> Repeat this procedure to set the values of other signals.

2.

Set “get_pepsi” to high for four non-consecutive rising
clock edges.

. Set “get_coke” to high for four non-consecutive rising clock

edges.

Set “reset” to high for one rising clock edge after the last
“get_coke” request.

Set “get_pepsi” and “get_coke” to high for one rising clock
edge, respectively, after the second reset.

After you have set the values of the input signals, you may wish
to change the screen resolution, in order to fit all activity in the
waveforms on one screen.
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To do so, select the “Resolution” item from the Options menu,
then set the resolution to, say, two pixels per simulation tic. The
result, when complete, should look like Figure 2-13.

Nova: REFILL Device: C22V10
File Edit Simulate Yiews Options

Figure 2-13. Input Signals Set.
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2.5. Run Nova to simulate the behavior of the design

2.5.5. Simulate and Examine Results

To simulate the design, select the “Execute” item from the Simulate
menu.

The results should look similar to Figure 2-14.

Nova: REFILL Device: C22V10
File Edit Simulate Yiews Options

Figure 2-14. Final Simulation Results.

The simulation starts with the drink machine empty. (Notice the
state of the refill_bin signal at the start of the simulation.)

When the reset signal goes high briefly near the start of the
simulation, the refill_bin signal is set to 0. The drink machine is
now ready to dispense drinks.

The drink machine dispenses a Pepsi in response to the first
three requests for a Pepsi. (Note the relationship between the
pulses in the get_pepsi and give_pepsi signals.) After the fourth
request for a Pepsi, however, the machine does not dispense a
drink; the Pepsi bin is empty.
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Similary, the drink machine dispenses a Coke in response to the
first three requests for a Coke. After the fourth request for a
Coke, the machine does not dispense one; the Coke bin is empty.

With both bins empty, the refill_bin signal goes high with the last
drink dispensed. It stays high until the reset signal goes high
again, telling the machine that the bins have been replenished.
The next two requests, for a Pepsi and a Coke respectively, are
honored.
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2.6. Conclusion

Now that we have verified the correct behavior of the design, the
REFILL.JED file can be transferred to a device programmer.

JEDEC files (.JED extension) generated by Warp can be
transferred to device programmers for PLDs and PROMs. See
the manual that came with your device programmer for
information on transferring and using this file to program
devices.

This concludes the Warp2 Tutorial. For more VHDL examples
and discussion, see Chapter 4 of the Warp Synthesis Reference
Manual.
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Cypress Software License Agreement

Cypress Software License Agreement

1. LICENSE. Cypress Semiconductor Corporation
(“Cypress”) hereby grants you, as a Customer and Lic-
ensee, a single-user, non-exclusive license to use the
enclosed Cypress software program (“Program”) on a sin-
gle CPU at any given point in time. Cypress authorizes
you to make archival copies of the software for the sole
purpose of backing up your software and protecting your
investment from loss.

2. TERM AND TERMINATION. This agreement is effective
from the date the diskettes are received until this agree-
ment is terminated. The unauthorized reproduction or use
of the Program and/or documentation will immediately
terminate this Agreement without notice. Upon termina-
tion you are to destroy both the Program and the docu-
mentation.

3. COPYRIGHT AND PROPRIETARY RIGHTS. The Pro-
gram and documentation are protected by both United
States Copyright Law and International Treaty provi-
sions. This means that you must treat the documentation
and Program just like a book, with the exception of mak-
ing archival copies for the sole purpose of protecting your
investment from loss. The Program may be used by any
number of people, and may be moved from one computer to
another, so long as there is No Possibility of its being
used by two people at the same time.

4. DISCLAIMER. THIS PROGRAM AND DOCUMENTA-
TION ARE LICENSED “AS-IS,” WITHOUT WARRANTY
AS TO PERFORMANCE. CYPRESS EXPRESSLY DIS-
CLAIMS ALL WARRANTIES, EXPRESSED OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE
IMPLIED WARRANTY OF MERCHANTABILITY OR
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Cypress Software License Agreement

v

FITNESS OF THIS PROGRAM FOR A PARTICULAR
PURPOSE.

. LIMITED WARRANTY. The diskette on which this Pro-

gram is recorded is guaranteed for 90 days from date of
purchase. If a defect occurs within 90 days, contact the

representative at the place of purchase to arrange for a
replacement.

. LIMITATION OF REMEDIES AND LIABILITY. IN NO

EVENT SHALL CYPRESS BE LIABLE FOR INCIDEN-
TAL OR CONSEQUENTIAL DAMAGES RESULTING
FROM PROGRAM USE, EVEN IF CYPRESS HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
CYPRESS'S EXCLUSIVE LIABILITY AND YOUR
EXCLUSIVE REMEDY WILL BE IN THE REPLACE-
MENT OF ANY DEFECTIVE DISKETTE AS PROVIDED
ABOVE. IN NO EVENT SHALL CYPRESS’S LIABILITY
HEREUNDER EXCEED THE PURCHASE PRICE OF
THE SOFTWARE.

. ENTIRE AGREEMENT. This agreement constitutes the

sole and complete Agreement between Cypress and the
Customer for use of the Program and documentation.
Changes to this Agreement may be made only by written
mutual consent.

. GOVERNING LAW. This Agreement shall be governed by

the laws of the State of California. Should you have any
question concerning this agreement, please contact:

Cypress Semiconductor Corporation
Attn: Legal Counsel

3901 N. First Street

San Jose, CA 95134-1599

408-943-2600
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Introduction

1.1. Introduction

Nova is Cypress Semiconductor Corporation’s name for its behavioral
simulator.

The Nova user interface gives you an easy way to:
* specify JEDEC files to simulate;
* read or write stimulus files;
e convert files from .JED to ViewSim format;
* edit input waveform traces;
* simulate the behavior of a design;

e alternate between various views (i.e., collections of
signals), and specify signals to include in each view;

* gspecify the length and resolution of a simulation;

* specify segments, where you can re-apply and edit initial
conditions, in order to compare results of differing initial
conditions side-by-side;

* and lots of other useful capabilities.

This manual tells you how to use Nova to simulate designs. It
assumes that you are already familiar with common user
interface operations for your computer, such as the use of scroll
bars, menu buttons, opening and closing windows, etc.
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Using Nova

2.1. Starting Nova

On Sun workstations, typing “nova” on the command line brings up the
Nova window. On PC’s and compatibles, double-clicking on the Nova
icon in the Cypress directory brings up the Nova window.

By default, Nova comes up ready to run on a color screen.

To start Nova on a monochrome Sun workstation, type “nova -m”
on the command line.

To set Nova to come up in monochrome mode when running
Windows on an IBM PC or compatible computer:

1

2-2

select the Nova icon from the Cypress window;

2. select “Properties” from the File menu;
3.
4. click OK.

edit the “Command Line” entry to include the -m option;
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2.2. The Nova Window

The Nova window (Figure 2-1) consists of a menu bar with several
items across the top; a column of buttons along the left side, listing pin
and node numbers and signal names; an area for displaying traces, and
scroll bars across the bottom and right sides.

Menu Bar

The menu items are File, Edit, Simulate, Views, and Options.
Under each of these items are menus for selecting related
actions. The menus are ordered so that the most common
operation is at the top. The contents of each menu are described
in greater detail later in this manual.

Only two menu items, Open and Exit, are enabled in the File
menu when you first enter Nova. When you open a “.jed” file or
“.cyp” file. the other menu items will be enabled.

Node Numbers, Signal Names

The left-hand side of the Nova window consists of a column of
buttons, displaying pin and node numbers and their associated
signal names. A “node” is an area of a circuit containing one or
more points whose locations you may wish to trace. (For
information about different values within a node, refer to
Section 2.4.4., "Nodes".)

To change the width of the buttons where signal names are
displayed, use the Signal Name Size item in the Options menu.

Trace Area

The trace area displays the values of the nodes/signals listed in
the left-hand column.
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Nova: BINCTR Device: C344A L
| File Edit  Simulate  Views Options F1=Help §

Figure 2-1. Main Nova Window.

You can display up to two measuring cursors, which allow you to
see precisely the value(s) of several signals at a single time. To
display the first cursor, click at the bottom of the trace window.
To display a second cursor, click at the bottom of the trace
window while pressing and holding the Shift key.

To change the position of either cursor, click and hold on the
cursor at the bottom of the trace window, then drag the cursor to
its new position. The cursor’s horizontal position in simulation
tics is displayed next to each cursor.

Note that a simulation tic does not represent any set amount of
real-time delay. Instead, a simulation tic is simply a unit delay of
simulation time.
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2.3. The File Menu

The File Menu contains items related to opening JEDEC files for
simulation, reading and writing stimulus files, and saving output files
in various formats.

The File menu (Figure 2-2) in the Nova dialog box contains the
following items:

Open...

Write Sim (*.sim)

Write Trace (*.psd)

Read Stimulus File

Write JEDEC Vectors

Write JEDEC File (*.jed)

Disassemble to ViewSim Format (*.vhd)
Exit

About...

The operations of each of these menu items are discussed in
greater detail on the next few pages.
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Write Sim [*.sim])

Write Trace [*.psd]

Read Stimulus File

Write JEDEC Vectors

Write JEDEC File [*.jed]

Disassemble to ViewSim format [*.vhd]

Exit
About...

Figure 2-2. Nova File Menu.

Nova User’s Manual



Using Nova

2.3. The File Menu
2.3.1. Opening Files

The Open... item in the Files menu selects which .JED or .CYP file to
open, and tells Nova what device is targeted in simulation.

Selecting Open... brings up the Open Files dialog box

(Figure 2-3). The “File Name" line specifies the names of files to
view in the Files window, or to open. By default, this line reads
“* JED”.

To open a file, you can select a file from the list shown in the Files
window, or type the name of the file on the “File name” line.
Selecting a .JED file and clicking on Open closes the dialog box
and displays traces. (If a stimulus file of the form filename.sim or
filename.stm exists, it is also read automatically.) Clicking on
Cancel closes the dialog box without opening a file.

The Select Device dialog box (Figure 2-4) comes up when you
click on Open in the Open Files dialog box, and the file to be
opened is a .JED file not created by Warp2. The Select Device
dialog box maps a JEDEC file to a device.

Selecting a device with the wrong number of fuses brings up a
message box stating: “Wrong device type for this jedec - QF
doesn’t match.” This indicates that the number of fuses in the
selected device don’t match the number in the JEDEC file.

If Nova says that it can’t find file DEVICES.DAT,

O check to make sure your CYPRESS_DIR environ-
NOTE ment variable is set correctly. Nova uses this file to
find the proper pin names and numbers for each

target device and package.
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Choose file to open...

File HName: Directories:
lm | c:\reptutfiles\w3tut

binctr.jed = o\

refill.jed = re
refill2.jed = t:tﬁles
refill3.jed

£ lc22v10
C11c335
£ ic344
List Files of Type: Drives:

|Files (*.JED) 4 -

Figure 2-3. Open Files Dialog Box.

Select Device

C16L8
C16R4
C16R6
C16R8
C16v38
c18G8
C20G10
CZ20RA1D
c2z2vi1o
c22vPio
C330
Cin
C332

L

Figure 2-4. Select Device Dialog Box.
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2.3. The File Menu
2.3.2. Reading and Writing Stimulus Files

Write Sim and Write Trace save simulation data. Read Stimulus
File reads data stored by a previous Write Sim operation.

Write Sim saves the current simulation data to filename.sim,
where filename is the prefix of the file you are simulating. If a
“sim” file already exists with this filename, the new simulation
data overwrites the old. The .sim file (see Figure 2-5) can be re-
read by Read Stimulus File.

Write Trace saves the trace information to filename.psd, where
filename is the prefix of the file you are simulating. The .psd file
(see Figure 2-6) provides a column-oriented, human-readable
record of trace values during the simulation. Bus values are not
written to the file.

Read Stimulus File reads simulation data from a .sim file.
Because reading in the simulation file may change some of the
settings the user has set for the current simulation, a message
box is displayed, asking if the stimulus file should be read in. A
“Yes” reply reads in the .sim file. A “No” reply returns you to the
main Nova window. The filename.sim file is automatically read
when the filename.jed file is opened.
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Figure 2-5. Portion of .sim File.

0:1000LLL
1m1800LLL
2210000LLL
3to000LLL
4:1000LLL
5:00001L L
6: 0000LLL
Z20000LLL
g:0100¢LLL
:0100LLL
10:1100L1L1L
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13:1100LL1L
14:1100LLL
15:0100L L L
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w:0010LLL
18: 00101LLL
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1010LL1L
1010LLL
oot1otLLlL

Figure 2-6. Portion of .psd File.
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2.3. The File Menu
2.3.3. Writing JEDEC Vectors

Write JEDEC Vectors appends vector information to the JEDEC file.
The vectors can be used to test parts after they are programmed.

Write JEDEC Vectors appends vector information to the
JEDEC file that you are simulating. If the JEDEC file already

contains vector information, the new vector information
overwrites the old.
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23. The File Menu
2.3.4. Converting Between File Formats

The File menu includes items that allow you to convert vector
information into different file formats, depending what you want to do
with it.

Figure 2-7 shows the various file types that can be input to or
output from Warp, Nova, and a device programmer.

Write JEDEC File (*.jed) writes out a JEDEC file from the
data available to the simulator. You would typically use this item
if you have input a .CYP file and want a JEDEC file to use on a
device programmer. The dialog box includes options to include an
instruction in the JEDEC file to blow the security fuse when the
device is programmed, and to write the JEDEC file using a
compressed, “K-field” hexadecimal representation. (This is the
default representation for the C340 family; it reduces the JEDEC
file size by nearly a factor of four.)

Disassemble to ViewSim format (*.vhd) writes a ViewSim
source file (with .VHD extension) from the data available to the
simulator. The resulting file can be revised with a text editor (to
hand-optimize the design, for example) and re-input to Warp.
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WARP @

JED NOVA
DEVICE
PROGRAMMER

Figure 2-7. Possible Data Paths and File Formats.

Nova User’s Manual 2-13



Using Nova

2.3. The File Menu
2.3.5. About and Exit

The File menu’s About item displays some basic information about the
Nova simulator. The Exit item exits the simulator.

Besides displaying version information about the Nova
simulator, the About dialog box also includes a Help button.
Clicking on Help brings up help about Nova.
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2.4. The Edit Menu

Use the items in the Edit Menu to modify trace information displayed
on the screen. With the Edit menu, you can set the selected range of a
trace, create and delete view nodes, create, delete and edit buses, and
change the bus radix.

Items in the Edit Menu (Figure 2-8) include:

High, Low: sets the selected trace or portion of a trace to
1 or 0, respectively.

Clock: sets up repetitive pulses.
Pulse: sets up a single pulse.

Node Defaults: specifies the default source for the
displayed value of a node.

Create View Node: creates a new trace, selects the point
within a node at which the displayed value is measured.

Delete View Node: deletes traces from the simulation.

Create Bus: groups traces for display as a single entity
called a bus; used when it is more convenient to think of
groups of signals as a single value. Bus values are only
displayed when a measuring cursor is present.

Delete Bus: un-defines a previously defined bus.
Edit Bus: adds or removes signals from a bus.

Bus Radix: specifies radix used to display a bus value.

These items are described in greater detail on the following

pages.
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Low

Clock

Pulse

Node Defaults
Create View Node
Delete View Node
Create Bus

Delete Bus

Edit Bus

Bus Radix »

Figure 2-8. Nova Edit Menu.

Nova User’s Manual



Using Nova

2.4. The Edit Menu

2.4.1. Setting Signals High or Low

With the Nova user interface, you can easily set the value of all or a
selected portion of an input signal high or low.

To set an entire input signal high or low:

click on the button containing the name of the signal in
the Nova window to select it. On color monitors, the button
changes color and the trace turns blue when selected. On
monochrome monitors, the button goes to inverse video
and the trace changes to a dotted line when selected.

select High or Low from the Edit menu as desired, or type
‘1’ or ‘0.

To set a portion of an input signal high or low (see Figure 2-9):

de-select the signal;

click and hold the mouse button on the trace at the point
where you want the left edge of the selected area to be;

drag the mouse to the point where you want the right edge
of the selected area to be;

then, select High or Low from the Edit menu, as
appropriate, or type ‘1’ or ‘0’.

Both the left and middle buttons of a 3-button mouse perform the
same action when clicked to position an edge.
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Figure 2-9. Setting a Portion of a Signal High or Low. Top: press and hold the mouse
button at the left edge of the selected area. Middle: drag to the right edge of the selected

area, and release the mouse button. Bottom: select High or Low from the Edit menu, or
type ‘1’ or ‘O’ from the keyboard.
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2.4. The Edit Menu
2.4.2. Setting Up Clock Signals (Repetitive Pulses)

The Clock item under the File menu lets you set up repetitive pulses on
a selected signal or portion thereof.

To set up a repetitive pulse or clock signal, select a signal or a
portion of a signal, then select the Clock item under the File
menu. This brings up the Clock dialog box (Figure 2-10), which
lets you fill in various parameters about the repetitive pulse you
wish to set up:

Clock Period specifies the period of repetition for the
pulse in simulator “tics”.

Clock Delay specifies the number of simulator tics to
wait (beginning with the left edge of the selected area)
before starting the repetition. The default is 0 tics.

Clock High Time specifies the amount of time that the
selected signal should be set to ‘1’ during each repetition.
The default is 5.

Start High and Start Low specify whether each
repetition starts with the signal set to ‘0’ or ‘1’;

OK sets up the repetitive pulse.

Cancel closes the Clock dialog box without affecting the
trace.
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Clock Period:

Clock Delay:

Clock High Time:

@ Start High
O Start Low

10

2-20

Figure 2-10. Clock Dialog Box.
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2.4. The Edit Menu
2.4.3. Setting Up Non-Repetitive Pulses

The Pulse item under the File menu lets you set up single pulses on a
selected signal.

To set up a single pulse on a signal, select a signal or a portion of
a signal, then select the Pulse item under the File menu. This
brings up the Pulse dialog box (Figure 2-11), which lets you fill in
various parameters about the pulse you wish to set up:

Pulse Duration specifies the length of the pulse, in
simulator “tics”.

Pulse Delay specifies the number of simulator tics to wait
(starting from the start of the simulation) before applying
the pulse. The default is 0.

Start High and Start Low specify whether the pulse sets
the signal to ‘0’ or ‘1’;

OK sets up the pulse.

Cancel closes the Pulse dialog box without affecting the
trace.
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Pulse Duration: 10
Fulse Delay: 0
@ Start High

 Start Low

Figure 2-11. Pulse Dialog Box.
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2.4. The Edit Menu
2.4.4. Nodes

A node is an area of a circuit containing one or more points at which you
may wish to trace a signal. Nova lets you specify the exact point or
points within a node at which to trace signal values. It also gives you
facilities for setting the default value of a node and for forcing one or
more positions in a node to known values.

To Nova, a node is:

1. any input to an array;

2. any output from an array;
3. any pin on the device;
4

. any other electrical position that needs to be modeled, but
doesn’t meet the first three criteria.

Figure 2-12 diagrams a simple PLD to illustrate what constitutes
a node. The pin to the left of the array meets criteria 1 and 3; the
macrocell to the right of the array meets criterion 2; and the
macrocell drawn below the array meets criterion 4.

For each node, you can:

* create a view node, i.e., specify one or more positions
within a node from which to trace values;

* gspecify the means by which a node is assigned its value;

¢ force any position in a node to a known value. This is often
useful for multi-segment simulations.

Each of these capabilities is discussed in greater detail on the
following pages.
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Node Array Node
(1,3) 2
. Macro-
Pin \Q cell
4)
Node

Figure 2-12. Logic Diagram of a Simple PLD, Showing Nodes.
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2.4. The Edit Menu
2.4.4. Nodes

2.4.4.1. Selecting Node Points to View

Many nodes contain several points at which you can trace simulation
values. Create View Node lets you select which of those points to view.

A view node allows you to see what is happening at various
points inside a node. Selecting Create View Node brings up the
Create Node View dialog box (Figure 2-13), which allows you to
select points to view within a selected node. To bring up this
dialog box, you must select a node with the current view set to
FULL. (See Section 2.6., "The Views Menu", for information
about changing views.)

The Create Node View dialog box displays the node name with
the view node name to be created directly below it. Nova creates
the view node name by taking the node number, followed by a
and an extension to represent the selected signal to be displayed.

The view node points that can be displayed depend upon the
selected node. Examples of view node points that can be
displayed include:

¢ Data from Array - This is the data at the output of an OR-
XOR combination of gates. Extension is “ardat”.

® Out value before OE - This is the data on the output pin if
the output enable is asserted. This includes the output
buffer inversion, if there is one. Extension is “b_oe”.

* OE Value - This is the state of the output enable. If high,
OE is asserted so the output is driven. Extension is “oe”.

* Node Output - This is the data on the pin. This is the
default view for output nodes. Extension is “out”.

Nova User’s Manual 2-25



Using Nova

Create Node Yiew

Node:

I 30-ardat

[ Signal to be displayed is:
@ Data from array

O Out register value

O Node output

O Feedback at input

O Feedback to array

Figure 2-13. Create Node View Dialog Box.

* Feedback at input - This is the data at the D input of the
input register, if there is one. If there is no input register,
feedback at input and feedback to array are identical.
Extension is “fbkin”.

* Feedback to array - This is the data that is being fed to the
array. It differs from feedback at input because it may be
the other side of a register. Extension is “fbk_ar”.

Selecting “OK” closes the Create Node View dialog box and
creates a view node, displayed at the end of the node list.
Selecting “Cancel” closes the Create Node View dialog box
without creating the view node.

To delete a view node, select the view node to delete, then select
Delete View Node from the Edit menu.
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2.4. The Edit Menu
2.4.4. Nodes
2.4.4.2. Setting Input Node Values

Node Defaults lets you specify the default source for the displayed
value of a node.

Selecting Node Defaults brings up the Node Defaults dialog box
(Figure 2-14).

You use the Change Default Input window of the Node Defaults
dialog box to specify the high-impedance source for the value of
an input node. The current setting is shown highlighted within
this window.

There are four possible settings for each input. They are:
* High (1): tie the signal to Vce.
* Low (0): tie the signal to Vss (ground)..

¢ Use Simulation Record: use the value(s) in the simulation
record (.sim file).

¢ Other Node Record: tie the signal to another node. Enter
the node number on the line to the right of the Other Node
Record button.
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MNode Defaults

Node:

~Change Default Input:
 High (1)
O Low [0)
® Use Simulation Recor
(> Other Node Record .
~Jam Load:
C Force Node High [1) O tnput Heyg High {1
® Force Node Low [0) @ input Heg Low 8]
< Output Reg High (1] O Zadd input Heg High {1
® Output Reg Low [0] @® Zod nput Heg Low (8

Figure 2-14. Node Defaults Dialog Box (1).
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2.4. The Edit Menu
2.4.4. Nodes

2.4.4.3. Forcing Output Node Values

Node Defaults lets you force the value of an output node at a specified
point.

Selecting Node Defaults brings up the Node Defaults dialog box
(Figure 2-15).

You use the Jam Load window of the Node Defaults dialog box to
force an output node to a specified value. Values of these nodes
rarely need to be touched for normal simulations. However, for
multi-segment simulation (for long counters and other long-
period design) or if there are problems in simulating the start-up
of a circuit, the values may need to be changed. The current
setting is shown highlighted.

Depending on the type of node, it may be possible to select from
Force Node High(1), Force Node Low(0), Output Reg High(1),
Output Reg Low (0), Input Reg High (1), Input Reg Low (0), 2nd
Input Reg High (1), and 2nd Input Reg Low(0).
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Node Defaults

—Change Default Input:
O High (1)
O Low [0)
@® Use Simulation Recor
C Other Node Record 0
~Jam Load:
 Force Node High (1) O mput Heg High §1
@® Force Node Low ([0) @ nput Heg Low
 Output Reg High [1) O Zad tnput Fog High {1
® OQutput Reg Low [0) ® Zud input Feg Low #

Figure 2-15. Node Defaults Dialog Box (2).
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2.4. The Edit Menu
2.4.5. Working With Buses

Sometimes, it’s more convenient to group several traces in a simulation
and view them as a single trace. You can do this with the Create Bus,
Delete Bus, and Edit Bus items in the Edit menu.

Selecting Create Bus brings up the Bus dialog box (Figure 2-16).
This dialog box combines nodes into a user-named bus. The View
list in the dialog box contains the names of all nodes in the
current view. The Bus list holds the names of each node in the
bus. A bus may be made up of any number of nodes.

Selecting OK closes the Bus dialog box and creates a bus with the
specified bus name. Buses are placed at the top of the trace area.
Selecting Cancel closes the Bus dialog box without changing the
trace area. Bus values are not displayed unless a measuring
cursor is present.

To add a node to the bus: select the node from the View list
and select the “Add>>" button. Double-clicking on the node name
also adds the selected node to the bus. The new node is added
below the selected node of the bus.

®

You can only add nodes in the current view to a
NOTE bus in that view.
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View: FULL Bus:

get_drink
clk
give_drink
empty
reset
remaining_IBY_1_BE}
remaining_IBY_0_BE}
node109

Bus Name:

generic bus

Figure 2-16. Bus Dialog Box.

Clicking on the Add-by-Name button brings up a dialog box that
asks you to specify the name(s) of signals to add to the bus. The
use of wild card characters is permitted. A “?” matches a single
character; a “*” matches any string of characters. The construct
name[m:n] denotes a range of signals, numbered from m through
n, beginning with the characters name. For example, “input[0:3]”
matches signals input0, inputl, input2, and input3.

To remove a node from the bus: select the node to be removed
and select the “Cut” button. Double-clicking on the node name in
the Bus list also removes the node from the bus.

To change a node’s position in the bus: Select the node, then
click “Cut.” Select another node, then click “Paste”. The node that
was previously cut will be inserted below the newly selected
node.
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To name the bus: click on the line below the words “Bus Name”
and enter the name for the bus. If no name is provided, the bus is
named “generic bus”.

To delete a bus: Select a bus trace by clicking on the bus name
button or the bus trace. After the bus is selected, selecting the
Delete Bus item from the Edit menu brings up a dialog box with
which you can remove the bus from the trace area.

Edit Bus brings up the same Bus dialog box used for creating
the bus. The bus name line is filled in, and the nodes in the bus
are displayed in the Bus list. Add and remove nodes from the bus
in the same way as when you create a bus. You may also change
the bus name when editing the bus.

After all changes have been completed, selecting OK closes the
bus dialog box and applies the modifications to the selected bus.
Selecting Cancel closes the dialog box without updating the bus.

Bus Radix brings up a submenu that allows you to choose how
bus information is displayed. The three choices are binary, octal
and hexadecimal. Hexadecimal is the default.
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2.5. The Simulate Menu

The Simulate Menu has only one menu item: Execute.

Selecting Execute from the Simulate Menu (Figure 2-17)
simulates the design’s operation. The Nova screen is redrawn,
and the resulting waveforms are displayed.

Execute

Figure 2-17. Simulate Menu.
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2.6. The Views Menu

Items in the Views menu let you select the views (i.e., groupings of
traces) that you see in the trace area.

The View menu (Figure 2-18) contains five items:
* Edit Views: lets you create and edit views.
* Select View: lets you select a view to display.

* Delete View: lets you remove one or more views from the
list.

e Zoom In (2X): multiplies the displayed timescale
resolution factor by two.

e Zoom Out (1/2X): divides the displayed timescale
resolution factor by two.

Each of these items is discussed in greater detail in the following
pages.

Lil="- 3 Options
Edit Views
Select View
Delete View
Zoom |n [2X]
Zoom Out [1/2X]

Figure 2-18. Views Menu.
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2.6. The Views Menu

2.6.1.

Editing Views

Edit Views lets you create new views, and add, remove, or exchange
traces in existing views.

2-36

Three views are automatically created with each .JED file: full,
pins-only, and pins & registers. The full view (default) lists all
nodes in the design. This view cannot be edited. The pins-only
view contains only nodes that are attached to pins. The pins &
registers view contains all nodes attached to registers or pins.

Selecting Edit Views displays the Edit Views dialog box
(Figure 2-19), used to edit the current view. The view list on the
left displays the FULL view, which contains the default traces for
all nodes. Use this list, along with appropriate buttons, to add or
remove traces from the view list on the right.

To create a new view: click on New View. You will be prompted
for a name, which is placed at the top of the right-hand view list.

To move between views: click on Next View or Previous View.

To add a trace to a view: select one or more traces from the left
(Full) view window, then click Add>>. If a trace is also selected in
the right window, the new traces are inserted after the selection;
otherwise, the new traces are added to the end of the view.

To remove traces from a view: select the traces in the right
window, then click on Cut.

To exchange (i.e., re-order) traces within a view: Select one
or more traces from the right view window, then click Cut. Then,
select another trace from the right view window and click Paste.
The previously cut trace(s) are inserted after the selected trace.
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View: FULL View: ports_only
2 clk 2 clk
4 empty 1 get_drink
1 get_drink 3 give_drink
3 give_drink 4 empty

0109 nodel09 13 reset

0029 node29
0030 node30
13 reset

Figure 2-19. Edit Views Dialog Box.

Add-by-Name brings up a dialog box that asks you to specify the
name(s) of traces to add. The use of wild card characters is
permitted. A “?” matches a single character; a “*” matches any
string of characters. The construct name[m:n] denotes a range of
signals, numbered from m through n, beginning with the
characters name. For example, “input[0:3]” matches signals
input0, inputl, input2, and input3. You can also use multiple
expressions separated by spaces.

Deselect All unselects all selected traces in either window.

Selecting OK closes the Edit Views dialog box and updates the
trace area to reflect changes made to the view. Selecting Cancel
closes the Edit Views dialog box without making any changes to
the view.
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2.6. The Views Menu
2.6.2. Selecting and Deleting Views

Select View lets you change the active view. Delete View lets you
remove a view from the list of available views.

Select View brings up the Select View dialog box (Figure 2-20).
The View line gives the name of the current view. To change the
current view, select the desired view from the list, then click OK
or type a carriage return. Clicking Cancel closes the Select View
dialog box without affecting the active view.

Delete View also brings up the Select View dialog box. Select
the view to delete from the scrollable list. The FULL view may
not be removed, and so it is not included in this list. Clicking OK
or typing carriage return applies the change to the list of views.
If you remove the current active view, the active view changes to
FULL. There is no undo for Delete View, so be certain the view
you are deleting is correct before clicking on OK or typing a
carriage return. Cancel closes the Select View dialog box without
deleting the selected view.
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View: FULL

FULL

PINS ONLY
PINS and REGS
ports_only

Figure 2-20. Select View Dialog Box.
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2.6. The Views Menu
2.6.3. Zoom In, Zoom Out

Zoom In doubles the time scale resolution of the trace window. Zoom
Out halves the time scale resolution of the trace window.

Zoom In doubles the time scale resolution of the trace window,
i.e., it doubles the number of pixels in the X-axis used to display
one tic of simulation time. The result is to “zoom in” the view of
displayed traces.

Zoom Out does just the reverse.

The resolution setting must be 1 or greater. The default is 5.
Attempting to set the time scale resolution lower than 1 has no
effect.
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2.7. The Options Menu

The Options Menu contains items that let you specify the simulation
length, create or delete simulation segments, and specify the viewing
resolution of the trace area.

The Options Menu (Figure 2-21) contains five items:

¢ Simulation Length: lets you set the length of the
simulation.

* Create Segment: lets you create a segment, or “new-
start-point”, within the simulation.

¢ Delete Segment: lets you delete a previously created
segment from the simulation.

* Resolution: lets you stretch and compress displayed
traces.

e Signal Name Size: lets you specify the width in
characters of Nova’s signal name buttons.

Each of these items is described in greater detail in the following
pages.

Simulation Length
Create Segment
Delete Segment
Besolution

Signal Name Size

Figure 2-21. Options Menu.

Nova User’s Manual 2-41



Using Nova

2.7. The Options Menu

2.7.1.

Simulation Length

Simulation Length lets you set the length of the simulation.

2-42

Selecting Simulation Length brings up the Simulation Length
dialog box (Figure 2-22).

The minimum and default simulation length is 256 tics. The
maximum simulation length is 9984. Clicking the up arrow adds
64 tics to the simulation length, to a maximum of 9984. Clicking
the down arrow subtracts 64 tics from the simulation length, to a
minimum of 256 tics.

You can also set the simulation length by typing a number on the
line next to the up and down arrows. The number will be rounded
downward to the nearest multiple of 64.

Clicking OK closes the Simulation Length dialog box and sets the
simulation length, to be used on the next simulator run. Clicking
Cancel closes the Simulation Length dialog box without affecting
the simulation length.

Simulation Length

2hb

Figure 2-22. Simulation Length Dialog Box.
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2.7. The Options Menu
2.7.2. Creating and Deleting Segments

Create Segment lets you create a segment, or “new start point,”
within the simulation. Delete Segment deletes a previously created
start boundary.

A segment is a point in the simulation at which various nodes are
reset to their “jam load” values (set through the Node Defaults
dialog box).

To create a segment, position the leftmost measuring cursor
where you would like the segment to start, then select Create
Segment from the Options menu to bring up the Create
Segment dialog box (Figure 2-23). The dialog box indicates the
starting and ending boundaries of the segment. Selecting Yes
closes the dialog box and creates the new simulation segment.
Selecting No closes the dialog box box without creating the
segment. You may create up to 15 segments.

To delete a segment, position the leftmost measuring cursor
within the segment to be deleted, then select Delete Segment to
bring up the Delete Segment dialog box (Figure 2-24). The dialog
box indicates the segment boundaries for the segment you wish
to delete. Selecting Yes closes the dialog box and deletes the
segment. Selecting No closes the dialog box without removing the
segment.
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CREATE SEGMENT from 7 to 256

Figure 2-23. Create Segment Dialog Box.

DELETE SEGMENT from 35 to 255

Figure 2-24. Delete Segment Dialog Box.

2-44 Nova User’s Manual



Using Nova

2.7. The Options Menu
2.7.3. Resolution

Resolution lets you stretch and compress displayed traces.

Selecting Resolution from the Options menu brings up the
Resolution dialog box (Figure 2-25). This dialog box lets you set
the number of screen pixels on the X-axis to be used per
simulation tic. Varying this number effectively stretches or
compresses the traces displayed on the screen.

The pixels-per-tic setting may be any number between 1 and 100.
The default is 5. The larger the number, the more “stretched” the
traces appear; the smaller the number, the more compressed the
traces appear.

Selecting OK closes the Resolution dialog box and updates the
trace display. Selecting Cancel closes the Resolution dialog box
without updating the trace display.

Please enter Pixels per tic:

Figure 2-25. Resolution Dialog Box.
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2.7. The Options Menu
2.7.4. Signal Name Size

Signal Name Size lets you specify the width in characters of Nova’s
signal name list buttons.

Selecting Signal Name Size from the Options menu brings up
the Signal Name size dialog box (Figure 2-26). This dialog box
lets you set the width in characters of the buttons in Nova’s
signal name list.

Please enter signal name size in chars:

Figure 2-26. Signal Name Size Dialog Box.
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Cypress Software License Agreement

Cypress Software License Agreement

1. LICENSE. Cypress Semiconductor Corporation
(“Cypress”) hereby grants you, as a Customer and Lic-
ensee, a single-user, non-exclusive license to use the
enclosed Cypress software program (“Program”) on a sin-
gle CPU at any given point in time. Cypress authorizes
you to make archival copies of the software for the sole
purpose of backing up your software and protecting your
investment from loss.

2. TERM AND TERMINATION. This agreement is effective
from the date the diskettes are received until this agree-
ment is terminated. The unauthorized reproduction or use
of the Program and/or documentation will immediately
terminate this Agreement without notice. Upon termina-
tion you are to destroy both the Program and the docu-
mentation.

3. COPYRIGHT AND PROPRIETARY RIGHTS. The Pro-
gram and documentation are protected by both United
States Copyright Law and International Treaty provi-
sions. This means that you must treat the documentation
and Program just like a book, with the exception of mak-
ing archival copies for the sole purpose of protecting your
investment from loss. The Program may be used by any
number of people, and may be moved from one computer to
another, so long as there is No Possibility of its being
used by two people at the same time.

4. DISCLAIMER. THIS PROGRAM AND DOCUMENTA-
TION ARE LICENSED “AS-IS,” WITHOUT WARRANTY
AS TO PERFORMANCE. CYPRESS EXPRESSLY DIS-
CLAIMS ALL WARRANTIES, EXPRESSED OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE
IMPLIED WARRANTY OF MERCHANTABILITY OR
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iv

FITNESS OF THIS PROGRAM FOR A PARTICULAR
PURPOSE.

. LIMITED WARRANTY. The diskette on which this Pro-

gram is recorded is guaranteed for 90 days from date of
purchase. If a defect occurs within 90 days, contact the

representative at the place of purchase to arrange for a
replacement.

. LIMITATION OF REMEDIES AND LIABILITY. IN NO

EVENT SHALL CYPRESS BE LIABLE FOR INCIDEN-
TAL OR CONSEQUENTIAL DAMAGES RESULTING
FROM PROGRAM USE, EVEN IF CYPRESS HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
CYPRESS'S EXCLUSIVE LIABILITY AND YOUR
EXCLUSIVE REMEDY WILL BE IN THE REPLACE-
MENT OF ANY DEFECTIVE DISKETTE AS PROVIDED
ABOVE. IN NO EVENT SHALL CYPRESS’S LIABILITY
HEREUNDER EXCEED THE PURCHASE PRICE OF
THE SOFTWARE.

. ENTIRE AGREEMENT. This agreement constitutes the

sole and complete Agreement between Cypress and the
Customer for use of the Program and documentation.
Changes to this Agreement may be made only by written
mutual consent.

. GOVERNING LAW. This Agreement shall be governed by

the laws of the State of California. Should you have any
question concerning this agreement, please contact:

Cypress Semiconductor Corporation
Attn: Legal Counsel

3901 N. First Street

San Jose, CA 95134-1599

408-943-2600
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Chapter

Introduction

About This Chapter

This chapter introduces the purpose, elements, and design flow
of the Warp system’s SpDE tools.
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1.1

Introduction

SpDE is the name of Cypress Semiconductor Corporation’s pASIC
processing toolkit.

This chapter tells you how to use the SpDE Toolkit to process
PASIC designs. It assumes that you are already familiar with
common user interface elements for your platform, such as scroll
bars, menu buttons, windows, etc. The SpDE toolkit runs within
a rich graphical environment that provides a consistent user
interface and a unified pASIC processing environment.

The SpDE Toolkit gives you the following pASIC processing
capabilities:

Design verification

Logic optimization

Automatic placement and routing

Physical viewing of pASIC layout
Post-layout delay modeling and back-annotation
Timing analysis

Automatic test vector generation (ATVG)

The typical order of use of the SpDE tools in Warp is:

import a .QDF file, using Import QDIF from the File
menu;

run all the SpDE tools in sequence, using Run All Tools
from the Tools menu;

export the .LOF file using Export/LOF from the File menu.
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Design Verifier

The Design Verifier analyzes a user design for common design
errors, architectural violations, and architectural warnings. In
addition to catching errors prior to running the other SpDE tools,
the Design Verifier alerts the user to such potential problems as
excessive fanout.

Logic Optimizer

Logic optimization is the first step in automatic placement and
routing. The Logic Optimizer utilizes two modules to efficiently
map logic into the pASIC logic cell: the Packer and the
Technology Mapper.

Starting with the user design, the Packer maps logic symbols
(hard macros) into logic cells. As many as four macro symbols
may be packed into a single logic cell. The Packer allows users to
design with easy and convenient macros, while achieving high
utilization of the pASIC resources.

The Technology Mapper provides automatic logic cell
optimization. For example, NOR gates can be implemented more
efficiently than OR gates. The Technology Mapper introduces
and removes inversion bubbles in order to improve capacity and
performance. In more general terms, the Logic Optimizer merges
gates in order to achieve more efficient implementations.

Placer

Placement is the second step in automatic placement and routing
(APR). Starting with the fully packed design, the Placer moves
cells around the pASIC to minimize routing delays. This not only
produces extremely fast pASICs, it also allows completely
automatic routing. The Placer offers fixed placement of I/O cells
as well as logic cells. Fixed I/O cell placement lets you take
circuit board considerations into account, while fixed logic cell
placement offers precise control over internal routing delays.
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Working closely with the Path Analyzer, the Placer offers timing-
driven placement. Timing constraints are specified directly in the
Path Analyzer; these are passed to the Placer to insure that
critical timing goals are met automatically.

Router

The Router connects cells by routing nets within the pASIC
matrix. The Router’s optimization capabilities minimize routing
delays and routing resources required.

Physical Viewer

The Physical Viewer displays the physical layout of a pASIC
part. The viewer allows the user to inspect the results of APR for
placement efficiency and routing congestion. Timing-critical
paths can easily be identified. This information can be fed back
into APR in order to improve the physical layout.

Delay Modeler

The Delay Modeler performs precise post-layout delay
calculations using state-of-the-art circuit analysis techniques.
Processing the complete results of APR, the Delay Modeler
analyzes packing, placement, and routing to determine intrinsic
delays and routing delays for the entire design. These precisely
calculated delays are written directly into the logic simulator
netlist for timing-accurate results.

Path Analyzer

1-4

The Path Analyzer performs path analysis of the circuit delays
from the Delay Modeler. The Path Analyzer offers automatic
analysis of the complete design, as well as interactive analysis of
user-specified portions of the design.
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Automatic Test Vector Generator

The Automatic Test Vector Generator (ATVG) provides
convenient and thorough test coverage of programmed pASIC
parts. Using the internal scan path circuitry built into every
pASIC, the Automatic Test Vector Generator achieves excellent
test coverage. The degree of test coverage can be easily
controlled, and user-specified test patterns can be included.
ATVG provides both ideal and actual coverage statistics,
allowing the design to be tuned for optimal testability.

Starting SpDE

To start SpDE, double-click on the “SPDE” icon in the Warp2
program group.
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1.2

The File Menu

The File menu (Figure 1-1) includes commands relating to: creating,
opening, and saving binary chip files: importing/exporting QDIF, EDIF,
and LOF files; printing the physical view of the layout; and exiting

SpDE.

1-6

SpDE operates primarily on chip files (file extension .CHP) and
QDIF files (file extension .QDF). Chip files have a compact and
efficient binary file format, while QDIF files have an open ASCII
file format. Chip files are used within SpDE for reasons of
efficiency, while QDIF files are used to import the output from
Warp synthesis operations.

New clears any current design and initializes SpDE to operate
on a new design.

Open loads an existing chip file (file extension .CHP). Selecting
Open brings up a dialog box, from which you can select a chip
file. Doing so re-initializes SpDE and loads the specified chip file.

Save saves the current design as a chip file. Save uses the
format specified by the current selection in the Tools-Options-
Simulator menu item. The default is Viewsim. Once a design has
been run through the tools, a saved file contains placement,
routing, timing, testing, and programming information.

Save As saves the current design as a chip file with a user-
specified name. Selecting Save As brings up a dialog box, which
allows you to specify the name for the chip file. This menu item
gives you the capability to save backup or history copies of a
design for later reference.
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New
Open...

sSave A,

Import 3
Expor LOF.

Pring Selup...
rint.,

1 REFILL3.CHP
2 REFILL3.QDF

Figure 1-1. File Menu
Import loads files saved in QDIF or EDIF format. Export LOF
saves the current design in LOF-file format. The Import and

Export LOF menu items are discussed in greater detail in
Section 1.2.1, "Importing, Exporting”.

Print Setup invokes the printer setup dialog box for the default
printer driver. Print prints the current physical view using the
parameters set in Print Setup.

Exit terminates SpDE, prompting you to save the design if it has
been modified since the last save. On PC’s and compatibles,
double-clicking the Control-Menu box (in the upper-left corner of
the SpDE window) is a shortcut for Exit.

Below the Exit menu item, the last five accessed files are listed.
This provides a shortcut for the Open and Import commands.
Clicking on a chip file from this list opens the file; clicking on
another file type from this list imports the file.
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1.2 The File Menu

1.2.1.

Importing, Exporting

Import lets you import files written in QDIF or EDIF formats. Export
LOF writes designs into LOF-format files.

1-8

The Import menu item features a pop-up sub-menu with QDIF
and EDIF entries. Position the cursor on the Import menu item,
click and hold the button, drag the cursor to select one of QDIF or
EDIF. This bring up a dialog box, from which you can select a
design. Doing so re-initializes SpDE and loads the specified file.

As the file is loaded, the Design Verifier analyzes it for common
design errors, architectural violations, and architectural
warnings. A dialog box lists any problems found.

Problems fall into one of four categories: Notice, Warning, Error,
or Fatal Error:

* Notices and Warnings serve as alerts; they may or may not
require action (e.g., excessive fanout).

¢ Errors prevent devices from being programmed, but do not
prevent the toolkit from running (e.g., floating inputs).

* Fatal Errors prevent the toolkit from being run (e.g., net
with multiple drivers).

The Design Verifier removes unused gates from the design; any
gate that cannot affect an output is removed. Unused counter
and register bits, for example, are automatically removed.
“Stripped” gates are flagged with a Notice to ensure that their
removal is sound.
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Export LOF saves the current design as a Link Object Format
file (file extension .LLOF) with the specified name. This format
yields a compressed file that contains all the data required to
program and test pASIC devices. Use this file to program the
pASIC on a device programmer.
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13

The View Menu

The View menu (Figure 1-2) includes commands for controlling the
physical view and highlighting nets.

1-10

Zoom In “magnifies” the Physical View. The command supports
two modes: “click” and “drag”. To use click mode, select Zoom In,
then click the mouse button once. This increases the scale factor
by 1.25, and centers the view on the current cursor position.

Drag mode allows an arbitrary rectangle to specify the desired
view. To use drag mode, select Zoom In, position the cursor
where you want the viewing rectangle to begin, and click and
hold the mouse button. Then, drag the cursor to the diagonally
opposite corner of the viewing rectangle and release the mouse
button. The view adjusts to fit the specified rectangle as closely
as possible. The shortcut key for Zoom In is Ctrl-Z.

Zoom Out “de-magnifies” the view. The shortcut key for Zoom
Out is Ctrl-X.

Full Fit modifies the scale factor to fit a view of the entire pASIC
chip on the screen. The shortcut key for Full Fit is Ctrl-F.

- Normal Fit sets the scale factor to its initial value, and centers

the view on the selected position. The shortcut key for Normal
Fit is Ctrl-N. (Note, though, that you must still click the mouse
button to select the viewing position.)

Preferences sets physical view options. These are discussed in
greater detail in Section 1.3.1, "Preferences”.

Hilight Net allows you to select nets to be highlighted in the

physical view. This menu item is discussed in greater detail in
Section 1.3.2, "Hilight Net”.
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Redraw erases and redraws the physical view.

Zoom In L
Zoom Qut A
Full Fit “F
Normal Fit *N
Preferences...
Hilight Net...
Bedraw

Figure 1-2. View Menu
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1.3 The View Menu

1.3.1.

Preferences

Preferences sets physical view options.

1-12

Selecting Preferences brings up the Preferences dialog box
(Figure 1-3).

The Texting group of check boxes includes items relating to text
in the physical view. Table 1-1 lists the check boxes and examples
of the items they control. Text items can be turned off to increase
redraw speed or simplify the physical view.

Table 1-1. Texting Options in the Physical View

Item Example

Logic Cell Locations Al, A2, B1,Cl,HI2
/O Cell Numbers 3,12,24,42
Flip-Flop Net Names specified in schematic
I/O Cell Net Names specified in schematic
Logic Cell Net Names specified in schematic

The Flip-Flop Net Names option only includes the net names of
logic cell flip-flop outputs. The Logic Cell Net Names option
includes the net names of all logic cell inputs and outputs.

The Drawing Style group of radio buttons controls the use of
color in classifying interconnects. In Black/White mode, all wires
are shown in black. In Color mode, short wires are shown in blue
and black, express wires are shown in green, I/O wires are shown
in red, and clock traces are shown in mauve. (That’s purple with
a college education.)
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Preferences

Figure 1-3. Preferences Dialog Box

The Detail group includes the Draw Cell Interiors check box.
De-selecting this check box replaces the detailed logic cells with
simple boxes, thereby increasing redraw speed.

Clicking OK accepts all preference settings for tools that are
subsequently executed. Clicking the Save button does the same,
and also records the preference settings in a file. These settings
are then used the next time SpDE is invoked.
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1.3 The View Menu

1.3.2.

Hilight Net

Hilight Net allows you to specify nets for SpDE to highlight in the
physical view.

1-14

Selecting Hilight Net brings up the Highlight Net dialog box
(Figure 1-4), and redraws the Physical View in light gray, which
allows the highlighted nets to stand out. The net list box on the
left of the dialog box contains the names of nets not currently
highlighted, while the net list box on the right contains the
names of nets that are currently highlighted.

To highlight nets, select one or more nets from the box on the left,
or specify a net name in the “Wildcard Selection” field on the left
side of the dialog box, and click on the right arrow button.

To remove nets from the highlight list, select one or more nets
from the box on the right, or specify a net name in the “Wildcard
Selection” field on the right side of the dialog box, and click on
the left arrow button.

When using the “Wildcard Selection” fields, the wildcard
characters “*” and “?” are accepted. The “*” character matches 0
or more occurrences of any character. The “?” character matches
a single occurrence of a single character.

Double-clicking on a net name in either list moves it to the other
list.

All nets can be removed from the highlight list by clicking on the
ALL button.

Once in highlight net mode, the highlight status may be toggled
by clicking directly on the desired nets in the physical view.
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Highlight Nets

EMAINING_IBY_1__
REMAINING_IBY_1__1
REMAINING_IBY_1__
REMAINING_IBY_1__
X0ORTMPS
REMAINING_IBY_O__

REMAINING IBY
wild i

Figure 1-4. Highlight Net Dialog Box

To exit highlight net mode, click OK. The Physical View will be
redrawn in the normal mode. To exit without redrawing the
Physical View, click Cancel.
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1.4

The Tools Menu

The Tools menu is used to set up and run the optimizing, placing,
routing, sequencing, delay modeling, back annotation, and path
analysis tools.

1-16

The Tools menu (Figure 1-5) contains three items: Run Tools,
Path Analyzer, and Options.

Path Analyzer...
Options b

Figure 1-5. Tools Menu.

Run Tools opens the Select Tools to Run window (Figure 1-6).
This window is used to select which tools are to be run on the
design. Disabled tools are grayed out. Tools that have already
been run are un-checked. Detailed descript