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elcome to EXTRA!. Delivering host type information to the
familiar setting of Windows, EXTRA! takes PC-to-host

communications several steps higher by streamlining how you work in
an enterprise environment.

EXTRA! gives you access to IBM Mainframe hosts via most direct,
remote, or LAN connections. From the point-and-click environment of
your PC you can run host applications, transfer files, and integrate data
into Windows programs. To simplify your interaction with host
resources, use the EXTRA! graphical, navigational, and macro tools.

You can use EXTRA! in Windows 95, Windows 98 or Windows NT.

Using Display Sessions

EXTRA! gives you a host workspace in Windows called a Display Session.
From this window you can enter and receive information directly from the
host. This includes any special characters, commands, or functions unique to
your host. A File Transfer feature makes it possible for you to send and
receive files directly between your PC and a host. Because you are working
in Windows you can:

• easily switch between EXTRA! sessions and other Windows
applications

• resize session windows

• change fonts

• cut, copy, and paste information between your PC and a host

The New Session wizard makes it easy to create new sessions for any
installed host type.

W
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Using Printer Sessions
Using an EXTRA! Printer Session, you can print IBM Host documents on
your local printer.

You can:

• set page layout features

• choose which font you want to use

• print an image of the display screen

• pause or cancel printing

• view the status of a printer or print job

• save the settings of your current printer session and page layout

After you start a print job from the host application in a display session,
you can pause or cancel a print job, and monitor the print status of the
host, your PC, and your printer.

Desktop Layouts and QuickPads
Desktop layouts let you start work with your windows in a prearranged
position on your screen. This is especially useful for running multiple
sessions. In addition, you may have a customized QuickPad open for
each display session. If saved in a layout, the session windows and the
customized QuickPads will always appear exactly as you like them.

QuickPad, a small movable window that “floats” on top of your session,
makes frequently used host commands and macros available with a
single mouse-click. You can use text and pictures to identify these
commands.
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Using File Transfer, HotSpots, and Recording Macros
Using the File Transfer feature, you can move files between your PC and
the host. You can also use EXTRA! OLE capabilities to embed host data
into your Windows applications. For example, use OLE to embed host
data into a Microsoft Excel spreadsheet.

HotSpots brings Windows “point and click” commands to your host,
putting program function keys, macros, EXTRA! commands at your
fingertips with a click of your mouse.

With the Macro Recorder you can capture frequently used tasks, and
then automatically re-play these tasks with a single mouse click or
keystroke. You can also add macros to toolbars, QuickPads, and logon
scripts. The Macro Editor enhances and expands the Macro Recorder.

Customizing EXTRA!
You can extend the standard features in EXTRA! and build upon its basic
tools. For example, you can customize your toolbars in a number of
ways:

• add and delete buttons

• use color or monochrome buttons, and make them large or small

• rearrange the buttons

• create multiple toolbars and load different ones for different sessions

EXTRA! Basic is a full-featured language tool. Use it to edit recorded
macros, existing macros, or to create entirely new macros. EXTRA! Basic
provides the flexibility of a standard Basic language and the power of
specific functions for EXTRA! and connectivity tasks.

You can use the Keyboard Remapper to reassign host functions to your
PC keyboard to fit your work style. You can also assign additional
functions and custom macros to unused keys or key sequences.
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Microsoft Office
EXTRA! is Microsoft Office Compatible. This means that its toolbars,
menus, and accelerator keys are similar to those used by Microsoft
Office. If you already know Microsoft Office, then you already know
many EXTRA! tasks.

The EXTRA! for Windows 98 and Windows NT Print
Documentation Set

In addition to this User’s Guide, the EXTRA! for Windows 98 and
Windows NT documentation set consists of the:

• EXTRA! Basic Language Reference

• EXTRA! OLE Automation Programmer’s Reference

These can be purchased separately or as a set.

EXTRA! Basic Language Reference

The following information is included in the EXTRA! Basic Language
Reference

• A language summary section

• A description of functions and statements in alphabetical order

OLE Automation Programmer’s Reference

The following information is included in the OLE Automation
Programmer’s Reference:

• An overview of how OLE works with EXTRA!

• A description of Properties, Methods and Statements in alphabetical
order
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About This Manual
You’ll probably want to get a session between your PC (client) and your
host up and running as quickly as possible. The EXTRA!  User’s Guide is
designed with this in mind.

• Chapters 1 through 6 cover the basics, including: opening and
configuring a display session and a printer session, transferring files
between your PC and mainframe, and printing mainframe files to
your local printer.

• Chapters 7through 10 cover the following customization topics: color
mapping, using the QuickPad, programming HotSpots, and
remapping your keyboard.

• Chapters 11 through 15 explore ways you can work more efficiently
using EXTRA!  -- with macros and the macro editor, security
features, and the Status application.

• Appendix A provides information on how to understand mainframe
messages.

• The glossary includes a list of common terms.

Conventions

Mouse Commands

If you see the terms “click” and “double-click” within a procedure, press
the left mouse button one or two times, respectively. If you need to press
the right mouse button as you work in EXTRA!, we’ll let you know.

Shortcut Keys

EXTRA! provides shortcut keys for several of its commands. These keys
are frequently used in combinations. For example, CTRL+T means to hold
down the CONTROL key while pressing T.

You can also access EXTRA!’s menus by using shortcut keys. These keys
function the same way as in your Windows applications. Using the ALT
key in combination with the underlined letter of the menu you wish to
access will open that menu. For example, (ALT+F) will open the File
Menu.
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Commands

Specific text you type at a command prompt appears in Courier typeface.
Information, such as a filename, that you must supply yourself appears
in Courier italic. For example,

• At the DOS command prompt, type:

WIX�MRH�JMPI!RI[CREQI

Command keys appear in small capital letters. In the following example,
the command ENTER indicates that you should press the Enter key.

• Type your user ID and press ENTER.

Notes

Note: As demonstrated in this paragraph, notes are separated from the
rest of the text in your manuals by two margin rules. The information
within a note provides helpful and often crucial supplementary material
intended to aid you in understanding EXTRA! works.

Caution Text

Let Us Know How We’re Doing
Please fill out the Customer Documentation Feedback Card that comes
with EXTRA! software package to let us know what you think about the
documentation. Your comments are valuable to us.

!! Caution: Always read text that contains an exclamation point in the left
margin. It means that there is important information that you need to be
aware of. That information may be as simple as a reminder or as critical
as a warning.
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Online Help

The online Help for this release of EXTRA! has been created using the
advanced functionality of Windows ‘95 help. Provided below is information
on using the Help system.

Note: If the custom installation option was selected during installation,
only the Help topics that are applicable to the installation options
selected appear in the Help file.

Using Help in EXTRA!
The following procedure explains how to access the Contents page in the
Help file, and how to make a topic selection.

1. Open a session in EXTRA!.

2. Choose the Help menu.

3. Select EXTRA! Help Topics.
The Help Contents page appears.

4. Double-click any of the book icons that appear in the Contents page.
The contents of that book display.

5. Double-click any of the document icons located under a book icon.
The help topic associated with that heading appears.

Using Context-Sensitive Help
EXTRA! includes context-sensitive Help. This means that you can:

• access online Help by pressing F1 to view specific information about
a dialog box or a menu command

• click the Help button that is located in each dialog box

• activate “What’s This” mode by selecting an item in the dialog box
and then clicking the right mouse button, or

• click the Help Mode toolbar button, then click the item for which
you’d like help
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EXTRA! Worksheet
You’ll need to know the following information to effectively open and
configure display and printer sessions in EXTRA!. Check with your
system administrator if you are unsure about any of the information in
this worksheet.

User ID: 

User Password: 

Other: 

Mainframe Operating System:

❍ VM/CMS ❍ VMS/TSO

❍ MVS/CICS ❍ VSE/CICS

Print Commands: 

Path for EXTRA! Files: 

Notes: 
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his chapter gets you started with EXTRA!. It describes the EXTRA!
icons, explains how to access a list of new features and updates,

discusses the startup and shutdown options, introduces session windows
and describes how to install EXTRA! on a Network using silent mode.

The EXTRA! Icons
The Setup application installs the following icons in your EXTRA! folder
or program group. (Depending on the type of installation you selected,
fewer icons may appear.)

Icon Description

EXTRA!

Provides access to the IBM Mainframe host.

Macro Editor

Displays an editor for writing BASIC language
macros, allowing you to automate and
customize EXTRA! functions.

Help

Displays help for EXTRA!.

Readme File

Contains last-minute information not included
in the Help or this User’s Guide.

Attachmate Forum

on Microsoft Network

Windows 95 and Windows 98 only.
Automatically navigates to the Attachmate
forum on the Microsoft Network, where you
can retrieve updated product files, technical
support material, and product information.

Uninstall

Removes the 32-bit EXTRA! product from your
computer.

Note: This icon appears in Windows NT only.
In Windows 95 and Windows 98, you must
choose the Add/Remove Programs icon in the
Control Panel. For uninstall details, refer to
Appendix A.

T
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Icon Description

APPN Configurator

Configures the APPN (Advanced Peer-to-Peer
Networking) Node, used to run LU6.2 applications.

Start/Stop APPN Node

Two icons, one to start and one to stop the APPN
Node.

APPN Node Manager

Provides a visual representation of the APPN Node
and its current status.

What’s New
A list of the new features and updates included with the most current
release of EXTRA! for Windows 98 and Windows NT can be found in
online Help.

To access the list of new features

1. Open a session.

2. Choose EXTRA! Help Topics from the Help menu.

3. Select Using EXTRA!, then select Welcome to EXTRA!.

4. Select What’s New to see a list and explanation of new features and
updates included with the latest release.

Starting EXTRA!
You can run EXTRA! on Windows 95, Windows 98 or on Windows NT,
version 3.51 or above. Follow the startup procedure applicable to your
operating system.
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To start EXTRA!

Use one of the following methods, depending on your environment.

From Windows 95 or Windows 98 From Windows NT

1. Click the Start button, then point
to Programs.

2. On the Programs menu, point to
the EXTRA! folder.

3. Click EXTRA!.

1. Open the EXTRA!
program group.

2. Double-click the
EXTRA! icon.

You are prompted to select one of the following startup options.

If you choose to create a session, EXTRA! will display the New Session
wizard, described in the next section.

If you choose to open a session, EXTRA! will display a list of available
sessions, including demonstration sessions simulating connections to a
mainframe.

For more information, refer to page 1-7.

If you choose to open a layout, EXTRA! will display a list of desktop
layouts. A desktop layout defines how one or more session windows
appear on your desktop. When opened, the layout positions the windows
the way you defined them. For more information, refer to page 1-8.

Note: Unless you have previously created desktop layouts, none will be
available to open.



Getting Started with EXTRA!

1-5

Creating Sessions
Using the New Session wizard, you can create sessions of any installed
host type. You have the option of creating a session when you first start
EXTRA!. And when you’re working in an open session, you can create
additional sessions — as many as your PC memory can handle.

To create a session, you must provide the New Session wizard with the
following information:

• Session type — display or printer.

• Connection type and settings.

• File transfer type applicable to the selected host type.

The wizard creates a session with many default settings, which
determine how the session appears, operates, and interacts with you. You
can later edit these settings to accommodate your preferences.

Tip: To create a new session with a profile identical or similar to an
existing session, use the Save Session As command instead of the New
Session wizard. Both procedures are described below.

To create a session with the New Session wizard

1. If you have a session open, do one of the following to create a new
one:

• From the File menu, choose New Session.

• Choose the  button from the toolbar.

2. Select a host type and click Next.

3. Select a session type and click Next.

4. Select a connection type and click Next.

5. Set the options for the selected connection and click Next.
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6. Select a file transfer type.

7. If you’re satisfied with your settings, click Finish.

EXTRA! displays the new session.

8. From the File menu, choose Save.

You can save the session with any name. The default file extensions
indicate the session type — .EDP for display sessions, and .EPP for
printer sessions.

To create a session with the Save Session As Command

1. Switch to the session that you want to save to a new session.

2. From the session’s File menu, choose Save Session As.

3. Type a filename for the new session.

So that you can distinguish between display and printer sessions, we
recommend that you maintain the file extensions of .EDP (display
session) and .EPP (printer session).

4. Choose Save.

To add a session icon to your EXTRA! program group in Windows NT 3.51

1. From the Program Manager File menu, choose New.

2. Select the Program Item option and choose the OK button.

The Program Item Properties dialog box is displayed.

3. In the Description field, type a short description of the icon.

4. Choose the Browse button.

The Browse dialog box is displayed.

5. In the Browse dialog box, change the Directories area from the
working directory to the directory in which EXTRA! was installed.
Double-click the subdirectory \SESSIONS.

6. Highlight the session that you want to include in your EXTRA!
Program Group and choose the OK button.

The Browse dialog box closes and the path and session name are
displayed in the Command Line field.

7. In the Working Directory field, type the path to EXTRA!.

For example, C:\Program Files\E!PC\Sessions.

8. Choose the OK button.
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Opening Sessions
Opening a session connects your PC to the host and provides a window
for accessing host data. You can open a session when you first start
EXTRA!, and from that session you can open additional sessions — as
many as your PC memory can handle.

You can open both display and printer sessions for any installed host
type.

To open a session

1. If you have a session open, do one of the following to open another
session:

• If the desired session is one of the three most recently opened
sessions, choose the session name from the bottom of the File
menu.

• From the File menu, choose Open Session.

• Choose the  button from the toolbar.

2. Type a session filename, or select a file from the list box.

By default, session files are located in Sessions. Display sessions
include the .EDP extension; printer sessions include the .EPP
extension.

Note: The mainframe demo session simulates a connection to the
host.

3. Choose Open.

The session window appears.
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Desktop Layouts
Desktop layouts allow you to open one or more EXTRA! windows in a
prearranged position on your screen. Desktop layouts are especially
useful for running multiple sessions. For example, you may consistently
work with three display sessions and one printer session. In addition,
you may have a QuickPad assigned for each display session. If this
arrangement of windows and utilities is saved as a layout, then you can
re-open all of them with a single command.

Using a desktop layout involves defining the how you want EXTRA!
windows to appear on your screen, saving this arrangement as a layout,
and then starting EXTRA! by opening the layout.

These procedures are described below.

To create a layout

1. Open sessions and any EXTRA! applications that you may want to
run concurrently.

2. Set the size and position of the windows.

3. Using the Options menu commands, set your session preferences.

4. From the File menu, choose Save Layout.

5. Type a new desktop layout filename, or scroll through the Filename
list and select an alternate layout file. (We suggest that you use the
.ELF extension.)

6. Choose OK.
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Open Layout Dialog Box

Use this dialog box to open a previously saved layout. If you already
have a session running, that session will be disconnected and closed
before the new session(s) are opened.

Load Layout Dialog Box

Open Layout: Opens a desktop layout — a set of EXTRA! windows
whose appearance and positions on the screen you define. When loaded,
the layout opens and positions the windows as previously saved.

Filename: Provides a text box for typing the layout filename. If the file
exists in the specified path, it appears in the list box. You can use *
(asterisk) as a wildcard. For example, you can type *.* to list all files. You
can also include the full path of a file.

File List Box: Lists the files in the selected folder. When you select a file,
the layout appears in the Layout Preview area. You can double-click the
file to open the layout.

List Files of Type: Shows the types of files that you can display in the list
box. By default, layouts include an ELF extension.

Drives: Lists the local and, if applicable, network drives that you can
select.

Folders: Lists the folders on the selected drive. To open a folder, double-
click it.

Network: Lists the network drives.

Layout Preview: Shows a preview of how the selected layout will appear
to help you choose the correct layout.
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To open a layout

1. From a desktop icon or Start menu, start EXTRA!.

2. In the Start by group, choose Opening an existing layout.

3. In the Open Layout dialog box, choose the name of the layout you
want.

4. Choose Open.

–or–

From an open session, choose Open Layout from the File menu.

5. Select a desktop layout filename.

6. Choose Open.

One or more EXTRA! windows appear as saved in the layout.

The Session Window
Depending on the type of session that you opened or created, EXTRA!
displays the window for a display or printer session. (If you open a
desktop layout, multiple windows of either session type can appear.)
This section provides an overview of each type of window.

Display Session Window
The illustration below shows a display session window for an IBM
mainframe connection. (The user interface for a display session is the
same for any type of host connection.) A display session includes the
standard window elements, including a status bar. You can toggle the
status bar on and off with the Status Bar command in the View menu.

The illustration shows a default session window as created by the New
Session Wizard. You can, however, customize how a session window
appears, operates, and interacts with you
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Printer Session Window
The illustration below shows a printer session window, from which you
can print IBM mainframe or AS/400 documents on a PC printer. For
details, refer to Chapter 7, “Printing.”

Note: A printer session is not required to print from a VAX/VMS, UNIX,
or asynchronous host.

Exiting Sessions
You can exit individual sessions, or you can exit EXTRA! completely
with one command. Exiting EXTRA! simultaneously closes all open
sessions and related programs, like Macro Editor.

Exiting from a single session breaks that session’s connection to the host
and closes the session window. Exiting from an unused session frees up
PC memory and makes a host resource available to other users. Other
open sessions and EXTRA! applications are unaffected. (Exiting the last
open session is equivalent to exiting the EXTRA! product.)

Note: To break a session’s host connection without closing its window,
disconnect rather than exit the session.

This section tells you how to disconnect a session, exit a session, and exit
from the EXTRA! product.

To disconnect a session

1. Log off the session.

2. From the Session menu, choose Disconnect.

3. If the session is connected, respond to the Disconnect prompt.

4. If you changed session settings without saving them, respond to the
Save prompt.
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To exit a single session

1. Log off the session.

2. From the File menu, choose Exit Session.

3. If the session is connected, respond to the Disconnect prompt.

4. If you changed session settings without saving them, respond to the
Save prompt.

To exit EXTRA!

1. Log off sessions.

2. From the File menu, choose Exit EXTRA!

3. If you changed session settings without saving them, respond to the
Save prompt.
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his chapter describes 3270 connection types available with EXTRA!.
To configure a connection you will need information about your

mainframe configuration, as well as your LAN configuration if you’re
running EXTRA! on a network.

To quickly find the connection type applicable to your connectivity, use
the table below.

Connection Type Page

802.2 Direct Connect 2-4

Attachmate Gateway via IPX/SPX 2-12

Attachmate Gateway via TCP/IP 2-15

Attachmate SNA Gateway via IPX/SPX 2-17

Attachmate SNA Gateway via TCP/IP 2-22

Cisco NCIA3 2-26

Dependent LU Requestor (DLUR) 2-35

DFT/Coax Direct Connect 2-40

DLSw Direct Connect 2-44

Eicon Gateway via IPX/SPX 2-51

Eicon SNA via NetBIOS 2-55

Hayes AutoSynch Direct Connect (SDLC) 2-58

IBM CICS Server 2-68

IrmaLAN Server via Banyan VINES 2-71

IrmaLAN Server via IPX/SPX 2-75

IrmaLAN Server via NetBIOS 2-79

LUA/LU0/RUI 2-83

T
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Connection Type Page

Microsoft SNA Server 2-87

NetWare for SAA via IPX/SPX 2-90

NetWare for SAA via TCP/IP 2-96

SDLC Direct Connect 2-102

SlideShow (Mainframe Demo) 2-109

TN3270 2-111

VINES to Banyan SNA Service 2-117

ZIP! Server via Banyan VINES 2-121

ZIP! Server via IPX/SPX 2-124

ZIP! SSNA via NetBIOS 2-127

ZIP! Server via TCP/IP 2-129
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802.2 Direct Connect (IBM Mainframe)
With the 802.2 Direct Connect protocol, you can connect token-ring or
Ethernet workstations to a mainframe on a token-ring network. A
gateway is not required. The mainframe, controller, or front-end
processor requires a token-ring interface coupler (TIC). If you are
connecting an Ethernet LAN to a token-ring network, a router that
supports transparent source routing is also required.

802.2 Direct Connect - System Requirements (IBM
Mainframe)

A DLC 802.2 connection requires:

• IBM’s token-ring interface coupler (TIC), installed in a 3270, 3725, or
3745 front-end processor, a 3174 control unit, or a 9370 mainframe

• Token-Ring LAN only:

Any token-ring LAN adapter, such as an IBM PC Network Adapter
II/A or an IBM Token-Ring Network PC Adapter (types /I, /II, or
/A), installed in the workstation

• Ethernet LAN only:

An Ethernet adapter installed in the workstation, and a bridge
supporting transparent source routing for connecting the Ethernet
LAN to the token-ring network.

The 802.2 Direct Connect, General Page (IBM Mainframe)

Use the 802.2 Direct Connect, General pagebox to specify LU resources to
be used for those connections. Consult your system administrator for the
correct values.
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New Session Wizard - 802.2 Direct Connect General page

You can change the following options or attributes:

Connection Definition list: Displays the currently available connection
definitions and shows the parameters for each definition.

Connection Name: Displays the name of the connection definition. This
name must be unique among all SDLC and 802.2 connections on your
workstation.

Destination Address: Displays the address of the mainframe.

Destination PU ID: Identifies to the host a PU used by your workstation.
The PU ID is an 8-digit hexadecimal number consisting of the 3-digit
IDBLK value followed by the 5-digit IDNUM value from your VTAM
definition.

Destination SAP: Identifies the Service Access Point (SAP) of the
controller, front-end processor, or mainframe to which the workstation is
connected. The SAP must be a hexadecimal multiple of 04 in the range of
04 to 254, for example, 08, 0C, 10, and so on. You can get this number
from your system administrator. The default SNA SAP is 04.
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Add: Adds a new connection definition with a name that you select and
default connection settings.

Edit: Changes the values of an existing connection definition.

Delete: Removes the selected connection definition.

Logical Unit (LU) Source for This Session

LU Pool: Makes a connection using the first available Logical Unit
(LU) from a given pool of LUs.

Pool Name: Lists the names of the LU pools that are configured for
802.2 connections.

Dedicated LU: Allows you to configure your session to a specific LU
number. If you select this option, you must enter a valid LU Number.

LU Number: Displays the LU number that will be used to make a
connection. For more information, contact your system
administrator.

Control Point (CP)

Network ID: Combined with the CP Name, forms a fully qualified
Control Point (FQCP) name.

CP Name: Combined with the Network ID, forms a fully qualified
Control Point (FQCP) name.

CP Alias: A local name used for the fully qualified Control Point
(FQCP) name, consisting of both the Network ID and the CP Name.
It is set to the CP Name if not specified.
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The Edit DLC 802.2 Definition Dialog Box (IBM Mainframe)

Use the Edit DLS 802.2 Definition dialog box to add a new 802.2
connection definition or to edit an existing one. Your system
administrator can provide you with the necessary values.

Edit DLC 802.2 definition dialog box

This dialog box has the following fields:

Support DLUR on This Link: Select this option to allow a connection
through a Dependent LU Requester (DLUR) to a Dependent LU Server
(DLUS).

Destination Parameters

Destination LAN Address (MAC): Indicates the address on the
mainframe. The format can be Ethernet or Token Ring based on your
mainframe configuration.

Token Ring: Indicates that you will be using a Token Ring address.

Ethernet: Indicates that you will be using a Ethernet address.
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Destination Physical Unit ID: Identifies to the host a PU used by
your workstation. The PU ID is an 8-digit hexadecimal number
consisting of the 3-digit IDBLK value followed by the 5-digit IDNUM
value from your VTAM definition.

Destination SAP: Identifies the Service Access Point (SAP) of the
controller, front end processor, or the mainframe to which the
workstation is connected. The SAP must be a hexadecimal multiple
of 04 in the range of 04 to 254, for example, 08, 0C, 10, and so on. You
can get this number from your system administrator. (The default
SNA SAP is 04.)

Workstation Parameters

I-Frame Size: Specifies the packet size of an information frame (I-
Frame), which the host uses to transfer data through your LAN
adapter to your workstation. Choose an I-Frame size that is
consistent with your workstation’s LAN Adapter and the I-Frame
size specified on the mainframe network. The default is 2042

Workstation SAP: Identifies the Service Access Point (SAP) for your
workstation.

LAN Adapter Number: Specifies which adapter you are using. You
can have up to two LAN adapters installed on your PC. If you are
configuring EXTRA! for a second adapter, change this value to 1;
otherwise use the default value

Destination Node Type

APPN Host (EN, NN): Select this option to connect to an up-level PU
type 2.1 node (Network Node or End Node).

PU 2.1 (LEN): Select this option to connect to a back-level Low-Entry
Networking (LEN) node. LEN nodes do not support APPN function.

PU 2.0 (XID0): Select this option to connect to a type 2.0 node.

LU Ranges

Pool Name: The name of the LU pool the range of LUs will belong to.

Base Name: The name of the LU range to which the LUs belong.

Minimum LU: The minimum LU value for the range.

Maximum LU: The maximum LU value for the range.
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Add: Creates a new LU range.

Edit: Changes the LU range.

Delete: Permanently removes the selected LU range.

To configure a DLC 802.2 (IBM Mainframe) connection

1. Start a new session, and select 802.2 Direct Connect as your
Connection type.

2. From the General page, select a connection definition.

3. Choose the Edit button to change the settings.

The Edit dialog box opens.

4. Set the appropriate destination parameters, workstation parameters,
and destination node type.

Refer to the Related Topics button below for more details on each
option. Contact your system administrator if you have any questions.

5. Choose the OK button to save your changes.

6. Select the appropriate Logical Unit source.

7. Enter the Control Point Network ID and Name for your node.
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The Edit LU Range Definition Dialog Box (IBM Mainframe)

Use the Edit LU Range Definition dialog box to add a new LU range
definition or edit an existing one.

Edit LU Range definition dialog box

This dialog box has the following fields:

Pool Name: Enter the name of the LU pool to which the range of LUs
will belong.

Base Name: Enter the name of the LU range to which the LUs belong.

Minimum LU: Enter the minimum LU value for the range.

Maximum LU: Enter the maximum LU value for the range.

To add a DLC 802.2 (IBM Mainframe) LU range)

1. From the 802.2 Direct Connect General page, select the connection
definition for which you want to add an LU range and choose the
Edit button.

The Edit DLC 802.2 Definition dialog box opens.

2. Choose the Add button.

The Add LU Range Definition dialog box opens.

3. Type the LU range definition.

4. Choose the OK button.
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To change a DLC 802.2 (IBM Mainframe) LU range

1. From the 802.2 Direct Connect General page, select the connection
definition for which you want to add an LU range and choose the
Edit button.

The Edit DLC 802.2 Definition dialog box opens.

2. Select the LU range that you want to change. Choose the Edit button.

The Edit LU Range Definition dialog box opens.

3. Type the appropriate changes.

4. Choose the OK button.

The Add DLC 802.2 Definition Dialog Box (IBM Mainframe)

Use the Add DLC 802.2 Definition dialog box to type in a name for your
connection definition. This name must be unique for all 802.2, SDLC,
COAXDFT, NCIA, and DLUR connections.

Add DLC 802.2 definition dialog box

You can change the following options or attributes:

Name: Type in a unique name for your definition.
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To create a new DLC 802.2 (IBM Mainframe) connection

1. Start a new session, and select 802.2 Direct Connect as your
connection type.

2. From the General page, choose the Add button to define a connection
definition.

The Add DLC 802.2 Definition dialog box opens.

3. Type a name for the new connection definition, then review and
change the default parameters as necessary.

4. Choose OK.

A new Connection Name will appear in the list of connection
definitions.

For more information on a particular field, refer to the General page topic
within this section. You may also use the What’s This? feature to get a
brief description of each field.

To delete a DLC 802.2 (IBM Mainframe) connection definition

1. With an 802.2 Direct Connect session open, from the 802.2
Connection Definition list,  select the connection definition. that you
want to delete, then choose the Delete button.

2. Choose the Delete button.

3. Choose OK when asked for confirmation.

Attachmate Gateway via IPX/SPX
You can communicate with IBM mainframes via an Attachmate Gateway,
using the IPX/SPX (Internetwork Packet Exchange/Sequenced Packet
Exchange) protocol.

Attachmate Gateway via IPX/SPX - System Requirements
Workstation requirements are listed below. If any of the Novell NetWare
files listed are not located on the workstation, check the NetWare server,
or contact your SAA Gateway administrator.

• A LAN adapter that supports IPX.

• Client service for NetWare.

• IPX/SPX Compatible transport.
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The Attachmate Gateway via IPX/SPX General Page

New Session Wizard - Attachmate Gateway via IPX/SPX General page

Use this page to define the Attachmate Gateway connection via IPX/SPX
protocol. From this page you will need to set the Resource Name and
your Workstation Name. You also have the option of setting how long
the system will try to connect and the number of retries.

The following section describes the individual fields on this page.

Resource Name: Identifies the name of the resource to which the
workstation will connect.

Workstation Name: Identifies the name of the workstation that will
connect to the server.

Connection Timeout (secs): Specifies how long EXTRA! for Windows 98
and Windows NT will wait before it aborts a connection.

Number of Retries: Specifies the number of times EXTRA! will try to
connect.
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The Attachmate Gateway via IPX/SPX Advanced Page

New Session Wizard - Attachmate Gateway via IPX/SPX Advanced page

Use this page to set the gateway options for your IPX/SPX connection.
You can choose from a list of available gateways or you can define your
own gateway.

The following section describes the individual fields on this page.

Available Gateways: Displays the available gateways based on your
existing network connection.

User Defined Gateway: Entry field where you can specify a gateway
name. The gateway name will then be added to the Select Gateway list.

Use Selected Gateways Only: Specifies that EXTRA! will only attempt to
make a connection with the gateways specified in the Selected Gateway
list.

Selected Gateways: Displays the gateway names that will be used to
establish a connection.

Add: Adds a gateway name to the Selected Gateway list.

Delete: Removes a gateway name from the Selected Gateway list.
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To configure an Attachmate Gateway connection via IPX/SPX

1. Start a new session, and select Attachmate Gateway via IPX/SPX as
your connection type.

2. From the General page, enter the resource to which the workstation
will connect.

3. Enter your workstation name. Each session can use a different
workstation name even when going to the same Attachmate
Gateway.

4. Enter a connection timeout value. The default is 10 seconds.

5. From the Advanced page, select a gateway from the Available
Gateway list or enter a gateway name or address in the User Defined
Gateway field.

6. Select Add.

7. Repeat Steps 5 and 6 for each gateway to which you want to try to
connect.

Attachmate Gateway via TCP/IP
You can communicate with IBM mainframes via an Attachmate Gateway,
using a TCP/IP (Transmission Control Protocol/Internet Protocol)
protocol.

Attachmate Gateway via TCP/IP - System Requirements
A TCP/IP connection requires:

• A communications adapter (Token-Ring or Ethernet adapter) or
modem using the Microsoft dial-up Networking adapter that passes
TCP/IP packets.

• A TCP/IP stack compliant with the Windows Sockets (WinSock) 1.1
specification.
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The Attachmate Gateway via TCP/IP General Page

New Session Wizard - Attachmate Gateway via TCP/IP General page

Use this page to define the Attachmate Gateway connection via TCP/IP
protocol. From this page you will need to set the Resource Name and
your Workstation Name. You also have the option of setting how long
the system will try to connect and the number of retries.

The following section describes the individual fields on this page.

Resource Name: Identifies the name of the resource to which the
workstation will connect.

Workstation Name: Identifies the name of the workstation that will
connect to the server.

Connection Timeout (secs): Specifies how long EXTRA! will wait before
it aborts a connection. The default is 0, which causes no timeout.

Gateway Selection

Enable LAN Broadcast: When selected, EXTRA! will broadcast a
resource request to all gateways on the LAN, connecting to the
resource of the first gateway that responds.

Host Alias/IP Address: Specifies the host name or IP address to
which the session will connect.
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To configure an Attachmate Gateway connection via TCP/IP

1. Start a new session, and select Attachmate Gateway via TCP/IP as
your connection type.

2. From the General page, enter the resource to which the workstation
will connect.

3. Enter your workstation name.

4. Enter a connection timeout value. The default is 10 seconds.

5. Enter the Host Alias/IP Address of the Attachmate Gateway.
–or–

Select the Enable LAN Broadcast option and EXTRA! will try to
connect to any available resource on your LAN (Local only).

Attachmate SNA Gateway via IPX/SPX Connection
With EXTRA! you can communicate with IBM mainframes via
Attachmate SNA Gateway, using an IPX/SPX (Internetwork Packet
Exchange/Sequenced Packet Exchange) protocol. This section describes
the Attachmate SNA Gateway connectivity options for IPX/SPX. To set
these options, you will need information about gateway names, group
names, and resource names.

Attachmate SNA Gateway via IPX/SPX - System
Requirements

Workstation requirements are listed below. If any of the Novell NetWare
files listed are not located on the workstation, contact your system
administrator.

• A LAN adapter that supports IPX

• Client Service for NetWare

• IPX/SPX compatible transport

The gateway computer must run version 2.0 or later of Attachmate SNA
Gateway.
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The Attachmate SNA Gateway via IPX/SPX General Page

Use this page to configure an Attachmate SNA Gateway connection via
IPX/SPX. You can define a new connection configuration, edit an
existing configuration, or you can enable or disable a configuration from
the Connection list. This page also has copy/paste features which make it
easier to create a series of connection configurations.

New Session Wizard - Attachmate SNA Gateway via IPX/SPX General
Page
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The following section describes the fields on this page.

Connection list: Displays the currently available connection definitions
and shows the parameters for each definition. You can configure up to
six connections for each session..

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Gateway Name: Specifies the names of the gateways to which you
want to attach. Place a check in the box next to the gateways to which
you want to attempt to connect for your session.

Group Name: Specifies a group to which the gateway belongs.
EXTRA! will connect to the gateway from this group with the lightest
load.

Resource Name: Specifies a selected resource from the gateway. This
resource is common to the other gateways in the selected gateway’s
group as well.

Add: Configures a new connection.

Edit: Modifies the selected Connection.

Delete: Removes the selected connection entry from the Connection list.

Copy: Copies the selected entry from the connection list to a temporary
buffer.

Paste: Pastes the selected entry from the temporary buffer into the
Connection list.

List Retries

Enable Infinite List Retries: Continues to attempt a connection until
successful.

Number of Retries: Indicates the number of times EXTRA! will try to
make a connection after each unsuccessful attempt. Use the arrows to
increase or decrease the number of retries. You can select a number
between 0 and 99. The default is 0.

Delay Between Servers (secs): Indicates the amount of time
(seconds) EXTRA! will wait before trying the next selected gateway
in the Connection list. The default is 3 seconds.

Connection Timeout (secs): Indicates the amount of time (seconds)
EXTRA! will wait to establish a connection. The default is 10 seconds.
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Up/Down Buttons: Reorders the gateway names within the Connection
list. The order determines which gateway name is tried first, then second,
and so on until a connection is made.

Enable Server Failure Rollover: If this option is selected and the
connected gateway fails after the session is established, EXTRA! attempts
to continue the session by connecting to the next gateway in the
Connection list.

The Add/Edit Connection Dialog Box

Add/Edit Connection dialog box

Use this dialog box to define a connection for an Attachmate SNA
Gateway via IPX/SPX or to edit an existing connection definition.

This dialog box has the following options:

Gateway Name: Specifies the gateway to use. Type in a gateway name,
or select one from the list.

Group Name: Displays the group or groups to which the specified
gateway belongs. To help balance the load on related gateways, EXTRA!
connects to the least-loaded gateway from the selected group. To connect
only to the specified gateway and not another gateway in the same
group, select the asterisk (*).
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Resource: Displays the resource pools connected to the selected gateway
or group. Selecting the asterisk (*) is equivalent to selecting “Clients”
from the list.

Information: Displays various details about the selected gateway.

To configure an Attachmate SNA Gateway connection via IPX/SPX

1. Start a new session, and select Attachmate SNA Gateway via
IPX/SPX as your connection type.

2. From the General page, click the Add button.

The Add/Edit Connection dialog box appears.

3. In the Gateway Name field, type the name of the Attachmate SNA
Gateway to which you want to attach, or select a gateway from the
list.

4. From the Group Name list, select the name of the group to which the
gateway belongs. If you select the asterisk (*), EXTRA! will connect
only to the gateway specified in the Gateway Name field; it will not
attempt to connect to any of other gateways grouped with the
specified gateway.

5. From the Resource list, select a resource pool to use. Selecting the
asterisk (*) is equivalent to selecting “Clients” from the list.

6. When you are satisfied with your selections, click the OK button to
save the configuration.

The connection configuration will now appear in the connection list
on the Attachmate SNA via IPX/SPX Gateway General page.
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Attachmate SNA Gateway via TCP/IP Connection
With EXTRA! you can communicate with IBM mainframes via
Attachmate SNA Gateway, using TCP/IP (Transmission Control
Protocol/Internet Protocol). This section describes the Attachmate SNA
Gateway connectivity options for TCP/IP. To set these options, you will
need information about gateway names, group names, resources, and IP
addresses.

Attachmate SNA Gateway via TCP/IP - System Requirements
To establish an Attachmate SNA Gateway connection via TCP/IP,
EXTRA! requires:

• A TCP/IP compatible transport on the workstation.

• Attachmate SNA Gateway version 2.0 or later on the gateway
computer.

The Attachmate SNA Gateway via TCP/IP General Page

Use this page to configure an Attachmate SNA Gateway connection via
TCP/IP. You can define a new connection configuration, edit an existing
configuration, or you can enable or disable a configuration from the
Connection list. This page also has copy/paste features which make it
easier to create a series of connection configurations.
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New Session Wizard - Attachmate SNA Gateway via TCP/IP General page

The following section describes the fields on this page.

Connection list: Displays the currently available connection definitions
and shows the parameters for each definition. You can configure up to
six connections for each session.

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Gateway  Name: Specifies the names of the gateways to which you
want to attach. Place a check in the box next to the gateways to which
you want to attempt to connect for your session.

Group Name: Specifies a group to which the gateway belongs.
EXTRA! will connect to the gateway from this group with the lightest
load.

Resource Name: Specifies a selected resource from the gateway. This
resource is common to the other gateways in the selected gateway’s
group as well.
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Add: Configures a new connection.

Edit: Modifies the selected connection.

Delete: Removes the selected connection entry from the Connection list.

Copy: Copies the selected entry from the Connection list to a temporary
buffer.

Paste: Pastes the selected entry from the temporary buffer into the
Connection list.

List Retries

Enable Infinite List Retries: Continues to attempt a connection until
successful.

Number of Retries: Indicates the number of times EXTRA! will try to
make a connection after each unsuccessful attempt. Use the arrows to
increase or decrease the number of retries. You can select a number
between 0 and 99. The default is 0.

Delay Between Servers (secs): Indicates the amount of time
(seconds) EXTRA! will wait before trying the next selected gateway
in the Connection list. The default is 3 seconds.

Connection Timeout (secs): Indicates the amount of time (seconds)
EXTRA! will wait to establish a connection. The default is 10 seconds.

Up/Down Buttons: Reorders the gateway names within the Connection
list. The order determines which gateway name is tried first, then second,
and so on until a connection is made.

Port Number: Port 2317 is assigned to EXTRA!. It is recommended that
this value remain unchanged unless it conflicts with another TCP
application.

Enable Server Failure Rollover: If this option is selected and the
connected gateway fails after the session is established, EXTRA! attempts
to continue the session by connecting to the next gateway in the
Connection list.
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The Add/Edit Connection Dialog Box

Use this dialog box to define a connection for an Attachmate SNA
Gateway via TCP/IP or to edit an existing connection definition. To
define a connection you need to select a gateway, server, and resource.

Add/Edit Connection dialog box

This dialog box has the following fields:

Gateway Name: Specifies the gateway to use. Type in the name or IP
address of an Attachmate SNA gateway.

Group Name: Displays the group or groups to which the specified
gateway belongs. To help balance the load on related gateways, EXTRA!
connects to the least-loaded gateway from the selected group. To connect
only to the specified gateway and not another gateway in the same
group, select the asterisk (*).

Resource Name: Displays the resources connected to the selected
gateway or group. Selecting the asterisk (*) is equivalent to selecting
“Clients” from the list.

Information: Displays various details about the selected gateway.
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To configure an Attachmate SNA Gateway connection via TCP/IP

1. Start a new session, and select Attachmate SNA Gateway via TCP/IP
as your connection type.

2. From the General page, click the Add button.

The Add/Edit Connection dialog box appears.

3. In the Gateway Name field, type the name or IP address of the
Attachmate SNA Gateway to which you want to attach, or select a
gateway from the list.

4. From the Group Name list, select the name of a group to which the
gateway belongs. If you select the asterisk (*), EXTRA! will connect
only to the gateway specified in the Gateway Name field; it will not
attempt to connect to any of other gateways grouped with the
specified gateway.

5. Select a resource from the Resource list.

6. When you are satisfied with your selections, click the OK button to
save the configuration.

The connection configuration will now appear in the connection list
on the Attachmate SNA via TCP/IP Gateway General page.

Cisco NCIA Connection
You can communicate with IBM mainframes via a Cisco NCIA (Native
Client Interface Architecture) Connection. NCIA is a communication
protocol that simulates a direct connection to a host by encapsulating
SNA traffic into TCP/IP packets for media independent transmission.
This method creates a direct connection to the host without the critical
transmission timing requirements of a true direct connection. If you are
connecting an Ethernet LAN to a Token-Ring network, a router that
supports Transparent Source Routing is also required.

EXTRA! also provides Dependent LU Requester (DLUR) connections
using NCIA protocol.
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Cisco NCIA - System Requirements
A Cisco NCIA connection requires:

• An IBM Token-Ring Interface Coupler (TIC), installed in a 3270, 3725,
or 3745 Front End Processor, a 3174 Control Unit, or a 9370
mainframe.

• A communications adapter (Token-Ring or Ethernet adapter) or
modem that passes TCP/IP packets.

• A TCP/IP protocol compliant with the Windows Socket (WinSock)
1.1 specification.

• A Cisco router with Remote Source Route Bridging installed and
enabled.

• Your workstation’s TCP/IP address configured on the Cisco router.

The Cisco NCIA General Page

New Session Wizard - Cisco NCIA General page

Use this page to select and create connection definitions for your Cisco
NCIA connection. A connection definition consists of a Connection Name
that you supply, a Destination Address, and a Destination TPC/IP
Address (if applicable). The link can also be DLUR (Dependent LU
Requester) enabled.
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You can also opt to enter the fully-qualified Control Point name (or alias).

The following section describes the fields on this page.

Connection Definition list: Displays the currently available connection
definitions and shows the parameters for each definition.

Connection Name: A name that you specify for a connection
definition. This name must be unique within all 802.2, SDLC,
COAXDFT, NCIA, and DLUR connections for your workstation.

Destination Address: The address of the mainframe. Change this
value in the Edit dialog box.

Destination TCP/IP Address: The TCP/IP address of the Cisco
router to which the workstation connects.

Add: Creates a new connection definition with a name that you select
and default connection settings.

Edit: Allows you to change settings for the selected connection definition.

Delete: Removes the selected connection definition.

Logical Unit Source for This Session

LU Pool: Makes a connection using the first available Logical Unit
(LU) from a given pool of LUs. If you select this option, you must
enter a valid LU Range (minimum and maximum).

Pool Name: Lists the names of the LU pools that are configured for
NCIA connections.

Dedicated LU: Allows you to configure your session to a specific LU
number. If you select this option, you must enter a valid LU Number.

LU Number: Enter a valid Logical Unit #. For more information,
contact your system administrator.

Control Point (CP)

Network ID: Combined with the CP Name, forms a fully qualified
Control Point (FQCP) name.

CP Name: Combined with the Network ID, forms a fully qualified
Control Point (FQCP) name.

CP Alias: A local name used for the fully qualified Control Point
(FQCP) name, consisting of both the Network ID and the CP Name.
It is set to the CP Name if not specified.
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The Edit Cisco NCIA Definition Dialog Box

Edit Cisco NCIA Definition dialog box

Use this dialog box to configure an NCIA connection. You will need to
select the appropriate destination parameters and workstation
parameters.

The following section describes the fields within this dialog box.

Support DLUR on This connection: Select this option to allow a
connection through a Dependent LU Requester (DLUR) to a Dependent
LU Server (DLUS).
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Destination Parameters

Destination LAN Address: Indicates the address on the mainframe.
The format can be Ethernet or Token Ring based on your mainframe
configuration.

Token Ring: Indicates that you will be using a Token Ring address.

Ethernet: Indicates that you will be using a Ethernet address.

APPN Host (EN, NN): Select this option when connecting to an up-
level PU type 2.1 node (Network Node or End Node).

PU 2.1 (LEN): Select this option when connecting to a back-level
Low-Entry Networking (LEN) node. LEN nodes do not support
APPN function.

PU 2.0 (XID0): Select this option when connecting to a type 2.0 node.

TCP/IP Address: Identifies the TCP/IP address of the Cisco router to
which the workstation connects.

Virtual Ring: Identifies the virtual ring on the Cisco router that your
TCP/IP address is configured on.

Local Acknowledgment: Uses your TCP/IP address for local
acknowledgment by the Cisco router.

Destination PU ID: Identifies your workstation to the mainframe.

Destination SAP: Identifies the Service Access Point (SAP) of the
controller, front end processor, or the mainframe to which the
workstation is connected.

Workstation Parameters groupbox

I-Frame Size: Defines the packet size of an information frame (I-
Frame), which the mainframe uses to transfer data through your
LAN adapter to your workstation.

Workstation SAP: Identifies the Service Access Point (SAP) of your
workstation.

Local LAN Address (MAC): Identifies the LAN address of your
workstation.

Local Ring: Identifies the network ring of your workstation.

Local Bridge: Identifies the network bridge that the network ring
uses to communicate to different rings.
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LU Ranges

Pool Name: The name of the LU pool the range of LUs will belong to.

Base Name: The name of the LU range the LUs belong to.

Minimum LU: The minimum LU value for the range.

Maximum LU: The maximum LU value for the range.

Add: Creates a new LU range.

Edit: Modifies the LU range.

Delete: Permanently removes the selected LU range.

To configure a Cisco NCIA connection definition

1. Start a new session, and select Cisco NCIA as your connection type.

2. From the General page, select a connection definition.

3. Choose the Edit button to change the settings.

The Edit dialog box opens.

4. Set the appropriate destination parameters and workstation
parameters.

Refer to the Related Topics button below for more details on each
option. Contact your system administrator if you have any questions.

5. Choose the OK button to save your changes.

6. Select the appropriate Logical Unit source.

7. Enter the Control Point Network ID and Name for your node.
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The Edit LU Range Definition Dialog Box

Edit LU Range Definition dialog box

Use this dialog box to add a new LU range definition or edit an existing
one.

The following section describes the fields within this dialog box.

Pool Name: Enter the name of the LU pool the range of LUs will belong
to.

Base Name: Enter the name of the LU range the LUs belong to.

Minimum LU: Enter the minimum LU value for the range.

Maximum LU: Enter the maximum LU value for the range.

To add an LU range

1. From the Cisco NCIA General page, select the connection definition
for which you want to add an LU range and choose the Edit button.

The Edit Cisco NCIA Definition dialog box opens.

2. Choose the Add button.

The Add LU Range Definition dialog box opens.

3. Type the LU range definition.

4. Choose OK.
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To change an LU range

1. From the Cisco NCIA General page, select the connection definition
for which you want to add an LU range and choose the Edit button.

The Edit Cisco NCIA Definition dialog box opens.

2. Select the LU range that you want to change. Choose the Edit button.

The Edit LU Range Definition dialog box opens.

3. Type the appropriate changes.

4. Choose OK.

The Add NCIA Definition Dialog Box

Add Cisco NCIA Definition dialog box

Name: Type in a unique name for your definition.

Use this dialog to type in a name for your connection definition. This
name must be unique for all 802.2, SDLC, COAXDFT, NCIA, and DLUR
connections.

To add a Cisco NCIA connection definition

1. Start a new session, and select Cisco NCIA as your connection type.

2. From the General page, choose the Add button.

The Add Cisco NCIA Definition dialog box opens.

3. Enter a valid name, then review and change the default parameters
as necessary.

4. Click OK.

A new Connection Name will appear in the list of connection
definitions.
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To delete a Cisco NCIA connection definition

1. With a Cisco NCIA session open, from the Cisco NCIA Connection
Definition list, select a connection definition.

2. Choose the Delete button.

3. Choose OK when asked for confirmation.

Demo Connection Tool
The Demo feature provides demo files (.SDB) that you can select to
simulate a connection to the host.

Demo Connection Tool - General Page

Demo Connection Tool General page

Filename: Type the name of the demonstration file (.SDB) you wish to
view.

Browse button: Choose to search for a specific demonstration file.

From this page, you can select a demonstration file (.SDB) that simulates
a host session.
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To setup a demo connection

1. Start a new session, and select Demo as your connection type.

2. From the next page, select the name of the demonstration file (.SDB)
you wish to view. Choose Browse to view a list of demonstration
files.

Dependent LU Requestor (DLUR)
By establishing DLUR connections with EXTRA!, you can route 3270 LU
information through APPN traffic. EXTRA! supports DLUR with the
following connectivity types:

• Cisco NCIA

• DLC 802.2

• DLSw

• Hayes AutoSync

• SDLC

Dependent LU Requestor (DLUR) - System Requirements
To establish a 3270 connection using DLUR, EXTRA! requires one or
more of the connectivities which support DLUR (Cisco NCIA, DLC 802.2,
DLSw, Hayes AutoSync, SDLC) to be installed on the workstation.
Alternately, you can install one or more of the APPN Node variations of
these connectivities while installing EXTRA! by choosing Custom as your
Setup Type.

The Dependent LU Requestor General Page

Use this page to select and create DLUR connection definitions and to
specify LU resources to be used for those connections. Consult your
system administrator for the correct values.
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New Session Wizard - Dependent LU Requestor General page

The following section describes the fields on this page.

Connection Definitions for This Session: Displays the currently
available connection definitions and shows the parameters for each
definition.

Connection Name: Displays the unique name by which the
connection is listed in the current node configuration file.

Primary DLUS: Displays the name of the connection’s primary DLU
server.

PU ID: Identifies to the host the PU used by your workstation. The
PU ID is an 8-digit hexadecimal number consisting of the 3-digit
IDBLK value followed by the 5-digit IDNUM value from your
VTAM definition.

Add: Adds a new connection definition with a name and settings
that you provide.

Edit: Changes the settings of the selected connection definition.

Delete: Removes the selected connection definition.

Logical Unit (LU) Source for This Session: Indicates whether the
connection will use a dedicated LU or an LU from a pool.
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LU Pool: Makes a connection using the first available Logical Unit
(LU) from a given pool of LUs.

Pool Name: Lists the names of LU pools configured for DLUR
connections. The default pool name is the first LU pool that belongs
to the connection definition highlighted in the connection definition
list. Other LU pools may be used as well.

Dedicated LU: Indicates that the session will use a specific LU
number. If you select this option, you must enter a valid LU Number.

LU Number: your system, contact your system administrator.

Control Point (CP)

Network ID: Combined with the CP Name, forms a fully qualified
Control Point (FQCP) name.

CP Name: Combined with the Network ID, forms a fully qualified
Control Point (FQCP) name.

CP Alias: A local name used for the fully qualified Control Point
(FQCP) name, consisting of both the Network ID and the CP Name.
It is set to the CP Name if not specified.

The Dependent LU Requestor Transport Page

Use this page to add, edit, and delete connection definitions for
connectivities which support DLUR. Consult your system administrator
for the correct values.
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New Session Wizard - Dependent LU Requestor Transport page

The following section describes the fields on this page.

Connection Name: The unique name by which the connection is listed in
the current node configuration file.

Destination: The LAN address of the LU with which the session will
connect.

Supports DLUR: Indicates whether the connection supports DLUR.

Connectivity: The connectivity to be used for the connection.

Add: Choose to create a new connection.

Edit: Choose to edit the selected connection’s settings.

Delete: Deletes the selected connection from the list of connections.
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To configure a DLUR connection

1. Start a new session, and select Dependent LU Requestor as your
connection type.

2. From the General page, choose an action as follows:

To Do this

Add a new DLUR
connection definition

Choose the Add button.

Edit a connection Select a DLUR definition from the list,
then choose the Edit button.

Delete a connection Select a DLUR definition from the list,
then choose the Delete button.

3. From the connection definition list, highlight the definition you want
to use.

4. Select LU Pool, then choose an LU pool name from the Pool Name
list.

–or–

Select Dedicated LU, then enter the LU number for the LU you want
to use.

5. Edit the Control Point information in the Network ID, CP Name, and
CP Alias fields as needed.

6. From the Transport page, choose an action as follows:

To Do this

Add a new DLUR transport connection
definition

Choose the Add button.

Edit the selected transport connection
definition

Select a connection from
the list, then choose the
Edit button.

Delete the selected transport definition Select a connection from
the list, then choose the
Delete button.
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DFT/Coax Direct Connect
The DFT/Coax Direct Connect protocol allows you to communicate with
an IBM mainframe using a coax adapter board.

To establish the physical connection between a PC and a compatible host
system, you only need to install a coax adapter into the PC and connect it
to a coax port on the host. This product supports IBM, IRMA, and
Attachmate coax adapters.

If you are configuring a connection under Windows NT, you must first
select a coax adapter.

DFT/Coax Direct Connect - System Requirements
A coax connection requires:

• One of the following adapters installed on your PC.

— Attachmate Advanced 3270 Adapter (PC/AT)

— Attachmate IRMA3t Adapter

— Attachmate MacIRMA PCI Coax

— IBM Coax

— PCMCIA Coax

• A compatible host system, such as one of the following:

— 3174, 3274, or 3276 Control Unit

— 360, 370, 3081, 3083, 3090, 4300, or 9370 mainframe

Note: To configure a connection under Windows NT, you must first
select an adapter. To use Irma3 Coax hardware, you need to download
the microcode that came with the hardware before you run the client
software. The downloaded microcode should match how the hardware
was installed through the .INF process, either IRMA in PJ Mode, or
IRMA in IBM Mode.
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The DFT/Coax Direct Connect Session Page

New Session Wizard - DFT/Coax Direct Connect Session page

Use this page to specify the Connection Type needed for a Coax DFT
connection. You can specify a pooled connection or you can specify a
specific connection number. You also have the option of activating this
connection during startup.

The following section describes the fields on this page:

LU Ranges: The Pool Name, Base Name, Minimum LU and Maximum
LU for the LU ranges.

Add: Displays the Add LU Range Definition dialog so that you can create
a new LU range.

Edit: Displays the Edit Add LU Range Definition dialog so that you can
change values associated with your LU ranges.

Delete: Permanently removes the selected LU range.
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Connection source for this session: Allows you to set your Logical Unit
Type to Pooled or Explicit.

Pooled: Makes a connection using the first available connection from
a given pool of connections.

Pool Name: Lists the names of the LU pools that are configured for
NCIA connections.

Explicit: Configures your session to a specific connection #. You
must enter a valid connection # in the Connection # field.

Connection #: Specifies a specific connection #. For more
information, contact your system administrator.

I-Frame Size: Defines the packet size of an information frame (I-frame),
which the mainframe uses to transfer data through your LAN adapter to
your workstation. Choose an I-frame size that is consistent with your
workstations’s LAN adapter and the I-frame size specified on the
mainframe network.

Suppress UNBIND: Suppresses inbound UNBIND requests.

To configure a 3270 adapter

1. From the Control Panel, select the 3270 Coax adapter.

The 3270 Adapter Configuration dialog box appears.

2. Select the appropriate adapter from the Adapter Type list.

3. Modify the Adapter Parameters if necessary.

4. Choose OK to save and exit the 3270 Adapter Configuration dialog
box.

5. When prompted, restart your computer.

You are now ready to configure a 3270 Coax connection.

Note: If you are using IRMA3 Coax hardware, you need to download
the microcode that came with the hardware before you run the client
software. The downloaded microcode should match how the
hardware was installed through the .INF process, either IRMA in PJ
Mode, or IRMA in IBM Mode.
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To configure a coax connection

Note: If you are configuring a connection under Windows NT, you
must first configure a 3270 adapter.

1. Start a new session, and select DFT/COAX Direct Connect as your
Connection type.

2. From the Session page and choose Pooled Connection or Explicit
Connection. If you choose Explicit you must enter a logical unit
number in the field provided.

3. (Optional) Set the Activate on Startup option if you want this session
to automatically connect during startup.

For more information on a particular field, refer to the Session page topic
within this section. You may also use the What’s This? feature to get a
brief description of each field.

The Edit LU Range Definition Dialog Box

Edit LU Range Definition dialog box

Use this dialog box to add a new LU range definition or edit an existing
one.

The following section describes the fields within this dialog box.

Pool Name: Enter the name of the LU pool to which the range of LUs
will belong.

Base Name: Enter the name of the LU range to which the LUs belong.

Minimum LU: Enter the minimum LU value for the range.

Maximum LU: Enter the maximum LU value for the range.
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To add an LU range

1. From the DFT/Coax Session page, choose the Add button.

The Add LU Range Definition dialog box opens.

2. Type the LU range definition.

3. Choose OK.

To edit an LU range

1. From the DFT/Coax Session page, select the connection definition
for which you want to add an LU range and choose the Edit button.

The Edit LU Range Definition dialog box opens.

2. Type the appropriate changes.

3. Choose OK.

DLSw Direct Connect (IBM Mainframe)
You can communicate with IBM mainframes via a Data Link Switching
(DLSw) Direct Connection. DLSw Direct Connect is an industry standard
for encapsulating LLC2 or DLC 802.2 data within TCP/IP data packets.
While DLSw is normally used for communicating between routers, it can
be used for communicating between a workstation and a router to pass
LLC2 data over a TCP network or over the Internet to a host without the
timing limitations of DLC 802.2.

DLSw Direct Connect - System Requirements (IBM
Mainframe)

An IBM mainframe-DLSw connection requires a TCP/IP connection to a
router that supports and is configured for each specific workstation. A
Token Ring or Ethernet card is not required on the workstation if using a
modem with the Dial Up Networking support from Microsoft.

The DLSw Direct Connect General Page (IBM Mainframe)

Use the DLSw Direct Connect, General page to select and create
connection definitions for your DLSw Direct connection. A connection
definition consists of a Connection Name that you supply, a Destination
Address and a Destination TCP/IP Address on the mainframe. The link
can also be DLUR (Dependent LU Requester) enabled.
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New Session Wizard - DLSw Direct Connect General page

This page has the following fields:

Connection Definition For This Session list

Displays the currently available connection definitions and shows the
parameters for each definition.

Add: Displays the Add DLSw Connection Definition dialog box from
which you can create a new connection definition.

Edit: Displays the Edit DLSw Connection Definition dialog box from
which you can change values associated with your connection definition.

Delete: Permanently removes the selected connection definition.
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Logical Unit Source for This Session

LU Pool: Makes a connection using the first available Logical Unit
(LU) from a given pool of LUs. If you select this option, you must
enter a valid LU Range (minimum and maximum).

Pool Name: Lists the names of the LU pools that are configured for
NCIA connections.

Dedicated LU: Configures your session to a specific LU number. If
you select this option, you must enter a valid LU Number.

LU Number: Allows you to enter a number for a specific LU to be
used when you connect to the host with this session setting. If you
use a specific LU, if the LU is already in use, you may have to wait
until it becomes available.

Control Point (CP)

Network ID: Combined with the CP Name, forms a fully qualified
Control Point (FQCP) name.

CP Name: Combined with the Network ID, forms a fully qualified
Control Point (FQCP) name.

CP Alias: A local name used only on this workstation. It is set to the
CP Name if not specified.
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The Edit DLSw Connection Definition Dialog Box (IBM Mainframe)

Edit DLSw Definition dialog box

Use the Edit DLSw Definition dialog box to configure a DLSw
connection. You will need to select the appropriate destination
parameters, workstation parameters, and destination node type. You
may also choose whether or not to support DLUR with this link.
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You can change the following options or attributes:

Support DLUR on This Link: Allows a connection through a Dependent
LU Requester (DLUR) to a Dependent LU Server (DLUS).

Dependent LU Server (DLUS)

Destination LAN Address (MAC): Indicates the address on the
mainframe. The format can be Ethernet or Token Ring based on your
mainframe configuration.

Token Ring: Indicates that you will be using a Token Ring address.

Ethernet: Indicates that you will be using an Ethernet address.

TCP/IP: Indicates the TCP/IP address of the router to make the
DLSw connection to. The router passes the LLC2 data to the host.

Destination PU ID: A number that identifies your workstation to the
mainframe.

Destination SAP: Identifies the Service Access Point (SAP) of the
controller, front end processor, or the mainframe to which the
workstation is connected.

I-Frame Size: Defines the packet size of an information frame (I-
Frame), which the mainframe uses to transfer data through your
LAN adapter to your workstation.

Workstation SAP: Identifies the Service Access Point (SAP) for your
workstation.

Local LAN Address (MAC): Indicates the LAA or MAC address of
the workstation to be sent to the router. This value does not have to
be the same as the value for the workstation’s real LAA or MAC
address. Enter a value 12 hex characters long whether you have a real
network card or not.

APPN Host (EN, NN): Indicates a connection to an up-level PU type
2.1 node (Network Node or End Node).

PU 2.1 (LEN): Indicates a connection to a back-level Low-Entry
Networking (LEN) node. LEN nodes do not support APPN function.

PU 2.0 (XID0): Indicates a connection to a type 2.0 node.
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LU Ranges: Displays a list of LU ranges which includes the name of the
LU pool, the name of the LU range and the minimum and maximum LU
value for the range.

Pool Name: Enter the name of the LU pool to which the range of LUs
will belong.

Base Name: Enter the name of the LU range to which the LUs belong.

Minimum LU: Enter the minimum LU value for the range.

Maximum LU: Enter the maximum LU value for the range.

To configure a DLSw connection (IBM Mainframe)

1. Start a new session, and select DLSw Direct Connect as your
Connection type.

2. From the General page, select a connection definition.

3. Choose the Edit button to change the settings.

The Edit DLSw Connection Definition dialog box opens.

4. Set the appropriate destination parameters, workstation parameters,
and destination node type and enter the alias or the TCP/IP Address.

Contact your system administrator if you have any questions.

5. Choose the OK button to save your changes.

6. Select the appropriate Logical Unit type and range (if necessary).

7. Enter the Control Point Network ID and Name for your node.
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The Add Connection Definition Dialog Box (IBM Mainframe)

Add DLSw Connection Definition dialog box

Use the Add Connection Definition dialog box to type in a name for your
connection definition. This name must be unique for all DLC 802.2,
SDLC, COAX DFT, DLSw, Twinax, MPTN, Hayes AutoSync, and DLUR
connections.

To create a new connection definition (IBM Mainframe)

1. Start a new session, and select DLSw Direct Connect as your
Connection type.

2. From the General page, choose the Add button.

The Add DLSw Connection Definition dialog box opens.

3. Enter a valid name.

4. Click OK.

A new Connection Name will appear in the list of connection
definitions.

For more information on a particular field, refer to the General page topic
within this section.

To delete a connection definition (IBM Mainframe)

1. From the DLSw Direct Connect General page, select a connection
definition.

2. Choose the Delete button.

3. Choose Yes when asked for confirmation.
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Eicon Gateway via IPX/SPX Connection
Using EXTRA! you can communicate with IBM mainframes via the Eicon
Gateway, using an IPX/SPX (Internetwork Packet Exchange/Sequenced
Packet Exchange) protocol. This section describes the Eicon gateway
connectivity options. To set these options, you will need information
about gateway names, PU names, LU numbers, and port IDs.

Eicon Gateway via IPX/SPX - System Requirements
Workstation requirements are listed below. If any of the Novell NetWare
files listed are not located on the workstation, contact your system
administrator.

• A LAN adapter that supports IPX

• Client Service for NetWare

• IPX/SPX compatible transport

The Eicon Gateway via IPX/SPX General Page

New Session Wizard - Eicon Gateway via IPX/SPX General page
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Use this page to configure an Eicon Gateway connection via IPX/SPX.
You can define a new connection, edit an existing connection, or you can
enable or disable a connection from the Connection list. This page also
has copy/paste features which make it easier to create a series of
connections.

Connection list: Displays the currently available connection definitions
and shows the parameters for each definition. You can configure up to
six connections for each Eicon session.

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Add: Configures a new connection.

Edit: Modifies the selected configuration.

Delete: Removes a connection entry from the Connection list.

Copy: Copies the selected entry from the Connection list to a temporary
buffer.

Paste: Pastes the copied entry from the temporary buffer into the
Connection list.

List Retries

Enable Infinite List Retries: Indicates that EXTRA! will continue to attempt a
connection until successful.

Number of Retries: Indicates the number of times EXTRA! will try to make a
connection after each unsuccessful attempt. Use the arrows to increase or decrease the
number of retries. You can select a number between 0 and 99. The default is 0.

Retry Delay (secs): Indicates the amount of time (seconds) EXTRA! will wait between
retries. The default is 1 second.

Connection Timeout (secs): Indicates the amount of time (seconds) EXTRA! will wait
to establish a connection. The default is 5 seconds.
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The Add/Edit Connection Dialog Box

Add/Edit Connection dialog box

Use this dialog box to define a connection for an Eicon Gateway via
IPX/SPX. To define a connection you need to specify a gateway name, a
PU name, an LU number, and a port ID. Each field you will need to
define is described in detail below.

Gateway: Specifies the names of the Eicon Gateways to which you want
to attach. To add a gateway name, select one of the names in the list and
type a new name in its place. BROADCAST will always remain in the list.
If you select BROADCAST, your workstation will broadcast to the first
gateway that responds (if it matches the PU name).

PU Name: Specifies the name of the PU (physical unit) as defined on the
gateway. The default is SNAGATE.

LU Number: Specifies the LU (logical unit) number. The LU number you
select must match an LU type defined on the gateway that supports the
terminal characteristics you require. If you select ANY, EXTRA! will
select the next available LU number.

Port ID: Selects the number assigned to the EiconCard or a port on a
multiport Eicon Card. The Port ID identifies the line you want to use on
an Eicon Gateway (the ID is assigned to a PU name when the gateway is
configured). A maximum of 15 ports is available on a gateway.
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To configure an Eicon Gateway connection via IPX/SPX

1. Start a new session, and select Eicon Gateway via IPX/SPX as your
connection type.

2. From the General page, click the Add button.

The Add/Edit Connection dialog box appears.

3. In the Gateway field, type the names of the Eicon Gateways to which
you want to attach. BROADCAST will always remain in the list. If
you select BROADCAST, your workstation will broadcast to the first
gateway that responds (if it matches the PU name).

4. In the PU Name field, select the name of the PU (physical unit) as
defined on the gateway. The default is SNAGATE.

5. From the LU Number list, select the LU (logical unit) number you
want to use. The LU number you select must match an LU type
defined on the gateway that supports the terminal characteristics you
require. If you select ANY, EXTRA! will select the next available LU
number.

6. From the Port ID list, select the number assigned to the EiconCard or
a port on a multiport EiconCard. The port ID identifies the line you
want to use on an Eicon Gateway (the ID is assigned to a PU name
when the gateway is configured). A maximum of 15 ports is available
on a gateway.

7. Click the OK button to save the connection.

The connection will now appear in the Connection list on the Eicon
Gateway General page.
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Eicon SNA via NetBIOS Connection
You can communicate with IBM mainframes via the Eicon gateway using
a NetBEUI protocol over NetBIOS. This section describes the Eicon
gateway connectivity options. To set these options, you will need
information about gateway names, PU names, LU numbers, and port
IDs.

Eicon SNA via NetBIOS - System Requirements
In addition to the general system requirements of EXTRA!, please note
the following NetBEUI NetBIOS connection requirements.

• A LAN adapter that supports NetBIOS.

• A NetBEUI Protocol over an IBM compatible NetBIOS.

• An Eicon Technology SNA Gateway version 3.1 or later running on
the local area network.

The Eicon SNA via NetBIOS General Page

New Session Wizard - Eicon Gateway via NetBIOS General page
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Use this page to configure an Eicon SNA connection via NetBIOS. You
can define a new connection, edit an existing connection, or you can
enable or disable a connection from the Connection list. This page also
has copy/paste features which make it easier to create a series of
connections.

The following section describes the individual fields on this page.

Connection list: Displays the currently available connection definitions
and shows the parameters for each definition.

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Add: Opens the Add/Edit Connection dialog box where you can
configure a new connection.

Edit: Opens the Add/Edit Connection dialog box where you can edit the
current connection.

Delete: Removes the selected connection entry from the Connection list.

Copy: Copies the selected entry from the Connection list to a temporary
buffer.

Paste: After a connection entry is copied using the Copy button, press the
Paste button to re-insert a copy of the entry into the Connection list.

Gateway List Retries: Specify retry settings for connection attempts.

Number of Retries: Indicates the number of times the system will try
to make a connection after each unsuccessful attempt. Use the arrows
to increase or decrease the number of retries. You can select a
number between 0 and 9999. The default is 0.

Retry Delay (secs): Indicates the amount of time (seconds) EXTRA!
will wait between retries. The default is 1 second.

Connection Timeout (secs): Indicates the amount of time (seconds)
EXTRA! will wait to establish a connection. The default is 5 seconds.

Lana Number: Identifies logical adapter number defined in this machine
for the NetBEUI transport stack.
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The Add/Edit Connection Dialog Box

Add/Edit Connection dialog box

Use this dialog box to define a connection for an Eicon SNA via NetBIOS.
To define a connection you need to specify a gateway name, a PU name,
an LU number, and a port ID. Each field you will need to define is
described in detail below.

The following section describes the individual fields on this page.

Gateway: Specifies the names of the Eicon Gateways to which you want
to attach. To add a gateway name, select one of the names in the list and
type a new name in its place.

PU Name: Specifies the name of the PU (physical unit) as defined on the
gateway. The default is SNAGATE.

LU Number: Specifies the LU (logical unit) number. The LU number you
select must match an LU type defined on the gateway that supports the
terminal characteristics you require. If you select ANY, EXTRA! will
select the next available LU number.

Port ID: Use this option to select the number assigned to the Eicon Card
or a port on a multiport EiconCard. The Port ID identifies the line you
want to use on an Eicon Gateway (the ID is assigned to a PU name when
the gateway is configured). A maximum of 15 ports is available on a
gateway.



User’s Guide

2-58

To configure an Eicon SNA connection via NetBIOS

1. Start a new session, and select Eicon SNA via NetBIOS as your
connection type.

2. From the General page, choose the Add button.

The Add/Edit Connection dialog box appears.

3. In the Gateway field, type the names of the Eicon gateways to which
you want to attach.

4. In the PU Name field, select the name of the PU (physical unit) as
defined on the gateway. The default is SNAGATE.

5. From the LU Number list, select the LU (logical unit) number you
want to use. The LU number you select must match an LU type
defined on the gateway that supports the terminal characteristics you
require. If you select ANY, EXTRA! will select the next available LU
number.

6. From the Port ID list, select the number assigned to the EiconCard or
a port on a multiport Eicon Card. The port ID identifies the line you
want to use on an Eicon Gateway (the ID is assigned to a PU name
when the gateway is configured). A maximum of 15 ports is available
on a gateway.

7. Choose the OK button to save the connection.

The connection will now appear in the Connection list on the Eicon
Gateway General page.

Hayes AutoSync (SDLC)
Hayes AutoSync Direct Connect is a support option for EXTRA! that
runs on an IBM mainframe such as a 3270. You can choose to run the
mainframe host session using a printer or display. The Hayes AutoSync
connection only works with the display host type at the current time, and
you must use a Hayes AutoSync-compatible modem.

You can connect to a mainframe using the Hayes AutoSync connection.
Hayes AutoSync is typically used for remote connections, where
workstations and mainframe computers use synchronous modems to
communicate over public or leased telephone lines.
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Hayes AutoSync (SDLC) - System Requirements
To use Hayes AutoSync as a method of connecting to a mainframe host,
you must first install a Hayes AutoSync-compatible modem.

Note: A modem that is Hayes-compatible is not automatically Hayes
AutoSync-compatible.

Using the New Session wizard, you can create a display host type
session. You have the option of creating a new session when you first
start EXTRA!, or, while working in an open session, you can create
additional sessions.

To create a session, you must provide the New Session wizard with the
following information:

• Host type—IBM Mainframe

• Session type (IBM hosts only)—display or printer

• Connection type and settings

• File transfer type applicable to the selected host type

The wizard creates a session with many default settings, which
determine how the session appears, operates, and interacts with you. You
can later edit these settings to accommodate your preferences.

To configure a Hayes AutoSync adapter

1. From your Windows Control Panel, select the Modems icon.

The Adapter Configuration dialog box is shown.

2. Select the appropriate adapter from the Available list, then select
Add.

Your selection will be added to the Installed list. You must now
configure the installed adapter.

3. Select the adapter from the Installed list, then select Configure.

The system displays the default settings associated with that adapter.
Check with your system administrator if you have any questions.
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4. Choose the OK button to save and exit the Adapter Settings dialog
box.

5. From the Adapter Configuration dialog box, choose the OK button to
save and exit.

You are now ready to configure a Hayes AutoSync connection.

To create a new Hayes AutoSync connection

1. Start EXTRA! and choose OK to create a new session.

2. Select IBM Mainframe as your host type, and then choose Next.

3. Select 3270 Display as your session type, and then choose Next.

4. Select Hayes AutoSync Direct Connect, and then choose Next.

5. Configure options on the General and DLUR pages to conform to
your needs, then choose Next.

6. Select one of the listed file transfer protocol types from the File
Transfer list, and then choose Finish.

7. Choose OK to accept the session described in the New Session
Information dialog box, or choose Cancel so that the session is not
created.
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The Hayes AutoSync (SDLC) General Page

New Session Wizard - Hayes AutoSync (SDLC) General page

Use this page to select and create connection definitions for your Hayes
AutoSync connection. A connection definition consists of a Connection
Name that you supply, a Destination PU ID, and a Poll Address. The
connection can also be DLUR (Dependent LU Requester) enabled.

You can also opt to enter the fully-qualified CP (Control Point) name (or
alias).

The following section describes the fields on this page.

Connection Definition for this Session: Displays the currently available
connection definitions and shows the parameters for each definition.

Add: Creates a new connection definition with a name that you select
and default connection settings.

Edit: Modifies values associated with your connection definition.

Delete: Removes the selected connection definition.
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Logical Unit (LU) Source for This Session: Indicates whether the
connection will use a dedicated LU or an LU from a pool. Specifies
whether the connection will use a dedicated LU or an LU from a pool.

LU Pool: Causes the system to make a connection using the first
available Logical Unit (LU) from a given pool of LUs. If you select
this option, you must enter a valid LU Range (minimum and
maximum).

Pool Name: Lists the names of the LU pools that are configured for
NCIA connections.

Dedicated LU: Allows you to configure your session to a specific LU
number. If you select this option, you must enter a valid LU Number.

LU Number: Allows you to enter a number for a specific LU to be
used when you connect to the host with this session setting. If you
use a specific LU, if the LU is already in use, you may have to wait
until it becomes available.

Control Point (CP)

Network ID: Combined with the Control Point Name, the Network
ID forms an FQCP name for the host.

CP Name: Combined with the Network ID, forms an FQCP name for
the host.

CP Alias: A local name used for the FQCP name. This field is set to
the CP Name if an alias is not specified.
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The Add Hayes AutoSync Definition Dialog Box

Add Hayes AutSync Definition dialog box

Type in a name for your connection definition. This name must be
unique within all DLC, 802.2, SDLC, COAX DFT, NCIA, Twinax, MPTN,
Hayes AutoSync, and DLUR connections for your workstation.

A new connection name, with default settings, will appear in the list of
connection definitions.
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The Edit Hayes AutoSync Definition Dialog Box

Edit Hayes AutoSync Definition dialog box

Use this dialog box to configure a Hayes AutoSync connection. You will
need to select the appropriate destination parameters, workstation
parameters, and other connection parameters.

The following fields are available from this dialog box:

Support DLUR on This Connection: Select to enable DLUR support for
this connection session.
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Destination Parameters

Destination PU ID: A 5-digit hexadecimal number that identifies
your workstation to the mainframe. If your network is connected
directly to the mainframe, or via an FEP, you must enter the PU ID
that the mainframe has assigned to your workstation. If your
network is connected through a controller, your workstation will be
identified by either its locally administered address (LAA) or its
“burned-in” network adapter address. Your system administrator
can provide you with your PU ID.

APPN Host (EN,NN): Select to connect to an up-level PU type 2.1
node (Network Node or End Node).

PU 21 (LEN): Select to connect to a back-level Low-Entry
Networking (LEN) node. LEN nodes do not support APPN
functions.

PU 20 (XDO): Select to connect to a type 2.0 node.

Country Code: Select your country code.

Area Code: Type in the area code of the destination host’s phone
number.

Phone Number: Type in the destination phone number of the host to
which you want to connect. You can configure up to two phone numbers.
Only one phone number can be used at a time.

Workstation Parameters

Connect Using: Select from the list of modems the one you will use.
If no options appear in this list, you can leave this option blank.
Remember that a Hayes-compatible modem does not necessarily
mean that it is Hayes AutoSync-compatible. The modem you choose
here must be Hayes AutoSync-compatible.

Poll Address: The  2-digit hexadecimal number that identifies your
workstation’s address to the mainframe.

I-Frame Size: Defines the packet size of an I-Frame (Information
Frame), which the mainframe uses to transfer data through your
LAN adapter to your workstation. Choose an I-Frame size that is
consistent with your workstation’s LAN Adapter and the I-Frame
size specified on the mainframe network. Ask your system
administrator for help determining the correct I-Frame size.



User’s Guide

2-66

NRZ (NRZ/NRZI): Enables the Non-Return to Zero Inverted (NRZI)
option that specifies the data stream encoding type. Your system
administrator can give you this information.

LU Ranges

Pool Name: The name of the LU pool to which the range of LUs will
belong.

Base Name: The name of the LU range to which the LUs belong.

Minimum LU: The minimum LU value for the range.

Maximum LU: The maximum LU value for the range.

To configure a Hayes AutoSync connection definition

Note: If you are configuring a connection under Windows NT, you must
first configure a Hayes AutoSync adapter.

1. Start a new session, and select Hayes AutoSync as your connection
type.

2. From the General page, choose the Add button.

The Add Hayes AutoSync Definition dialog box displays.

3. Enter a valid name, then review and change the default parameters
as necessary.

4. Choose the OK button to save your connection.

A new Connection Name will appear in the list of connection
definitions.

The Edit LU Range Definition Dialog Box

Edit LU Range Definition dialog box
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Use this dialog box to add a new LU range definition or edit an existing
one.

The following section describes the fields within this dialog box.

Pool Name: Enter the name of the LU pool to which the range of LUs
will belong.

Base Name: Enter the name of the LU range to which the LUs belong.

Minimum LU: Enter the minimum LU value for the range.

Maximum LU: Enter the maximum LU value for the range.
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IBM CICS Server
You can communicate with IBM mainframes using IBM CICS Server via
TCP/IP or NetBEUI protocol.

IBM CICS Server - System Requirements
A connection to the IBM CICS Server requires:

• IBM Client software running on each client workstation.

• TCP/IP or NetBEUI transport protocol, installed on the IBM CICS
Server and on the client workstations.

The IBM CICS Server General Page

New Session Wizard - IBM CICS Server General page

Use this page to edit or create IBM CICS Server connection definitions.
Using the copy/paste features, you can  easily create a series of
connections.
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The following section describes the fields on this page.

Connection Definitions: Displays the currently available connection
definitions and shows the parameters for each definition. The system
attempts to connect with each server in the list, beginning with the first,
until a connection is made.

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Server Name: Specifies the name of the server to which the session
will connect.

Terminal Resource: Specifies the name of the terminal resource used
to make a connection.

Device Type: Specifies the device type used to make a connection.

Initial Transaction ID: Specifies the 4-character  string value that is
sent to the host during startup, which will cause the host to send
back an appropriate response.

Move Up/Move Down buttons: Reorder the list of connection
definitions. The order in the list determines the order in which the
connection definitions are tried when making a connection.

Add: Creates a new connection definition with a name that you select
and default connection settings.

Edit: Changes the values of an existing connection definition.

Delete: Removes the selected connection definition.

Copy: Makes a copy of an existing connection definition.

Paste: Pastes a copy of an existing connection definition to the list.

Enable Infinite List Retries: When selected, the system goes through the
entire list of connection definitions repeatedly, until a connection is
made.

Number of Retries: Specifies the number of additional times the session
will try to connect if the first attempt fails. The default is 0. If more than
one connection definition is listed, the system will go through the whole
list the specified number of times.
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The Edit Connection Dialog Box

Edit Connection dialog box

Use this dialog box to configure an IBM CICS connection. To define a
connection, you will need to specify the Server Name, Terminal
Resource, and Device Type. You can also set the Initial Transaction ID,
Number of Retries, and Time Between Retries.

The following section describes the fields within this dialog box.

Server Name: Type the name of the server to which the session will
connect.

Terminal Resource: Type the name of the terminal resource used to
make a connection.

Device Type: Type the device type used to make a connection.

Initial Transaction ID: Type the 4-character string value that is sent to
the host during startup, which will cause the host to send back an
appropriate response. (Same as Transaction ID on the General Page.)

Number of Retries: Specifies the number of additional times the session
will try to connect if the first attempt fails. The default is 0. If more than
one connection definition is listed, the system will go through the whole
list the specified number of times.

Time Between Retries (secs): Specifies the number of seconds the session
will wait between retries. The default is 0.
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To remove an IBM CICS Server connection

• With an IBM CICS Server session open, in the Connection
Definitions list, select the connection you want to disable, then
clear the check box to the left of it.

The connection remains on the list for future use (re-enable it by
selecting the check box).

–or–

• With an IBM CICS Server session open, in the Connection
Definitions list, select the connection you want to delete, then
choose the Delete button.

The connection is permanently removed from the list.

IrmaLAN Server via Banyan VINES
You can connect to the mainframe using IrmaLAN server gateway, via
Banyan VINES. You can configure any number of gateways for
connection, as well as the level of security when accessing each of these
gateways.

IrmaLAN Server via Banyan VINES - System Requirements
A Banyan VINES connection requires:

• A LAN adapter that supports Banyan VINES

• Banyan VINES Enterprise Client (5.56 or later) for Windows NT,
Windows 95 or Windows 98
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The IrmaLAN Server via Banyan VINES General Page

New Session Wizard - IrmaLAN Server via Banyan VINES General page

Use this page to define gateway information when using an IrmaLAN for
Banyan VINES gateway to access a host. You can select from a list of
available gateways or you can define a specific gateway name or address.
The gateway provides the host session support for the Mainframe
Terminal and Mainframe Printer applications.

The following section describes the fields on this page.

Available Gateways: Displays the gateways currently available for
connection.

User Defined Gateway: Type a gateway name, then choose Add>> to
add the gateway name to the Selected Gateways list.

Selected Gateways: Displays the gateway names that will be used to
establish a connection. The session attempts to connect with each
gateway in the list, beginning with the first, until a connection is made.
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Add>>: Adds a gateway name to the Selected Gateways list.

Delete: Removes a gateway name from the Selected Gateways list.

Move Up/Move Down buttons: Reorder the gateway names within the
Selected Gateways list. The order in the list determines the order in
which the gateway names are tried when making a connection.

To configure an IrmaLAN for Banyan VINES connection

1. Start a new session, and select IrmaLAN Server via Banyan VINES as
your connection type.

2. From the General page, select a gateway from the Available Gateway
list.

–or–

Enter a gateway name or address under User Defined Gateway.

When specifying a gateway address, you need to delimit the network
and node address by a period (.), for example 0000300A.4000000061.

3. Choose the Add button.

4. From the Advanced page, select the security option for your
connection (the default is None).

5. Repeat Steps 2, 3, and 4 for each gateway you want to have available
for connection.

For more information on a particular field, refer to the General page topic
within this section.
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The IrmaLAN via Banyan VINES Advanced Page

New Session Wizard - IrmaLAN Server via Banyan VINES Advanced page

Use this page to define security settings when accessing an IrmaLAN
Gateway. You can specify no security, security for a particular
workstation, or user-specific access.

The following section describes the fields on this page.

Security Option: Define the level of security for accessing an IrmaLAN
gateway. You can specify no security, security for a particular
workstation, or user-specific access.

None: Select if no security (Workstation Name, or User ID and
Password) is required to connect to the gateway.

Symbolic: Select to reserve LUs for a specific workstation without
requiring User IDs and passwords.

Workstation Name: Type a workstation name that consists of a
maximum of 8 alphanumeric characters. The Workstation Name is
case-sensitive.
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Enhanced: Select if a User ID and password are required to connect
to the gateway.

User ID: Type a User ID that consists of a maximum of 8
alphanumeric characters. The User ID is case-sensitive.

Password: Type a password that consists of a maximum of 8
alphanumeric characters. The password is case-sensitive.

Enable Kkeep Alive: Select to provide a constant check between your
session and the gateway.

IrmaLAN Server via IPX/SPX (NetWare)
You can connect to the mainframe using IrmaLAN server gateway, via
IPX/SPX (Internetwork Package Exchange/Sequenced Packet Exchange).
You can configure any number of gateways for connection, as well as the
level of security when accessing each of these gateways.

IrmaLAN Server via IPX/SPX - System Requirements
Workstation requirements are listed below. If any of the required Novell
NetWare files are not on the workstation, check the NetWare server, or
contact your SAA Gateway administrator. (You can also download these
files from CompuServe or the Novell NetWire service.)

• A LAN adapter that supports IPX

• Client service for NetWare

• IPX/SPX compatible transport
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The IrmaLAN Server via IPX/SPX General Pages

New Session Wizard - IrmaLAN Server via IPX/SPX General page

Use this page to define gateway information when using an IrmaLAN for
IPX/SPX gateway to access a host. You can select from a list of available
gateways or you can define a specific gateway name or address. The
gateway provides the host session support for the Mainframe Terminal
and Mainframe Printer applications.

The following section describes the fields on this page.

Available Gateways: Displays the gateways currently available for
connection.

Gateway Address: Displays the network address and node address value
for the gateway selected in the Available Gateways list.

Network: Displays the network address value of the selected gateway in
the Available Gateways list. This field is read-only.

Node: Displays the node address value of the selected gateway in the
Available Gateways list. This field is read-only.
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User Defined Gateway: Type a gateway name or address, then choose
Add>> to add the gateway name to the Selected Gateways list. When
specifying a gateway address, you need to delimit the network and node
address by a period (.), for example 0000300A.4000000061.

Selected Gateways: Displays the gateway names that will be used to
establish a connection. The session attempts to connect with each
gateway in the list, beginning with the first, until a connection is made.

Add>>: Adds a gateway name to the Selected Gateways list.

Delete: Removes a gateway name from the Selected Gateways list.

Add Address: Adds a user-defined gateway address (Network
Address.Node Address) to the Selected Gateways list.

Move Up/Move Down buttons: Reorder the gateway names within the
Selected Gateways list. The order in the list determines the order in
which the gateway names are tried when making a connection.

The IrmaLAN Server via IPX/SPX Advanced Page

New Session Wizard - IrmaLAN Server via IPX/SPX Advanced page

Use this page to define security settings when accessing an IrmaLAN
Gateway. You can specify no security, security for a particular
workstation, or user-specific access.
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The following section describes the fields on this page.

Security Options: Define the level of security for accessing an IrmaLAN
gateway. You can specify no security, security for a particular
workstation, or user-specific access.

None: Select if no security (Workstation Name, or User ID and
Password) is required to connect to the gateway.

Symbolic: Select to reserve LUs for a specific workstation without
requiring User IDs and passwords.

Workstation Name: Type a workstation name that consists of a
maximum of 8 alphanumeric characters. The Workstation Name is
case-sensitive.

Enhanced: Select if a User ID and password are required to connect
to the gateway.

UserID: Type a User ID that consists of a maximum of 8
alphanumeric characters. The User ID is case-sensitive.

Password: Type a password that consists of a maximum of 8
alphanumeric characters. The password is case-sensitive.

Enable Keep Alive: Select to provide a constant check between your
session and the gateway.

To configure an IrmaLAN Connection via IPX/SPX

1. Start a new session, and select IrmaLAN Server via IPX/SPX as your
connection type.

2. From the General page, select a gateway from the Available Gateway
list.

–or–

Enter a gateway name or address under User Defined Gateway.

When specifying a gateway address, you need to delimit the network
and node address by a period (.), for example 0000300A.4000000061.

3. Choose the Add button.
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4. From the Advanced page, select the security option for your
connection (the default is None).

5. Repeat Steps 2, 3, and 4 for each gateway you want to have available
for connection.

For more information on a particular field, refer to the General page topic
within this section.

IrmaLAN Server via NetBIOS
You can connect to a mainframe using IrmaLAN server gateway, via
NetBEUI protocol over NetBIOS. You can configure any number of
gateways for connection, as well as the level of security when accessing
each of these gateways.

IrmaLAN Server via NetBIOS - System Requirements
An IrmaLAN Server via NetBIOS connection requires:

• A LAN adapter that supports NetBIOS

• A NetBEUI Protocol over an IBM compatible NetBIOS

• A gateway running ZIP! SNA Gateway or IrmaLAN for NetBIOS
Server
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The IrmaLAN Server via NetBIOS General Page

New Session Wizard - IrmaLAN Server via NetBIOS General page

Use this page to define gateway information when configuring an
IrmaLAN for NetBIOS connection. You can choose from a list of selected
gateways, or you can define a specific gateway name or address.

The following section describes the fields on this page.

User Defined Gateway: Type a gateway name or address, then choose
Add to add the gateway name to the Selected Gateways list.

Add: Adds a gateway name to the Selected Gateways list.

Delete: Removes a gateway name from the Selected Gateways list.

Selected Gateways: Displays the gateway names that will be used to
establish a connection. The session attempts to connect with each
gateway in the list, beginning with the first, until a connection is made.

Up/Down buttons: Reorder the gateway names within the Selected
Gateways list. The order in the list determines the order in which the
gateway names are tried when making a connection.
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To define a gateway

1. Enter a gateway name in the User Defined Gateway field.

2. Click Add.

The gateway name appears in the Selected Gateways list. You can
also remove a gateway name by using the Delete button. If a gateway
name already appears in the list, it is not added again.

The IrmaLAN Server via NetBIOS Advanced Page

New Session Wizard - IrmaLAN Server via NetBIOS Advanced page

Use this page to define security settings when accessing an IrmaLAN
Gateway. You can specify no security, security for a particular
workstation, or user-specific access.
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The following section describes the fields on this page.

Security Options: Define the level of security for accessing an IrmaLAN
gateway. You can specify no security, security for a particular
workstation, or user-specific access.

None: Select if no security (Workstation Name, or User ID and
Password) is required to connect to the gateway.

Symbolic: Select to reserve LUs for a specific workstation without
requiring User IDs and passwords.

Workstation Name: Type a workstation name that consists of a
maximum of 8 alphanumeric characters. The Workstation Name is
case-sensitive.

Enhanced: Select if a User ID and password are required to connect
to the gateway.

UserID: Type a User ID that consists of a maximum of 8
alphanumeric characters. The User ID is case-sensitive.

Password: Type a password that consists of a maximum of 8
alphanumeric characters. The password is case-sensitive.

Lana Number: Specify the NetBIOS to NetBEUI lana (LAN adapter)
number for your workstation. The default is Auto Detect.

To define security settings

1. Select Symbolic or Enhanced option.

2. If you chose Symbolic, enter a workstation name in the appropriate
field.

–or–

If you chose Enhanced, enter a valid User ID and Password in the
appropriate fields.

To set the number of lana options

• From the Advanced page, enter the NetBIOS to NetBEUI lana
number for your workstation.

The default is set to Auto Detect.
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To configure an IrmaLAN Connection via NetBEUI NetBIOS

1. Start a new session, and select IrmaLAN Server via NetBIOS as your
connection type.

2. From the General page, enter a gateway name under User Defined
Gateway.

3. Choose the Add button.

4. From the Advanced page, select the security option for your
connection (the default is None).

5. Repeat Steps 2, 3, and 4 for each gateway you want to have available
for connection.

For more information on a particular field, refer to the General page topic
within this section.

LUA/LU0/RUI
You can connect to the mainframe using the LUA/LU0/RUI application
programming interface (API), which will be referred to here as LUA.
EXTRA! supports the following LUA vendor stacks:

• Attachmate APPN Node

• Attachmate SNA Gateway

• Attachmate SNA Gateway Client

• Microsoft SNA Server Client

Using Attachmate APPN Node, you can make an LUA connection over
the following connectivity types:

• Cisco NCIA

• Coax DFT

• DLC 802.2

• DLSw

• Hayes AutoSync

• SDLC

System requirements vary depending on the connectivity type you
choose.
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The LUA/LU0/RUI General Page

New Session wizard - LUA General page

Use this page to define the LUs to which you want to connect via
LUA.The following section describes the features on this page.

LU Name: Displays the names of LUs to which EXTRA! will attempt to
connect. EXTRA! tries to connect to the topmost LU in the list first. If the
attempt fails, EXTRA! tries to connect to the next LU, and continues
down the list in this manner until a connection is made. You can change
the order of LUs in the list using the up and down arrows to the right of
the list. The list holds up to 6 LUs.

LUA Provider: Displays the LUA provider stack selected for each LU.

Up/Down Buttons: Reorders the LU names within the Connection list.
The order determines which LU is tried first, then second, and so on until
a connection is made.

Add: Displays the Add Connection dialog box from which you can name
a new LU and select its LUA provider stack. The new LU will be placed
at the bottom of the LU list.

Edit: Displays the Edit LUA Session dialog box from which you can edit
the connection information for the selected LU.

Delete: Deletes the selected LU from the LU list.
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Copy: Copies the selected LU connection information to a local memory
buffer.

Paste: Pastes previously-copied LU connection information from the local
memory buffer into a new LU element in the LU list immediately above
the currently selected LU element.

List Retries

Enable Infinite List Retries: Specifies that EXTRA! will go through
the list of LUs continuously until a successful connection is made.

Number of Retries: Displays the number of additional times EXTRA!
will try to connect if the first connection attempt fails. EXTRA! will
always try to connect to each LU in the list once. The default number
of additional attempts is 0.

Delay Between Lus (secs): Specifies the number of seconds to wait
before connecting to the next LU. The default is 1 second.

Connection Timeou (secs): Indicates the number of seconds the
session waits for a successful connection before stopping. The default
is 10 seconds. The maximum value is 300 seconds; 0 implies no
timeout.
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The Add Connection Dialog Box

Add Connection dialog box

Use the Add Connection dialog box to add LUs to the list of LUs to
which EXTRA! will attempt to connect. The following section describes
the fields on this page.

LUA Provider: Displays the LUA provider stack to be used. If you select
“Any”, EXTRA! will attempt to connect to the LU using each supported
LUA stack.

LU Name: Displays the LUs available from the currently selected LUA
provider stack. If you chose “Any” in the LUA Provider list, LU Name
displays the LUs available on all supported LUA provider stacks. If the
desired LU does not appear in this list, you can enter it manually.

Configure button: Starts the configurator for the currently selected LUA
provider. If you chose “Attachmate APPN Node” in the LU Provider list,
the Configure Attachmate APPN Node dialog box appears.

To configure an LUA connection

1. Start a new session, and select LUA as your connection type.

2. From the General page, choose an action as follows:

To Do this

Delete the connection. Select an LU from the list, then
choose the Delete button.

Copy the LU’s connection
settings to the Clipboard

Select an LU from the list, then
choose the Copy button.

Paste the copied settings
into the selected connection

Choose the Paste button.
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3. Select Enable Infinite List Retries if you want EXTRA! to go through
the list of configured connections repeatedly until a successful
connection is made.

4. From the Connection Timeout field, enter a value in seconds. The
default is 10 seconds.

5. From the Number of retries field, enter a value for the number
retries. The default is 0.

6. Select Enable Infinite List Retries if you want EXTRA! to go through
the list of LUs repeatedly until a successful connection is made.

–or–

In the Number of retries field, enter a value for the number of retries.
The default is 0.

7. In the Delay Between LUs field, enter a delay value in seconds. The
default is 1 second.

8. In the Connection Timeout field, enter a timeout value in seconds.
The default is 10 seconds.

To add or edit an LUA connection

1. Start a new session, and select LUA as your connection type.

2. From the General page, select an LU from the list, then choose the
Add button.

The Add connection dialog box appears.

-or-

From the General page, select an LU from the list, then choose the
Edit button.

The Edit LUA dialog box appears.

3. From the LUA Provider list, select an LUA stack.

4. Choose Configure to edit your LUA stack settings.

5. From the LU name list, select an LU.

6. Choose OK.
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Microsoft SNA Server
You can connect to an IBM mainframe via a Microsoft SNA Server. A
Microsoft SNA Server connection supports the complete range of
terminal and printer types, on single or multiple hosts, and IND$FILE
transfer.

Microsoft SNA Server - System Requirements
A connection to the Microsoft SNA Server requires:

• Microsoft SNA Client software running on each client workstation.
Two clients are available: one specifically for NT, and the second
made to run under Windows 95, Windows 98 and Windows NT 3.51
(included with EXTRA!).

• TCP/IP, Novell NetWare (IPX/SPX), or MS Networking (Named
Pipes) transport protocol, installed on the SNA Server and on the
client workstations.

The Microsoft SNA Server General Page

New Session Wizard - Microsoft SNA Server General page
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Use this page to configure a Microsoft SNA Server connection. You can
select from a list of available resources or you can define a specific
resource.

The following section describes the fields on this page.

Available Resources: Displays the available resources for your
workstation.

User Defined Resource: Type a resource name, then choose Add>> to
add the resource to the Selected Resources list.

Note: You can enter a resource that is not yet configured on the SNA
Server (and thus does not appear in the Available Resources list), which
allows you to enter a resource to be made available at a later date.

Connect to any resource: Select to allow the session to connect with all
available resources, not just those specified in the Selected Resources list.

Selected Resources: Displays the resources that will be used to establish
a connection (unless the Connect to Any Resources option is selected).
The session attempts to connect with each resource in the list, beginning
with the first, until a connection is made.

Add>>: Adds a resource to the Selected Resources list.

Delete: Removes a resource from the Selected Resources list.

Move Up/Move Down buttons: Reorder the resources within the
Selected Resources list. The order in the list determines the order in
which the resources are tried when making a connection.

To configure a Microsoft SNA Server connection

1. Start a new session, and select MS SNA Server as your connection
type.

2. From the next page, select a resource from the Available Resources
list.

–or–

Enter a resource name under User Defined Resource.

4. Choose Add.

5. Choose OK.

For more information on a particular field, refer to the General page topic
within this section.
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NetWare for SAA via IPX/SPX
You can connect to IBM mainframes via the Novell SAA Gateway, using
an IPX/SPX (Internetwork Packet Exchange/Sequenced Packet
Exchange) protocol.

NetWare for SAA via IPX/SPX - System Requirements
Workstation requirements are listed below. If any of the Novell NetWare
files listed are not located on the workstation, check the NetWare server,
or contact your SAA Gateway administrator. (You can also download
these files from CompuServe or the Novell NetWire service.)

• A LAN adapter that supports IPX

• Client Service for NetWare

• IPX/SPX compatible transport

The NetWare for SAA via IPX/SPX General Page

New Session Wizard - NetWare for SAA via IPX/SPX General page
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Use this page to configure a NetWare for SAA connection via IPX/SPX.
You can define a new connection, edit an existing connection, or you can
enable or disable a connection from the Connection Definition list. This
page also has copy/paste features which makes it easier to create a series
of connections.

Connection Definitions

Displays the currently available connection definitions and shows the
parameters for each definition. The system attempts to connect with each
server in the list, beginning with the first, until a connection is made.

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Server Name: Indicates the server name to which you are connecting.

User Name: Indicates the user who is making the connection.

Resource Name: Indicates the resource name for this connection.

Resource Type: Indicates the resource type for this connection.

Add: Opens the Add Connection dialog box where you can configure a
connection.

Edit: Opens the Edit Connection dialog box where you can edit the
current configuration.

Delete: Removes a connection entry from the Connection list.

Copy: Copies the selected entry from the Connection list to a temporary
buffer.

Paste: After a connection entry is copied using the Copy button, press the
Paste button to re-insert a copy of the entry into the Connection list.

Move Up/Move Down buttons: Reorder the list of connection
definitions. The order in the list determines the order in which the
connection definitions are tried when making a connection.
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List Retries

Enable Infinite List Retries: When selected, the system goes through
the entire list of connection definitions repeatedly, until a connection
is made.

Number of Retries: Specifies the number of additional times the
session will try to connect if the first attempt fails. The default is 0. If
more than one connection definition is listed, the system will go
through the whole list the specified number of times.

NDS User Configuration: NDS User Configuration works only on a
NetWare Server version 2.2 or later, with the client running over a
NetWare IPX stack. If the client is running over a Microsoft IPX stack, or
if supporting DLLs for the NetWare stack are unavailable, the NDS User
Configuration option will be unavailable.

Enable NDS Configuration: Select to allow the session to use a pre-
defined configuration (an NDS user configuration) on the NetWare
server. Using a server session selected from the Session list, you can
assign users, or groups of users, to different servers and share the
configuration. Make sure you are logged into NDS from your
Windows directory before using an NDS user configuration.

Session: Provides a list of sessions defined on the server that are
available for you to use for an NDS user configuration.

The Edit Connection Dialog Box

Edit Connection dialog box

Use this dialog box to define a NetWare for SAA connection via
IPX/SPX. To define a connection, you need to specify a server name, a
user name and password, SNA service, resource name, and resource
type. The following section describes each field in detail.
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Server Name: Enter the name of the server to which you want to connect.
To connect to the first server that has a matching User Name, SNA
Service Name, Resource Name, and Resource Type, select the asterisk (*).

User Name: Type the login ID set up for you by your NetWare for SAA
administrator, or use an asterisk (*) to use the current NetWare User ID.
The User Name identifies your workstation to the server and the LAN. It
must be unique and from 1 to 47 characters long.

Password: Type the password defined with your login ID.

SNA Service: To provide access to multiple service profiles, select a
service name from the list, or type a service name provided by your
NetWare for SAA administrator. The service name is case-sensitive. To
use the first service that is available on the specified server, select the
asterisk (*).

Resource Type: Select a resource type from the list. Your options are Any
(default), Public, Pooled, or Dedicated.

Any: Specifies a connection to the first available LU that you are
authorized to use.

Pooled: Specifies a connection to the first available LU in the pool
specified by the Resource Name. If all pools are unavailable, the
session connects to a public LU. Workstations that are authorized in a
named pool can access this resource. The NetWare for SAA
administrator may have defined a pool of users for those who need
access to specific applications.

Public: Specifies a connection to the first available public LU.

Dedicated: Specifies a workstation that needs access to a specific LU
is dedicated to this resource.

Resource Name: Type the name of the resource to which the workstation
will connect. Each Resource Name is associated with a Resource Type.
The Resource Name is case-sensitive.
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To configure a NetWare for SAA connection via IPX/SPX

Note: In most cases, the default settings will automatically make a
connection with the first available resource based on your current
network connection. Change the settings only if you wish to specify a
specific resource.

1. Start a new session, and select NetWare for SAA via IPX/SPX as
your connection type.

2. From the next page, choose Add.

The Edit Connection dialog box appears.

3. From the Edit Connection dialog box, review the default options and
change as necessary.

4. Type your user name and password, if required.

5. Choose OK.

For more information on a particular field, refer to the General page topic
within this section.

To remove a NetWare for SAA via IPX/SPX connection

• With a NetWare for SAA via IPX/SPX session open, in the
Connection Definitions list, select the connection you want to
disable, then clear the check box to the left of it.

The connection remains on the list for future use (re-enable it by
selecting the check box).

–or–

• With a NetWare for SAA via IPX/SPX session open, in the
Connection Definitions list, select the connection you want to
delete, then choose the Delete button.

The connection is permanently removed from the list.
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The NetWare for SAA via IPX/SPX Advanced Page

New Session Wizard - NetWare for SAA via IPX/SPX Advanced page

Use this page to set advanced connection features such as broadcast
search, which allows your workstation to search for the first available
gateway. You can also set password encryption, general service query,
and gateway hot rollover options.

The following section describes the fields on this page.

Broadcast Search

Enable Broadcast Search: Select to specify that, upon session startup,
your workstation will broadcast a request for all available resources
and return a list of available servers, which are then listed in the
Connection Definition list on the General page.

Broadcast to Type 2.0 Gateway Only: Select to restrict the broadcast
search to 2.0 gateway types.
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Broadcast Range (Hops): Limit the range of the broadcast search to
those responding servers that are within the specified number of
routers or rings away, known as hops. This option is useful when
you do not want to use a resource that is several hops away. The
default is 10. To use the local ring only, enter 1; to disable this option,
enter 0.

Note: If the Enable General Services Query option is selected, it
overrides the Broadcast Search settings.

Enable Password Encryption: Select to use Novell public key encryption
when making a connection.

Enable General Services Query: Select to send a general broadcast to all
available resources and return a list of available servers, which are then
listed in the Connection Definition list on the General page. This option
overrides any Broadcast Search options set above.

Enable Gateway Hot Rollover: Select to roll over to the next
configuration specified in the Connection Definitions list when an error
occurs after a connection is made, or when a system administrator
intervenes.

Connection Timeout (secondes): Displays the number of seconds the
system will wait for a successful connection before stopping. The default
is 0, which causes no timeout.

NetWare for SAA via TCP/IP
You can connect to IBM mainframes via the Novell SAA Gateway, using
a TCP/IP (Transmission Control Protocol/Internet Protocol) protocol.

NetWare for SAA via TCP/IP - System Requirements
An SAA connection via TCP/IP requires:

• A communications adapter (token-ring or Ethernet adapter) that
passes TCP/IP packets

• A TCP/IP stack compliant with the Windows Sockets (WinSock) 1.1
specification
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The NetWare for SAA via TCP/IP General Page

New Session Wizard - NetWare for SAA via TCP/IP General page

Use this page to define resources for a NetWare for SAA via TCP/IP
connection. You can define a new connection, edit an existing connection,
or you can enable or disable a connection from the Connection Definition
list. This page also has copy/paste features which makes it easier to
create a series of connections.

The following section describes the fields on this page.

Connection Definitions: Displays the currently available connection
definitions and shows the parameters for each definition. The system
attempts to connect with each server in the list, beginning with the first,
until a connection is made.

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Server Name: Indicates the server name to which you are connecting.

User Name: Indicates the user who is making the connection.

Resource Name: Indicates the resource name for this connection.
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Resource Type: Indicates the resource type for this connection.

Add: Adds a new connection definition with a name that you select and
default connection settings.

Edit: Changes the values of an existing connection definition.

Delete: Removes the selected connection definition.

Copy: Makes a copy of an existing connection definition.

Paste: Pastes a copy of an existing connection definition to the list.

Move Up/Move Down buttons: Reorder the list of connection
definitions. The order in the list determines the order in which the
connection definitions are tried when making a connection.

List Retries

Enable Infinite List Retries: When selected, the system goes through
the entire list of connection definitions repeatedly, until a connection
is made.

Number of Retries: Specifies the number of additional times the
session will try to connect if the first attempt fails. The default is 0. If
more than one connection definition is listed, the system will go
through the whole list the specified number of times.

The Edit Connection Dialog Box

Edit Connection dialog box

Use this dialog box to define a NetWare for SAA via TCP/IP connection.
You need to specify a server name, a username and password, SNA
service, resource name, and resource type. The following section
describes each field in detail.



Connection Types

2-99

Server Name: Type the address or Domain Name Service (DNS) that will
establish your connection. Ask your system administrator for available
addresses or valid DNS names.

User Name: Type the login ID set up for you by your NetWare for SAA
administrator, or type an asterisk (*) to use the current NetWare User ID.
The User Name identifies your workstation to the server and the LAN. It
must be unique and from 1 to 47 characters long.

Password: Type the password defined with your login ID.

SNA Service: To provide access to multiple service profiles, select a
service name from the list, or type a service name provided by your
NetWare for SAA administrator. The service name is case-sensitive. To
use the first service that is available on the specified server, select the
asterisk (*).

Resource Type: Select a resource type from the list. Your options are Any
(default), Public, Pooled, or Dedicated.

Any: Specifies a connection to the first available LU that you are
authorized to use.

Public: Specifies a connection to the first available public LU.

Pooled: Specifies a connection to the first available LU in the pool
specified by the Resource Name. If all pools are unavailable, the
session connects to a public LU. Workstations that are authorized in a
named pool can access this resource. The NetWare for SAA
administrator may have defined a pool of users for those who need
access to specific applications.

Dedicated: Specifies a workstation that needs access to a specific LU
is dedicated to this resource.

Resource Name: Type the name of the resource to which the workstation
will connect. Each Resource Name is associated with a Resource Type.
The Resource Name is case-sensitive.
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To configure a NetWare for SAA via TCP/IP connection

1. Start a new session, and select NetWare for SAA via TCP/IP as your
connection.

2. From the next page, choose Add.

The Edit Connection dialog box appears.

3. From the Edit Connection dialog box, enter the required information.

4. (Optional) Set the appropriate List Retry options as necessary.

5. Choose OK.

For more information on a particular field, refer to the General page topic
within this section.

To remove a NetWare for SAA via TCP/IP connection

• With a NetWare for SAA via TCP/IP session open, in the
Connection Definitions list, select the connection you want to
disable, then clear the check box to the left of it.

The connection remains on the list for future use (re-enable it by
selecting the check box).

–or–

• With a NetWare for SAA via TCP/IP session open, in the
Connection Definitions list, select the connection you want to
delete, then choose the Delete button.

The connection is permanently removed from the list.
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The NetWare for SAA via TCP/IP Advanced Page

New Session Wizard - NetWare for SAA via TCP/IP Advanced page

Use this page to set advanced options when connecting to the host. The
advanced features include password encryption, gateway hot rollover,
and connection timeout.

These features are described below.

Enable Password Encryption: Select to use Novell public key encryption
when making a connection.

Enable Gateway Hot Rollover: Select to roll over to the next
configuration specified in the Connection Definitions list when an error
occurs after a connection is made, or when a system administrator
intervenes.

Connection Timeout (seconds): Displays the number of seconds the
system will wait for a successful connection before stopping. The default
is 0, which causes no timeout.
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SDLC Direct Connect
An SDLC (Synchronous Data Link Control) connection allows you to
communicate with an IBM mainframe via Synchronous DLC (Data Link
Control), typically over a public or leased telephone line.

To define an SDLC connection, you need the SDLC configuration settings
for the host (check with your system administrator). You may also need
to consult your modem and SDLC adapter documentation. If you are
configuring a connection under Windows NT, you must first select an
SDLC adapter.

SDLC Direct Connect - System Requirements
An SDLC (Synchronous Data Link Control) connection requires one of
the following adapters:

• Attachmate SCA Adapter

• Attachmate SDLC Adapter

• IBM SDLC Adapter

• IBM MPCA Adapter
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The SDLC Direct Connect General Page

New Session Wizard - SDLC Direct Connect General page

Use this page to select and create SDLC connection definitions and to
specify LU resources to be used for those connections. Consult your
system administrator for the correct values.

The following section describes the fields on this page.

Connection Definition list: Displays the currently available connection
definitions and shows the parameters for each definition.

Connection Name: Displays the name of the connection definition.
This name must be unique among all SDLC and 802.2 connections on
your workstation.

Destination PU ID: Identifies to the host a PU used by your
workstation. The PU ID is an 8-digit hexadecimal number consisting
of the 3-digit IDBLK value followed by the 5-digit IDNUM value
from your VTAM definition.

Poll Address: Identifies your workstation to the host. The poll
address is a 2-digit hexadecimal number; the default is C1.

NZRI Encoding: Indicates the type of data-stream encoding used.
Yes indicates NRZI encoding, No indicates NRZ.
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Add: Adds a new connection definition with a name that you select and
default connection settings.

Edit: Changes the values of an existing connection definition.

Delete: Permanently removes the selected connection definition.

Logical Unit Source for This Session

LU Pool: Select to  make a connection using the first available Logical
Unit (LU) from a given pool of LUs. If you select this option, you
must enter a valid LU Range (minimum and maximum).

Pool Name: Lists the names of the LU pools that are configured for
SDLC connections.

Select to configure your session to a specific LU number. If you select
this option, you must enter a valid LU Number.

LU Number: Displays the LU number that will be used to make a
connection. For more information, contact your system
administrator.

Control Point (CP)

Network ID: Combined with the CP Name, forms a fully qualified
Control Point (FQCP) name.

CP Name: Combined with the Network ID, forms a fully qualified
Control Point (FQCP) name.

CP Alias: A local name used for the fully qualified Control Point
(FQCP) name, consisting of both the Network ID and the CP Name.
It is set to the CP Name if not specified.
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The Edit SDLC Definition Dialog Box

Edit SDLC Definition dialog box

Use this dialog box to configure an SDLC connection. You will need to
select the appropriate destination parameters, workstation parameters,
and other connection parameters. You may also choose whether or not to
support DLUR with this link.

The following section describes the fields within this dialog box.

Support DLUR on This Connection: Select this option to allow a
connection through a Dependent LU Requester (DLUR) to a Dependent
LU Server (DLUS).

Destination Parameters

Destination PU ID: Identifies to the host a PU used by your
workstation. The PU ID is an 8-digit hexadecimal number consisting
of the 3-digit IDBLK value followed by the 5-digit IDNUM value
from your VTAM definition.

APPN Host (EN, NN): Select to connect to an up-level PU type 2.1
node (End Node or Network Node).
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PU 2.1 (LEN): Select to connect to a back-level Low-Entry
Networking (LEN) node. LEN nodes do not support APPN function.

PU 2.0 (XID0): Select to connect to a type 2.0 node.

Workstation Parameters

Poll Address: Identifies your workstation to the host. The poll
address is a 2-digit hexadecimal number; the default is C1.

I-Frame Size: Specifies the packet size of an information frame (I-
Frame), which the host uses to transfer data through your LAN
adapter to your workstation. Choose an I-Frame size that is
consistent with your workstation’s LAN Adapter and the I-Frame
size specified on the mainframe network. The default is 265.

Line Type

Leased: Indicates a dedicated line.

Switched: Indicates a dial-up line.

Link Capability

Half Duplex: Indicates the type of link capability set by your system
administrator.

Full Duplex: Indicates the type of link capability set by your system
administrator.

NRZ

NRZ: Specifies the data-stream encoding type.

NRZI: Indicates Non-Return to Zero Inverted data-stream encoding.

Wiring Type

2 Wire: Used mainly for a switched (dial-up) connection to your host.
May be used on leased multi-drop lines.

4 Wire: Used mainly for a dedicated (no phone) connection to your
host.

LU Ranges

Pool Name: The name of the LU pool to which the range of LUs will
belong.

The name of the LU range to which the LUs belong.

Minimum LU: The minimum LU value for the range.

Maximum LU: The maximum LU value for the range.
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Add: Creates a new LU range.

Edit: Modifies the LU range.

Delete: Permanently removes the selected LU range.

To configure an SDLC connection definition

Note: If you are configuring a connection under Windows NT, you must
first configure an SDLC adapter.

1. Start a new session, and select SDLC Direct Connect as your
connection type.

2. From the General page, select a connection definition.

3. Choose the Edit button to change the settings.

The Edit dialog box opens.

4. Set the appropriate destination parameters, workstation parameters,
and other linking parameters.

Refer to the Related Topics button below for more details on each
option. Contact your system administrator if you have any questions.

5. Choose the OK button to save your changes.

6. Select the appropriate Logical Unit type and range (if necessary).

7. Enter the Control Point Network ID and Name for your node.

For more information on a particular field, refer to the General page topic
within this section.
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The Edit LU Range Dialog Box

Edit LU Range Definition dialog box

Use this dialog box to add a new LU range definition or edit an existing
one.

The following section describes the fields within this dialog box.

Pool Name: Enter the name of the LU pool to which the range of LUs
will belong.

Base Name: Enter the name of the LU range to which the LUs belong.

Minimum LU: Enter the minimum LU value for the range.

Maximum LU: Enter the maximum LU value for the range.

To configure an SDLC adapter for a version Windows NT earlier than 4.0

1. From the Control Panel, select the SDLC icon.

The SDLC Adapter Configuration dialog box appears.

2. Select the appropriate adapter from the Available list, then select
Add.

Your selection will be added to the Installed list. You must now
configure the installed adapter.

3. Select the adapter from the Installed list, then choose Configure.

The system displays the default settings associated with that adapter.
Check with your systems administrator if you have any questions.

4. Choose OK to save and exit the SDLC Adapter Settings dialog box.

5. Choose OK again to save and exit the SDLC Adapter Configuration
dialog box.

6. When prompted, restart your computer.

You are now ready to configure an SDLC connection.
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The Add SDLC Definition Dialog Box

Add SDLC Definition dialog box

Use this dialog box to enter a name for your new connection definition.

To add an SDLC connection definition

1. Start a new session, and select SDLC as your connection type.

2. From the General page, choose the Add button to define a connection
definition.

The Add SDLC Connection Definition dialog box appears.

3. Type a name for the new connection definition, then review and
change the default parameters as necessary.

4. Choose OK.

A new Connection Name, with default settings will appear in the list
of connection definitions.

For more information on a particular field, refer to the General page topic
within this section.

To delete an SDLC connection definition

• With an SDLC Direct Connect session open, from the SDLC
Connection Definition list, select the connection you want to delete,
then choose the Delete button.

The connection is removed from the list.
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SlideShow/Mainframe Demo
The SlideShow/Mainframe Demo option is a demonstration feature that
lets you simulate a connection and the response time when you go from
one host screen to another.

The SlideShow General Page

New Session Wizard - SlideShow General page

Use this page to select a sample slideshow file (.PSS), which simulates a
mainframe session.

The following section describes the fields on this page.

Filename: Type the filename of the SlideShow file (.PSS) you wish to
view.

Pause Time  Between Screens (secs): Type the number of seconds to
delay between screens. This allows you to simulate the response time of a
real host connection.

Browse button: Choose to search for a specific SlideShow file.
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To configure a Mainframe Demo connection

1. Start a new session for the host and select Mainframe Demo as your
connection type.

2. From the next page, select the name of the SlideShow file (.PSS) you
wish to view. Choose Browse to view a list of SlideShow files.

For more information on a particular field, refer to the General page topic
within this section.

TN3270
You can connect to the mainframe using the TCP/IP application protocol
TN3270. The TN3270 connectivity option supports TCP/IP software that
is compliant with the Windows Sockets (WinSock) 1.1 specification, and
also supports the complete range of terminal types (3278/3279 models 2
through 5 with EABs) — on single or multiple hosts — and file transfer.

TN3270 - System Requirements
A TN3270 connection requires:

• Any Telnet server that supports TN3270 devices (clients).

• A communications adapter (token-ring or Ethernet adapter) that
passes TCP/IP packets.

• A TCP/IP protocol compliant with the Windows Sockets (WinSock)
1.1 specification.
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The TN3270 General Page

New Session Wizard - TN3270 General page

Use this page to define your TN3270 connection. You will need to know
the host alias name or IP address and the port number to properly set up
your connection.

The following section describes the fields on this page.

Host Alias/IP Address/Terminal/Device Type: Host Alias/IP Address,
displays either the alias name or numeric IP address of the remote host.

Terminal/Device Type displays a terminal/device type string to be
negotiated with the TN3270 server.

Up/Down Arrow: Moves the selection up or down on the list to assist in
reprioritizing.

Add: Displays the Configure Connection dialog box where you can
define TN3270 connections (enter the host alias or IP address, set the
terminal type and port number) to add to the list of connections.

Edit: Displays the Configure Connection dialog box where you can edit
the connection information for the selected host.
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Delete: Deletes the selected host from the list.

Copy: Copies the selected connection information to a local buffer.

Paste: Pastes the selected connection information from the local buffer
into the currently selected host.

Enable Infinite List Retries: Specifies that EXTRA! will go through the
list of configured connections continuously until a successful connection
is made.

Number of Retries: Displays the number of additional times the session
will try to connect if the first attempt fails. The default is 0.

Delay Between Hosts (secs): Displays the number of seconds the session
waits before connecting to the next host. The default is 3.

Connection Timeout (secs): Indicates the number of seconds the session
waits for a successful connection before stopping. The default is 10
seconds. The maximum value you can enter here is 300 seconds; 0
implies no timeout.

The Configure Connection Dialog Box

Configure Connection dialog box

Use the Configure Connection dialog box to add or edit TN3270
connections. You can configure up to 32 hosts. From the TN3270 General
page choose Add to add a connection or select a connection from the list
box and click Edit to edit a connection. You will need to know the Host
Alias Name or IP Address and the port number to properly set up your
connection(s).
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Host Alias/IP Address: Indicates the name of the remote host. Enter
either the numeric IP address or the alias name, using up to 32 characters.
This option is case-sensitive.

Terminal/Device Type: Displays the terminal/device type string that is
negotiated with the TN3270 server. The default is IBM-3278.

Port Number: Specifies the Telnet port address on the server. An address
can be up to 4 digits long. The default is 23.

Auto Reconnect: Specifies whether EXTRA! reconnects or remains
disconnected when the TN3270 session is logged off. In a TCP/IP
network, a session disconnects when you log off from it--a useful feature
when network traffic (bandwidth) is an issue. However, you may prefer
that EXTRA! maintain the connection by automatically reconnecting at
logoff. (The default is On.)

The TN3270 Advanced Page

Use this page to define the advanced TN3270 features, such as NVT
(Network Virtual Terminal) options, TN3270-defined keys (ATTN and
SYSREQ), and TN3270 enhanced protocol.

The TN3270E server maintains sets of both general device pools and
specific device pools.

General Device Pools General device pools are pools of terminal and
printer LUs from which the server assigns any available LU when no
specific device-name is requested.

For example, if a user does not request a specific terminal, the server
assigns any available device-name from the general terminal device pool.

Specific Device Pools Specific device pools are pools of terminal and
printer LUs that can only be used for specific terminal or printer session
requests.

For example, if a user requests a particular LU by specifying a device-
name, the server assigns from a specific device pool.



Connection Types

2-115

New Session Wizard - TN3270 Advanced page

The following section describes the fields on this page.

NVT Specific: Specifies the function of the ENTER and BACKSPACE keys
during a session.

Enter Key Interpretation: Specifies the function of the ENTER key.

Carriage Return and Linefeed: Feeds a blank line and then positions
the cursor at the beginning of the next line when the ENTER key is
pressed.

Carriage Return: Positions the cursor at the beginning of the next
line when the ENTER key is pressed.

Backspace Key Interpretation: Moves the cursor back one character
and deletes that character when the BACKSPACE key is pressed.

Delete: Moves the cursor back one character and deletes that
character when the BACKSPACE key is pressed.

Backspace: Moves the cursor back one character without deleting the
character when the BACKSPACE key is pressed.

TN3270 Specific: Enables non-TN3270-defined SNA AID keys (ATTN
and SYSREQ), and the use of the same model for both primary and
alternate screen sizes.



User’s Guide

2-116

Enable ATTN Key as IAC Break: Select to send an IAC Break Telnet
command when an ATTN is pressed during a host session.

Enable SYSREQ Key as IAC Interrupt Process: Select to send an
IAC Interrupt Telnet command when a SYSREQ key is pressed during
a host session.

Same Model for Primary and Alternate Screens: Select to use the
same model type for both primary and alternate screen sizes. When
selected, you can use a model type other than model 2 for primary
screens.

Use TN3270 When Supported: Enables TN3270 enhanced protocols
when supported.

Resource/Device Name: Specify a particular LU on the host. If no
device name is entered, the server connects to any available LU at
that port.

The TN3270E server maintains sets of both general device pools and
specific device pools.

To configure a TN3270 connection

1. Start a new session, and select TN3270 as your connection type.

Do this To

Choose the Add button Add a new TN3270 connection
type.

Select a connection type from the
list and choose the Edit button

Edit a connection.

Select a connection type from the
list and choose the Delete button

Delete a connection.

Select a connection type from the
list and choose the Copy button

Copy a connection type to the
Clipboard.

Choose the Paste button Paste the copied connection
into the list.

3. Select Enable Infinite List Retries if you want EXTRA! to go through
the list of configured connections again and again until a successful
connection is made.
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4. From the Connection Timeout field, enter a value in seconds. The
default is 10 seconds.

5. From the Number of retries field, enter a value for the number
retries. The default is 0.

If you are adding or editing a connection, the Configure Connection
dialog box displays. Follow these instructions.

1. Enter either the numeric IP address or the alias name, using up to 32
characters. This option is case-sensitive.

2. From the Terminal/Device Type list, select a device type. The default
is IBM-3278.

3. From the Port Number field, enter a number. The default is 23.

4. (Optional) Select the Auto Reconnect option to specify whether
EXTRA! is to reconnect or is to remain disconnected when the
TN3270 session is logged off.

Note: If you are using the Microsoft Network, you may experience
problems when loading your TN3270 session. The Microsoft
Network dialog box may appear during the connection process.

To avoid this problem, in the Windows Control Panel, double-click
the Internet icon and clear the Use Autodial option. This prevents the
dialog box from appearing when loading a session.

VINES to Banyan SNA Service
You can connect to the mainframes via a Banyan VINES SNA Server
using Banyan VINES. You have two ways of configuring a connection:
you can specify a Service Name and Logical Unit (LU), or you can specify
a predefined Profile Key. The first option allows you to set specific values
for the connection. The second option obtains the default settings from
the Banyan VINES Server. To use the profile key option, your system
administrator must define it on the Banyan server.
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VINES to Banyan SNA Service - System Requirements
A Banyan SNA Service connection requires:

• Banyan SNA Base or Advanced Option package installed on the
Banyan VINES Server

• A LAN adapter that supports Banyan VINES

• Banyan VINES Enterprise Client (5.56 or later) for Windows NT or
Windows 95

The VINES to Banyan SNA Service - General Page

New Session Wizard - VINES to Banyan SNA Service General page

Use this page to define session information when using Banyan SNA
Service to access a host. You can define up to five different service names
or you can provide a profile key, which uses the default settings from the
server. Contact your system administrator for a valid profile key.
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The following section describes the fields on this page.

Override with VINES User Profile: Select this to use the service names
and LUs defined in the profile key on the server. Contact your system
administrator for a valid profile key.

Profile Key: Type a valid profile key as specified by your system
administrator. The profile key provides predefined service names and
LUs.

Connection Definitions: Displays the currently available connection
definitions and shows the parameters for each definition. The system
attempts to connect with each service in the list, beginning with the first,
until a connection is made.

You can clear the check box to the left of each server to disable a specific
configuration. If a server displayed in the list is going to be down for an
extended period of time, you can disable it (without deleting it), and
reconfigure the server later.

Add: Adds a profile to the Connection Profile list.

Edit: Changes the values of an existing profile.

Delete: Removes a profile from the Connection Profile list.

Copy: Makes a copy of an existing profile.

Paste: Pastes a copy of an existing profile in the list.

Move Up/Move Down buttons: Reorder the profile entries within the
Connection Profile list. The order determines which profile name is tried
first, then second, and so on until a connection is made.

List Retries

Enable Infinite List Retries: When selected, the system goes through
the entire list of connection definitions repeatedly, until a connection
is made.

Number of Retries: Specifies the number of additional times the
session will try to connect if the first attempt fails. The default is 0. If
more than one connection definition is listed, the system will go
through the whole list the specified number of times.

Note: This setting controls the number of times the session will go
through the list of connection definitions. Each connection definition
also has an individual setting for Number of Retries. On each pass
through the list, the session makes the number of attempts specified
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in the individual setting for each connection definition, then moves
on to the next connection definition.

Retry Delay: Indicates the number of seconds the session waits
between retries.

Connection Timeout (secs): Indicates the number of seconds the
session waits for a successful connection before stopping. The default
is 10 seconds. The maximum value is 300 seconds; 0 implies no
timeout.

The Edit Connection Dialog Box

Edit Connection dialog box

Use this dialog box to add or edit a connection definition.

Service Name: Lists the available service names. An asterisk (*) specifies
that the connection will access the first available service name.

LU Number: Lists the available LUs. The default is Any, with the range
of 2-255.

To configure a VINES to Banyan SNA Service connection

1. Start a new session, and select VINES to Banyan SNA Service as your
connection type.

2. From the next page, choose Add.

The Add Connection dialog box appears.

–or–

Select the Override with VINES User Profile check box, then enter a
valid profile key in the appropriate field and skip Steps 3 and 4.

3. From the Add Connection dialog box, select a service name and LU.

4. Choose OK.
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5. (Optional) Set the appropriate List Retry options as necessary.

For more information on a particular field, refer to the General page topic
within this section.

Using the Profile Key

Before you can use the Profile Key option, your system administrator
must set up a profile key on the Banyan Server using the following
format:

�TVSJMPICOI]�RYQFIVCSJCVIXVMIW�VIXV]CHIPE]

GSRRIGXMSRCXMQISYX�7IVZMGIC2EQI�09C2YQFIV����

7IVZMGIC2EQI�09C2YQFIV

The maximum length of the entire string is 255 characters. The List
Retries parameters are interpreted in order from left to right; if one or
more of the parameters is omitted, the system defaults to the values
listed on the General page. If the service name starts with a number or
has a space in it, the service name must be enclosed in double quotes, for
example: “1banyan” or “banyan service.” If an LU number is omitted, the
system defaults to “Any.”

Example

�463*-0)�������l&ER]ER�72%�7IVZMGI�z���l&ER]ER�72%

7IZMGI�z�l&ER]ER�72%�7IVZMGI�z���

In the example above, the profile key is PROFILE1. The number of retries
is 5, the retry delay is 30 seconds, and the connection timeout on the
General page will be used. The system will first attempt to connect to
Banyan SNA Service 1 using LU 4. If that attempt fails, it will next try
Banyan SNA Service 2 using the next available LU between 2 and 255. If
that fails, the system will next try Banyan SNA Service 3 using LU 20. If
that fails, it will start over with Banyan SNA Service 1.

ZIP! Server via Banyan VINES
You can connect to IBM mainframes via a ZIP! Server, using a Banyan
VINES protocol.

Before you can make a connection, you must first log on to your Banyan
Server.
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ZIP! Server via Banyan VINES - System Requirements
A Banyan VINES Connection requires:

• A LAN adapter that supports Banyan VINES

• Banyan VINES Enterprise Client (5.56 or later) for Windows NT,
Windows 95 or Windows 98

The ZIP! Server via Banyan VINES General Page

New Session Wizard - ZIP! Server via Banyan VINES General page

Use this page to define the ZIP! Server connection via Banyan VINES
protocol.

The following section describes the individual fields on this page.

Use Server Configuration: Select this option to use the information
defined within the StreetTalk profile located on your Banyan Server.

Note: All other options on this page are unavailable when Use Server
Configuration is selected.
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Gateway Selection

Enable LAN Broadcast: Select to specify that, upon session startup,
you workstation will broadcast a resource request to all gateways on
the LAN, connecting to the resource of the first gateway that
responds. A LAN broadcast is local; it will not traverse any
internetworking devices.

Gateway Name: Type the name of the specific gateway to which the
workstation will connect. Use the following syntax:

1EGLMRI2EQI$+VSYT2EQI$3VKERM^EXMSR2EQI

Contact your systems administrator for valid gateway names.

Resource Name: Type the name of the resource to which the workstation
will connect.

Workstation Name: Type the name of the workstation that will connect
to the server. To have the server assign a unique workstation name for
you, use an asterisk (*) in place of a workstation name.

Connection Timeout (secs): Specifies how long EXTRA! will wait before
it aborts a connection.

To configure a ZIP! Server connection via Banyan VINES

Before you can make a connection, you must first log on to your Banyan
Server as your connection type.

1. Start a new session, and select ZIP! Server via Banyan VINES as your
connection type.

2. To use the server’s configuration when you make a connection, from
the General page, select Use Server Configuration.

–or–

To connect to any available resource on your LAN, from the General
page, select Enable LAN Broadcast.

–or–

To connect to a specific gateway, from the General page, under
Gateway Name, type the name of the gateway to which you want to
connect. Use the following syntax:

1EGLMRI2EQI$+VSYT2EQI$3VKERM^EXMSR2EQI
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3. Enter a Resource Name.

4. Enter a Workstation Name. You can use the asterisk (*) symbol in
place of a workstation name to have the server assign a unique
workstation name for you.

5. Choose OK.

For more information on a particular field, refer to the General page topic
within this section.

ZIP! Server via IPX/SPX
You can connect to IBM mainframes via a ZIP! Server, using the IPX/SPX
(Internetwork Packet Exchange/Sequenced Packet Exchange) protocol.

ZIP! Server via IPX/SPX - System Requirements
Workstation requirements are listed below:

• A LAN adapter that supports IPX.

• Client service for NetWare.

• IPX/SPX Compatible transport.
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The ZIP! Server via IPX/SPX General Page

New Session Wizard - ZIP! Server via IPX/SPX General page

Use this page to define the ZIP! Server connection via IPX/SPX protocol.

The following section describes the individual fields on this page.

Resource Name: Type the name of the resource to which the workstation
will connect.

Workstation Name: Type the name of the workstation that will connect
to the server. To have the server assign a unique workstation name for
you, use an asterisk (*) in place of a workstation name.

Connection Timeout (secs): Displays the number of seconds the system
will wait for a successful connection before stopping. The default is 0,
which causes no timeout.

Number of Retries: Displays the number of additional times the session
will try to connect if the first attempt fails. The default is 0.
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The ZIP! Server via IPX/SPX Advanced Page

New Session Wizard - ZIP! Server via IPX/SPX Advanced page

Use this page to set the gateway options for your IPX/SPX connection.
You can choose from a list of available gateways or you can define your
own gateway. The following section describes the individual fields on
this page.

Available Gateways: Displays the available gateways currently available
for connection.

User Defined Gateway: Type a gateway name, then choose Add>> to
add the gateway name to the Selected Gateways list.

Use Selected Gateways Only: Select to limit session connections with the
gateways specified in the Selected Gateway list.

Selected Gateways: Displays the gateway names that will be used to
establish a connection (if the Use Selected Gateways Only option is
selected).

Add>>: Adds a gateway name to the Selected Gateways list.

Delete: Removes a gateway name from the Selected Gateways list.
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To configure a ZIP! Server connection via IPX/SPX

1. Start a new session, and select ZIP! Server via IPX/SPX as your
connection type.

2. From the General page, enter a Resource Name, then enter a
Workstation Name, if desired. You can use the asterisk (*) symbol in
place of a workstation name to have the server assign a unique
workstation name for you.

3. Change the Connection Timeout and Number of Retries, if desired.

4. From the Advanced page, select a gateway from the Available
Gateway list or type a gateway name or address under User Defined
Gateway, then choose Add>>.

5. Repeat Step 4 for each gateway to which you want to connect.

6. Choose OK.

For more information on a particular field, refer to the General page topic
within this section.

ZIP! SNA via NetBIOS
You can connect to IBM mainframes via a ZIP! Server, using the NetBEUI
protocol over NetBIOS.

ZIP! SNA via NetBIOS - System Requirements
In addition to general system requirements, please note the following
NetBEUI NetBIOS connection requirements:

• A LAN adapter that supports NetBIOS.

• A NetBEUI Protocol over an IBM compatible NetBIOS.

• A gateway running ZIP! SNA Gateway or IrmaLAN Server.
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The ZIP! SNA via NetBIOS General Page

New Session Wizard - ZIP! SNA Server via NetBIOS General page

Use this page to define the ZIP! Server connection via NetBEUI protocol
over NetBIOS

The following section describes the individual fields on this page.

Resource Name: Type the name of the resource to which the workstation
will connect.

Workstation Name: Type the name of the workstation that will connect
to the server. To have the server assign a unique workstation name for
you, use an asterisk (*) in place of a workstation name.

Connection Timeout (Secs): Indicates the number of seconds the session
waits for a successful connection before stopping. The default is 10
seconds. The maximum value you can enter here is 300 seconds; 0
implies no timeout.
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To configure a ZIP! SNA connection via NetBIOS

1. Start a new session, and select ZIP! Server via NetBIOS as your
connection type.

2. From the General page, enter a Resource Name, then enter a
Workstation Name, if desired. You can use the asterisk (*) symbol in
place of a workstation name to have the server assign a unique
workstation name for you.

3. Choose OK.

For more information on a particular field, refer to the General page topic
within this section.

ZIP! Server via TCP/IP
You can connect to IBM mainframes via a ZIP! Server, using a TCP/IP
(Transmission Control Protocol/Internet Protocol) protocol.

ZIP Server via TCP/IP - System Requirements
A TCP/IP connection requires:

• A communications adapter (Token-Ring or Ethernet adapter) that
passes TCP/IP packets.

• A TCP/IP stack compliant with the Windows Sockets (WinSock) 1.1
specification.
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The ZIP! Server via TCP/IP General Page

New Session Wizard - ZIP! Server via TCP/IP General page

Use this page to define the ZIP! Server connection via TCP/IP protocol

The following section describes the individual fields on this page.

Resource Name: Type the name of the resource to which the workstation
will connect.

Workstation Name: Type the name of the workstation that will connect
to the server. To have the server assign a unique workstation name for
you, use an asterisk (*) in place of a workstation name.

Connection Timeout (secs): Displays the number of seconds the system
will wait for a successful connection before stopping. The default is 0,
which causes no timeout.
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Gateway Selection

Enable LAN Broadcast: Select to specify that, upon session startup,
your workstation will broadcast a resource request to all gateways on
the LAN, connecting to the resource of the first gateway that
responds. A LAN broadcast is local; it will not traverse any
internetworking devices.

Host Alias/IP Address: Type either the alias name or the IP address
of the remote host.

To configure a ZIP! Server Connection via TCP/IP

1. Start a new session, and select ZIP! Server via TCP/IP as your
connection type.

2. From the General page, enter a Resource Name.

3. Select Enable LAN Broadcast to have the session connect to any
available resource on your LAN.

–or–

Enter the Host Alias/IP Address of the ZIP! Server.

4. Enter a Workstation Name, if desired. You can use the asterisk (*)
symbol in place of a workstation name to have the server assign a
unique workstation name for you.

5. Choose OK.

For more information on a particular field, refer to the General page topic
within this section.
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XTRA! provides many ways to customize how your sessions look
and act. You can decide what is displayed on your screen, which

colors and fonts are used, which display settings are used, as well as how
you cut, copy, and paste host information.

In addition, using the Options menu you can decide which type of
session you are using, which preferences a specific session can have, as
well as global preferences that determine how all your sessions act.

Customizing EXTRA! can help you identify specific sessions at a glance,
speed up your performance with custom functions, and give you the
flexibility to make your job easier.

Using a Startup Macro
By assigning a macro to a session, you can automatically run that macro
whenever you open the session. For example, you can assign macro that
automates logging on to your host and opening a host application.
Another good choice is a macro that performs a batch operation. For
example, you can create a startup macro that logs on to the host, uploads
a PC file, then logs off  all with little to no user interaction.

You can also assign a macro to a specific host page. When you access that
page  regardless of navigation method  the macro executes.

To assign a startup macro to a session

1. From the Edit menu, choose Settings.

2. Select the Macro category.

The Macro General page is displayed.

3. Type the name of a macro file, or choose Browse to select from a list
of files.

4. Choose OK.

Note: When you secure the startup macro, it removes the (name)
command from the Edit menu. The user can no longer set a macro to run
at startup.

E
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To remove a startup macro from a session

1. From the Edit menu, choose Settings.

2. Select the Macro category.

The Macro General page is displayed.

3. In the File Name text box, delete the name of the macro file.

4. Choose OK.

To select a macro file to run at startup

1 From the Options menu, choose Settings.

2. Choose the Macro category.

3. In the Startup Macro File box, either type the path and name of the
macro file or choose the Browse button and select the macro file you
want to run.

4. Choose OK.

The macro you selected will be run automatically the next time you
load EXTRA!.

To assign a macro to a host screen

1. From the Tools menu, select Record Pages.

EXTRA! is now in Record Pages mode. Any page that you move to
will be recorded.

If the host screen page that you want to add a macro to is already
recorded, skip this step and the next step.

2. Enter a Page Name for the host screen, or leave the name as the
default, and select the Stop button.

EXTRA! is no longer in Record Pages mode.

3. From the Tools menu, select Page Settings.

The Page Settings dialog box opens, with all recorded pages for this
session listed in their groups on the left.

4. Select the Page Name from the list and choose the Settings tab.
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5. Under the Available Settings list, open the folder labeled Macros.

6. Highlight the desired Macro and choose the Add button to add the
macro to the host screen.

7. Choose OK to save your changes.

Every time you access the recorded page   regardless of navigation
method   the macro you specify will execute.

Global Preferences
Global preferences are options that affect the way all EXTRA! sessions
operate. They are not specific to a particular session.

For example, you can specify whether to be prompted when you
disconnect a session from the host. If you select this option, EXTRA! will
ask you if you want to disconnect from the session when you choose Exit
Session or Exit EXTRA!.

You can set the following types of options:

• Session and application opening and closing options (General page)

• Advanced options for the Record Pages command (General page)

• Assign and remove HLLAPI short names to sessions, and select the
HLLAPI transport type (Advanced page)

• Change the type (physical configuration) of Keyboard assigned
during the Setup routine (Advanced page)

• Specify the default paths for startup macros and the locations of
schemes and settings files (Files/Directories page)
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The Global Preferences General Page

You can use this dialog box to specify whether sessions will be saved
automatically, whether the Open dialog box should appear when you
run EXTRA!, and whether you will be prompted for verification when
you disconnect a session from a host.

You can change the following options or attributes:

On Close Session/Application Exit: Choose Auto-Save Session Settings
to save the changes to session configuration automatically upon closing
the session or exiting the application, or Prompt for Session Saves to
prompt you about saving session configuration changes.

Auto-Save Session Settings: Saves any changes to the session
configuration automatically upon closing the session or exiting the
application.

Prompt for Session Saves: Prompts you to save session configuration
changes upon closing the session or exiting the application.

Show Open Session Dialog at Startup: Displays the Open Session dialog
box each time you run EXTRA!. This might be preferable if you run
EXTRA! from the Windows 95 Start menu. You may also want to use this
option if you open sessions by double-clicking them in My Computer or
Windows Explorer, or by double-clicking shortcuts on your desktop.

If you clear this option, the Open dialog box will not appear when you
run the application.

Prompt for Disconnection: Select this option if you want to be prompted
for confirmation before disconnecting from a host. This can be helpful in
preventing accidental host disconnections.

If you clear this option, you will not be prompted when you disconnect
from a host; the session will disconnect immediately.

Expand Page Settings dialog box: This page lets you edit the
navigational path and page identification information for recorded pages
(Tools, Record Pages command.)

Assign ENTER Key to Left Mouse Button Double-Click: Assigns the
left mouse button, when double-clicked, the same function as the ENTER
key.
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To save settings when closing a session or exiting EXTRA!

1. From the Options menu, choose Global Preferences.

2. On the General page, select the Auto-save Session Settings check box.

–or–

Select the Prompt for Session Saves check box.

To show the Open Session dialog box at startup

1. From the Options menu, choose Global Preferences.

2. On the General page, select the Show Open Session Dialog at Startup
option.

The Open dialog box will display each time you run EXTRA!.

To be prompted to disconnect sessions upon exiting EXTRA!

1. From the Options menu, choose Global Preferences.

2. On the General page, select the Prompt for Disconnection option.

You will be prompted for confirmation before disconnecting from a
host.

The Global Preferences Advanced Page

Use this page to assign a short name to a session for HLLAPI purposes,
select a HLLAPI transport type and select a keyboard type different from
the one selected during installation.

You can change the following options or attributes:

Browse button: Search for a session file to assign to a short name.

HLLAPI Short Name text box: Displays the short name and the session
file assigned to it. You must assign a HLLAPI short name before you
connect to a session, or if you already have session connections, you must
exit all sessions and restart the sessions before the HLLAPI short name
settings will take effect.

Remove button: Select a HLLAPI short name and remove the session
profile associated with it.

Keyboard Type: Changes the keyboard type from he one selected during
the Setup program.

Standard Transport Type (HLLAPI): Select for standard transport.

Enhanced Transport Type (HLLAPI): Select for enhanced transport.
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To associate a HLLAPI short name with a session

Note: You must assign a HLLAPI short name before you connect to a
session, or if you already have session connections, you must exit all
sessions and restart the sessions before the HLLAPI short name settings
will take effect.

1. From the Options menu, choose Global Preferences.

2. Choose the Advanced tab.

3. Choose the Browse button and select the session you want to assign
to a short name, then choose OK.

To remove a session association with a HLLAPI short name

1. From the Options menu, choose Global Preferences.

2. Choose the Advanced tab.

3. Select a HLLAPI short name and session profile associated with it.

4. Choose the Remove button, then choose Apply or OK.

The session profile is no longer associated with that short name.

The Global Preferences Files/Directories Page

Use this page to specify a startup macro (if desired), the macro search
path, and the locations of schemes and settings files.

This page has the following fields:

Macro Search Path: Displays the name of the directory where macros are
stored.

To use a different directory, choose Browse and select the desired
directory from the Browse for Folder dialog box.

Browse button: Select the desired file or folder from a list of available
files or folders.

Local Path: Displays the name of the directory on your PC where
schemes, keyboard maps, and QuickPads are stored. By default, all new
schemes, keyboard maps, and QuickPads are created in this location.

Remote Path: Displays the name of the network directory where
schemes, keyboard maps, and QuickPads are stored.

To use a different directory, choose Browse and select the desired
directory from the Browse for Folder dialog box.



User’s Guide

3-8

Browse: Enables the user to select the desired file or folder from a list of
available files or folders.

To select a scheme or settings file using the local or remote path

1. From the Options menu, choose Global Preferences.

2. Choose the Files/Directories tab.

3. In the Settings Information box, choose the Browse button and select
the scheme or settings file you want to use, then choose OK.

Securing Global Preferences
When you secure Global Preferences, it removes the command from the
Options menu. The user can no longer:

• Set startup and exit functions, and advanced page settings

• Assign short names to sessions for HLLAPI purposes

• Browse to find macro, scheme, or settings files to use

For more information on setting Security, see Chapter 14, “Using
Security.”

Viewing Session Properties
EXTRA! provides you with a quick way to view the properties of your
sessions. You can view:

• General properties (General page) such as the session type, location
of the session file, the size of the file, and the dates the session file
was created, modified, and last accessed.

• Statistics (Statistics page) such as the host type, connection type,
terminal type, and file transfer protocol used by the session.

• Current session properties (Session page) such as communications
status, server information, resource name, local address and
workstation name, as well as any miscellaneous information
regarding the connection.

In addition to the properties mentioned above, a Summary page is
provided where you can enter the author’s name, session description,
and comments.
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To view a Properties page

1. From the File menu, choose Properties to display the Properties
dialog box.

2. Choose the page that contains the properties you want to view:
General, Statistics, or Session.

To define summary information

3. From the File menu, choose Properties to display the Properties
dialog box.

4. Choose the Summary tab to display the Summary page.

5. Enter the author’s name.

6. Enter a description of the session.

7. Add any comments about the session.

8. Click OK.

Changing the Look of Your Sessions
This section explains how to change what is displayed on your screen. It
covers how to display HotSpots, how to remove and display the toolbar,
as well as how to display the keyboard map you are using and any
QuickPads associated with your sessions.

HotSpots
Using EXTRA!, you can associate a function with a specific area on your
screen so you can double-click the left mouse button on that area to carry
out the function, macro, or command. The area you specify is known as a
HotSpot. You can create your own HotSpots and use them individually
associated with a session, or you can create a group of them called a
scheme and associate them with any session or host screen.

For more information on HotSpots, see Chapter 7, “Using HotSpots.”
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To view HotSpots in your session

1. From the View Menu, choose HotSpots.

The Settings - HotSpots dialog box appears.

2. On the General page, select the Enable HotSpots check box and
choose OK.

Toolbars
EXTRA! comes with default toolbars (*.ETB) that appear when you create
a new session or open one of the default sessions. Toolbars can help you
perform tasks that are hard to remember or that you have to repeat
routinely. They are also useful if you prefer using a mouse to using the
keyboard to execute commands.

Toolbars display small color buttons, and a ToolTip appears when the
mouse pointer is over a button for more than one or two seconds. Once
you add a toolbar to a session and then save the session, that toolbar
loads automatically the next time you open that session. You can load
multiple toolbars for a session.

For more information on toolbars in general, or on creating, editing, or
removing toolbars, see Chapter 11, “Using QuickPads and Toolbars.”

To add a toolbar to your session

1. From the View menu, choose the Toolbars command.

This displays the Settings dialog with the Toolbars category selected.
A list of available toolbar schemes is displayed. You can select more
than one toolbar to be loaded during a session.

2. Choose the name of the toolbar to load by selecting its checkbox.

You have other options in this dialog, such as displaying large
toolbar buttons, choosing between color and monochrome buttons,
or whether to show ToolTips for the buttons.
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Keyboard Maps
To enable your PC to communicate with a host in the same way as a
terminal, EXTRA! uses a “keyboard map” which substitutes a PC key (or
combination of keys) for the terminal function. You can use the default
keyboard map, choose from a list of pre-made maps, or create your own.

To view the keyboard map associated with the current session

• From the View menu, choose Keyboard Map.

You can use the mouse to click the keys on the keyboard map, and the
corresponding characters appear on the session window. When you click
on an action key, the corresponding actions are taken in the session. For
information on keyboard maps, see Chapter 8, “Customizing the
Keyboard.”

QuickPads
A QuickPad is a small window that you can load during a session that
can contain text, buttons, bitmaps, icons, and other graphic elements,
each of which initiates an action when chosen. QuickPads can help you
perform tasks that are hard to remember or that you have to repeat
routinely. They are also useful if you prefer using a mouse to using the
keyboard to execute commands.

The buttons and icons on QuickPads can perform the following tasks:

• send keystrokes

• run a macro

• run an application

• load a scheme

• perform any function that can be performed using EXTRA! menus

Once you add a QuickPad to a session and then save the session, that
QuickPad loads automatically the next time you open that session. You
can load multiple QuickPads for a session.

EXTRA! comes with predefined QuickPads that are already set up and
ready to use. You can use the predefined QuickPads, you can edit them,
or you can create your own to meet your unique needs. For more
information on QuickPads in general, or on creating, editing, or
removing QuickPads, see Chapter 9, “Using QuickPads and Toolbars.”
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To add a QuickPad to your session

1. From the View menu, choose QuickPads.

This displays the Settings dialog box with the QuickPads category
selected. A list of available QuickPad schemes is displayed. You can
select more than one QuickPad to be added during a session.

2. Select the check boxes for the QuickPads that you want to add to the
session display. Clear the check boxes for the QuickPads you want to
remove from the session display.

To define summary information

1. From the File menu, choose Properties to display the Properties
dialog box.

2. Choose the Summary tab to display the Summary page.

3. Enter the author’s name.

4. Enter a description of the session.

5. Add any comments about the session.

6. Click OK.

Customizing Colors
The following section discusses how you can customize EXTRA! to
change the colors displayed in your session or graphics window.

Changing Color Settings
You can change the colors in a display or graphics session including the
foreground and background of the text colors sent from the mainframe.
The foreground consists of the text within an area while the background
is the area surrounding that text. Think of these areas as the basic colors
of your screen. You can change the color of your cursor.

You can also change colors of the more advanced areas of your screen,
including host attributes, such as protected and unprotected fields.
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After changing the colors on your screen, you can save those changes to a
scheme, which can then be assigned to another session or a specific host
screen. EXTRA! also comes with its own color schemes from which you
can choose. Changing colors might make certain areas of the display
session easier to read or perhaps make it easier to differentiate one
session or host screen from another that has a different color scheme.

The 3270 Settings - Colors General Page

The Settings-Colors Page is used to change the colors of your display
screen and create color schemes that you can use with any session.

The 3270 Settings - Colors General Page

Scheme: Lists color schemes you can choose from to apply to a session.
The list includes those schemes provided by EXTRA! and the schemes
you have created.

Save As button: Opens the Save As dialog box where you can save a
color scheme to be used later.

Delete button: Deletes the color scheme selected in the Scheme list box.

Host Monitor: Shows the colors and display areas that can be mapped to
other colors. Once you have mapped an item on this list using the Host
list box and the Mapping palette, that item displays in the new color.
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Mapping Palette

Foreground Color: Provides colors from which you can choose to
map the foreground of your display.

Background Color: Provides colors from which you can choose to
map the background of your display.

Host List: Lists the colors and display areas that can be mapped to other
colors. Select an item from this list, then use the Mapping palette to
change its color.

Color Mode: Lists the color options for mapping display colors to host
field attributes.

Always 2-Color: Maps colors to protected and unprotected host field
attributes.

2 or 4-Color: Choose this option to have the host determine the host
field attributes available to the user for color mapping, either two or
four.

Always 4-Color: Maps colors to protected normal, protected high,
unprotected normal, and unprotected high host field attributes.

To change 3270 screen colors

1. From the Options menu, choose Settings.

2. From the Categories list, choose Colors.

3. On the General page, select the item you want to map from the Host
list box located below the monitor.

4. Select the color you want to map the item to on the mapping palette.

The item mapped changes to the new color on the monitor.

5. Choose Apply or OK.

The Colors Graphics Page is used to change the colors of your graphics
screen and create color schemes that you can use.
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The 3270 Settings - Colors Graphics Page

The Settings-Colors Graphics Page is used to change the colors of your
graphics screen and create color schemes that you can use.

3270 Settings - Colors Graphics Page

Scheme: Lists color schemes you can choose from to apply to a session.
The list includes those schemes provided by EXTRA! and the schemes
you have created.

Save As button: Opens the Save As dialog box where you can save a
color scheme to be used later.

Delete button: Deletes the color scheme selected in the Scheme list box.

Host Monitor: Shows the colors and display areas that can be mapped to
other colors. Once you have mapped an item on this list using the Host
list box and the Mapping palette, that item displays in the new color.

Mapping Palette: Gives you the colors to choose from for mapping
purposes.

Host List: Lists the colors and display areas that can be mapped to other
colors. Select an item from this list, then use the Mapping palette to
change its color.
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To change 3270 graphics colors

1. From the Options menu, choose Settings.

2. From the Categories list, choose Colors.

3. On the Graphics page, select the item you want to map from the Host
list box located below the monitor.

4. Select the color you want to map the item to on the mapping palette.

The item mapped changes to the new color on the monitor.

5. Choose Apply or OK.

To change 3270 host attribute colors

1. From the Options menu, choose Settings.

2. From the Categories list, choose Colors.

3. On the General page, select the color mode you want from the
available options. The mode you choose will determine what is
available to choose from in the Host list box.

4. From the Host list box below the sample host monitor, select the item
you want to map.

5. Select the foreground and background colors you want to map the
item to on the mapping palette.

Note: The item you mapped has changed to the new color on the
sample host monitor.

6. Choose Apply or OK.

To create a 3270 color scheme

1. From the Options menu, choose Settings.

2. From the Categories list, choose Colors.

3. Map the colors that you want to change.
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4. Choose the Save As button.

5. In the Save Scheme dialog box, enter the name of your new scheme
and choose the Local or Remote option button, then choose OK.

Note: The path for Local copy is a default setting. The path for
Remote copy can be set using Options Global Preferences.

To delete a 3270 color scheme

1. From the Options menu, choose Settings.

2. From the Categories list, choose Colors.

3. In the Scheme list box, choose the scheme you want to delete.

4. Choose the Delete button, then choose OK.

Securing 3270 Colors
When you secure colors, it removes Colors from the Categories list in the
Options Settings dialog box. The user can no longer map colors or create
color schemes.For more information on setting Security, see Chapter 13,
“Using Security.”

For more information on setting Security, see Chapter 14, “Using
Security.”
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Changing Display Session Fonts
Using EXTRA!, you can change the font displayed in your display
session window. You can change the display font and its size; and you
can specify whether you want the font to be adjusted automatically when
you resize the display session window. The following section discusses
how you can customize EXTRA! to change the font displayed in your
session window.

In EXTRA!, you can change the display session font to:

• Use a different font type.

• Use a different font point size.

• Exclude incompatible aspect ratio fonts.

• Scale raster fonts.

• Automatically resize when you resize the display session window.

• Automatically resize the display session window to best fit around
the selected text.

• Use a different margin width.
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Changing 3270 Display Fonts

The 3270 Settings - Font General Page

Use this page to customize the font displayed in your display session
window. The following section describes the fields within this dialog
box.

The 3270 Settings - Font General page

Font: Displays a list of the available fonts from which to select for your
display session window. Your display session appears in the font you
select.

Size: Displays a list of available point sizes for the font you have selected.
The default point size for each font is AUTO which automatically selects
the most appropriate font size to fit your display session window.
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Margins: Select either Wide or Narrow to adjust the margin width in
your display session window. Select Wide to use a wide margin setting
where characters are centered in your display window. Select Narrow to
reduce extra margin spacing around the text by expanding characters
and distributing them using the entire window area. This makes text
more readable.

Margins - Wide: Uses a wide margin setting where characters are
centered in your display window.

Margins - Narrow: Reduces extra margin spacing around the text by
expanding characters and distributing them using the entire window
area. This makes text more readable.

Margins - None: Removes the margin and expands characters over
the entire window area.

Autosize Window to Font Size: Resizes the display session window
automatically based on the font size being used. This reduces empty
space around the text.

Advanced: Offers the options to exclude incompatible aspect ratio fonts
and allow raster font scaling.

Exclude Incompatible Aspect Ratio Fonts: Excludes fonts with
incompatible aspect ratios (the normal height-to-width relationship
of the characters). Some scaleable fonts have an unusually large or
small number of characters per inch because the image of each
character is stretched or squeezed horizontally. Because this
stretching and squeezing can make a scaleable font less attractive,
selecting this option will allow EXTRA! to only use fonts that are
readable.

Allow Raster Font Scaling: When selected, raster fonts can be scaled.
Raster fonts are fonts that are stored as bitmaps.

Sample: Displays an example of the font in the size you have selected.

To change 3270 font, point size, and margins

1. From the Edit or Options menu, choose Settings.

2. From the Categories List, select Font.

3. On the General page, choose from the font, size, margin and
advanced options:

You can preview your selection in the Sample box.

4. Choose the OK or Apply button.
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Automatic 3270 Session Window Sizing

When you select Autosize Window, EXTRA! adjusts the display window
size to best fit the current font. This eliminates extra margin spacing
around the text once a font is established.

To size your 3270 session window automatically

1. From the Options menu, choose Settings.

2. From the Categories List, select Font.

3. From the General page, select the Auto Size Window to Font Size
check box.

4. Choose the OK or Apply button.

If you do not want the display window to resize automatically, clear
the Auto Size Window to Font Size check box.

Changing Display Settings
Using EXTRA! you can change the settings of your display sessions to fit
your specific requirements. For example, you can change the type, size,
and style of fonts used, change the cursor size, and define show
attributes, in addition to other settings.

Most of the work you do in EXTRA! takes place in a display session
window. This is the window that emulates your host terminal session,
and allows you to transfer information between your PC and mainframe
environments or between two or more mainframe sessions.

Once you establish a connection between your PC and the mainframe,
the EXTRA! display session window opens on your screen. You will see
the host’s logon screen. The exact appearance of this screen depends on
the way your system administrator set up the host system. After you log
on, you can access all of your host’s programs.

Once you have successfully logged on to the host through EXTRA!, you
can access and manipulate any of your host’s applications or files as
though you were working on a host terminal.

You can change the model type of the host you are emulating, change the
host code page, define show attributes, and start a graphics session, in
addition to many other settings.
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3270 Display Sessions
The display session window presents information from the mainframe,
bringing the same capabilities of a mainframe terminal to your PC.
EXTRA! can emulate one or more sessions at a time, giving you a display
session window for each terminal emulated. While you work in a display
session window, your PC keyboard no longer generates PC characters,
but instead produces 3270 display keyboard characters and special
functions. Each display session has its own connection to the mainframe.

EXTRA! can emulate mainframe terminal models 2, 3, 4, and 5. These
models differ by the number of rows and columns of text that they
display. The host graphics features in EXTRA! provide graphics terminal
emulation.

You use the Display Settings pages to define options for a 3270 display or
graphics session. Depending on your specific requirements, you may
want to make changes to the appearance of your display or graphics
session window.

Use the following tabbed pages to define your session window:

General: Use this page to select the display or graphics model for your
session window, the appearance of the graphics cursor, and support for
extended attributes, and program symbols.

Host Code Page: Use this page to specify the type of host code page you
need to use for your display session. If you are not sure which country
and code page you should be using, check with your system
administrator. The default is English U.S., code page 037.

Miscellaneous: Use this page to select numeric field override and the
APL (A Programming Language) mode for your keyboard map. You can
also use this page to access the Print utilities, and mouse options.

Attributes: Use this page to select show attribute options such as field
attribute value, unprotected attributes, uppercase only, and host beep
attribute. This page also provides options to change the appearance of
blinking text and the cursor.
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To define settings for 3270 display sessions

1. From the Edit or Options menu, choose Settings.

2. Click Display from the Category list to open the Settings - 3270
Display pages.

3. From the General page, set the appropriate display session options.

4. From the Host Code page, set the appropriate host code options,
listed below. The default is English U.S., code page 037.

5. From the Miscellaneous page, set the Numeric Field Override, APL,
Profs Print, PS Print and mouse options.

6. From the Attributes page, set the appropriate attributes options,
listed below.

7. Click OK when you have finished defining your display settings.

To define settings for 3270 graphics session

1. Open a display session in EXTRA!.

2. From the Settings dialog box, select Display.

3. From the General Page, set the appropriate Text Display graphics
sessions options

4. Choose the Graphics Display options.

5. Choose the Cursor options.

6. Choose the OK button to save settings and return to the session.

7. Select Yes in the dialog box to disconnect from your current session
and to start the graphics session.
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The Settings - 3270 Display General Page

Use this dialog to make changes to your 3270 display session window.

The Settings - 3270 Display General page

Text Display Options: Lists the types of models from which you can
select and also list the support options.

Model: Specifies the type of mainframe terminal model emulated for
3270 display sessions. You can choose from:  Any model, 2 - 24 x80,
3 - 32 x 80, 4 - 43 x 80, or 5 - 27 x 132.

Support Extended Attributes: Enables support of Extended
Attribute Bytes (EABs). EABs are codes used by many mainframe
applications to display highlighting, reverse image, blinking, and
seven colors. If selected, the EABs option allows the PC to emulate
the full capability of the mainframe screen.

Support Program Symbols: Enables loadable symbols support.
Loadable symbols, also called graphic symbol sets, are sets of
symbols that are treated as small, individual bitmaps. Loadable
symbols can appear in the graphics layer or the text layer. In the text
layer, they are referred to as Program Symbols and are used as
custom text. These are turned on by default for the 3279S3G graphics
model.



Changing Session Settings

3-25

Graphics Display Options: Includes types of graphics models to select
from as well as selections for graphic size and graphics cursor
appearance.

Model: Choose from the graphics terminal models for your session.
Note that the Support extended attributes option must be on for you
to choose one of these terminal models.

Expand Graphic Size: Tells the host that the screen size being
requested needs to be bigger than the current monitor resolution.

Graphics Cursor Appearance: Choose the type of graphics cursor
you want to use with your graphics session. This option is available
only for the 3179G, 3472G, and 3270PCG graphics terminal models
only.

Crosshair Cursor: Displays the crosshair graphics cursor for your
graphics session when selected.

Box Cursor: Displays the box graphics cursor for your graphics
session when selected.

Cursor Options: Displays cursor and rule line appearance choices.

Cursor Appearance: Specifies whether the cursor should be full
block, half block or underlined.

Show Cursor Blinking: If selected, this option indicates that you
want a blinking cursor. If not selected, the cursor will be solid.

Rule Line Appearance: Specifies the appearance of the rule line,
which displays to provide a visual cue of your location on the screen.
You can select a vertical line, a horizontal line or cross (vertical and
horizontal) lines.

Move Rule Line With Cursor: If selected, indicates that the rule line
should follow the cursor. If not selected, the rule line will not move
with the cursor but can be positioned by selecting the Rule Lines
option from the View menu once in the session.

Rule Line Style: Specifies whether the rule line should be a solid or
dotted line.
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The Settings - 3270 Display Host Code Page

Use this dialog to specify the type of host code page you want to use with
your 3270 display session.

The Settings - 3270 Display Host Code Page

Country: Lists the country languages from which you can select for your
3270 display session. The default is English U.S.

Code Page: Lists the character display code page numbers associated
with the country language. The default code page is 037.

Following is a list of the country code languages and their corresponding
code pages:
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Country Code
Language

Code
Page

Country Code
Language

Code
Page

Austrian 273 International 500
Austrian Euro 1141 International Euro 1148
Belgian 274 Italian 280
Belgian New 500 Italian Euro 114
Belgian New Euro 1148 Latin 1/Open Systems 1047
Brazilian 275 Cyrillic Macedonian 1025
Brazilian New 037 Norwegian 277
Brazilian New Euro 1140 Norwegian Euro 1142
Cyrillic Bulgarian 1025 Polish 870
Canadian Bilingual 037 Portuguese 037
Canadian Bilingual
Euro

1140 Portuguese Euro 1140

Croatian 870 Romanian 870
Czech 870 Russian 1025
Danish 277 Serbian 870
Danish Euro 1142 Cyrillic Serbian 1025
Dutch 037 Slovak 870
Dutch Euro 1140 Slovenian 870
English UK 285 Spanish 284
English UK Euro 1146 Spanish Euro 1145
English US 037 Spanish Speaking 284
English US Euro 1140 Spanish Speaking Euro 1145
Finnish 278 Swedish 278
Finnish Euro 1143 Swedish Euro 1143
French 297 Swiss French 500
French Euro 1147 Swiss French Euro 1148
German 273 Swiss German 500
German Euro 1141 Swiss German Euro 1148
Greek New 875 Turkish New 1026
Hungarian 870
Icelandic 871
Icelandic Euro 1149



User’s Guide

3-28

If you are not sure which country and code page you should be using,
check with your system administrator. The default is English U.S., code
page 037.

The Settings - 3270 Display Miscellaneous Page

Use this dialog to enable miscellaneous options for your 3270 display
session.

EXTRA! supports lightpen-detectable fields in a 3270 application.

Note: EXTRA! supports lightpen-detectable fields in a 3270 application.
Make sure that your lightpen device is recognized by the operating
system and configured to emulate a mouse.

The Settings - 3270 Display Miscellaneous page

Numeric Field Override: Enables the numeric field override feature.

APL: Enables your keyboard to support the “A Programming Language”
(APL) character set. The default is on. Note that if you are installing over
an earlier version of EXTRA!, you must enable this option to use your
keyboard in the APL mode.
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Mouse Options

Support Lightpen with Left Button Click: Enables support for the
lightpen (a light-sensitive device that can be used to select fields on
the screen) configured as a mouse.

Right Button: Allows you to choose the configuration for the right
mouse button. You can select Windows Default, Emulate Lightpen or
Send ENTER Key

Profs Print - Enable Profs Print: Configures the Profs Print utility. Profs
Print monitors the PROFS or OfficeVision/VM session from which you
select it. When you use the PF key print function in that session to print a
note, calendar, notelog, or other text, Profs Print prints it on the default
printer selected in Microsoft Windows instead of the host printer.

PS Print - Enable PS Print: Configures the PS Print utility. PS Print is a
Windows utility that redirects notes and documents from a PS/CICS
mainframe session to the printer defined in your Windows Control Panel
Print settings, while maintaining all system maintenance between the
mainframe and PC connections. PS Print will not print the formatting of
the target document, only the text.

To configure a 3270 session to accept lightpen

1. From the Options menu, choose Settings.

The Settings dialog displays.

2. Choose the Display category.

The General page displays.

3. Choose the Miscellaneous tab. The Miscellaneous page displays.

4. Select the Support Lightpen with left button click option.

–or–

If you want to use the right mouse button to emulate lightpen then
select Enable Lightpen from the Right Button drop-down list.

5. Choose the OK button.

The session is now ready to recognize lightpen-detectable fields.

If no lightpen is available or if you want to use the keyboard instead of
the lightpen, the text cursor and cursor select key can be substituted.
Move the!session’s text cursor to a lightpen-detectable field and then
press the Cursor Select key to simulate lightpen input.
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To determine which key is configured as the Cursor Select key for your
keyboard:

1. From a session View menu, choose Keyboard Map.

2. Scan the keyboard map for either the Cursor or CURSEL key — it is
often the SCROLL LOCK key.

3. Close the keybo`ard map.

The Settings - 3270 Display Attributes Page

The Settings - 3270 Display Attributes page

Attribute options: Display attributes are characters that appear on your
screen indicating where text formatting begins and ends. Use the options
in this group box to specify how attributes are shown.

Show Field Attribute Value: When selected, the display attributes
appear as small hexadecimal numbers before and after each field in
the display session.

Show Unprotected Attributes: When selected, selected data in a
display session is shown in an unprotected field.

Show Display Characters in Uppercase Only: When selected, all
text is displayed in uppercase characters.
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Enable Host Beep Attribute: When selected, your display session’s
blinking text style beeps.

Enable Toggle Insert Mode: When selected, the insert mode is
toggled on.

Blinking Text Appearance: Use the options in this group box to specify
where text formatting begins and ends. You can select the style of
blinking text from one of the following:  plain, underline, blink, or
reverse.

Plain: When selected, the style of blinking text is plain.

Underline: When selected, the style of blinking text is underlined.

Blink: When selected, this option allows you to enable specific text to
blink.

Reverse: When selected, the blinking text style is reverse.

Changing Edit Settings
Some of the most common tasks performed in a display session
connected to a host computer are those involving cutting, copying, and
pasting text. This can be moving text within a session, moving text
between sessions, or moving text to or from a separate application. In
order to change the way that EXTRA! handles cutting, copying, or
pasting text, you must change the Edit settings.

3270 Edit Settings
The way in which data or text is copied or pasted from a session depends
upon the Edit settings. Edit settings include options such as:

• copying to protected fields

• copying to unprotected fields

• replacing cut or cleared text with space or NULL characters

• pasting as text rows, with or without word wrap to keep from
truncating data

• pasting field by field, which can help get an accurate “fit” from the
copied space to the pasting space

• a character or characters with which to replace tabs when pasting
tab-delimited information
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The 3270 Settings - Edit General Page

Using this page, you can specify the settings that you prefer for cutting,
copying, and pasting text to and from sessions.

The 3270 Settings - Edit General Page

Scheme: Select the scheme you wish to edit, or delete.

Save As: Saves the current Edit settings under another name as a new
scheme.

Delete: Removes the current scheme from the scheme list.

Copy Options: Protected fields copies from areas on the screen where
input is not allowed and Unprotected copies from areas on the screen
where input is allowed.

Protected Fields: Allows copying from areas on the screen where
input is not allowed.

Unprotected Fields: Allows copying from areas on the screen where
input is allowed.

Cut/Clear Filler: Replace with Spaces - Replaces cut or cleared
characters with an equal number of spaces. Only unprotected fields can
be cleared.
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Replace with Nulls - Replaces cut or cleared characters with an equal
number of nulls. Only unprotected fields can be cleared.

Paste Options

Row Oriented: Pastes rows of text that end with carriage returns or
line feeds. The first row is pasted to the first unprotected field in the
current session, the second row is pasted to the second unprotected
field, and so on until the buffer is empty. If a row of copied text is
larger than the unprotected field it is pasted into, extra characters are
truncated (unless you select Word Wrap).

Field Oriented: Pastes field information. The first field is pasted to
the first field in the current session, the second field is pasted to the
second field in the current session, and so on until the buffer is
empty.

Character Oriented: Pastes characters.

Word Wrap: Causes information which would have been truncated
at the end of a field (or the selected paste area) to be pasted to the
next unprotected field instead of truncating it.

Paste to Protected Fields: Pastes from the Clipboard to the selected
area of the host destination screen field, regardless of whether these
fields are protected or unprotected. You cannot paste over a
protected field.

Replace Tabs With: Specifies the character(s) to replace any tabs in
the data being pasted, if, for example, you are pasting tab-delimited
data from Microsoft Word.

The 3270 Settings - Edit Advanced Page

The 3270 Edit Settings - Advanced page lets you specify advanced
settings for cutting, copying and pasting text to and from sessions. Using
this page, you can specify advanced settings that you prefer for cutting,
copying, and pasting text to and from sessions.

The following describes the options available on the Edit Settings -
Advanced page.
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The 3270 Settings - Edit Advanced Page

Scheme: Type the filename of an existing Edit scheme, or select a scheme
from the list.

Save As: Choose this button to save the selected option as an Edit
scheme.

Delete

Choose this button to delete the displayed Edit scheme.

Format Options: Includes cutting, copying and pasting options which
include; proprietary format, spreadsheet format, unformatted text and
bitmap format.

Attachmate 3270 (proprietary format): This clipboard format allows
the cutting, copying, and pasting of 3270 information such as APL
characters, and field attributes.

Cell Delimited (spreadsheet): This clipboard format allows the
cutting, copying and pasting of spreadsheet or other cell-based
information. Use this format for spreadsheet or databases.



Changing Session Settings

3-35

Separate at field/Separate at word: Choose Separate at field when
cutting or copying information to the clipboard, the information is
separated according to 3270 fields. Choose Separate at word when
cutting or copying information to the clipboard, the information is
separated according to word boundaries.

Text (unformatted text): This clipboard format allows the cutting,
copying, and pasting of plain text, which is the most common format
used in Windows programs.

DIB (Device Independent Bitmap): This clipboard format allows
you to cut or copy device independent bitmap images (DIB’s) to the
clipboard.

Changing Session Types and Preferences
The following section discusses how you can customize EXTRA! to
change the type of session you are using and how to change settings,
which can be session specific or global in nature.

Editing Session Types
Your session type includes the connection type, the display/device type,
and the file transfer protocol. When you create a new session, you choose
one of each of these. However, you can change some of these settings
later using the Session Type command from the Options menu. The file
transfer protocol can be changed while you are working in your session.
However, we recommend that you log off from your host applications
and disconnect from the current session before you change the
connection type. You cannot change a session from display to printer, or
from printer to display, in the display/device type field.

The Session Type Page

Use this page to change the connection type and the file transfer protocol
used for the current session. This changes the settings you chose when
using the New Session wizard to create a session. You cannot change the
display/device type of your session.

Note: When choosing a different connection type, it is best to first log off
from your host applications and disconnect from your session using the
Session Disconnect command.
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This feature is composed of the following elements:

Host Type: Displays the host type with which you currently have a
session.

Connection Type: Lists the connection types available to the current
session.

Note: When choosing a different connection type, it is best to first log off
from your host applications and disconnect from your session using
Session Disconnect.

Display/Device Type: Displays the display/device type of the current
session. The display/device type can be either display or printer.

File Transfer Protocol: Lists the file transfer protocols available to the
current session.

Settings Button: Opens the Options Settings page(s) pertaining to the
item you have currently selected. You can then edit that item’s settings.

To verify your Host type

• From the Options menu, choose Session Type.

The Host Type display lists the type of host to which your current
session is connected.

To edit your connection type

1. From the Options menu, choose Session Type.

2. From the Connection Type list, select the new connection type and
then choose OK.

Note: When choosing a different connection type, it is best to first log
off from your host applications and disconnect from your session
using the Session Disconnect Command.
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To edit your connection option settings

1. From the Options menu, choose Session Type.

2. From the Connection Type list, select a connection.

3. Choose the Settings button.

The Settings - Connection page appears.

To edit your display option settings

1. From the Options menu, choose Session Type.

2. From the Display/Device type list, select a display/device type.

3. Choose the Settings button.

The Settings - Display page appears. For more information on editing
display settings, see “Changing Display Settings” earlier in this
chapter.

To edit your file transfer protocol

1. From the Options menu, choose Session Type.

2. From the File Transfer Protocol list, select the new protocol and
choose OK.

To edit your file transfer option settings

1. From the Options menu, choose Session Type.

2. From the File Transfer Protocol list, select a protocol.

You must select a protocol from the list; you cannot select None.

3. Choose the Settings button.

The Settings - File Transfer page appears. For more information on
editing file transfer settings, see Chapter 6, “File Transfer.”





Working
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ome of the most common tasks performed in a display session
connected to a host computer involve cutting, copying, and pasting

text. For example, moving text within a session, moving text between
sessions, or moving text to or from a separate application.

This chapter tells  how you can select, cut, copy, and paste text into and
out of EXTRA!. It includes sections on:

• Appending text to the Clipboard so that you can add information to
the existing contents of the Clipboard (at the end).

• Pasting Clipboard contents (Paste Continue) that are larger than the
destination host screen.

• Pasting OLE links from EXTRA! into other applications such as
Microsoft Excel.

Selecting Text in EXTRA!
When a session is open, you can select text on the session window in
three ways:

• Hold down the SHIFT key and use the ARROW keys to select a
contiguous stream of characters, from the starting cursor position to
the ending cursor position.

Note: If you are using a keyboard map that has defined these
keystrokes to perform different functions, the functions associated
with the keyboard map override the default functions described
here.

• Hold down the left mouse button and drag it to select a contiguous
stream of characters, from the starting cursor position to the ending
cursor position (stream selection).

• Hold down the left mouse button. Drag it to select a rectangular
block of text that includes all lines and columns from the starting
cursor position to the ending cursor position (rectangle selection).

Tip: You can toggle the method of text selection (stream selection or
rectangle selection) dynamically during a session by holding down
the CTRL key while selecting text. Toggling applies only to selecting
text using a mouse.

S
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To select text in a session window

• Position the mouse pointer where you want to begin the text
selection, hold down the left mouse button, and drag the mouse
pointer across the text that you want to select.

You can select either a contiguous stream of characters from the
starting pointer position to the ending pointer position (stream
selection), or a rectangular block of text that includes all lines and
columns from the starting pointer position to the ending pointer
position (rectangle selection).

You can toggle the method of text selection (stream selection or
rectangle selection) dynamically during a session by holding down
the CTRL key while selecting text. Toggling applies only to selecting
text using a mouse.

–or–

• Position the cursor where you want to begin the text selection, hold
down the SHIFT key, and use the ARROW keys to highlight the text. If
you are using a keyboard map that has defined these keystrokes to
perform different functions, the functions associated with the
keyboard map override the default functions described here.

–or–

• If the left mouse button double-click has been configured to select a
word, then double-click the word that you want to select.

To toggle the text selection method

1. In the session window, press the CTRL key and begin selecting text
with the mouse.

2. Release the CTRL key, but do not release the mouse button.

3. Release the mouse button.

To select all text in a session window

• From the Edit menu, choose Select All.
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To clear selected text from a session window

1. In an open session, select the text that you want to clear.

2. From the Edit menu, choose Clear.

Note: Cleared text is removed from the display. It is not placed on
the PC Clipboard and cannot be pasted.

To cut text to the Clipboard from a session window

1. Select the text that you want to cut.

2. From the Edit menu, choose Cut (CTRL+X).

To copy text to the Clipboard from a session

1. Select the text that you want to copy.

2. From the Edit menu, choose Copy (CTRL+C).

Click the Copy button on the toolbar.

To cut text from a session and append it to the Clipboard

1. Select the text that you want to cut.

2. From the Edit menu, choose Cut and Append.

Note: The information is placed at the end of the Clipboard.

To copy text from a session and append it to the Clipboard

1. Select the text that you want to copy.

2. From the Edit menu, choose Copy and Append.

Note: The information is placed at the end of the Clipboard.

To paste text into a session window

1. Position the cursor where you want to insert the cut or copied text.

2. From the Edit menu, choose Paste (CTRL+V).
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To continue pasting when text in Clipboard is too large for destination
host screen

1. Position the cursor where you want to insert the cut or copied text.

2. From the Edit menu, choose Paste Continue.

Linking EXTRA! to Other Applications
Use EXTRA! OLE linking and embedding to exchange information
between EXTRA! and documents created in other applications. Use
linking when you want the information to be updated dynamically as the
information in your host application changes.

For example, you can link accounting application information to a
Microsoft Excel chart. Whenever the information changes in your host
application, your changes are displayed in the chart in the Microsoft
Excel document if it is open. If the Microsoft Excel document is not open,
the chart is updated the next time you open the document. To create a
link between an EXTRA! and a document in another application, that
application must be running, and it must support object linking and
embedding (OLE).

For information about how to use the OLE capabilities of EXTRA! from
an external program, refer to the EXTRA! OLE Automation Programmer’s
Reference.

To embed selected information from an EXTRA! session

1. Start EXTRA! (the “source application”) and navigate to the host
screen page that contains the data you want to embed.

2. Start the application in which you want to embed EXTRA! session
information (the “target application”).

3. Select the portion of the host screen containing your information.

4. Switch to the target application and select the location where you
would like to embed the information.

5. From the Edit menu in your target application, choose Paste Special.

6. In the Paste Special dialog box, select Text data type from the As box,
and select the Paste Link option.

7. Choose the OK button.
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To embed an entire EXTRA! session

1. Start the application in which you want to embed the EXTRA!
session (the “target application”).

2. From the Insert menu, choose Object.

3. Choose the Create From File tab.

4. Select the EXTRA! session file that you want to embed. If the file does
not appear in the current file list, select the correct directory, or use
the Network button or the Find File button to locate it.

5. Choose the OK button.

Edit Settings
The way in which data or text is copied or pasted from a session depends
upon the Edit settings. In the Edit Settings dialog box, you can specify
options that include:

• Copying to protected fields

• Copying to unprotected fields

• Replacing cut or cleared text with space or NULL characters

• Pasting as text rows, with or without word wrap to keep from
truncating data

• Pasting field by field (or in “blocks”), which can help get an accurate
“fit” from the copied space to the pasting space

• A character or characters with which to replace tabs when pasting
tab-delimited information

To access the Edit Settings dialog box

1. From the Edit menu, choose Settings.

2. From the Options menu, choose Settings, then click the Edit category.
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The Edit Menu
With the Edit menu commands, you can move information into and out
of sessions. Standard editing commands such as Cut, Copy, and Paste are
included here. Also included are Cut and Append and Copy and
Append commands which allow you to add text from a display session
to the existing contents of the Clipboard. Paste Continue is another
command offered which lets you paste the remaining portion of the
contents of the Clipboard if a Clipboard item is larger than the
destination host screen. Finally, the Settings command allows you to set
defaults for editing methods.

Using the Edit Menu
With the Edit menu commands, you can use information from one
session in another session or in a desktop application, or to configure
settings that control these operations. The commands available in the
Edit menu are:

This feature is composed of the following elements:

Cut: Removes selected text from the session and stores it in the
Clipboard.

Copy: Stores the selected text on the Clipboard, but leaves the selected
text unchanged in the display.

Cut and Append: Removes selected text from a session and appends it to
the existing contents of the Clipboard.

Note: You can only append information to the Clipboard within a single
session. You cannot append information from one session and then
append additional information from another session to the Clipboard.

Copy and Append: Adds the selected text from a session to the existing
contents of the Clipboard but leaves the selected text unchanged in the
display.

Note: You can only append information to the Clipboard within a single
session. You cannot append information from one session and then
append additional information from another session to the Clipboard.
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Paste: Places the contents of the Clipboard into the display session at the
cursor position (or into the selected area), subject to the Edit Settings
specifications.

Paste Continue: Pastes the remaining portion of the contents of the
Clipboard, if a Clipboard item is larger than the destination host screen.

Clear: Removes selected text from the session without storing it in the
Clipboard.

Select All: Selects the entire contents of the current session display,
making it available for cutting, copying, or clearing.

Settings: Opens the Settings dialog box, with the Edit Settings selected.
Use this dialog box to set Copy, Paste, and Cut/Clear options.

Securing Edit Menu Commands
The Security dialog boxes can be used to restrict access to all Edit menu
commands, as well as access to the Edit Settings dialog boxes. If you clear
the check boxes for the Edit commands in the Security Action dialog box,
the commands will no longer be available from the Edit menu.

If you clear the check box for the Settings command in the Security
Action dialog box, the program removes the Settings command from the
Edit menu. The user will not be able to start the Settings dialog box from
the Edit menu to modify how Cut, Copy, and Paste work on their host
screen when this command is secured.

To secure the Cut, Copy, and Paste commands

1 From the Options menu, choose Security.

The Security dialog box is displayed.

3. Select the security scheme you want to edit. The name of the security
scheme is listed in the Scheme field. Click Browse if you want to
select a different scheme.

4. Choose the Options tab.

5. If asked for a password, enter the password in the Security Password
dialog box and click OK.

6. From the Category list, choose Edit.

7. In the Commands list, clear the check boxes for the Edit commands
you want to secure: Cut, Copy, Paste, Clear, Select All, or Settings.

8. To save the scheme, go to the File page and click Save As.
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sing EXTRA! you can print Host files on your local printer. You can:

• open and configure printing sessions

• print multiple screens

• specify how many host screens to print per page

• define page layouts

• print an image of the display screen

• hold or cancel printing

• access printer session status information

• save printer session configuration and page layout settings

A printer session sets up the communications link between the host and
your local printer. A display session is used to enter the necessary host
print commands. Like display sessions, printer sessions are created,
opened, and closed. With EXTRA! you can configure Host print job
settings as you would a PC print job. You can set parameters that range
from margins and fonts, to advanced host printing parameters such as
hex passthrough data stream processing. Once print commands are
issued from the display session, the print job can be controlled and
monitored from the printer session using printer controls and the status
feature.

Opening a Printer Session
Before you can print host data, a printer session must be opened. A
printer session may be opened from a display session, an open printer
session, or in a variety of file-oriented methods.

Opening a printer session establishes connections between your PC, the
host, and the printer. You can open a printer session when you first start
EXTRA!, and from that session you can open additional sessions  — as
many as your PC memory can handle.

You can open printer sessions for any installed host type, with the
exception of a VAX/VMS, UNIX, or asynchronous host. Unlike IBM
hosts, printing from a VAX/VMS, UNIX, or asynchronous host does not
require a printer session.

U
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You open a printer session by selecting a file with an .EPP extension. A
profile defines how a session appears, operates, and interacts with you.
As a file consisting of settings, a profile specifies a session’s connection
type, and other attributes, all of which you can change to accommodate
your preferences.

To open a printer session from the display sessionsession

1. From the display session File menu, choose Open Session (CTRL+O).

–or–

Choose the   button from the toolbar.

2. Select the session filename.

3. Choose Open.

To open another printer session from the printer

1. From the printer session File menu, choose Open Session (CTRL+O).

–or–

Choose the   button from the toolbar.

2. Select the session filename.

3. Choose Open.
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Creating a Printer Session
Using the New Session wizard, you can create printer sessions of any
installed host type. You have the option of creating a printer session
when you first start EXTRA!. And when you’re working in an open
session, you can create additional printer sessions— as many as your PC
memory can handle.

To create a session, you must provide the New Session wizard with the
following information:

• Host type

• Session type — printer for IBM hosts.

Note: Unlike the IBM hosts, printing from a VAX/VMS, UNIX, or
asynchronous host does not require a printer session.

• Connection type and settings.

The wizard creates a printer session with many default settings, which
determine how the printer session appears, operates, and interacts with
you. You can later edit these settings to accommodate your preferences.

Tip: To create a new session with a profile identical or similar to an
existing session, use the Save As command instead of the New Session
wizard.

To create a printer session

1. From the File menu, choose New Session.

–or–

Choose the  button from the toolbar.

2. In the New Session wizard, select Printer Session, and then choose
Next.

3. Select a printer session type and choose Next.

4. Select a connection type and choose Next.
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5. Set the options for the selected connection and choose Next.

6. If you’re satisfied with your settings, choose Finish.

EXTRA! displays the new session.

7. From the File menu, choose Save Session.

You can save the session with any name. The default file extension of
.EPP indicates a printer session.

Closing a Printer Session
Closing a printer session breaks the  session’s connection to the host and
closes the printer session’s window. By closing a session, you free up PC
memory and make the host printing resource available to other users.

You can close printer sessions individually. Closing the last open printer
session is equivalent to exiting EXTRA!. If you have multiple sessions
open, you can simultaneously close all sessions by exiting the program.

Note: If you want to break the host connection without closing the
session window, disconnect rather than close the session.

To close a printer session

1. Log off from the session.

2. From the File menu, choose Exit Session.

3. If the session is connected, respond to the Disconnect prompt.

4. If you changed session settings without saving them, respond to the
Save prompt.
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Selecting a Printer
The printer you select either receives your print job directly or its local
definition is used to format a file on your PC. You may select any local
printer that is installed in Windows NT, Windows 95 or Windows 98.

To select a printer

1. From the printer session Options menu, choose Settings.

–or–

From the printer session File menu, choose Print Setup.

–or–

Choose the  button from the toolbar.

The Settings dialog box appears.

2. Select the Printer category.

The Settings - Printer dialog box appears.

3 On the Printer property page, select Printer, then select the Printer
name from the list.

Note: The choice of Default will make use of your currently installed
default Windows printer. If you select another printer, choose the
Apply button before moving on to other printer settings.

4. Choose OK to save your changes and close the printer settings dialog
box.

–or–

Choose Apply if you wish to save your changes and continue to
configure printer settings.

3270 Printer Settings
With EXTRA! you can configure your Host print job settings as you
would a PC print job, setting parameters such as margins, fonts, and
orientation. In addition, advanced host printing parameters may be set,
including substitution of the default host escape character, enablement of
hex passthrough data stream processing, and custom handling of form
feeds.
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To set up 3270 printer settings

1. From the printer session Options menu, choose Settings.

–or–

Choose the   button from the toolbar.

The Settings dialog box appears.

2. Select the Printer category.

The Settings - 3270 Printer dialog box appears.

3. Choose one of the following tabs that appear:

Printer, General, Margins, Fonts, LU1/LU4, LU3, or Data Stream.

4. Configure your settings under the tab that you select.

5. Choose OK to save your changes and close the printer settings dialog
box.

–or–

Choose Apply if you wish to save your changes and continue to
configure printer settings.

6. Repeat steps 1 through 5 for printer settings that appear under other
tabs on the Settings - 3270 Printer dialog box.

The Settings - 3270 Printer Printer Page

Use the 3270 Printer page to set options such as printer name and
destination (printer or file), and the option to bypass the Windows
Graphics Device Interface.
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The Settings - 3270 Printer Printer page

Destination: Displays print destination options.

Printer: Sends print data to printer.

Printer Name: Select the printer name to which you want to print.
You must choose the Apply button before moving on to other printer
settings.

File: Sends print data to disk file.

File Name: Enter the filename to print to.

Append to Existing File: When checked, the print job will be added
to the end of the specified filename. If the file does not exist, one will
be created.

Browse button: Choose this button to search for an existing file to print
to.

Bypass Windows GDI printing system: Translates the print datastream
directly to raw ASCII, and strips the datastream of host printing control
commands.

Paper Status: Displays the current paper size and source.
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The Settings - 3270 Printer General Page

Use the 3270 Printer General page to set host code page options, units of
measurement to be used in the printer session, line and page formatting
options, and font options.

The Settings - 3270 Printer General page

Host Code Page: Defines the character display code page used by the
host. (IBM 3812 printer switch = c04.)

PC Code Page: Defines the character display code page used by the PC.

Units of Measurement: Provides the choice of displaying measurement
units in centimeters or inches.

Inches: Displays units of measurement in inches.

Centimeters: Displays units of measurement in centimeters.

PC Uses OEM Character Set: Enables the PC to use the OEM character
set.

Enable Restrike Printing: Also known as “near letter quality,” restrike
printing enables dot matrix printers to type each character multiple times
on the same page.

Print only with Uppercase Characters: Prints all alphabetic characters in
uppercase. (IBM 3812 printer switch = c08.)
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Suppress Initial Form Feed: Instructs the printer to disregard the first
form feed command that it receives with the print job.

Wrap Text at Right Margin: Continues words that exceed the line length
onto the next line.

The Settings - 3270 Printer Margins Page

Use the 3270 Printer Margins page to configure the printable area of the
page. The Margins page provides a Margin Preview, which displays the
general page layout, margin size selections, and page orientation choices
(standard, host defined, COR, or compressed).

The Settings - 3270 Printer Margins page

Margin Preview: Displays image of sample page with the defined
orientation, margins, and line spacing.

Margins (inches) or (cm): Displays margin selections.

Top: Defines the size of the printing area at the top of the page.

Bottom: Defines the size of the printing area at the bottom of the
page.

Set Bottom = Top: Sets the bottom margin size equal to the top
margin size.
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Left: Defines the size of the printing area on the left side of the page.

Right: Defines the size of the printing area on the right side of the
page.

Set Right = Left: Sets the right margin size equal to the left margin
size.

Page Orientation: Defines the page definitions and direction that the
print job will print on the page.

Type: Lists the possible sources of page definitions for the print job.
(IBM 3812 printer switch = c01.)

Rotation: Displays the rotation options.

Portrait: Prints the document in portrait mode.

Landscape: Prints the document in landscape mode.

The Settings - 3270 Printer Fonts Page

Use the 3270 printer Fonts page to configure typeface names, sizes,
character density, and automatic adjustments that EXTRA! makes to the
printed page. Automatic adjustments include using line spacing
adjustments and the insertion of additional character spacing, when
desired.

The Settings - 3270 Printer  Fonts page
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Font Options: Lists the available font choices and sizes.

Font: Lists the available font choices based on your printer selection.
If you have recently changed your printer selection, make sure you
choose the Apply button from the Printer Page to update the font list.

Size: Lists the available font sizes.

Character Density: Defines the density of text on the page.

Number of Characters: Defines the number of characters to set per
line or inch.

Characters Per: Displays the option to set the number of printed
characters to per line or per inch.

Characters Per Line (CPL): Sets the number of printed characters to
characters per line.

Characters Per Inch (CPI): Sets the number of printed characters to
characters per inch.

Adjust Character Spacing: Proportionally increases character
spacing so that text is left and right justified.

Line Density: Defines the density of lines on the page.

Number of Lines: Defines the number of lines per page or inch.

Lines Per: Displays the options to sets the number of printed lines to
per page or per inch.

Lines Per Page (LPP): Sets the number of printed lines to lines per
page.

Lines Per Inch (LPI): Sets the number of printed lines to lines per
inch.

Adjust Line Height: Increases text leading so that the lines of text fit
proportionally between the top and bottom margins of the page.

Use the font that best matches the character and line densities: Instructs
EXTRA! to select a font based on page width, margin width, character
density, and line density.

The Settings - 3270 Printer LU1/LU4 Page

Use the 3270 Printer LU1/LU4 page to configure printer session options
for LU1 datastream printers. These are Host printer types that can
support advanced printing options. The LU1 options instruct EXTRA! in
how to process host printing information contained in LU1 SCS
transparency blocks, in both ASCII and EBCDIC formats.
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The Settings - 3270 Printer LU1/LU4 page

Host Formatting: Establishes EXTRA!’streatment of host control codes.

Ignore Host Formatting Orders: Disregards host control codes.

Honor Host Formatting Orders in Current Job Only: Recognizes
host control codes for the current job only.

Honor Host Formatting and Retain in Subsequent Jobs: Recognizes
host control codes for all jobs.

Ignore Host Setting for MPP and MPL: Disregards host settings for
maximum print position (MPP) and maximum page length (MPL). (IBM
3812 printer switch = c06.)

Ignore Vertical Channel Select (VCS): Disregards incoming Vertical
Channel Select (VCS) codes.

Discard LU1 SCS Transparency Blocks: Discards host print formatting
commands.

Add Blank Page at the End of the Print Job: Prints a blank page after the
print job ends.

Double Space Lines: Formats the print job with double spaced lines.
(IBM 3812 printer switch = c06.)

LU1 [0x35] Transparency Blocks Contain ASCII Data: Allows
embedding of ASCII printer control codes in the host data stream.
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Ignore Form Feeds Encountered in LU1 SCS Transparency Blocks:
Disregards the form feed command in the host print data stream.

Printer Type: Specifies the type of printer emulated by the printer
session. Choose either Laser (IBM 3812) or Dot Matrix (IBM 5224).

Laser: Selects a laser (IBM 3812) printer for the printer session to
emulate.

Dot Matrix: Selects a dot matrix (IBM 5224) printer for the printer
session to emulate.

The Settings - 3270 Printer LU3 Page

Use the 3270 Printer LU3 (DSC/DSE) page to configure printer session
options for LU3 type Host printers. These are Host printer types that
support basic formatting commands. These include page and job
formatting options such as form feed recognition and line feed insertion
into a print job.

The Settings - 3270 Printer LU3 page
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Page Formatting: Sets page settings for LU3 (DSC/DSE) printers.

Automatically Insert a New Line Character at the End of Each Line:
Advances the printer one line when a carriage return occurs after the
maximum print position. The next print position is the current line
plus one, column 1. (IBM 3812 printer switch = c18.)

Double Space Lines: Formats the print job with double space lines.
(IBM 3812 printer switch = c06.)

Ignore Host-Defined Characters per Line Setting (WCC):
Disregards the characters per line setting received from the host.

Print a Blank Line if no Printable Characters Exist in the Line:
Adds a line feed character if no printable characters exist in the line.
(IBM 3812 printer switch = c22.)

Form Feeds are Honored Only if Found in First Column: The first
column of the print job is the only area where form feeds are
recognized. (IBM 3812 printer switch = c23.)

Form Feed Resets Print Position to Top Row, Column Two:
Reinitializes the print position after form feed. (IBM 3812 printer
switch = c20.)

Job Formatting: Sets formatting for LU3 (DSC/DSE) print jobs.

Add a Blank Page at End of the Print Job: Prints a blank page after
the print job. (IBM 3812 printer switch = c16.)

Insert a New Line at the End of the Print Job: Inserts a new line
after the print job. (IBM 3812 printer switch = c21.)

The Settings - 3270 Printer Data Stream Page

Use the 3270 Printer Data Stream page to configure the interpretation of
host printing commands. Hex data translation of printing commands and
print job control options are configurable options.
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The Settings - 3270 Printer Data Stream page

Data Stream Translation: Displays options for handling host printing
instructions.

Substitute ESC for Character: Enables substitution of the standard
host escape character with a user-defined character.

Substitution Character: Lists possible character replacements for the
host escape character.

Enable Hex Passthrough: Switches how EXTRA! processes the data
stream from normal text to hexadecimal conversion.

Trigger: Lists possible characters that signal the beginning and end
of hexadecimal format data in the data stream.

End Print Job On: Ends print job on host unbind signal.

End Bracket: Ends print job on the end bracket that delimits print
data buffers.

End of Media: Ends print job on the end of media.

Form Feed: Ends print job on form feed.

Time Out Value (secs): Specifies the amount of time a printer will
wait for data before aborting a print job.
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Printing from the Host
Using EXTRA! you can print directly to your local printer or to a file
(including an ASCII file). Before printing, you may want to perform the
following actions to verify your setup:

• Make sure that you have at least one Printer Session configured.

• Make sure that you have set the correct print destination.

• Set page layout options to define how the printed page should
appear. For example, you can set font, margins, and line and
character spacing.

• Set the printer time-out, which is the maximum amount of time
EXTRA! will wait for information while it is printing

• Send a form feed to the printer, immediately ejecting the current
page from the printer.

To print to a printer

• From your display session, enter your host print commands.

To view the printer’s status, refer to the Print Status option in the
printer session window. For more information, see “Printer Status”
later in this chapter.

To print to a file

• From your display session, enter the host print commands.

To view the printer’s status, refer to the Print Status option in the
printer session window. For more information, see “Printer Status”
later in this chapter.
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Printer Controls
As EXTRA! prints, you can perform any of the following actions:

Hold Print : Temporarily suspends print jobs in the mainframe’s spooler.
You can use this command to store several print jobs so they can be
printed at one time, or to temporarily halt printing to change page layout
options. Hold print enables the PA1, PA2, Form Feed, Cancel Print, and
Align Form commands. The mainframe suspends all spooled print jobs
until you again choose the Hold Print command.

PA1 and PA2: Sends PA1 and PA2 commands to your mainframe
application. These keys simulate the PA1 and PA2 keys on a 3287 printer
control panel. The functions performed by these keys depend on the
mainframe application from which you are printing. (Some applications
may not support these functions.)

The PA 1 and PA2 commands are available to you if the session is
configured for an LU1 printer resource. To confirm that you are
configured for an LU1 printer resource, choose Session Status from the
View menu of the printer session.

Cancel Print: Cancels a print job at any time if you are configured for an
LU1 printer resource. To confirm that you are configured for an LU1
printer resource, choose Session Status from the View menu of the
printer session.

Form Feed: Sends a Form Feed command to your printer, immediately
ejecting the current page from the printer.

Align Form: Tests the alignment of text on preprinted forms on the
printer. You can specify the text to print and the row and column at
which it should be printed.



Printing

5-19

To hold printing

• From the printer session Control menu, choose Hold Print.

–or–

Choose this  button on the toolbar.

The Job Status field in Print Status will indicate that the printer is on
hold. (A check mark also appears next to the Hold Print command in
the Control menu.)

To send a PA1 or PA2 command

1. From the printer session Control menu, choose Hold Print. (A check
mark appears next to the Hold Print command.)

2. Choose either PA1 or PA2 from the Control menu.

3. Choose Hold Print from the Control menu to bring your session back
on line.

To cancel printing

1. From the printer session Control menu, choose Hold Print. (A check
mark appears next to the Hold Print command.)

2. Choose Cancel Print from the Control menu.

3. Choose Hold Print from the Control menu to bring your session back
on line.

To send a form feed command

1. From the printer session Control menu, choose the Hold Print
command. (A check mark appears next to the Hold Print command.)

2. From the Control menu, choose the Form Feed command.

EXTRA! sends a form feed to the selected printer.

3. To bring your session back online, choose the Hold Print command
from the Control menu.
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The Align Pre-printed Forms Dialog Box

Use the Align Pre-Printed Formsdialog box to help align data from the
host onto pre-printed forms or non-standarded paper sizes. For example,
printing inventory forms or mailing labels.

The Align Pre-printed Forms dialog box remains active until you close it.

The Align Pre-printed Forms dialog box

Refer to the following field descriptions for the Align Pre-printed Forms
dialog box.

Text: Specifies the text that will print as a sample to test your form
alignment settings.

Row: Defines the vertical starting point for the form data (represented by
the sample Text).

Column: Defines the horizontal starting point for the form data
(represented by the sample Text).

Print button: Prints a test page containing your sample Text.

Close button: Closes the Align Pre-printed Forms dialog box. The dialog
box will not close until this button is selected.

To align forms

1. From the printer session Tools menu choose Align Form.

2. Enter the sample text you want printed on the form in the Text field.

3. Enter the row and column values to change the starting point for the
sample text.

4. Choose the Print button.
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Printer Status
From the Printer Session you can access status information about your
print job. Refer to the following sections.

Viewing Session Status
The following information appears in the client area for a 3270 printer
session:

Device Info: Indicates the type of printer resource, for example LU1 or
LU3.

Session State: “Active and not bound” appears when the session was
only activated by the SSCP and BIND has not been received. “Bound”
appears when the BIND is successful and the printer session is ready to
accept print jobs. “Inactive” appears if the printer session has been
deactivated by the SSCP.

Server Info: Displays the server name and server software version.

Resource Name: The LU, or LU pool if your workstation is connected to
the host via a gateway. This field will also display the name for this LU
on the host.

Resource Address: Displays the resource name. Displays the LU number
where applicable.

The following information appears in the client area for a 5250 (AS/400)
printer session:

Device Type: Displays the printer type that the session is emulating.

Device Name: The name of the virtual device that the session is
emulating.

Message Queue: The message queue where printer messages are sent.
The default message queue is contained in library QSYSOPR.

To view session status

• From the printer session View menu choose the Session Status
command.

-or-

Choose the  button on the toolbar.
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Viewing Print Status
The following information appears in the client area for a 3270 printer
session:

Job Status: Displays the state of your local printer. The states include:
Idle, Printer Inactive, Printing in progress, Print job on hold, and Print
Job in error.

Pages Printed: Displays the number of pages printed.

Printer Name: Displays the name of the printer and printer port the
session is using.

Driver Name: Displays the name of the printer driver the session is
using.

Output Name: The name of the port for a printer or the name of the file
for file output. If the printer is a network printer, the printer name is
repeated in this field.

The following information appears in the client area for a 5250 (AS/400)
printer session:

Job Status: Displays the state of your local printer: Not Started, Running,
or On Hold.

Pages Printed: Displays the number of pages printed.

Printer Name: Displays the name of the printer the session is using.

Driver Name: Displays the name of the printer driver the session is
using.

To view print status

• From the printer session View menu choose the Print Status
command.

-or-

Choose the  button on the toolbar.
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Printing a Screen
The Print Screen feature prints an image of the display screen to the
printer specified in the Print Screen dialog box. You can print the whole
image, even if it is not all currently displayed in the display window.

Refer to the following sections on setting options for printing the screen
image.

The Print Settings Dialog Box

Using the Print Settings dialog box, you can configure various page set-
up options such as page orientation, and margins and you can assign a
document name as well as header and footer information.

The Print Settings dialog box
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Refer to the following field descriptions for the Print Settings dialog box.

Preview: Shows how the page layout will look. As you change the
options, the page layout example changes.

Orientation - Portrait or Landscape: Specifies how the document is
positioned on the page. Portrait orients the paper vertically. Landscape
rotates the paper 90 degrees clockwise.

Left Margin: Defines the distance between the left edge of the page and
the left end of each line, in inches.

Top Margin: Defines the distance between the top of the page and the
top of the first line on the page, in inches.

Right Margin: Defines the distance between the right edge of the page
and the right end of each line, in inches.

Bottom  Margin: Defines the distance between the bottom of the page
and the bottom of the last line on the page, in inches.

Document Title: Specifies a “title” for the document you are going to
print. The header and footer text appears just outside of the pages
margins. You can type text for the header and footer, or used the &F
variable to include the document filename in either the header or footer.

Header Text: Specifies the text that will appear in the header of the
printed document (up to 80 characters). This header appears one line
above the top margin. If you do not want to use a header, delete the
default values.

Footer Text: Specifies the text that will appear in the footer of the printed
document (up to 80 characters). This footer appears one line below the
bottom margin. If you do not want to use a footer, delete the default
values.

Font: Selects the font for the header or footer text. You can also change
font styles such as bold, italic, or bold and italic.

To configure page setup

1. From the display session File menu choose Print Settings.

2. Complete the Print Settings dialog box.

For information about a specific field in this dialog box, refer to the
field descriptions listed previously in this section.
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To specify the print orientation

1. From the display session File menu choose the Printer Settings
option.

2. In the Orientation group box, select the option that indicates how the
document should be positioned on the page.

As you select each option, the sample at the top of the dialog box
changes to show how the orientation affects the page layout.

To specify the printing margins

1. From the display session File menu choose Printer Settings.

2. In the left, right, top, and bottom boxes, select the number of inches
or centimeters from the edges of the paper where printing should not
occur.

As you select these numbers, the sample in the middle of the dialog
box changes to show how the changes affect the page layout.

To specify the document name for the printed header or footer

1. From the display session File menu choose Printer Settings.

2. Enter a name in the Document Title text box.

You can use the &F variable in both the Header or Footer text boxes, to
have the title you typed appear on the page.
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To specify the printed header

1. From the display session File menu choose Printer Settings.

2. In the Header text box, type the information that you want to appear
in the header of the printed document (up to 80 characters).

This header appears one line above the top margin. If you do not
want to use a header, delete the default values. You can also use
these variables:

To print Type

The page number 	4

The document name (as specified in
the Document Name text box)

	*

The date 	(

The time 	8

To specify the printed footer

1. From the display session File menu choose Printer Settings.

2. In the Footer text box, type the information that you want to appear
in the footer of the printed document (up to 80 characters).

This footer appears one line below the bottom margin. If you do not
want to use a footer, delete the default values. You can also use these
variables:

To print Type

The page number 	4

The document name (as specified in
the Document Name text box)

	*

The date 	(

The time 	8
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To choose the print font

1. From the display session File menu choose Print Screen.

2. Choose the Font button.

3. Complete the Font dialog box.

The Print Screen Dialog Box

Using the Print Screen dialog box, you can configure various printing
options, such as the printer to print to and the number of copies to print.
You can also select the destination for the print job.

The Print Screen dialog box
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Refer to the following field descriptions for the Print Screen dialog box.

Destination: Select the destination for the print job. You can send it to
either a printer or to a file.

Printer: Sends the data to a printer instead of a file.

File: Sends the data to a file instead of a printer.

Printer Settings: Allows you to choose printer options if you chose to
send your file to the printer rather than to file.

Properties: Choose this button to set up options for this printer. The
options available depend on the features of the printer.

Enable the Cancel Print Operation: Displays the Cancel Print Screen
dialog box while printing is in progress. This enables you to stop a
print job before it has completed. You can select this option only if
you have chosen to print to file.

Reverse Black and White for Graphics Printing: Prints black areas
of the image as white, and white areas as black. (Useful when the
host display is white text on a black background.)

File Settings: Allows you to choose options if you chose to send your file
to print.

File Name: Enter the name of the file you want to print to file.

Browse button: Choose this button to select an existing file if you
chose to print or append the data to a file.

Replace File: Replaces data. The new data will overwrite any
existing data in the file.

Append to File: Adds the data to the end of any existing data in the
file.

Display File Dialog: Displays the File Open dialog box when you
choose the Print Screen command from the toolbar.
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Host Screens: Specify how many host screens you want to print per
page. From the display session file menu you can choose Print Multiple
Screens to create a queue of host screens and send them to the printer at
one time. This field only displays if the Print Multiple Screens command
has been selected.

Host Screens Per Page: Specify the number of host screens that at
most will print per page. From the display session file menu you can
choose Print Multiple Screens to create a queue of host screens and
send them to the printer at one time. . This field only displays if the
Print Multiple Screens command has been selected.

Copies: Specify the number of copies to print.

Number of copies: Specify the number of copies to print.

Print Settings: Choose this button to configure more printing options.
Refer to the Print Settings Dialog Box section for more information.

To print a screen

1. From the display session File menu choose Print Screen.

2. Choose the destination Printer and complete the Print Settings
section of the dialog box.

For information about a specific field in this dialog box, refer to the
field descriptions listed previously in this section.

To configure the print screen options for the current printer

1. From the display session File menu choose Print Screen.

2. Choose the destination Printer and complete the Print Settings
section of the dialog box.

For information about a specific field in this dialog box, refer to the
field descriptions listed previously in this section.

To print the screen to a file

1. From the display session File menu choose Print Screen.

2. Choose File as the destination.

3. Select Replace File to overwrite any existing data in the specified file
with new data.

–or–

Select Append to File to add the new data to the end of any existing
data in the specified file.
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To configure print settings options

1. From the display session File menu choose Print Screen.

2. Choose the Print Settings button.

3. Complete the Print Settings information.

For information about a specific field in this dialog box, refer to the
field descriptions listed previously in this section.

To display the Cancel Print dialog box during printing

1. From the display session File menu, choose Print Screen.

2. Choose Enable the cancel print operation to display the Cancel Print
dialog box while printing is in progress.

Note: You can select this option only if you are printing to a file and
the destination File is selected.

Printing Multiple Screens

Using the Print Multiple Screens dialog box, you can create a queue of
host screens and send them to the printer at one time.

The Print Multiple Screens dialog box
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To print multiple screens

1. From the display session file menu, choose Print Multiple Screens.

2. Go to the first screen you want to print.

3. Choose the capture button (in the top left corner of the dialog box.)
The first line of the screen displays in the window.

4. Go to the next screen you want to print and select the capture button
again.

5. Continue until all host screens that you want to print are shown in
the window.

6. Choose the Print button.

Note: The option Host Screens Per Page which appears on the Print
Screen Dialog Box allows you to specify how many host screens you
want to print per page.

Printer Session Troubleshooting
This section describes how you can recognize and solve some of the most
common problems you may encounter when printing. If you cannot
locate your particular problem in this list or if the remedies presented
here do not eliminate your problem, contact your system administrator
or call our Customer Support department.

Refer to the following sections to solve some common printing issues.
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If You Can’t Print From the Host
Check for the following conditions if you cannot print from the host.

• Is the host resource you are using defined as a printer resource at
the host?

If it isn’t, either reconfigure the session for a different resource, or
have your system administrator change the resource at the host to a
printer resource.

Choose Session Status from the View menu. Make sure you are using
the correct resource and session profile. If you find an error,
reconfigure EXTRA!. Also check to see that the host has sent a Bind
ID to EXTRA!. If there is no Bind ID, contact your system
administrator and find out if the host’s printing application is
running.

• Is the host resource active and not in use?

If the resource is inactive or already in use, reconfigure EXTRA! for a
different resource.

• Is the printer online?

If your printer is offline, or, if your printer is on a network, an “off-
line” message may indicate that the network is down.

• Is your printer an active Windows printer?

Open the Windows Print Manager and see if your printer is listed.
For information on using the Print Manager, refer to your Microsoft
Windows User’s Guide.

• Has Windows been set up to print?

There are several ways to check to see if Windows is configured for
printing. Try any of the following tests to see if Windows is sending
the job to your printer.

• Try to print using the Windows Notepad.

• Try to print one of the Windows online Help topics.

No matter which test you choose, you should be able to track the
print job in the Microsoft Windows Print Manager. The Print
Manager displays each print job as it is received. It tells you if the job
is spooled, or if it has been sent to the printer.



Printing

5-33

The Printed Page Looks Incorrect
Check for the following conditions if the text on your printed page does
not look quite right.

Your output is missing tab settings or other formatting options.

Choose Session Status from the View menu and make sure the LU type is
correct. More than likely, this should be an LU1 resource. LU1 host
printers support a wider variety of format options than LU3 printers.

If it is not the correct LU type, either select a different session or
reconfigure the current session for the correct resource.

EXTRA! is not formatting the output correctly.

Check to ensure that the output settings are configured correctly by
checking the Printer Settings. For information on Printer Settings and
how to view them, refer to the Printer Settings section previously in this
chapter.

The Printer Stops before the Job is Completed
The printer time-out value may be set for too short a period of time. To
change the printer time-out setting, refer to “Printer Settings - The Data
Stream Page” earlier in this chapter.

Formatting Print Output
EXTRA! provides two methods for formatting print output: emulation of
SCS (IBM’s SNA Control Set) orders, and emulation of the Hewlett-
Packard PCL5 printer control language. SCS is the control set used in
Logical Unit 1 (LU1) printing. Minimal formatting (newline and form
feed) is defined by IBM for LU3 printing.

In addition to full support of the IBM control sets for each of these LU
types, EXTRA! supports emulation of PCL5 in all three LU types. PCL5 is
the printer control language used by Hewlett-Packard in their popular
LaserJet and InkJet printers. Many other printer vendors emulate PCL5
in their printers. EXTRA! emulates PCL5 by recognizing PCL commands
within the print stream and making the equivalent series of calls to the
Windows GDI (Graphics Device Interface) service. This means that you
can use PCL commands to format output even on printers which do not
have built-in support for PCL (because Windows transforms the GDI
calls into the appropriate commands for those printers).
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On rare occasions, you may need more specialized control over
formatting. You may wish to use capabilities of a specific printer (such as
a Postscript printer) which are not available in SCS nor in PCL. Or you
may want to suppress all output formatting entirely. For example, you
might want to “print” to a disk file which will become input to another
program, such as a database.

EXTRA! offers the Raw Output Mode option for this purpose. In Raw
Output Mode, the print datastream from the host is translated from
EBCDIC to ASCII, SCS formatting controls are stripped from the stream,
and the resulting ASCII stream is copied directly to the printer or disk
file. Most of the EXTRA! processing is skipped, and the Windows GDI
and printing system is bypassed entirely. Formatting control sequences
in the print data (if any) are performed by the printer itself. This provides
complete access to the print device’s capabilities.

Printer Emulation in the Windows Environment
Unlike DOS host applications, emulating a printer in the Windows
environment presents a special challenge. Windows expects you to
perform positioning, line and box drawing, and other formatting
operations through the Windows Graphics Device Interface (GDI),
instead of using the traditional text stream with embedded formatting
control codes employed by DOS.

EXTRA! provides two ways to perform formatting:

GDI Mode intercepts SCS and PCL5 commands within the host print
datastream (either embedded in text, or within LU1 SCS transparency
blocks) and emulates them through the Windows GDI. Because EXTRA!
emulates PCL commands by transforming them into GDI service calls,
PCL commands can be “performed” on any Windows graphics printer,
whether it has built-in support for PCL or not.

Raw Output Mode bypasses the Windows GDI altogether. Formatting
commands in the printer’s “native” command language (whether
embedded in text or placed in LU1 transparency blocks) are sent directly
to the printer. EXTRA! discards standard SCS controls for Raw Output
Mode. Raw Output Mode can be used with any manufacturer’s printer.
Typical uses for Raw Output Mode include printing to Postscript or other
non-PCL printers, and creating text files for input to other PC programs
such as databases.
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To set up Windows for GDI or Raw Output Modes

1. From the printer session Options Menu, choose Settings.

–or–

Choose the   button from the toolbar.

The Settings - Connection dialog box appears.

2. Choose the OK button to save your changes and close the printer
settings dialog box.

–or–

Choose the Apply button if you wish to save your changes and
continue to configure printer settings.

Transparency Block Configurations
LU1

For LU1 sessions, EXTRA! supports three transparency-block formats
containing ASCII data.

The following figure shows the SCS transparency block configuration
defined by IBM. This applies to LU1 sessions only—LU3 and LU4 do not
define a “transparency block” control.

The first is the standard IBM transparency block. In an LU1 session, each
transparency block must be preceded by a 2-byte header containing
either hexadecimal code 0x35 or 0x36, and a character count.

0x35 indicates that the data block is in EBCDIC, the native IBM host
character set. EXTRA! will translate the block to ASCII before sending it
to the printer.

0x36 is an Attachmate extension to the LU1 SCS control set, which
indicates that a block contains ASCII data. EXTRA! does not perform
translation.

A second format, specific to EXTRA! and configured in the LU1 page of
Printer settings, allows you to indicate that transparency blocks

Header Character
Count Data

254 Bytes (or less)2 Bytes

(text and/or printer-native
formatting controls)

(0x35 or 0x36)
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beginning with 0x35 contain ASCII data rather than EBCDIC. If selected,
this option will apply to all transparency blocks in all print jobs run by
the session.

The third format, also defined by IBM, created an extension to its SCS
controls that has a three-byte header:

Header Character
Count Data

255 Bytes (or less)

(text and/or printer-native
formatting controls)(35)

Header
(2B)

3 Bytes

ASCII

In Raw Mode, the data block is sent directly to the print device. In GDI
Mode, the data block is broken down and interpreted through the
Windows Graphics Device Interface. In GDI mode, all formatting within
transparency blocks must be done with PCL printer commands. (In raw
mode, you would use commands native to your printer instead.) EXTRA!
versions 5.x and earlier required that a PCL command be completed
within the transparency block in which it starts. In EXTRA!, a PCL
command may start within one transparency block and complete in a
subsequent block.

LU3 and LU4

LU3 does not support SCS. PCL commands may be embedded directly
into the text stream to perform formatting in LU3. You can also put PCL
commands in the text stream in LU1 as well.

To configure [0x35] transparency blocks in EXTRA!

1. From the printer session Options menu, choose Settings.

–or–

Choose the   button from the toolbar.

The Settings - Connection dialog box appears.

2. Select the Printer Category.

3. Select the LU1 tab.

The LU1 printer settings dialog box appears.
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4. Select LU1 [0x35] transparency blocks contain ASCII data.

Choose the OK button to save your changes and close the printer
settings dialog box.

–or–

Choose the Apply button if you wish to save your changes and
continue to configure printer settings.

Hex Passthrough Blocks

To enable hex passthrough blocks

1. From the printer session Options menu, choose the Settings
command.

–or–

Choose the   button from the toolbar.

The Settings - Connection dialog box appears.

2. Select the Printer Category.

3. Choose the Data Stream tab.

The Data Stream printer settings dialog box appears.

4. Select the Enable Hex Passthrough option.

5. Select the appropriate Trigger signature from the drop-down list.

EXTRA! supports an alternative method for embedding “transparency”
data within a text stream, called hex passthrough. A one- or two-
character user-selected “trigger signature” switches the EXTRA!
processing of the datastream from normal text to hexadecimal
conversion. Hex blocks consist of a combination of hexadecimal digits
and spaces. The trigger signature character is not printed in the output. It
simply signals that the job is entering hex passthrough mode, and then
the signature character is discarded. Hex passthrough blocks may be
embedded in LU1, and LU3 print streams.

You may select the appropriate trigger from the EXTRA! Data Stream
settings dialog.
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6. Choose the OK button to save your changes and close the printer
settings dialog box.

–or–

Choose the Apply button if you want to save your changes and
continue to other configure printer settings.

Hex Passthrough Trigger Signatures

You can enable the processing of hexadecimal characters in mid-data
stream by defining a trigger character and choosing the Enable Hex
Passthrough option.

Once EXTRA! “sees” the start trigger character, it expects the following
text to consist only of hexadecimal digits (0-9, A-F) and optional spaces.
Hex passthrough processing stops when EXTRA! “sees” a non-hex
character. This non-hex character is then stripped out of the data stream,
and processing of the data stream returns to normal text. One exception
to this is the “double-percent” (%%)trigger character used specifically for
the Tangram Arbiter product. In the event that %% is used for the start
and termination trigger character, then both %% termination characters
will be discarded from the beginning and end of the hex block. If any
other single non-hex, non-%% termination character is encountered, only
that single termination character will be discarded from the end of the
hex block.

Hex Passthrough Processing Examples

The following four examples demonstrate  various processing scenarios
of hex passthrough blocks embedded within text streams.

%% as Start and End trigger

This EBCDIC input

*SYVWGSVI�ERH��������������]IEVW�EKS

Results in this ASCII output

*SYVWGSVI�ERH�����]IEVW�EKS

This example uses the Arbiter-specific “double-percent” as both start and
end trigger characters. The “%%” characters are stripped from the
beginning of the hex block, and hex conversion proceeds until the non-
hex “%%” characters are encountered at the end of the block. Both “%%”
characters are then stripped from the data stream, and processing returns
to normal text.
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Hex 40 is an ASCII [space]. Hex 31, 32, and 33 are ASCII characters ‘1’,
‘2’, and ‘3’, respectively. No further translation is completed.

%% as Start trigger only

This EBCDIC input

*SYVWGSVI�ERH������������	]IEVW

Results in this ASCII output

*SYVWGSVI�ERH�����]IEVW�EKS

This example uses the Arbiter-specific “double-percent” character as the
start trigger. The “%%” characters are stripped from the beginning of the
hex block, and hex conversion proceeds until a non-hex character (&) is
encountered, and that non-hex character is stripped from the data
stream. Processing then returns to normal text.

Hex 40 is an ASCII [space]. Hex 31, 32, and 33 are ASCII characters ‘1’,
‘2’, and ‘3’, respectively. No further translation is completed.

Start trigger only used

This EBCDIC input

*SYVWGSVI�ERH$����������]IEVW�EKS

Results in this ASCII output

*SYVWGSVI�ERH�����]IEVW�EKS

This example demonstrates processing when a start trigger character (@)
is encountered at the beginning of the block, but no trigger character is
inserted at the end of the block. The start trigger character is stripped
from the data stream, and hex conversion proceeds until a non-hex
character is encountered. That non-hex character is stripped from the
data stream. Without the insertion of a non-hex end trigger character into
the block, a valid data character is stripped out of the print data stream.

Hex 40 is an ASCII [space]. Hex 31, 32, and 33 are ASCII characters ‘1’,
‘2’, and ‘3’, respectively. No further translation is completed.
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Start and End trigger used

This EBCDIC input

*SYVWGSVI�ERH$����������B]IEVW�EKS

Results in this ASCII output

*SYVWGSVI�ERH�����]IEVW�EKS

This example demonstrates processing when a start trigger character
(@)is encountered at the beginning of the block, and a single non-hex
character is inserted into the data stream as the end trigger character. The
start trigger character is stripped from the data stream, and hex
conversion continues until the non-hex trigger character (^) is
encountered. The non-hex end trigger character is stripped from the data
stream, and processing returns to normal text.

Hex 40 is an ASCII [space]. Hex 31, 32, and 33 are ASCII characters ‘1’,
‘2’, ‘3’, respectively. No further translation is completed.

The Hex Passthrough Data Stream - Byte Values and Spaces

Byte Values

One or two hex digits represent a byte. If two digits are available,
EXTRA! assumes that both contribute to the byte’s value. If only one is
available, it is considered to be the low-order value of the byte. For
example,

���������

converts to three bytes �?��A�?��A�?��A�HIGMQEP�

Spaces

?7TEGIWA are skipped within a hex block. This assists in debugging
binary values by making them more readable. A [space] does not
contribute to a byte’s value, but it does terminate a byte value. That is,

�������

is read as two bytes ?��A�?��A rather than as a single�?��A�

Note: Because the host sees the hex passthrough block as “normal text,”
and is written in the native character set of the host, you should not write
hex values using ASCII characters.
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Deciding Between GDI and Raw Output Mode
There are several factors to take into consideration when determining
which printing mode to use. This section further defines GDI Mode and
Raw Output Mode, and describes the advantages and disadvantages
associated with both.

GDI Mode

In GDI mode, EXTRA! scans the text stream and transparency blocks for
supported PCL5 page description language commands, and then
simulates those PCL5 commands using GDI calls. You can use PCL5
control codes to switch between fonts, apply type styles (such as bold
and italic), draw lines and boxes, shade rectangular areas, move
anywhere on the page, and so forth.

GDI Mode gives your host application access to all fonts available under
Windows. These include fonts built into your laser printer, and Windows
system and “soft” fonts such as TrueType, Adobe Type Manager,
Bitstream Facelift, and other third-party font engines. Refer to the section
“Font Support Within Transparency Blocks” for additional information.

The emulation provided by EXTRA! supports a large subset of of the
PCL5 language, but not the complete language. PCL commands which
create downloadable soft fonts or draw bitmaps are not supported. Also,
EXTRA! does not emulate the HP-GL/2 vector drawing language. If your
print job contains such items, you must select Raw Output Mode and
configure the job accordingly.

Raw Output Mode

Raw Output Mode bypasses the Windows GDI altogether; an entire print
job is sent directly to the printer or to a disk file.

Raw Output Mode will accommodate any printer, page description
language, or printer-control syntax. It also allows you to generate an
output file or page which contains no printer commands whatsoever, not
even the initialization “setup” automatically generated by most Windows
printer device drivers.
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Disadvantages

Any formatting done in Raw Output Mode must be specified in native
printer commands embedded in the text stream or within LU1
transparency blocks. Formatting SCS controls in LU1 and LU4 jobs (such
as Set Vertical Format, Presentation Position and so on) are discarded in
Raw Output Mode, since EXTRA! has no way of knowing what native
printer commands they could be translated into.

EXTRA! does not track the number of lines and pages printed. The only
progress indication given is a message showing that the job is still bound
to the host application.

SCS and PCL Coordinate System Differences
SCS and PCL use different page coordinate systems. These differences
must be taken into consideration when using GDI Mode. As shown in the
figure on the next page, PCL uses a coordinate system with an origin of
0,0 which is located at the intersection of the left edge of the logical page
and the PCL top margin (usually below the top edge of the logical and
physical page). Numbering increases down and to the right from the
origin. SCS, on the other hand, considers the logical page to be a grid of
rows and columns. The origin cell is row 1, column 1, and is located at
the upper left corner of the physical page.

SCS and PCL coordinates

perf-skip area 1/2"

left logical page edge

left margin

top margin

(gray area is logical page)

right logical page edge

<

>

<

SCS(1,1)

PCL(0,0) character cell baseline
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It is important to note that SCS row 1 is NOT located immediately below
the PCL top margin (PCL row 0). For example, with the default three-line
PCL top margin, SCS row 1 corresponds to PCL row -3. When the top
margin is changed (using SCS Set Vertical Format or PCL Set Top
Margin) or when the height of a row is changed (SCS Set Line Density or
PCL Set Vertical Motion Index), the correspondence between SCS row
numbering and PCL row numbering will also change.

Note: While EXTRA! converts between SCS and PCL movements as
accurately as possible, generally it is easier to design a document using
one command set exclusively. Mixing SCS and PCL commands is
supported but can lead to unexpected results, because of differences in
the two coordinate systems.

Font Support within Transparency PCL Blocks
PCL enables you to select the characteristics for a desired font by sending
a series of commands that specify each of the characteristics. For instance,
to select as the primary PCL font, a non-proportional, bold, 12-point
Courier font with 10-character-per-inch pitch, upright style, using the
normal Roman-8 character set, you would send the sequence:

[ESC](8U[ESC](s0P[ESC](s10H[ESC](s12v[ESC](s0S[ESC](s3B[ESC](s3T

where

?)7'A��9 specifies the Roman-8 symbol set
?)7'A�W�4 specifies fixed spacing
?)7'A�W��, specifies 10 characters per inch
?)7'A�W��Z specifies 12-point height
?)7'A�W�7 specifies upright style
?)7'A�W�& specifies bold weight
?)7'A�W�8 specifies the Courier typeface family

Note: PCL will accept a partial font description; the omitted portions are
carried over from the previous font selection. THIS CAN LEAD TO
UNEXPECTED RESULTS AND IS NOT RECOMMENDED. As a rule,
you should specify all of the characteristics when selecting a new font.
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Specifying a Windows Scaleable Font
Windows scaleable fonts include the TrueType fonts introduced in
Windows 3.1. Fonts provided by many third-party font engines such as
Adobe Type Manager and Bitstream Facelift are scaleable, as are some of
the standard LaserJet fonts (like CG Times and Univers) and certain fonts
available on ROM cartridges. For these scaleable fonts, Windows may be
able to change the “aspect ratio” (the normal height-to-width relationship
of the characters). As a result, some scaleable fonts can be used with an
unusually large or small number of characters per inch by stretching or
squeezing the image of each character horizontally.

Because this stretching and squeezing can make a scaleable font less
attractive, the EXTRA! GDI Mode lets you specify a pitch of “zero
characters per inch” using the command ?)7'A�W�,. This special value
is a signal to the font selection algorithm that the height and quality of
the font is more significant than the width of the characters. Windows
will then select a font based on height alone and calculate an appropriate
width to ensure that the character images do not appear distorted.

Enabling Fonts for GDI Mode
The EXTRA! printer settings Fonts page provides default font choices.
These are all fixed-space fonts corresponding to the original IBM concept
for LU1 and LU3 printing on a rectangular grid of rows and columns.
Because GDI Mode allows you to use all fonts available in Windows, you
must tell the PCL algorithm how to choose them.

Windows and PCL both use numeric parameters to specify a font’s size,
width, stroke weight and other characteristics. However, Windows and
PCL use very different methods to identify the name of the typeface, and
to specify what character glyphs can be printed in the font (its symbol
set).

Windows identifies a typeface by the string naming it. PCL assigns to the
typeface a number that identifies both the typeface base value and the
face’s vendor.

Note: A vendor is a company, such as Linotype Co., Adobe Systems, or
AGFA, that creates typefaces and licenses their use. Their versions of a
common face such as Times Roman have the same base value, but
different vendor codes.
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PCL also specifies one or more symbol sets that can be printed in a given
font. The most common, Roman-8, includes the letters, numbers and
punctuation used for English text. More exotic symbol sets can print
languages such as Cyrillic (Russian), Thai, or Arabic, line-drawing
characters, special symbols for chemistry, mathematics and other
sciences, bar-codes, or decorative glyphs such as “dingbats.” Windows
supports only five symbol sets—ANSI, Windows, Symbols (math and
decoratives), Shift-JIS (Japanese), and “OEM” which is defined by the
vendor or original equipment manufacturer. Each Windows font is
assigned exactly one of these sets.

Note: All fonts on the Windows printer are available to EXTRA! print
jobs. However, EXTRA! has no way to equate the name by which
Windows knows a typeface with the number which PCL uses to refer to
it. EXTRA! will ignore a PCL face specification and choose a font based
on the other specified characteristics (character height, width, weight,
style, and so on). This can easily result in selection of an “incorrect” font,
if it matches those other characteristics.

To select a default font in EXTRA!

1. From the printer session Options menu, choose the Settings
command.

–or–

Choose the   button from the toolbar.

The Settings - Connection dialog box appears.

2. Select the Printer Category.

3. Choose the Fonts tab.

The Fonts dialog box appears.

4. In the Font Options group, select the Use PC Font Setting option.

5. Choose a font type from the Font List.

6. (Optional.) Select a font size from the Size list.

7. Choose the OK button to save your changes and close the printer
settings dialog box.

–or–

Choose the Apply button if you wish to save your changes and
continue to configure printer settings.
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SCS and PCL5 Printer Control Sequences
The following tables list the SCS and PCL5 printer controls that are
supported in EXTRA! using GDI Mode. Substitute the appropriate
numeric parameter string for the # sign. Numeric parameter strings can
include a leading plus or minus sign, any number of decimal digits, and
an optional decimal point and fraction. The numeric parameter string can
also be empty.

Refer to the following Hewlett-Packard publications for additional
information:

PCL 5 Printing Language Technical Reference Manual
Hewlett-Packard Part Number 33459-90903
PCL 5 Comparison Guide
Hewlett-Packard Part Number 33481-90968

Supported SCS Control Sequences

Function Code Description Comment

BEL 0x2F Bell Ignored by EXTRA!

CR 0x0D Carriage
return

FF 0x0C Form-feed

GE 0x08
+

Graphic
Escape

Prints a hyphen, followed by
the next byte treated as an
ASCII character

HT 0x05 Horizontal
tab

IRS 0x1E Interchange
record
separator

Treated like NL

LF 0x25 Line feed

NL 0x15 New line

NUL 0x00 Null Ignored by EXTRA!

Note: A plus sign indicates a multi-byte sequence.
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Function Code Description Comment

RFF 0x3A Required
form feed

Treated like FF

RNL 0x06 Required new
line

Treated like NL

SA 0x28
+

Set attribute Subfunctions enable/disable
underlining and select
standard fonts

SHF 0x2B
+

Set horizontal
format

Sets left and right margins and
tabstops

SLD 0x2B
+

Set line
density

SPD 0x2B
+

Set print
density

SVF 0x2B
+

Set vertical
format

Sets top and bottom margins
and vertical tabstops

TRN 0x35 Transparency Begins a transparency block
with EBCDIC-to-ASCII
translation — block may
contain both text and PCL5
commands (which will be
emulated)

ATRN 0x36 Absolute
transparency

Begins an untranslated
transparency block

VT 0x0B Vertical tab

Note: A plus sign indicates a multi-byte sequence.
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Supported PCL5 Control Sequences

Note the following:

• [ESC] represents the ASCII escape character (hexadecimal 1B).

• In codes containing an ampersand (&), the character following the
ampersand is almost always a lowercase alphabetic character. Be
careful not to mistake a lowercase L (l) for the numeral one (1).

Supported PCL5 Font Selection and Characteristics Control Sequences

Code Description Comment

[ESC]&a#P Print direction

[ESC]&l#0 Page orientation

[ESC]&d#D Enable underline

[ESC]&d@ Disable underline

[ESC](3@ Select primary font as
default*

[ESC](s#B Primary font stroke
weight*

[ESC](s#H Primary font pitch*

[ESC]&k#S Primary font pitch
mode*

Defaults to pica, elite,
compressed

[ESC](s#P Primary font spacing*

[ESC](s#S Primary font style*

[ESC](s#T Primary font typeface
family*

[ESC](s#V Primary font height*

[ESC]([font_
ID])

Primary font symbol
set*

Provides support for
special fonts (like bar-
codes, for example)

* For secondary font, substitute ) for ( in code sequence. For example, [ESC] )3@ selects the
secondary font as the default instead of the primary.
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Supported PCL5 Positioning Control Sequences

Code Description Comment

[ESC]&l#A Page size (type of
paper)

For example, letter, legal,
A4, Executive

[ESC]&k#H Horizontal motion
index

Sets column size

[ESC]&l#C Vertical motion index Sets row size

[ESC]&a#C Horizontal cursor
positioning (measured
in columns)

[ESC]*p#X Horizontal cursor
positioning (measured
in pixels)*

[ESC]&a#H Horizontal cursor
positioning (measured
in decipoints)*

[ESC]&a#R Vertical cursor
positioning (measured
in rows)*

[ESC]*p#Y Vertical cursor
positioning (measured
in pixels)*

[ESC]&a#V Vertical cursor
positioning (measured
in decipoints)*

* Hewlett-Packard LaserJets can position by pixels (300 pixels to an inch), decipoints (720
decipoints to an inch), or rows and columns (as set by the horizontal motion index and the
vertical motion index). The actual position is rounded to the nearest pixel.
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Code Description Comment

[ESC]&f#S Push/pop cursor
position

[ESC]&l#D Line spacing

[ESC]&= Half-line feed

[ESC]&l#E Top margin

[ESC]&l#F Text length

[ESC]&a#L Left margin

[ESC]&a#M Right margin

[ESC]9 Clear horizontal
margins

* Hewlett-Packard LaserJets can position by pixels (300 pixels to an inch), decipoints (720
decipoints to an inch), or rows and columns (as set by the horizontal motion index and the
vertical motion index). The actual position is rounded to the nearest pixel.
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Supported PCL5 Rectangle Management Control Sequences

Code Description Comment

[ESC]*c#A Horizontal rectangle
size (measured in
pixels)*

[ESC]*c#H Horizontal rectangle
size (measured in
decipoints)*

[ESC]*c#B Vertical rectangle size
(measured in pixels)*

[ESC]*c#V Vertical rectangle size
(measured in
decipoints)*

[ESC]*v#T Select current pattern User-defined patterns or
transparencies not
permitted — standard
patterns only

[ESC]*c#G Area fill pattern ID

[ESC]*c#P Fill rectangular area

[ESC]*v#N Source transparency
mode

Affects how background
and foreground combine

[ESC]*v#O Pattern transparency
mode

Affects how background
and foreground combine

* Hewlett-Packard LaserJets can position by pixels (300 pixels to an inch), decipoints (720
decipoints to an inch), or rows and columns (as set by the horizontal motion index and the
vertical motion index). The actual position is rounded to the nearest pixel.
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Supported PCL5 Job/Paper Control Sequences

Code Description Comment

[ESC]&l#X Number of copies Refers to number of copies
of each page (does not
collate)

[ESC]&l#H Paper source For example, upper or
lower tray, envelope

[ESC]&l#G Paper destination Refers to the upper output
bin

[ESC]&l#L Perforation skip Controls whether text and
graphics are clipped or
printed at the top and
bottom edges of the
physical page

Supported PCL5 Simplex/Duplex Printing

Code Description Comment

[ESC]&l#S Simplex/duplex printing Double-sided printing
(Laserjet IID and IIID
only)

Supported Miscellaneous PCL5 Control Sequences

Code Description Comment

[ESC]
&l#P

Page length

[ESC]
&s#C

End-of-line wrap always
disabled; text past end-of-
line is truncated

[ESC]E Printer reset
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Unsupported PCL5 Command Sequences

The following controls sequences are ignored during GDI Mode. If such
control sequences are required, use Raw Output Mode.

Unsupported PCL5 Raster (Bitmap) Graphics Control Sequences

Code Description Comment

[ESC]
*r#A

Start raster graphics Functionally identical to
Windows bitmap graphics
operations

[ESC] *r#F Raster graphics
presentation

[ESC] *t#R Raster graphics
resolution

[ESC] *r#T Raster height

[ESC] *r#S Raster width

[ESC]
*b#Y

Raster Y offset

[ESC]
*b#M

Set compression mode

[ESC]
*b#W

Transfer raster data

[ESC] *rB End raster graphics
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Unsupported PCL5 Rectangle Management Control Sequences

Code Description

[ESC] c#W User-defined pattern

[ESC] c#Q User-defined pattern control

[ESC] p#R Set pattern reference point

Unsupported PCL5 Soft Font Management Control Sequences

Code Description

[ESC] *c#D Assign font ID

[ESC] *c#E Character code

[ESC] *c#F Font control

[ESC] (s#W Character descriptor and data

[ESC] )s#W Font descriptor

[ESC] *c#R Set symbol set

[ESC] (f#W Define symbol set

[ESC] *c#S Symbol set control
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Unsupported Miscellaneous PCL5 Control Sequences

Code Description Comment

[ESC]&l#U Left (long-edge) offset Measured in decipoints

[ESC]&l#Z Right (short edge)
registration

[ESC] &f#X Macro control

[ESC] &f#Y Assign macro ID

[ESC] %#A Enter PCL mode

[ESC] %#B Enter HP-GL/2 mode

[ESC] *c#K HP-GL/2 plot horizontal
size

[ESC] *c#L HP-GL/2 plot vertical
size

[ESC] *c#T Set picture frame anchor
point

[ESC] *c#X Picture frame horizontal
size

[ESC] *c#Y Picture frame vertical
size





Transferring 
Files
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ile transfer is the process of moving files between your PC and the
host. You can transfer a file from your PC to the host so that other

host users can access it. Conversely, you can transfer a host file to your
PC where you might, for example, bring it into a word processing
program or spreadsheet application.

To transfer files, EXTRA! must communicate with a file transfer tool on
the host. Each host type has certain types of file transfer tools that are
designed to support it.

Using EXTRA! you can transfer files in the background in one host
session while you continue to work uninterrupted in another. You can
also monitor the progress of your file transfer and even send a file to the
mainframe in one session while receiving a file in another session.

Here are the general steps required fora file transfer:

Note:  Be at the “Ready” prompt before initiating a file transfer.

1. Determine your session type and start a new session.

2. Configure your file transfer options, which creates transfer schemes.

3. Open the Transfer File dialog box.

4. Select a scheme.

5. Start File Transfer and observe the progress.

3270 File Transfer
EXTRA! 3270 file transfer sends and receives files using three different
file transfer tools: IND$FILE, DISOSS, FTP. To use transfer files using
IND$FILE, one of the following must be resident on your host:
VM/CMS; MVS/TSO; or MVS/CICS or VSE/CICS, or PS/CICS
(IND$FILE only). The table below includes a description of each host
type. The host type is often displayed as part of the Startup screen when
you log on. If yours isn’t and you don’t know your mainframe host type,
check with your system administrator.

Note: To use DISOSS, you must have PS/CICS resident on your host.

For information about transferring files using FTP, see “FTP File
Transfer” later in this chapter.

F
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Host Type Description

VM/CMS VM/CMS stands for Virtual
Machine/Conversational Monitor System. CMS is an
interactive mainframe application that resides under
the VM operating system. This system works with
IBM’s CMS IND$FILE program (#5664-281) to
transfer files.

MVS/TSO MVS/TSO stands for Multiple Virtual Storage/Time
Sharing Option. TSO is an interactive mainframe
application that resides under the MVS operating
system. This system works with IBM’s TSO
IND$FILE program (#5665-311) to transfer files.

MVS/CICS
or VSE/CICS

MVS/CICS stands for Multiple Virtual
Storage/Customer Information Control System, and
VSE/CICS stands for Virtual Storage
Extended/Customer Information Control System.
Under these operating systems, EXTRA! supports
file transfers using IBM’s DISOSS (Distributed Office
Support System) (MVS: #5665-290; VSE: #5666-270).
MVS/CICS can also use IBM’s IND$FILE program
(#5665-311) for file transfer.

PS/CICS EXTRA! utilizes a separate transfer facility called
DISOSS for OV/MVS (PS/CICS) mainframe
systems. This file transfer method is initiated and
controlled by the mainframe, and works differently
from IND$FILE transfers. This method is also
referred to as a Host-Initiated transfer.

You can use the same commands for transferring files individually or in a
batch, regardless of the protocol you choose.

Tip: You can send a file to a host using whichever transfer method you
have selected by dragging the file from the Windows Explorer, My
Computer, or the NT File Manager, and dropping it on a session that is
connected to the host.
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The Transfer File Dialog Box

Open a session and choose Transfer File from the Tools menu to display
the Transfer File dialog box. Use the options in this box to create a list of
files and transfer them as a batch to or from one of the available host
environments.

You can edit the transfer options for individual files and you can save a
list of files to display and transfer again.

Before transferring files, it may be helpful to set up a file transfer scheme
(define settings) which specifies the way a particular file will be
transferred.

Tip: You can use drag-and-drop to add files from Windows Explorer, My
Computer, or the NT Explorer to the Transfer List in this dialog box. If
you are using Windows 95, Windows 98, or Windows NT 4.0, you can
also copy and paste files to the Transfer List.

Transfer File dialog box with Browse selected
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Transfer List Name: Select a name from the list to display a previously
saved list of files. The names of saved transfer lists are based on the
transfer type. Your most recently used transfer list is available, even if
you did not specifically save it.

Save As: Saves the displayed transfer list under a different name so that
you can reuse it at a later time.

Delete: Removes the transfer list displayed in the Transfer List Name
box.

Transfer List: Displays a list of transfers that can be selected for transfer.
Click the checkbox to the left of the transfer to select which transfers to
actually perform. Click a header button to sort the list accordingly.

Note: When files are dragged to this area the host name is assigned based
on the host type chosen and it is accepted as a send transfer.

PC: Specifies the PC files to transfer.

Filename: Type a filename to add to the transfer list.

Path: Displays the current path to the file on your PC.

Browse: Choose to search for a specific PC file.

Send: Sends the specified file to the host when you start a file transfer.

Receive: Receives the specified file from the host when you start a file
transfer.

Host: Specifies the Host files to transfer and the host system type.

Filename: Type a filename to add to the transfer list.

Type: Select the host system type: CMS, TSO, or CICS.

Transfer: Initiates the file transfer.

Cancel: Closes this dialog box without transferring files.

Remove: Removes the selected file from the transfer list.

Remove All: Removes all files displayed in the transfer list.

Help: Displays more general Help for this dialog box.

Scheme: Specifies the scheme that will be used for the transfer. If there is
no chosen scheme, “Current settings” displays.

Settings: Displays the Settings pages for your file transfer method where
transfer options for the file selected in the transfer list can be edited.
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Add To List/Apply Changes: Adds your selection to the Transfer List or
applies changes made to an item in the Transfer List.

Splitter bar: Adjusts the sizes of the two window areas when the PC
Browser is displayed. This does not change the window size.

List Local Files Of Type: Filters the displayed list of PC files by type.

Folder List: Displays a list of folders located on your PC.

File List: Displays a list of files in the selected folder.

The File Transfer Progress Dialog Box

The File Transfer Progress dialog box displays the transfer progress for
the current transfer. You can stop the transfer of an individual file or the
entire batch by choosing either the Abort File or the Abort All button.

The File Transfer Progress dialog box

Progress Message: Displays the transfer progress message for the file
currently being transferred.

Current: Displays the transfer progress (number of bytes sent or
received) for the file currently being transferred.

Total: Displays the transfer progress (number of bytes sent or received)
for the entire transfer batch.

Errors: Displays the number of transmission errors that have occurred
during the transfer session.

Timeouts: Displays the number of timeouts that have occurred during
the transfer session.
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Files: Displays the number of successfully transferred files out of the
total number of files to transfer.

Abort File: Aborts the transfer of the current file. When a transfer fails,
this button changes to Close.

Abort All: Aborts the transfer of the entire transfer batch.

Transfer Completion Options

Close Progress at Completion of Transfer: Closes the File Transfer
Progress dialog box immediately upon completion of the last
transfer.

Display Transfer Summary: Displays the Transfer Summary dialog
box when the File Transfer Progress dialog box closes.

The Transfer Summary Dialog Box

The Transfer Summary dialog box displays when all transfers are
complete, providing a summary of how each transfer completed as well
as the statistics for the transfer session.

Transfer Summary dialog box
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Transfer Schemes
A file transfer scheme specifies the way a particular file will be
transferred, the type of translation, and any special parameters required
by the receiving environment. Schemes allow you to save all of these
settings in a file that you can reuse. This saves time and ensures
consistency if you repeatedly run file transfers that require the same
transfer settings. File transfer schemes are saved in files with an .EIS
extension.

Schemes include the option to set send and receive parameters for each
host type. The send and receive options you set for one host type are
different from the options for other host types. However, you can select
options for all three environments in each file transfer scheme so that you
can use the same scheme regardless of environment constraints.

Access the File Transfer Settings dialog box by choosing the Settings
button from the Transfer File dialog box, or by choosing Settings from
the Edit or Options menu.

You can do one of the following:

• Choose an existing scheme to edit.

• Choose the Save As button and type a new scheme name to create a
new scheme. The new scheme will have the settings of the scheme
you copied, which you can then change to suit your needs.

• Remove an existing scheme.

To create a file transfer scheme

1. Open a session and from the Tools menu, choose Transfer File.

2. From the Transfer File dialog box, choose Settings to display the File
Transfer Settings dialog box.

You can also access this dialog box if you choose Settings from the
Options menu.

3. From the General Settings page, (or Local Options page for FTP file
transfers) set the appropriate transfer scheme parameters.

4. If necessary, go to the CMS, TSO, or CICS pages to adjust the settings
for your host type.

5. Choose the Save As button.
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6. Enter the name of the new scheme using the .EIS extension in the
Save Scheme dialog box and choose whether to save it in a local or
remote destination.

7. Choose OK in the File Transfer Settings dialog box. The new scheme
name appears in the Scheme list and can be selected at any time.

To copy a file transfer scheme

1. From the Transfer File dialog box, choose Settings to display the File
Transfer Settings dialog box.

You can also access this dialog box if you choose Settings from  the
Options menu.

2. Select the file transfer scheme you want to copy.

3. Choose the Save As button.

4. Enter the name of the new scheme using the .EIS extension in the
Save Scheme dialog box.

5. Choose OK in the File Transfer Settings dialog box. The new scheme
name appears in the scroll list and can be selected at any time.

To delete a file transfer scheme

1. From the Transfer File dialog box, choose Settings to display the File
Transfer Settings dialog box.

You can also access this dialog box if you choose Settings from the
Options menu.

2. Select the file transfer scheme you want to delete.

3. Choose the Delete button.

3270 IND$FILE File Transfer
This section describes the procedures used to send and receive files on
hosts set up for IND$FILE transfers.

EXTRA! supports the IND$FILE file transfer program which can be used
on CMS, TSO, and CICS systems. Send and receive procedures using the
IND$FILE are different depending on the host system you are using.
Because EXTRA! can be configured to run using several different host
types, you will have to set file transfer options on the Settings page
before you send or receive files.
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Preparing for IND$FILE File Transfers

If you want to change the file transfer type while in a session, follow
these procedures before you send or receive files.

Notes:

• You must have an active session with a host before attempting to
transfer files.

• You can use the same commands for transferring files individually or
in a batch.

• You can both send and receive files in the same batch.

Tip: You can send a file to a host using whichever transfer method you
have selected by dragging the file from the Windows Explorer, My
Computer, or the NT File Manager, and dropping it on a session that is
connected to the host.

To change a file transfer type

1. Open a display session.

2. From the Options menu, choose Session Type.

3. Select the file transfer protocol and click OK..

4. Depending on the host type you are using, type one of the following
commands (at your display session command line) to turn off
unsolicited messages:

To
Type this command and
press Enter

Turn off messages for a CMS session WIX�QWK�SJJ

Turn messages back on after you have
finished transferring files using CMS

WIX�QWK�SR

Turn off messages for a TSO session TVSJ�RSMRXIVGSQ

Sending and Receiving Transfers Using IND$FILE

This section describes the procedures to use for sending and receiving
files on hosts et up for IND$FILE transfers using settings for CMS, TSO
and CICS host environments.
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To send a PC file using IND$FILE

1. Open the Transfer File dialog box by choosing Transfer File from the
Tools menu.

2. When the dialog box displays, choose Send.

Note: Send is the default direction of transfer when this dialog box is
opened.

3. Under PC, in the Filename box, enter the name of the existing PC file.

Either type the name (and path, if required) directly in the field or
choose the Browse button to access the Select PC File dialog box.
From this dialog box, make your selection and then choose OK.

4. Under Host, in the Filename box, enter the name of the new
mainframe file (or existing mainframe file, if you are appending).

When you send a file and you supply a Host Filename that already
exists, the PC file overwrites the mainframe file unless you select the
Append to Host File option from the IND$FILE Settings General
page.

5. Select the host type from the list. For most file transfers, the default
settings are adequate. However, you can change the settings to
control how the PC file you are transferring will be stored on the
mainframe

6. (Optional) To edit the settings of the transfer scheme you are using,
choose the Settings button. For information on editing file transfer
schemes, see “Transfer Schemes” earlier in this chapter.

7. Choose the Transfer button to begin the transfer.

The File Transfer Progress dialog box is displayed during the transfer
informing you of the transfer status.

To receive a file using IND$FILE

1. Open the Transfer File dialog box by choosing Transfer File from the
Tools menu.

2. When the dialog box displays, select Receive.

3. Under PC in the Filename box, enter the name of the new file (or
existing file, if you are appending)..
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Either type the name (and path, if required) directly in the field or
choose the Browse button to access the Select PC File dialog box.
From this dialog box, make your selection and then choose OK.

When you receive a file and you supply a PC Filename that already
exists, the Host file overwrites the PC file unless you select the
Append to PC File option in the IND$FILE Settings General page
(see step 6, below).

4. Under Host, in the Filename box, enter the name of the existing
mainframe file.

5. Select the Host Type from the list. For most file transfers, the default
settings are adequate. However, you can change the settings to
control how the PC file you are transferring will be stored on the
mainframe.

6. (Optional) To edit the settings of the transfer scheme you are using,
choose the Settings button. For information on editing file transfer
schemes, see “Transfer Schemes” earlier in this chapter.

7. Choose the Transfer button to begin the transfer operation.

The File Transfer Progress dialog box is displayed during the transfer
informing you of its status.

File Transfer Settings - IND$FILE

You use the File Transfer Settings pages to create, edit, or delete a file
transfer scheme. Each scheme can include specific information for each
file transfer type - CMS, TSO, and CICS and when you send and receive
files, you can use the same transfer scheme regardless of the file transfer
type. Choose from the following tabbed pages:

General: Sets the basic parameters for a file transfer scheme. The
parameters include the file format, host options if a file exists when a PC
file is sent to the host, PC options if a file exists when a file is received
from the host, structured field size and transfer path information.

CMS: Sets options for a file transfer scheme specific to CMS file transfer.
The options include record format, record length, and CMS send and
receive parameters.

TSO: Sets options for a file transfer scheme specific to TSO file transfer.
The options include record format, record length, space allocation, and
TSO send and receive parameters.
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CICS: Sets options for a file transfer scheme specific to CICS file transfer.
The options include host file, CICS comments, and CICS send and
receive parameters.

Advanced: Sets the advanced parameters for a file transfer scheme. The
parameters include host program options such as transfer program
name, timeout, and lead key.

The Settings - IND$FILE General Page

Use the options in the Settings - IND$FILE General page to define the
parameters for a file transfer scheme.

The Settings - IND$FILE General page

Scheme: Choose an existing transfer scheme or create a new transfer
scheme.

Save As: Saves your transfer scheme under the filename and location you
provide..

Delete: Choose to delete the selected file transfer scheme.
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Send Options

If Host File Exists On Send: Contains the options to overwrite or
append if the file already exists on the host.

Note: Host file options are not available for CICS file transfer.

Include Files In Subfolders: Select to send all files (or file types, if
you are using a wildcard)in the subdirectories of the directory
selected in PC, under Filename, on the Transfer File dialog box.

Receive Options

If PC File Exists On Receive: Select to save the file with a unique
name, rename the existing PC file, abort the transfer, overwrite the
existing PC file, append the existing PC file, or prompt for action.

Create Path if it Does Not Exist: Choose to have the path (for the
received file)automatically assigned if it does not already exist.

Structured Field Size (KB): With structured fields, files are transferred in
blocks of data which can be between 2 K and 32 K in size. In addition,
structured field transfer compresses the file during the transfer. The
larger block size and file compression reduce the amount of time
required to transfer a file. The larger the block size, the greater the
increase in speed.

Manual: Specifies the field size when performing a manual transfer.
The field size can be between 2KB and 32KB.

HLLAPI: Specifies the field size when performing a HLLAPI
transfer.

File Format

Text: Specifies that files are transferred with default settings for all
host types. Files sent to the host are converted from ASCII (the
character code set used by the PC) to EBCDIC (the code set used by
the host). Files received from the host are converted from EBCDIC to
ASCII.

Carriage Return and Line Feed: When you are receiving a file, this
option inserts end-of-line characters during the file transfer. When
you are sending a file to the mainframe, this option leaves (that is, it
does not remove) those characters during the file transfer. Generally,
you should use this option because the host file separates
information with end-of-line characters, whereas the PC uses
carriage return and line feed.
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Default Transfer Path: If the file does not already exist on the PC,
displays the path specified in the Transfer File dialog box.

The Settings - IND$FILE CMS Page

CMS is an interactive mainframe application that resides under the VM
(Virtual Machine) operating system. This system works with IBM’s CMS
IND$FILE program to transfer files. The send and receive options using
CMS are different from the options for the other host environments, such
as TSO and CICS. However, you can select options for all three
environments in each scheme so that you can use the same scheme
regardless of environment constraints.

The Settings - IND$FILE CMS page

Scheme: Choose an existing transfer scheme or create a new transfer
scheme.

Save As: Saves your transfer scheme under the filename and location you
provide.

Delete: Choose to delete the selected file transfer scheme.



User’s Guide

6-16

Record Format: Specifies the record format of the mainframe file. You
can choose from Host Default, Fixed, or Variable. The default is Host
Default.

Record Length: Specifies the logical record length for the file, where the
value is the number of characters in each record. The acceptable range of
values is based on the selected record format. The default record length
is 0 bytes. If the record format is variable or fixed, enter a value of 5 to
32767 (inclusive). If you are appending to an existing file, the record
length is ignored. For most file transfers, you won’t need to change this
option.

CMS Send Parameters: Specifies any additional file transfer parameters
needed to send a PC file.

CMS Receive Parameters: Specifies any additional file transfer
parameters needed to receive a PC file.

The Settings - IND$FILE TSO Page

TSO is an interactive mainframe application that resides under the MVS
(Multiple Virtual Storage) operating system. This system works with
IBM’s TSO IND$FILE program to transfer files. The TSO send and
receive options are different from the options for the other host
environments, such as CMS and CICS. However, you can select options
for all three environments in each scheme so that you can use the same
scheme regardless of environment constraints.
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The Settings - IND$FILE TSO page

Scheme: Choose an existing transfer scheme or create a new transfer
scheme.

Save As: Saves your transfer scheme under the filename and location you
provide.

Delete: Choose to delete the selected file transfer scheme.

Record Format: Specifies the record format of the mainframe file. You
can choose from Host Default, Fixed, Variable, or Undefined. The default
is Host Default.

Record Length: Specifies the logical record length for the file, where the
value is the number of characters in each record. The acceptable range of
values is based on the selected record format. The default record length
is 255 bytes. If the record format is variable or fixed, enter a value of 5 to
32767 (inclusive). If you are appending to an existing file, the record
length is ignored. For most file transfers, you won’t need to change this
option.
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Block Size: Specifies the appropriate size of the TSO data set, where the
value is the number of bytes per block.

Space Allocation

Quantity: Specifies the amount of space to be allocated on the host
for a new data set.

Increment: Specifies an additional increment of space units on the
host for a new data set. If the amount of space defined in the
Quantity field is insufficient, use this option to specify an additional
amount of space on the host.

Space Units: Specifies whether space on the mainframe is assigned
in blocks, tracks, or cylinders. If you select blocks, you must also
enter an Average Block Size.

Average Block: If the type of space unit specified was blocks, enter
the average block size.

TSO Send Parameters: Any additional parameters needed to send a PC
file.

TSO Receive Parameters: Any additional parameters needed to receive a
PC file.

The Settings - IND$FILE CICS Page

EXTRA! supports two different types of CICS transfers: IND$FILE, and
DISOSS (Distributed Office Support System). All three types of file
transfer are known as host-based transfer because they are controlled by
programs running on the host. The IND$FILE file transfer program is run
from an interactive mainframe application that works with IBM’s CICS
IND$FILE program to transfer files. DISOSS is run using PS/CICS or
OfficeVision/MVS, programs available on many CICS systems, and
works in conjunction with the PC program TRANSFER. See “3270
DISOSS File Transfer” if you are interested in using DISOSS file transfers.
For CICS IND$FILE file transfer, the send and receive options are
different from the options for the other host environments, such as CMS
and TSO. However, you can select options for all three environments in
each scheme so that you can use the same scheme regardless of
environment constraints.
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The Settings - IND$FILE CICS page

Scheme: Choose an existing transfer scheme or create a new transfer
scheme.

Save As: Saves your transfer scheme under the filename and location you
provide.

Delete: Choose to delete the selected file transfer scheme

Host File: This option allows you to specify where the mainframe stores
a file before the file is sent or after it is received. The default is the host
default. Options include:

HTF Indicates the file is to be stored in the Host Transfer File.

TS Indicates the file is to be stored in a CICS temporary storage
queue.

LST Indicates the file is to be stored in the VSE (Virtual Storage
Extended) power list queue.

RDR Indicates the file is to be stored in the VSE power reader
queue.

PUN Indicates the file is to be stored in the VSE power punch
queue.
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CICS Send Parameters: Specify any additional IND$FILE parameters
needed to send a PC file.

CICS Receive Parameters: Specify any additional IND$FILE parameters
needed to receive a PC file.

CICS Comments: (Optional) Add comments to a file. Use any
combination of letters and numbers, but do not use parentheses.

The Settings - IND$FILE Advanced Page

Use the Advanced page to define the advanced parameters for a file
transfer scheme. All three host types share common advanced IND$FILE
settings.

The Settings - IND$FILE Advanced page

Scheme: Choose an existing transfer scheme or create a new transfer
scheme.

Save As: Saves your transfer scheme under the filename and location you
provide.

Delete: Choose to delete the selected file transfer scheme.
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Host Program:

Transfer Program Name: Specifies an IND$FILE compatible host
transfer program name.

Timeout: Specifies the number of seconds the file transfer program
waits for the host transfer program to respond to a command before
file transfer is terminated. The default is 60 seconds. You can enter
any number between 1 and 999 seconds.

Lead Key: Allows you to specify certain actions before transferring
files. Your choices are None, Clear, Erase input, Erase to end of field,
and Auto Sense.

Code Pages

PC Code Page: Specifies the PC code page. Check with your system
administrator if you don’t know which code page is appropriate.

Host Code Page: Specifies the character display code page used by
the host. The default setting corresponds with your Windows default
setting. IND$FILE file transfer can be executed in another language
without making any modifications to your PC environment. Check
with your system administrator if you don’t know which code page
is appropriate.

Troubleshooting IND$FILE Transfers

• Be at the “Ready” prompt before initiating a file transfer.

• Do not turn the power off in a terminal session that is performing a
transfer.

• Do not change to a new screen layout while you are transferring a
file.

• Do not close a session during file transfer.

Problems with Files that have been Transferred

A successfully transferred file may be unusable at the destination if the
original file is not readable on the system it has been transferred to, or if
the parameters controlling the transfer were inappropriate.

If a File Sent to the Mainframe is Unreadable

Make sure that the file you sent from your PC was saved as a text-only
file and that you selected the correct options in the Transfer Send dialog
box.
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If You Cannot Open a File Received on Your PC

Verify that the Host Filename and PC Filename you specified prior to the
file transfer are correct. Also make sure that the file you sent from the
mainframe was a text format file.

If a Received File has Only One “Paragraph”

Make sure that the Remove Line Ends parameter in the transfer scheme
used for the transfer is set correctly.

A File Sent and then Received has a Different Number of Bytes

In some circumstances the mainframe strips spaces from, or adds them
to, the end of each record. Except for these spaces, the information in the
file should be unaffected.

Problems with the IND$FILE Program

In some installations, the name of your mainframe Send/Receive
program may be different from the name EXTRA! expects. If the
Send/Receive program has been installed on your mainframe under a
name other than IND$FILE, you will need to go to the Transfer Options
dialog box and specify the new program name in the Transfer Program
field.

3270 DISOSS File Transfer
This section describes how to send and receive files for host-initiated file
transfers using PS/CICS DISOSS (Distributed Office Support System).
DISOSS works in conjunction with an IBM PC program called
TRANSFER. DISOSS transfers are performed using PC/CICS menu
commands.

Before you can transfer files using DISOSS, your mainframe must meet
the following requirements:

• PS/CICS must be available on the mainframe with appropriate
VTAM settings.

• CICS must be active on the DISOSS network.

• Must have a DFT connection and be able to receive EDS (Extended
Data Stream) from the mainframe.

• The TRANSFER program must be running in the PC display session.

The following information on configuring CICS and VTAM is optional:
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• Uppercase translation should be off to support both uppercase and
lowercase characters. If uppercase translation is on, all lowercase
characters are translated to uppercase.

• Dual-case keyboard should be supported. If uppercase translation is
off, both cases need to be supported.

• Program symbols must be supported.

• Query must be set to ALL.

• A logmode table entry must be defined for EDS (Extended Data
Stream).

To send a file using DISOSS

1. Open a mainframe session and log on to your PS/CICS system.

2. From the PS/CICS main menu, choose option 4, Create a Document.

3. From the Create a Document menu, choose option 3, Import a
Document from the Workstation.

The next screen lets you provide information that PS/CICS will use
to identify the imported file.

4. In the first field, type the path and filename of the PC file you want
to send to the mainframe.

5. Click the Tab button to move to the next field, Document Name.
Enter the name you want the file to have on the mainframe.

6. Click the Tab button to move to the other fields and enter
information as appropriate. When finished, press enter to start the
transfer operation.

7. Return to your PC session. The transfer begins when you are in your
PC session and continues only while you remain in the PC session.
The File Transfer Progress dialog box displays the status of the
transfer.

8. When the transfer is completed, your CICS session displays the
message shown below.

*MPI�8VERWJIV�'SQTPIXIH
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To receive a file using DISOSS

Before you can send a file using DISOSS, you need to open a mainframe
session and log on to your PS/CICS system.

1. From the PS/CICS main menu, choose option 5, Work with File
Cabinet Items.

2. In the Select items by field, select 1 or 2 to get a list of files listed by
Date filed or Date due.

3. Select the file you want to export by typing an x in the CMD field
and press enter.

4. Choose option 22 to bring up the export menu.

5. Move to Copy to workstation. In the File Identifier field, type the
path and name you want the file to be given on your PC. You can
also specify whether to replace an existing PC file. Press enter to start
the transfer operation.

6. Return to your PC session. The transfer begins when you are in your
PC session and continues only while you remain in the PC session.
The File Transfer Progress dialog box displays the status of the
transfer.

7. When the transfer is completed, your CICS session displays the
message shown below.

*MPI�8VERWJIV�'SQTPIXIH

FTP File Transfer
FTP is the Internet standard File Transfer Protocol. It is generally the
fastest method for transferring files. It always makes its own connection,
outside of any active display session. With FTP, you can both send and
receive files in a single batch.

The Transfer File Dialog Box

The Transfer File dialog box is displayed when you choose Transfer File
from the Tools menu. Use the options in this box to create a list of files
and transfer them as a batch to or from the host.

You can edit the transfer options for individual files and you can save a
list of files to display and transfer again.
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Tip: You can drag and drop files from the Windows Explorer, My
Computer, or the NT File Manager to add them to the Transfer List in
this dialog box. If you are using Windows 95 or Windows 98, you can
also copy and paste files to the transfer list.

Transfer File dialog box

Transfer List Name: Select a name from the list to display a previously
saved list of files. Your most recently used transfer list is available, even
if you did not specifically save it.

Save As: Saves the displayed transfer list under a different name so that
you can reuse it at a later time.

Delete: Removes the transfer list displayed in the Transfer List Name
box.

Transfer List: Displays a list of files that can be selected for transfer.
Click the check box to the left of a file to select which transfers to actually
perform. Click a label at the top of the list to sort the list by that attribute.
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Local: Specifies the PC files to transfer.

Filename: Type a file name to add to the transfer list.

Path: Displays the current path to the file on your PC.

Browse: Choose to search for a specific PC file.

Send: Sends the specified file to the host when a file transfer is started.

Receive: Receives the specified file from the host when a file transfer is
started.

Host: Specifies the host files to transfer.

Filename: Type a file name to add to the transfer list.

If the files are to be transferred to a PDS (partitioned data set) on the
host, type the name of the PDS followed by an asterisk. For example,
type MyPDS* to transfer files to the PDS, MyPDS.

When the files are transferred to the host, they become members of
the named PDS and lose the file name extensions they had as local
files. For example, when the local file newfile.txt is transferred to the
host and becomes a member of MyPDS, its file name becomes
MyPDS(newfile).

Transfer: Initiates the file transfer.

Cancel: Closes this dialog box without transferring files.

Remove: Removes the selected file from the transfer list.

Remove All: Removes all files displayed in the transfer list.

Help: Displays more general Help for this dialog box.

Add To List/Apply: Adds your selection to the transfer list or applies
changes you made to an item in the transfer list.

Settings: Displays the Settings pages for your file transfer method where
transfer options for the file selected in the transfer list can be edited.

Scheme: Specifies the scheme that will be used for the transfer. If you do
not select a scheme, “Current settings” displays.

Splitter bar: Adjusts the sizes of the two window areas when the PC
Browser is displayed. This does not change the window size.

List Local Files Of Type: Filters the displayed list of PC files by type.

Folder List: Displays a list of folders located on your PC.
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To transfer a file or batch of files

1. From the Tools menu, choose Transfer File.

2. To add files to your transfer list, use the Local and Host Filename
options to choose the files you want to transfer, then choose Add To
List.

-or-

Under Local, choose the Browse button. From the list that appears,
double-click the file you want to add.

-or-

From Windows Explorer, find the file you want to transfer and drag
it onto the transfer list.

-or-

Select an existing transfer list from the Transfer List Name list.

You can both send and receive files in a single batch.

3. Choose Transfer. When the transfer completes, a summary window
displays the results of the transfer.

Note: If you use Windows 95 or Windows 98, you can also copy and
paste files to the transfer list.

To edit the transfer list

• Make changes as follows:

To Do this

Change the transfer direction for
a particular file

Select the file, then select either
Send or Receive and choose
Apply.

Remove an individual file from
the transfer list

Select the file and choose
Remove, or press the Delete key
on your keyboard.

Exclude a particular file from the
current transfer batch without
removing it from the transfer list

Clear the check mark next to the
file name in the transfer list.

Save your transfer list Choose Save As.
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The File Transfer Dialog Box

The File Transfer dialog box displays the transfer progress for the current
transfer. You can stop the transfer of an individual file or the entire batch
by choosing either the Abort File or the Abort All button.

File Transfer dialog box

Current: Displays the transfer progress (number of bytes sent or
received) for the file currently being transferred.

Total: Displays the transfer progress (number of bytes sent or received)
for the entire transfer batch.

Errors: Displays the number of transmission errors that have occurred
during the transfer session.

Timeouts: Displays the number of timeouts that have occurred during
the transfer session.

Transfer Speed: Displays the file transfer progress measured in
characters per second.

Est. time left: Displays the estimated time until the transfer is completed.

Files: Displays the number of successfully transferred files out of the
total number of files to transfer.

Abort File: Aborts the transfer of the current file. When a transfer fails,
this button changes to Close.

Abort All: Aborts the transfer of the entire transfer batch.
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Transfer Schemes
You can select a group of file transfer options and save them as a scheme.
Then, you need only select the scheme to apply the group of options to a
particular file transfer. When you save a scheme, options on the File
Handling, Folders, and File Types pages are saved. Options on the
General and Proxies pages are not saved.

Schemes are saved with the file name extension .EDT in the SCHEMES
subfolder of the EXTRA! program folder.

To save file transfer options as a scheme

1. From the Options menu, choose Settings.

2. Under Categories, choose File Transfer.

3. In the File Handling, Folders, and File Types pages, set transfer
options to suit your requirements.

4. In the File Handling page, choose Save As and provide a file name
and location for your scheme.

Tip: If you use the navigation feature to record host pages and attach a
scheme of transfer options to a particular host application screen, the
scheme that you attach is used whenever you view that screen, even
when you do not use navigation to display it. You can use this feature to
force an individual host screen to use a specific set of transfer options.

To apply a scheme of transfer options to a file transfer batch

1. From the Tools menu, choose Transfer File.

2. In the Transfer File dialog box under Scheme, select an existing file
transfer scheme.

3. If you want to edit the transfer options or create a new scheme,
choose Settings.
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File Transfer Settings - FTP
You use the File Transfer Settings pages to select options for transferring
files during your session. You can also create, edit, or delete a file transfer
scheme. When you save a scheme, options on the File Handling, Folders,
and File Types pages are saved. Options on the General and Proxies
pages are not saved. Choose from the following tabbed pages:

General: Set options for connecting to your host.

Proxies: Configure your FTP or SOCKS version 4.0 proxy server options.

File Handling: Save or delete your file transfer scheme. Set options for
processing an incoming file when a file of the same name already exists
on the PC. Set the end-of-line character for files sent to the host.

Folders: Set options for determining the destination location of files on
the PC and the host.

File Types: Set options for determining the file type during file transfer.

The Settings - FTP General Page

Use the options in the FTP General page to set your default FTP login
options.

If you have already selected FTP as your File Transfer Protocol, you can
access the File Transfer FTP General page by choosing Settings from the
Options menu. Otherwise, choose Session Type from the Options menu
and change your File Transfer Protocol, then choose Settings.

If you select Choose Host Name Now, and include your login
information, the information you type is saved when you save your
session, and used when you make an FTP connection using the same
session profile.
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The Settings - FTP General page

Prompt For Host When Connecting: Choose the host when you initiate a
connection. When you select this option, all other options on this page
are unavailable.

Choose Host Name Now: Choose the host now and avoid having to
choose the host when you initiate a connection. When you select this
option, you should also enter or select a Host Name.

Host: Type the name or IP address of the host to which you want to
connect, or select a Host name from the list. The list displays up to
four of your most recently used Host names, and the Host names in
the Windows Sockets Hosts File if it exists. The Host name you type
does not have to be one of those displayed in the list.

Login Information

User ID: Type your user name here.

Password: Type your password here. This password is encrypted
when it is saved as part of your session configuration.

Account: If the host requires your account name before you can log
on, type your account name here.
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FTP Port: Specifies the number of your host’s FTP port and provides
a space for you to change it. The usual FTP port is 21.

To set up FTP file transfers

1. From the Options menu, choose Session Type.

2. Under File Transfer Protocol, select FTP.

3. Choose Settings to display the Settings dialog box, and under
Categories, select File Transfer.

4. In the FTP General page, select either Prompt For Host When
Connecting or Choose Host Name Now.

5. If you select Choose Host Name Now, also type a host name or IP
address in the Host text box, or select a Host name from the list. Type
your User ID and Password, if required.

Note: If you use an FTP proxy, Host name lookup for the remote host
is performed by the proxy. The proxy might use a different Domain
Name Server than you would use locally. In order to be sure that
Host names are resolved correctly, do not use abbreviated names for
hosts outside your local area network.

6. If you use an FTP or SOCKS proxy server, in the FTP Proxies page,
configure the options that suit your requirements.

7. In the File Handling, Folders, and File Types pages, select the options
that suit your requirements.

The information you select is saved when you save your session, and
used whenever you make an FTP connection using the same session
profile.

Note: If you select Prompt For Host When Connecting, all other options
in the General page become unavailable. You are prompted to select a
host and provide your login information when you attempt to make a
connection.

The Settings - FTP Proxies Page

A proxy is a server that works in conjunction with a firewall (often as
part of the same system) to provide network security. A proxy acts as an
intermediary to limit access between clients in an internal network and
servers outside the network.



Transferring Files

6-33

EXTRA! supports FTP and SOCKS version 4.0 proxies.

Use the options in the FTP Proxies page to configure your FTP or SOCKS
version 4.0 proxy server options.

Note: If you have already selected FTP as your File Transfer Protocol,
you can access the File Transfer FTP Proxies page by choosing Settings
from the Options menu. Otherwise, choose Session Type from the
Options menu and change your File Transfer Protocol, then choose
Settings.

The Settings - FTP Proxies page

No Proxy: Select this option if you have a direct connection to the
Internet. That is, you do not connect through a proxy.

Use FTP Proxy: Select this option if you use an FTP proxy. If you select
this option, also select Use Passive Mode When Transferring Files.

FTP Proxy: Type the Host name or IP address of your FTP proxy
server.

Port: Type the port number for your FTP proxy server.
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Use SOCKS Proxy: Select this option if you use a SOCKS proxy. A
SOCKS proxy can be used for FTP sessions.

SOCKS Proxy: Type the Host name or IP address of your SOCKS
proxy server.

Port: Type the port number for your SOCKS proxy server.

Use Passive Mode When Transferring Files: Establish the FTP
connection by the client (your PC), rather than by the server. Select this
option if you use an FTP proxy. This works for most servers and is
sometimes necessary if the client is behind a firewall. If your FTP
connection fails with this option selected, try reconnecting with this
option cleared. The default is cleared.

To configure EXTRA! to use an FTP proxy server

1. From the Options menu, choose Session Type.

2. Under File Transfer Protocol, select FTP.

3. Choose Settings to display the Settings dialog box, and under
Categories, select File Transfer.

4. In the FTP Proxies page, select either Use FTP Proxy or Use SOCKS
Proxy. If you use an FTP proxy, under FTP Proxy, type the Host
name or IP address of your FTP proxy server. Under FTP Port, type
the port number of your FTP proxy server. Also select the FTP
Passive Mode Transfers option.

-or-

If you use a SOCKS proxy, under SOCKS Proxy, type the Host name
or IP address of your SOCKS proxy server. Under SOCKS Port, type
the port number of your SOCKS proxy server. EXTRA! supports
SOCKS version 4.0 proxies using an FTP connection.

The Settings - File Handling, Folders, and File Types Pages

Use the options in the File Handling, Folders, and File Types pages to
select transfer options for FTP file transfers.

The options you select here are saved when you save your session, and
used as defaults whenever you use the same session profile. In addition,
you can save these options as a scheme in a file that can be reused
whenever you need to transfer files using the same settings.

To access the Settings - File Transfer pages, from the Options menu
choose Settings. Under Categories, select File Transfer.
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The Settings - FTP File Handling page

Scheme: Choose an existing transfer scheme or create a new transfer
scheme.

Save As: Saves your transfer scheme under the file name and location
you provide.

Delete: Deletes the displayed scheme of transfer options.

If PC File Exists on Receive: Select how to process an incoming file that
has the same name as another file in the target folder. The Rename value
renames the incoming file by adding numbers or incrementing numbers
in the file name. The extension is not changed. The default is Prompt To
Replace.

Send End Of Line As: Select the end of line character that your host uses
when transferring text files. The default is CRLF (carriage return-
linefeed).
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The Settings - Folders Page

The Settings - FTP Folders page

Default Transfer Path: If the file does not already exist on the PC,
displays the path specified in the Transfer File dialog box.

Use Host Path: Select this option to store the file based on the path
supplied by the host, which is appended to the local receive path.

Create Path If It Does Not Already Exist: Choose to have the path (for
the received file) automatically assigned if it does not already exist.

Strip Partitioned Data Set Names: When this option is selected, files
downloaded from a PDS (partitioned data set) on the host are given local
file names that do not include the PDS in the path. For example, when
transferred to the folder C:\DATA, a file named MyPDS(NEWFILE) on
the host becomes C:\DATA\NEWFILE on the PC.

If this option is cleared and the Create Path option is selected, the PDS is
added to the local path when a file is received from the host. If the Create
Path option is not selected, the PDS is used only if there is already a
folder of that name in the specified path.
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Send Full Path: Select this option to send the file’s complete path
information, excluding the drive letter and colon. See also the Include
Files In Subfolders option.

Include Files In Subfolders: Select this option to send all files (or file
types, if you use a wildcard) in the subfolders of the folder selected in the
Transfer File dialog box under Local Filename.

The Settings - File Types Page

The Settings - FTP File Types page

Automatic: Select this option to enable automatic file type processing
based on the file name extension and file scanning options.

Binary: Select this option to send files in binary mode. Typically, binary
files are object code or executable files.

Text: Select this option to send files in text mode. When receiving files,
single LF characters are converted to CRLF. When sending files, you can
select the end of line character. See Send End Of Line As under Send
Options in the File Handling page.
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Text File Extensions: Specify the file extensions you want to identify as
text files. This option is available only if File Type Automatic is selected.

Scan File Contents To Determine Type: Select this option to read a
portion of the file to determine if it contains any 8-bit or control codes. If
it does, use binary for the file type. This option is available only if File
Type Automatic is selected.

The FTP Connect Dialog Box

The FTP Connect dialog box is displayed when you attempt to make an
FTP connection, if you selected Prompt For Host When Connecting in the
FTP General page.

Information you supply in the FTP Connect dialog box is used only for
the current connection.

The FTP Connect dialog box

Host: Type the name or IP address of the host to which you want to
connect, or select a Host name from the list. The list displays up to four of
your most recently used Host names, a double line separator, and the
Host names in the Windows Sockets Hosts File if it exists. The Host name
you type does not have to be one of those displayed in the list.

Login Information

User ID: Provides a space for you to type your user name.

Password: Provides a space for you to type your password. This
password is encrypted when it is saved as part of your session
configuration.

Account: If the host requires your account name before you can log
on, type your account name here.

FTP Port: Specifies the number of your host’s FTP port and provides
a space for you to change it. The usual FTP port is 21.



Using
HotSpots
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XTRA! HotSpots let you associate host functions, macros, or
commands with a specific area or text that appears in the terminal

area of a display session. Afterwards, you can use your left mouse button
to select that area or text to carry out the function, macro, or command.
The area you specify is known as a HotSpot. You can create and use
HotSpots individually within a session, or as a group or scheme and then
associate that scheme with any session or host screen.

Using HotSpots, you can create shortcuts that will decrease the time it
takes to finish your tasks. Here is how you can accomplish this. A region
HotSpot is a HotSpot that is associated with an area on the display screen
and has an action assigned to it. Let’s say you use Notepad a lot during
your day. If you assign the action of opening Notepad to a region
HotSpot, whenever you double-click the region using the left mouse
button, Notepad opens. This replaces all the steps you would have to go
through to open Notepad the conventional way.

Text HotSpots and Region HotSpots
Text HotSpots are specific words or characters that have an action
assigned to them. Each time that word or character occurs on your
display screen, you can double-click it to perform an action.

Region HotSpots are areas on the display screen that you define. They
also have an action assigned to them and that action will execute when
you double-click anywhere in the region.

Using a HotSpot
HotSpots can be enabled or disabled. They can also be visible or invisible,
but as long as they are enabled, visible or not, you can use them to
execute an action.

Note: If you define a region HotSpot that is out of the display area, it gets
clipped off or doesn’t show at all if the boundaries are completely
outside the display area.

E
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HotSpot Hierarchy
HotSpots can overlap, which means that there are some rules about
which HotSpot takes precedence over another. Text HotSpots take
precedence over region HotSpots. For example, if you have a text
HotSpot sitting in the middle of a region HotSpot, when you double-click
it, the action assigned to the text HotSpot executes. As for region
HotSpots that overlap one another, the first region HotSpot you create
takes precedence over the next one created and so on.

Adding and Editing HotSpots
You use the HotSpot Properties page, to add or edit HotSpots. The
appearance of the Properties page changes depending on which type of
HotSpot you are working with. For more information about the
Properties page as it pertains to text and region HotSpots, see “The
Add/Edit Properties Page - Text” and “The Add/Edit Properties Page -
Region” later in this chapter.

The Add/Edit HotSpot Properties Page - Text

You use the Text version of the HotSpot Properties page to add or edit a
text HotSpot and define its properties.

Add/Edit HotSpot Properties Page - Text
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HotSpot Text: Type the character(s) or word(s) that you want to use as a
HotSpot.

If you selected characters or words on the session window before
accessing this dialog box, your selection appears in this text box
automatically.

If Only Valid At is cleared, the text for the HotSpot must be unique
within the session or scheme.

Type: Select the type of HotSpot to create: a text HotSpot or a region
HotSpot.

The available options changes, depending on your choice of HotSpot
type.

Text: Creates a text-type HotSpot.

Region Option Button: Creates a region-type HotSpot.

Options (text): Select options you want to apply to your text HotSpot.

Only Valid At: Specify that text should be a HotSpot only if it occurs
in a specific row or column.

If you select this option, you must specify the row or column number
in the adjacent text boxes, otherwise text will be a HotSpot wherever
it occurs in the session window.

Case Sensitive: Specify that text should be a HotSpot only if it
appears in the same combination of lowercase and uppercase
characters as specified in the Text text box.

Text is Preceded by a Space: Specify that text should be a HotSpot
only if it is preceded by a space or field delimiter.

Text is Followed by a Space: Specify that text should be a HotSpot
only if it is followed by a space or field delimiter.

Auto-invoke When Text appears on Display: Actions associated
with this HotSpot are invoked whenever the HotSpot appears in the
session window.

Row: Type the row number where the specified text must occur in
order to be a HotSpot. Available when you also select the Only Valid
At option.

Column: Type the column number where the specified text must
occur in order to be a HotSpot. Available when you also select the
Only Valid At option.
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To add or edit text HotSpots

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Assignments Tab.

4. If you want to add a new HotSpot, choose the Add button.

-or-

If you want to edit a HotSpot, select the HotSpot from the Defined
HotSpots list and choose the Edit button.

The Properties page appears.

5. If you want to add a text HotSpot, choose the Text option button and
type the name of the HotSpot text in the HotSpot Text box. Then
select the options you want and choose Apply or OK.

-or-

If you want to edit a text HotSpot, change the options you want and
choose Apply or OK.

Note: You can also access the HotSpots Settings pages directly using
the View menu.
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The Add/Edit HotSpot Properties Page - Region

Use this dialog page to add or edit a region HotSpot and define its
properties.

You can change the following options or attributes:

Add/Edit HotSpot Properties Page - Region

HotSpot Name: Type the character(s) or word(s) to use as a HotSpot.

If you selected characters or words on the session window before
accessing this dialog box, your selection appears in this text box
automatically.

If Only Valid At is cleared, the text for the HotSpot must be unique
within the session or scheme.

Text: Select the type of HotSpot to create.

This dialog box changes, depending on whether the HotSpot is a text
HotSpot or a region HotSpot.
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Region: Select the type of HotSpot to create.

This dialog box changes, depending on whether the HotSpot is a text
HotSpot or a region HotSpot.

Region Description: Type the coordinates of your region HotSpot.

Upper Left Corner at Row and Column: Type the row and column
number where the upper left corner of the HotSpot occurs.

Lower Right Corner at Row and Column: Type the row and column
number where the lower right corner of the HotSpot occurs.

To add or edit region HotSpots

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Assignments Tab.

4. If you want to add a new HotSpot, choose the Add button.

-or-

If you want to edit a HotSpot, select the HotSpot from the Defined
HotSpots list and choose the Edit button.

5. If you want to add a region HotSpot, choose the Region option
button and type the name of the HotSpot identifier text in the
HotSpot Name box, then select the options you want and choose
Apply or OK.

-or-

If you want to edit a region HotSpot, change the options you want
and choose Apply or OK.
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The Add/Edit HotSpot Action Page

Add/Edit HotSpot Action Page

From this page, the user can assign (or edit an assigned action) to a text
or region HotSpot. Actions can include executing menu commands,
macros, or functions, or starting applications. The options available
depends on the Catagory and Command selected.

Actions are divided into categories. HotSpot you can see and assign at
any one time are defined by the category you have selected. You may
have to supply additional information in order to assign some actions,
such as the keystroke to send for a SendKeys command.

Category: Choose the type of action to perform. The actions in the
Commands list box change, depending on the Category selected.

Commands: Choose the action to perform. Depending on which action
you choose, the dialog box might prompt you for additional information.
For example, if you click Run Application, you must specifiy which
program to run. If you click Send Keystrokes, you must specify which
keystrokes to send.

Description: Displays a description of the selected command.

Application: Type the name of the application to run, including the drive
and directory where the application is located. If desired, click the
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Browse button to display the Browse dialog box, then select the desired
application from the list of available applications.

Scheme/Session/Page: When this box is labeled Scheme, it displays a
drop-down menu of the available schemes this action can load.

When this box is labeled Session, it displays a drop-down menu of the
available session profiles this action can load.

When this box is labeled Page, it displays a drop-down menu of the
recorded host screen pages to which this action can navigate.

Macro: Type the name of the macro to run, including the drive and
directory where the macro is located. If desired, click the Browse button
to display the Browse dialog box, then select the desired macro from the
list of available macros.

Page: Select the name of the host screen to which to navigate.

Keystrokes: Type the keystroke(s) to be performed. You can double-click
one or more keystrokes from the Display Keys list box to select them.
When you double-click a keystroke, it appears in the Keystrokes text box.
All control code strings (for example, <BS>, <CR>, or <ESC>) must
include angle brackets.

When EXTRA! encounters a control code string, it checks to see if that
string is among its recognized strings. If the string is valid, EXTRA!
passes the corresponding control code character to the display session. If
the string is not valid, EXTRA! passes the string directly to the display
session so that the display session can determine if it is a valid keystroke
string for that display session.

If you do not want EXTRA! to interpret the control code string, you must
include an accent grave (‘) in front of the string.

Display: Choose the Display type from the drop-down list.

Display Keys: Double-click the keystroke(s) to add to the Keystrokes text
box.
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To assign or edit a HotSpot action

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Assignments tab.

4. Follow the procedure to add a HotSpot.

-or-

Select a HotSpot from the Defined HotSpots box and choose the Edit
button.

5. Select the Action tab.

The Action page appears.

6. Select the appropriate Category from Category list.

7. Select the appropriate command that you want to assign to the
HotSpot from the Command list.

Other text boxes may appear depending on what you have chosen.

8. Type in the information and choose OK.

To use a HotSpot

• Double-click the defined HotSpot area of the display window and
the action assigned to the HotSpot will execute.

If you have selected Auto-invoke When Text Appears on Display on
the HotSpot Properties page, the action will execute as soon as the
display session appears in the window.

The HotSpots Settings Assignments Page

You can use the Settings - HotSpots, Assignment page to add, edit, or
delete HotSpots. You can view the current HotSpot assignments, save the
existing settings as a scheme, and delete HotSpot schemes.

You can change the following options or attributes:
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The Settings - HotSpots Assignments Page

Scheme: Select the scheme that you want to apply, edit, or delete.

The HotSpots associated with the selected scheme appear in the Defined
HotSpot box.

Save As: Saves the current list of HotSpots as a scheme. Use to copy
defined HotSpots as a new scheme.

Delete: Deletes the selected scheme. All HotSpots associated with that
scheme are deleted.

Defined HotSpots: Lists the HotSpots that have been defined for during
the current session or the selected scheme.

To edit or delete a HotSpot, select the desired HotSpot in this list and
choose Edit or Delete.

Add Button: Add a HotSpot to the session or selected scheme.

Edit Button: Edit the HotSpot selected in the Defined HotSpot list.

Delete Button: Delete the HotSpot selected in the Defined HotSpot list.
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To delete a HotSpot

This page has the following fields:

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Assignments tab.

4. In the Defined HotSpots box, select the HotSpot you want to delete.

5. Choose the Delete button below the Defined HotSpots box.

Using HotSpot Schemes
A collection of individual HotSpots grouped together and then named is
called a scheme of HotSpots. You can apply a scheme to as many display
sessions as you choose. This is different than an individual HotSpot,
which can only be applied to the session in which it is created.

You can also apply a scheme to an individual host screen. Whenever you
access that host screen{bmc emdash.bmp}  regardless of the navigation
method used{bmc emdash.bmp}  the HotSpot scheme you specify will
be automatically enabled.

To create a scheme of HotSpots

1. Create the HotSpots you want to have in your scheme.

For more information about creating HotSpots, see “To add or edit
text HotSpots” and “To add or edit region HotSpots” above.

2. Choose the Save As button.

The Save Scheme dialog appears.

3. Enter a name for the scheme in the Save This Scheme As box.

4. Select from the Local Copy or Remote Copy options depending on
where you want the scheme file to be saved, then choose OK.
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To edit a scheme of HotSpots

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Assignments tab.

4. In the Scheme list box, select the scheme you want to edit.

5. In the Defined HotSpots box, select the HotSpot(s) you want to
change and choose Edit.

6. When you are finished making changes to the HotSpot(s) in the
scheme, choose OK.

To delete a scheme of HotSpots

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Assignments tab.

4. In the Scheme list box, select the scheme you want to delete.

5. Choose the Delete button.

All the HotSpots in that scheme are deleted.

To apply a HotSpot scheme to a host screen

1. From the Tools menu, select Record Pages.

EXTRA! is now in Record Pages mode. Any page that you move to
will be recorded.

If the host screen page that you want to add a HotSpot scheme to is
already recorded, skip this step and the next step.

2. Enter a Page Name for the host screen, or leave the name as the
default, and select the Stop button.

EXTRA! is no longer in Record Pages mode.

3. From the Tools menu, select Page Settings.

The Page Settings dialog box opens, with all recorded pages for this
session listed in their groups on the left.

4. Select the Page Name from the list and choose the Settings tab.

5. Under the Available Settings list, open the folder labeled HotSpots.



User’s Guide

7-14

6. Highlight the desired HotSpot scheme and choose the Add button to
add the scheme to the host screen.

7. Choose OK to save your changes.

Every time you access the recorded page--regardless of navigation
method--the HotSpot scheme you specify will be enabled.

Displaying HotSpots
HotSpots have many states; they can be enabled, disabled, visible, or
invisible. When they are visible, you can choose their appearance. When
they are invisible, the mouse pointer still turns into a pointing hand
when it is over a HotSpot.

Visible text HotSpots can appear on the screen in three ways: outline
rectangle, recessed panel, and filled rectangle. Visible region HotSpots
can appear as outline rectangles or recessed panels.

Note: The recessed panel option works well only when you have your
display colors set in the mid-range. If your background color is black or
white, you will only see part of the recessed panel.

The Settings - HotSpots General Page

You can use the Settings - HotSpots, General Page to set HotSpots. on or
off, determine how HostSpots will look (both Text and Region) and how
they are activated.

You can change the following options or attributes:
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Settings - HotSpots General Page

Enable HotSpots check box: Enables HotSpots.

When HotSpots are enabled, the mouse pointer turns into a pointing
hand when it is over a HotSpot.

Region HotSpot Style: Determines (along with Text HotSpot Style) how
HotSpots will appear in the client area:

Text HotSpot Style box: Determines (along with Region HotSport Style)
how HotSpots will appear in the client area.

Note: The recessed panel option works well only when you have your
display colors set in the mid-range. If your background color is black or
white, you will only see part of the recessed panel.

Single-click: Activates the HotSpot (when the pointer is on the HotSpot)
with a single-click of the mouse.

Double-click: Activates the HotSpot (when the pointer is on the
HotSpot) with a double-click of the mouse.

Enable QuickFields check box: Enables or disables all QuickFields.
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When QuickFields are enabled, all enterable (unprotected) fields are
highlighted for easy recognition. If you clear this option, all QuickFields
will be disabled.

To enable HotSpots

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Enable HotSpots check box, then choose Apply or OK.

To disable HotSpots

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Clear the Enable HotSpots check box and choose Apply or OK.

To enable QuickFields

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Select the Enable QuickFields check box, then select the Enable
HotSpots check box.

4. Choose Apply or OK.

To disable QuickFields

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. Clear the Enable QuickFields check box and choose Apply or OK.
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To set a HotSpot display style

1. From the Options menu, choose Settings.

2. From the Categories list, select HotSpots.

3. On the General page, select the option that indicates how you want
to display all region HotSpots.

4. Select the option that indicates how you want to display all text
HotSpots.

5. Choose Apply or OK.

Securing HotSpots
When you secure HotSpots, it removes HotSpots from the Categories list
in the Options Settings dialog box. The user can no longer create
HotSpots or HotSpot schemes.
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erminal and PC keyboards have different sets of keys. For example,
many terminal keyboards have a Transmit key, PC keyboards do not.

To enable your PC to communicate with a host in the same way as a
terminal, EXTRA! uses a “keyboard map” which substitutes a PC key (or
combination of keys) for the terminal function. For example, you might
perform the function associated with the Transmit key by pressing the
plus (+) key on the PC’s numeric keypad.

You can use the default keyboard map, pick from a list of pre-made
maps, or create your own. In either case, you can assign different maps to
each session. (Initially, each session uses the default keyboard map.)

Loading a Keyboard Map
EXTRA! offers several pre-made keyboard maps. You can also create
your own maps or modify existing ones. You can assign any one of these
keyboard maps to a particular session from a list in the Settings -
Keyboard Maps dialog box.

Keyboard Map General Page

T
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You can change the following options or attributes:

Select a Keyboard Map: Lists the available keyboard maps to load or
edit.

Edit: Opens the selected keyboard map in the Keyboard Map Editor
where you can add or edit the commands, functions, and macros
assigned to the current keyboard map.

New: Opens a new keyboard map template in the Keyboard Map Editor
for you to create a new keyboard map.

Delete: Deletes the selected keyboard map from the list of available
keyboard maps.

Type Ahead Enable: Allows you to continue typing into the keystroke
buffer while the host is busy. When the host is ready, the keystrokes are
sent to the host.

Timeout Value: Indicates the amount of time (milliseconds) that EXTRA!
will wait before it sends the keystrokes to the host. The maximum value
you can enter is 5000 milliseconds. The default value is 0.

PrintScreen Key Enable: Enables the PrintScreen key to capture just the
client area and not the title bar or toolbar buttons.

To load a keyboard map

1. From any open session, choose the Settings command in the Options
menu.

2. Under Categories, select Keyboard Maps.

3. In the Settings - Keyboard Maps dialog box, select the keyboard map
from the Select a Keyboard Map list.

4. Choose the OK button to assign this keyboard map to the current
session.

Note: The list of available keyboard maps may be limited to the
options defined by your system administrator.
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Viewing a Keyboard Map
You can view the keyboard map associated with the current session. As
you click keys on the keyboard map, the corresponding characters
appear in the session window, or the corresponding actions are taken.

To view a keyboard map

1. Open a session by choosing Open Session from the File Menu.

2. From the View menu, choose Keyboard Maps.

The keyboard map for your keyboard is displayed.

3. Click the keys on the keyboard map to display them in your session,
or to perform actions.

Deleting a Keyboard Map
You can delete a keyboard map from the Settings dialog box or from the
DOS prompt with the proper security authorization. Before deleting a
keyboard map, make sure that it is the map you want to delete.

To delete a keyboard map

1. From the Options menu, choose Settings.

2. Choose Keyboards to display the list of available keyboards.

3. Highlight the keyboard you want to delete.

4. Click Delete.

5. Answer “Yes” to “Are you sure that you want to delete this
Keyboard Mapping?”

The keyboard map you selected is deleted.

Also, from the DOS prompt, you can delete the appropriate .EKM file to
delete a keyboard map.
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Using a Keyboard Map in the APL Mode
You can change your keyboard state from normal to the APL
(Programming Language) mode by using a key that is mapped to the
Toggle Keyboard command in the Action page. By default all 3270
keyboard maps have ALT+BACKSPACE key mapped to the Toggle
Keyboard command in the Action page. You can, however, map any key
to Toggle Keyboard. See “Assigning APL Characters to Keys” for more
information.

Note: If you are installing over an earlier version of EXTRA!, you must
enable the APL option in the Miscellaneous Page of the Settings dialog
box to be able to use your keyboard map in the APL mode. In version 6.2
of EXTRA!, the default for this option is on.

To set a keyboard map to the APL mode

• From the session window, click ALT+BACKSPACE.

You are now in APL mode and “APL” is displayed on the status line
in your session window, and the list of available keyboard maps
displayed in the Settings dialog box is prefaced with APL.

• To return your keyboard map to the normal mode, click
ALT+BACKSPACE again.

Keyboard Map Editor
The Keyboard Map Editor displays a graphic representation of a PC
keyboard. Using the Keyboard Map Editor you can create customized
keyboard maps, or edit existing keyboard maps. You can also load the
keyboard map to use with your sessions. Depending on the security, you
may have only restricted access to the functionality of the Keyboard Map
Editor. You may view or print your keyboard map but you will not able
to remap it. Contact your system administrator for your security options.
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Using the Keyboard Map Editor, you can perform a number of tasks.

• Copy a function or character from one location to another on the
working keyboard map.

For example, if the transmit function may be assigned to the plus (+)
key on the numeric keypad, you can change it to F2 by copying the
function from the current location to the desired location.

• Copy a function or character from the default keyboard map to the
working keyboard map.

The default keyboard map has certain terminal tool-specific functions
associated with various keys. You cannot edit the default keyboard
map, but you can display it while you are creating or editing another
keyboard map. When the default keyboard map is displayed, you
can drag and drop functions from the default keyboard map onto
your working keyboard map.

• Assign a function to a key.

Functions include sending keystrokes, running an application, a
script, or a macro, and performing any function that appears on the
menus, such as connecting to a host, navigating to a host screen,
transferring a file, or printing.

The keys on each map are color-coded. The red keys cannot be mapped;
the black and blank keys can be mapped. In addition, several keystrokes,
such as ALT+SCROLL LOCK, are reserved by Windows functions. These
keys are unavailable for remapping and will always perform their
standard Windows functions. See “Keys Reserved By Windows” later in
this chapter for more information.

You can also undo any editing action you perform, such as deleting a
keystroke.
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Keyboard Map Editor Menu Commands

Keyboard Map Editor

The menu commands for the Keyboard Map Editor are described below.

New: Creates a new keyboard map.

Open: Displays a list of maps for your keyboard type. Selecting from this
list opens an existing keyboard for your EXTRA! session.

Save: Saves the open keyboard. If you edit the default map, you are
prompted to save it under another name to prevent the default map from
being overwritten.

Save As: Saves the open keyboard under a different name.

Exit: Exits the Keyboard Map Editor.

Undo: Reverses the changes made on the keyboard map and restores the
keyboard map editor to the previous state.

Show Defaults: Displays a keyboard map with all the default keystrokes
of the terminal type for the current session.

Keyboard Map Editor Help: Displays the online Help for the Keyboard
Map Editor.
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Displaying the Default Keyboard Map
You can display or hide the default keyboard map for a session. The
default keyboard map contains the default terminal emulation keystrokes
inherent in the emulator.

To display or hide the default keyboard map

1. Open a keyboard map.

2. To display the default keyboard map, from the Edit menu, choose
Show Defaults.

The default keyboard map is displayed. A check mark appears in
front of Show Defaults when the default keyboard map is displayed.

3. To hide the default keyboard map, from the Edit menu, choose Show
Defaults once again.

Opening a Keyboard Map
You can open a keyboard map from a session window or from the
Keyboard Map Editor. The keyboard maps you can open may be limited
depending on the security set up by your system administrator.

To open a keyboard map from the session window

1. Open a session by choosing Open Session from the File Menu.

2. From the Options menu, choose Settings.

3. Choose Keyboard Maps.

4. Double-click the keyboard map that you want to open.

To open a keyboard map from the Keyboard Map Editor

1. From the File menu, choose Open.

2. Complete the Open dialog box by selecting the keyboard map you
want from the list displayed or by entering a filename (.EKM) and
clicking Open.

Since you can have only one keyboard map open at a time, you will
be prompted to save changes to the current keyboard map before the
selected map opens.
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Printing a Keyboard Map
You can print a keyboard map from the Keyboard Map Editor, then you
can:

• print the text description showing a text format listing of the
mappings

• print a graphic view showing a graphic bitmap of the current
keyboard map

• print selected layers (shift-state combinations) in the keyboard map

The Keyboard Map Print Dialog Box

From the Keyboard Map Print dialog box, you can print either a text
description or a graphic view of the keyboard map, and choose shift-state
combinations.

The Keyboard Map Print dialog box

Print Formats: Offers a choice of either printing a text format listing of
the mappings or a graphic view of the current keyboard map.

Text Descriptions: Prints a text format list of the mappings for the
current keyboard map. The list includes the neame of each key, the action
to which it is mapped, and a description of the mapping.

Text Descriptions: Prints a text-format list of the mappings for the
current keyboard map. The list includes the name of each key, the action
to which it is mapped, and a description of the mapping.

Graphic Views: Prints a graphic bitmap of the current keyboard map,
similar to what appears in the editor window.

Layers: Lists all the layers (shift-state combinations) in the keyboard
map.
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Normal: Identifies the keyboard state that has no shifted keys (SHIFT,
CONTROL or ALT) held down.

Shift: Identifies the keyboard state when only the SHIFT key is held
down.

Ctrl: Identifies the keyboard state when only the CONTROL key is
held down.

Alt: Identifies the keyboard state when only the ALT key is held
down.

Shift + Ctrl: Identifies the keyboard state when only the SHIFT and
CONTROL keys are simultaneously held down.

Shift + Alt: Identifies the keyboard state when only the SHIFT and
ALT keys are simultaneously held down.

Ctrl + Alt: Identifies the keyboard state when only the CONTROL and
ALT keys are simultaneously held down.

Shift + Ctrl + Alt: Identifies the keyboard state when SHIFT,
CONTROL and ALT are simultaneously held down.

Help: Choose this to display an overview of this dialog box. For
information on any item in the dialog box, click the question mark in the
upper right corner of the dialog box and then click the desired item.

Setup: Displays the Print dialog box where you can select which printer
to print to, the print range and how many copies to print.

To print a keyboard map

1. To print a text description, from the File menu, choose Print, then
from the Keyboard Map Print dialog box, under Print Formats, select
Text Descriptions.

-or-

To print a graphic view, from the File menu, choose Print, then from
the Keyboard Map Print dialog box, under Print Formats, select
Graphic Views.

2. Under Layers, select specific layers (shift-state combinations) to
print, then choose OK.

Note: From the Keyboard Map Print dialog box you can also choose
the Setup button to display the Print dialog box.
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3. From the File menu, choose Print Setup, then select the desired
printer, the print range, and the number of copies to print, then
choose OK.

Keys Reserved by Windows
Certain keys and key combinations are reserved by Windows or are
translated by the keyboard driver. These keys are unavailable for
remapping. Below is a chart of the keys and key combinations that
cannot be mapped. These keys usually display the name of the key in red
letters or they display a small red square.

The marked columns, in combination with the PC key listed, cannot be
mapped.

PC KEY NORMAL SHIFT CTRL ALT SHIFT+
CTRL

SHIFT+
ALT

CTRL+
ALT

SHIFT+
CTRL+
ALT

TAB

ENTER

SPACE

ESCAPE

PRNT SCRN

101

PRNT SCRN

84

SCRL LOCK

PAUSE

NUM LOCK

Keys Reserved by Windows
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Creating a Keyboard Map
You can create a new keyboard map from a session or from the Keyboard
Map Editor.

To create a keyboard map from a session

1. Open a session (if not already open) by choosing Open Session from
the File Menu.

2. From the Edit or Options menu, choose Settings.

3. Choose Keyboard Maps.

4. Click New.

5. Double-click the key you want to assign a function to and complete
the Action page. (See instructions for assigning functions to keys.)

You can also display the default map and copy functions to the new map.
You can save the map under a new name, if you wish.

To create a keyboard map from the Keyboard Map Editor

1. Display an existing keyboard map from the Settings dialog box.

2. From the File menu, choose New or click the New button.

The Keyboard Map Editor displays a new keyboard.

3. Create your new keyboard map by assigning functions to keys. (See
instructions on assigning functions to keys.)

4. Save your keyboard map when prompted.

Copying a Function
You can copy the key functions from the working keyboard map and/or
from the default keyboard map.

To copy a function on the working keyboard map

1. Open a keyboard map.

2. Click the key whose function you want to copy. Hold the button until
the cursor turns from an arrow to a black key with a plus (+) sign.

Note: If you are copying a combination keystroke (for example, a
keystroke preceded by a SHIFT, ALT, or CTRL), be sure to press the
SHIFT, ALT, or CTRL key before clicking the key.
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3. Drag the function to the desired key and release the mouse button.

The new function overwrites any function currently assigned to the
key.

Note: If you are assigning the function to a combination keystroke
(for example, a keystroke preceded by a SHIFT, ALT, or CTRL), be sure
to press the SHIFT, ALT, or CTRL key before releasing the mouse
button.

To copy a function from the default keyboard map

1. Open a keyboard map.

2. Display the default keyboard map by choosing Show Defaults from
the Edit menu.

3. Click the key on the default keyboard map whose function you want
to copy. Hold the button until the cursor turns from an arrow to a
black key with a plus (+) sign.

Note: If you are copying a combination keystroke (for example, a
keystroke preceded by a SHIFT, ALT, or CTRL), be sure to press the
SHIFT, ALT, or CTRL key before clicking the key.

4. Drag the function to the desired key on the working keyboard map
and release the mouse button.

The new function overwrites any function currently assigned to the
key.

Note: If you are assigning the function to a combination keystroke
(for example, a keystroke preceded by a SHIFT, ALT, or CTRL), be sure
to press the SHIFT, ALT, or CTRL key before releasing the mouse
button.
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Assigning Keyboard Map Actions
You can use the Action page to assign an action for a key on a keyboard
map. Select the Send Keys from Commands in the dialog box to specify
the keystrokes you want to send to the host.

Key Properties dialog box Action page

Category: Performs the function when you click the name of the menu or
category. Select Miscellaneous for keyboard maps.

Commands: Performs the action you click on. Click Send Keys to specify
the keystrokes to send to the host.

Description: Describes the command highlighted in Commands.

Keystrokes: Displays the keystroke you double-clicked on the keyboard
map.
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Display: Displays the terminal type.

Display Keys: Displays the keys associated with the terminal display.

OK button: Assigns the function you selected in Display Keys to the
keystroke in Keystrokes.

Cancel button: Closes the Action page without any saving any changes.

Apply button: Applies the function to the key.

Help: Displays the Help for the Action page.

To assign an action to a key

1. Open the keyboard map.

2. Double-click the key to which you want to assign an action.

The Key Properties dialog box Action page is displayed.

Key Properties Dialog Box, Action Page

Note: If you are assigning the function to a combination keystroke
(for example, a keystroke preceded by a SHIFT, ALT, or CTRL), be sure
to press the SHIFT, ALT, or CTRL key before double-clicking the key.
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3. Choose Send Keys in Commands to specify the keystrokes to send.

Keystrokes shows the key you selected on the keyboard.

4. Double-click the function you want the key to perform in Display
Keys.

The function is displayed along with the key you chose in
Keystrokes.

5. Click OK.

6. Repeat the above steps for assigning actions to other keys and save
the keyboard map.

Assigning APL Characters to Keys
You can use APL characters from a normal keyboard, even when you are
not in the APL mode by mapping keys to APL characters in the Action
page.

To assign an APL character to a key

1. From the Keyboard Map Editor, double-click on the desired key.

2. From Category, choose Miscellaneous.

3. From Commands, choose Send Special Keys.

The Key Properties dialog box Action page is displayed.

4. From Keystrokes, choose the desired APL character.

5. Click OK.

Mapping Keys to Toggle to APL Mode
In all 3270 keyboard maps, the ALT+BACKSPACE key is mapped by
default to toggle the APL mode on and off. You can, however, assign the
Toggle Keyboard command to any key you want.

To map a key to toggle to the APL mode

1. From the Keyboard Map Editor, double-click on the desired key.

2. From Category, choose Miscellaneous.

3. From Commands, choose Toggle Keyboard.

4. Click OK.

The key now toggles your keyboard map on and off the APL mode.
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Deleting a Function
You can delete a function that is currently assigned to a key.

To delete a function for a key

1. Open a keyboard.

2. Double-click the key whose function you want to delete.

The Key Properties dialog box Action page is displayed.

Note: If you are deleting a combination keystroke (for example, a
keystroke preceded by a SHIFT, ALT, or CTRL), be sure to press the
SHIFT, ALT, or CTRL key before clicking the key.

3. In Keystrokes, highlight and delete the function currently assigned to
key only (not the key).

4. Click OK.

Saving a Keyboard Map
You can save an existing keyboard map, a new keyboard map, or an
existing keyboard map under a new name.

To save a keyboard map

• From the File menu, choose Save to save an existing keyboard map.

The keyboard map is saved under its current name and remains open
until you close it.

• From the File menu, choose Save As and complete the dialog box to
save a new keyboard map or to save an existing menu under a
different name.

The keyboard map remains open until you close it.
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Exiting the Keyboard Map Editor
You can exit the Keyboard Map and if you want, save the changes made
to the keyboard map.

To exit the Keyboard Map Editor

• Choose Exit from the File menu.

You will be prompted to save any changes you made to the keyboard
map.
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ome of the most common tasks performed in an EXTRA! session can
be simplified by using the QuickPads and toolbars provided with the

product or by creating your own QuickPads and toolbars. Using
QuickPads, you can create a custom tool that includes pictures or text to
assist you in using it. Using toolbars, you can perform tasks with a
familiar type of tool.

This chapter tells you how to attach QuickPads and toolbars into your
sessions, create new ones, and edit existing ones. The QuickPads section
is first, followed by the Toolbars section.

QuickPads
A QuickPad is a customized window with text, buttons, bitmaps, icons,
or other graphic elements that allow you to quickly perform basic
actions. EXTRA! includes some sample QuickPads for you to use, or you
can create your own. QuickPads can be any shape or size, and as simple
or as complex as you want.

The buttons and icons on QuickPads can perform the following tasks:

• Send keystrokes to the host

• Run a macro

• Run an application

• Assign a scheme

• Perform any function that can be performed using EXTRA! menus

Basically, QuickPads can help you perform tasks that are hard to
remember or that you routinely repeat. They are also useful if you prefer
using a mouse instead of the keyboard.

This section covers the following topics:

• Attaching QuickPads your host session or page

• Creating new QuickPads

• Customizing existing QuickPads

• Setting Security for QuickPads

S
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Attaching QuickPads
To use a QuickPad, you must attach it to a session or an individual host
screen.

When you open a QuickPad and then save the session, that QuickPad
will load automatically the next time you open that session. The
QuickPad will remain visible on any host screen until you remove it. You
can attach multiple QuickPads for each session.

You can also attach a QuickPad to an individual host screen in a session.
Any time you access that host screen, regardless of how you navigated to
the screen, the QuickPad will load automatically.

EXTRA! includes several predefined QuickPads that are ready to attach
and use. You can use or edit predefined QuickPads or create your own.

To attach a QuickPad to a session

1. From the View menu, choose QuickPads.

The Settings dialog box appears, with the QuickPads category
selected, and a list of available QuickPad schemes displayed. You can
select more than one QuickPad to be loaded during a session.

2. Select the check boxes for the QuickPads that you want to load; clear
the check boxes for the QuickPads you don’t want to use.

To attach a QuickPad to a host screen

1. From the Tools menu, choose Record Pages.

EXTRA! is now in Record Pages mode. Any page that you move to
will be recorded.

If the host screen page to which you want to add a QuickPad is
already recorded, skip this step and the next step.

2. Navigate to the host screen where you want the QuickPad to appear.

3. In the Record Pages control bar, type a name for the host screen, or
leave the default name, and then click the Stop button.

4. From the Tools menu, choose Page Settings.

The Page Settings dialog box appears, with all recorded pages for
this session listed in their groups on the left.

5. Select the page name in the list, then choose the Settings tab.
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6. From the Available Settings list, open the folder labeled QuickPads.

7. Select the QuickPad you want to use, then click the Add button.

The QuickPad is added to the host screen.

8. Choose OK to save your changes.

Every time you access the recorded page—regardless of navigation
method—the QuickPad you specify will appear.

Toolbars
EXTRA! comes with default toolbars (*.ETB) that appear when you create
a new session or open one of the default sessions.

Toolbars contain buttons that can perform certain actions, when selected
by the user.

You can customize a toolbar in a number of ways:

• Display color or monochrome buttons

• Display large or small buttons

• Show or hide ToolTips

• Rearrange the buttons

• Delete buttons

• Add buttons that can send keystrokes, run macros, run applications,
load schemes, or perform any other function that you can perform
using the EXTRA! menus

• Add or delete spacing between the toolbar buttons

• Move a toolbar from its default position at the top of the screen to
any location lower on the screen to better fit the layout of your screen

You can create multiple toolbars and load different ones for different
sessions. Any toolbar you use is saved as part of the session profile when
you save the session.
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Attaching Toolbars
For you to use a toolbar, you must attach it to an entire session or just an
individual host screen.

When you open a toolbar and then save the session, that toolbar will load
automatically the next time you open that session. The toolbar will
remain visible on any host screen until you remove it. You are allowed to
load multiple toolbars for each session.

You can also attach a toolbar to an individual host screen in a session.
Any time you access that screen, regardless of how you navigated to the
screen, the toolbar will load automatically.

EXTRA! includes predefined toolbars that are already set up and ready
to use. You can use the predefined toolbars, you can edit them, or create
your own to meet your unique needs.

To attach a toolbar to a session

1. From the View menu, choose the Toolbars command.

This displays the Settings dialog box, with the Toolbars category
selected, and a list of available toolbar schemes displayed. You can
select more than one toolbar.

2. Select the name of the toolbar to attach.

You have other options in this dialog box, such as displaying large
toolbar buttons, or choosing between color and monochrome
buttons.

To attach a toolbar to a host screen

1. From the Tools menu, choose Record Pages.

EXTRA! is now in Record Pages mode. Any page that you move to
will be recorded.

If the host screen page to which you want to add a toolbar to is
already recorded, skip this step and the next step.

2. Enter a Page Name for the host screen, or leave the name as the
default, then choose the Stop button.

3. From the Tools menu, choose Page Settings.

The Page Settings dialog box appears, with all recorded pages for
this session listed in their groups on the left.

4. Select the Page Name from the list, then choose the Settings tab.
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5. From the Available Settings list, open the folder labeled Toolbars.

6. Select the desired toolbar, then choose the Add button.

The toolbar is added to the host screen.

7. Choose OK to save your changes.

Every time you access the recorded page—regardless of navigation
method—the toolbar you specify will appear.

QuickPad Settings
Using the Settings - QuickPads General page, you can:

• Specify which QuickPad(s) to attach or unattach for this session

• Create a new QuickPad

• Edit an existing QuickPad

• Select the ToolTips check box to display the title of the button when
pausing over it with the cursor

The Settings - QuickPads General Page
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Toolbar Settings
Use the Settings - Toolbars, General pagebox to select one or more
toolbars to load into a session, add a new toolbar to the schemes list, or
select a toolbar to edit or delete.

You can also choose the following options:

• Display all toolbars with color buttons

• Display all toolbars with large buttons

• Display the title of the button when the cursor pauses over it

Creating and Modifying QuickPads
You can easily create your own QuickPads, or modify existing ones to
suit your needs. EXTRA! comes with several pre-made QuickPads that
provide ready to use functions or ideas you can use in creating your own
QuickPad or Toolbar.

The EXTRA!’built-in QuickPad editors are similar to each other so they
are very easy to use. However, because there are slightly different
functions between QuickPads and Toolbars, their respective editors also
have minor differences.

Creating QuickPads
During a session, you can use the QuickPads that are included with
EXTRA! — you can edit them or create your own using the QuickPad
editor.
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The QuickPad Editor
Using the QuickPad editor, you can perform the following tasks:

• Specify the size, title, color, and layout of the QuickPad

• Add graphic elements such as text, rectangles, group boxes, and
bitmaps

• Add buttons and icons to perform actions such as sending
keystrokes; running an application, script, or macro; and performing
any command that appears on EXTRA! menus, such as connecting to
a host, navigating to a host screen, transferring a file, or printing

• Make single or multiple copies of QuickPad objects

• Align QuickPad objects on a grid

• Resize the QuickPad

• Move layered objects to the foreground or background

To create a QuickPad from a session

1. From the View menu, choose QuickPads.

The Settings dialog box appears, with the QuickPads category
selected, displaying a list of available QuickPad schemes.

2. Choose New.

To create a QuickPad from the QuickPad editor

• On the QuickPad toolbar, click the New QuickPad button.

-or-

• From the File menu, choose New.

Since you can open only one QuickPad at a time, you will be prompted to
save changes to the current open QuickPad before opening the new
QuickPad.

To open a QuickPad to edit from a session window

1. From the View menu, choose QuickPads.

The Settings dialog box appears, with the QuickPads category
selected, and a list of available QuickPad schemes displayed.

2. Select the check box for the QuickPads that you want to change.

3. Choose Edit.
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To open a QuickPad from the QuickPad editor

1. From the File menu, choose Open (or use the Open button on the
toolbar).

2. Choose a QuickPad from the displayed list.

Since you can open only one QuickPad at a time, if you have made
changes to the QuickPad that is currently open, you will be prompted to
save the changes before opening another QuickPad.

Customizing QuickPads
The most powerful feature of the EXTRA! QuickPad is that it allows you
to set up QuickPads according to your needs.

You can customize a QuickPad in the following ways:

• Change the title

• Change the background color

• Add new objects (buttons, icons, group boxes, and so on)

• Move and align objects

QuickPad Properties

One way to customize your QuickPad is to give it a unique name. Using
the QuickPad editor, you can enter a name for your QuickPad. When you
specify a name, try to use a name that helps explain its purpose. For
example, a QuickPad that contains functions for a mail utility might be
named “MAIL.”

You can also choose one of sixteen colors for the background color of
your QuickPad.

The QuickPad Properties Dialog Box

Use this dialog box to assign a title to the QuickPad and set its
background color.
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To name a QuickPad

1. Open a QuickPad.

2. Double-click an empty area of the QuickPad.

-or-

From the Edit menu, choose QuickPad Properties.

3. Enter a name in the Title field.

To set the color of a QuickPad

1. Open a QuickPad.

2. Double-click an empty area of the QuickPad.

-or-

From the Edit menu, choose QuickPad Properties.

3. Select a color from the Background Color list.

To resize a QuickPad

1. Open a QuickPad.

2. Using the left mouse button, click one of the QuickPad handles.
Continue to hold down the mouse button and drag the handle until
the QuickPad is the desired size.

-or-

From the Layout menu, choose Resize to Fit. The QuickPad is
reduced to the smallest size that will still accommodate the objects on
the QuickPad.
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QuickPad Objects
Every object that you can place on a QuickPad has a set of properties.
These properties range in complexity from the bitmap, which has only a
filename, to the buttons, which have a label, a font, and an action.
Typically, you will be assigning actions to objects so that in a session you
can click the QuickPad to perform a function.

The different objects that you can place onto a QuickPad are:

• A labeled button that performs a specific action when clicked

• An outlined or filled-in colored rectangle

• A labeled group box to group a set of objects

• A customized text field

• A bitmap picture (*.BMP file)

• An icon (*.ICO file) that performs a specific action when clicked

• A bitmap button that performs a specific action when clicked

To place an object on a QuickPad

1. Open a QuickPad.

2. From the toolbar, click the type of object to place on the QuickPad:

• Button

• Rectangle

• Group box

• Text

• Bitmap

• Icon

• Bitmap button

3. Move the mouse pointer to the QuickPad. Hold down the left mouse
button and drag the pointer to make the object the desired size.

Objects on a QuickPad can overlap one another. For example, you
can have text overlap a bitmap. Icons on a QuickPad are a fixed size;
they cannot be enlarged or reduced. The size of a bitmap is
determined by the bitmap itself rather than by any action performed
on the QuickPad.

4. Release the mouse button.



User’s Guide

9-12

To create a QuickPad button

1. Open a QuickPad.

2. Click the Button button on the toolbar.

3. Move the mouse pointer to the QuickPad, hold down the left mouse
button and drag the pointer to make the button the desired size, then
release the mouse button.

Note: Objects on a QuickPad can overlap one another.

4. From the edit menu, choose Object Properties.

5. On the Font page, select a font type, size, and style.

6. On the Action page, choose an action Category, then select
Command from the list for that category.

7. On the Label page, type in the text for the button, choose an
accelerator key for the button (optional), and type in a ToolTip label.

8. Choose the OK button.

To create a QuickPad rectangle

1. Open a QuickPad.

2. Click the Rectangle button on the toolbar.

3. Position the mouse pointer on the QuickPad, hold down the left
mouse button and drag the pointer to make the object the desired
size, then release the mouse button.

Note: Objects on a QuickPad may overlap one another.

4. From the Edit menu, choose Object Properties.

5. On the Rectangle page, choose a color and style (outline or filled) for
the rectangle.

6. Choose the OK button.
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To create a QuickPad group box

1. Open a QuickPad.

2. Click the Group box button on the toolbar.

3. Position the mouse pointer on the QuickPad, hold down the left
mouse button and drag the pointer to make the object the desired
size, then release the mouse button.

Note: Objects on a QuickPad can overlap one another.

4. From the Edit menu, choose Object Properties.

5. On the Font page, select a font type, size, and style.

6. On the Label page, type in the text for the group box, choose the
alignment of the text, and choose a color for the group box.

7. Choose the OK button.

To add text to a QuickPad

1. Open a QuickPad.

2. Click the Text button on the toolbar.

3. Move the mouse pointer to the QuickPad, hold down the left mouse
button and drag the pointer to make the object the desired size, then
release the mouse button.

Note: Objects on a QuickPad may overlap one another.

4. From the Edit menu, choose Object Properties.

5. On the Font page, select a font type, size, and style.

6. On the Label page, type in the text for the field, choose the alignment
of the text, and choose a color for the text.

7. Choose the OK button.
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To add a bitmap to a QuickPad

1. Open a QuickPad.

2. Click the Bitmap button on the toolbar.

3. Move the mouse pointer to the QuickPad, hold down the left mouse
button and drag the pointer to make the object the desired size, then
release the mouse button.

Note: Objects on a QuickPad may overlap one another.

4. From the Edit menu, choose Object Properties.

5. Browse and select a bitmap file.

To create a QuickPad icon

1. Open a QuickPad.

2. Click the Icon button on the toolbar.

3. Move the mouse pointer to the QuickPad, hold down the left mouse
button and drag the pointer to make the object the desired size, then
release the mouse button.

Note: Objects on a QuickPad may overlap one another.

4. From the Edit menu, choose Object Properties.

5. On the Icon page, choose an icon listed or browse for another icon
file, choose an accelerator key for the icon (optional), and type in a
ToolTip label.

6. On the Action page, choose an action Category, then select
Command from that category’s list.

7. Choose the OK button.
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To create a QuickPad bitmap button

1. Open a QuickPad.

2. Click the Bitmap Button on the toolbar.

3. Move the mouse pointer to the QuickPad, hold down the left mouse
button and drag the pointer to make the object the desired size, then
release the mouse button.

Note: Objects on a QuickPad may overlap one another.

4. From the Edit menu,  choose Object Properties.

5. On the Action page, choose an action Category, then select
Command from that category’s list.

6. Choose the Customize button to change the bitmap that appears on
the button.

7. On the Bitmap Button page, choose an accelerator key for the button
(optional), and type in a ToolTip label.

8. Choose the OK button.

The Font Page

Using this page, you can specify the font (family), font size, and font style
(such as normal, bold, or italic) to use for the text that appears on the
QuickPad in a text area, on a button, or on a group box label.

Font: Selects the font (family) of the text that appears on the QuickPad
button, text area, or group box label.

Size: Selects the font size for the text that appears on the QuickPad. The
options available vary, depending on which font you select.

Style: Selects the font style (such as normal, bold, or italic) for the text
that appears on the QuickPad. The available options vary, depending on
which font you select.

Sample: Shows an example of how the text will appear on the QuickPad
using the currently selected font, size, and style.
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The Button Dialog Box Label Page

Use this dialog box page to specify the text that appears on the QuickPad
button and an accelerator key to initiate the action associated with this
button.

Text: Defines the text that appears on the QuickPad button.

Accelerator: Defines the accelerator key (or keystrokes) that can be used
to initiate the action associated with the QuickPad button. If you are
using a keyboard map that has defined this keystroke to perform a
different function, the function associated with the keyboard map takes
precedence.

The Rectangle Dialog Box

Use this dialog box to define the properties of the rectangle you are
placing on your QuickPad. You can select a color for the rectangle, and
specify whether the color is to apply to the rectangle as an outline, or if
the color is to fill the rectangle.

Color: Sets the color of the outline or fill color for the rectangle.

Outline: Defines rectangles placed on the QuickPad as outlines. The
interior of the rectangle is transparent.

Filled: Defines rectangles placed on the QuickPad as solid rectangles in
the selected color. The interior of the rectangle is opaque.

The Group Box Dialog Box Label Page

Use this page to specify the text, text color, and text alignment for the top
line of the group box.

Text: Defines the text that appears on the top line of the group box.

Left: Aligns the defined group label text on the left side of the group box.

Center: Aligns the defined group label text at the center of the group box.

Right: Aligns the defined group label text on the right side of the group
box.

Color: Sets the color for the outline of the group box and the group box
text label.
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The Text Dialog Box Label Page

Use this page to specify the font, font size, and font style for text objects
that appear on the QuickPad.

Text: Type the text that you want to appear on the QuickPad.

Left: Aligns all text on the left side of the text object boundary.

Center: Aligns all text in the center of the text object boundary.

Right: Aligns all text on the right side of the text object boundary.

Color: Sets the color for the text objects that appear on the QuickPad.

The Open Bitmap Dialog Box

Use this dialog box to choose a bitmap to display on the QuickPad.

The Icon Dialog Box Icon Page

Use this page to select an icon to place on the QuickPad.

Icon: Selects the icon to be placed on the QuickPad. You can also use the
Browse button to look for other icon resources.

Browse: Searches for other icon resources.

Accelerator: Defines the keyboard accelerator key to initiates the action
associated with the selected icon. If you are using a keyboard map that
has defined this keystroke to perform a different function, the function
associated with the keyboard map takes precedence.

The Bitmap Button Dialog Box Bitmap Button Page

Using this page, you can select the accelerator key combination for the
button you are placing on the QuickPad. You can also enter the text that
appears as the ToolTip when the cursor pauses over the button.

Help Text: Defines the text you want to be used as the ToolTip for this
button.

Accelerator: Defines the accelerator key (or keystrokes) that can be used
to initiate the action associated with the QuickPad icon. If you are using a
keyboard map that has defined this keystroke to perform a different
function, the function associated with the keyboard map takes
precedence.

ToolTip: Defines the text that appears when the user pauses the cursor
over the button.
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To select a QuickPad object

1. Open a QuickPad.

2. Select an object using one of the following methods:

To select Do this

A single object Click the desired object.

Multiple objects Hold down the SHIFT key and click each
object.

All objects From the Edit menu, choose Select All.

The appearance of handles indicates that the object is selected.

To edit a QuickPad object

1. Open a QuickPad.

2. Double-click the object that you want to modify and complete the
dialog box associated with that object.

–or–

Select the object that you want to modify, choose Object Properties
from the Edit menu, and complete the dialog box associated with
that object.

To move a QuickPad object

1. Open a QuickPad.

2. Select the object that you want to move.

You can move one QuickPad object at a time, or you can select
multiple objects and move all of them at once.

3. Place the mouse pointer anywhere on the object except on the
handles and hold down the left mouse button.

4. Drag the object until it is positioned where you want it on the
QuickPad, then release the mouse button.
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To rearrange a QuickPad object

1. Open a QuickPad.

2. Select the object that you want to move.

3. From the Arrange menu, click the action you want to perform on the
selected object:

Choose To move the selected object

Move Forward One step closer to the front of a stack of objects.

Move to Front To the front of a stack of objects.

Move Backward One step toward the back of a stack of objects.

Move to Back To the back of a stack of objects.

To resize a QuickPad object

1. Open a QuickPad.

2. Select the object that you want to resize.

You can resize any object except icons, which are always a fixed size.

In addition, the size of any bitmap is determined by the bitmap
rather than by any action performed on the QuickPad.

3. Using the left mouse button, click one of the object handles. Hold
down the mouse button and drag the handle until the object is the
desired size.

To delete a QuickPad object

1. Open a QuickPad.

2. Select the object that you want to delete.

3. Press the DELETE key.

–or–

From the Edit menu, choose Clear.
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To cut a QuickPad object

1. Open a QuickPad.

2. Select the object(s) that you want to cut.

3. From the Edit menu, choose Cut.

The selected object is removed from the QuickPad, but remains in the PC
Clipboard until you cut or copy a different object.

To copy a QuickPad object (one copy) using the mouse

1. Open a QuickPad.

2. Select the object(s) that you want to copy.

3. Position the cursor anywhere on the object except the handles.

4. Press and hold down the CTRL key, hold down the left mouse button,
and drag the copy to the desired location.

5. Release the CTRL key and the mouse button.

The copy has all the attributes of the original object, except for the
label associated with that object (if any). For example, if you copy a
button named Transmit, the copy will be the same size and perform
the same function, but the label on the button might be Button1.

6. If you are copying a button, group box, or text object, double-click
the copy and type a new label for the object.

To copy a QuickPad object (one copy) using the keyboard

1. Open a QuickPad.

2. Select the object that you want to copy.

3. From the Edit menu, choose Copy.

4. From the Edit menu, choose Paste.

5. Drag the copied object to the desired location.

The copy has all the attributes of the original object, except for the
label associated with that object (if any). For example, if you copy a
button named Transmit, the copy will be the same size and perform
the same function, but the label on the button might be Button#.

6. If you are copying a button, group box, or text object, double-click
the copy and type a new label for the object.
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To copy a QuickPad object (multiple copies)

1. Open a QuickPad.

2. Select the object that you want to copy.

3. Position the pointer on one of the handles of the object.

4. Press and hold down the CTRL key, hold down the left mouse
button, and drag the handle of the object. The handles disappear, and
a dotted square surrounds the object. As you drag the square, it
becomes filled with copies of the selected object.

5. Drag the dotted square until it contains the desired number of copies.

6. Release the CTRL key and the mouse button. The dotted square
disappears, and all the duplicate objects are selected.

The copies have all the attributes of the original object, except for the
label associated with that object (if any). For example, if you copy a
button named Transmit, the copies will be the same size and perform
the same function, but the labels on the buttons might be Button1,
Button2, and so on.

7. If you are copying a button, group box, or text object, double-click
each copy and type a new label for the object.

To paste a QuickPad object

1. Open a QuickPad.

2. Select the desired QuickPad object.

3. From the Edit menu, choose either Cut or Copy.

4. From the Edit menu, click Paste and drag the object to the desired
location.

You can paste a cut or copied QuickPad object in a different location or in
a different QuickPad.

The QuickPad Grid
The QuickPad grid helps you align objects within a QuickPad. With the
grid enabled, horizontal and vertical lines appear over your QuickPad in
a grid formation. This grid does not appear on the saved QuickPad, it
only appears in the QuickPad editor. This section shows you how to
enable and disable the grid, modify the spacing of the grid lines, and
how to align your objects using the grid.
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The Grid Settings Dialog Box

Using this dialog box, you can specify the grid spacing on a QuickPad.
The smaller the values you enter into this dialog box, the more flexibility
you have in placing QuickPad objects. A larger grid spacing might help
you align objects more easily on the QuickPad.

To change the QuickPad grid spacing

1. Open a QuickPad.

2. From the Layout menu, choose Grid Settings.

3. Complete the Grid Settings dialog box.

For information about any item on this dialog box, click the Help button
in the upper right corner of the dialog box and then click the desired
item.

To show or hide the QuickPad grid

1. Open a QuickPad.

2. From the Layout menu, choose Show Grid.

A check mark appears next to this command when the grid is displayed.

To align a QuickPad object to the grid

1. Open a QuickPad.

2. From the Layout menu, choose Show Grid.

Displaying the grid will give you a better idea of where the objects
will be positioned. The closer the spacing on the grid, the more
flexibility you have for placing objects on the grid. The looser the
spacing on the grid, the easier it is to align objects because there are
fewer grid lines to align to.

3. (Optional) To change the grid settings, choose Grid Settings from the
layout menu, then enter the desired settings.

4. Select the objects that you want to align. To choose more than one
object, hold down the SHIFT key and click the objects.

5. From the Layout menu, choose Snap to Grid. Drag any objects that
you want to reposition.
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Saving QuickPads
You can save a QuickPad using the current name, or you can save a
QuickPad under a new name and in a new directory. This section
provides instructions for both methods, , and explains how to exit the
QuickPad editor.

To save a QuickPad

1. Click the Save button on the toolbar.

–or–

From the File menu, choose Save.

2. If you are saving a new QuickPad, complete the Save As dialog box.

–or–

If you are saving an existing QuickPad, the QuickPad is saved under
its current name and remains open until you close it.

To save a QuickPad under a different name

1. From the File menu, choose Save As.

2. Complete the Save As dialog box.

The QuickPad remains open until you close it.

To exit the QuickPad editor

• From the File menu, choose Exit.

–or–

• From the Control menu, choose Close.

–or–

• Double-click the Control-menu icon.

–or–

• Press ALT+F4.

You will be prompted to save changes you have made to the open
QuickPad. If EXTRA! is being run programmatically by another
application, EXTRA! closes when you close the last open session or
editor.
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QuickPad Security
You can  restrict access to QuickPad Settings, and, in doing so, to restrict
access to the QuickPad editor. If you clear the check boxes for the
QuickPads command in the Security Action dialog box, the command
will no longer be available from the View menu.

To set QuickPad security

1. From the Options menu, choose Security.

The Security dialog box appears.

2. Select the security scheme you want to edit. The name of the security
scheme is listed in the Scheme field. Click Browse if you want to
select a different scheme.

3. Choose the Options tab.

4. If asked for a password, enter the password in the Security Password
dialog box, then click OK.

5. From the Category list, choose View.

6. In the Commands list, clear the QuickPads check box.

7. To save the scheme, from the File page, click Save As.

Creating and Modifying Toolbars
You can easily create your own Toolbars, or modify existing ones to suit
your needs. EXTRA! comes with several pre-made Toolbars that provide
ready to use functions or ideas you can use in creating your own Toolbar.

EXTRA!’s built-in QuickPad and Toolbar editors are similar to each other
so they are very easy to use. However, because there are slightly
different functions between QuickPads and Toolbars, their respective
editors also have minor differences.
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Creating Toolbars
During a session, you can use the toolbars that are included with EXTRA!
— you can edit them or create your own using the Toolbar editor.

The Toolbar Editor
During a session, you can use one of the default toolbars that come with
your emulator, or you can edit one of them or create your own using the
Toolbar editor.

Buttons on the toolbar can be large or small, color or black-and-white.
They can be configured to send keystrokes, run a macro, or perform any
command that appears on EXTRA! menus, such as connecting to a host,
accessing a host screen, transferring a file, or printing.

With the Toolbar editor, you can perform the following tasks:

• Specify the size and appearance of the toolbar buttons

• Add, delete, cut, copy, and paste the functions of toolbar buttons

• Rearrange the buttons on the toolbar

• Add or delete spacing between the toolbar buttons

• Resize the toolbar to fit the toolbar buttons

To create a new toolbar

1. From the View menu, choose the Toolbars command.

This displays the Settings dialog box with the Toolbars category
selected, and a list of available toolbar schemes displayed. You can
select more than one toolbar to be loaded during a session.

2. Select a toolbar from the list.

3. Choose the New button.

The Toolbar editor runs, displaying an untitled toolbar.
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To open an existing toolbar

1. From the View menu, choose Toolbars.

This displays the Settings dialog box with the Toolbars category
selected, and a list of available toolbar schemes displayed. You can
select more than one toolbar to be loaded during a session.

2. Select a toolbar from the list.

3. Choose the Edit button.

–or–

Double-click the toolbar that you want to edit.

The Toolbar editor runs, displaying the selected toolbar.

Customizing Toolbars
The EXTRA! Toolbar editor allows you to set up toolbars according to
your needs.

You can customize a toolbar in the following ways:

• Change the title

• Change the buttons from color to monochrome

• Change the size of the buttons

• Add and remove buttons

• Move buttons

Toolbar Properties

Toolbar properties affect the toolbar as a whole. One way to customize
your toolbar is to give it a unique name. Using the Toolbar editor, you
can enter a title for your Toolbar.

You can also choose color or monochrome, or you can change the size of
the buttons.

The Toolbar Title Dialog Box

Using this dialog box, you can assign a title to the toolbar that will be
visible whenever the toolbar is undocked from the application window.

Title: Type in the title that you want displayed at the top of the toolbar
when it is loaded during a session and undocked.

Help: This button displays Help for the dialog box.



Using QuickPads and Toolbars

9-27

To set a toolbar’s title

1. Open a toolbar.

2. Double-click an empty area of the toolbar.

–or–

From the Edit menu, choose Toolbar Properties.

3. Type the desired title into the Toolbar Properties dialog box.

4. Choose the OK button.

To set the color of a toolbar

1. In the EXTRA! main window, choose Toolbars from the View menu.

This displays the Settings dialog box with the Toolbars category
selected, and a list of available toolbar schemes displayed.

2. Select the Color Buttons attribute if you want all toolbar buttons to be
displayed in color.

If this attribute is not selected, the buttons will display in
monochrome.

3. Choose the OK button.

To set a toolbar’s button size

1. In the EXTRA! main window, choose Toolbars from the View menu.

This displays the Settings dialog box with the Toolbars category
selected, and a list of available toolbar schemes displayed.

2. Select the Large Buttons attribute if you want all toolbar buttons to
have large icons.

If this attribute is not selected, the buttons will display smaller icons.

3. Choose the OK button.
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To set  toolbar ToolTips on or off

1. In the EXTRA! main window, choose Toolbars from the View menu.

This displays the Settings dialog box with the Toolbars category
selected, and a list of available toolbar schemes displayed.

2. Select the Show ToolTips attribute if you want every toolbar’s
buttons to show ToolTips when the user’s cursor pauses over them.

If this attribute is not selected, ToolTips will not appear.

3. Choose the OK button.

Toolbar Buttons and Separators

A toolbar is comprised of a series of buttons. When a user chooses a
button (by clicking it using a mouse), that button will then perform a
programmed action.

If your toolbar has many (more than three or four) buttons, try to
organize them into similar groups. You can then place separators in
between the groups.

This section describes how to add buttons and separators, how to assign
actions to buttons, and how to place buttons and separators in their
desired positions.

To add a button or separator on a toolbar

1. Open a toolbar.

2. From the Toolbar editor toolbar, click the type of object to place on
the toolbar:

Click To place

A button

A separator

The corresponding object type appears at the end of the toolbar.
Until you assign an action to a toolbar button, a number appears on
the button.

3. Repeat the previous step until the toolbar contains all the buttons
and separators that you need.
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To customize a toolbar button

1. Open a toolbar.

2. Double-click the button to which you want to assign the action.

The Action page for that button opens. For more information on this
page, see the section “The Action Page.”

3. Select a Category and a Command from that Category for the
button’s action to be performed when the user selects the button.

4. Type in a brief description in the field provided.

5. Choose the Bitmap Button page.

6. Type in the title of your button in the ToolTip field and select an
accelerator key (optional).

7. Choose the OK button.

To assign a bitmap to a toolbar button

1. Open a toolbar.

2. Double-click the button to which you want to assign the bitmap.

The Action page for that button opens.

3. Choose the Customize button in the Bitmap group box.

The Select Bitmap dialog box opens.

4. Select a bitmap from the list, browse for a *.BMP file, or edit the
existing bitmap.

5. Choose the OK button.

The button’s bitmap appears next to the Customize button.

6. Choose the OK button.

To move a toolbar button or separator

1. Open a toolbar.

2. Select the button or separator that you want to move. You can move
only one object at a time.

3. Place the mouse pointer anywhere on the object except on the
handles and hold down the left the mouse button.
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4. Drag the object until it is positioned where you want it on the
toolbar.

5. Release the mouse button.

To cut a toolbar button or separator

1. Open a toolbar.

2. Select the object(s) that you want to cut.

3. From the Edit menu, choose Cut.

The selected object is removed from the toolbar, but remains on the
Windows Clipboard until you cut or copy a different object.

To copy a toolbar button or separator

1. Open a toolbar.

2. Select the object(s) that you want to copy.

3. From the Edit menu, choose Copy.

4. To paste the copied object, choose Paste from the Edit menu and drag
the copy to the desired location.

The copy has all the attributes of the original object.

5. If you copied a button, double-click the button and assign the desired
action to it.

To paste a toolbar button or separator

1. Open a toolbar.

2. Select the desired toolbar object.

3. From the Edit menu, choose Cut.

–or–

From the Edit menu, choose Copy.

4. From the Edit menu, choose Paste thendrag the object to the desired
location.

You can paste a cut or copied toolbar object in a different location or in a
different toolbar.
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To delete a toolbar button or separator

1. Open a toolbar.

2. Select the object(s) that you want to delete.

3. Press the DELETE key.

–or–

From the Edit menu, choose Clear.

To save a toolbar

1. Click the Save button on the Toolbar editor toolbar.

–or–

From the File menu, choose Save.

2. If you are saving a new toolbar, complete the Save As dialog box.

–or–

If you are saving an existing toolbar, the toolbar is saved under its
current name and remains open until you close it.

To save a toolbar under a different name

1. From the File menu, choose Save As.

2. Complete the Save As dialog box.

The toolbar remains open until you close it.

To exit the Toolbar editor

• From the File menu, choose Exit.

–or–

• From the Control menu, choose Close.

–or–

• Double-click the Control-menu icon.

–or–

• Press ALT+F4.

You will be prompted to save any changes you have made to any open
toolbar. If EXTRA! is being run programmatically by another application,
EXTRA! closes when you close the last open session or editor.
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Toolbar Security
You can restrict access to Toolbar setting, and, in doing so, restrict access
to the Toolbar editor. If you clear the check box for the Toolbars
command in the Security Action dialog box, the command will no longer
be available from the View menu.

To set toolbar security

1. From the Options menu, choose Security.

The Security dialog box appears. Select the security scheme you want
to edit. The name of the security scheme is listed in the Scheme field.
Click Browse if you want to select a different scheme.

2. Choose the Options tab.

3. If asked for a password, enter the password in the Security Password
dialog box, then click OK.

4. From the Category list, choose View.

5. In the Commands list, clear the Toolbars check box.

6. To save the scheme, from the File page, click Save As.

Assigning an Action or Function
You can use the Action page to assign an action or function to a keyboard
key, a QuickPad object, a Toolbar button, or a HotSpot. Actions are
divided into categories, and the actions available for assignment to a key,
QuickPad, Toolbar or HotSpot depends on the selected category. Some
functions also require additional information such as the keystrokes to
send for a SendKeys command.
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The Action Page

Sample Action Page (from QuickPads)

Depending upon the type of control you are assigning an action to, you
may be able to change the following options or attributes:

Category: Selects the type of action to perform. The actions in the
Commands list box change, depending on the Category selected.

Commands: Select the action to perform. Depending on which action
you choose, the dialog box might prompt you for additional information.
For example, if the Run Application command, requires you to specify
the program to run.

Description: Shows a description of the selected command.
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Keystrokes: Type the keystroke(s) to be performed. You can double-click
one or more keystrokes from the Display Keys list box to select them.
When you double-click a keystroke, it appears in the Keystrokes text box.
All control code strings (for example, <BS>, <CR>, or <ESC>) must
include angle brackets.

When EXTRA! encounters a control code string, it checks to see if that
string is among its recognized strings. If the string is valid, EXTRA!
passes the corresponding control code character to the display session. If
the string is not valid, EXTRA! passes the string directly to the display
session so that the display session can determine if it is a valid keystroke
string for that display session.

If you do not want EXTRA! to interpret the control code string, you must
include an accent grave (‘) in front of the string.

Display: Choose the Display type from the drop-down list.

Display Keys: Adds keystrokes to the Keystroke text box. Double-click
one or more keystroke(s) strings to add new Keystrokes to the text box.

To assign an action to a key, QuickPad object, toolbar, or HotSpot

1. Open the editor for the object to which you are attaching the action:

2. Choose the Action tab in the dialog using the appropriate method:

b For Keys, in the Keyboard editor, double click the keyboard
key.

b For QuickPad objects, in the QuickPad editor, double click
on the object, and then choose the Action page.

b For Toolbar buttons, in the Toolbar editor, double click on
the button, and then choose the Action page.

b For HotSpots, from the Settings - HotSpots dialog box,
choose either New or Edit, and then choose the Action page..

3. In the Action page, select a category from the Category list. The
actions in that category appear in the Commands list.

4. In the Command list, select a command. Depending on your
selection, you may have to supply other information, such as the
keystroke to send for a SendKeys command.

5. Click OK.
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The Select Bitmap Dialog Box

Use the Select Bitmap, box to select the bitmap to appear on the Toolbar
or QuickPad button that you are editing. You can use any bitmap image
that is 16-by-16 pixels. Use the Browse button to locate bitmaps in other
directories. You can use the Edit button to edit an existing bitmap.

Select Bitmap Dialog Box

You can change the following options or attributes:

Bitmap List: Selects the bitmap you want to appear on the QuickPad or
Toolbar button. The Preview box shows the selected bitmap.

Preview: Shows an actual-size image of the bitmap that is selected.

To select a bitmap for a button

1. Select or create the toolbar button or QuickPad bitmap button.

2. Double click the button or choose the Object Properties command
from the Edit menu.

3. Choose the Action page, and then choose the Customize button in
the Bitmap group.

4. In the Bitmap list, select the button you want to use.

5. Choose OK.

The Edit Bitmap Dialog Box

Use the Edit Bitmap dialog box to edit the appearance of a bitmap on a
Toolbar or QuickPad button. The left and right mouse buttons can
independently apply colors.
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Edit Bitmap Dialog Box

You can change the following options or attributes:

Preview: Displays an actual-size preview of the icon, updated
continuously as you edit.

Editing Area: Displays the bitmap and allows you to edit bitmap pixels.

Colors: Select a color from this palette by clicking it. Click the left mouse
button on a color to “attach” it to the left mouse button; click the right
mouse button on a color to “attach” it to the right mouse button.

Left Mouse Button Color: Displays the color attached to the left mouse
button. Click the left mouse button on a color to attach a different color.

Right Mouse Button Color: Displays the color attached to the right
mouse button. Click the right mouse button on a color to attach a
different color.

To edit the bitmap on a bitmap button

1. Select or create the toolbar button or QuickPad bitmap button.

2. Double click the button or choose the Object Properties command
from the Edit menu.

3. Choose the Action page, and then choose the Customize button in
the Bitmap group.

4. Select the bitmap you want to edit, and then choose Edit.

5. Click the right or left mouse buttons on the larger image at left to
change them. You can see your results in the Preview area.

6. You can select different colors for the right or left mouse buttons by
clicking that button on the desired color in Colors.
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Adjusting Page Recording Time for Host “Settle”
EXTRA! adds from 2 to 20 seconds of buffer time between recorded
pages to give the host time to “settle” or recognize the new screen. A
page recorded with an inadequate settle time may play back as partial,
blank, or missing or its keystrokes may be associated with the previous
or next screen. Your host’s settle time requirement can be greater when
response is slow due to connection type or because of heavy traffic.

Based on host and connection type, EXTRA! automatically selects an
appropriate settle time for you. If this default settle time is inadequate or
excessive, you can override the default from the Settings dialog box.
Choose the Navigations category, General page.

Navigation Settings

Use this page to alter the host “settle time” delay or choose to do so
manually during the page recording process. The slider bar is
automatically set to an appropriate settle time derived from your host
and connection type.

This feature is composed of the following elements:

Slider bar: Adjust the slider bar to between 2 and 20 seconds by using
the mouse cursor to drag the control. Increase or decrease the settle time
in four-second increments by clicking the mouse cursor on the bar either
to the right or left of the control. Your settle time selection is indicated to
the right of the slider bar.

To alter host settle time

1. From the Options menu, choose Settings.

The Settings dialog box is displayed.

2. Choose the Navigations category.

The Navigations General page is displayed.

3. Use the mouse cursor to move the slider bar right or left to increase
or decrease the settle time.
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Host Graphics Emulation
his chapter gives you a brief introduction to host graphics emulation
in EXTRA!. If you have not worked with host graphics software

before, this overview may help you to understand the basic concepts of
host graphics emulation.

The EXTRA! host graphics emulation provided by EXTRA! allows you to
emulate a host graphics terminal and to work with vector graphics
applications on the mainframe. Vector graphics consist of lines and arcs
as opposed to bitmaps which consist of rows and columns of dots.
EXTRA!’s host graphics emulation gives you true graphics terminal
emulation. This means that the mainframe computer treats your
computer as if it were a mainframe graphics terminal. EXTRA! supports
four mainframe graphics applications: AS, SAS. GDDM, and GRAFPAK.
You have three graphics models to choose from for your emulation:
3179G, 3192G, 3472G, and 3270PCG.

Note: Many GDDM applications may not support display models 4 and
5.

The terms you will encounter frequently while using EXTRA!’s host
graphics emulation are explained below.

A graphics session is a terminal session that supports host graphics. It has
options that work specifically with host graphics applications.

The graphics cursor is the pointer that affects the host graphic image. It is
different from and operates differently from the Windows pointer and
can be displayed as crosshair or boxed crosshair.

Graphics Terminal Characteristics
A standard terminal displays text characters in rows and columns. A
model 2 terminal screen displays 1920 cells of 24 rows with 80 characters
in each row. Each cell can display a character defined in the character set
for the terminal.

These characters cells, however, are not the smallest display unit on the
screen. Each cell is composed of rows and columns of pixels, tiny areas of
light that can be turned off or on individually. To form a character in a
cell, the terminal lights up only those pixels that form a representation of
the character.

T
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A graphics terminal uses pixels to draw characters or graphic images. It
does this by processing instructions from the mainframe application that
tell it to construct images using basic graphics elements. These elements,
called primitives, consist of objects such as lines, ellipses, arcs, curves,
and patterns. When these elements are received by the graphics terminal,
the terminal then searches its character definition set and constructs the
elements on the screen by lighting up the appropriate pixels.

This type of graphics construction, where the terminal can process the
primitives directly, is called vector graphics. It is also called All Points
Addressable (APA) graphics.

Host graphics applications have two layers: a text layer and a graphics
layer as shown in the figure below.

The text layer contains the application interface text, such as menus, list
of commands, and display characters. The graphics layer contains an
image and the space surrounding it.

The text layer is superimposed over the graphics layer to form the image
you see in the display space. The text layer can contain both transparent
text (which allows the graphical image to show through) and non
transparent text (which overlays the graphical image). These layers are
the same size. On a standard IBM 3179G terminal, the size would be
720x384 pixels.
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Loadable Symbols
Loadable symbols, also called graphic symbol sets, are sets of symbols up
to 32x32 pixels in size that are treated as small, individual bitmaps.

There are different uses of loadable symbols. They can appear in the
graphics layer or the text layer. In the graphics layer, they are commonly
referred to as Graphics Symbol Sets and can be used as markers, fill
patterns, or custom text. In the text layer, they are referred to as Program
Symbols and are used as custom text. In either case, the symbol sets are
created on a mainframe host graphics application and then downloaded
to the graphics terminal. The application then selects a symbol or group
of symbols to display on the text or graphics layer.

For example, if loadable symbols were used to draw custom text, and the
character size was 9x12 pixels, an “A” might appear as shown in the
following illustration.

True Graphics Terminal Emulation
Graphics Terminal Emulation has the capability of displaying all the
primitives as an IBM graphics terminal, such as the 3179G or the 3472G,
would. Primitives such as lines, ellipses, arcs, patterns, and loadable
symbols are all rendered correctly and scaled to fit within the terminal
window on your display screen. This is important since certain
mainframe graphics applications will perform properly only on terminals
having certain display characteristics. Using this program your display
can appear as an IBM 3179G, a 3192G, a 3472G, or a 3270PCG.
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The window dimensions for the terminal emulation session might not be
the same as configured for the display (3179G, or 3472G). If the
dimensions deviate significantly from the proportions of the configured
display resolution, the image may appear stretched or compressed as it is
sized to fit the terminal window. EXTRA!’s display fonts allows you to
display graphics correctly.

To display your graphics correctly, in your graphics session, choose from
ATM Graphics 2.5, or ATM Graphics 3.4 from Fonts in the Settings dialog
box.

Customizing Your Graphics Sessions
EXTRA!’s host graphics emulation lets you customize host sessions to fit
your needs. You can choose the IBM graphics terminal to emulate, and
customize your terminal emulation. Emulating a mainframe graphics
terminal in Windows gives you a very powerful tool in an easy-to-use-
environment, with various display and performance options to choose
from.

You can customize your graphics by using the options on the Display
page. The graphics options include selecting the graphics cursor type and
the colors for your session.

Starting a Graphics Session
You can start a graphics session using the Settings dialog box after you
have started a terminal session. On the General Page in Display, you can
choose the following:

• graphics model for your graphics session

• support for extended attributes

• program symbols and the light pen device

• graphics cursor type for the session
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The Settings - 3270 Display General Page

To start a graphics session

1. Open a display session in EXTRA!.

2. From the Settings dialog box, select Display.

3. From the General Page, set the appropriate graphics sessions options
listed below.

Support Extended Attributes: Select this to choose your graphics
terminal model.

Program Symbols Support: Enables loadable symbols support.
Loadable symbols, also called graphic symbol sets, are sets of
symbols that are treated as small, individual bitmaps. Loadable
symbols can appear in the graphics layer or the text layer. In the text
layer, they are referred to as Program Symbols and are used as
custom text.

No Graphics: Displays a non-graphics session when selected.
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4. Choose from one of the graphics terminal models listed below.

3179G or 3192G: Displays a graphics terminal with the screen size
720x512. Model 2 cell size is 9x16, and model 3 cell size is 9x12.

3472G: Displays a graphics terminal with the screen size 720x384.
Model 2 cell size is 9x21, and model 3 cell size is 9x16.

3270PCG: Displays a graphics terminal with the screen size. Model 2
cell size is 9x21, and model 3 cell size is 9x16.

Graphics Cursor Appearance: Specifies the appearance of the
graphics cursor. You can choose from Crosshair or Boxed crosshair

5. Choose the OK button to save settings and return to the session.

6. Select Yes in the dialog box to disconnect from your current session.

Note: Changing these settings closes the current session and starts
the graphics session. Also note that the data in your current session
will be lost.

Changing Host Graphics Colors
With host graphics, you can change the colors of the image as they are
displayed in the session using the Colors page in the Settings dialog box.
The color changes affect how the image is displayed and captured.

When you save part or all of the image to the Clipboard or file, you will
save the colors displayed on the screen. Each session has its own color
settings.
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Interacting With Graphics
Some mainframe graphics applications have interactive features that
allow you to manage graphics input. These applications allow you to
select and move an object in a drawing. The host graphics emulation in
EXTRA! supports many of these interactive applications through your
PC mouse. EXTRA! provides a graphics cursor that you can display as a
crosshair or a boxed crosshair cursor. The graphics cursor you choose in
EXTRA! allows you to move the host interactive cursor as necessary. The
left mouse button acts as the host mouse button.

Working With Graphics and Text
Some mainframe graphics images contain text and graphics, and some
contain only graphics. The images you display and the type of graphics
you choose determine how you work with text and graphics, as All
Points Addressable (APA) or Programmed Symbols (PS). In EXTRA!, the
text is considered standard 3270 text, and the graphic is considered a
graphic image. However, note that some graphics can contain elements
that appear to be text, but are actually graphics.

When you copy all or part of a graphic that contains both text and
graphics, you can paste the graphic into other Windows applications in
the metafile or bitmap format. In the metafile format, only text or graphic
elements can be pasted, depending on the part of the image that was
copied. In the bitmap format, all elements of the image are pasted in. You
can choose the format after you copy the image to the Clipboard by
choosing Picture or Bitmap.

Copying and Pasting Graphic Images
After you display a drawing or image, you can copy and paste the
contents of the text or graphics window to other Windows applications
such as CorelDRAW!, PC Paintbrush, PageMaker, or Ventura Publisher.
You can copy all or part of your terminal screen, the text only or the text
and graphics together. You need to select the area you want to copy.

You can select the area as you would in any Windows application, by
clicking where you want to start and dragging across the area.
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To copy and paste graphic images

1. Select the area you want to copy.

2. From the Edit menu, choose Copy.

The text or graphics are copied to the Clipboard in Windows Metafile
Format (WMF) or as a bitmap image.

3. Open the Windows application you want and paste the contents of
the Clipboard into the application.

Note: You can paste text into any unprotected text field in your terminal
session. However, you cannot paste graphics into any session, including
a graphics session.
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ne of the most time-consuming tasks in a host session is often that of
merely getting to the particular host application screen in which

you are interested. In EXTRA! we have included a feature to take the
repetition out of navigating through your host applications. Using
EXTRA!, you can record the “path” that you take to and from your host
applications, then replay this recording later to automatically perform the
navigation. We refer to the various screens you traverse on the host as
“pages.”

In addition, using EXTRA! you can “bookmark” a host screen page.
Later, when you want to return to that page, you can select the
bookmark, which then takes you to the selected point in the navigation
path. This chapter covers the procedures necessary to record, replay, and
edit navigation path recordings.

Recording Host Screen Pages
You can record a series of host screen pages by using the procedures you
would normally use to navigate through the host application.

Then, any time you want to display a particular host screen, you can
choose Go To Bookmark/Page from the Tools menu and select the
desired screen name.

Once you have recorded host screens, you can also perform the following
tasks:

• Rename a host screen (for example, renaming Page001 to “Logon
Screen,” Page002 to “Main Menu,” and so on).

• Associate a QuickPad, macro, toolbar, or scheme (such as a color
scheme or a HotSpot scheme) with specific host screen or group of
host screens. Any time you access that host screen, the associated
item is started (for example, the toolbar or QuickPad loads, the
macro runs, the colors or HotSpots are applied, and so on).

• Specify which host screens to use as bookmarks. Bookmarks make it
easy to work with only the recorded pages in which you are most
interested For example, you might record ten host screens, but only
be interested in navigating to the last one. When you specify that the
last screen is a bookmark, only that screen will appear in the list box
when you choose Go To Bookmark/Page from the Tools menu and
select View Bookmarks.

O
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• Create groups of host screens that you want to handle in a similar
way. For example, if you want a particular group of host screens to
use a specific color scheme, you can put those host screens together
in a group and apply the color scheme to the group, rather than
having to apply it to each host screen one at a time.

• Perform advanced functions, such as customizing how the host
screen is accessed or identified.

The Record Pages Tool bar
When you start to record the path to the screen you want to bookmark,
the Record Page toolbar appears at the bottom right of your session’s
window. As you navigate through your host screens, the tool bar shows
the default name associated with each recorded page, and lets you edit
this name, mark a recorded page with a bookmark, pause the recording
of pages, and stop recording.

Record Page Toolbar

You can change the following options or attributes:

Stop button: Stops the recording of host screen navigation, and cancels
the dialog box. Any previously recorded host screen pages are saved.

Pause button: Pauses the recording of pages. Any actions that cause a
new screen to appear will not be recorded. To continue recording, choose
this button again.

Add Bookmark button: Marks the currently displayed page name as a
bookmark. Bookmarks make it easy to work with only the recorded
pages in which you are most interested.
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Page Name: Displays the name assigned to the currently recorded host
screen page. You can edit this name while recording, or edit it later in the
Page Settings dialog box.

Recording Indicator: An animated record indicator indicates that the
recording of page navigation is in progress.

To record host pages

1. Starting at your log on screen (recommended), choose the Record
Pages command from the Tools menu.

The Record Pages toolbar appears on the session.

2. Wait until a name appears in the Record Pages window. Until this
happens, the program is reading the host screen and recording
identifiers.

3. (Optional) In the Page Name box of the Record Pages tool bar, type a
name to identify this screen. You can also rename the screen pages
later by using the Page Settings dialog box.

4. Use your usual procedures for navigating through the host
application screens, repeating steps 2 and 3 for each host screen page.

5. When you have navigated through all the host screens that you want
to record, choose the Stop button on the Record Pages window to
stop recording.

The Bookmark/Pages Dialog Box

Use the Bookmarks/Pages dialog box to “play back” a recorded
navigation path and to go directly to a recorded host screen page or
bookmark.

!! Important: If you don’t wait long enough at each screen, you may
record partial screens. Also, make sure you do not type any
additional keystrokes as they will be associated with the navigation
to this screen.

!! Important: For best results, return to the screen from which you
started before stopping the recording.
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The Bookmarks/Pages dialog box

You can change the following options or attributes:

Stay Visible button: Keeps the Bookmarks/Pages dialog box visible (on
top) of all other session windows.

Page Settings button: Opens the Page Settings dialog box where you can
change the properties (for example, change the page name, add
bookmarks, group pages into navigation schemes, and so on) of the
recorded pages.

Go button: Shows the screen associated with the page selected in the
Bookmark/Pages list.

Bookmark or Page List: Lists the recorded pages in the selected category:
Bookmarked only or All Pages.

View Bookmarks option: Shows all pages (in the Bookmarked/Pages
list) that are bookmarked.

View All Pages option: Shows all recorded pages in the
Bookmarked/Pages.

To go to a recorded host page

1. From the Tools menu, choose the Go To command, then choose the
More command.

2. In the Bookmarks/Pages dialog box, select the View All Pages option
at the bottom of the dialog box.

Note: If you want to go to more than one page, choose the Stay
Visible button (pushpin).
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3. In the Bookmarks/Pages list, select the page, and then choose the Go
button from the toolbar:

To go to a bookmark

1. From the Tools menu, choose the Go To command.

2. From the Go To commands list, choose the name of the bookmarked
page you want.

To select several bookmark pages sequentially:

1. From the Tools menu, choose the Go To command, and then choose
the more command.

2. In the Bookmarks/Pages dialog box, choose the Stay Visible button

3. Choose the View Bookmarks option at the bottom of the dialog box.

4. Select a bookmark from the list, then choose the Go buttonGo button.

Working with Recorded Host Screen Pages
The Page Settings dialog box contains controls you can use to:

• View an image of a recorded page

• Attach one or more settings (such as a macro, color scheme,
QuickPad, or toolbar) to a recorded page or group of pages

• Designate certain recorded pages as bookmarks

• Create groups of recorded pages so that you can more easily attach
settings to many recorded pages at once

• Edit recorded paths

• Edit page names and other identification for pages
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The general options on the Page Settings dialog box are as follows:

“Session_Name” Pages: Displays the name of the recording.

Page list: Displays the names of the recorded host screen pages.

Rename: Choose this button to rename the selected page.

The Page Settings Preview Page

Using this page, you can view an image of the selected host screen.

Page Preview: Displays the selected page as it appeared when it was
recorded.

Choose Page Preview to display the selected page as it appeared when it
was recorded.

To preview a recorded host page

1. Choose the Page Settings command from the Tools menu to display
the Page Settings dialog box. You can display this dialog box only if
you have recorded host screens.

2. From the “Session_Name” Pages list box, choose the screen that you
want to preview.

3. Choose the Preview tab.

The Page Settings, Settings Page

Using this page, you can associate a file transfer type, QuickPad, macro,
toolbar, or scheme (such as a color scheme or a HotSpot scheme) with
specific host screen or group of host screens.

Every time a user accesses a recorded screen — by using a bookmark that
passes through the screen, or just by logging on normally — the screen
shows your settings.

Page Settings: Displays the QuickPads, macros, toolbar, or schemes that
are currently associated with the selected host screen or group of host
screens.

Add: Associates the selected QuickPad, macro, toolbar, or scheme with
the selected host screen.

Delete: Removes the selected QuickPad, macro, toolbar, or scheme fom
the list of items associated with the selected host screen.

Available Settings: Displays the QuickPads, macros, toolbars, or
schemes that can be associated with the selected host screen.
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To add settings to a host page

1. From the Tools menu, choose Page Settings to display the Page
Settings dialog box, or choose the Page Settings button on the
toolbar, if it is available. This may vary depending on the toolbar that
is attached to your session.

You can display this dialog box only if you have recorded host
screens.

2. From the “Session_Name” Pages list box, choose the screen or group
of screens with which you want to associate a setting.

3. Choose the Settings tab.

4. From the Available Settings list box, double-choose the folder that
contains the setting that you want to add.

Folders preceded by a plus symbol (+) contain settings that can be
associated with host screens. When you choose a folder preceded by
this symbol (or choose the plus symbol), the settings associated with
the selected folder appear in the list box.

A minus symbol (-) appears in front of folders that you can collapse.
When you choose a folder preceded by this symbol (or choose the
minus symbol), the listed settings no longer appear in this list box.

5. Choose the setting to add to the host screen or group of screens.

All configured settings appear in the Available Settings list box, but
not all settings might be appropriate for each host screen. Be sure to
associate only those settings that are appropriate for the selected host
screen. Every time a user accesses a recorded screen — by using a
bookmark that passes through the screen, or just by logging on
normally — the screen shows your settings.

6. Choose Add.

The Page Settings  Bookmarks Page

Using this page, you can specify which host screens should be
bookmarks. Following is a description of the options available on the
Page Settings Bookmarks page.

Add: Adds the selected host screen to the list of bookmarks.

Delete: Removes the selected host screen from the list of bookmarks.

Page list: Displays the host screens that are currently specified as
bookmarks.
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To bookmark recorded host pages

1. From the Tools menu, choose Page Settings to display the Page
Settings dialog box, or choose the Page Settings button on the
toolbar, if it is available. Whether the button is available depends on
the toolbar that is attached to your session.

You can display this dialog box only if you have recorded host
screens.

2. From the “Session_Name” Pages list box, select the screen that you
want to specify as a bookmark.

3. Choose the Bookmarks tab.

4. Choose Add.

The Page Settings Groups Page

Using this tab, you can create groups of host screens. This makes it easier
to associate settings with host screens, since you can associate the settings
with an entire group rather than with one screen at a time.

For example, if you want a particular group of host screens to use a
specific color scheme, you can put those host screens together in a group
and apply the color scheme to the entire group. It often makes sense to
group all pages from a particular host application.

Note: Every time a user accesses a recorded screen — by using a
bookmark that passes through the screen, or just by logging on normally
— the screen shows your settings. Therefore, you must use caution when
setting multiple screens at once with the same schemes.

Following is a description of the options available on the Page Settings
Groups page.

Group list: Displays the name of the group to which you want to add
host screens or from which to delete host screens. If you have not created
any groups yet, this text box is blank. Select New Group to create a
group.

New Group: Creates a new group.

Remove: Choose to delete the selected group.
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Add: Adds the selected host screen to the specified group.

Delete: Removes the selected host screen from the specified group.

Page list: Displays the host screens that are currently in the specified
group.

To group host screen pages

1. From the Tools menu, choose Page Settings to display the Page
Settings dialog box, or choose the Page Settings button on the
toolbar, if it is available. This may vary depending on the toolbar that
is attached to your session.

You can display this dialog box only if you have recorded host
screens.

2. Choose the Groups tab.

3. If you have not already created a group for your host screen pages,
choose New Group. Complete the New Group dialog box, creating a
name for the new group.

4. From the “Session_Name” Pages list box, choose the screen that you
want to include in the group.

5. Choose Add.

6. Repeat steps 4 and 5 until the group contains all the desired host
screen pages.

To delete a group of host screen pages

1. From the Tools menu, choose Page Settings to display the Page
Settings dialog box, or choose the Page Settings button on the
toolbar, if it is available. This may vary depending on the toolbar that
is attached to your session.

You can display this dialog box only if you have recorded host
screens.

2. Choose the Groups tab.

3. On the Groups page, select the group that you want to remove from
the Group list box.

4. Choose Remove.

Note: The group is removed, but none of the host screen pages
included in the group are removed.
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To remove a host page from a group

1. From the Tools menu, choose Page Settings to display the Page
Settings dialog box, or choose the Page Settings button on the
toolbar, if it is available. This may vary depending on the toolbar that
is attached to your session.

You can display this dialog box only if you have recorded host
screens.

2. Choose the Groups tab.

3. From the Group pull-down list, select the group from which you
want to remove a host screen.

4. From the pages list box, select the host screen that you want to
remove from the specified group.

5. Choose Delete. The page is removed from the group, but not from
the recording.

The Page Settings Advanced Page

Using this page, you can edit either a recording (of a navigation path) to
a particular host screen page, or edit Page Identification, such as the
name of a recorded page.

Note: The Advanced Page is available only if you select the Expand Page
Settings Dialog Box option in the Global Preferences dialog box.

The ability to edit recorded navigations provides a powerful method for
tailoring the paths to your host screen pages, eliminating any
unnecessary steps on the way. EXTRA! provides five dialog boxes with
which you can manipulate your recorded paths. Depending on your
selections, you might encounter the same dialog box at different points in
the process. The five dialog boxes are:

• Edit Recording

• Edit Screen

• Edit Path

• Edit Field

• Edit Identification Field
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Following is a description of the options available on the Page Settings
Advanced page.

Edit Paths: Choose here to open the Edit Recording dialog box.

Edit Page Identification: Choose here to open the Edit Screen dialog box.

The Edit Recording Dialog Box

This dialog box shows the navigation path that your recording
represents. From this dialog box, you can edit either the included host
screen pages or the path itself.

Following is a description of the options available on the Edit Recording
dialog box.

Expand/Collapse button: Choose this button to show or hide the list of
recorded screens or the list of recorded paths.

Add: Adds a new element into the path or screen list.

Edit: Allows you to edit a path, a field, or an identification field.

Delete: Removes the selected element from the screen or path list.

Variable Length Recorded Data: Contains the list of recorded screens
and paths.

Information window: Displays information about the paths and screens
in the current recording.

OK: Closes the window and saves any changes you have made.

Cancel: Closes the window and without saving any changes you have
made.

The Edit Screen Dialog Box

This dialog box shows the terminal fields, identification fields, and paths
from the selected screen page, so that you can:

• Change any of the terminal field names for the selected screen page

• Change the way EXTRA! recognizes an identification field

• Add an identification field

• Remove an identification field

• Remove or change any of the recorded paths from the selected screen

• Add a path from the selected screen
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Following is a description of the options available on the Edit Screen
dialog box.

Screen Name: Displays the name of the selected host screen page in the
recording.

Expand/Collapse: Choose this button to show or hide the list of terminal
fields, the list of identification fields, or the list of paths.

Add: Adds a new element into the identification field list or the direct
path list.

Edit: Displays the dialog box to edit a path, a field, or an identification
field.

Delete: Removes the selected element from the identification field list or
the direct path list.

Variable Length Recorded Data: Contains the list of terminal fields,
identification fields, and paths away from the selected screen page.

Information Area: Displays information about the paths and screens in
the current recording.

OK: Closes the window and saves any changes you have made.

Cancel: Closes the window without saving any changes you have made.

The Edit Path Dialog Box

This dialog box shows the user entries, terminal keystrokes, and the path
from the selected screen page, so that you can:

• add a prompt for the user to enter text

• type in any text you want to be entered as if it were user input; for
example, a logon ID

• select keystrokes from a list to be added to the path entries

• insert, replace, or delete key entries in the path
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Following is a description of the options available from the Edit Path
dialog box.

Prompt User for Input Text: You can type in an appropriate prompt for
text that the user must enter, such as a password. It displays the prompt
in a text entry dialog box at the designated point in the path.

Edit Entry: Specify the text that you would like added, or  inserted, or
that should replace an entry in the Key Entries path list. You can type the
text in directly for a logon ID or host command, or you can select
keystrokes from the Terminal Keys list.

Terminal Keys: Choosing a key name from this list causes it to appear in
the Edit Entry box, from which you can add or insert it into the list, or
replace another entry.

Insert: Inserts the contents of the Edit Entry text box into the Key Entries
list. The item is inserted above the selected entry.

Add: Adds the contents of the Edit Entry text box to the Key Entries list.
The item is added below the selected entry.

Replace: Replaces the selected entry in the Key Entries list with the
contents of the Edit Entry text box.

Delete: Deletes the selected entry in the Key Entries list.

Key Entries in Path: Contains all of the text and keystrokes that either
were entered as the path was recorded or added within this dialog box.

OK: Closes the window and saves any changes you have made.

Cancel: Closes the window without saving any changes you have made.

To edit a recorded path

1. From the Page Settings dialog box, choose the Advanced tab.

2. Choose Edit Paths.

3. Edit the appropriate items and choose OK. From the Edit Recording
dialog box, you can edit paths, screens, or both.

When you edit a path, you are editing the keystrokes that EXTRA!
sends to the host when playing back a recording. When you edit a
screen, you are editing the labels on fields, or defining or modifying
which fields EXTRA! uses to identify screen pages.
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The Edit Field Dialog Box

This dialog box shows the field number, row, column, length of the
selected host screen field, along with its field attributes. From this dialog
box, you can assign a new name to the field.

Following is a description of the options available on the Edit Field
dialog box.

Field Name: Displays the name of the field and allows you to change the
field name.

Field Information: Displays the field number, row, column, length of the
selected host screen field, along with its field attributes.

OK: Closes the window and saves any changes you have made.

Cancel: Closes the window without saving any changes you have made.

The Edit Identification Field Dialog Box

From this dialog box, you can specify the row position, column position,
and length for a field used to identify the host screen page. You can have
the program use asterisk (*) wildcard characters.

Following is a description of the options available on the Edit
Identification Field dialog box.

Row: Displays the beginning row of the screen identification field.

Column: Displays the beginning column of the screen identification field.

Length: Displays the length of the screen identification field.

Absolute Position: Saves both the row and column position on which the
field is to begin.

Anywhere on this Row: Saves the row position but replaces the column
postion with a wildcard character (*).

Anywhere in this Column: Saves the column position but replaces the
row postion with a wildcard character (*).

Anywhere in Screen: Replaces both the row and column postion with
wildcard characters (*).

Data: Displays the characters on the selected host screen page at the
selected positions.

OK: Closes the window and saves any changes you have made.

Cancel: Closes the window without saving any changes you have made.
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To edit an identification field

1. With a host screen selected in the Page Settings dialog, choose the
Advanced tab.

2. Choose the Edit Page Identification button. The Edit Screen dialog is
displayed.

3. Choose the Indentification Fields icon, then choose Expand.

4. Choose Add to add a new identification field

–or–

Select a field and choose Edit to edit an existing identification field.

5. Select appropriate values for the row, column, and length settings.

6. Select whether you would like absolute positioning, a row wildcard,
a column wildcard, or both.

7. Choose OK if you are satisfied with the changes you have made.

Recording Pages Security
You can restrict access to all page recording commands. If you clear the
check boxes for the Record Pages, Page Settings, or Go To
Bookmark/Page commands in the Security Action dialog box, the
commands will no longer be available from the Tools menu, and the
program removes the commands from the Category list in the Action
dialog box. The user will not be able to record host screen pages,
associate settings with pages or page groups, or select a page or
bookmark to go to when these commands are disabled in the Security
dialog box.
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To set recording pages security

1. Select Security from the Options menu.

The Security dialog box is displayed.

2. Select the security scheme you want to edit. The name of the security
scheme is listed in the Scheme field. Choose Browse if you want to
select a different scheme.

3. Choose the Options tab.

4. If asked for a password, enter the password in the Security Password
dialog box then choose OK.

5. From the Category list, choose Tools.

6. In the Commands list, clear the checkboxes for the navigation
commands you want to secure: Record Pages, Page Settings, or Go
To Bookmark/Page.

7. To save the scheme, go back to the File page and choose Save As.
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 macro is a series of recorded keystrokes, actions, or special
commands that you can combine into a single file. This file can then

be associated with a menu command, key combination, at the opening of
a session, a particular host screen, HotSpot, QuickPad and more. Macros
automate repetitive tasks and can simplify complex ones  into a single
command or keystroke.

You can create macros by recording keystrokes you enter as you’re
working, create them using the Macro Editor in conjunction with the full-
featured EXTRA! Basic Macro Language, or using a combination of both
methods.

This chapter provides step-by-step instructions for both methods.

Here are some common uses for macros:

• Simplifying complex tasks such as transfering a series of files from
your host to your PC.

• Automating repetitive tasks such as logging into your host, typing
your user ID, password, and pressing the ENTER key, then navigating
to your host application.

• Extend or create new EXTRA! functions. For example, the provided
macro CAPTUR32.EBM grabs an entire screen of data from the host
and lets you edit the data in Notepad.

Recording a Macro
The fastest way to create a macro is to record it. Start the macro recorder
by choosing Record from the Macro menu. EXTRA! records your actions
until you stop the macro recorder. When you run the macro, it ‘‘plays
back’‘ what you recorded  but it does so much more quickly.

EXTRA! also includes a Macro Editor that you can use to edit your
recorded macro code or to create more complex macros with the EXTRA!
Basic macro language. This editor has a built-in compiler and several
debugging tools so you can check the syntax of your macro and make
sure it will run correctly.

A
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The Record Macro Dialog Box

Use the Record Macro dialog box to record a macro. When you record a
macro, you can temporarily pause the recording. For example, if you
forget the name of a file to be included in the macro, you can pause the
recording, look up the file name, and then resume recording.

In addition, you can insert several special macro functions into a macro
as you record it.

The Record Macro dialog box

Record Macro Name: Enter a unique name for your macro.

Description: (Optional) In the Description field, enter a brief description
of the macro. Your description provides a quick reference, especially in
installations where many different macros have been created.

Make Macro Available To: Enter the location to which you want to make
your macro available.
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Recording Options

Use with any Active Session: When selected, your macro is used
with any session that is active.

Use with this Session Only: When selected, your macro is used only
with the current session.

Default Wait Timeout: Indicates the amount of time the macro waits
before continuing to record actions. The default is 3 seconds.

To record a macro

1. From a session, choose Macro from the Tools menu.

The Macro dialog box appears on your screen.

2. Choose the Record button.

The Record Macro dialog box opens.
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3. In the Macro Name field, enter a unique name for your macro.

4. (Optional) In the Description field, enter a brief description of the
macro. Your description provides a quick reference, especially in
installations where many different macros have been created.

5. In the Make Macro Available To field, enter the location to which
you want to make your macro available.

6. Select from the recording options listed below:

Use with any Active Sessions: When selected, your macro is used
with any session that is active.

Use with this Session Only: When selected, your macro is used only
with the current session.

Default Wait Timeout: Indicates the amount of time the macro waits
before continuing to record actions. The default is 3 seconds.

7 Choose the OK button.

The macro recording panel displays.
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8 Perform the actions you want to record.

To stop recording temporarily, press the Pause button. Press the
Pause button again to continue recording.

To pause the macro and insert a special macro command into the
script, press the Insert button. The special macro commands that can
be inserted include:

• Wait Functions

• Move Cursor Position

• Prompt Message Text

9. To stop recording after the last action, press the Stop button.

To run a macro from the Macro Editor

When all syntax errors have been located and corrected and your macro
compiles successfully, you can further test the macro by running it.

1. If you have more than one macro displayed, make sure the
appropriate macro is active.

2. From the Run menu, choose Go.

To run a macro from EXTRA!

The following steps describe how you can run a macro after you’ve
recorded it, or saved it in the Macro Editor.

1. From the Options menu, choose Macro.

The Macro dialog box appears on your screen.

2. Type the name of the macro you want to run or select Browse to
locate the macro file, and then choose the Run button.

To stop macro execution from within the Macro Editor

To stop execution of a macro while it is running,

• From the Run menu, choose Stop.
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Inserting Special Macro Commands
You can pause a macro recording and insert special macro functions into
the script. The following types of special macro functions are included:

• Wait functions cause the macro to wait until specified host conditions
are met before resuming (specific text appears, host is ready, a
specified number of seconds has elapsed, the cursor is positioned at a
specified row and column, the cursor moves up, down, left, or right a
specified amount). Wait functions are useful in macros that require
the host to do time-consuming processing.

• Moving cursor position moves the cursor to a new position on the
host screen.

• Entering text pauses the macro and displays a text prompt. When
responded to, the macro resumes.

The Insert Functions Dialog Box

In this dialog box, you can insert a wait command which pauses the
macro until the specified host conditions are met, move the cursor to a
new position on the host or pause the macro and display a text prompt.

The Insert Functions dialog box.
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Functions

Wait for Text: Causes the macro to wait until specified text appears.
You can choose to have it appear at a specific position (Row(s),
Col(s)) or you can choose no specific position (Anywhere On Screen).

Wait for Cursor to Appear at: Causes the macro to wait until the
cursor is at the designated row and column.

Wait for Cursor to Move: Causes the macro to wait until the cursor
moves to the designated location, relative to its current (up/down,
left/right) location.

Wait Until Host is Quiet for: Causes the macro to wait until the host
is quiet (ready) for the designated number of seconds.

Pause for ___ Seconds: Causes the macro to wait the designated
number of seconds before resuming.

Move Cursor To: Indicates what row and column you want the
cursor position to be on the host.

Display Message Box With Text: Causes the macro to wait until the
user responds to the message box with this text.

Text: Enter the text that you would like to appear in the prompt message.

Anywhere On Screen: Indicates that the specified text may appear
anywhere on the screen to satisfy the wait condition.

At Screen Position: Indicates that the text must appear at a
designated screen position (Row and Col) to satisfy the wait
condition.

Screen Position

Row (s): If the Wait Until Cursor Moves function is selected, this
field indicates a relative move up or down this many rows.

Column(s): If the Wait Until Cursor Moves function is selected, this
field indicates a relative move left or right this many columns.

Up: Indicates the cursor must move this many rows (up) from its
current position before the macro resumes.

Down: Indicates the cursor must move this many rows (down) from
its current position before the macro resumes.
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Left: Indicates the cursor must move this many columns (left) from
its current position before the macro resumes.

Right: Indicates the cursor must move this many columns (right)
from its current position before the macro resumes.

Seconds: Enter the number of seconds to wait before resuming. You can
enter the number of seconds the host is quiet or you can enter the
number of seconds the macro should wait before resuming.

To insert special macro functions

The following steps describe how to insert special macro functions as you
record a macro.

1. From the Macro Recorder panel, press the Insert button.

2. Select the function you’d like to insert.

• Wait functions cause the macro to wait until specified host
conditions are met before resuming (specific text appears, host is
ready, a specified number of seconds has elapsed, the cursor is
positioned at a specified row and column, the cursor moves up,
down, left, or right a specified amount). Wait functions are
useful in macros that require the host to do time-consuming
processing.

• Moving the cursor position moves the cursor to a new position
on the host screen.

Note: This function repositions the cursor only when the macro is
running. As you record, you must move the cursor manually.

• Entering text pauses the macro and displays a text prompt.
When responded to, the macro resumes.

3. Choose the OK button.

4. Finish recording your macro.
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EXTRA! Basic Language
If you’ve worked with macros or done some Basic programming before,
much of the material here will be familiar to you. If you haven’t had any
experience with macros or programming in Basic, you may find it helpful
to consult a book on fundamental programming skills or get help from
your system administrator.

You can create a macro by recording a series of actions in EXTRA!,
writing it from scratch using the EXTRA! Basic Language, or by
recording some parts and writing others. Recording is best for simple
macros, while more complex macros typically use macro instructions that
cannot be recorded.

Note: Each EXTRA! Basic statement, function, and OLE automation call
online Help topic includes an example. To copy the example code into
your macro code, choose the Copy button in the example window, then
position the cursor in the Editor workspace and choose Paste from the
Edit menu. Then rework the example as needed.

Whether you record a macro or use the Macro Editor to create a macro,
it’s important that the commands you use are carefully worded and
punctuated. Each command must conform to specific rules, or syntax. If
the syntax is incorrect, your macro won’t compile.

The list below will help you understand the syntax that EXTRA! Basic
uses for its macros:

• A function line always starts with a variable assignment. Everything
that follows the function name is enclosed in parentheses.

• You can include text strings, numbers, and other required or optional
parameters within the parentheses. Separate each item with a
comma.

• Text strings are surrounded by quotation marks. For example, “This
is a text string.‘‘ Notice that the period within the quotation marks is
part of the string.

• Comments begin with an apostrophe (‘) or the letters REM, and end
at the end of the line. You can start a comment at the beginning of a
line or place it at the end, but you can’t embed a comment within a
function line. Once a comment begins, the rest of the function line is
ignored when the macro is running.
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The Macro Editor
EXTRA! provides the Macro Editor to write and edit macros. The Macro
Editor is an editing environment in which you can type your own
commands, or insert function, statement, or object templates by choosing
from a Functions and Objects list. Refer to the EXTRA! User’s Guide for
details about using the Macro Editor.

One of the nice things about using the templates provided by the Macro
Editor is that they already contain the correct syntax. All you have to do
is supply actual variable names or strings as required.

Using the Macro Editor, you can also debug your macro by:

• Printing your macro source code or viewing it in the Macro Editor.

• Inserting a breakpoint by selecting the sidebar directly opposite a
function or statement. (Breakpoints can be toggled on or off during
the debugging process.)

• Single-stepping through your macro code.

• Watching specific variable values as your macro runs.

• Compiling your macro and checking for syntax errors.

Tip: To display a detailed online Help topic about a particular EXTRA!
Basic or OLE element, highlight the function, statement, or call in the
Editor workspace and press F1. The Help Index is displayed pointing to
the highest-level entry pertaining to the highlighted language item or
object. Choose an appropriate sub-entry, if desired, and then choose the
Display button.

To start the Macro Editor

1. Choose the Macro Editor icon from the EXTRA! program group in
the Program Manager or the EXTRA! folder in the Windows 95
Explorer.

–or–

Choose Macro from the Tools menu of EXTRA!.

The Macro dialog box appears.
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2. To edit an existing macro, highlight the desired macro filename and
choose the Edit button.

–or–

To create a new macro, enter the name of the new macro in the
Macro name text field and choose the Edit button.

The Macro Editor is displayed.

To start the Dialog Editor

• Choose Dialog Editor from the Macro Editor Tools menu.

To exit the Macro Editor

1. Make sure you have saved your macro.

2. Choose Exit from the File menu.

To code a new macro

1. From the Macro dialog box, enter the name of the new macro in the
Macro name text field and choose the Edit button.

–or–

From the Macro Editor, choose New from the File menu.

The Sub Main...End Main structure is supplied automatically.

2. Type the statements or functions you want in your macro, or insert
them from the Functions and Objects browser.

3. To save your macro, choose Save As from the File menu, and give
your macro a unique name.

EXTRA! provides the filename extension (.EBM) for all macro files.

Note: Each time you run your macro, EXTRA! automatically compiles the
macro and checks for syntax errors.
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To copy and paste online Help example code into your macro

Each EXTRA! Basic statement, function, and OLE automation call online
Help topic includes an example.

1. Display the online Help topic for the appropriate function, statement,
or OLE automation call. (Navigate to the topic using the online Help
index, or by highlighting the language element in the Functions and
Objects browser and choosing the small question mark button.)

2. From the function, statement, or OLE automation topic, choose the
Example button.

3. From the Example window, choose the Copy button.

4. Position the cursor at the appropriate location in the Editor
workspace.

5. Choose Paste from the Macro Editor Edit menu.

6. Rework the example, as required.

To open an existing macro

1. Start the Macro Editor from the EXTRA! Program Group or from the
Windows 95 Explorer.

–or–

Choose Macro from the Tools menu of EXTRA!.

The Macro dialog box appears.

2. Highlight the desired macro filename and choose the Edit button.

The Macro Editor displays your macro source code.

3. If you want to edit more than one macro at the same time, choose
Open or New from the Macro Editor File menu until all the macros
you need are displayed.

If you are working on more than one macro, you can display them in
the Editor the same way you display any window in the Windows
environment. You can display them as objects, you can use the Tile
or Cascade command, and so on.
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The Macro Editor Toolbar, Status Bar, Side Bar, and Editing Workspace

Refer to the following chart for details about the various toolbar options
available with the Macro Editor.

Choose To do this Or

Create a new macro. From the File menu, choose
New.

Access the Open dialog
box so that you can open
an existing macro.

From the File menu, choose
Open.

Save changes to the
current macro.

From the File menu, choose
Save.

Print your macro source
code.

From the File menu, choose
Print.

Cut the selection to the
Clipboard.

From the File menu, choose
Cut.

Copy the selection to the
Clipboard.

From the File menu, choose
Copy.

Paste from the Clipboard
to the cursor location.

From the File menu, choose
Paste.

Undo the last edit. From the File menu, choose
Undo.

Toggle the current line
from code to remark or
remark to code.

From the File menu, choose
Toggle REM.

Access the Find dialog box
so that you can search for
a string in the current
macro.

From the Search menu,
choose Find or Replace.

Repeat the last Find
procedure.

From the Search menu,
choose Repeat Find.
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Choose To do this Or

Display the Functions and
Object browser.

From the View menu, choose
Functions and Objects.

Go to the Dialog Editor. From the Tools menu, choose
Dialog Editor.

Display the Variable
Watch window.

From the View menu, choose
Variable Watch.

Add the current variable
to the Variable Watch
window.

Compile your macro. From the Run menu, choose
Compile.

Run or continue the
current macro.

From the Run menu, choose
Go.

Stop execution of the
current macro.

From the Run menu, choose
Stop.

Single-step through the
macro source code.

From the Run menu, choose
Step.

Step into a called
procedure.

From the Run menu, choose
Step Into.

Step out of a called
procedure.

From the Run menu, choose
Step Out.

Move to the previous bug. From the Search menu,
choose Previous Error.

Move to the next bug. From the Search menu,
choose Next Error.

Activate the context-
sensitive Help cursor.
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Moving the Cursor within the Macro Editor Workspace

As with any Windows-based editor or word processing application, you
can use your mouse to reposition the cursor. Refer to the table below for
a list of keyboard shortcuts you can use to move the cursor.

Press To move

LEFT ARROW LEFT ONE CHARACTER

RIGHT ARROW Right one character

UP ARROW Up one line

DOWN ARROW Down one line

HOME To the beginning of the current line

END To the end of the current line

CTRL+LEFT ARROW Left one word

CTRL+RIGHT ARROW Right one word

PGUP Up one screen

PGDN Down one screen

CTRL+HOME To the beginning of the macro source code

CTRL+END To the end of the macro source code
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Macro Properties
Using the Properties and Security dialog box, the Macro Editor provides
a way to track macro author name and current revision number and to
limit access to the macro source code.

The Properties Dialog Box

In this dialog box, you can list the macro author, provide a macro
description for the most-recently-used macro list, provide Windows 95
Explorer keywords, provide command line execution information, or
choose or edit the bitmap icon associated with the macro. This dialog box
also allows you to limit access to its source code.

Refer to the following field descriptions for more information.

General page:

Macro Name: This is the name of the macro currently displayed in
the Macro Editor.

Revision: This is the revision number of the source code associated
with the named macro.

Author: (Optional) Enter the name of the macro author.

Description: (Optional) Enter a brief description of the macro. This
description will appear in the most-recently-used macro list.

Keywords: (Optional) Enter keywords for use in the Windows 95
Explorer search feature.

Command Line: (Optional) If you want this macro to be executable
from the operating system, enter the command required.

Customize button: (Optional) By default, the Macro Editor assigns
the bitmap icon shown to the left of the Customize button to the
current macro. To assign a different icon, or to edit the current icon,
choose the Customize button.

Bitmap Preview area: The bitmap you selected is displayed here for
verification.
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Security page:

No Restrictions: Choose this option for unlimited access to the
source code for this macro.

Require Password to Edit: Choose this option to require a password
in order to access the source code for this macro. Supply the
password in the Password text box described below.

Read-only - No Edits Allowed: Choose this option to provide read-
only access to the macro source code, but not write privileges.

Read-only Recommended - Warn Before Allowing Edits: Choose
this option to provide read-only access to the macro source code
along with a warning message that cautions other users to edit the
source code at their own risk.

Password text field: (Only required if you select the Read-Only or
Require Password to Edit options.) Enter the password you want to
associate with this macro. The next time anyone tries to open the
macro source code, they will be asked to supply this password.

To set macro properties and security access

1. From the Macro Editor File menu, choose Properties.

The Properties and Security dialog box is displayed with the General
page active.

2. Supply the necessary information in the General page.

3. Choose the Security tab to display the Security page.

4. Choose the appropriate security option and provide a password, if
necessary.

Associating an Existing Bitmap with a Macro
Any macro you create, whether recorded or written using EXTRA! Basic,
can have a bitmap assigned to it. This bitmap can then be included in an
EXTRA! Toolbar or QuickPad.
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The Select Bitmap Dialog Box

Use the Select Bitmap dialog box to choose a bitmap to assign to your
macro. From this dialog box, you can also choose to edit one of the
bitmaps provided.

Access this dialog box from the Properties and Security dialog box,
General page, Customize button.

Refer to the following field descriptions for more information.

Available Bitmaps list: Select one of the bitmaps provided with EXTRA!.
You can either accept this bitmap as is, or edit it to better illustrate your
macro’s functionality.

Preview area: This area displays how the selected bitmap will look as an
icon.

Edit button: Choose this to access the Edit Bitmap dialog box. From the
Edit Bitmap dialog box, you can alter the selected bitmap.

To associate an existing bitmap with a macro

1. From the Properties and Security dialog box, choose the Customize
button.

The Select Bitmap dialog box is displayed.

2. Scroll through the list of available bitmaps and select one.

–or–

Choose the Browse button to locate a bitmap not included in the
default collection supplied with EXTRA!.

The one you selected is displayed in the Preview area.

3. Choose OK to associate the bitmap you selected with the current
macro.

Editing the Bitmap Associated with a Macro
The stock icons included with EXTRA! should illustrate most of the
typical macros you might create. You will probably at some point,
however, create a macro for which there is no suitable stock icon. For this
reason, EXTRA! provides a simple icon editor that allows you to
manipulate a base icon pixel by pixel.

The Edit Bitmap Dialog Box

Use the Edit Bitmap dialog box to alter the selected bitmap design.



User’s Guide

12-20

Access this dialog box from the Select Bitmap dialog box, Edit button.

Refer to the following field descriptions for more information.

Preview area: This area displays how the working bitmap will look as a
finished icon.

Bitmap Workspace: This area is where you can edit your bitmap icon,
pixel by pixel.

To edit the bitmap associated with a macro

1. From the Properties and Security dialog box, choose the Customize
button.

The Select Bitmap dialog box is displayed.

2. Scroll through the list of available bitmaps and select a bitmap that
resembles the one you want to create.

–or–

Choose the Browse button to locate a bitmap not included in the
default collection supplied with EXTRA!.

The one you selected is displayed in the Preview area.

3. Choose Edit to display the selected bitmap in the Edit Bitmap dialog
box.

4. Use the color palette to paint the pixels in the bitmap work area.

5. Look at the Preview area to see how the finished icon will look.

6. Choose OK to accept the icon and add it to the list of available
bitmaps in the Select Bitmap dialog box.

7. Choose OK to associate the bitmap you selected with the current
macro.



Recording and Editing Macros

12-21

Reviewing Your Macro Code
The first step in locating errors is to compile your macro source code.

After an unsuccessful compile, the Macro Editor displays a “bug” symbol
in the side bar, next to the statement containing the error.

In addition, a description of the error appears in the status bar.

Review this description for syntax or usage errors. If you cannot find an
error, examine adjacent lines of code as well.

The Print Dialog Box

The Print dialog box enables you to print the source code in the active
macro window. Use this dialog box to specify the printer name, print
range, and the number of copies to print.

To print your macro code

If you prefer to review your macro source code on paper instead of on
the screen, you can print it out.

1. From the File menu, choose Print.

The Print dialog box appears.

2. Select the print range and print quality (dots per inch).

3. Specify the number of copies and indicate whether multiple copies
should be collated.

4. Choose OK.
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Editing Macro Code
You can add functions to your macro by typing each line in yourself,
including all the function’s parameters, or you can let the Macro Editor
insert a statement or function template for you. All you have to do is
supply the appropriate parameter values or variable names. In addition
to saving time, using the Macro Editor’s template feature means you
don’t have to worry about syntax errors.

Tip: To display a detailed online Help topic about a particular EXTRA!
Basic or OLE element, highlight the function, statement, or call in the
Editor workspace and press F1. The Help Index is displayed pointing to
the highest-level entry pertaining to the highlighted language item or
object. Choose an appropriate sub-entry, if desired, and then choose the
Display button.

To edit existing or recorded macro code

1. Start the Macro Editor from the EXTRA! Program Group or from the
Windows 95 Explorer.

–or–

Choose Macro from the Tools menu of EXTRA!.

The Macro dialog box appears.

2. Highlight the desired macro filename and choose the Edit button.

The Macro Editor displays your macro source code in the Macro
Editor workspace.

Undoing the Last Edit
Use the Undo feature to reverse the last edit performed.

To undo the last edit

• Choose Undo from the Edit menu.

Your macro is restored to the way it was before your last edit.



Recording and Editing Macros

12-23

Cutting the Highlighted Code Block
With the Macro Editor, you can cut a block of macro source code to the
Clipboard and, optionally, paste it from the Clipboard to another location
within the same macro or into a different macro.

To cut the highlighted code block

1. Position the cursor to the left of the first character in the code block
and drag to the right of the last character in the code block.

2. From the Edit menu, choose Cut.

Your code selection is removed from the Editor workspace and
copied to the Clipboard.

3. (Optional) Position the cursor where you want to insert the cut
source code.

4. From the Edit menu, choose Paste.

Your code selection is copied from the Clipboard to the Editor
workspace at the cursor location.

Copying the Highlighted Code Block
With the Macro Editor, you can copy a block of macro source code to the
Clipboard and paste it from the Clipboard to another location within the
same macro or into a different macro.

Note: Each EXTRA! Basic statement, function, and OLE automation call
online Help topic includes an example. To copy the example code into
your macro code, choose the Copy button in the example window, then
position the cursor in the Editor workspace and choose Paste from the
Edit menu. Rework the example, as needed.

To copy the highlighted code block

1. Position the cursor to the left of the first character in the code block
and drag to the right of the last character in the code block.

2. From the Edit menu, choose Copy.

Your code selection is copied to the Clipboard.
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3. Position the cursor where you want to insert the copied source code.

4. From the Edit menu, choose Paste.

Your code selection is copied from the Clipboard to the Editor
workspace at the cursor location.

Pasting from the Clipboard to the Cursor Location
With the Macro Editor, you can cut or copy a block of macro source code
to the Clipboard and paste it from the Clipboard to another location
within the same macro or into a different macro.

Note: Each EXTRA! Basic statement, function, and OLE automation call
online Help topic includes an example. To copy the example code into
your macro code, choose the Copy button in the example window, then
position the cursor in the Editor workspace and choose Paste from the
Edit menu. Rework the example, as needed.

To paste from the Clipboard to the cursor location

1. Position the cursor where you want to insert the copied source code.

2. From the Edit menu, choose Paste.

Your code selection is copied from the Clipboard to the Editor
workspace at the cursor location.

To move text within a macro

1. Position the cursor to the left of the first character in the code block
and drag to the right of the last character in the code block.

2. From the Edit menu, choose Cut.

Your code selection is copied to the Clipboard.

3. Position the cursor where you want to insert the cut source code.

4. From the Edit menu, choose Paste.

Your code selection is copied from the Clipboard to the into the
Editor workspace at the cursor location.
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Marking the Current Line or Code Block as a Remark
To isolate a bug in your macro source code logic, you may want to
temporarily skip a line (or more) of code by tagging the line as a
comment.

To mark the current line or code block as a remark

1. Position the cursor anywhere on the line.

2. From the Edit menu, choose Line REM.

This feature is a toggle. Repeat the procedure above to unmark the line.

Adding a Function or Object Shell to Your Macro Code
The Macro Editor provides a browser from which you can select EXTRA!
Basic statements and functions or Object Linking and Embedding calls.
Using the browser ensures that your syntax will be correct and eliminates
the need to memorize or look up complex syntax and parameter lists.

The Functions and Objects Browser
The Browser inserts a ‘‘shell’‘ or ‘‘template’‘ for the selected language call
into your macro source code at the cursor position. All you have to do is
substitute your macro-specific parameter names for the ones supplied by
the browser.

The Functions and Objects browser, Functions page.
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Functions page: Choose this to display a list of EXTRA! Basic functions
and statements.

Functions list: These are the EXTRA! Basic statements or functions.
Double-click a category to reveal the available statements and
functions. Double-click a statement or function to insert the syntax
shell in your source code.

Syntax: This area displays the syntax for the highlighted statement or
function. For more information, right-click on the window above.

Description: This area provides a brief description of the highlighted
statement or function.

The Functions and Objects browser, Objects page.

Objects page: Choose this to display a list of OLE Automation objects,
properties, and methods.

Type Library: These are the most-recently-used type libraries.
EXTRA.TLB is displayed the first time you access the Macro Editor.

Objects list: These are the OLE automation calls. Double-click a call
to insert the syntax shell in your source code.

Object syntax: This area displays the syntax for the highlighted OLE
object call.

Description: This area provides a brief description of the highlighted
OLE object call.
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To add a function or object shell to your macro code

1. From the View menu, choose Functions and Objects.

The Functions and Objects browser appears.

2. Choose the appropriate tab.

3. Choose the plus sign to the left of a folder to display the calls in that
category.

4. Scroll through the list until the call you want is displayed.

5. Choose the language call to display the syntax and a brief description
in the lower section of the browser.

Tip: Choose the small question mark button to the right of the syntax
to display the full online Help topic for that function, statement, or
object.

6. Choose the language call to copy a shell of the call to the current
cursor position in the Editor workspace.

7. From the Editor workspace, substitute your macro-specific
parameter names for the generic ones supplied with the shell.

Altering the Macro Editor User Interface
To gain more real-estate in the Macro Editor workspace, you can toggle
off the display of the Status bar, the Side bar, and line numbers. These
features are most important during the debugging phase of macro
development.

Toggling the Status Bar
The Status bar is located at the bottom of the Macro Editor. It displays
Editor information, compiler errors, and current cursor location.

To toggle the Status Bar on or off

• From the View menu, choose Status bar.

A check mark is displayed to the left of the Status bar option when
the Status bar is displayed.
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Toggling the Side Bar
The Side bar is located to the left of the Macro Editor workspace. This is
where items such as compilation errors and breakpoints are indicated. A
compilation error is indicated by a bug symbol:

and breakpoints are indicated by a stop sign:

When you are not actively debugging your macro source code, you may
opt to not show the Side bar. This will allow more room on the display
for your source code.

To toggle the Side Bar

• From the View menu, choose Side Bar.

A check mark is displayed to the left of the Side Bar option when the
Side Bar is displayed.

Toggling Line Numbers
Line numbers are located to the left of the Macro Editor workspace and
to the right of the Side bar (if it is toggled on). Line numbers are
important when trying to locate compiler errors.

To toggle line numbers

• From the View menu, choose Line Numbers.

A check mark is displayed to the left of the Line Numbers option
when Line Numbers are displayed.

Changing the Display Font
By default, the Macro Editor displays your macro source code using in
10-point Courier font. You can switch to a different font, if you’d like.
Note that the display font you select is also the font used to print your
macro source code.
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The Toolbar Dialog Box

Use the Toolbar dialog box to change the way in which the toolbar
buttons are displayed.

Refer to the following field descriptions for more information.

Show Toolbar: Select this option to display the Macro Editor toolbar.

If you clear this option, the toolbar does not appear.

Large Buttons: Select this option to display large buttons on the Macro
Editor toolbar.

If you clear this option, the Macro Editor displays small buttons.

Color Buttons: Select this option to display color buttons on the Macro
Editor toolbar.

If you clear this option, the Macro Editor displays monochrome buttons.

Show ToolTips: Select this option to display a brief description of the
function of the Macro Editor toolbar button when the mouse pointer is
over the button for more than one or two seconds.

If you clear this option, ToolTips do not appear.

To change the display font

1. From the Tools menu, choose Font.

The Font dialog box is displayed.

2. Choose a font, font style, and point size.

–or–

Choose a previously-defined font script.

3. Review the sample and revise your selections, if necessary.

4. Choose OK.
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Searching for Specific Text, a Line Number, or Errors
The Macro Editor allows you to search for a specific word, statement,
function, parameter, or OLE call in your macro. For example, you may
need to update a logon parameter for a new user ID. Using the Find
command, you can locate the old ID faster than if you search for it
manually. After finding and changing it, you can then use the Repeat
Find command to search the rest of the macro for any other IDs.

The Search menu also allows you to go to a particular line number or
from one compiler error to the next.

The Find Dialog Box

The find criteria used in a search are specified in the Find dialog box.

Refer to the following field descriptions for more information.

Find What: Type the string you want to locate.

Match Case: Select this option to find only those occurrences of the Find
What string with the identical capitalization.

Direction Up: Select this option to search from the cursor location to the
beginning of the macro.

Direction Down: Select this option to search from the cursor location to
the end of the macro.

Find Next: Choose this button to locate the next occurrence of the search
string.

To find macro code text

1. Place the cursor at the point in the macro source code where you
want to begin the search.

2. Choose Find from the Search menu.

The Find dialog box appears on your screen.

3. In the Find What text box, enter the exact word or phrase for which
you want to search.

Make sure your search string is spelled correctly and doesn’t include
extra blank spaces.

4. Select any of the other options, if desired.

5. Choose the Find Again button.



Recording and Editing Macros

12-31

Going to a Particular Line Number
In addition to searching for a particular string or jumping from one
compiler error to the next, you can also jump to a particular line number
in your macro source code. This feature is most useful when used in
conjunction with the compilation error report to jump directly to a
particular syntax error.

The Go To Dialog Box

This dialog box is used to specify the number of the line you want to
jump to within your macro source code.

In the Go To Line text box,  specify the number of the line to which you
want the Macro Editor to jump.

To go to a particular line number

1. From the Search menu, choose Go To.

The Go To dialog box is displayed.

2. Specify the number of the line to which you want to jump.

3. Choose OK.

To repeat the previous find action

1. Place the cursor at the point in the macro source code where you
want to continue the search.

2. Choose Repeat Find from the Search menu.

The Replace Dialog Box

The find criteria used in a search are specified in the Find and Replace
dialog box.

This feature is composed of the following elements:

Find What: Type the string you want to locate.

Replace With: Type the replacement text.

Match Case: Select this option to find only those occurrences of the Find
What string with the identical capitalization.
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Find Next button: Choose this button to locate the next occurrence of the
search string.

Replace button: Choose this button to replace the current Find What text
with the Replace With text.

Replace All button: Choose this button to replace all occurences of the
Find What text with the Replace With text.

To replace text

1. Place the cursor at the point in the macro source code where you
want to begin the search and replace command.

2. Choose Replace from the Search menu.

The Replace dialog box appears on your screen.

3. In the Find What text box, enter the exact word or phrase for which
you want to search.

Make sure your search string is spelled correctly and doesn’t include
extra blank spaces.

4. In the Replace With text box, enter the exact word or phrase with
which you want to replace the Find What text.

5. (Optional) Choose the Match Case option to find only those
occurrences of the Find What text with the identical capitalization.

6. Choose the Find Next button to jump to the next occurrence of the
Find What text.

7. Choose the Replace button to replace the current Find What text with
the Replace With text.

–or–

Choose the Replace All button to replace all occurences of the Find
What text with the Replace With text.
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To repeat the previous find and replace action

1. Place the cursor at the point in the macro source code where you
want to continue the search.

2. Choose Replace from the Search menu.

Make sure that the Find What and Replace With string is correct.

3. Choose the Find Next button.

4. Choose the Replace button.

–or–

Choose the Replace All button to replace all of the occurences of the
Find What text with the Replace With text from the cursor location
through the end of the macro source code.

To go to the next or previous compiler error

• To jump to the next error, from the Search menu, choose Next Error.

–or–

• To jump to the previous error, from the Search menu, choose
Previous Error.

To save a macro

• If you are working on an existing file and you want to save your
edits, choose Save from the File menu. The macro is saved under its
original name.

–or–

If you are working on several existing macros and you want to save
all of them, choose Save All from the File menu. The macros are
saved under their original names.

To save a macro under a different name

1.. If this is a new macro or you want to save it under a different name,
choose Save As from the File menu.

The Save As dialog box appears on your screen.

2.. In the Directories list box, select the directory to which you want to
save the macro.
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By default, the Macro Editor looks for macros in the \E!PC\Schemes
directory. For consistency, you should save your macros to this
directory.

3.. In the File Name field, enter a filename for the macro.

The Macro Editor automatically assigns the filename extension
(.EBM) to the file.

4.. Choose OK.

The macro is saved; its new name is displayed in the title bar of the
Macro Editor.

To delete a macro

Before you delete a macro, make sure it is not assigned to the Toolbar or
a QuickPad. Use the Unassign procedure before deleting.

1. Open the Windows File Manager or open the Windows 95 Explorer.

2. Locate the macro you want to delete and select it.

Unless you specified otherwise, the macro will be located in the
\E!PC\Schemes directory and will have the filename extension
.EBM.

3. Choose Delete from the File menu and then choose OK.

Compiling and Debugging Your Macro Code
Before you can run a macro, it must compile successfully  that is,
without syntax or semantic errors. A syntax error violates the
grammatical rules of EXTRA! Basic including spelling errors  for
example:

VG�!�'YVV(MV��HVMZIREQI��

D�*YRGXMSR�REQI�LEW�ER�I\XVE�DDV
D

And incorrect form  for example:

VG�!�'YV(MV����

D�*YRGXMSR�MW�QMWWMRK�XLI�HVMZI�REQI�TEVEQIXIV�

as well as missing or incorrect punctuation.

A semantic error is often syntactically correct but logically incorrect. For
example:

VG�!�'YV(MV��l�z�

D�2YQFIVW�EVI�RSX�ZEPMH�HVMZI�REQIW�
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Sometimes semantic errors are not detected by the Compiler. If your
macro compiles correctly but does not operate as expected when you run
it, your macro source code undoubtedly contains one or more semantic
errors. The Macro Editor comes with a variety of debugging tools that
will help you isolate such semantic errors.

To compile your macro

• From the Run menu, choose Compile.

The Macro Editor compiles your macro source code.

Note: Your macro is compiled automatically when you choose Go.

About Stepping
Step through your macro source code to execute the code one instruction
at a time in the same order in which the instructions are executed when
you actually run the macro. Stepping is the best way to pinpoint errors in
source code logic.

If the current line is a call to an EXTRA! Basic subroutine or function, use
the Step Into command to jump to the first line of the called subroutine
or function. Use the Step Out command to break out of the subroutine or
function and return to the next line of the calling procedure.

Note: If you do not explicitly Step Into a called subroutine or function, it
will be executed as a single line of code.

To step through your source code

1. From the Run menu, choose Step.

The first instruction to be executed is highlighted.

2. Repeat until you have located the logical error or until you have
single-stepped through the entire macro.

–or–

If the current instruction is a call to a subroutine or function, choose
Step Into from the Run menu to single-step through the subroutine
or function instead of executing the entire call at once. Choose Step
Out to break out of the subroutine or function and return to the next
line of the calling procedure.
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Setting Breakpoints
To suspend execution at a particular line so that the state of your macro
can be examined, set a breakpoint. This method is most effective when
you have narrowed your search for a bug to a few specific lines.

The Breakpoints Dialog Box

From the Breakpoints dialog box you can add, delete, and clear
breakpoints. It provides a list box of all of the breakpoints set for the
current macro.

The Breakpoints dialog box.

Refer to the following field descriptions for more information.

Location: If an existing breakpoint is selected in the Breakpoints list box,
the line number of the breakpoint is listed here. If you want to create a
new breakpoint, type the breakpoint line number here.

Breakpoints: This list box displays the line numbers of the current
breakpoints.

Add: Choose this button to add a new breakpoint at the line number
indicated in Location.

Delete: Choose this button to delete the breakpoint currently highlighted
in the Breakpoints list box.

Clear All: Choose this button to remove all breakpoints.
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To set breakpoints

1. Place the cursor anywhere within the line in which you want to set a
breakpoint.

2. From the Run menu, choose Toggle Breakpoint.

–or–

Choose on the side bar next to the line in which you want to set a
breakpoint.

The Macro Editor places a breakpoint symbol in the side bar directly
opposite the line with the breakpoint. The breakpoint symbol looks
like this:

3. From the run menu, choose Go to run the macro.

Execution stops at the first line with a breakpoint.

To clear a breakpoint

1. Place the cursor anywhere within the line containing the breakpoint.

2. From the Run menu, choose Toggle Breakpoint.

–or–

Choose the Breakpoint icon in the side bar.

The breakpoint is cleared and the breakpoint symbol is removed from
the side bar.

To clear all breakpoints

• From the Run menu, choose Clear All Breakpoints.
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Monitoring the Value of a Particular Variable
The variable window is used, when debugging, to examine the contents
of the variables associated with a particular function or procedure.

The Variable Watch window.

The graphic above illustrates a variable watch at line number 19.

To watch the value of a variable, single-step through your macro source
code.



Using the
Macro Dialog

Editor
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he Dialog Box Editor is used to graphically edit the layout of dialog
boxes used in the Macro Editor. The Macro Editor invokes the dialog

box editor with the Dialog Editor command in the Tools menu. You can
run the dialog box editor directly, with input from the Clipboard or from
a file.

Creating, Opening, and Saving Dialog Box Editor Files
Refer to the following procedures to create a file, open an existing file,
and save a file.

To create a new file

• Choose New from the File menu (CTRL+N).

This command clears the contents of the current dialog box and creates
the default dialog box.

To open an existing file

• Choose Open from the File menu (CTRL+O).

This command replaces the contents of the current dialog box with a new
dialog box read in from a file.

To save a file

• Choose Save from the File menu (Ctrl+S).

This command saves the contents of the current dialog box to a file.

To save a file as a different name

0 Choose Save As from the File menu.

This command saves the contents of the current dialog box to a file with a
new name.

To use the Recent File Command

• Choose a file name in the list to re-open the file.

This command displays a list of the most recently opened files.

T
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Configuration Options
The Dialog Editor allows you to set configuration options for the dialog
box code. The configuration options include undo levels, grid size, 3D
controls, and input/output units.

The Options Dialog Box

The following configuration options are available in the Options dialog
box.

Undo Levels:  The number of operations that will be remembered for
undo (memory permitting). For more information about undo actions,
refer to Undoing and Redoing Actions.

Grid:  Configures the horizontal and vertical grid size. For more
information about the grid, refer to Using the Grid Command later in this
chapter.

3D Controls:  Changes the look of the controls in the dialog box.

Word 6 Units:  Indicates whether the input and output units for the
dialog box are the units used by Microsoft Word, Version 6.0 or the
standard dialog box units.

To set configuration options

1. Choose Options from the View menu.

–or–

Select the Options button  from the toolbar.

2. Set the configuration options as desired.

3. Select OK.

Dialog Box Controls
The Dialog Box controls appear on a floating control palette in the Dialog
Editor’s desktop. Controls can be added to the dialog box and then
moved and sized as needed. Each control has a set of properties, such as
a label and a unique ID. This section discusses how to use the control
palette and identifies each control and the control’s properties.
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The Control Palette
The Control Palette is displayed as a floating toolbar in the Dialog Box
Editor workspace. The following controls appear in the palette.

  Selection Tool

  Button Control

  OptionButton Control

  Text Control

  TextBox Control

  CheckBox Control

  ListBox Control

  StaticComboBox Control

  DropComboBox Control

  DropListBox Control

  GroupBox Control

  Picture Control

For more information on each control, refer to the section that covers the
specified control.

To view the Control Palette

• Choose Control Palette from the View menu to show or hide the
palette.
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To add a control

1. Click and hold the control button on the Control Palette.

2. Drag the control onto the dialog box where you want it to appear.

3. Release the mouse button.

– or –

1. Select a control from the Control menu.

2. Drag a frame in the dialog box with the mouse to indicate where you
want the control to appear.

3. Release the mouse button.

The selected control will appear in the area you indicated.

Control Properties

There are several attributes of a control that may be edited in the
control’s property sheet.

Examples of control properties include the control’s position and size. In
addition, many controls have a control ID, which is the identifier used to
access the control from a Basic script and a control Label.

Control labels are either strings or Basic expression, which when
executed in Basic result in a string. This resulting string is then used to
visually identify a control in the dialog box and to assist in keyboard
navigation of the dialog box. Characters preceded by an ampersand (&)
in a label are underlined. For example, setting a label to &Name causes
Name to be displayed on the control with which the label is associated.
This underlined letter indicates the hot key associated with this control.
For Buttons, OptionButtons, and CheckBoxes the action is the same as
clicking the mouse on the control. For Text Controls, the hot key causes
the control following the text control in the Tab Order to be activated.
This provides a mechanism for labeling controls that do not have labels
of their own, such as TextBoxes and ListBoxes. For more information on
Tab Order, refer to “Setting the Tab Order” later in this chapter.

For information on properties particular to individual controls, see the
description of those controls.
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To open the control’s property sheet

1. Add the control to your dialog box by clicking the control in the
Control Palette and dragging it onto the dialog box.

2. Double-click the control, or select the control and press ENTER.

The Selection Tool
The Selection tool is used to manipulate a dialog box’s controls.
Modifications to existing controls are typically made by executing
commands which act on the currently selected controls in the dialog box.
There are several ways to modify the selection.

Clicking on a control with the Selection tool active selects that control
and deselects any other controls that may be selected. Pressing the SHIFT
key on the keyboard and clicking on a control toggles its selection state
without modifying the selection state of any of the other controls in the
dialog box.

The Selection tool may also be used to select a set of controls touching a
rectangular region — just drag out a frame. All controls inside or
touching the rectangle become the current selection. Pressing the SHIFT
key on the keyboard while dragging out a rectangle adds all controls
inside or touching the rectangle to the current selection.

Selected controls look like this:

Some editing commands in the dialog box editor use size and position
attributes of the primary control to modify the size and position
attributes of other controls in the selection. In this example, the Cancel
button is the primary control. Selected controls can be moved, sized,
deleted, and cut or copied to the clipboard.

To activate the selection tool

• Choose the  tool on the Control Palette, or choose Select from the
Control menu.
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The Button Control
The button control is used to create push buttons in the dialog box. There
are three kinds of push buttons in dialog boxes:

Normal Button:  These are the most basic push buttons. These buttons
may have labels and IDs.

OK Button:  These buttons are like normal buttons except their labels
cannot be modified and there can only be one OK Button in a dialog box.

Cancel Button:  These buttons are like normal buttons except their labels
cannot be modified and there can only be one Cancel Button in a dialog
box.

For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

Button Properties

To open the Properties dialog box, double-click the control.

Button Type:  If the button is an OK or Cancel button, the label cannot be
modified and only one OK or Cancel button can appear in a dialog box.
The Normal button has a label and an ID.

Button Label:  Labels are either strings or a Basic expression, which
when executed in Basic result in a string. This resulting string is then
used to visually identify a control in the dialog box and to assist in
keyboard navigation of the dialog box. Characters preceded by an
ampersand (&) in a label are underlined. For example, setting a label to
&Name causes Name to be displayed on the button. This underlined
letter indicates the hot key associated with the button.

Button ID:  The identifier used to access the control from a Basic script
and a control label.

Label is a macro variable:  Select this option if the label is a macro
variable.

Size and Position:  The X and Y coordinates of the button, indicating the
button’s position in the dialog box, and the width and height of the
button.
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The OptionButton Control
OptionButtons are used to present a set of options to the user of the
dialog box. Every option button belongs to a particular OptionGroup,
which is configurable from the OptionButton Group drop down combo
box in the OptionButton Properties dialog box.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

OptionButton Properties

To open the Properties dialog box, double-click the control.

OptionButton label: Labels are either strings or a Basic expression,
which when executed in Basic result in a string. This resulting string is
then used to visually identify a control in the dialog box and to assist in
keyboard navigation of the dialog box. Characters preceded by an
ampersand (&) in a label are underlined. For example, setting a label to
&Name causes Name to be displayed next to the option button. This
underlined letter indicates the hot key associated with the option button.

OptionButton ID: The identifier used to access the control from a Basic
script and a control label.

OptionButton group:  The group to which the option button belongs.

Label is a macro variable: Select this option if the label is a macro
variable.

Size and position: The X and Y coordinates of the option button,
indicating the option button’s position in the dialog box, and the width
and height of the option button.

The Text Control
Text controls are typically used to label other controls that do not have a
visible label. To use them as a navigation aid, place them immediately
before the control they are labeling in the Tab Order. For more
information on Tab Order, refer to “Setting the Tab Order” later in this
chapter.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.
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Text Properties

To open the Properties dialog box, double-click the control.

Text Label:  Labels are either strings or a Basic expression, which when
executed in Basic result in a string. This resulting string is then used to
visually identify a control in the dialog box and to assist in keyboard
navigation of the dialog box. Characters preceded by an ampersand (&)
in a label are underlined. For example, setting a label to &Name causes
Name to be displayed as the text. This underlined letter indicates the hot
key associated with the text.

Text ID:  The identifier used to access the control from a Basic script and
a control label.

Label is a macro variable: Select this option if the label is a macro
variable.

Size and position: The X and Y coordinates of the text, indicating the
text’s position in the dialog box, and the width and height of the text.

The TextBox Control
TextBox controls are used to gather input from the user of the dialog box.
Normally, the TextBox control echoes characters as the user of the dialog
box types them in. Selecting No Echo in the Text Box Properties dialog
box causes the edit control to echo asterisks instead.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

TextBox Properties

To open the Properties dialog box, double-click the control.

TextBox ID:  The identifier used to access the control from a Basic script
and a control label.

Password/no echo style: Select this option if you want the edit control to
echo asterisks instead of the actual password when entered.

Size and position: The X and Y coordinates of the text box, indicating the
text box’s position in the dialog box, and the width and height of the text
box.
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The CheckBox Control
CheckBox controls are used to present the dialog box user with a two-
state switch.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

CheckBox Properties

To open the Properties dialog box, double-click the control.

CheckBox Label: Labels are either strings or a Basic expression, which
when executed in Basic result in a string. This resulting string is then
used to visually identify a control in the dialog box and to assist in
keyboard navigation of the dialog box. Characters preceded by an
ampersand (&) in a label are underlined. For example, setting a label to
&Name causes Name to be displayed next to the check box. This
underlined letter indicates the hot key associated with the check box.

CheckBox ID: The identifier used to access the control from a Basic script
and a control label.

Label is a macro variable: Select this option if the label is a macro
variable.

Size and position: The X and Y coordinates of the check box, indicating
the position of the control in the dialog box, and the width and height of
the check box.

The ListBox Control
ListBox controls are used to present the dialog box user with a list of
strings.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.
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ListBox Properties

To open the Properties dialog box, double-click the control.

ListBox ID: The identifier used to access the control from a Basic script
and a control label.

ListBox Contents: The list of options to appear in the ListBox.

Contents are a macro variable expression: Select this option if the
contents of the ListBox are macro variable expressions.

Size and position: The X and Y coordinates of the ListBox, indicating the
position of the control in the dialog box, and the width and height of the
ListBox.

The StaticComboBox Control
StaticComboBox controls are similar to ListBox controls, except that the
user may type in a new string instead of selecting one of the strings in the
list.

For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

StaticComboBox Properties

To open the Properties dialog box, double-click the control.

StaticComboBox ID: The identifier used to access the control from a
Basic script and a control label.

StaticComboBox Contents: The list of options to appear in the
StaticComboBox. The user may type in a new string instead of selecting
one of the strings in the list.

Contents are a macro variable expression: Select this option if the
contents of the StaticComboBox are macro variable expressions.

Size and position: The X and Y coordinates of the StaticComboBox,
indicating the position of the control in the dialog box, and the width and
height of the StaticComboBox.
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The DropComboBox Control
DropComboBox controls are similar to DropListBox Controls, except that
the user may type in a new string instead of selecting from one of the
strings in the list.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

DropComboBox Properties

To open the Properties dialog box, double-click the control.

DropComboBox ID: The identifier used to access the control from a
Basic script and a control label.

DropComboBox Contents: The list of options to appear in the
DropComboBox. The user may type in a new string instead of selecting
one of the strings in the list.

Contents are a macro variable expression: Select this option if the
contents of the DropComboBox are macro variable expressions.

Size and position: The X and Y coordinates of the DropComboBox,
indicating the position of the control in the dialog box, and the width and
height of the DropComboBox.

The DropListBox Control
DropListBox controls differ from ListBox controls in appearance only.
Typically, drop list boxes look like this:

If a string from the control is selected, it appears in the control. When the

user clicks on the , the control expands to present the list of the
strings.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.
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DropListBox Properties

To open the Properties dialog box, double-click the control.

DropListBox ID: The identifier used to access the control from a Basic
script and a control label.

DropListBox Contents: The list of options to appear in the DropListBox.
The user may type in a new string instead of selecting one of the strings
in the list.

Contents are a macro variable expression: Select this option if the
contents of the DropListBox are macro variable expressions.

Size and position: The X and Y coordinates of the DropListBox,
indicating the position of the control in the dialog box, and the width and
height of the DropListBox.

The GroupBox Control
GroupBox controls visually group controls in a dialog box. In addition,
they can be used to provide a navigational hierarchy to the dialog box
user.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

GroupBox Properties

To open the Properties dialog box, double-click the control.

GroupBox Label: Labels are either strings or a Basic expression, which
when executed in Basic result in a string. This resulting string is then
used to visually identify a control in the dialog box and to assist in
keyboard navigation of the dialog box. Characters preceded by an
ampersand (&) in a label are underlined. For example, setting a label to
&Name causes Name to be displayed above the GroupBox. This
underlined letter indicates the hot key associated with the GroupBox.

GroupBox ID: The identifier used to access the control from a Basic
script and a control label.

Label is a macro variable: Select this option if the label is a macro
variable.

Size and position: The X and Y coordinates of the GroupBox, indicating
the position of the control in the dialog box, and the width and height of
the GroupBox.
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The Picture Control
Picture controls are used to place bitmaps into the dialog box. Picture
controls get their contents from either the clipboard or a Windows
bitmap (.BMP) file. The Picture Filename, the Browse button and the
Filename is a Macro Variable checkbox are unavailable if the Picture
Source is set to Clipboard.

 For information on adding a control and opening the control’s property
sheet, refer to “The Control Palette” earlier in this chapter.

Picture Properties

To open the Properties dialog box, double-click the control.

Picture source: Choose File or Clipboard to specify the source of the
picture.

Picture file name: If you chose the File option above, enter the .BMP
filename in this field, or choose the Browse button to specify the .BMP
file that you want to use.

Picture ID: The identifier used to access the control from a Basic script
and a control label.

Suppress message: Specifies that the picture control not display the
“missing picture” warning if the picture for the dialog box cannot be
located.

Filename is a macro variable: Specifies that the string in the Picture File
field is a formula.

Size and position: The X and Y coordinates of the Picture, indicating the
position of the control in the dialog box, and the width and height of the
Picture.
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Designing the Dialog Box Layout
Use the following commands and tools to modify the layout of the dialog
box.

Aligning Controls
Use the following Align Controls commands to arrange groups of
controls.

The first control selected in the dialog box becomes the primary control.
The Align Controls command uses size and position attributes of the
primary control to modify the size and position attributes of other
controls in the selection.

Left:  Align the selected controls to the left edge of the primary control
(keyboard shortcut: CTRL + LEFT ARROW).

Right: Align the selected controls to the right edge of the primary control
(keyboard shortcut: CTRL + RIGHT ARROW).

Top: Align the selected controls to the top edge of the primary control
(keyboard shortcut: CTRL + UP ARROW).

Bottom: Align the selected controls to the bottom edge of the primary
control (keyboard shortcut: CTRL + DOWN ARROW).

Vert. Centers: Align the selected controls so that their vertical center is
the same as that of the primary control (keyboard shortcut: F9).

Horiz. Centers: Align the selected controls so that their horizontal center
is the same as that of the primary control (keyboard shortcut: SHIFT + F9).

To align controls

1. Choose Align Controls from the Layout menu.

2. From the submenu, choose Right, Left, Top, Bottom, Vert. Centers, or
Horiz. Centers.



User’s Guide

13-16

Spacing Controls Evenly
This command is used to equalize the horizontal or vertical spacing of
three or more selected controls.

Across: The leftmost and rightmost controls are not moved. The
remaining controls are spaced evenly between the leftmost and rightmost
controls in their tab order. (keyboard shortcut: ALT + RIGHT ARROW).

Down: The uppermost and bottom controls are not moved. The
remaining controls are spaced evenly between the topmost and bottom
controls in their tab order. (keyboard shortcut: ALT + DOWN ARROW).

To space controls evenly

1. Choose Space Evenly from the Layout menu.

2. From the submenu choose Across or Down.

Centering a Control in the Dialog Box
This command is used to center the controls in the dialog box.

Vertical: Center the bounding frame of the selected controls vertically in
the dialog box (keyboard shortcut: CTRL + F9).

Horizontal: Center the bounding frame of the selected controls
horizontally in the dialog box (keyboard shortcut: CTRL + SHIFT + F9).

To center a control in the dialog box

1. Choose Center in Dialog from the Layout menu.

2. From the submenu choose Vertical or Horizontal.

Arranging Buttons
The Arrange Buttons command aligns selected buttons.

Right: This command lines up the selected buttons on the right side of
the dialog box. The buttons are arranged in tab order from top to bottom
(keyboard shortcut: CTRL + B).

Bottom: This command lines up the selected buttons centered on the
bottom of the dialog box. The buttons are arranged in tab order from left
to right (keyboard shortcut: CTRL + SHIFT + B).
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To arrange buttons

1. Choose Arrange Buttons from the Layout menu.

2. From the submenu choose Right or Bottom.

Making Controls the Same Size
The Make Same Size commands size the selected controls to match that
of the primary control.

The first control selected in the dialog box becomes the primary control.
The Make Same Size command uses size and position attributes of the
primary control to modify the size and position attributes of other
controls in the selection.

Width: Size the selected controls so that their width is the same as that of
the primary control (keyboard shortcut: CTRL + -).

Height: Size the selected controls so that their height is the same as that
of the primary control (keyboard shortcut: CTRL + \).

Both: Size the selected controls so that their width and height is the same
as that of the primary control (keyboard shortcut: CTRL + =).

To make controls the same size

1. Choose Make Same Size from the Layout menu.

2. From the submenu choose Width, Height or Both.

Sizing to Content
This command changes the size of various controls to be the right size for
the control’s contents. For Text, CheckBox, Button and OptionButton
controls, the control size is adjusted to accommodate the labels for these
controls. For the picture control, the control is resized to be either the size
of the picture or the maximum picture size that preserves aspect ratio
and fits in the dialog box, whichever is smaller.

To size to content

• Choose Size to Content (CTRL + =) from the Layout menu.
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Moving, Sizing, and Deleting
Dialog box controls can be moved within the dialog box, modified to a
different size and deleted. The dialog box can be moved and sized.

To move a control

1. Position the mouse over the selected control until the cursor turns
into .

2. Press and hold the mouse button and drag the control to the desired
position.

3. Release the mouse button.

Collections of selected controls can be moved in a similar manner — drag
one of the selected controls and the rest will follow.

To size a control

1. Click the control so that the hatched frame appears around it. The
sizing handles of a selected control are the solid black squares that
appear in the hatched border around the selected control.

2. Move the cursor over on of these black squares until the cursor
changes to , , , or .

3. Press and hold the mouse button and drag the control to the desired
size.

4. Release the mouse button.

To delete a control

1. Click the control so that the hatched frame appears around it,
indicating that it is selected.

2. Choose Delete from the Edit menu, or press the DEL button.
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To size the dialog box

1. Move the mouse over the borders of the dialog box until the cursor
changes to either , , , or .

2. Press and hold the mouse button and move the mouse until the
outline shows the desired size.

3. Release the mouse button to complete the operation.

The size and position of the dialog box as well as other properties of
the dialog box can be modified in the Dialog Box Properties dialog
box.

To move the dialog box

1. Move the mouse into the caption of the dialog box.

2. Press and hold the mouse button and move the mouse until the
dialog box is in the desired position.

3. Release the mouse button.

The size and position of the dialog box as well as other properties of
the dialog box can be modified in the Dialog Box Properties dialog
box. For more information on dialog box properties, refer to “Dialog
Box Properties” later in this chapter.

Setting the Tab Order
The tab order is the order in which focus shifts when the user of the
dialog box presses the tab button. Also, the tab order is used to associate
Text controls with the controls they label, that is, TextBox, ListBox,
DropListBox, StaticComboBox, and DropComboBox.

When this mode is activated, the tab order of the controls is indicated by
the number that appears in the upper left corner of each control. The
control with the number one (1) is the control that will receive the focus
when the dialog box is opened by the user.
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To set the tab order

1. Choose Set Tab Order from the Layout menu. Set Tab Order mode is
indicated by the number that appears in the upper left corner of each
control. The number indicates the control’s place in the tab order.

2. Change the tab order by clicking each control in the sequence you
want the tab order to be. The tab order number in the upper left
corner will change accordingly.

Pressing ESC, clicking on anything but a control, or reaching the end
of the tab list exits the tab order setting mode.

Undoing and Redoing Actions
Use the following procedures to undo and redo actions.

To undo an action

• Choose Undo from the Edit menu (CTRL+Z).

The number of operations that can be undone is limited by the size of
memory and is configurable in the Options dialog box. For more
information, refer to “Configuration Options” earlier in this chapter.

To Redo an action

• Choose Redo from the Edit menu (CTRL+R).

This command re-executes the last undone editing operation.

Cutting, Copying, Deleting and Pasting
Use these commands to remove, copy and paste controls within the
dialog box.

To use the Cut command

• Choose Cut from the Edit menu (CTRL+X).

This command copies the current selection to the clipboard and then
deletes the current selection.

To use the Copy command

• Choose Copy from the Edit menu (CTRL+C).

This command copies the code for the current selection to the clipboard.
If there is no current selection, this command copies the entire dialog box
to the clipboard.
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To use the Delete command

• Choose Delete from the Edit menu (DEL).

This command removes the selected control(s) from the dialog box.

To use the Paste command

• Choose Paste from the Edit menu (CTRL+V).

This command pastes the controls on the clipboard into the current
dialog box and makes the pasted controls the selection. If there is an
entire dialog box on the clipboard, the current dialog box is replaced with
that dialog box.

Copying the Dialog Box to the Clipboard
This command copies the entire dialog box to the Clipboard. The dialog
box will stay in the Clipboard until something else is copied to the
Clipboard.

To copy the entire dialog box to the Clipboard

• From the Edit menu choose Copy Entire Dialog to the Clipboard.

Using the Parse Command
The Parse command compiles the dialog box code.

To use the Parse Command

• Choose Parse from the Edit menu.

Using the Grid Command
The Grid is a layout aid which forces controls to be aligned on
configurable horizontal and vertical intervals. Turning the grid on and
off has no effect on the controls in the dialog box. Rather, the effect is
realized when creating, moving and sizing controls in the dialog box.

When the grid is turned on, the dialog box will display black dots to
indicated the horizontal and vertical alignment intervals. When controls
are sized, the coordinates being modified are aligned to the alignment
intervals. When controls are moved or created, the upper left corner of
the controls is aligned to the alignment intervals. When a control is
created by dragging a frame with the mouse, the lower right corner of the
control is aligned as well.
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To activate the grid

• Choose the  button from the toolbar to turn the grid on and off.

Viewing the Toolbar
This command will show or hide the toolbar.

To view the toolbar

• Choose Toolbar from the View menu to show or hide the toolbar.

Viewing the Status Bar
This command shows or hides the status bar.

To view the status bar

• Choose Status Bar from the View menu to show or hide the status
bar.

Viewing the Code
This command displays a dialog box which shows the Basic code that
represents the dialog box being edited. You may modify this code and
press the Update button to replace the current dialog box with the one
represented by the code in the dialog box.

To view the code

1. Choose Code from the View menu to open the Dialog Code dialog
box.

2. Choose the Update button to replace the current dialog box with
modified code.

3. Choose Cancel to close the Dialog Code dialog box.

Dialog Box Properties
The dialog box has several properties that affect its behavior in your basic
program. The size and relative position of the dialog box may be
modified directly by changing the size and position of the dialog box
window in the dialog box editor.
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The Dialog Properties Dialog Box

The following is a description of the properties that can be modified in
the Dialog Box Properties dialog box:

Dialog ID:  This specifies the type name of the dialog box used in your
Basic script.

Caption type & Caption:  The Caption Type field specifies the type of
caption to use for your dialog box. If None is selected, the Caption field
of this dialog box is disabled and the dialog box caption is set to the
application’s default dialog box caption. If Caption Type is set to String,
the Caption field is enabled and its contents is used to set the caption of
the dialog box. If Caption Type is set to Expression, the Caption field is
assumed to contain a Basic expression. In this last case, the Basic
expression is not interpreted by the dialog box editor, but will be
properly interpreted by Basic when the program using the Basic dialog
box is executed.

Macro function name:  This field specifies the name of the optional
dialog box function associated with this Basic dialog box.

ButtonGroup ID:  This field specifies the name of the optional
ButtonGroup associated with this Basic dialog box.

Size and Position:  The position of the dialog box relative to the upper
left corner of the application can be set by selecting the Position check
box and modifying the X and Y fields of the Dialog Box Properties dialog
box. If X and/or Y contains a valid number, the position of the dialog box
window in the dialog box editor is modified accordingly. Non-numeric
values for X and/or Y are assumed to be Basic expressions which are
interpreted when the program using the Basic dialog box is executed. If
the Position check box is not selected, the dialog box is centered on the
application. The Width and Height fields of the dialog box are used to
change the size of the dialog box.

To display the Dialog Properties dialog box

• Double click on an area of the dialog box window that does not
contain any controls, or press ENTER if there are no controls selected.
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Inserting the Dialog Box Code into the Macro Editor
Once the dialog box code is completed, copy the code into the Macro
Editor by using the following procedure.

To insert the dialog box code into the Macro Editor

1. From the Edit menu, choose Copy Entire Dialog Box to Clipboard.

2. Move to the Macro Editor and place the cursor where you want the
dialog box code to appear.

3. From the Macro Editor Edit menu, choose Paste.

Exiting the Dialog Editor
Use the following procedure to close the Macro Dialog Box Editor.

To exit Macro Dialog Box Editor

• Choose Exit from the File menu (ALT+F4).
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sing EXTRA! Security you can control how EXTRA! performs. By
making parts of EXTRA! secure, you can remove commands from

menus, disable buttons on toolbars and QuickPads, and disable keys on
keyboard maps.

For example, if you want to stop all users from creating a new session,
you can secure the New Session command. The next time a user tries to
create a new session, the New Session command will no longer appear in
the File menu, and any keystrokes or buttons that are supposed to open a
new session will be disabled as well. (If the user tries to use the keystroke
or button to open a new session, a security error message is displayed.)

In addition to making parts of EXTRA! secured, you can limit who can
use Security by adding password-protection to Security. When you set a
Security password, the user will have to enter the password before he or
she can change any security settings.

Important: The Security dialog box contains commands that may not be
available with different configurations of EXTRA!. For example, if you
have not configured a File Transfer protocol, file transfer commands will
not appear in the Tools menu or the toolbar. Also, if you remove all
commands from a menu, that menu name will not appear on the menu
bar.

For quick reference, the procedures in this chapter are listed below. If
you are not familiar with all the commands that can be secured or you
don’t know which category a command is in, read the following section
first and then go to the procedures.

To Go to page

Select a scheme to edit 13

Select the active scheme 14

Secure a command 13

Set a password 14

U
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Commands You Can Secure
The following commands can be removed from EXTRA!. To select a
command, you will need to know which category it is in.

Application Commands
Run Application: Removes Run Application from the commands
available on the Action page. The user will not be able to run applications
using keyboard maps, Toolbars, HotSpots, or QuickPads when this
command is secured.

Run Keyboard Map Editor: Removes Keyboard Map Editor from the
commands available on the Action page. The user will not be able to edit
maps from a Toolbar, HotSpot, QuickPad, or another keyboard map
when this command is secured.

The Keyboard Map Editor will be still available through the Settings
dialog box.

Run QuickPad Editor: Removes Run QuickPad Editor from the
commands available on the Action page. The user will not be able to edit
QuickPads from a keyboard map, Toolbar, HotSpot, or another QuickPad
when this command is secured.

The QuickPad Editor will be still available through the Settings dialog
box.

Run Toolbar Editor: Removes Run Toolbar Editor from the commands
available on the Action page. The user will not be able to edit Toolbars
from a keyboard map, HotSpot, QuickPad, or another Toolbar when this
command is secured.

The Toolbar Editor will be still available through the Settings dialog box.
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Help Menu Commands
Help Topics: Removes the Help Topics command from the Help menu
and from the commands available on the Action page. The user can still
activate Help from Help buttons and from the What’s This button.

Help Instructions: Removes the Using Help command from the Help
menu.

Office Compatible Help: Removes the Office Compatible command
from the Help menu.

About: Removes the About EXTRA! command from the Help menu.

Edit Menu Commands
Cut Command: Removes the Cut command from the Edit menu and
from the commands available on the Action page. The user will not be
able to cut selected text from sessions and save it to the clipboard when
this command is secured.

Copy Command: Removes the Copy command from the Edit menu and
from the commands available on the Action page. The user will not be
able to copy selected text from sessions when this command is secured.

Cut Append Command: Removes the Cut Append command from the
Edit menu and from the commands available on the Action page. The
user will not be able to cut selected text and append it to sessions when
this command is secured.

Copy Append Command: Removes the Copy Append command from
the Edit menu and from the commands available on the Action page. The
user will not be able to copy selected text and append it to sessions when
this command is secured.

Paste Command: Removes the Paste command from the Edit menu and
from the commands available on the Action page. The user will not be
able to paste text to his or her sessions when this command is secured.

Paste Continue Command: Removes the Paste Continue command from
the Edit menu and from the commands available on the Action page. The
user will not be able to paste the remaining portion of the contents of the
Clipboard if a Clipboard item is larger than the destination host screen.

Clear Display Command: For VT sessions only. Removes the Clear
Display command from the Edit menu and from the commands available
on the Action page.
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Select All Command: Removes the Select All command from the Edit
menu and from the commands available on the Action page. The user
will not be able to select all the display with a single command when
Select All is secured.

Select Display Command: For VT sessions only. Removes the Select
Display command from the Edit menu and from the commands available
on the Action page.

Settings Command: Removes the Settings command from the Edit menu
and from the commands available on the Action page. The user will not
be able to open the Settings dialog box from the Edit menu when this
command is secured.

The Settings dialog box will still be available through the Options menu
and from the Session Type dialog box.

File Menu Commands
New Session Command: Removes the New Session command from the
File menu and from the commands available on the Action page. In
addition, the prompt for adding a new session during setup is also
removed.

The user will not be able to create a new session when this command is
secured.

Open Session Command: Removes the Open Session command from the
File menu and from the commands available on the Action page. In
addition, the prompt for opening an existing session during setup is also
removed.

The user will not be able to open an existing session when this command
is secured.

Open Specific Session Command: Removes the Open Session command
from the commands available on the Action page.

Save Session Command: Removes the Save Session command from the
File menu and from the commands available on the Action page. The
user will not be able to save a session under its existing name when this
command is secured.

Save Session As Command: Removes the Save Session As command
from the File menu and from the commands available on the Action
page. The user will not be able to save a session under a new name when
this command is secured.
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Open Layout Command: Removes the Open Layout command from the
File menu and from the commands available on the Action page. The
user will not be able to open a different layout when this command is
secured.

Save Layout Command: Removes the Save Layout command from the
File menu and from the commands available on the Action page. The
user will not be able to save any changes he or she has made to the layout
of their session when this command is secured.

Properties Command: Removes the Properties command from the File
menu and from the commands available on the Action page. The user
will not be able to see information about his or her session when this
command is secured.

Print Settings Command: Removes the Print Settings command from the
File menu and from the commands available on the Action page. The
user will not be able to change page options when this command is
secured.

Print Screen Dialog Command: Removes the Print Screen Dialog
command from the File menu and from the commands available on the
Action page. The user will not be able to change printer settings when
this command is secured.

Print Screen Command: Removes the Print Screen command from the
File menu and from the commands available on the Action page. The
user will not be able to print what is on his or her screen when this
command is secured.

Print Multiple Screens Command: Removes Print Multiple Screens from
the File menu and from the commands available on the Action page. The
user will not be able to print multiple screens when this command is
secured.

Finish Printing Command: For VT sessions only. Removes the Finish
Printing command from the File menu and from the commands available
on the Action page.
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Exit Session Command: Removes the Exit session command from the
File menu and from the commands available on the Action page. The
user will not be able to exit an individual session when this command is
secured.

Exit EXTRA! Command: Removes the Exit EXTRA! command from the
File menu and from the commands available on the Action page. The
user will not be able to exit EXTRA! when this command is secured.

Session MRU Command: Removes the Session MRU command from the
File menu. The user will not be able to see the session most recently used
list when this command is secured.

Macro Commands
Run Macro: Removes the Run button from the Macro dialog box and
removes Run Macro from the Action page. The user will not be able to
run macros when this command is secured.

Run Macro Editor: Removes the Edit button from the Macro dialog box
and removes Run Macro Editor from the Action page. The user will not
be able to edit macros when this command is secured.

Record Macro: Removes the Record button from the Macro dialog box
and removes Record Macro from the Action page. The user will not be
able to record macros when this command is secured.

Miscellaneous Commands
Advanced Global Preferences: Removes the Global Preferences
command from the Action page. The user will not be able to use this
command in his or her keyboard maps, toolbars or QuickPads.

Terminal Setup: Removes the Terminal Setup command from the Action
page. The user will not be able to change the data stream attributes.
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Options Menu Commands
Settings Command: Removes Settings from the Options menu, from the
Action page, and disables the Settings buttons in Session Type dialog
box.

The Settings dialog box will still be available through the Settings
command in the Edit menu and the Toolbar, QuickPad, and HotSpot
commands in the View menu.

Session Type Command: Removes Session Type from the Options menu
and from the commands available on the Action page. The user will not
be able to view information about his or her session when this command
is secured.

Global Preferences Command: Removes Global Preferences from the
Options menu and from the commands available on the Action page.

Security Command: Removes Security from the Options menu and from
the commands available on the Action page. The user will not be able to
change what commands are secured when this command is removed.

Session Menu Commands
Connect: Removes Connect from the Sessions menu and from the
commands available on the Action page. The user will not be able to
connect a session when this command is secured.

Disconnect Command: Removes Disconnect from the Sessions menu
and from the commands available on the Action page. The user will not
be able to disconnect his or her session when this command is secured.

Reset Display Command: Removes Reset Display from the Sessions
menu and from the commands available on the Action page.
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Change Settings Commands
Color Settings: Removes Color from the Category list in the Settings
dialog box and from the commands available on the Action page. The
user will not be able to customize the colors of his or her session,
including create color schemes, when this command is secured.

Connection Settings: Removes Connection from the Category list in the
Settings dialog box and from the commands available on the Action
page.

Display Settings: Removes Display from the Category list in the Settings
dialog box and from the commands available on the Action page.

Edit Settings: Removes Edit from the Category list in the Settings dialog
box and from the commands available on the Action page. The user will
not be able to modify the way Cut, Copy, and Paste work on his or her
host screen when this command is secured.

We recommend securing Settings in the Edit category when Edit Settings
is secured.

File Transfer Settings: Removes File Transfer from the Category list in
the Settings dialog box and from the commands available on the Action
page. The user will not be able to create a File Transfer scheme when this
command is secured.

Users can still transfer files.

Font Settings: Removes Font from the Category list in the Settings dialog
box and from the commands available on the Action page. The user will
not be able to select a different font, or change the Autosize Font and
Autosize Window settings when this command is secured.

HotSpot Settings: Removes HotSpots from the Category list in the
Settings dialog box and from the commands available on the Action
page. The user will not be able to create HotSpots when this command is
secured.

We recommend securing HotSpots in the View category when HotSpot
Settings is secured.

Keyboard Maps: Removes Keyboard Maps from the Category list in the
Settings dialog box and from the commands available on the Action
page. The user will not be able to create a keyboard map when this
command is secured.



User’s Guide

14-10

Macro Settings: Removes Macro from the Category list in the Settings
dialog box and from the commands available on the Action page. The
user will not be able to create Macros when this command is secured.

Navigation Settings: Removes Navigation from the Category list in the
Settings dialog box and from the commands available on the Action
page. The user will not be able to record paths when this command is
secured.

QuickPads: Removes QuickPads from the Category list in the Settings
dialog box and from the commands available on the Action page. The
user will not be able to create QuickPads when this command is secured.

We recommend securing QuickPads in the View category when
QuickPad Settings is secured.

Toolbars: Removes Toolbars from the Category list in the Settings dialog
box and from the commands available on the Action page. The user will
not be able to create, edit, or delete Toolbars when this command is
secured.

We recommend securing Toolbars in the View category when Toolbar
Settings is secured.

Printer Settings: Removes Printer from the Category list in the Settings
dialog box and from the commands available on the Action page.

Tools Menu Commands
Transfer File Command: For 3270 and VT sessions only. Removes
Transfer Files from the Tools menu and from the commands available on
the Action page. The user will not be able to transfer files one at a time
when this command is secured.

FTP file transfer will still allow transfer of multiple files.

5250 File Transfer Command: For 5250 sessions only. Removes Transfer
Files from the Tools menu and from the commands available on the
Action page. The user will not be able to transfer files one at a time when
this command is secured.

FTP file transfer will still allow transfer of multiple files.

Transfer Multiple Files Command: For FTP file transfer only. Removes
Transfer Multiple Files from the Tools menu and from the commands
available on the Action page. The user will not be able to transfer
multiple files when this command is secured.

The user can still transferring single files.
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Macro Editor Command: Removes Macro from the Tools menu and from
the commands available on the Action page. The user will not be able to
create, edit, or run macros when this command is secured.

Record Pages Command: Removes Record Pages from the Tools menu
and from the commands available on the Action page. The user will not
be able to record his or her host pages when this command is secured.

Page Settings Command: Removes Page Settings from the Tools menu
and from the commands available on the Action page. The user will not
be able to modify any host page recordings when this command is
secured.

Go to Bookmark/Page: Removes Go To Bookmark/Page from the Tools
menu and from the commands available on the Action page. The user
will not be able to jump to a specific bookmark or page when this
command is secured.

Status Application: Removes Status Application from the Tools menu
and from the commands available on the Action page. The user will not
be view the Audit log, trace API calls, or trace Communications traffic
when this command is secured.

Macro MRU: Removes Macro MRU from the Tools menu and from the
commands available on the Action page. The user will not be view the
list of macros most recently used when this command is secured.

Password Protection: Shows passwords when macros, HLLAPI, screen
copy, and navigation are used.
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View Menu Commands
Toolbars Command: Removes Toolbars from the View menu and from
the commands available on the Action page. The user will not be able to
display the Settings dialog box with Toolbars selected when this
command is secured.

The Settings dialog box will still be available through the Settings
command on the Edit and Options menu.

Toggle Status Bar Command: Removes Statusbar from the View menu
and from the commands available on the Action page. The user will not
be able to toggle between viewing the Status bar when this command is
secured.

QuickPads Command: Removes QuickPads from the View menu and
from the commands available on the Action page. The user will not be
able to display the Settings dialog box with QuickPads selected when this
command is secured.

The Settings dialog box will still be available through the Settings
command on the Edit and Options menu.

HotSpots Command: Removes HotSpots from the View menu and from
the commands available on the Action page. The user will not be able to
display the Settings dialog box with HotSpots selected when this
command is secured.

The Settings dialog box will still be available through the Settings
command on the Edit and Options menu.

Keyboard Map Command: Removes Keyboard Map from the View
menu and from the Category list in the Action dialog box. The user will
not be able to display their keyboard map when this command is
secured.

Rule Lines Command: Removes Rule Lines from the View menu and
from the Category list in the Action dialog box. The user will not be able
to toggle the rule lines option on or off when this command is secured.
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Setting Security
When you are ready to secure a set of commands, or a single command,
you will be editing a Security scheme. You can edit the default scheme
(DEFAULT.ESF) that is supplied with EXTRA!, or you can create your
own schemes. Creating your own schemes will allow you to limit what
your users will be able to do. For example, if you have a group of users
that should not be transferring files, you can create a new Security
scheme for them where the File Transfer command is no longer available.

We recommend using DEFAULT.ESF whenever possible.

To select a scheme to edit

1. Open a session.

2. From the Options menu, choose Security.

The Security dialog box appears.

3. From the File page, choose Browse to display the Browse for Security
File dialog box.

4. Select the Security file you want to use, then click OK.

To secure a command

1. Open a session.

2. From the Options menu, choose Security.

The Security dialog box appears.

3. Make sure the scheme you want to edit is displayed in the Scheme
field. If it is not, choose Browse to select the correct file.

4. Choose the Options tab.

5. If asked for a password, enter the password in the Security Password
dialog box, then click OK.

6. Select the Category that contains the command(s) you want to set.

7. Clear the check mark from the command(s) you want secured.

8. Repeat steps 6 and 7 for all the commands you want secured.

9. To save the scheme, go to the File page and choose Save As.
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Selecting the Active Scheme
Although you can edit any Security scheme, you need to go into your
Registry to change which scheme is active. For that reason, we
recommend using the default scheme (DEFAULT.ESF) whenever
possible.

To select the active scheme

1. Using your Registry editor, open the HKey root of the registry.

2. Go to Software\Attachmate\EXTRA!\Security.

3. Change the path to correspond to your security file (extension .ESF).

Setting a Security Password
By setting a password for Security, you can control who has access to a
Security scheme. You can set a password for the default scheme
(DEFAULT.ESF), as well as any other new schemes you create. The
password you set limits who can change a specific scheme; it does not
limit access to security.

To set a password

1. Open a session.

2. From the Options menu, choose Security.

The Security dialog box appears.

3. Select the security scheme you want to edit. The name of the security
scheme is listed in the Scheme field.

4. Choose the Change Password tab.

5. If asked for a password, enter the password in the Security Password
dialog box, then click OK.

6. If the password has been changed already, enter the old password in
the Old Password field.

7. Enter a new password in the New Password field.

8. Verify the password you entered by typing it in the Verify New field.
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here are three types of information you can gather using the Status
window. The first type of information is an Audit Log that tracks the

work EXTRA! is doing. The second and third types of information are
traces, one of API calls and the other of communications traffic. EXTRA!
also provides support for host response measurements, or Response
Time Monitoring (RTM).

The main sections of this chapter describe in more detail the Audit Log,
tracing API calls, tracing communications, and Response Time
Monitoring (RTM).

The Audit Log
The Audit Log is automatically generated while you use EXTRA!. When
you are using EXTRA!, the Audit Log keeps track of all the critical events
that take place. These events are displayed on the Audit Log page and
saved to a file with the extension .LOG. Audit log information can
accumulate in the audit log file up to 1 MB. If the file grows to this size,
the last half of the file is deleted and EXTRA! continues to add events to
the beginning of the file.

The events in the Audit Log are always listed with the most recent event
at the top of the list.

The Audit Log provides the following information for each critical event:

• The date of the event.

• The time of the event.

• The type of event that occurred. (The text in the Category column is
defined by the application using the EXTRA! session, not by
EXTRA!.)

• A brief description of the event. (The text in the Description column
is defined by the application using the EXTRA! session. It is not
defined by EXTRA!.)

• Additional detail for each event. The Audit Details dialog box
(displayed by choosing an event) provides a closer look at the data
sent to the Audit log when the event occurred. This dialog box shows
whether the event succeeded or failed, and it also allows you to view
the data involved.

T
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To view the Audit Log

1. Select Status in the Tools menu.

2. If the Audit page is not displayed, choose the Audit tab at the bottom
of the window.

3. To view details of a single event, choose the event to display the
Audit Details dialog box.

4. To see details on other events close by, use the Previous and Next
buttons.

5. Choose Close to close the Audit Details dialog box.

Tracing your APIs
API traces contain information on the calls made by one or more of your
common API applications. For example, if you have an OLE application
that is not working as you think it should, you could capture all the API
calls that the application sends and receives. This information is
displayed on the API Trace page, and is also saved to a file.

The events in the API Trace page are always listed with the most recent
call at the bottom of the trace.

The API Trace page shows the following information:

• The date the call was executed.

• The time the call was executed.

• The type of API that made the call. This is very helpful when tracing
more then one type of API.

• The name of the call that was made.

The API Trace page can also be split into two panes. The first pane
contains the list of calls. The second pane, called the Parameter Details
pane, provides the details for a specific call.

The Parameter Details pane shows the following information:

• The type of value the parameter has.

• The name of the parameter.

• The value of the parameter.
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To record a new API trace

1. From the Tools menu, choose Status to open the Status window.

2. If the API Trace page is not displayed, choose the API Trace tab.

3. From the Options menu, choose Settings to select the types of API
you want to trace.

4. Choose the Record button to start the trace.

5. To view more information about a specific call, double-choose the
call to display the Parameter Details pane.

6. Choose the Stop button to stop the trace.

7. Save the trace to a file.

To view an old API trace

1. From the Tools menu, choose Status to open the Status window.

2. If the API Trace page is not displayed, choose the API Trace tab.

3. From the File menu, choose Open to display the File Open dialog
box.

4. Select the trace file you want to open and choose OK.

5. To view more information about a specific call, choose the call to
display the Parameter Details pane.

To add to an API Trace

1. From the Tools menu, choose Status to open the Status window.

2. If the API Trace page is not displayed, choose the API Trace tab.

3. From the File menu, choose Open to display the File Open dialog
box.

4. Select the trace file to which you want to add information and choose
OK.

5. Choose the Record button to start tracing. The new information is
added to the end of the trace.

6. To view more information about a specific call, choose the call to
display the Parameter Details pane.

7. Choose the Stop button to stop tracing.

8. Save the new trace under its existing name or give it a new name.
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Tracing your Workstation’s Communications
Communication traces contain all the communications traffic associated
with a particular session. Unlike the other types of information, your
communications traces are not displayed in the Status window. The
information is sent directly to a trace file. Each trace creates a separate
temporary file which can be saved after the trace is stopped. The Status
window displays all the sessions that can be traced, indicating which are
running traces and which are not.

Similar to API traces, you can start and stop a trace until you capture all
the communications traffic you need.

The Communications page provides:

• A Running icon to indicate if the trace is recording or stopped.

• The name of the session being traced.

• The machine on which the session is running.

• The type of connection the session is using.

• The number of events in the trace.

• The size of the trace (in bytes).

• The name of the files used to save the trace, and the temporary file
used to build the trace.

To record a new Communications trace

1. From the Tools menu, choose Status to open the Status window.

2. If the Communications page is not displayed, choose the
Communications tab.

3. Choose the session you want to trace using the Open button (you can
also use the Open command from the File menu). The session is
added to the Communications trace and the Running icon stops.

4. Choose the Record button to start the trace.

5. Choose the Stop button to stop the trace.

6. Save the trace to a file.
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To add to a Communications trace

1. From the Tools menu, choose Status to open the Status window.

2. If the Communications page is not displayed, choose the
Communications tab.

3. Select the session to which you want to add information.

4. Choose the Record button to start the trace. The new information is
added to the end of the trace file.

5. Choose the Stop button to stop the trace.

6. Save the trace to a file using its existing name, or use a new name if
you want to keep the old trace as well.

Response Time Monitoring
The Response Time Monitor (RTM) measures how long it takes the host
to respond after you issue a command from a display session, such as
pressing a PF key or the ENTER key. RTM then keeps a running count of
the various response times, storing the count in bins. The Response Time
Monitor is one of the functions of NetView, IBM’s network monitoring
and control software.

EXTRA! provides remote RTM support which allows the host to monitor
workstation RTM measurements. Remote RTM support is available for
the 3270 connectivities listed below.

• 802.2 Direct Connect

• Cisco NCIA

• DFT/Coax Direct Connect

• SDLC Direct Connect

• Hayes Autosync Direct Connect
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he APPN Node Manager provides a visual representation of the
APPN node and its current status. Not only can you monitor the

APPN node, you can save some of the information to your clipboard for
future reference.

You can monitor the following types of information:

• Node

• DLC Connection

• Link

• Local LU

• Session

• Configuration

The Node Manager Window
The Node Manager contains a toolbar with buttons you can use to select
the type of APPN information you want to see, tabbed pages from which
you can monitor specific information, and a status bar that relates to you
the connection status of your APPN connections.

For example, when you choose the Node button, the Node and Node
Statistics pages are available on your screen. You can then choose the
Node Statistics tab to view function and timer details.

APPN Node Properties
You can monitor the status of the APPN node, and set node properties
such as display options, the active configuration, node tracing, and auto
shutdown delay using the APPN Node Properties dialog box. You access
this dialog box by double-clicking the APPN Node Properties icon
displayed in the Windows Control Panel.

Once EXTRA! is installed, you’ll see the APPN Node Properties icon in
the Windows Control Panel.

T
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To edit the properties of the APPN node

1. Double-click the APPN Node Properties icon in your Windows
Control Panel.

The APPN Node Properties dialog box opens.

The APPN Node Properties - General Page

The General page displays the current status of the node, updated
every ten seconds, in the APPN Node Status field. This page also has
three different options from which you can choose to display the
node’s icon when active, the initialization status window, and the
link outage message box.

2. Choose the Advanced tab to set advanced options for the APPN
node.

The APPN Node Properties Advanced page is shown.
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The APPN Node Properties - Advanced Page

From the Advanced page, you can change the current APPN
configuration file. In the Active Configuration field, choose the
Browse button to select a different configuration file.

If you want to change the size of the blocks of virtual memory
allocated, type a number in the Initial Virtual Memory Size (K bytes)
box.

If you want to activate node tracing, select the Enable Node Tracing
option. After you have activated node tracing, enter the size limit of
the trace file, and select either to append new data to the end of a file
or to create a new file each time the node is started.

If you want to change the amount of time the APPN node will wait
before it automatically shuts down, type a number in the Auto
Shutdown Delay box. The default amount of time is 15 seconds.

3. When finished, choose the Apply or OK button.
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Viewing Node Information
Choose the Node Pages button to get a general view of the current status
of your APPN node. The information is divided between two pages: the
Node page and the Node Statistics page.

The Node page displays the current configuration of the node control
point and the status of the node’s memory pool.

The Node Statistics page displays general information on the functions
supported by the node, counters for the XID frames processed by the
node, and a timer that indicates the total elapsed time from when the
node was started.

The Node Page
This page displays the current configuration of the node control point
and the status of the node’s memory pool.

The information on this page is static—use the Refresh button to update
the page.

To view node information

1. Start the APPN Node Manager.

2. For information on control point configuration and memory usage,
choose Node Pages from the View menu, then choose Node.

–or–

For statistical information about the node, choose Node Pages from
the View menu, then choose Node Statistics.

The following information is displayed:

• Functions supported by the node

• Counters for XID frames processed by the node

• Total elapsed time from when the node was started

3. Choose the To Copy button to save information for later reference.
This copies the information on the Node Statistics page to your
Clipboard.
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The Node Statistics Page
This page displays general information on the functions supported by the
node, counters for the XID frames processed by the node, and a timer
that indicates the total elapsed time from when the node was started.

The information on this page is static—use the Refresh button to update
the page.

Viewing DLC Information
Access information about all the external connections defined by your
node by choosing the DLC Pages button. Not only can you see the
statistics for these connections, buttons are provided for starting and
stopping them as well.

The DLC page displays a list of all the defined connections. Each entry
includes the type of connection (LAN, SDLC, or DFT), the logical port
number for 802.2 and SDLC connections, and the current status of the
connection.

The DLC Statistics page displays the current statistics for the connection
selected on the DLC page. In addition to displaying information on the
connection you selected, you can cycle through the rest of your
connections using the Previous and Next buttons on this page.

The DLC Page
Displays a list of all the defined connections. Each entry includes the type
of connection (LAN, SDLC, or DFT), the logical port number for 802.2
and SDLC connections, and the current status of the connection. This
display is updated dynamically by the node.

In addition, Start and Stop buttons are included to activate and
deactivate the connection.

To view DLC connection information

1. Start the APPN Node Manager.

2. To select a connection or to start and stop a connection, choose DLC
Pages from the View menu, then choose DLC.

–or–

For statistical information about the DLC connection, choose DLC
Pages from the View menu, then choose DLC Statistics.
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The following information is displayed:

• BTU sizes

• Link activation limits

• XID information

3. To see information on a different connection, use the Previous and
Next buttons to cycle through your connections.

4. Choose the To Copy button to save the information. This copies the
information on the DLC Statistics page to your Clipboard.

The DLC Statistics Page
This page displays the current statistics for the connection selected on the
DLC page. In addition to displaying information on this connection, you
can cycle through the rest of your connections using the Previous and
Next buttons on this page.

The DLC Statistics page provides:

• BTU sizes

• Link activation limits

• XID information

The information on this page is static—use the Refresh button to update
the page.

Viewing Link Information
Choose the Link Pages button to view information about the logical
connection between your local node and the remote nodes. You can get
information on both the links defined by your configuration, as well as
any active dynamic links. Link information is divided into two pages: the
Link page and the Link Statistics page.

The Link page displays a list of all the defined connections plus any
active dynamic links (dynamic links are removed from the page when
they become inactive).

The Link Statistics page displays the current statistics for the link selected
on the Link page. In addition to displaying information on the link you
selected, you can cycle through the rest of your connections using the
Previous and Next buttons on this page.



User’s Guide

16-8

The Link Page
This page displays a list of all defined Links and active dynamic links
(dynamic links are removed from the page when they become inactive).
The information on this page is updated dynamically by the node.

The Link page provides:

• The name of the link. This is the name specified in the configuration,
or for dynamic links, the name is formatted as @I000000 for implicit
links and @D000000 for virtual routing nodes.

• The associated Data Link Control.

• The number of sessions currently using the link (all LU types).

• The status of the link.

• The adjacent node control point.

• The adjacent node type.

The page also includes Start and Stop buttons for activating and
deactivating links.

To view link information

1. Start the APPN Node Manager.

2. To select a link, or to start and stop a link, choose Link Pages from
the View menu, then choose Link.

–or–

For statistical information about the link, choose Link Pages from the
View menu, then choose Link Statistics.

The following information is displayed:

• The TG number

• Start and Stop times

• Active time

• The adjacent node ID

• XID bytes received and sent

• Data bytes received and sent

• Bad SNA frames received

• Session CH frames received and sent
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3. To see information on a different link, use the Previous and Next
buttons to cycle through your active sessions.

4. Choose the To Copy button to save the information. This copies the
information displayed on the Link Statistics page to your Clipboard.

The Link Statistics Page
This page displays the current statistics for the link selected on the Link
page. In addition to displaying information on this link, you can cycle
through the rest of your links using the Previous and Next buttons on
this page.

The information on this page is static—use the Refresh button to update
the page.

Viewing Local LU Information
Choose the Local LU Pages button to access a listing of all the local LUs
defined by your node. The information is divided between two pages:
the LU 6.2 page and the LU 0 to 3 page.

The LU 6.2 page lists all the type 6.2 LUs defined by the local node. Each
item in the list contains the LU name, LU alias, and the LU type
(independent or dependent).

The LU 0 to 3 page lists all of the conventional (type 0, 1, 2, and 3) LUs
defined by your node. Conventional LUs are typically defined to support
3270 display and printer sessions.

The LU 6.2 Page
This page lists all the type 6.2 LUs defined by the local node. Even if no
LUs are defined, this list always includes the control point LU. The
display includes the LU’s alias and the LU type (independent or
dependent).

The LU 6.2 page provides:

• The LU name. This is the network name used to reference the LU.

• The LU alias. This is the local name used to reference the LU. A
partner LU or partner transaction program can use this name to
reference the LU.

• The type of LU (independent or dependent).

The information on this page is updated dynamically by the node.
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To view local LU information

1. Start the APPN Node Manager.

2. For a list of 6.2 LUs defined by your node, choose LLU Pages from
the View menu, then choose Local LU.

–or–

For a list of all the conventional LUs defined by your node, choose
LLU Pages from the View menu, then choose LU0 to 3.

The LU 0 to 3 Page
This page lists all of the conventional (type 0, 1, 2, and 3) LUs defined by
your node. Conventional LUs are typically defined to support 3270
display and printer sessions.

The LU 0 to 3 page provides:

• The name of the LU.

• The name of its associated PU.

• The status of the LU (inactive, SSCP, or Bound).

• The type of LU (Any or Model 2-5).

Viewing Session Information
Choose the Sessions Pages button to access information on all active LU
6.2 sessions. The information is divided between two pages: the Session
page and the Session Statistics page.

The Sessions page lists all the active LU 6.2 sessions.

The Session Statistics page displays the statistics for the session selected
on the Sessions page.

The Sessions Page
This page lists all the active LU 6.2 sessions.

The Sessions page provides:

• The Session ID.

• The LU name or alias of the Local LU the session is using. (If you are
using a CP-CP session, this will be the CP name.)

• The LU name or alias of the partner LU associated with this session.
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• The Mode used by the session.

This information is updated automatically by the node.

To view session information

1. Start the APPN Node Manager.

2. To select a session, choose Sessions from the View menu, then choose
Sessions.

–or–

For statistical information about the session, choose Sessions from the
View menu, then choose Session Statistics.

The following information is displayed:

• FQPCID

• Polarity

• Contention

• RU size sent and received

• Maximum BTU sent and received

• Maximum pacing sent and received

• Data frames sent

• Data bytes sent and received

• The link station name

3. To see information on a different session, use the Previous and Next
buttons to cycle through your active sessions.

4. Choose the To Copy button to save the information. This copies the
information on the Session Statistics page to your Clipboard.

The Session Statistics Page
This page displays the statistics for the session selected on the Sessions
page. In addition to displaying information on this session, you can cycle
through the rest of your sessions using the Previous and Next buttons on
this page.

The information on this page is static—use the Refresh button to update
the page.
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Viewing Configuration Information
Choose the Configuration button to access information on the active
configuration of the node. The Configuration page displays a copy of the
configuration settings being used at this time.

The Configuration Page
This page displays a copy of the configuration settings being used at this
time.

To view configuration information

1. Start the APPN Node Manager.

2. Choose Configuration from the View menu.

3. Refer to the Configuration page to view the active configuration. Use
the horizontal and vertical scroll bars to maneuver through the file.
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XTRA! includes the Uninstall program, which removes the 32-bit
EXTRA! components from your Windows NT, Windows 95, or

Windows 98 PC. Specifically, Uninstall deletes the EXTRA! files, removes
the program folder or group, and purges associated configuration
information stored in the Windows registry.

Caution: If you want to reinstall the EXTRA! (32-bit) software, run
Uninstall before Setup.

Be aware that Uninstall removes only those components which the
EXTRA! Setup has installed to the EXTRA! folders, directories, or
program groups. In the cases described below, Uninstall will not remove
components; you must remove them manually.

• Uninstall will not remove EXTRA! icons, programs, or files moved
from the folders or program groups to which they were initially
installed by Setup.

• In Windows 95, Uninstall will not remove user-created shortcuts to
EXTRA! components.

• If you add non-EXTRA! icons to the EXTRA! folder or program
group, Uninstall will not remove these icons. Likewise, it will not
remove files, folders, or shortcuts added to the EXTRA! folders
created by Setup.

For additional information about Uninstall, refer to the ReadMe file,
located in your EXTRA! folder or program group.

To uninstall from Windows NT 3.51

1. Exit from EXTRA!. All sessions must be closed before you uninstall.

2. From the EXTRA! program group, double-click the Uninstall icon.

3. When prompted to confirm file deletion, select Yes.

Uninstall displays its progress as it removes files.

4. When Uninstall is completed, choose OK.

E
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To uninstall from Windows 95, Windows 98 and Windows NT 4.0

1. Exit from EXTRA!. All sessions must be closed before you uninstall.

2. From the Control Panel, double-click the Add/Remove Programs
icon.

3. From the Install/Uninstall page, select EXTRA! (32 bit) from the list
box, then click Add/Remove.

4. When prompted to confirm file deletion, select Yes.

Uninstall displays its progress as it removes files.

5. When Uninstall is completed, choose OK.
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henever you connect to the mainframe, it sends messages to your
PC to keep you posted on the status of your connection. In

EXTRA!, these messages appear in the Operator Information Area (OIA),
located at the bottom of the Display window.

Read this appendix to learn:

• How to read the fields that appear in the Operator Information Area
of your display session.

• How to monitor your connection to the mainframe.

• How to identify and decipher mainframe messages.

• What action to take when the mainframe reports a problem.

Fields in the OIA
If you are using EXTRA! with an EXTRA! font, the characters displayed
in the OIA field look like this (each field is explained in the table on the
next page):

If you are using EXTRA! without an EXTRA! font, the characters
displayed in the OIA fields look like this (each field is explained in the
table on the next page):

W

Field # 1

4 B

4

Aa

5 6

A

7

Session 1

8

R 13  C 11

10

10:13

11

10/25/93

2

X

9

02

3

+z 598

4B   X()  -+z_598  Aa      A  Session1   R 13 C 11  o-o 02  10:13  10/25/93

1 2 3 4 5 6 7 8 9 10 11Field #
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Explanation of Fields
The table below identifies the field number, the name of the field, the
symbols you might see in the field, and the page in this appendix where
you can find a description of the field. The symbols that appear on your
screen may be slightly different.

Field # Field Name Field Symbols Page

1 Condition of
Connection

4 B B-4

2 Condition of
Communication

X B-6

3 Communication Check
Reminders

Host Attribute
Symbols

Last Transaction Time
Clock

598

a S0 a

03:55

B-16

4 Case Mode Aa B-26

5 Shifts and Modes ^ B-26

6 Session Short Name
and Screen Profile

A B-27

7 Session Long Name Session1 B-27

8 Cursor Position R 13 C 11 B-28

9 Printer Status  02 B-28

10 Time 10:13 B-29

11 Date 10/25/93 B-29
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Field 1: Condition of Connection
Messages in this field tell you three things:

• The kind of control unit to which you are connected,

• The type of communications system or architecture your mainframe
system is using, and,

• Whether or not you have successfully connected to the control
program.

Field 1 is separated into three positions.

1 2 3
 |  |  |
4 B 4

The table below describes all the messages that can be displayed in these
three positions.

Condition of Connection Messages

Message Meaning

4

or
4

This message appears in the first position and indicates
that you are connected either to a 3274 or 3174 control
unit.

6

or
6

This message appears in the first position and indicates
that you are connected to a 3276 control unit.

S This message appears in the first position and indicates
that you are connected to a 3174 control unit.

N This message appears in the first position and indicates
that you have a connection to a 9370 or ES/9000
workstation controller card using non-SNA protocols.

Continued on next page.
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Condition of Connection Messages (cont.)

Message Meaning

A
or
A

On-line A
This message appears in the second position and
indicates that you have a connection to a remote system
that is using the BSC protocol, or you are connected to a
locally-attached control unit using non-SNA protocols.

B
or
B

On-line B
This message appears in the second position and
indicates that you have a connection to a remote system
that is using SDLC protocol, a connection to a locally-
attached control unit using non-SNA protocols, or any
system with SNA protocol running DLC.

N In-Use Indicator (X.21 and X.25)
This message appears in the second position and means
that the control unit is connected to the mainframe
through a network, and the control unit is in the data
transfer state.

or
R Control Program Owned

This message appears in the third position and indicates
that the control program, SSCP, has established contact
with your PC.

?
or

?

Unowned
This message appears in the third position and indicates
that your PC is connected to the mainframe system, but
is not connected to an application program or a control
program. Contact your mainframe system administrator.

Continued on next page.
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Condition of Connection Messages (cont.)

Message Meaning

4 Application Owned
This message appears in the third position and indicates
that you are connected to a mainframe application
program, such as CMS or TSO.

TEST Test Mode
This message appears in CUT mode only and means that
your terminal is in Test mode. Test mode allows you to
use test functions located in the control unit. These test
functions make it possible for you to test your terminal
to make sure it is functioning properly and diagnose any
terminal problems encountered.

Field 2: Condition of Communication
When there is a problem with your connection to the mainframe, a
Communication Condition messages is displayed in Field 2. These
messages include:

• Machine Check Messages

• Program Check Messages

• General Input Check Messages

The following tables list and explain the messages, suggesting what
action you might take to resolve problems.

If you are unable to solve a Communication problem, contact your
mainframe system administrator or call Attachmate Customer Support.

Machine Check Messages

Machine Check messages usually indicate a problem with the physical
connection of your workstation to the control unit or gateway.
Sometimes Machine Check messages are caused by something as simple
as a loose cable or, if you are communicating by modem, dialing a wrong
number.

The table on the following page lists the more common Machine Check
messages.
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Machine Check Messages

Message Meaning Action

X        204
or

You have a parity
error, which means
you have lost
information while
communicating with
the mainframe.

Turn your PC off,
check your coax
connections to make
sure you are connected
properly, then turn
your PC on and try to
connect to the
mainframe again.

X        207
or

A timeout error has
occurred, which means
you have lost
information while
communicating with
the mainframe.

Follow the same
corrective procedure
for an X ∅ 204 error.

or

X        209
X        211

X        208 You have a command
failure between your
workstation and the
control unit. Usually,
this condition is
caused by a connection
problem with your
coax cables, which
connect you to the
control unit.

Turn your PC off,
check your coax
connections to make
sure you are connected
properly, then turn
your PC on and try to
connect to the
mainframe again.

Continued on next page.
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Machine Check Messages (cont.)

Message Meaning Action

or

X        240-243
X        292-299

You have a device
failure, with device
referring to hardware
items such as the coax
cabling, the connecting
pieces on the cabling,
the control unit, or
maybe even your
workstation. Often the
problem is simply a
chance error; it might
not happen again.

Turn your PC off and
check your coax
connections to make
sure you are
connected properly,
then turn your PC on
and try to connect to
the mainframe again.

X        310-399
or

The control unit that
your coax is connected
to has failed.

Refer to your control
unit manufacturer’s
documentation for
information on how
to correct the
problem.

X        620
or

You have a device
failure.

To clear this
condition, press
RESET, then try your
request again.

X        630-640
or

These messages
indicate that the 3274
control unit is failing.

To clear this
condition, press
RESET, then try your
request again.

Continued on next page.
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Machine Check Messages (cont.)

Message Meaning Action

X        650-699
or

You have a device
failure.

To clear this
condition, press
RESET, then try your
request again.

X        999
or

You have a NetBIOS
name conflict, or there
is a hardware error
somewhere along the
network that connects
you to the mainframe.

Check the cables and
connections to make
sure they are correct.
Another possible
solution may be to
change your
workstation’s station
name. To clear this
condition, press
RESET, then try your
request again.

Program Check Messages

Program Check messages are divided into configuration messages and
general input messages.

Configuration Messages

This type of Program Check message varies depending on the type of
problem you have. If your workstation is running a terminal in CUT
mode, the three-digit messages range between 400 and 499. If you are in
DFT mode, the messages range between 700 and 799. Other EXTRA!
display session messages range between 900 and 999.

The most common configuration messages occur when there are
configuration mismatches in the mainframe, front-end processor,
controller, or workstation. You can correct some of these errors with
workstation configuration changes.
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The following table lists the most common Program Check messages that
you can correct from your workstation.

Configuration Messages

Message Meaning Action

X PROG 700 SNA Protocol
violation
This message is gener-
ated when the SNA
server detects an error
with information sent
to or received from the
mainframe.

Check the EXTRA! Xlog
for more details, then
contact your system
administrator to run a
trace on your system.

X PROG 714 Bind Rejected
This message is genera-
ted when the
mainframe rejects a
bind.

Check LU configuration
at the mainframe. You
may be trying to connect
a display session to a
printer LU at the main-
frame.

X PROG 723 Invalid LU Type
This message is
generated when the
workstation receives an
incorrect SNA bind
command. It can mean
a display session
received a printer bind
command, a printer
session receives a
terminal bind
command, or the
mainframe thinks the
printer session is an
LU1 (SCS) printer and
the workstation is
configured as an LU3.

Reconfigure EXTRA! so
your session and its
mainframe LU are the
same type (for example,
match your display
sessions with mainframe
LUs configured for
terminal connections).

Continued on next page.
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Configuration Messages (cont.)

Message Meaning Action

X PROG 724 Invalid Screen Size
This code is generated
when the workstation
receives an SNA bind
command for a
terminal model size
larger than that defined
for the session. For
example, the
mainframe may be
configured for a model
3 terminal but your
workstation may be
emulating a model 2.

Reconfigure EXTRA! for
a larger terminal model
size.

X PROG 755 Invalid Order
Received
Usually this code oc-
curs when the main-
frame sends undis-
played EBCDIC char-
acters, and the work-
station is configured to
generate an error code
rather than displaying
a hyphen (-) as a
substitute character.

Contact your system
administrator and report
you are receiving invalid
characters from the
mainframe.

X PROG 756 Invalid Structured
Field
This message can oc-
cur, for example, when
the mainframe thinks
the terminal has
graphics capabilities,
and the workstation
session is not con-
figured for graphics.

Reconfigure EXTRA!,
adding the capabilities
you need.
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General Input Messages

While many Program Checks are caused by configuration errors, general
input messages fall into two categories:

• Problems undetected by the communications protocol layer. For
example, if a session power-off is not detected by the mainframe you
will frequently see these messages:

<�463+������7IWWMSR�%PVIEH]�'SRRIGXIH�

<�463+������7IWWMSR�0MQMX�)\GIIHIH�

<�463+������2S�09�SV�09�7IWWMSR�

• Programming errors in the mainframe.

These remaining errors are less likely to occur than those caused by
configuration errors, and they cannot be fixed at the workstation. The
best thing you can do is report the problem to your mainframe system
administrator.

If you are the mainframe system administrator, consult the
documentation for your IBM 3174 or 3274 control unit, which contains a
bibliography of documentation for control units.

General Input messages give you information on the general condition of
your mainframe connection. The following table explains some of the
more common general input messages.
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General Input Messages

Message Meaning Action

or
X       Busy with Request

This message is called
the “X clock.” It means
the mainframe is busy
processing your input.

Please wait.

X        NUM Numeric
This message appears
when the Numeric Lock
feature is on. You tried
to make a non-numeric
entry at a location on
the screen where only
numeric information is
allowed.

To clear this condition
and try again, press
RESET.

X        Go Elsewhere
You tried to enter infor-
mation in a protected
field, a field in which
you are not permitted to
place data.

To clear this condition,
press RESET.

or
X        More Than

You tried to put too
much data in the field.

To clear this condition
and try again, press
RESET.

Continued on next page.
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General Input Check Messages (cont.)

Message Meaning Action

X-f Minus Function
You requested a
function that is
currently unavailable.

To clear this condition,
press RESET.

X       #   
or

What Number?
This symbol appears in
a coax-connected ses-
sion when you enter a
number that the system
does not recognize. You
may have requested a
printer ID number that
is not in the system, or
you may have tried to
use numbers to request
a printer that has a non-
numeric ID. Or you may
have made your entry
while your terminal is in
Test mode.

To clear this condition
and try again, press
RESET.

X SYSTEM System Lock
The mainframe has
locked your keyboard
after receiving your last
request. Look for an
accompanying message.
This condition may be
more prevalent in a
non-SNA environment.

Wait until the host
computer completes
your request and clears
the OIA.

To restore the
keyboard, press RESET.

Continued on next page.
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General Input Check Messages (cont.)

Message Meaning Action

X-s Minus Symbol
The symbol or character
that you tried to enter is
not available.

To clear this condition,
press RESET.

X       X   
or

Operator Unauthorized
You requested a printer
you are not authorized
to request. This cond-
ition could be caused
by:

• Pressing the PRINT
key when Field 9 of
the OIA is empty.

• Pressing the IDENT
key when Field 9 of
the OIA is empty.

• Requesting a printer
that is recognized by
your system, but is
incompatible with
your display.

• Pressing the PRINT
key, but there is not
enough memory in
the print buffer to
accommodate all the
information that’s on
the screen.

To clear this condition,
press RESET.



User’s Guide

B-16

Field 3: Communication Check Reminders
Field 3 can display Host Attribute symbols, the Last Transaction Time
(LTT), or Communication Check Reminders.

Host Attribute Symbols

The table below lists the Host Attribute symbols that can be displayed in
the OIA. (For information on turning these symbols on or off, as well as
setting these attributes , see your EXTRA! User’s Guide.) These symbols
are only displayed if you are using an EXTRA! font.

Symbol Meaning

a Transparency On: This symbol indicates that you want
the graphic level of your cell to be transparent.

a Transparency Off: This symbol indicates that you want
to display the graphic level of your cell.

a Reverse Video: This symbol indicates that you want to
create text with reverse video.

a Blinking: This symbol indicates that you want to create
blinking text.

a Underline: This symbol indicates that you want to
underline text.

S0 Base Character Set: This symbol indicates that you are
using the mainframe’s base character set.

SA SA Program Symbol Set: This symbol indicates that you
are using Program Symbol Set A. Symbol Set A is
defined by the mainframe.

SB SB Program Symbol Set: This symbol indicates that you
are using Program Symbol Set B. Symbol Set B is
defined by the mainframe.

Continued on next page.



Understanding Mainframe Messages

B-17

Host Attribute Symbols (cont.)

Symbol Meaning

Color Symbol: This symbol indicates which color you
are using.

User Selected Symbol: This symbol indicates that the
attribute symbol to its left is defined by the
application, not the mainframe. It is displayed
whenever the mainframe’s attribute definition is not
being used.

Mainframe Default Symbol: This symbol indicates that
the attribute symbol to its left is defined by the
mainframe, not the application. It is displayed
whenever the mainframe’s attribute definition is being
used.

Last Transaction Time

When you are monitoring your communications, the Last Transaction
Time is displayed in Field 3. The time displayed can be in minutes and
seconds, or seconds and tenths of a second. (The clock to the left of the
time is only displayed if you are using an EXTRA! font.) Both formats are
shown below.

03:55 (minutes/seconds)

– or –

:03:5 (seconds/tenths of seconds)

Communications Check Reminders

Communication Check Reminders appear in your OIA when the system
detects a break in the proper flow of communication between your PC
and the mainframe. These messages automatically overwrite any Host
Attribute symbols or transaction times if they are being displayed.

Often the cause of such a break is as simple as a loose cable or modem
connection. At other times, the control unit or gateway doesn’t recognize
your PC because the address or some other element of your
configuration isn’t quite right.
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The presence of a Communication Check Reminder more than likely
suggests that a hardware problem exists, probably at the control unit,
gateway, or mainframe. A Communication Check Reminder will not
clear when you press Reset; it will remain until the hardware problem is
resolved.

Communication Check Reminder messages consist of a  symbol
(called a lightning bolt) followed by a three-digit code.

The following tables list the more common Communication Check
Reminders, their probable causes, and some suggestions for resolving
them. If the problem persists, contact your system administrator.

Communication Check Reminder Messages

Message Meaning Action

497 The link service process
quit unexpectedly.

Contact your system
administrator.

501 The Data Set Ready
(DSR) was dropped,
indicating a broken or
lost connection.

Redial the connection.

502 The Clear to Send (CTS)
connection is not present,
which may indicate a
broken modem or cable.

Check the modem and
cable for possible
damage and try again.

504 You probably lost the
Carrier Detect
connection, causing you
to lose the phone call.

Redial. If this condition
persists, reconfigure
EXTRA! to make sure the
Physical Unit Address
(PUADD) and NRZI
fields for the modem are
set correctly.

Continued on next page.
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Communication Check Reminder Messages (cont.)

Message Meaning Action

505 It is normal to receive
this message when your
workstation is making a
connection with the
mainframe; it indicates
that the mainframe does
not acknowledge your
unit. This message
remains on the screen
until the connection is
finally made.

If the message does not
clear away by itself, try
connecting again. If you
still get this error, you
may have a configuration
mismatch. Make sure
your PUID corresponds
to the mainframe
definitions of your unit.

510 The physical unit (PU) is
not active. If you are
connected to a gateway,
it could be that the
gateway’s commun-
ication to the mainframe
may be cut off. This is
especially likely in cases
where you have suc-
cessfully connected
before. Another possible
cause for this condition is
that the physical unit ID
(PUID) may already be
in use, incorrectly
specified, or the physical
unit address (PUADD)
may be incorrectly
specified. In a DLC
environment, it is likely
the host address has not
been specified.

First, make sure that the
mainframe gateway is
still operational. Second,
check the PUADD and
the host address in your
configuration.

Continued on next page.



User’s Guide

B-20

Communication Check Reminder Messages (cont.)

Message Meaning Action

511 This message might
appear if you are on a
phone line that has
interference.

Try redialing.

518 The SNA segment was
received in an
unacceptable sequence.

Try the operation again.

519 Your message extended
beyond the allowable
length.

Try the operation again.

520 This message indicates
that EXTRA! received a
retry command from the
mainframe before any-
thing was sent, which
means that you have an
error on the link level of
your communications.

Check your communica-
tions link. The host may
have received some line
noise and interpreted it
as data coming from
your workstation.

521 This message is called
Idle Time-out. There has
been no activity on the
communications line for
the past 25 seconds. This
most likely indicates that
the modem connection is
down.

Try the operation again.

525 This message indicates a
problem with your
mainframe connection.

Check all the cabling
between your
workstation and the
mainframe.

Continued on next page.
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Communication Check Reminder Messages (cont.)

Message Meaning Action

528 A number of issues can
cause this condition. The
control unit might be
incorrectly defined to the
mainframe, or there is an
intermittent error at your
workstation or the
mainframe. It’s also
possible that the physical
unit (PU) is down or that
the mainframe is down.

First, make sure that the
mainframe gateway is
still operational. Second,
check your
configuration.

529 The control unit has lost
its connection with the
mainframe. The cause is
probably the modem or
cable. With a DLC 802.2
connection, it might be
that the LAN is down or
there could be a problem
with the network
adapter.

First, make sure that the
network is still opera-
tional. Second, check
your modem, cable and
network adapter
connections.

530 The control unit has
timed out under a Write
command and has shut
itself down. The cause is
probably a modem or
cable.

Contact your system
administrator.

Continued on next page.
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Communication Check Reminder Messages (cont.)

Message Meaning Action

539 This message indicates a
loss of the virtual circuit
on your X.25 link.

Check the cabling on
your X.25 link and test
your X.25 network
software.

580 This message confirms
that your workstation
closed the secondary
virtual circuit on your
X.25 network.

Contact your system
administrator to check
the X.25 network
software and the SNA
server configuration.

581 This message confirms
that your workstation
reset the primary virtual
circuit on your X.25
network.

Contact your system
administrator to check
the X.25 network
software and the SNA
server configuration.

582 This message indicates
that the mainframe failed
to connect to your
workstation through a
secondary virtual circuit.

Contact your system
administrator to check
the X.25 network
software and the SNA
server configuration.

586 The name of this
message is “received
data failure.” You might
have a problem with
your network adapter.

Check your network
adapter and refer to your
adapter’s documentation
for instructions.

587 The name of this
message is “fatal DLC
error detected.” You
have a communication
problem originating
from your network
adapter.

Check your network
adapter and refer to your
adapter’s documentation
for instructions.

Continued on next page.
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Communication Check Reminder Messages (cont.)

Message Meaning Action

588 The name of this
message is “unable to
initialize token-ring
adapter.” This indicates
that your adapter
initialization failed.

The communications
software is unable to
start using the LAN
adapter.

This may occur if the
configured adapter
number does not exist.
Check with your system
administrator to
determine the correct
adapter number.

589 The name of this mes-
sage is “unable to open
Service Access Point
(SAP).” Your SAP para-
meters may be incorrect
or missing from your
CONFIG.SYS file.

The configured Service
Access Point could not
be opened.

Check with your system
administrator to
determine the correct
SAP number.

590 If you are in CUT mode,
this message means that
your connection with the
control unit has been
dropped.

(continued on next page)

Check your coax cable to
make sure it is attached
properly to your
workstation and to the
control unit or gateway.

Continued on next page.
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Communication Check Reminder Messages (cont.)

Message Meaning Action

590
(cont.)

If you have a token-ring
connection, this message
means: the token-ring
adapter driver is
unavailable.

Contact your system
administrator.

591 Open Link Station or
Link Receive failed.

The resources configured
for the token-ring
software may not be
sufficient to support an
additional Link Station.

Contact your system
administrator.

592 Transmit failed on Text
or XID.

The configured host
address may be invalid.
Contact your system
administrator.

593 Link Station connect
failed as primary side.

The workstation could
not initiate a connection
to the host.

Contact your system
administrator to check
the TIC configuration on
the host.

594 Link Station connect
failed as secondary side.

The workstation could
not accept a connection
initiation from the host.

Contact your system
administrator to check
the TIC configuration on
the host.

Continued on next page.



Understanding Mainframe Messages

B-25

Communication Check Reminder Messages (cont.)

Message Meaning Action

597 The gateway (SNA
Server) has stopped
communicating with
your terminal, indicating
the gateway (server) is
probably down.

Wait and then try the
operation again.

598 The gateway (SNA
server) has not respond-
ed to your terminal. You
may have an incorrect
network station name,
host resource name, or
an associated
workstation to gateway
(server) identification
problem. Or it could be
that the gateway’s
communication to the
mainframe has been cut
off. This is especially true
in cases where you have
successfully connected
before.

First, make sure that the
gateway (server) is still
operational. Second,
check your configura-
tion.

Continued on next page.



User’s Guide

B-26

Communication Check Reminder Messages (cont.)

Message Meaning Action

599 The gateway (SNA
server) has not respond-
ed to your terminal. You
may have an incorrect
network station name,
host resource name, or
an associated work-
station (server) ident-
ification problem. Or it
could be that the
gateway’s communica-
tion to the mainframe
has been cut off. This is
especially true in cases
where you have
successfully connected
before.

First, make sure that the
gateway (server) is still
operational. Second,
check your
configuration.

Field 4: Case Mode
This field tells you whether the display is in uppercase or lowercase
mode. If it is in uppercase mode, the symbol will be AA and all the text
on the display will appear in uppercase. If it is in lowercase mode, the
symbol will be Aa and all the text on the display will be displayed in both
uppercase and lowercase.

Field 5: Shifts and Modes Messages
When you use the mainframe, you can place your keyboard into different
modes so that you can carry out certain keyboard tasks. For instance, you
may need to do a lot of numeric input, so you might want to lock your
keyboard into the numeric mode. The numeric mode, in effect, turns the
right side of your 101-key keyboard into a 10-key keypad.
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The following table lists and describes the different shifts and modes
messages displayed by the OIA.

Shift and Mode Messages

Message Meaning

^ Insert
The keyboard is in the insert mode, which
means that, as you type characters at the cursor
location, characters to the right of the cursor
will move to make room for the inserted
characters. To turn off Insert mode, press the
Reset key. (Refer to your particular keyboard
mapping for the location of the Insert and Reset
keys).

APL APL Mode
The keyboard is in APL mode, allowing you to
write and modify programs using APL
characters. (APL stands for A Programming
Language).

NUM Numeric Mode
The message indicates that your cursor is
positioned in a field with the numeric attribute
set. This turns the right side of your 101-key
keyboard into a 10-key keypad.

Field 6: Session Short Name
The symbol in this field tells you which letter is assigned to the session
you currently have open. Session short names are assigned to sessions
during configuration. For example, the session short name might be A.

Field 7: Session Long Name
The name in this field is the session long name assigned to the display
session you currently have open. Session long names are assigned to
sessions during configuration. For example, the session long name might
be Session1.
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Field 8: Cursor Position
The Cursor Position tells you where the cursor is currently located on
your screen. The “R” represents the row number. Rows run horizontally
on your screen, and your screen can have up to 43 rows, depending on
which screen model you are using. For example, a model 2 screen mode
displays 24 rows. A line of text on your screen is one row.

The “C” represents the column number. Columns run vertically on your
screen, and your screen can have up to 132 columns, depending on which
screen model you are using. For example, a model 2 screen mode
displays 80 columns.

Field 9: Printer Status
Messages in the Printer Status field only appear if you have a coax
connection type. These messages tell you a number of things about the
current status of the printer, such as which printer you are connected to
and if the printer is printing your print job.

Keep in mind that these messages refer to the print command you
execute from the keyboard, which prints out what is currently on your
mainframe screen, not printer emulation.

Printer Status Messages

Message Meaning

nn
or
o-o nn

Printer Assignment
You are able to print from your display to the printer
whose printer address number is nn.

??
or
o-o??

Unidentified Printer
The printer IDENT (identification) has changed. Press
the IDENT key to display the new printer assignment.

nn
or
o-æ nn

Printer Printing
The printer identified by nn is printing your print job.

Continued on next page.
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Printer Status Messages (cont.)

Message Meaning

nn
or
o-o nn

Printer Failure
This message looks just like the Printer Assignment
message. If your printer successfully prints a job, you
would see a Printer Printing message. If this message
appears after you sent a job, it indicates that there is a
printer failure. You can clear this condition in one of
three ways:

• Check the printer and bring it back online.

• If the print job was sent by pressing the Print key,
press the DEVCNCL key.

• If the print job was sent by using a mainframe
program’s print command, press the Field Mark
key.

Fields 10 and 11: Time and Date
The final two fields in the OIA display the time and date according to the
system clock on your PC.
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3270: A protocol used by an IBM mainframe to communicate with other
devices, including PCs. An EXTRA! session with a mainframe is
sometimes referred to as a 3270 session.

7-Bit and 8-Bit codes: Coding formats for characters. Seven-bit (7-bit)
coding uses 7 bits to send each character to the host system, 8-bit coding
uses 8 bits. The ASCII character set uses 7-bit coding; the DEC
Multinational and ISO character sets use 8-bit coding.

ANSI Character Types: The American National Standards Institute
graphic (alphanumeric), and control character type definitions. You can
display graphic characters on the screen. These include letters, numbers,
punctuation marks, and any other displayable character.

Usually, you do not display control characters. You use them to make the
host perform specific functions in data communication and text
processing. Control characters include carriage return (CR), form feed
(FF), and escape (ESC).

APL ( A Programming Language): A general purpose language for
diverse applications, and best known for its use of non-ASCII symbols,
including a few Greek letters.

ASCII: American Standard Code for Information Interchange. ASCII is
an 8-bit code developed by the American National Standards Institute for
the exchange of information between communications devices, and their
associated equipment. The ASCII character set contains both control and
graphics characters.

Active page: The page that receives data from the host system; the host
selects the active page. The text cursor appears on the active page only.
Whether the active page is the current (displayed) page depends on the
page you select to display, and whether you enabled page coupling.

Active position: The location, indicated by the cursor, where the next
typed character will appear.

Alias Response: A sequence the terminal uses to identify itself to the
host as some other type of terminal. You can configure these responses.
Each response corresponds to a certain operating level.

Attribute: A characteristic of a unit of data such as length, value, or
method of representation. An attribute can also be a characteristic of a
session, such as the font and colors configured for a session.

Auto Print: The mode, controlled by the host, in which data appears on
the screen and the printer.
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Autosize Font: A font option that sizes the display font automatically to
best fit the current size of the display session window.

Autosize Window: A font option that sizes the display window
automatically to best fit the current size of the display session font.

Backing Store: A feature that provides two methods of storing graphics
images: Bitmap, and Display List.

Bitmap: An array of pixels representing an object.

Bookmark: A host screen page of special interest that you marked during
recording or afterward. A bookmark can be used to “navigate” directly to
a recorded page.

Buffer: A temporary storage area in memory used to hold information.

CSI code: Control Sequence Introducer code. The control function used
to start most ANSI commands. You can transmit CSI as the two 7-bit
characters ESC [ or the single 8-bit character CSI (9B hex).

Character Set: A group of graphic and control characters stored as a unit
in the terminal. You can display graphic characters on the screen. You
use control characters to perform special functions.

Code Page: A Character Translation table that sets up the keyboard and
display characters for various foreign languages. Code Pages are defined
for both the PC and Host.

Columns: A vertical row of character positions on the screen. You can
display lines containing 80 or 132 columns.

Communications Adapter: A device and associated software that
provide the actual connection between a PC and a host computer. There
are several types of communications adapters that support different
types of connections. For example, you can connect a PC to a host with a
direct cable link, through a LAN (local area network), or through a
modem.

Control codes: Specific terminal commands or formatting instructions
such as LF (line feed) or CR (carriage return); usually preceded by a caret
(^).

Current page: The displayed page.

Cursor: The indicator of the active position on the screen. The text cursor
usually appears as a blinking underline or block; the mouse cursor as an
I-bar symbol.
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DA Reports: Reports to send in response to a host request. Device
attribute (DA) reports inform the host about particular attribute
configurations and the current terminal state. Most are transparent to
you, but you can configure the Primary DA and Secondary DA reports.
Otherwise, these assume defaults based on the selected terminal type.

Data bits: Number of bits, 7 or 8, in each data packet sent between two
computers.

Desktop Layout: An arrangement of EXTRA! windows that you define.
When loaded, the layout opens and positions the windows as defined.
Desktop layouts are especially useful for quickly starting multiple
sessions.

Device Attributes: Characteristics, stored as control sequences, that
describe the terminal and its configuration. When the host requests it, the
terminal sends a device attribute (DA) response. This response identifies
the particular type of terminal.

Display List: A set of instructions for drawing an object (image).

Display Session: The equivalent of a host terminal session, using a
window called the display session. This window allows you to transfer
information between your PC and mainframe environments, or between
two or more mainframe sessions.

Download: To transfer a file from a host system to a personal computer.

Dynamically Redefinable Character Set (DRCS): A character set that an
application loads from the host. You can design your own set. Also called
“Downloadable,” or “Soft Character” Set.

EAB (Extended Attribute Byte): Allows a workstation to support 3270
Extended Attributes for display: highlighting, reverse image, blinking,
and 7 colors.

Echo: Display data sent to the host system on the screen as you type. If
the host does not send back characters it receives, you can select Local
Echo in the Settings - Display, General tab.

EXTRA! Basic Macro: A sequence of commands saved in a file, with an
extension of .EBM. The commands consist of statements and functions of
the EXTRA! Basic language, included with EXTRA!.

Firewall: A security gateway that limits access to an internal network by
the rest of the Internet.

Flow control: Processes that regulate the rate at which data is transferred
from one device to another. This compensates for the differences in input
and output data flow.



Glossary

Glossary-5

Font: A set of characters with the same typeface, style, stroke weight, and
size.

FTP: File Transfer Protocol. A high level protocol used for transferring
files between machines. FTP is usually implemented in application
programs and makes use of the lower level Telnet and TCP protocols.

Function keys: A row or rows of keys that perform special local
functions, such as displaying Help.

GDI Mode: An EXTRA! print processing option, it intercepts SCS and
PCL5 commands within the host print datastream (either embedded in
text, or within LU1 SCS transparency blocks) and emulates them through
the Windows GDI. See also Windows GDI.

Graphic Escape (GE): An IBM-defined two-byte print order for LU1
sessions. EXTRA! does not support graphic escape pages. The GE code is
discarded in EXTRA!.

Graphic table: The terminal’s two part in-use table. The left half contains
the GL codes for use in 7-bit and 8-bit environments. The right half
contains the GR codes for use in 8-bit environments only.

Graphics cursor: A specialized cursor that manipulates host graphics
and responds to commands from host graphics applications.

Graphics layer: The part of a graphics terminal that contains graphic
elements such as lines, ellipses, and graphic alphanumeric characters.
Compare with Text Layer.

Handles: Small black squares that appear on the corners of a selected
QuickPad or selected QuickPad objects. By dragging an object’s handles,
you can resize the object.

Hex Passthrough: Method for embedding “transparency” data within a
text stream. It uses a one or two-character “trigger” character which
switches EXTRA!’s processing of the datastream from normal text to
hexadecimal conversion. Hex passthrough blocks may be embedded in
LU1 and LU3 print streams.

History Buffer: A temporary storage area where you can keep data no
longer displayed in the emulation window. You can view, copy, and
paste this data.

History File: A file in which you store information from the History
Buffer.

Host: The computer to which your PC connects. Through EXTRA!, you
can run host applications, transfer files, and integrate host data into
Windows applications.
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Hosts File: A list of available Host names and their associated IP
addresses to which you can connect. In Windows 95, the Hosts file is
located in the Windows directory. In Windows NT, the Hosts file is
located in the DRIVERS\ETC subdirectory of the Windows NT system
directory. See also Region HotSpots and Text HotSpots.

HotSpots: HotSpots are defined areas of the display window that have
an action attached to them. This action can be to run a mainframe
Program Function, macro, application and so on. EXTRA! executes it if
you click on the HotSpot with the mouse. You can create your own
HotSpots and include them in your display sessions.

IP Address: A unique 32-bit number defining each machine connected to
the Internet (for example, 100.201.160.3). The IP address is used in all
communications with a TCP/IP host. It uniquely identifies the network
and the specific host address on that network. The number of address
bits that define the network and the number that define the host vary
according to the class of the address.

ISO Latin-1 Supplemental Set: An 8-bit character set including letters
with accents and diacritical marks, and special symbols. For most
purposes, this set is an extension of the DEC Multinational character set.

Keyboard Map: A keyboard map is a file (with the .EKM extension) that
defines the function that each key on a PC keyboard performs to
communicate with a host.

LU1 Printer Resource: An LU1 printer supports complex format
commands such as tabs, margins, underlining, bold, italics, and so forth.
Compared to other types of mainframe printers, it supports more
formatting commands and takes less processing time to print a job.

LU3 Printer Resource: An LU3 printer supports basic formatting
commands. These include page and job formatting options such as form
feed recognition and line feed insertion into a print job.

Line attributes: Characteristics (formats) you apply to a line to change
the way it appears on the screen.

Loadable Symbols: A set of symbols is which each character is treated as
a small picture and can be used as a marker, pattern, or text on the
graphics layer. Also called “graphic symbol sets.”

Local Edit: An editing mode in which the text you type is stored in page
memory. You can edit this text locally, and then send a block of edited
text to the host.

Local mode: An operating state in which keystrokes are displayed on the
screen, but not sent to the host.
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Local Printer: A printer that is connected directly to your PC, or
connected to a PC on your network.

Macro: A sequence of commands and keystrokes saved in a file. When
you run a macro, its contents are automatically sent to the mainframe.

MVS/CICS or VSE/CICS: MVS/CICS stands for Multiple Virtual
Storage/Customer Information Control System, and VSE/CICS stands
for Virtual Storage Extended/Customer Information Control System.
Under these operating systems, EXTRA! supports file transfers using
IBM’s DISOSS (Distributed Office Support System) (MVS: #5665-290;
VSE: #5666-270). MVS/CICS can also use IBM’s IND$FILE program
(#5665-311) for file transfer.

MVS/TSO: MVS/TSO stands for Multiple Virtual Storage/Time Sharing
Option. TSO is an interactive mainframe application that resides under
the MVS operating system. This system works with IBM’s TSO
IND$FILE program (#5665-311) to transfer files.

National Replacement Character Set: A class of 7-bit character sets
created for different languages and dialects.

PCL5: Hewlett-Packard’s printer control language, used in their popular
LaserJet and InkJet printers. EXTRA! emulates PCL5 in printer types LU1
and LU3.

PS/CICS: EXTRA! utilizes a separate transfer facility called DISOSS for
OV/MVS (PS/CICS) mainframe systems. This file transfer method is
initiated and controlled by the mainframe, and works differently from
IND$FILE transfers. This method is also referred to as a “Host-Initiated”
transfer.

Page Coordinate System: Points on the printed page, identified by a pair
of coordinates. PCL and SCS use differing page coordinate systems, and
this must be taken into account when using GDI Mode. See also GDI
Mode.

Parity: An error-detection method that checks the validity of a
transmitted character; both systems must use the same type of parity.

PF keys (Program Function keys): Functions that invoke mainframe
commands, such as Exit. Displayed on most mainframe screens, program
functions are invoked by pressing corresponding keys on an IBM
terminal keyboard. Because a PC keyboard does not include Program
Function keys, EXTRA! assigns the functions to PC keys. You can also
use EXTRA!’s HotSpots features to execute Program Functions.
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Ping: Packet InterNet Groper. Refers to the program used on the Internet
to test the availability of a host by sending an echo request and waiting
for a reply.

Pixel: Pixel, or pel (picture element) refers to the smallest displayable
unit on a video screen. The resolution of a video screen is measured in
pixels. For example, a standard VGA screen is 640 pixels wide by 480
pixels high. Pixels are used as a measure of font width.

Point size (fonts): A unit of measurement, equal to 1/72 of an inch, that
is used to specify the size (in height) of fonts. For example: a 36 point font
is (nominally) 1/2 inch in height.

Print buffer: Temporary storage area for information sent to a printer.

Printer controller mode: Mode in which data is sent directly from the
host to a printer, without being displayed on the screen.

Printer Session: The window where printer emulation takes place. This
window provides options for controlling the print data sent from the host
to the PC printer.

Profile: A session document that you use when you open an existing
session. The session profile contains relevant information about the
session: connection type, layout, colors, file transfer methods, attached
toolbars or QuickPads, and so on.

Proportional Fonts: A font in which different characters have varying
widths. All magazines and newspapers are printed in proportional
characters, which make reading easier. By contrast, in a monospaced
font, such as one on an old typewriter, all characters have the same
widths.

Protected Field: On a display screen, a display field in which a user
cannot enter, modify, or erase data.

Protocol: A set of rules and procedures for communication between
devices. For example, Kermit is a file transfer protocol, and XON/XOFF
is a flow control protocol for serial communications.

Proxy: A server that works in conjunction with a firewall (often as part of
the same system) to provide network security. A proxy acts as an
intermediary to limit access between clients in an internal network and
outside servers.

QuickPad: A QuickPad is a small window that you can load during a
session that contains text, buttons, bitmaps, icons, and other graphic
elements, each of which initiates an action when clicked. QuickPads can
be any shape or size, and as simple or as complex as you want.
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Raw Output Mode: An EXTRA! print processing option, it translates the
print datastream from EBCDIC to ASCII, strips SCS formatting controls
from the datastream, and copies the resulting ASCII datastream directly
to a printer or a disk file. The Windows GDI is bypassed entirely. See also
Windows GDI.

Region HotSpots: Region HotSpots are defined areas of the display
window that have an action attached to them. This action can be to run a
mainframe Program Function, macro, application and so on. EXTRA!
executes it if you click on the region HotSpot with the mouse. You can
create your own region HotSpots and include them in your display
sessions. See also HotSpots and Text HotSpots.

ReGIS: DIGITAL’s Remote Graphics Instruction Set. A set of commands
that describes a graphics image using geometric shapes (lines, curves,
and circles), and actions (fills and patterns).

Resolution: Number of dots that make up an image on a screen or
printer. The more dots, the higher the resolution, and the finer and
smoother images appear when displayed at a given size.

SCS: IBM’s SNA control set, used in LU1 printing.

Scheme: A collection of settings used to customize the way you use
EXTRA!. In a scheme, you can save specific features of a session such as
file transfers, HotSpots, colors, and so on.

Scrolling region: The area on the current page between the top, bottom,
left, and right page margins. The default scrolling region is the complete
page.

Session: A conversation between the host and PC. Each session runs in
its own window, providing “point-and-click” commands and graphical
tools to simplify host access.

A display session allows you to access host applications, and transfer
files. IBM hosts require a separate printer session to set up and control
printing.

Serial port: Port used for devices that accept information one bit at a
time; uses a single line to transfer data.

Sixel: A unit of graphics data transmitted as a character. One sixel
represents six vertical pixels of an image.

SOCKS: A proxy protocol that can be used to establish a controlled data
channel between two computers across a firewall. EXTRA! supports
SOCKS version 4.0 proxies using either a Telnet or an FTP connection.
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Spooler: System program that automatically runs when you choose a
print command. A spooler lets you print a series of documents or files in
the background while you continue working in the application.

Stop bit: Timing unit between transmitted characters.

Supplemental Character Set: The 8-bit character set the terminal
normally uses, usually the DEC Multinational or ISO Latin-1 character
set.

TCP/IP: Transmission Control Protocol/Internet Protocol. TCP is the
Internet standard transport level protocol. It provides full duplex reliable
stream service, which application level protocols such as Telnet and FTP
rely on.

Tektronix, 4014: A vector graphics terminal that uses direct-view storage
tube technology.

Telnet: Protocol for terminal access to hosts using TCP/IP.

Terminator: Control character(s) that signal the end of a line, document,
and so on.

Text HotSpots: Text HotSpots are defined words that have an action
attached to them. This action can be to run a mainframe Program
Function, macro, application and so on. EXTRA! executes it if you click
on the text HotSpot with the mouse. You can create your own text
HotSpots and include them in your display sessions. See also HotSpots
and Region HotSpots.

Text layer: A part of the graphics terminal that contains the host graphic
application’s user interface, such as menus and commands. Compare
with Graphics layer.

Toggle command: A menu command that alternately activates and de-
activates a command option. When activated, a check mark appears in
front of the command name.

Tool Tip: A brief reminder that pops-up when you hold the mouse
pointer over a toolbar button for a few seconds.

Transparent mode: A special operating mode in which you can display
control code characters. In this mode, control functions are not
performed, only the characters are displayed.

Trigger Signature: One- or two-characters in length, this character
switches EXTRA!’s processing of the print datastream from normal text
to hexadecimal conversion.
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Unprotected Field: On a display screen, a display field in which a user
can enter, modify, or erase data.

Upload: To transfer a file from a personal computer to a host.

VM/CMS: VM/CMS stands for Virtual Machine/Conversational
Monitor System. CMS is an interactive mainframe application that
resides under the VM operating system. This system works with IBM’s
CMS IND$FILE program (#5664-281) to transfer files.

VSE/CICS or MVS/CICS: MVS/CICS stands for Multiple Virtual
Storage/Customer Information Control System, and VSE/CICS stands
for Virtual Storage Extended/Customer Information Control System.
Under these operating systems, EXTRA! supports file transfers using
IBM’s DISOSS (Distributed Office Support System) (MVS: #5665-290;
VSE: #5666-270). MVS/CICS can also use IBM’s IND$FILE program
(#5665-311) for file transfer.

Vector Graphics: Form of graphics where the image is created using
graphic elements such as ellipses and lines, for example (called
primitives) that describe shapes and their positions on the screen. Also
known as All Points Addressable Graphics since each point on the screen
is accessible by the host graphics package.

Windows Graphics Device Interface (GDI): The Windows graphics
language used to provide output to the screen and printer. Applications
call the GDI functions in Windows to display and print. GDI in turn calls
the screen and printer drivers to produce the final output.

Xon/Xoff: Standard ASCII control characters used to tell an intelligent
device to stop and resume transmission of data.

Zoom: Increase or decrease the magnification of an object (image).
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%% (trigger signature), 5-38
0x35 transparency block, 5-35
0x36 transparency block, 5-35
3270

Colors
General page, 3-13, 3-15
Graphics page, 3-14

Display
Attributes page, 3-30
defining settings, 3-23
General page, 3-24
Host Code Page, 3-26
Miscellaneous page, 3-28

Edit
Advanced page, 3-33
General page, 3-32
options, 3-32
settings, 3-31

Font General page, 3-19
Printer

Data Stream page, 5-15
Fonts page, 5-11
General page, 5-9
LU1/LU4 page, 5-12
LU3 page, 5-14
Margins page, 5-10
page, 5-7

802.2 Direct Connect
General page, 2-4
overview, 2-4
system requirements, 2-4

802.2 Edit LU Range dialog box, 2-10

A
aligning forms, printing, 5-20
accelerator key

bitmap button, 9-17
QuickPad button, 9-16
QuickPad icon, 9-17

Action page, 8-14
actions assigning to keys, HotSpots, QuickPads,

or Toolbars, 9-32
adapter, Hayes AutoSync, 2-59

adding
HotSpot region, 7-7
HotSpot text, 7-5
HotSpots, 7-3
QuickPad to a session, 3-12
toolbar to a session, 3-10

adjusting page recording time, 9-37
advanced settings, editing 3270, 3-33
Align Form, 5-18, 5-20
alignment, QuickPad

group box, 9-16
object to grid, 9-22
text, 9-17

altering host settle time, 9-37
APL characters, assigning to keys, 8-16
APL mode

mapping key to toggle, 8-16
setting keyboard map, 8-5
toggling, 8-5
using a keyboard map, 8-5

Application commands, securing, 14-4
APPN Manager, 16-7, 16-10
APPN node

auto shutdown, 16-3
changing the current configuration, 16-3
editing properties, 16-3
node tracing, 16-3
properties, 16-2
status, 16-5

assigning
action to a key, 8-14
APL characters to keys, 8-16
function to a key, 8-5
HotSpot action, 7-10

asynchronous host, file transfer schemes, 6-29
Attachmate Gateway via IPX/SPX

Advanced page, 2-14
configuring a connection, 2-15
General page, 2-13
overview, 2-12
system requirements, 2-12

Attachmate Gateway via TCP/IP
configuring a connection, 2-16, 2-17
defining, 2-16
General page, 2-16
LAN Broadcast option, 2-16
overview, 2-15
system requirements, 2-15
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autosize 3270 windows
described, 3-21
editing, 3-21

autosizing
fonts, 3-19
windows, 3-19

B
Banyan SNA Service via VINES

configuring a connection, 2-120
defining a profile key, 2-121
Edit Connection dialog box, 2-120
General page settings, 2-118
overview, 2-117
Profile Key option, 2-121
system requirements, 2-118

Banyan VINES to IrmaLAN Server
Advance page, 2-74
configuring a connection, 2-73
Enable Keep Alive option, 2-74
General page, 2-72
overview, 2-71
Security options, 2-74
Symbolic Workstation Name, 2-74
system requirements, 2-71

Banyan VINES to ZIP! Server
configuring, 2-123
General page, 2-122
overview, 2-121
system requirements, 2-122

bitmap
button

accelerator key, 9-17
placing on a QuickPad, 9-11
ToolTips, 9-17

QuickPad, 3-11
aligning to the grid, 9-22
arranging, 9-19
copying, 9-20, 9-21
cutting, 9-20
deleting, 9-19
modifying, 9-18
moving, 9-18
pasting, 9-21
placing, 9-11
resizing, 9-19

Black and white buttons on a toolbar, 3-10, 9-4

Button
on a toolbar, 3-10
QuickPad, 3-11

aligning to the grid, 9-22
arranging, 9-19
copying, 9-20, 9-21
cutting, 9-20
deleting, 9-19
modifying, 9-18
moving, 9-18
pasting, 9-21
placing, 9-11
resizing, 9-19

toolbar
assigning a bitmap, 9-29
assigning properties, 9-29
copying, 9-30
cutting, 9-30
deleting, 9-31
description, 9-28
moving, 9-29
pasting, 9-30
placing, 9-28

C
Cancel Print command, 5-19
Cancel Print, 5-18
Case Mode field. See Operator Information Area

(OIA)
Change Settings commands, securing, 14-10
changing

display session
colors, 3-12, 3-14
fonts, 3-20
margins, 3-20
settings, 3-21, 3-31

graphics colors, 3-16
host attribute colors, 3-16
keyboard type, 3-4
text colors, 3-12, 3-14

characters, APL, assigning to keys, 8-16
Checks, machine. See Operator Information

Area (OIA)
CICS

MVS/CICS, 6-3
PS/CICS, 6-3
VSE/CICS, 6-3
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Cisco NCIA connection
Block ID, 2-27
destination settings, 2-27
Edit LU Range dialog box, 2-32
editing, 2-29
Ethernet adapter, 2-27
General settings, 2-27
I-Frame Size, 2-27
Logical Unit Type, 2-27
overview, 2-26
system requirements, 2-27
TCP/IP Address, 2-27
Token-Ring adapter, 2-27
Virtual Ring, 2-27
workstation settings, 2-27

Clear command, display session, 4-7
close program, how to, 1-12
closing sessions, 1-11 – 1-12
CMS, VM/CMS, 6-3
color

3270 schemes
deleting, 3-17
description, 3-12

QuickPad
rectangle, 9-16
setting, 9-10

toolbar buttons, 9-4, 9-27
Color buttons on a toolbar, 3-10
colors

changing graphics colors, 3-16
changing display session, 3-12, 3-14
changing host attribute, 3-16
editing, 3-13, 3-15
editing host attribute, 3-16
mapping host attribute, 3-16
setting security, 3-17

Colors General page, 3270, 3-13, 3-15
Colors Graphics page, 3270, 3-14
commands, assigning to keys, HotSpots,

QuickPads, or Toolbars, 9-32
commands, securing

Application, 14-4
Change Settings, 14-10
Edit menu, 14-5
File menu, 14-7
Help menu, 14-4
Macro, 14-7
Miscellaneous, 14-8

commands, securing, continued
Options menu, 14-8
Session menu, 14-9
Tools menu, 14-12
View menu, 14-13

Communication Check Reminders field. See
Operator Information Area (OIA). See
Operator Information Area (OIA)

Condition of Communications field. See
Operator Information Area (OIA)

Condition of Connection field. See Operator
Information Area (OIA)

configuration
information, viewing, 16-12
messages. See Operator Information Area

(OIA)
page, 16-12

configuring [0x35] Transparency blocks, 5-36
Connect dialog box, 6-38
connection

options
Attachmate Gateway via TCP/IP, 2-15
ZIP! Server via TCP/IP, 2-129

tool, 2-34, 2-110
type, editing, 3-35, 3-36, 3-37

Context-sensitive Help
dialog box, xxiv
menu command, xxiv

Control sequences supported under GDI Mode,
5-46, 5-48

Copy and Append command, display session,
4-7

Copy command, display session, 4-7
copying

function to a key, 8-5
key function, 8-12

creating
color scheme 3270, 3-16
file transfer schemes, 6-29
HotSpot schemes, 7-12
keyboard map from a session, 8-12
keyboard map from Keyboard Map Editor,

8-12
layouts, 1-8
printer sessions, 5-4
QuickPad, 9-6, 9-37
sessions, 1-4, 1-5, 1-6
toolbar, 9-7
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Cursor Position field. See Operator Information
Area (OIA)

customizing toolbars, 9-26
Cut and Append command, display session, 4-7
Cut command, display session, 4-7

D
Date field. See Operator Information Area (OIA)
default font, enabling, 5-45
default path, startup macros and settings files,

3-4
defining display sessions, 3270, 3-23
deleting

function from a key, 8-5, 8-17
HotSpot schemes, 7-13
HotSpots, 7-12
keyboard map, 8-4
QuickPad, 9-6, 9-37
toolbar, 9-7

Demo
connection, configuring, 2-111
tool

.PSS files, 2-110
files, 2-34
General page, 2-34, 2-110
overview, 2-110

Dependent LU Requestor connection
configuring, 2-39
Connection list, 2-35
overview, 2-35
system requirements, 2-35
Transport page, 2-37

desktop layouts
creating, 1-8
description, 1-8
opening, 1-10
saving, 1-8

dialog boxes, context-sensitive Help, xxiv
disabling

HotSpots, 7-16
QuickFields, 7-16

disconnecting sessions, 1-11, 1-12

display
3270

Attributes page, 3-30
defining, 3-23
General page, 3-24
Host Code Page, 3-26
Lightpen, 3-29
Miscellaneous page, 3-28
overview, 3-22

options, editing, 3-37
session. See individual session type.
session files, 1-7
settings, changing, 3-21
type, editing, 3-35

displaying
default keyboard map, 8-4, 8-8
HotSpots, 7-14

DLC
connection

list, 16-6
statistics, 16-7

information, viewing, 16-6
Statistics page, 16-6, 16-7

DLSw Direct Connect
Add DLSw Connection Definition dialog

box, 2-50
frame size, 2-47
I-Frame, 2-47
LAN Adapter #, 2-47
overview, 2-44
service access point, 2-47
system requirements, 2-44
TCP/IP address, 2-47

DLUR connection
configuring a connection, 2-39
General page, 2-35
overview, 2-35
system requirements, 2-35
Transport page, 2-37

document name, specifying in Print Screen, 5-25
dragging files to the transfer list, 6-27
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E
Edit

3270 settings, 3-31, 3-32
Advanced page, 3270, 3-33
General page, 3270, 3-32
menu

commands, 4-7, 14-5
described, 4-7
display session, 4-7

editing
autosize 3270 windows, 3-21
host attribute colors, 3270, 3-16
HotSpot region, 7-7
HotSpot schemes, 7-13
HotSpot text, 7-5
HotSpots, 7-3
keyboard map, 8-5
options, 3270, 3-31, 3-32
QuickPad, 9-6, 9-37
toolbar, 9-7

editor, QuickPad, description, 9-8
Eicon Gateway via IPX/SPX

Add/Edit dialog box, 2-53
configuring a connection, 2-54
Connection list, 2-51
General page, 2-51
LU Number, 2-53
overview, 2-51
Port ID, 2-53
PU Name, 2-53
system requirements, 2-51

Eicon Gateway via NetBIOS
Add/Edit dialog box, 2-57
General page, 2-55
overview, 2-55
system requirements, 2-55

embedding EXTRA! sessions, 4-5
enabling

HotSpots, 3-10, 7-16
QuickFields, 7-16

Ethernet. see also 802.2 Direct Connect
exit program, how to, 1-12
exiting

EXTRA!, 1-11
Keyboard Map Editor, 8-18
sessions, 1-11, 1-12

EXTRA!, starting, 1-3, 1-4

F
File Handling page, 6-34
File menu commands, securing, 14-7
file transfer

CICS
MVS/CICS, 6-3
PS/CICS, 6-3
VSE/CICS, 6-3

CMS, VM/CMS, 6-3
File Handling page, 6-34
File Transfer dialog box, 6-28
File Types page, 6-37
Folders page, 6-36
FTP, See FTP file transfer, 6-24
overview, 0-2
protocol, editing, 3-35, 3-37
schemes

applying, 6-29
creating, 6-29
described, 6-29
saving, 6-29

sending and receiving files, 6-27
settings, editing, 3-37
Transfer File dialog box, 6-24
transfer summary, 6-27
transferring a batch of files, 6-27
TSO, MVS/TSO, 6-3

File Types page, 6-37
Folders page, 6-36
font

Font General page, 3270, 3-19
QuickPad button or text, 9-15
specifying in Print Screen, 5-27
support within Transparency PCL Blocks,

5-43
fonts

3270
changing in display sessions, 3-19, 3-20
customizing, 3-19

enabling for GDI Mode, 5-44
footer, specifying in Print Screen, 5-26
Form Feed, 5-18
Form Feed command, 5-19
formatting printer output, overview, 5-33
FTP file transfer

Connect dialog box, 6-38
connecting, 6-38
described, 6-24
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FTP file transfer, continued
General page, 6-30
proxies, 6-32, 6-34
Proxies page, 6-32
sending and receiving files, 6-27
setting up, 6-32
settings, 6-30, 6-34, 6-36, 6-37

function, copying, 8-12
Function shell, adding in the Macro Editor,

12-25

G
GDI Mode

advantages, 5-41
deciding between GDI or raw output mode,

5-41
defined, 5-34
disadvantages, 5-41
enabling fonts, 5-44
PCL5 control sequences not supported

bitmap-related, 5-53
miscellaneous, 5-55
rectangle-related, 5-54

PCL5 control sequences supported, 5-48
font related, 5-48
job/paper-related, 5-52
miscellaneous, 5-52
position-related, 5-49
rectangle-related, 5-51
simplex/duplex-related, 5-52

setting up Windows, 5-35
General Input messages. See Operator

Information Area (OIA)
General page, FTP file transfer, 6-30
general tips, online Help, xxi
global preferences

editing, 3-4, 3-6, 3-7
Global Preferences General page, 3-5
saving settings, 3-6
setting security, 3-8

grid, QuickPad, 9-22
group box, QuickPad

aligning to the grid, 9-22
arranging, 9-19
copying, 9-20, 9-21
cutting, 9-20
deleting, 9-19
font, font size and font style, 9-15

group box, QuickPad, continued
modifying, 9-18
moving, 9-18
pasting, 9-21
placing, 9-11
resizing, 9-19

H
Hayes AutoSync Direct Connect

configuring adapter, 2-59
connection definition, 2-64
Connection Name, 2-61
CP name, 2-61
creating new session, 2-60
Destination Node Type, 2-64
Destination PU ID, 2-61, 2-64
general settings, 2-61
link capability, 2-64
NRZ, 2-64
overview, 2-58
Phone Number, 2-64
Poll Address, 2-61
system requirements, 2-59
Wiring Type, 2-64
workstation parameters, 2-64

header, specifying in Print Screen, 5-26
Help

context-sensitive, xxiv
menu commands, securing, 14-4

Hex passthrough blocks
byte values, 5-40
description, 5-37
enabling, 5-37
processing examples, 5-38
spaces, 5-40
trigger signature description, 5-38

Hold Print command, 5-19
Hiding the Status Bar, 1-10
HLLAPI, short names, 3-6, 3-7
Hold Print, 5-18
Host Attribute symbols, B-16
host code pages, 3270 display, 3-26
host printing, 5-17

defined, 5-17
, 5-17

Host screens, applying HotSpot schemes to, 7-13
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HotSpots
Action page, 7-8
adding, 7-3
assigning an action, 7-10, 9-32
Assignments page, 7-10
boundaries, 7-2
deleting, 7-12
description, 7-2
disabling, 7-14, 7-16
displaying, description, 7-14
editing, 7-3
enabling, 3-10, 7-14, 7-16
example, 7-2
General page, 7-14
hierarchy, 7-3
Properties (text) page, 7-3
region

adding, 7-7
description, 7-2
editing, 7-7
Properties page, 7-6

schemes
applying to a host screen, 7-13
creating, 7-12
deleting, 7-13
description, 7-2, 7-12
editing, 7-13

setting display style, 7-17
setting security, 7-17
text

adding, 7-5
description, 7-2
editing, 7-5

using, 7-10
viewing, 3-10

I
IBM CICS Server connection

Connection list, 2-68
Edit Connection dialog box, 2-70
General page, 2-68
Initial Transaction ID, 2-68, 2-70
Number of Retries, 2-68, 2-70
overview, 2-68
removing a connection, 2-71
Server Name, 2-70
system requirements, 2-68
Terminal Resource, 2-70

icon, QuickPad, 3-11
aligning to the grid, 9-22
arranging, 9-19
copying, 9-20, 9-21
cutting, 9-20
deleting, 9-19
modifying, 9-18
moving, 9-18
pasting, 9-21
placing, 9-11
resizing, 9-19

icons, adding to Program Group in NT 3.51, 1-6
information monitoring, APPN Node Manager,

16-2
IPX/SPX to Eicon Gateway

Add/Edit dialog box, 2-53
configuring a connection, 2-54
Connection list, 2-51
Connection Timeout, 2-51
Enable Infinite List Retries, 2-51
General page, 2-51
LU Number, 2-53
overview, 2-51
Port ID, 2-53
PU Name, 2-53
Retry Delay, 2-51
system requirements, 2-51

IPX/SPX to NetWare for SAA
adding a connection, 2-94
Advanced page, 2-95
Broadcast Range (hops), 2-95
Broadcast Search, 2-95
Connection list, 2-90
Connection Timeout option, 2-95
Edit Connection dialog box, 2-92
Gateway Hot Rollover option, 2-95
General page, 2-90
General Service option, 2-95
NDS User configuration, 2-90
overview, 2-90
Password Encryption option, 2-95
removing a connection, 2-94
SNA Service, 2-93
system requirements, 2-90

IrmaLAN Server via Banyan VINES
Advance page, 2-74
configuring a connection, 2-73
Enable Keep Alive option, 2-74
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IrmaLAN Server via Banyan VINES, continued
General page, 2-72
overview, 2-71
Security options, 2-74
Symbolic Workstation Name, 2-74
system requirements, 2-71

IrmaLAN Server via IPX/SPX
Advanced page, 2-77
configuring a connection, 2-78
Enable Keep Alive option, 2-77
General page, 2-76
overview, 2-75
Security options, 2-77
Symbolic Workstation Name, 2-77
system requirements, 2-75

IrmaLAN Server via NetBIOS
Advanced page, 2-81
gateway page, 2-81
General page, 2-80
Lana option, 2-81
overview, 2-79
security options, 2-81
system requirements, 2-79

K
key action, assigning, 8-14
key function, copying, 8-12
keyboard accelerator keys

bitmap buttons, 9-17
QuickPad buttons, 9-16
QuickPad icons, 9-17

keyboard map
assigning a function, 8-5
copying a function, 8-5
creating, 8-12
creating from Keyboard Map Editor, 8-12
deleting, 8-4
deleting a function, 8-5, 8-17
displaying default, 8-8
editing, 8-5, 8-18
loading, 8-2
opening, 8-8
printing, 8-9
saving, 8-17
viewing, 8-4, 8-8

Keystrokes, keyboard maps, 0-2
keyboard maps, 0-2
reserved keys, 8-11

Keyboard states, B-26
keyboard type, changing, 3-4

L
label, QuickPad

button, 9-16
group box, 9-16
text, 9-17

Large buttons on a toolbar, 3-10, 9-4
Last Transaction Time clock, B-17
layouts, desktop, 1-4, 1-8, 1-10
Lightpen, 3270, 3-29
link

information, viewing, 16-8
list, 16-8

Link Statistics page, 16-8, 16-9
linking EXTRA! to other applications, 4-5
loading

keyboard map, 8-2
QuickPad, 9-6, 9-37
toolbar, 3-10, 3-12, 9-7

Local LU information, viewing, 16-9
Local Path, description, 3-7
Long Name field. See Operator Information

Area (OIA)
LU

6.2 list, 16-10
information, viewing, 16-9
list, conventional, 16-10
sessions list, 16-11

LU 0 to 3 page, 16-9, 16-10
LU 6.2 page, 16-9, 16-10
LUA. See LUA/LU0/RUI
LUA/LU0/RUI

Add Connection dialog box, 2-86
configuring a connection, 2-86
General page, 2-84
overview, 2-83
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M
Machine Checks. See Operator Information Area

(OIA)
Macro commands, securing, 14-7
Macro Editor, adding a function or object shell,

12-25
Macro Search Path, description, 3-7
macros

running at specific host page, 3-2
running at startup, 3-2, 3-3

Mainframe Demo, SlideShow, 2-110 – 2-111
mapping

host attribute colors, 3270, 3-16
key to toggle APL mode, 8-16

margins
changing 3270 display session, 3-19, 3-20
specifying for Print Screen, 5-25

menu commands, context-sensitive Help, xxiv
Microsoft SNA Server, configuring a connection
Microsoft SNA Server connection, 2-88 – 2-89
Miscellaneous commands, securing, 14-8
Miscellaneous page, 3270, 3-28
monitoring information, APPN Node Manager,

16-2
Monochrome buttons on a toolbar, 3-10, 9-4
moving a QuickPad object, 9-18
MS SNA Server connection (Mainframe)

General page, 2-88
overview, 2-88
system requirements, 2-88

multiple screen printing, 5-30
MVS/CICS, 6-3
MVS/TSO, 6-3

N
Navigations Settings dialog box, 9-37
NCIA connection

Block ID, 2-27
destination settings, 2-27
Edit LU Range dialog box, 2-32
editing, 2-29
Ethernet adapter, 2-27
General settings, 2-27
I-Frame Size, 2-27
Logical Unit Type, 2-27
overview, 2-26
system requirements, 2-27

NCIA connection, continued
TCP/IP Address, 2-27
Token-Ring adapter, 2-27
Virtual Ring, 2-27
workstation settings, 2-27

NDS User configuration, IPX/SPX to NetWare
for SAA, 2-90

NetBEUI, 2-79, 2-80, 2-81
NetBIOS connection

Advanced page, 2-81
gateway page, 2-81
General page, 2-80
Lana option, 2-81
overview, 2-79
security options, 2-81
system requirements, 2-79

NetWare for SAA via IPX/SPX
adding a connection, 2-94
Advanced page, 2-95
Broadcast Range (hops), 2-95
Broadcast Search, 2-95
Connection list, 2-90
Connection Timeout option, 2-95
Edit Connection dialog box, 2-92
Gateway Hot Rollover option, 2-95
General page, 2-90
General Service option, 2-95
NDS User configuration, 2-90
overview, 2-90
Password Encryption option, 2-95
removing a connection, 2-94
SNA Service, 2-93
system requirements, 2-90

NetWare for SAA via TCP/IP
Advanced page, 2-101
Connection list, 2-97
Connection Timeout option, 2-101
Edit connection dialog box, 2-98
Gateway Hot Rollover option, 2-101
General page, 2-97
overview, 2-96
Password Encryption option, 2-101
Server Name, 2-99
system requirements, 2-96

New Session command, 1-5
Node, 16-5 – 16-6
Node Manager, 16-2, 16-6
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O
object linking and embedding

embedding an entire EXTRA! session, 4-6
embedding selected information from an

EXTRA! session, 4-5
linking EXTRA! to other applications, 4-5

Object shell, adding in the Macro Editor, 12-25
object, QuickPad

aligning to the grid, 9-22
placing on a QuickPad, 9-11
properties, 9-11

OLE
embedding an entire EXTRA! session, 4-6
embedding selected information from an

EXTRA! session, 4-5
linking EXTRA! to other applications, 4-5

Online Help, context-sensitive, xxiv
Open Session command, 1-7
opening

keyboard map, 8-8
layouts, 1-10
printer sessions, 5-3
QuickPad, 9-8, 9-9
sessions, 1-4, 1-7

Operator Information Area (OIA)
Case Mode field, B-26
Communication Check Reminders field

Communication Check Reminder
messages, B-18 to B-26

described, B-16
Host Attribute symbols, B-16 to B-17
Last Transaction Time clock, B-17

Condition of Communication field
Configuration messages, B-10 to B-11
described, B-6
General Input messages, B-13 to B-15
Machine Check messages, B-7 to B-9

Condition of Connection field, B-4 to B-6
Cursor Position field, B-28
Date field, B-29
fields, table, B-3
Printer Status field

described, B-28
messages, B-28 to B-29

Session Long Name field, B-27
Session Short Name field, B-27
Shifts and Modes messages, B-27
Time field, B-29

Options menu commands, securing, 14-8
orientation, printing a screen, 5-25
outline, QuickPad rectangle property, 9-16

P
PA1

defined, 5-18
 sending a PA1 command, 5-19

PA2
defined, 5-18
sending a PA2 command, 5-19

passwords, 14-14
Paste command, display session, 4-7
Paste Continue command, display session, 4-7
PCL5 control sequences

not supported under GDI Mode
bitmap-related, 5-53
miscellaneous, 5-55
rectangle-related, 5-54
soft font-related, 5-54

supported under GDI Mode, 5-48
font-related, 5-48
job/paper-related, 5-52
miscellaneous, 5-52
position-related, 5-49
rectangle-related, 5-51
simplex/duplex printing-related, 5-52

placing an object on a QuickPad, 9-11
printer

3270 Printer settings
Data Stream page, 5-15
Fonts page, 5-11
General page, 5-9
LU1/LU4 page, 5-12
LU3 page, 5-14
Margins page, 5-10
Printer page, 5-7

controls, 5-18 – 5-20
page setup options, 5-23
selecting, 5-6
session

closing, 5-5
creating, 5-4
described, 5-2
files, 1-7
opening, 5-2, 5-3
status, 5-21
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printer, continued
session

troubleshooting, 5-31
status, viewing, 5-21 –  5-22

Print Multiple Screens dialog box, 5-30
Print Screen

configuring advanced options, 5-30
defined, 5-23
dialog box, 5-27
document name, 5-25
font, 5-27
footer, 5-26
header, 5-26
margins, 5-25
page setup, 5-23
print orientation, 5-25
Print Screen dialog box, 5-27
printing, 5-29
printing to a file, 5-29

Printer Status field. See Operator Information
Area (OIA)

Printing
aligning forms, 5-20
formatting output, overview, 5-33
from the host, 5-17
Hold Print, 5-19
keyboard map, 8-9
multiple screens, 5-30
overview, 5-2
PA1 and PA2 commands, 5-19
Print Screen, 5-23
printer controls, 5-18
printer emulation in Windows, 5-34
screen, 5-29
to a file, 5-17
to a printer, 5-17

Profile Key option, 2-120, 2-121
profiles, session, 1-5, 1-7
properties, QuickPad, 3-8

object, 9-11
rectangle, 9-16
setting, 9-9

proxies, 6-32, 6-34
PS/CICS, 6-3

Q
QuickFields, 7-14 – 7-16
QuickPad

aligning an object to the grid, 9-22
assigning an action, 9-32
attaching to

host screen, 9-3
session, 9-3

button dialog box Label page, 9-16
configuring the grid, 9-22
copying an object, 9-20, 9-21
creating a QuickPad using the editor, 9-8
cutting a object, 9-20
deleting an object, 9-19
described, 9-2
editing an object, 9-18
editor, 9-8
exiting the QuickPad editor, 9-23
Font page, 9-15
Grid Settings dialog box, 9-22
group box dialog box Label page, 9-16
Icon dialog box, Icon page, 9-17
loading, 3-12
moving an object, 9-18
object properties, 9-11
Open Bitmap dialog box, 9-17
opening from the QuickPad editor, 9-9
opening from the session window, 9-8
opening QuickPad editor from a Session,

9-8
overview, 3-11
paste an object, 9-21
placing an object, 9-11
Properties dialog box, 9-9
rearranging an object, 9-19
rectangle dialog box, 9-16
resizing, 9-10
resizing an object, 9-19
saving, 9-23
security settings, 9-24
selecting an object, 9-18
setting

color, 9-10
title, 9-10

Settings dialog box, 9-6, 9-37
showing or hiding the grid, 9-22
Text dialog box Label page, 9-17
unloading, 3-12
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R
raw output mode

advantages, 5-41
defined, 5-34
description, 5-33
disadvantages, 5-42

receiving files, FTP, 6-27
rectangle, QuickPad

aligning to the grid, 9-22
arranging, 9-19
copying, 9-20, 9-21
cutting, 9-20
deleting, 9-19
modifying, 9-18
moving, 9-18
pasting, 9-21
placing on a QuickPad, 9-11
QuickPad object, 9-16
resizing, 9-19

rectangular selection, 4-2, 4-3
region HotSpots, 7-2
Remote Path, description, 3-7
removing QuickPad from session, 3-12
reserved keys, 8-11
resizing QuickPad, 9-10
RUI. See LUA/LU0/RUI

S
Save Session As command, 1-6
saving

file transfer schemes, 6-29
global preference settings, 3-6
keyboard map, 8-17
layouts, 1-8
transfer list, 6-27

scheme files, selecting, 3-8
schemes

3270 color
creating, 3-16
deleting, 3-17
overview, 3-12

file transfer, 6-29
HotSpot, 7-2, 7-13
setting default path, 3-4

screen printing, 5-29
screen layouts, 1-8, 1-10

SCS and PCL coordinate system differences,
described, 5-42

SCS and PCL5 printer control sequences
supported, 5-46

SDLC Direct Connect
adapters, 2-102
configuring, 2-107
Destination PU ID, 2-105
Edit DLUR dialog box, 2-108
General page, 2-103
I-Frame, 2-105
Line Type, 2-105
Link Capability, 2-105
Node Type, 2-105
NRZ, 2-105
overview, 2-102
Poll Address, 2-105
synchronous modem, 2-102
system requirements, 2-102
Wiring Type, 2-105

securing
Application commands, 14-4
Change Settings commands, 14-10
Edit menu commands, 14-5
File menu commands, 14-7
Help menu commands, 14-4
Macro commands, 14-7
Miscellaneous commands, 14-8
Options menu commands, 14-8
Session menu commands, 14-9
Tools menu commands, 14-12
View menu commands, 14-13

security
categories, 14-3
described, 0-2
Edit settings, 4-8
HotSpot, 7-17
QuickPad, 9-24
securing commands, 14-13
selecting scheme to edit, 14-13
selecting schemes, 14-14
setting 3270 colors, 3-17
setting a password, 14-14
setting global preferences, 3-8
toolbar, 9-32

Select All command, display session, 4-7
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selecting
printer, 5-6
printer session, 5-6
QuickPad, 3-12
toolbar, 3-10
text, 4-2, 4-3

sending files, FTP, 6-27
separator, toolbar

copying, 9-30
cutting, 9-30
deleting, 9-31
description, 9-28
moving, 9-29
pasting, 9-30
placing, 9-28

Service Name, 2-120
Session Long Name field. See Operator

Information Area (OIA)
Session Short Name field. See Operator

Information Area (OIA)
Session Statistics page, 16-10, 16-11, 16-12
Session Type command, 3-35
Session Type page, 3-35
sessions

adding icons to Program Group in NT 3.51,
1-6

closing and exiting, 1-11
creating, 1-4, 1-5, 1-6
disconnecting, 1-11
exiting, 1-12
exiting, howto, 1-12
files, 1-5, 1-6, 1-7
icons, adding to Program Group in NT 3.51,

1-6
menu commands, securing, 14-9
opening, 1-4, 1-7
preferences, global, 3-4
properties, 3-8
viewing information, 16-10

setting
display style, HotSpots, 7-17
FTP transfer options, 6-32
keyboard to APL mode, 8-5
proxy server options, 6-34

setting, continued
QuickPad

color, 9-10
object properties, 9-11
properties, 9-9
title, 9-10

settings
3270 file transfer, FTP, See FTP file

Transfer, 6-30
FTP file transfer, 6-30, 6-34
HotSpots, 7-3
IND$FILE General page, 6-30

Settings command, display session, 4-7
Settings dialog box

Navigations, 9-37
QuickPads, 9-6, 9-37
toolbars, 9-7

settings files, selecting, 3-8
Settle time, altering host, 9-37
Shifts and modes messages. See Operator

Information Area (OIA)
Short name field. See Operator Information Area

(OIA)
Short names, HLLAPI, 3-7
SlideShow connection

.PSS files, 2-110
configuring, 2-111
General page, 2-110
overview, 2-110

SNA character string, control sequences
supported under GDI Mode, 5-46

SOCKS proxies, 6-34
spacing, QuickPad grid, 9-22
status, viewing printer session, 5-22
starting EXTRA!, 1-3, 1-4
startup macro

running, 3-2
setting default path, 3-4

States, keyboard, B-26
statistics

DLC connections, 16-7
links, 16-9
LU sessions, 16-12
node, 16-5



Index

Index-15

status, viewing for printer sessions, 5-21
Status Bar

hiding the, 1-10
viewing, 1-10

T
TCP/IP for SAA

Advanced page, 2-101
Connection list, 2-97
Connection Timeout option, 2-101
Edit connection dialog box, 2-98
Gateway Hot Rollover option, 2-101
General page, 2-97
overview, 2-96
Password Encryption option, 2-101
Server Name, 2-99
system requirements, 2-96

text
3270 colors, changing, 3-12, 3-14
HotSpots, 7-2
QuickPad, 3-11

aligning to the grid, 9-22
arranging, 9-19
copying, 9-20, 9-21
cutting, 9-20
deleting, 9-19
font, font size and font style, 9-15
for a QuickPad group box, 9-16
modifying, 9-18
moving, 9-18
pasting, 9-21
placing on a QuickPad, 9-11
QuickPad Label page, 9-17
resizing, 9-19

selecting, 4-2, 4-3
Time field. See Operator Information Area (OIA)
title

QuickPad, 9-10
toolbar, 9-27

TN3270 connection
Advanced page, 2-114
ATTN function, 2-114
Auto Reconnect, 2-112
configuring, 2-116
Connection timeout, 2-112
General page, 2-112
Host alias, 2-112
NVT Specific options, 2-114

TN3270 connection, continued
overview, 2-111
problems using with Microsoft Network,

2-116
Same model for primary and alternate

screens, 2-114
SYSREQ function, 2-114
system requirements, 2-111
Terminal/Device Type, 2-112
TN3270E support, 2-114

toggling the APL mode, keyboard map, 8-5
Token Ring, supported adapters, 2-4
Toolbar

assigning an action, 9-32
attaching, 9-5
button

assigning a bitmap, 9-29
assigning a title, 9-29
assigning an accelerator key, 9-29
assigning an action, 9-29
copying, 9-30
cutting, 9-30
deleting, 9-31
moving, 9-29
overview, 9-28
pasting, 9-30

creating new, 9-25
creating or editing, 9-25
customizing, 9-26
described, 3-10, 9-4
editing an existing toolbar, 9-26
loading, 3-10
placing a button or separator, 9-28
properties, 9-26
saving a toolbar, 9-31
security settings, 9-32
selecting different, 9-5
separator

copying, 9-30
cutting, 9-30
deleting, 9-31
moving, 9-29
overview, 9-28
pasting, 9-30

setting
button size, 9-27
color, 9-27
title, 9-27
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Toolbar, continued
setting

ToolTips on or off, 9-28
Title dialog box, 9-26
unloading, 3-10
viewing, 9-5

Toolbar Editor
description, 9-25
exiting, 9-31
opening, 9-26

Toolbar Settings dialog box, 9-7
Tools menu commands, securing, 14-12
ToolTips

bitmap button, 9-17
on a toolbar, 3-10
setting on or off, 9-28

Transfer File dialog box, 6-24
transfer list, 6-27
Transparency Block Configurations

described, 5-35
LU1 session, 5-35
LU3 session, 5-36

Trigger signature (hex passthrough)
%% as start and end trigger, 5-38
%% as start trigger only, 5-39
described, 5-37
start and end trigger, 5-40
start trigger only, 5-39

type, QuickPad button or text, 9-15

U
unloading

QuickPad, 3-12
toolbar, 3-10

using HotSpots, 7-10

V
View menu commands, securing, 14-13
Viewing

configuration information, 16-12
DLC connection information, 16-7
HotSpots, 3-10
keyboard map, 8-4, 8-8
link information, 16-9
Local LU information, 16-10
Node information, 16-6
Session information, 16-11
Status Bar, 1-10

VINES to Banyan SNA Service
configuring a connection, 2-120
defining a profile key, 2-121
Edit Connection dialog box, 2-120
General page settings, 2-118
overview, 2-117
Profile Key option, 2-121
system requirements, 2-118

VM/CMS, 6-3
VSE/CICS, 6-3

W
Windows 95 and Windows 98, starting EXTRA!

from, 1-3
Windows GDI, 5-33
Windows NT, starting EXTRA! from, 1-3
Windows-scaleable font support, 5-44

Z
ZIP! Server IPX/SPX

Advanced page, 2-126
configuringa connection, 2-127
General page, 2-125
overview, 2-124
system requirements, 2-124



Index

Index-17

ZIP! Server via Banyan VINES
configuring, 2-123
General page, 2-122
overview, 2-121
system requirements, 2-122

ZIP! Server via TCP/IP
configuring a connection, 2-130
configuringa connection, 2-131
defining

gateway, 2-130
resource, 2-130

General page, 2-130
LAN Broadcast option, 2-130
overview, 2-129
system requirements, 2-129

ZIP! SNA via NetBIOS
General page, 2-128
overview, 2-127
Resource Name, 2-128
system requirements, 2-127
Workstation Name, 2-128
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