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elcome to EXTRA! Personal Client! Besides giving individual PC
clients access to a variety of host types, EXTRA! provides system

administrators with a number of tools for setting up and managing the
EXTRA! installations on their enterprise networks. This System
Administrator’s Guide discusses the following EXTRA! features.

The Host Code Page Editor

Using EXTRA!’s Host Code Page Editor, you can create and edit custom
host code pages to ensure that host output appears correctly on attached
workstations and printers.

Support for Policy Based Management

You can use Windows NT, Windows 95, and Windows 98 user profiles
and system policies to customize and automate installation of EXTRA!
and manage user access to applications and user-interface controls.

The Remote Command Utility

Using the Remote Command utility, you can start and control AS/400
host programs without opening an AS/400 session. You can send an
AS/400 individual commands, or batches of commands stored in ASCII
files.

Silent EXTRA! Installation

With EXTRA!’s silent mode, you can distribute EXTRA! to networks
quickly by automating repetitive installation steps. You can record and
edit scripts to fine-tune silent installations.

Uninstalling EXTRA!

The Uninstall program removes 32-bit EXTRA! components from
Windows NT, Windows 95, and Windows 98 computers.

W
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ttachmate Host Code Page Editor allows you to create custom code
pages that:

• can be used for display, printer and file translations.

• change how a character is translated between the host and the PC.

Creating custom code pages is easy because you use an existing code
page as the basis for the custom code page. The custom code page is
saved and can be used when choosing a code page or used as the basis
for creating another code page.

It is particularly convenient to use Host Code Page Editor to change host
values if characters print or display incorrectly, or if a department wants
different characters to appear. For example, if a character prints
incorrectly on a laser printer, you can change the host value to print a
dollar sign ($) instead of an asterisk (*), or if a department wants to print
a space instead of a pipe sign (|), it can be done easily.

It can be helpful to create a new host code page to make temporary
printing changes to a host document.

Host Code Page Editor makes it easy for you to determine which host
value should display. For example, if you are having trouble with file
transfer and would like to know which value should display a copyright
symbol (©), you can open Host Code Page Editor and find the value.

You can view the host and PC code page settings, and the translation of
the character represented on the PC. Note that some characters are non-
displayable.

A
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This property Represents

Host Value The currently selected Host Value (code point).

PC Value The value to which the Host Value (code point)
translates on the PC when using the selected PC
code page. The PC Value is the numeric
representation of the PC Character.

PC Character The graphical representation of the PC Value.

PC Code Page
Reference

The PC code page currently selected.

n/d A non-displayable character.
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Custom Code Pages
Custom code pages can be created based on any of the existing host code
pages.

Once you create a custom code page, it can be edited or used as the basis
for new code pages.

Note: The standard-language code pages cannot be edited, but you can
use them as the basis for creating a custom page.

The Select Base Host Code Page Dialog Box

The Select Base Host Code Page dialog box appears when you select
Open from the File menu of the Host Code Page Editor. From this dialog
box, you can select a code page to edit.

The Save Custom Code Page Dialog Box

The Save Custom Code Page dialog box appears when you select the
Save As command from the File menu of a code page. You can save a
code page under a different name using this dialog box.
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In Custom Code Page Name, type a code page name for the custom code
page you are creating.

To create a new code page

1. From the File menu, choose New.

The Select Base Host Code Page dialog box appears.

2. Select the host code page that you want to use as the basis for the
custom code page and choose OK.

The selected code page appears.

3. To change from Text mode, from the View menu, choose Hex. The
translation table includes rows and columns: rows are labeled with a
character followed by a hyphen, and columns are labeled with a
hyphen followed by a character. Read the row first (down), then the
column (across).

4. Make the desired changes to the host code pages:

To Do this

Select the text to change Double-click the character in the
table that you want to change.

Move the selection Use the cursor keys to place the
selection in the desired location,
then press ENTER.

Move a character from one
field to another

Use the copy and paste features.
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Note: To the right of the table, a display window shows the Host
Value, PC Value and PC Character for the selected field as well as the
PC Code Page Reference used for translations.

5. From the File menu, choose Save As.

The Save Custom Code Page dialog box appears.

6. Type a name for the new custom code page, then choose OK.

To edit a custom code page

1. From the File menu, choose Open.

The Select Base Host Code Page dialog box appears.

2. Select the custom code page to edit and choose OK.

The selected code page appears.

3. To change from Text mode, from the View menu, choose Hex. The
translation table includes rows and columns: rows are labeled with a
character followed by a hyphen, and columns are labeled with a
hyphen followed by a character. Read the row first (down), then the
column (across).
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4. Make the desired changes to the host code pages:

To Do this

Select the text to change Double-click the character in the table
that you want to change.

Move the selection Use the cursor keys to place the
selection in the desired location, then
press ENTER.

Move a character from
one field to another

Use the copy and paste features.

Note: To the right of the table, a display window shows the Host
Value, PC Value and PC Character for the selected field as well as the
PC Code Page Reference used for translations.

5. When you have finished making your changes, choose Save from the
File menu.

Changing the PC Code Page Reference
The PC Code Page Reference identifies the PC code page used to
translate and display the Host Code Page. The default is ANSI
(WinLatin1) (1252).

The Select PC Code Page Dialog Box

From this dialog box, you can choose from a list of supported PC code
pages.
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To change the PC code page reference

1. From the Options menu, choose PC Code Page.

The Select PC Code Page dialog box appears, listing the PC code
pages currently supported by Attachmate.

2. Select the desired PC Code Page and choose OK.

Changing Host Code Page Properties
From the Properties dialog box you can change the following properties
for a code page:

• Country Code

• Windows Code Page

• Windows Character Set

This information is used internally to determine host values.

!! Important: Before making any changes to these settings, verify that the
information in the IBM Character Data Representation Library is correct.
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The Properties Dialog Box

Following are descriptions of the Properties dialog box settings:

This setting Represents

Host Code Page The host code points (from a defined encoding
structure) for each graphic character in a set.

Code Page Type Either EBCDIC (host) or ASCII/ANSI (PC).

Host Character
Set

A defined set of characters for the host—a
collection of elements used to represent textual
information.

Keyboard ID The keyboard identification code.

Country Code The code assigned to the code page for the
selected country.

Windows Code
Page

The specification of Windows code points for
each graphic character in a set.

Windows
Character Set

A defined set of characters for Windows—a
collection of elements used to represent textual
information.
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To change the properties of a host code page

1. From the View menu, choose Properties.

The Properties dialog box appears.

2. Change the values for the Country Code, Windows Code Page and
Windows Character Set fields as necessary.
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he two key components of Policy Based Management are User
Profiles and System Policies.

Windows NT and Windows 95 workstations store settings and
preferences for each user or group of users in files called User Profiles.
Among other things, a User Profile determines which network
connections are made when a user logs on to a workstation, which parts
of the workstation and the network the user can access, and the look of
the desktop and the Windows Start menu. User Profiles can be roaming or
mandatory. The following section on User Profiles discusses these two
types of User Profiles and their uses with EXTRA!.

System policies provide the network administrator with a simple method
to control a user’s access to applications, and individual application user
interface controls, from a central location. See the following section on
System Policies for more information.

User Profiles
A user profile is essentially an HKEY_CURRENT_USER (HKCU) registry
key that the Win32 system loads after the user has been identified during
logon. With Windows NT, user profiles are automatically created for
each user who logs onto the system, but in Windows 95 you must
configure each workstation to enable their use.

With Windows 95, a user profile is stored in a file with the default name
USER.DAT, and with Windows NT, with a name NTUSER.DAT. User
profile files are commonly stored within the Windows\Profiles\username
folder.

Because the contents of a profile are stored in a file, copies of one file can
be used by a group of users who have the same desktop requirements. A
common technique for preparing one profile for use by a group is to
create a new user account on the system, to be used only for the purpose
of preparing profiles. Then, after you’ve configured the special account’s
profile, you log off, and copy the generated USER.DAT file to the various
group members’ personal folders on the network server.

T
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To create a new user account

1. Log in to the special account.

The special account is the account some administrators may establish
for the purpose of preparing profiles for users. An administrator can
create an Accounting department profile account, a Sales department
account, and so on. Then if the administrator wants to change an
entire department’s profile, only the special account need to be
modified and the .DAT file distributed to the various department
members’ logon directories.

2. Modify its desktop so that the shortcuts, drive mappings, display
properties, and HKCU application preferences are as you want them
presented to each of the users in the group.

3. Log off and copy the resulting .DAT file to each user’s home
directory.

Roaming Profiles
A roaming profile is stored in a directory on the user’s logon server, and
is therefore available to the user from any workstation where they may
log on to the network.

Using Microsoft Client for Windows, the roaming profile file is usually
placed on the user’s home directory on the logon server,
WINDOWS\USERS\username.

Using Microsoft Client for NetWare networks, the roaming profile file
belongs in the user’s SYS\MAIL directory.

A Windows 95 system checks its logon server for a roaming profile by
default. With Windows NT, roaming profiles must be enabled for a user.

To enable roaming profiles on Windows NT

1. From the taskbar, choose the Start button.

2. Choose Settings, then Control Panel.

3. Choose the System utility.

The System Properties dialog box appears.

4. Click the User Profiles tab.

5. Select the user’s account name, then choose the Change Type button.
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After the user profile has been set to Roaming Profile, the workstation
will always look to the user’s server logon directory for its profile at
logon.

Mandatory Profiles
A Mandatory Profile provides the network administrator with complete
control over a user’s profile settings. When loaded, a mandatory profile
merges with the user’s profile settings and overwrites any that are
different from those it includes. If the file which contains a user’s
mandatory profile is not located during logon, the system does not
permit desktop access to the user. This means that if a user, whose
account is configured to use a mandatory profile, tries to work outside of
the constraints of his or her assigned profile by disconnecting the
network connection, the local system prevents him or her from logging
on. A mandatory profile is identical to other profiles both in how it was
prepared and its content. It becomes mandatory only after its filename
extension is changed to man.

A mandatory profile is usually used on a long-term basis to maintain an
administrator’s choice of settings on a user’s workstation. A mandatory
profile can also be used on an as-needed basis to push workstation
updates of applications or configurations.

Using Profiles with EXTRA!
A profile can provide a network administrator with an efficient
mechanism for distributing EXTRA! to the user who loads it. When the
network server version of EXTRA! is installed on a server, the
SETUP.EXE program stored there can quickly install a small footprint
version of EXTRA! to a user’s client workstation. If, however, the server
resident copy of EXTRA.EXE is selected, EXTRA! searches the calling
workstation for a working copy of EXTRA!, and runs it if it’s found. If it
is not found, EXTRA! invokes the Network Client Setup program.

If a roaming profile contains a Start menu shortcut that points to the
server installation of EXTRA.EXE, each workstation where the user logs
on is a click away from providing EXTRA! to the user. For example, if a
roaming user profile contains a Start menu group named EXTRA! 32-BIT,
which includes a shortcut with the command line
\\JMC\E!PC\EXTRA.EXE, EXTRA! can be installed and run on every
workstation where this user logged on. If the profile also contains specific
EXTRA! configuration details, such as a list of EXTRA! layout files and
HLLAPI session short name associations, they would also be available
everywhere the user logs on.
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Another installation option which can be useful in the preceding scenario
is a silent installation. If the command line in the shortcut previously
described above includes a pair of command line switches which instruct
Setup to run in silent mode the installation occurs unseen by the user and
driven by a set of configuration options specified by the administrator.

Silent Install

A profile with a shortcut that points to EXTRA.EXE or SETUP.EXE on the
network server can provide easy access to EXTRA! from any workstation
on the network. Using EXTRA! silent install mode, driven by the contents
of a file previously recorded, Setup can run in the background, hidden
from the user. This installation mode reduces the frequently with which
an administrator must provide guidance to users, and enforces a set of
administrator-chosen configuration options — when silent install is run,
the user does not have the opportunity to specify configuration options.

To prepare a silent install driver script

• Specify the following command line when calling EXTRA!’s Setup:

7IXYT��V��J�WGVMTXCJMPIREQI�MWW

Where:

-r tells Setup to record the choices that will be made in the dialog
boxes that follow

-f1 which immediately precedes the name of the file in which the
recording will be stored

script_filename.iss is the name of your script file

Note: No spaces appear between the -f1 and the filename, and the
filename must contain the extension .ISS. See the EXTRA!’s Silent Install
Help topic for more information.

When an .ISS script file is replayed, EXTRA! is installed with exactly the
same set of configuration options that were specified in the recorded
session.
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To replay the silent install

• Type the following command:

WIXYT��W��J�WGVMTXCJMPIREQI�MWW

–or–

I\XVE��W��J�WGVMTXCJMPIREQI�MWW

Silent install runs in the background and is not visible to the workstation
user.

Example: EXTRA! Silent Install and User Profiles

EXTRA! installs a network client version of itself on any network
workstation if it senses that EXTRA! was loaded from a remote server
and isn’t installed locally. If the silent install command line options are
added to those shown in the profile example, Using Profiles with EXTRA!,
EXTRA! automatically installs itself in the background on a workstation
where it isn’t yet installed. Since user interface is presented, no user
input is necessary.

An example of a profile command line that automatically and silently
installs EXTRA! is:

@@.1'@)�4'@)<86%�)<)��W��J�G�@()4C%�-77

Placing this command line within a profile’s shortcut initiates a silent
install, copying EXTRA.EXE from the EXTRA! folder on the JMC server
to the local workstation. Within a span of approximately twenty seconds
the command line duplicates the steps and choices the administrator
specified when the file DEPT_A.ISS was recorded, and prepares the
workstation with Start menu items and an Uninstall utility.

System Policies
Windows System Policies provide a simple means by which a network
administrator can control a user’s access to applications and the
applications’ user interface controls from a central location. System
Policies were introduced as a new feature in Windows 95 and Windows
NT 4.0, but are not yet in widespread use because few software
applications currently provide support for them. EXTRA! fully supports
the use of System Policies.
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Preparing Your System to Use System Policies
The System Policy Editor, POLEDIT.EXE, can be installed from the
Windows 95, Windows NT 4.0 Server, or Windows NT 4.0 Resource Kit
CD-ROMs. Policy template files (.ADM files) are also included on those
CD-ROMs that provide a description of the basic Windows system you
are using.

An application provides an .ADM template file will support Policy Based
Management.

This operating system Uses the file(s)

Windows 95 ADMIN.ADM

Windows NT 4.0 COMMON.ADM

WINNT.ADM

WINDOWS.ADM

EXTRA! EPC_MIN.ADM

The COMMON.ADM files include user interface controls that are
common to both Windows 95 and Windows NT 4.0. WINDOWS.ADM is
specific to Windows 95, and WINNT.ADM is specific to Windows NT
4.0. Copy the Windows .ADM files that are appropriate for use in your
environment, and the EXTRA! policy template EPC_MIN.ADM, to the
working directory you will use with your policy editor such as
WINDOWS\INF.

System policies are usually stored in a file named CONFIG.POL for a
Windows 95 user, and NTCONFIG.POL on Windows NT 4.0. To use a
different name for the policy file on your system, modify your system to
allow manual policy downloading. The operating system looks for these
files on a network in either the Windows NT logon server’s NETLOGON
folder, or in the PUBLIC directory if the user logs on to a NetWare
server.

If you experience problems, verify that the user is logging on with the
appropriate Microsoft network client Client for Microsoft Windows or
Client for NetWare Networks. You can verify this on the Services page in
the Network utility in Control Panel.
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Establishing Policies on Your Domain for Each User or Group
of Users

Using the System Policy Editor, you can establish policies on your
domain for each user or group of users. The System Policy Editor has two
views that contain information specifying user-specific or common user
policies: Default User and Default Computer.

Default User includes a user’s preferences that are in effect if no user
profile is prepared for the named userid. Default Computer controls
users’ access on a particular machine. For instance, JanPetersen may be a
user whose preferences are controlled by the Default User policy when
her ID isn’t specifically named as a policy user. But, everyone who logs
onto the machine HK_NT40 is affected by the Default Computer policy
settings.

Since the preference and configuration settings for EXTRA! are stored
primarily in the registry’s HKCU hive, you will need to edit the EXTRA!
policy settings only within the user specific policies.

When you modify the Default User policies, everyone who logs on to the
server experiences the effects of this policy. You can prepare a unique set
of access limits for a user or a certain user group.

Note: Only one policy file is used to hold the information for a system’s
policies.

To add policy template files

1. Open the System Policy Editor.

2. From the Options menu, choose Policy Template.

3. Add the desired policy template (.ADM) files that you want your
new system policy file to use.

To create a unique set of access limits for a user or user group

1. Open the System Policy Editor.

2. From the File menu, choose New Policy.

3. Create the settings as desired.
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4. To save your changes, from the File menu, choose Save.

5. For Windows NT clients, name your file NTCONFIG.POL.

–or–

For Windows 95 clients, name your file CONFIG.POL.

To edit a system policy file

1. Choose a user icon, then click on the E!PC tree to see the list of
EXTRA! menu items that can be controlled with a system policy.

Properties Dialog Box

2. Change the settings as desired. You can toggle through the following
three settings in each checkbox:

• Selected: a check mark appears in the check box. Items will be
disabled when that user loads EXTRA!.

• Cleared: the check box appears empty. Items will be enabled
when that user loads EXTRA!.
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• No changes: the check box is filled with gray shading indicating
that no changes will be made to the user’s settings. Shaded items
will not modify the current state of the user’s policy. If a policy
on a particular menu item has previously been in place for a user
and you change the status to shaded, the user’s access will not
have been changed by your actions.

3. When you are finished changing the settings, choose OK.

4. To save your changes, from the File menu, choose Save.

5. Copy the system policy file to the appropriate network folder: either
a Windows NT logon server NETLOGON folder, or a NetWare
server PUBLIC directory.

To create a system policy file

1. Open System Policy Editor.

2. From the Edit menu, choose Add User.

3. When you are finished added users or user groups, choose OK.
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sing the Remote Command utility, you can start and control non-
interactive programs on an AS/400 host without opening an

AS/400 display session. Commands can be sent individually, or in
combination, and can be saved as an ASCII file for resubmission.

Note: Return codes are received but program data cannot be returned
from the host.

The Remote Command utility provides:

• An interface to automate sending one command or a batch of
commands.

• An API set for Remote Command and Distributed Program Call.
This includes header files, an .LIB file, and sample code.

Sample files are provided on the EXTRA! Personal Client CD-ROM in the
SAMPLE/RCSAMPLE directory.

Before Using Remote Command
Perform the following actions before using Remote Command:

1. Determine the non-interactive programs on the AS/400 host that
you’d like to start and control from your PC. Following are some
sample commands.

To
Use this
command For example

Send an
immediate
message to one or
more message
queues

72(17+ 72(17+�17+��D8IWXMRK

6IQSXI�'SQQERH�
�

83976�97)6-(�

Add a library %((0-&0)�0-& %((0-&0)�0-&��1=0-&�

Copy a file from
one library to
another library

'4=*�*631*-0)

83*-0)

'4=*�*631*-0)

�5+40�8)14��

83*-0)�1=0-&�8)14�

Submit a job to a
queue to be run
later as a batch
file

7&1.3&�'1( 7&1.3&�'1(��'68'04+1

4+1��2);4+1�

8)<8�D2I[�TVSKVEQ
�

U
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2. From the display session, try the command you want to send to
make sure it is a legitimate command.

3. Copy the command lines that you are entering from the display
session. This is easier than remembering a long command line.

The Remote Command Utility
The Remote Command utility provides a way to start and control non-
interactive programs.
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The settings for Remote Command are:

Host Selection: Includes Host Name, Configure Host and Edit Host
Configuration options for you to select/configure the AS/400 connection.

Host Name: Identifies the AS/400 connection.

Configure Host: Displays the AS/400 Connection dialog box from
which you can select, configure, edit and test a connection type to the
host.

Edit Host Configuration: Displays the AS/400 Connection dialog
box from which you can select and define general settings for your
AS/400 connection.

Send Command: Sends the selected command line to the host. The
cursor location determines which line is the current line to be sent.

Send All Commands: Sends all the commands listed in the Command
Lines box, to the host.

Command Lines: Type the Command Lines you want to send to the host
or paste command lines (copied from your display session).

Clear Output: Clears the Command Output Messages box.

Command Output Messages: Displays the actual messages that were
sent.

To access Remote Command from Windows command line or DOS

• To open Remote Command, from the Windows command line, the
DOS prompt, or a DOS session, type the following command:

618'1(����6182(�8<8

• To execute a command, from the Windows command line, from the
DOS prompt, or in a DOS session, type the following command:

618'1(����6182(�8<8�6
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Creating New Command Scripts
You can create command scripts to send one command or multiple
commands from your PC instead of the host. You can either create new
command scripts or create command scripts based on previous scripts.

To create new command scripts

1. When the Remote Command utility opens, the header reads
Untitled – Remote Command. At this point you can create a new
script on this screen.

Note: If you have a previously created Remote Command script
open, choose New from the File menu.

2. Type the command that you want to send to the host, or if you have
copied commands from your display session, paste them into the
Command Lines box.

3. Configure a connection to an AS/400:

• To select a Connection Type to the host, choose the Configure
Host button.

• To define general settings for your AS/400 connection, choose
the Edit Host Configuration button. You will need to select the
appropriate host and PC options.

4. To send one command line, move your cursor to the command line
to be sent, then choose the Send Command button.

–or–

To send all the commands listed in the box, choose the Send All
Commands button.

5. When commands are sent, the actual messages that were sent display
in the Command Output Messages box.

Note: If an incorrect command line is sent, an error message displays.
To clear the Command Output Message box choose the Clear Output
button.
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6. When you are finished:

To From the File menu

Save new command scripts Choose Save.

Save edited command scripts to be
resubmitted

Choose Save As

Close the Command Line utility without
saving your changes

Choose Exit.

To edit command scripts

1. Open the Remote Command utility.

2. From the File menu, choose Open.

3. Select the filename of the script you’d like to edit, then choose Open.

4. Make the desired changes.

5. To send one command line, move your cursor to the command line
to be sent, then choose the Send Command button.

–or–

To send all commands listed in the box, choose the Send All
Commands button.

When commands are sent, the actual messages that were sent display
in the Command Output Messages box.

Note: If an incorrect command line is sent, an error message displays.
To clear the Command Output Message box choose the Clear Output
button.
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6. When you are finished:

To From the File menu

Save new command scripts Choose Save.

Save edited command scripts to
be resubmitted

Choose Save As.

Close the Command Line utility
without saving your changes

Choose Exit.

Sample Application
Using the Sample Application source code you can develop or use the
Remote Command API set from within your application.

To Do this

Review the sample application Double-click RCSAMPLE.EXE
in your E!PC directory.

Type message text and identify
the user to whom you are
sending the message, hiding the
details

Use the 72(17+ (Send Message)
command.

Send a command and see the
result from the host, suppressing
the message

Enter a command string and
return code using the Remote
Command utility.

Call a program object on the
AS/400 with input/output
parameters

Use Distributed Program Call.
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XTRA! is compatible with the Microsoft BackOffice products and
supports automated electronic distribution, also known as silent

installation, with or without the use of Microsoft Systems Management
Server (SMS).

You can also invoke silent mode with predefined installation selections to
skip all repetitive user interface and speed up the distribution of EXTRA!
on networks. With EXTRA! silent mode Setup, you do not need to
monitor the installation process or provide input via dialog boxes. Silent
mode installation runs on its own, without intervention.

Silent mode installation is accomplished by referencing a predefined set
of installation selections in a response file (a simple text file, with the
extension .ISS).

Using the EXTRA! record mode feature you can automatically create a
custom response file by running Setup with the -r option.

Record Mode
Using record mode, you can record your own automatically customized
script.

E

!! Important!
When recording to create a network response file: Run Setup from the
network server. Be sure to choose Network Administrator Install in the
Setup program’s Select Install Type dialog box (during step 5 in the
procedure below). This will install product options to the network
server.

When recording to create a client response file: Run Setup from the
network server install location. Setup will detect that a network server
install has occurred and, therefore, will not display the Select Install Type
dialog box.

Also, no host or file transfer options are presented during client Setup (as
these are selected during network installation).



Installing EXTRA! on a Network Using Silent Install

4-3

To create a response file using record mode

1. Choose the Start button and then choose Run.

The Run dialog box appears.

2. Choose the Browse button, and then from the Look In list, select the
CD-ROM drive or the directory containing the EXTRA! distribution
media.:

3. Select  \WIN32\EPCLIENT\SETUP.EXE, then choose Open.

The Run dialog box appears with \path\SETUP.EXE in the Open text
box.

Note: Do not run this command line using the SETUP.EXE from the
root level of the EXTRA! directory. It will not create the .ISS file. The
SETUP.EXE that supports the silent install resides in the
\WIN32\EPCLIENT subdirectory.

4. Add the -r and -f1 options as shown below:

@TEXL@WIXYT��V��J�VIWTSRWICJMPI�MWW

Where path is the path to the Setup executable, and response_file is the
path and name of the .ISS response file you want to create. (If you are
not running Setup from the CD-ROM, the path to Setup cannot be
more than three directories deep. The path to the response file cannot
exceed 50 characters.)

For example:

WIXYT�I\I��V��J�G�@WXSVEKI@VIWTSRWI�MWW

Note: There is no space between the -f1 switch and the response file
path. (If you do not include the -f1 option, the .ISS file is written to
the \WINDOWS directory.)

5. Choose OK.

Setup is launched.

6. Proceed through the Setup program.

Note: User and Company names will be identical for all users of a client
.ISS file.
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Using Silent Mode Response Files
Silent mode installation is accomplished using a predefined set of
installation selections in a response file (a simple text file, with the
extension .ISS). The content of the response file coincides with the user
interface selections in a normal, non-silent mode installation. All of the
dialog box selections presented during a normal Setup are reflected in
the silent response file.

To install using a silent mode response file

Note: When using silent mode with Microsoft Systems Management
Server, if you are installing to a directory other than the default, you
must modify the line pointing to DEISL1.ISU in ATTM_SMS.PDF.

1. Choose the Start button and then choose Run.

The Run dialog box appears.

2. Choose the Browse button, and then from the Look In list, select the
CD-ROM drive or the directory containing the EXTRA! distribution
media.

3. Select SETUP.EXE, then choose Open.

The Run dialog box reappears with SETUP.EXE in the Open text box.

4. Add the -s and -f1 options as shown below:

WIXYT��W��J�VIWTSRWICJMPI�-77

–or–

WIXYT��717��W��J�VIWTSRWICJMPI�-77

Where response_file is the path and name of the .ISS response file you
created using record mode (the -f1 option and the path and response
filename are required during silent installation), and -SMS is the
System Management Server switch. Note that there is no space
between the f1 switch and the response file path.

Tip: You can use Microsoft SMS to schedule a silent mode execution
by using the command line format shown above, and then executing
the Setup at a pre-defined time (like midnight). For details on using
Microsoft SMS, please refer to the Microsoft SMS documentation.
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5. Choose OK.

EXTRA! uses your response file entries to perform the installation
automatically.

6. After installation, review the SETUP.LOG file to make sure that
Setup performed the tasks successfully.

To display a status bar during silent installation

• Add the -ATMSTATUS command line when running setup (step 4 of
the procedure “To install using your silent mode response file”), as
follows:

WIXYT��%8178%897��W��J�VIWTSRWICJMPI�-77
–or–
WIXYT��%8178%897��717��W��J�VIWTSRWICJMPI�-77

Where response_file is the path and name of the .ISS response file you
created using record mode (the -f1 option and the path and response
filename are required during silent installation), and -SMS is the
System Management Server switch. Note that there is no space
between the f1 switch and the response file path.

When silent install runs, a status bar will display showing the process
that is running and the percent complete.

For details on Microsoft SMS, refer to the Microsoft SMS documentation.

To unninstall using silent mode response file

When uninstalling using silent mode, if you are uninstalling from a
directory other than the default, you must modify the line.

1. Choose the Start button, then choose Run.

The Run dialog box appears.

• If you are running Windows 95, type the following:

'�@�;-2(-6�@-W9RMRWX�I\I��E

�Jz%XXEGLQEXIC-RWXEPPEXMSRC(MVIGXSV]@(I-W0��MWYz

�'z'�@%XXEGLQEXIC-RWXEPPEXMSRC(MVIGXSV]@YRMRWXRX���HPPz

–or–

• If you are running Windows NT, type the following:

'�@�;-2(-6�@-W9RMRWX�I\I��E

�Jz%XXEGLQEXIC-RWXEPPEXMSRC(MVIGXSV]@(I-W0��MWYz

�'z'�@%XXEGLQEXIC-RWXEPPEXMSRC(MVIGXSV]@YRMRWXRX�HPPz
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Editing Your Silent Mode Response File
The response file you create in record mode can be used without editing.
If, however, you need to change a parameter but do not want to re-record
a response file, the file can be opened in a text editor (such as
NOTEPAD.EXE) and revised.

Following is a section-by-section explanation of the contents of your .ISS
file.

Header Section

This section is required for every response file, and is internal to the
Setup program.

?-RWXEPP7,-)0(�7MPIRXA
:IVWMSR!Z��������
*MPI!6IWTSRWI�*MPI

?%TTPMGEXMSRA
2EQI!)<86%�
:IVWMSR!���
'SQTER]!%XXEGLQEXI
0ERK!����

Dialog Sequence Section

This section lists all dialog boxes in order of their appearance if the Setup
runs normally. The exact content and order will vary.

?(PK3VHIVA
(PK�!7H&MXQET��
'SYRX!��
(PK�!7H0MGIRWI��
(PK�!7H6IKMWXIV9WIV��
(PK�!7H6IKMWXIV9WIV)\��
(PK�!7H%WO3TXMSRW��
(PK�!7H%WO(IWX4EXL��
(PK�!7H%WO3TXMSRW��
(PK�!7IXYT8]TI��
(PK�!7H'SQTSRIRX(MEPSK���
(PK�!7H%WO3TXMSRW��
(PK��!7H%WO3TXMSRW��
(PK��!7H7IPIGX*SPHIV��
(PK��!7H7XEVX'ST]��
(PK��!%WO3TXMSRW��

!! Caution: EDIT ONLY THOSE LINES OR SECTIONS THAT APPEAR IN
BOLD!
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The item “Count=” should always reflect the total number of dialogs
listed in a particular mode. The number always starts with Dlg0. If you
alter your response file and dialogs are added or removed, make sure
that you update this total count and that all of the dialog entries are
numbered consecutively.

Note: The order of the dialogs in the Dialog Data Section (described next)
must match the order listed in the Dialog Sequence Section. If they do not
match, an error will occur.

Dialog Data Section

This section contains the selections within each dialog box. Some dialog
data should not be edited, but some parameters can be changed. Refer to
the following:

?7H&MXQET��A
6IWYPX!�

?7H0MGIRWI��A
6IWYPX!�

?7H6IKMWXIV9WIV��A
W^2EQI!YWIVCREQI �YWIVCREQI��GSQTER]CREQI
W^'SQTER]!GSQTER]CREQI ��YWIH�XS�VIKMWXIV�XLI
6IWYPX!� ��TVSHYGX��7YFWXMXYXI�[MXL

��ETTVSTVMEXI�MRJSVQEXMSR�

?7H6IKMWXIV9WIV)\��A
W^2EQI! YWIVCREQI
W^'SQTER]!�GSQTER]CREQI
W^7IVMEP!�GSQTER]CREQI
6IWYPX!�

?7H%WO3TXMSRW��A
'SQTSRIRX�X]TI!WXVMRK
'SQTSRIRX�GSYRX!�
'SQTSRIRX��!0SGEP�	;SVOWXEXMSR�-RWXEPPEXMSR
6IWYPX!�

?7H%WO(IWX4EXL��A
W^(MV!'�TEXL �7YFWXMXYXI�[MXL�XLI

�GSVVIGX�TEXL��MJ�RIGIWWEV]�
6IWYPX!�

?7H%WO3TXMSRW��A
'SQTSRIRX�X]TI!WXVMRK
'SQTSRIRX�GSYRX!�
'SQTSRIRX��!	7XERHEVH�����/I]�SV�1MGVSWSJX�2EXYVEP�/I]FSEVH
�HIJEYPX�
6IWYPX!�
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?7IXYT8]TI��A
6IWYPX!��� ������!�8]TMGEP�MRWXEPP�

�����!�'SQTEGX�MRWXEPP�
�����!�'YWXSQ�MRWXEPP��

?7H'SQTSRIRX(MEPSK���A
'SQTSRIRX�X]TI!WXVMRK
'SQTSRIRX�GSYRX!� �:EVMIW�[MXL�IEGL�TVSHYGX�
'SQTSRIRX��!,3787@1%-2*6%1)
'SQTSRIRX��!,3787@%7����
'SQTSRIRX��!,3787@:%<
'SQTSRIRX��!-RZMWMFPI�*VEQI�-XIQ
6IWYPX!�

The SdComponentDialog2 section determines which host type is
installed. If you clear a host type (delete it from the response file), the
Component count item must be changed to reflect the total number of
host types, and the Component number item sequencing must be
adjusted (unless the last host type is the only one eliminated). For
example, if you clear AS/400, the SdComponentDialog2 section should
look like this:

?7H%WO3TXMSRW��A
'SQTSRIRX�X]TI!WXVMRK
'SQTSRIRX�GSYRX!�
'SQTSRIRX��!=IW��	9RMUYI�XS�IEGL�YWIV�
6IWYPX!�

?7H%WO3TXMSRW��A
'SQTSRIRX�X]TI!WXVMRK
'SQTSRIRX�GSYRX!�
'SQTSRIRX��!=IW��1	SHMJ]�XLI�7IEVGL�4EXL�JSV�QI�
6IWYPX!�

?7H7IPIGX*SPHIV��A
W^*SPHIV!)<86%��4IVWSREP�'PMIRX����FMX
6IWYPX!�

?7H7XEVX'ST]��A
6IWYPX!�

?%WO3TXMSRW��A
6IWYPX!�
7IP��!�
7IP��!�
7IP��!�
6IWYPX!�
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The Silent Mode Installation Log File
After you have recorded and (optionally) edited your response file, you
are ready to run the EXTRA! installation in silent mode. When running
an installation in silent mode, remember that no messages will be
displayed. Instead, a log file named SETUP.LOG captures installation
information, including whether the installation was successful.

Open SETUP.LOG in a text editor to view the log information generated
from the last silent mode installation procedure.

A successful installation generates a SETUP.LOG file that looks like this:

?-RWXEPP7LMIPH�7MPIRXA
:IVWMSR!Z��������
*MPI!0SK�*MPI

?%TTPMGEXMSRA
2EQI!)<86%��4IVWSREP�'PMIRX
:IVWMSR!���
'SQTER]!%XXEGLQEXI

?6IWTSRWI6IWYPXA
6IWYPX'SHI!�

The last section, ResponseResult, ResultCode=0 indicates that no errors
occurred while navigating the dialog boxes. (Errors logged during the
file copy portion of the installation procedure are not reflected in the log
file.)

If errors did occur, ResultCode will present a negative number.

Following is an explanation of the possible Result Codes that may appear
in the SETUP.LOG file upon completion of a silent install:

Result Code Meaning

0 Install exited normally. Typically means a
successful installation.

-1 General error.

-3 Required data not found in the silent response file
(*.ISS).

-4 Not enough memory available.

-5 File does not exist.
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Result Code Meaning

-6 Cannot write to the response file.

-9 Not a valid list type (string or number).

-10 Data type is invalid.

-11 Unknown error during setup.

-12 Dialogs in the .ISS file are out of order.

Common Errors

Error During Setup Procedure

This indicates that an error has occurred during the Setup that resulted in
the display of an error message box. Frequently this is caused by
insufficient disk space on the target or the destination, or insufficient
temporary directory space.

Your SETUP.LOG file might look like this:

?6IWTSRWI6IWYPXA
6IWYPX'SHI!��
7IGXMSR!1IWWEKI&S\��
/I]!
8]TI!�

Response File Error

This indicates that an error in the response caused the Setup procedure to
stop. The “Section” text string indicates the section of the .ISS file in
which the error occurred.

Note: The order of the dialogs in the Dialog Data section must match the
order listed in the Dialog Sequence section. If they do not match, this
error occurs.

Your SETUP.LOG file might look like this:

?6IWTSRWI6IWYPXA
6IWYPX'SHI!���
7IGXMSR!7H%WO3TXMSRW��
/I]!6IWYPX
8]TI!�
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Log File Does Not Indicate That an Error Occurred, but Setup Procedure
Failed

If there is no error in the log file, but the Setup procedure failed to install
or skipped certain parts of the option selections, the flags for a particular
option are not set correctly. Double-check the response file to make sure
that the option flags are set correctly.

Microsoft Systems Management Server Considerations
Combining EXTRA! silent mode installation with Microsoft Systems
Management Server (SMS) is another method you can use to automate
installation and setup of EXTRA! across the enterprise.

In addition to the response file required for silent mode setup, SMS uses
a package definition file (.PDF) and returns a management information
file (.MIF). The package definition file (ATTM_SMS.PDF) is supplied on
the EXTRA! distribution media. The .MIF file, which indicates setup
success or failure, is generated automatically by the Setup program at
completion and placed in the \WINDOWS directory. Read this file using
a text editor like Windows NOTEPAD.EXE.

For details on using Microsoft SMS, refer to the Microsoft SMS
documentation.
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XTRA! includes the Uninstall program, which removes the 32-bit
EXTRA! components from your Windows NT or Windows 95 PC.

Specifically, Uninstall deletes the EXTRA! files, removes the program
folder or group, and purges associated configuration information stored
in the Windows registry.

Be aware that Uninstall removes only those components which the
EXTRA! Setup has installed to the EXTRA! folders, directories, or
program groups. In the cases described below, Uninstall will not remove
components; you must remove them manually.

• EXTRA! icons, programs, or files moved from the folders or program
groups to which they were initially installed by Setup will not be
removed by Uninstall.

• In Windows 95, Uninstall will not remove user-created shortcuts to
EXTRA! components.

• If you add non-EXTRA! icons to the EXTRA! folder or program
group, Uninstall will not remove these icons. Likewise, it will not
remove files, folders, or shortcuts added to the EXTRA! folders
created by Setup.

For additional information about Uninstall, refer to the ReadMe file,
located in your EXTRA! folder or program group.

To uninstall from Windows NT 3.51

1. Exit from EXTRA!. All sessions must be closed before you uninstall.

2. From the EXTRA! program group, double-click the Uninstall icon.

3. When prompted to confirm file deletion, choose Yes.

Uninstall displays its progress as it removes files.

4. When Uninstall is completed, choose OK.

E

!! Caution: If you want to reinstall the EXTRA! (32-bit) software, run
Uninstall before Setup.
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To uninstall from Windows 95 and Windows NT 4.0

1. Exit from EXTRA!. All sessions must be closed before you uninstall.

2. From the Control Panel, choose Add/Remove Programs.

3. From the Install/Uninstall page, select EXTRA! (32 bit) from the list
box, then choose Add/Remove.

4. When prompted to confirm file deletion, choose Yes.

Uninstall displays its progress as it removes files.

5. When Uninstall is completed, choose OK.
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editing

custom code pages, 1-6
Remote Command Scripts, 3-6
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system policy file, 2-9
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L
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P
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Policy Based Management, 2-2
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creating

system policy file, 2-10
unique access limits for user or user

group, 2-8
editing a system policy file, 2-9
establishing Policies on your domain, 2-8
example - EXTRA!’s Silent Installation and

user profiles, 2-6
mandatory profile, 2-4
preparing your system to use system

policies, 2-7
roaming profile, 2-3
Silent Install, 2-5
system policies, 2-6
user profiles, 2-2
using profiles with EXTRA!, 2-4
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sample application, remote command, 3-7
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Select Code Page dialog box, 1-7
Setup program, 5-2
SETUP.LOG silent mode log file, 4-9
silent install, policy based management, 2-5
silent mode

log file, 4-9
overview, 4-2
response files, 4-6

system policies, 2-6
Systems Management Server, Microsoft, 4-11

U
uninstall program, 5-2
uninstalling EXTRA!, 5-2
user profiles, 2-2
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